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Overview
Petra is a standalone solution for data management, manipulation, visualization and
integration of geological, geophysical and engineering data. You can quickly visualize
results using mapping, cross-sections, seismic interpretations, log plots, cross-plots,
3D visualization, and production and reservoir analysis. IHS offers two versions of
Petra:
Petra 2014 Standard
Petra 2014 Workgroup

Petra 2014 Standard
Designed to support single-user or small team interpretation workflows.
Petra Standard Edition's reliable, easy to use capabilities make it the ideal platform
for customers who are looking for an all-encompassing geological solution for their
exploration, development, and production analysis needs, with limited IT or
administrative overhead.

Petra 2014 Workgroup
Designed to support large teams working concurrently on shared Petra projects,
including simultaneous data loading workflows.
Petra Workgroup Edition provides scalability, database management, and user
permissions management for customers who require workgroup support and
performance solutions. This solution typically requires increased IT support and is
more suited for larger companies with many users.
Petra Workgroup can be run in either Shared or Private mode.
In Shared Mode, Petra uses an external database server which must be installed
separately.
In Private Mode, Petra uses an internal database server built into Petra’s Main
Module. This internal database server needs no special installation.

Petra Modules
IHS 2014 Petra is composed of a Main module and several specialized tool
modules. The Main module provides most of the well data viewing, editing functions,
and calculation options. Main also launches the other tool modules and coordinates
inter-task communication between the tools.

© 2014

Overview

21

Related Topics
Customer Care

1.1

Customer Care
IHS Customer Care
+1 800 IHS-CARE (+1 800 447-2273)
Hours of Operation:
Monday-Friday 8:00 am to 6:00 pm
Website: www.ihs.com/Petra
Sales: etasales@ihs.com
Support: customercare@ihs.com
Licensing: Petralicensing@ihs.com

1.2

Petra Modules

Main Module
The Main module provides the basis for all functions in PETRA. Projects are created,
opened and closed from Main. Unlike other modules, the Main Module is always open.
Main provides screens for viewing and modifying all well data, including header
information, formation tops, user defined z data, and production data. Main provides
many data calculation functions, including isopach, footage summations from log data,
production cumulative values, and user-defined equation evaluations.

Map Module
The Map module displays a highly-customizable map of the project area. This can
include wells, culture data, bubble maps, and attribute maps. The Map Module also
creates grids of geological surfaces or any other data that varies aerially.

Cross Section Module
This module displays cross sections of well data. These cross sections usually
display digital or raster wireline logs, and are commonly used to correlate formation
tops across a field. The Cross Section Module has more options for customization,
and is generally better suited to presentation quality images.

Spreadsheet Module
This module creates a spreadsheet of wells versus information in the database. Each
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well forms a row, with the selected header data, zone data, or formation top as a
column.

Log Cross Plot Module
This module creates a cross plot between two or three digital log curves. The area
covered by the petrophysical relationship of the curves can be used to encode specific
lithologic or fluid relationships.

Z Cross Plot Module
This module creates a cross plot between 2 zone or formation tops. The Z Cross Plot
Module can calculate a variety of regression equations or create polygons based on
the cross plot relationship.

Histogram Module
This module creates a histogram of a selected digital log curve. This log curve can be
filtered by other log curves, by depths, or by formation tops.

Monthly Production Analysis Module
This module displays monthly production data for individual wells. This module can
also predict reserve estimates.

Production Group Plot Module
This module displays aggregate monthly production for one or multiple wells. This
production can be normalized by reservoir and start date/earliest max production to
provide an "average" producer for a specified reservoir.

Thematic Mapper Module
This module imports, displays, and manipulates ESRI Shape Files based on attribute
data. The Thematic Mapper Module can then send the results to the Mapping
Module's overlay feature.

3D Visualizer Module
This module displays well paths, grids (most commonly of geological surfaces), and
overlay data in an interactive three dimensional environment.

Slip Logs Module
This module displays two or more raster logs horizontally for formation top correlation.

Log Correlation Module
© 2014

Overview

23

Like the Cross Section Module, this module displays wireline logs for several different
wells. With fewer display options, this module is geared to rapidly correlate formation
tops across a field.

Directional Well Module
This module is useful both for planning horizontal wells and for displaying log and well
data for existing horizontal wells.

1.3

Workgroup 2014 Database Server
Petra Workgroup Edition provides scalability, database management, and user
permissions management for customers who require workgroup support and
performance solutions. Designed to support large teams working concurrently on
shared Petra projects, including simultaneous data loading workflows.
2014 Workgroup requires increased IT support and is more suited for larger
companies with multiple users.
Petra Workgroup can be run in either Shared or Private mode.
In Private Mode, Petra uses an internal database server built into Petra’s Main
Module. This internal database server needs no special installation.
In Shared Mode, Petra uses an external database server which must be installed
separately. This single database server directly manages all data requests and
changes to each project’s database, performs project repairs and maintenance,
establishes users and permissions (“roles”), and delivers user settings. In Private
Mode, uses an internal database server built into Petra’s Main Module.

Petra Workgroup file architecture in a network environment in Shared Mode

Though the database server itself can only run in a Windows environment, project
database files can reside on a Windows or Linux platform, or a Network Attached
Storage (NAS) device. To use a network location for the database location, you may
© 2014

24

PETRA Help

have to edit the service properties to log on with an account that has permissions to
read and write to that directory.
Related Topics
Installing Workgroup Database Server
Workgroup Database Server Admin Tool
Workgroup Modes
1.3.1

Installing Workgroup Database Server
The first step to install the Database Server is to run the latest version of
PetraEDBServer_X_Y.EXE (where the EDB version is X.Y) on the desired computer.
Though the database server itself can only run in a Windows environment, the storage
requirements can reside on a Windows or Linux platform, or a Network Attached
Storage (NAS) device.
1. Run the latest version of PetraEDBServer_X_Y.EXE (where the EDB Version is X.
Y) on the desired server. From the Welcome screen, select “Next.”

The Petra Database Server installation program’s first screen

2. On the Install Folder window, set the location of the Database Server executable
files.
a. The default location is C:\Program Files\IHS\ElevateDB Server (Unicode)\. This
default is highly recommended.
b. Once the Database Server’s installation location is set, select “Next.”
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The default location of the database server executable files (as shown) is highly recommended

3. On the Project Database Folder window, set the location of the project database
files. The default path is C:\ProgramData\Elevate Software\Elevate DB Server
(Unicode)\Configuration.
a. Select “Change” to set a new location. (User preferred option).

Setting the location of Petra project databases

b. On the Change Current Destination Folder window, navigate to the desired
location for the Petra projects. This can either be a location on the local
computer, or on the network.
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Changing the location of Petra project databases

To use a network location for the database location, you may have to edit the service
properties to log on with an account that has permissions to read and write to that
directory.
Network drives must use UNC pathing (\\Shared1_svr\ PetraProjects\) rather than
drive mapping (Z:\PetraProjects).
c. Once the location is set, select “OK” to return to the Installation Wizard.
d. Select “Next.”

Finalizing the location of Petra project databases

4. On the Initial Status screen, make sure the “Start ElevateDB Server” is on, and
select “Next.”
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Starting the ElevateDB Server

5. Select “Install” to begin the installation.

Finishing the installation

The database server runs as a Windows Service, which will start automatically and
function in the background with little to no user interaction. As a Windows Service, the
database server runs as EDBSRVR on the Services Tab of the task manager. To
start and stop the service, right click the service on the Task manager and select
either ”Start Service” or “Stop Service.”

The Petra Database Server runs as “EDBSRVR” on the Windows Task Manager Services Tab

Once the database server is installed, use the Project Migration Tool to upgrade
legacy v3 projects. Alternatively, the Database Server Admin Tool can run before
migration to perform some tasks that don’t need a project, including creating a DB
Server List, adding users, and changing passwords (particularly the default
administrator password).
1.3.1.1

Managing Private Mode Projects

Private projects sometimes need routine maintenance. Petra’s Private mode uses a
simplified version of the Database Server Admin Tool to back up and restore projects,
update project databases, and perform table maintenance. There are a two slightly
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different ways to open the Private Mode’s Petra Server Admin Tool.
In an open project, select Project>Settings>Open Server Admin Tool.
With no open project, select Project>Open Server Admin Tool.

Project Management Tab
The Project Management Tab displays information on the migrated Petra projects.
Importantly, this section also handles database versions, project maintenance, and
backups. The central list provides a short summary of project name, well count,
project version, and descriptions. This list will always include a “Master” project that
the database server uses as a template for Petra project tables. The far right column
provides more detailed project information or maintenance options

Project Information Tab
The Project Information Tab displays the basics of a Petra Project on the Petra
Database Server, including the database and public folder pathways, as well as the
original creator and migration date.

The Petra Server Admin Tool’s Project Management Tab (Project Information)

DB Path – This entry shows the path for the database root folder.
Project Public Path – This entry shows the public path for the project. The "Edit”
button modifies the Project Public Path.
Created By – This entry shows the project creator.
Creation Date –This entry shows the project’s creation date.
Migration Date – This entry shows the project’s migration date.
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DB Maintenance Tab
The Maintenance Tab performs some of the basic project maintenance tasks,
including updating, cloning, and backing up project databases. This tab also handles
project database table repairs.

The Petra Server Admin Tool’s Project Management Tab (DB Maintenance)

Project Database DB Version
Update - As Petra changes in the future, the way a Petra project stores data in tables
may also change. This button upgrades project databases to the latest version. As
part of the upgrade process, the Server Admin Tool creates an optional backup of the
project. To disable the backup, select the “Skip Backup Before Updating” option.
Verify – This option goes through the entire database to confirm that the project’s
table structure is correct. If there’s a problem select the “Table Maintenance” tool.
Delete Selected Project – This option deletes the project data stored on the DB
server. This option also can erase the entire project folder.

Table Maintenance
The “Table Maintenance” button opens the Project Maintenance window, which
controls some of the more common database procedures, including table verification,
repair, and optimization. This tool handles table index problems that usually show up
as “Access Violation” errors.
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The Table Maintenance Tool

Verify Selected – This option goes through the checked tables in the database to
verify its table structure is correct. More specifically, this tool finds mismatches
between the table index and the actual numbers of tables. The Verify Selected option
will remove the check on project tables with no problems, leaving only the tables with
problems checked.
Repair Selected – This option searches through the checked tables and verifies
database integrity and consistency. This tool fixes the database table relationships.
Before attempting any database repair, make sure to close the project.
Optimize Selected – This option is intended for routine project maintenance. Deleting
data from the database sometimes leaves empty slots in the tables. Much like
defragmenting a hard drive, the Optimize tool eliminates empty spaces by copying all
valid data to a temporary file, sorting the data, and then replacing the original file with
the temporary file. Indexes aren’t normally rebuilt whenever data is added or deleted
from the DAT file, so they can get slower with time. The Optimize Selected tool
rebuilds the index file using the current dataset and can make querying data more
efficient.

Clone Project Database
The Petra Server Admin Tool creates a copy of the selected project in the project list.
This clone can either reside on a different server, or the same server (with a different
name).
Destination Server – This dropdown sets the destination of the copied project. In
Private Mode, this dropdown will always read “PrivateMode.”
New Project Name – This option sets the name of the copied project. By default, the
Server Admin Tool adds “COPY_” to the beginning of the selected project’s name.

Project Database Backups
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Create New – This option creates a new backup of the selected Petra project
database. This includes the project database and database-server-stored individual
user settings. This backup will not include external files (like grids and *.MAP/*.CSP
settings files).
Note that these backups are automatically stored on the Petra database server.
Restore – This option overwrites the existing active project with the backup. This will
overwrite all public and private Petra project data modified since the backup. This
includes all “public” data like well data, zones, tops, and logs, as well as “private” data
like map settings, cross-section settings, and preferences. Restoring from backup
will not affect external files (like grids and *.MAP/*.CSP settings files).
Delete – This option deletes the selected backup.

Full Project Backup Tab
The Petra Server Admin Tool can create entire project backups. The Full Project
Backup creates a copy of the entire public folder and zips it up into a single *.PBF file.

The Petra Server Admin Tool’s Project Management Tab (Full Project Backup)

Backup File - This option creates the name and location of the project backup file.
Select the
button and navigate to the desired *.PBF file.
Ignore OVERLAY Folder – This option excludes the project’s OVERLAY folder from
the backup file.
Ignore IMAGES Folder - This option excludes the project’s IMAGES folder from the
backup file.
Overwrite if Backup Exists – By default, the Petra Server Admin Tool will not
overwrite an existing backup with the same name in the same location. This option
forces the backup to overwrite the existing backup.
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Session Management Tab
The Petra Session Management tab lists and terminates active sessions on selected
database servers.
A session is an active connection to the database server. In addition to a background
session for every user, each open module has its own session. As an example, a
user working with the Map Module, the Main Module, and the Cross-Section Module
will have 4 total sessions.
The
button refreshes the active sessions for the connected servers. Note that the
Session Management Tab will remain blank until this button is selected. button
refreshes the active sessions for the connected servers. Note that the Session
Management Tab will remain blank until this button is selected.
button kills the selected session. When a Petra module crashes or closes
The
unexpectedly, it can leave an open session with the database that prevents the user
from reconnecting to the project. Though a session will timeout on its own after a
period of inactivity (120 seconds by default), the button terminates the selected open
session so the user can reconnect immediately.

The Petra Server Admin Tool’s Session Management Tab

Logs Tab
Petra keeps two kinds of database server records: migrations and database
updates, and other server events.

Petra Logs Tab
The Petra Logs Tab displays project migration and database update logs. The
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button refreshes “Log Filename” list of the available records on the connected
servers. Petra stores these logs as: Process-Username –YYYY-MM-DD_HH.MM.
SS. Note that the Petra Log Tab will remain blank until this button is selected. The
dropdown on the top of the screen trim the list of logs to include project migration,
database updates, or all.

Migration logs in the Logs folder

Migration logs can also contain “Dropping orphaned record” lines. These records
indicate that the Migration Tool has fixed any orphan records not removed during the
Pack step in project preparation. Migration and DB update logs are also stored
externally in the Support/Logs folder inside the Project Databases folder.

Server Log Tab
The Server Log Tab displays a record of database server events, including user
activity and errors. The
button refreshes the log for the connected servers. Note
that the Server Log Tab will remain blank until this button is selected. The buttons on
the top of the screen trim the log to just include the last 24 hours, last week, or last
month.
The server log has a maximum file size, which will eventually truncate old messages
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The Petra Server Admin Tool’s Server Log Tab

This screen contains columns for the error code, the function, a timestamp, the
relevant user, the IP address, and a longer description of the event. To sort by the
various columns, select the column header once for ascending order and twice for
descending order. For more information on error codes, see: http://www.elevatesoft.
com/manual?action=topics&id=edb2sql&section=appendix_error_msg
1.3.2

Workgroup Modes
Petra Workgroup 2014 can run in two separate modes:
Shared Mode - is designed for networked projects used by multiple simultaneous
users. In Shared mode, Petra Workgroup uses an external database server. This
external database server is installed separately - generally on a dedicated machine.
Private Mode - uses an internal database server built into the Main Module. This
internal database server is installed along with Petra Workgroup and needs no
separate installation. Users who do not ever plan on using Shared mode do not
need an external database server.
After logging in and opening a project, the processes of importing well data,
interpreting logs, picking tops, and making maps and cross-sections all remain the
same as previous versions.
In large multi-user environments, most users will be assigned a username and
password by a network or IT administrator. For more information on creating user ID
and passwords, see the Database Server Admin Tool.

© 2014

Overview

35

Logging into Petra

Related Topics:
Shared Mode
Private Mode
Migrating Projects in Shared Mode
Opening Shared Mode Projects
Creating New Shared Mode Projects
1.3.2.1

Petra Workgroup 2014 Shared Mode

Shared Mode is designed for networked projects used by multiple simultaneous users.
This mode uses an external Petra Database Server to coordinate how users read
and write to the same project database.
After logging in and opening a project, users won’t notice any difference with earlier
versions of Petra. The processes of importing well data, interpreting logs, picking
tops, and making maps and cross-sections all remain the same as previous versions.
Related Topics:
Migrating Projects in Shared Mode
Opening Shared Mode Projects
Creating New Shared Mode Projects
Private Mode
1.3.2.1.1 Migrating Projects in Shared Mode

Petra Workgroup uses a different database requireing older Petra project database
tables to be upgraded or “migrated” with the Project Migration tool. This utility
automatically installs with the Petra Workgroup installation. A project only needs to
be migrated once. Migration does not erase any data from the original v3 project,
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and leaves it intact. The migration process only applies to the database tables.
External files, such as overlays and grids, are not affected.
There are a few different ways to open the Project Migration Tool.
On the Windows Start Menu, select IHS>Petra>Project Migration Tool.
Select the “DB Migrator” button on the Select Project to Open window within Petra
(See the Opening and Using Petra Projects section of this manual)
With no active project, select Project>Launch DB Migrator on the Menu Bar at the
top of the Main Module.
The Project Migration Tool is a standalone application, ElevDB Migrator.EXE. This
executable file is located inside the ElevateDB Migrator folder in the Petra Database
Server path, as well as in the Petra Standalone and Petra Server path.

The Migration Tool’s in a Database Server directory (Left) and in a Petra Standalone directory (Right)

The Project Migration Tool can be installed and run on any computer as a standalone
application with Petra_4X_Migrator.EXE (with the PetraVersion = 4.X).
Though this tool can remotely migrate projects on any server connected to the
network, it’s generally best to run the migration process on the computer where the
ElevateDB Server is installed.
The Migration Tool automatically looks in the Petra v4 installation’s “Parms” directory
for projects. After loading the projects, the tool lists all the available projects by
name, project path, INI path, shared status, and status.
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The Project Migration Tool in Shared Mode. Both shared and non-shared v3 projects can be migrated.

Server Address – This option sets the IP address or hostname of the database
server. To migrate projects on a local machine, set this field to localhost or
127.0.0.1.
Server Port – This option sets the port of the database server. To migrate projects
on a local machine, set the port to 12010.
EDB Login – This option sets the username.
Password – This option sets the password. The username and password will need
the appropriate permission. Brand new DB servers will only have a single
administrator user at first. EDBLogin: Administrator; Password: EDBDefault
Auto-Drop Existing DBs – This option automatically replaces projects with the same
name already on the Database Server.
For Invalid Project Names – This option determines how the Migration Tool handles
projects with names that start with a number or exceed the 40 character limit.
The “Skip Migration” option completely skips the migration.
The “Prompt user for new name” requests a new name for the project.
The “Automatically truncate and/or prefix name with:” both truncates characters
beyond the 40 character limit and/or adds a prefix for project names that start with
a number.
1.3.2.1.2 Opening Shared Mode Projects

Select the Petra Project to Open window displays all migrated projects on the
available servers. These projects are listed in a spreadsheet with columns for name,
description, the last opened date and time, the server name, server IP, and server
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port. There’s an additional column to the far left for “favorites.” Selecting the star
next to a project name designates a project as a favorite project, making it more
visible and easier to pick.
Marking a project as a favorite marks the project with a star for every user using the
same Petra installation.

The Select the Petra Project to Open window

In addition to opening projects, this window has a few other options:
Cancel – This option closes the “Select the Petra Project to Open” window and
returns to the Main Module.
Info – This option displays information about the selected project, including map
projection, access history, and folder pathways.
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Project information

Refresh – This option refreshes the projects available from the Petra Database
Servers.
Server Mgmt – This option opens the Petra Server Manager, and is primarily used to
add or remove available Petra Database Servers.
Change Login – This option changes the username and password used to login to the
Petra Database Server. Different user names may have different access privileges.
Open DB Migrator – This option opens the Shared Mode's Project Migration Tool.
# Wells – This option adds a column displaying the total well count for each project.
Filter – This option filters the available projects. To set a search criterion, select
whether the projects will be filtered by name, description, or server with the dropdown
menu. Next, enter the desired search term and select the “Filter” button. To remove
search criteria, select “Clear.” The “Favorites Only” option only displays projects with
a favorites star.

1.3.2.1.3 Creating New Shared Mode Projects

Creating a new project from scratch involves setting the following:
Project name
Description
Location of public and private directories
Database server
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Creating a new project also sets the locations of the public and private folders. Recall
that the public folder contains common and shared external files (GRIDS, IMAGES,
OVERLAY, etc.) while the private folder contains user-created files (like WSN lists,
import templates, or settings files) that customize Petra’s appearance and behavior.
Private folders should be separated both by user and by project.

1. Select the

button on the toolbar at the upper left corner of the Main Module.

2. On the Create New Petra Project window, select the “Create a New Project”
option.

Creating a new project

3. Create a name and description for the project, and select the desired database
server for the project.
This list displays the available database servers from the Petra DB Servers List. To
add or drop servers from this list, select “Server Mgmt.” Changing the servers here
will change the available servers for all users on this installation, so the file may be
locked by an IT administrator.
Recall that the database server can use roles to restrict what users can do, including
the ability to create new projects. To change login, select the “Change Login” button.
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Setting the name and description of the new project

4. Establish the project folder. The project folder is also known as the public
database path.

Setting the public folder in a shared project

5. Set the destination of the personal parameters folder - also known as the private
parameters path.
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Setting the private parameters folder for shared project

6. Review the settings, and select the “Finish” button to create the new project.

Creating the new project

1.3.2.2

Workgroup Private Mode

Private Mode is designed for projects that won’t be shared. Private Mode trades the
ability to share projects between multiple simultaneous users for an easier setup and
maintenance. In a large multi-user environment, Private Mode can be useful for
creating temporary “sandbox” projects for testing imports or working with data without
affecting a primary production project.
In Private mode, Petra Workgroup works very similarly to Petra Standard. Though
Petra Workgroup still has a database server, it is built into the Main Module and does
not need to be separately installed. Additionally, this mode always stores projects
locally on the host computer.
After opening a project, most users won’t notice any difference with earlier versions of
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Petra. The processes of importing well data, interpreting logs, picking tops, and
making maps and cross-sections all remain the same as previous versions.
Related Topics:
Migrating Projects in Private Mode
Opening Private Mode Projects
Creating New Private Mode Projects
Managing Private Mode Projects
Shared Mode)
1.3.2.2.1 Migrating Projects in Private Mode

Private Mode users launch the Project Migration Tool directly within Petra. When
running Petra in Private Mode for the first time, the program checks for locally stored
non-shared projects, and prompts you to open the Migration Tool.

Select "Yes" to open the Migration Tool

To open the Migration tool inside Petra's Private Mode:
Select the “DB Migrator” button on the Select Project to Open window within Petra
(see Opening Private Mode Projects)
With no active project, select Project>Launch DB Migrator on the Menu Bar at the
top of the Main Module.
The Migration tool displays a list of projects from the Petra v3 installation’s “Parms”
directory. This list displays the available projects by name, project path, INI path,
shared status, and status. To migrate projects from a different installation, select the
button and navigate to the Petra “Parms” folder containing the desired project INI
files. Next, select the “Load Projects” button.
Select the desired projects to migrate with the check boxes on the left side of the list.
Select the “Migrate” button to migrate the projects to the Database server. This
process copies the data inside the project to the database save location and
establishes the links to the database server.
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The Migration Tool in Private Mode. Note that shared projects cannot be selected for migration.

Auto-Drop Existing DBs – This option automatically replaces projects with the same
name already on the Database Server.
For Invalid Project Names – This option determines how the Migration Tool handles
projects with names that start with a number or exceed the 40 character limit.
The “Skip Migration” option completely skips the migration.
The “Prompt user for new name” requests a new name for the project.
The “Automatically truncate and/or prefix name with:” both truncates characters
beyond the 40 character limit and/or adds a prefix for project names that start with
a number.
1.3.2.2.2 Opening Private Mode Projects

The Select the Petra Project to Open window displays all migrated projects on the
available servers. These projects are listed in a spreadsheet with columns for name,
description, the last opened date and time, the server name, server IP, and server
port. There’s an additional column to the far left for “favorites.” Selecting the star
next to a project name designates a project as a favorite project, making it more
visible and easier to pick.
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The Select the Petra Project to Open window

In addition to opening projects, this window has a few other options:
Cancel – This option closes the “Select the Petra Project to Open” window and
returns to the Main Module.
Info – This option displays information about the selected project, including map
projection, access history, and folder pathways.

Project information

Refresh – This option refreshes the projects available from the Petra Database
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Servers.
Open DB Migrator – This option opens the Private Mode's Project Migration Tool.
# Wells – This option adds a column displaying the total well count for each project.
Filter – This option filters the available projects. To set a search criterion, select
whether the projects will be filtered by name, description, or server with the dropdown
menu. Next, enter the desired search term and select the “Filter” button. To remove
search criteria, select “Clear.” The “Favorites Only” option only displays projects with
a favorites star.
1.3.2.2.3 Creating New Private Mode Projects

Creating a new project from scratch involves setting the name, description, shared
status, and the location of public and private directories.
When choosing a name, remember that the name will show up in Petra as well as in
the project’s file folder. The description will show up in the Main Module as well as on
some maps, so it’s a good idea to give a few seconds thought to what you want
displayed, rather than just hammering in “ASDF.”
Creating a new project also sets the locations of the public and private folders. Recall
that the public folder contains common and shared external files (GRIDS, IMAGES,
OVERLAY, etc.) while the private folder contains user-created files (like WSN lists,
import templates, or settings files) that customize Petra’s appearance and behavior.
In Private Mode, all private parameters are stored in the project Parms folder.
Projects created in Private mode are limited to a single user.
1. Select the
button on the toolbar at the upper left corner of the screen. This
starts the Create New Petra Project wizard. Select the “Create a New Project”
option.

Creating a new project

2. Create a name and description for the project
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Setting the name and description of the new project

3. Establish the project folder. Petra will store both project data and private
parameters in this directory under a folder using the project name.
Most private mode users will use the default C:\geoplus1\Projects directory.

Setting the public folder in a shared project

4. Select the “Finish” button to create the new project.

Reviewing the project and parameter directories for the private project.

1.3.3

Active Directory
Petra can use the Active Directory (AD) directory service to establish and maintain
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Petra Database Server users and roles. When using AD, the database server
automatically creates Petra users from AD usernames and assigns roles from AD
groups. This method can use Kerberos authentication for additional security. From a
user’s perspective, Petra automatically logs in with the user’s AD credentials, which
translates to one fewer username/password to manage. Petra installations with AD
enabled in the Petra.ini file can ONLY connect to Petra Database Servers with AD
enabled.
Active Directory requires Petra v4.0.6 or higher, PetraEDBServer v1.03 or higher, and
a domain using Active Directory.

Configuring the Petra Database Server with edbsrvr.INI
Enabling AD on the database server requires a few modifications to the server’s
edbsrvr.INI file. With a default installation, this file is in the “C:\ProgramData\Elevate
Software\...” folder, and can be edited in any basic text editor. Alternatively, use the
Petra Server Admin Tool’s EDB Server Maintenance tool and select “open ini file.”
The following entries should be in the [Server] section of the edbsrvr.INI file.
Active Directory Enabled=1 – This line enables and disables AD on the server. Set
this to “1” to enable Active Directory, and “0” to disable Active Directory.
Active Directory SPN=host/computer_name - See the Working with SPN section for
more information on how to set this up.
Active Directory Override Users=Administrator,EDBProc,Billy – This line creates a list
of users that can access the Petra Database Server without using AD authentication.
At a minimum, this line should include the “Admin User” mentioned below and the
“Proc_Username” user (see Petra.INI section).
Admin User=Administrator – The database server needs administrative rights in order
to copy and modify users from the AD groups. This line simply lists a user in the
“Administrators” role. This user must be listed in the “Active Directory Override
Users” list mentioned above.
Admin Password=EDBDefault – This entry sets the password for the administrator
user.
IHS recommends creating another administrative account for this edbsrvr.INI file, or at
least changing the default password. The edbsrvr.INI file stores an administrator
username and password in plain text, so consider taking extra precautions when
assigning read/write permissions to this file.

Mapping AD Groups to Petra Database Server Roles
A mapping file connects user AD groups to database server roles. The database
server uses this mapping file to slot AD users into different roles, which can change as
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their group changes. This mapping is stored in AD_EDB_GroupMappings.XML in the
same location as the edbsrvr.INI file, and can be setup and modified through the Petra
Server Admin Tool. If AD is enabled on the Petra Database, the Server Admin Tool
will have a new button on the User Management Tab.

The Active Directory to EDB Mappings button

Selecting that button opens the Active Directory to EDB Mappings tool. To add a line,
select the green “+” button. To drop a line select the red “-” button. To establish a
relationship, type in the Petra Database Server roles (EDB Roles) and the associated
AD group. Note that this can be a one-to-many mapping – a role can be fed from
multiple groups.

Mapping database server roles to Active Directory groups

When done, click “Save” and you will get a notification explaining which roles will be
added or dropped to complete the mappings. Select “Yes” to complete the changes.
Once this is done, any user from one of these AD Groups will be able to login to Petra
and be automatically created (if doesn’t already exist) and assigned to the mapped
Petra Database Server Roles.

Configuring the Petra Installation with Petra.INI
In addition to configuring the Petra Database Server, enabling AD requires a few
modifications to the Petra’s configuration file, Petra.INI. This file isn’t created
automatically, so it’s necessary to either create it from scratch or copy the sample
Petra.INI located in the PetraSRV\PARMS folder to the Petra installation directory.
[ActiveDirectory] Section
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Enabled=1 - Set to ‘0’ to disable AD
SecurityPackage=Kerberos - Though other security packages (NTLM & Negotiate)
are available, IHS recommends Kerberos.
Delegate=YES/NO - Please refer to Microsoft SSPI documentation for an explanation
of this option. Default is ‘NO’.
MutualAuth=YES/NO - Please refer to Microsoft SSPI documentation for an
explanation of this option. Default is ‘NO’.
[EDB] Section
Proc_Username=EDBProc – This line sets a username that is ONLY used to make
initial contact with the Petra Database Server before AD Authentication. This user
should NOT be added to any roles which have access to your Petra Project
Databases. This user must exist in the “Active Directory Override Users” list
mentioned above.
Proc_Password=EDBProc – This line sets password for the “Proc_user” mentioned
above.
1.3.3.1

SPN

MSDN Information: http://msdn.microsoft.com/en-us/library/ms191153.aspx
Petra does not automatically register SPN’s with AD. Instead, Petra uses the SPN
listed in the edbsrvr.INI file’s “Active Directory SPN” line. This line can be set up in a
couple of different ways:

The EDBSrvr service is set to “Log On As” local system
In this scenario, the edbsrvr.INI setting should simply be set to “host/
computer_name”, where computer_name is the name of the computer running the
Petra Database Server. This SPN is registered by default for any AD computer and
there is no need to register it manually.

The EDBSrvr service is set to “Log On As” a specific user
account
This scenario requires a SPN registered for the specified specific user account. By
default, AD does not register any SPN’s for User Accounts. IHS recommends
registering the SPN the following way: “PetraKrbHost/user_name”, where user_name
is the user the SPN is registered to and is the same user as the EDBSrvr service is
using.

Registering an SPN
Please see MSDN documentation (link above) for information on registering an SPN,
however below is a quick tutorial on viewing, registering, and deleting SPN’s on your
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domain.
Perform these commands from the command prompt with an account with AD Admin
access
// lists all SPN’s registered to a given User
setspn –L UserName
// lists all SPN’s registered to a given Computer
setspn –L ComputerName
// Adds the SPN “PetraKrbHost/UserName” to the given User
// after verifying no duplicates exist
setspn –S PetraKrbHost/UserName UserName
// delete the SPN “PetraKrbHost/UserName” from the given User
setspn –D PetraKrbHost/UserName UserName
1.3.4

Workgroup Database Server Admin Tool
The following information only applies to Petra Workgroup 2014.
The Petra Server Admin Tool performs some database setup and most routine
maintenance. This includes creating server lists, managing users and roles, backing
up and restoring projects, and controlling individual Petra connections to the database
server or “sessions.” The Petra Server Admin Tool can be used at any time after
installation. Run before migration to perform some tasks that don’t need a project,
including creating a DB Server List, adding users, and changing passwords
(particularly the default administrator password).
There are a few different ways to open the Petra Server Admin Tool:
On the Windows Start Menu, select IHS>Petra>Server Admin Tool.
The Petra Server Admin Tool is a standalone application, PetraServerAdminTool.
EXE. This executable file is located inside the Petra Database Server path, as well
as in the Petra Standalone and Petra Server path.
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The Server Admin Tool in a Database Server directory (Left) and in a Petra Standalone directory (Right)

Note: PetraServerAdminTool.EXE can be copied and run on any computer.
When it first opens, the Petra Server Admin Tool has no active connections to a
Database Server. Note that the “Servers” list on the left side of the screen is blank.

The Petra Server Admin Tool without a connection to a database server

1.3.4.1

EDB Server Maintenance

The EDBServer Maintenance button on the menu bar at the top of the Petra Server
Admin tool opens the EDB Server Maintenance tool. This tool controls a few
additional options for the server, including changing the server port, opening the
Services Management Console, and opening the Database Server’s configuration
edbsrvr.INI file.
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The EDB Server Maintenance Tool

Server Port – This entry sets the Petra Database Server’s port. By default, this entry
is set to 12010. Make sure to select the “Save Changes” button and restart the
Database Server.
Configuration Path – This entry displays the location of the Petra database files. This
entry cannot change, and is just for display only.

Services
The Services button on the top of the Server Maintenance Tool opens the Microsoft
Service Maintenance Console. This can be useful for stopping and restarting the
ElevateDB Server to apply changes to the database.

The Service Management Console with the ElevateDB Server service highlighted

Open INI File
The Open INI File Button opens the Petra Database Server configuration file, edbsrvr.
INI. For more information on these configuration settings, see:
http://www.elevatesoft.com/manual?
action=viewtopic&id=edb2sql&topic=Starting_Configuring_Server
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The Database Server configuration file, edbsrvr.INI

1.3.4.2

Server Management Tab

The Server Management Tab provides an overview of the users and projects on the
currently available servers.

The Petra Server Admin Tool’s Server Management Tab

User Sync
This tool copies users from one server to another. You must be connected to at least
two servers to use User Sync. Copying users requires a login with administrative
privileges on both servers. To sync a user:
1. Select the two desired servers from the respective dropdown lists.
2. To copy a user from one server to another, select the relevant user name and
select the adjacent “>” or “<” button. In the example below, the username “Dana”
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has been copied from the “LocalHost” Server to the “ProjectServer.”
3. Select the Save icon and then close the Sync Users window.

Syncing users between two servers

Role Sync
This tool copies roles from one server to another. Copying roles requires a login with
administrative privileges on both servers. To sync a role:
1. Select the two desired servers from the respective dropdown lists.
2. To copy a role from one server to another, select the relevant role and select the
adjacent “>” or “<” button. In the example below, the “GeoTechs” role has been
copied from the “LocalHost” Server to the “ProjectServer.”
3. Select the Save icon and then close the Sync Roles window.
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Syncing roles from one server to another

1.3.4.3

Project Management Tab

The Project Management Tab displays information on the selected Petra database
server's projects. Importantly, this section also handles database versions, project
maintenance, and backups. The central list provides a short summary of project
name, well count, project version, and descriptions. This list will always include a
“Master” project that the database server uses as a template for Petra project tables.
The far right column provides more detailed project information or maintenance
options

Project Information Tab
The Project Information Tab displays the basics of a Petra Project on the Petra
Database Server, including the database and public folder pathways, as well as the
original creator and migration date.
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The Petra Server Admin Tool’s Project Management Tab (Project Information)

DB Path – This entry shows the path for the database root folder.
Project Public Path – This entry shows the public path for the project. The “Edit”
button modifies the Project Public Path. It’s recommended to use UNC pathing (\
\Shared1_svr\ PetraProjects \) rather than drive mapping (Z:\PetraProjects).
Created By – This entry shows the project creator.
Creation Date –This entry shows the project’s creation date
.Migration Date – This entry shows the project’s migration date.

Maintenance Tab
The Maintenance Tab performs some of the basic project maintenance tasks,
including updating, cloning, and backing up project databases. This tab also handles
project database table repairs.
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The Petra Server Admin Tool’s Project Management Tab (DB Maintenance)

Project Database DB Version
Update - As Petra changes in the future, the way a Petra project stores data in tables
may also change. This button upgrades project databases to the latest version. As
part of the upgrade process, the Server Admin Tool creates an optional backup of the
project. To disable the backup, select the “Skip Backup Before Updating” option.
Keeping the Master project updated insures that new projects are created with the
most current database version.
Verify – This option goes through the entire database to confirm that the project’s
table structure is correct. If there’s a problem select the “Table Maintenance” tool.
Delete Selected Project – This option deletes the project data stored on the DB
server. This option also can erase the entire project folder; however, the project INI
file in the program Parms folder (C:\geoplus1\Parms) is still retained.

Table Maintenance
The “Table Maintenance” button opens the Project Maintenance window, which
controls some of the more common database procedures, including table verification,
repair, and optimization. This tool handles table index problems that usually
show up as “Access Violation” errors.
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The Table Maintenance Tool

Verify Selected – This option goes through the checked tables in the database to
verify its table structure is correct. More specifically, this tool finds mismatches
between the table index and the actual numbers of tables. The Verify Selected option
will remove the check on project tables with no problems, leaving only the tables with
problems checked.
Repair Selected – This option searches through the checked tables and verifies
database integrity and consistency. This tool fixes the database table relationships.
Before attempting any database repair, make sure all users are out of the project.
See Appendix B for more information on how to forcibly kick users out of a project.
Optimize Selected – This option is intended for routine project maintenance. Deleting
data from the database sometimes leaves empty slots in the tables. Much like
defragmenting a hard drive, the Optimize tool eliminates empty spaces by copying all
valid data to a temporary file, sorting the data, and then replacing the original file with
the temporary file.
Indexes aren’t normally rebuilt whenever data is added or deleted from the DAT file,
so they can get slower with time. The Optimize Selected tool rebuilds the index file
using the current dataset and can make querying data more efficient.

DB String Cleanup
Most projects which were migrated to the new database prior to Petra v4.0.5 stored
some text fields inefficiently. This utility recovers disk space caused by this
inefficiency. Depending on the project, the amount of disk space which can be
recovered will vary from a few kilobytes to gigabytes. Projects migrated using
Petra v4.0.5 or later will not benefit from running this cleanup.
Analyze - This option runs a query to see how much disk space can be cleaned up.
The total amount is listed in the lo file displayed at the bottom of the window.
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The DB String Cleanup window's Analyze tool

Cleanup - This option optimizes the affected tables. Note that the process can take a
significant amount of time on large projects. Once the database records are updated,
this tool runs an optimization process each affected table to complete the process and
recover disk space. The optimize portion can be skipped by unchecking the
checkbox; however the disk space will not be recovered until a database optimization
is complete.

The DB String Cleanup window's Cleanup tool

Clone Project Database
The Petra Server Admin Tool creates a copy of the selected project in the project list.
This clone can either reside on a different server, or the same server (with a different
name).
Destination Server – This dropdown sets the destination of the copied project.
New Project Name – This option sets the name of the copied project. By default, the
Server Admin Tool adds “COPY_” to the beginning of the selected project’s name.

Project Database Backups
Create New – This option creates a new backup of the selected Petra project
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database. This includes the project database and database-server-stored individual
user settings. This backup will not include external files (like grids and *.MAP/*.CSP
settings files). Note that these backups are automatically stored on the Petra
database server.
Restore– This option overwrites the existing active project with the backup. This will
overwrite all public and private Petra project data modified since the backup. This
includes all “public” data like well data, zones, tops, and logs, as well as “private” data
like map settings, cross-section settings, and preferences. Restoring from backup
will not affect external files (like grids and *.MAP/*.CSP settings files).
Delete – This option deletes the selected backup.

Full Project Backup Tab
The Petra Server Admin Tool can create entire project backups. The Full Project
Backup creates a copy of the entire public folder and zips it up into a single *.PBF file.

The Petra Server Admin Tool’s Project Management Tab (Full Project Backup)

Backup File - This option creates the name and location of the project backup file.
Select the
button and navigate to the desired *.PBF file.
Ignore OVERLAY Folder – This option excludes the project’s OVERLAY folder from
the backup file.
Ignore IMAGES Folder - This option excludes the project’s IMAGES folder from the
backup file.
Overwrite if Backup Exists – By default, the Petra Server Admin Tool will not
overwrite an existing backup with the same name in the same location. This option
forces the backup to overwrite the existing backup.
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User Management Tab

Petra v4 distinguishes between different users to deliver personal parameters (such
as map settings) and to restrict permissions with “roles.” Petra defines a role as a
set of permissions to read and write to individual projects, as well as the ability to
create new projects from scratch. Only users in the “Administrators” role can edit
users and roles.
Petra's Database Server can use an Active Directory network to create users and
dynamically maintain roles.

All Users List
The Users List creates, modifies, and removes new users from the Petra database
server. Selecting a specific user changes the tab to reflect the detailed settings for
the individual user, including the user name, description, and obscured password.

The Petra Server Admin Tool’s User Management Tab

To create a new user, select the “+” button at the top of the All Users List, and
enter the new name, description, and password.
To delete an existing user, select the “X” button at the top of the All Users List.
To modify an existing user, select the desired user from the All Users list, and select
the “Edit” button on the right side of the screen. Select “Save” after editing.
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Adding a new username with a description and password

Roles List
The Roles List creates, modifies, and deletes roles. Each role defines a set of
permissions for a set of projects, which provides a great deal of flexibility. Selecting a
role changes the far right part of the screen to reflect the detailed permissions of the
role. This screen indicates the name and description of the selected role, as well as
the specific read/write permissions for each project. Permissions are additive. Any
user in a role with permission to create and/or delete projects will be able to create
new projects regardless of permission set in their other roles.
By default, Petra’s database server has two roles: “Administrators” and “Public.”
Administrators have read/write access to all projects on the server and can create
new projects. Public users, by default, can read (but not change) all existing projects,
as well as create new and delete existing projects. New users are automatically put
into the Public role. Editing the Public role changes the default permissions for all
users. Changing the “New Project Defaults” in the Public role changes the default
read and write permissions for new projects.
Users can’t be dropped from the Public role. To restrict users creating and deleting
projects, remove that functionality from the Public role and create another dedicated
role with the create new projects/delete existing projects options enabled.

The Petra Server Admin Tool’s User Management Tab with the “Public” role selected
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To add a new role, select the “+” button at the top of the Roles list and enter a
name and description.
To delete an existing role, select the “X” button at the top of the Roles List.
To edit the selected role, select the “Edit” button, make the desired changes, and
select the “Save” button.

The Roles List also contains the usernames associated with each role. Selecting the
triangle or plus to the left of the role name expands the tree to display all users in that
role.
To add a new user to a role, drag the selected user from the All Users List into the
desired role.
To remove a user from a role, drag the user inside the Roles List back into the All
Users List, or to the box at the bottom of the Roles List.
1.3.4.5

Session Management Tab

The Petra Session Management tab lists and terminates active sessions on selected
database servers. A session is an active connection to the database server. In
addition to a background session for every user, each open module has its own
session. As an example, a user working with the Map Module, the Main Module, and
the Cross-Section Module will have 4 total sessions.

The Petra Server Admin Tool’s Session Management Tab

- This button refreshes the active sessions for the connected servers. Note that
the Session Management Tab will remain blank until this button is selected.
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- This button kills the selected session. When a Petra module crashes or closes
unexpectedly, it can leave an open session with the database that prevents the user
from reconnecting to the project. Though a session will timeout on its own after a
period of inactivity (120 seconds by default), the button terminates the selected open
session so the user can reconnect immediately. In an emergency, kill can also be
used to remove users prior to performing a repair.

1.3.4.6

Logs Tab

Petra keeps two kinds of database server records: migrations and database
updates, and other server events.

Petra Logs Tab
The Petra Logs Tab displays project migration and database update logs. The
button refreshes the “Log Filename” list of the available records on the connected
servers. Petra stores these logs as: Process-Username –YYYY-MM-DD_HH.MM.
SS. Note that the Petra Log Tab will remain blank until this button is selected. The
dropdown on the top of the screen trims the list of logs to include project migration,
database updates, or all.

Migration logs in the Logs folder

Migration logs can contain “Dropping orphaned record” lines. These records indicate
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that the Migration Tool fixed orphan records not removed during the Pack step in
project preparation.
Migration and DB update logs are also stored externally in the Support/Logs folder
inside the Project Databases folder.

Server Log Tab
The Server Log Tab displays a record of database server events, including user
activity and errors. The
button refreshes the log for the connected servers. Note
that the Server Log Tab will remain blank until this button is selected. The buttons on
the top of the screen trim the log to just include the last 24 hours, last week, or last
month. The server log has a maximum file size, which will eventually truncate old
messages

The Petra Server Admin Tool’s Server Log Tab

This screen contains columns for the error code, the function, a timestamp, the
relevant user, the IP address, and a longer description of the event. To sort by the
various columns, select the column header once for ascending order and twice for
descending order. For more information on error codes, see:
http://www.elevatesoft.com/manual?
action=topics&id=edb2sql&section=appendix_error_msg
1.3.4.7

Jobs Tab

The Jobs Tab schedules regular project backups and repairs.
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The Petra Server Admin Tool’s Jobs Tab

Create Job – This option opens the “Create A New Job” dialog.
Alter Job – This option modifies the selected job.
Rename Job – This option renames the selected job.
Delete Selected Job – This option deletes the currently selected job.
Copy Job – This option creates a copy of the currently selected job.

Adding and Modifying Jobs
The Create New Job button creates a new job on the server, while the Alter Job
button modifies an existing job. The process of creating and modifying a job are very
similar. Both the Create New Job and Alter Job buttons open the same three
windows: general tab, definition tab, and scheduling tab. These tabs name the job,
select the specific process and Petra project, and schedule the time and occurrence
of the job.

General Tab
The General Tab sets the name and description of the job. The example below
shows a job that will back up all projects nightly.
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The Create New Job (left) and Alter Job (right) General Tab

Definition Tab
The Definition Tab sets the specific process and project for the job. A single job can
either create a new backup of a project, or repair a working project. Next, select the
desired project or all projects. The example below will affect all projects on the
database server.

The Create New Job (left) and Alter Job (right) Definition Tab

Scheduling Tab
The Scheduling Tab sets the job’s interval and timeframe.
Interval – This dropdown sets the job’s frequency. Options here include once, hourly,
daily, weekly, monthly, and “every.”
The “Every” option repeats the job by a set number of minutes, hours, days, or
weeks, starting at the time specified by the “Between” option below. Note that the
number of minutes, days, hours, or weeks needs to be specified in round numbers.
Additionally, the “Weekly” option performs the job on specified days of the week.
From/To – These two options set the calendar date range for the job. Note that
dates can be entered manually, or selected on a dropdown calendar.
Between/And – These two options set the timeframe of the job. Note that times can
be entered manually, or with the up/down windows to the immediate right of each
time.
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The Create New Job (left) and Alter Job (right) Scheduling Tab

1.4

Petra Standard 2014
Petra Standard edition is designed provide the same features as Workgroup but in a
single-user or small team interpretation environment. The processes of importing well
data, interpreting logs, picking tops, and making maps and cross-sections all remain
the same as the Workgroup version.

Related Topic
Internal DBI Database
1.4.1

Internal DBI Database
Petra 2014 Standard and Workgroup private mode use an internal database that
stores each project’s internal database files in a series of tables named for the data
type. Again, each table has three files, though the file extensions now all have an
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“EDB” prefix: *.EDBBlb, *.EDBTbl, and *.EDBIdx. These project database files are
stored in a single folder; in Shared Mode the folder reflects the name of the project,
while in Private Mode the folder name is DB4. In the screenshot below, the Tutorial
project has a “TUTORIAL” folder that contains all the table files.
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Installing & Configuring Petra
There are three separate components to the installation and configuration of Petra:
SW Installation
Licensing
Database (Internal or Database Server)

SW Installation
There are two types of installation; standalone and network. The type of Installation
only affects the location of Petra's executable files. Both allow projects to be shared
between multiple users.

Licensing
Petra can run with one of two licensing methods: a network license manager or a
hardware “bitlock”. Licensing is managed using the Config.EXE utility for both license
types.

Database
Petra 2014 Standard and Workgroup Private mode both use an Internal Database
Petra 2014 Workgroup Shared mode uses a Database Server

2.1

Petra Installations
Both Petra Standard and Workgroup editions support standalone and network
installations. The type of installation only affects the location of Petra's executable
files and does not affect project sharing between multiple users.
One advantage of network installations is the ease of updates; Network installations
only require a single network server to be updated. Standalone installations require
each individual workstation to be updated.

Standalone Installation
For standalone installations run the Petra standalone installer
Petra 2014 Standard, " ALLDI SKS. ex e" .
Petra 2014 Workgroup, " PETRASTANDALONE. ex e"
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Program files will be stored in "C:\Geoplus1" by default. IHS recommends that you
always use the default directories.

Network Installation
Network installations require both a server and client installation.

Petra Server Installation
A network installation stores Petra executable files are installed on a single network
file server accessible to all Petra users. Petra's network server installer, "server.
EXE" installs the files in C:\PetraSRV by default. The location of the network
executable files is often referred to as the Petra "system path."

Petra Client Installation
With a network installation, each individual workstation requires a "client" to be
recognized by the server. Petra's client installer, "client.EXE", installs the files in "C:
\Geoplus1" by default. Once installed, "Config.EXE" is run to specify the network
program path, client path and licensing method.

2.2

Upgrading from V3.x to Workgroup 2014
Petra Workgroup 2014 provides a dedicated database server that controls how users
read and write to the database tables. This single database server directly manages
all data requests and changes to each project’s database, performs project repairs
and maintenance, establishes users and permissions (“roles”), and delivers user
settings.
Petra Workgroup can run in two separate modes: Shared and Private.
In Shared Mode, Petra uses an external database server. This server needs to be
installed separately.
In Private Mode, Petra uses an internal database server built into Petra’s Main
Module. This internal database server needs no special installation.

Quick Start Guides
Shared Mode Quick Start Guide
Private Mode Quick Start Guide
After the installation completes the new Petra icon:
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Total v4 Upgrade vs Concurrent v3 and v4 Installations
IHS recommends a total upgrade to v4 rather than running simultaneous v3 and v4
Petra installations. Though it is possible, it adds more complexity to the v4 upgrade
process. It also introduces the potential for lost data; changes (such as picked tops)
made in v3 projects do not automatically propagate to v4 projects, and vice versa.
During the installation process, if the installer detects an older version of Petra, the
Question window changes whether the install will upgrade Petra v3 to v4 or create
concurrent Petra v3 and Petra v4 installations:
“Yes”: this option completely uninstalls and automatically overwrites the existing
installation with no further user input. IHS recommends this option.
“No”: this option leaves the old version of Petra in place and concurrently installs the
new version in a different location. See here for information on concurrent
installations

Selecting whether to overwrite Petra v3 or install v4 in a different location

2.2.1

Updates
Petra updates periodically contain changes and additions to the database tables. If
an updated version of Petra is used to access a shared project, older versions of
Petra may no longer be able to access that project.
All Petra seats within an organization should be updated at the same time. If the
organization prefers to test new versions of Petra before general release to all users,
it is best that testing be done with dedicated testing projects rather than projects that
the organization wishes still be accessible to older versions of Petra
Updates for both standalone and network installations are available at:
http://www.ihs.com/permission/en/pps-downloads.aspx

Network Updates
PetraServer.EXE, updates the Petra network program files. These files are typically
located in the "petrasrv" folder on the network drive.
PetraClient.EXE, updates the Petra Client on individual workstations. Since the
client only links to the server installation, it's rare for the client to need updating.
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Standalone Updates
Standalone copies of Petra are updated from the web using either "alldisks.exe" or
"petraup.exe" download files.
Petraup.EXE contains just the essentials for updating the Petra program files for an
existing standalone installation.
Alldisks.EXE contains all of the files to update Petra with the exception of the bitlock
drivers.

Upgrading Versions
For more detailed information on updating Petra v3 to v4, see here.
2.2.2

Upgrading to V4 (Private & Shared Mode)

Quick Start Guide
Install the Database Server
Run PetraEDBServer_X_Y.EXE (EDB Version = X.Y)
Set database installation and database storage paths
Set logon information for Elevate DB Service (only if storing projects on a network
drive)

Install Petra v4
For standalone Installations, run PetraStandalone.EXE
For server/client Installations run PetraServer.EXE on the desired server, and run
PetraClient.EXE on all client computers
Use Config.EXE to set up licensing and networking

Migrate Projects to v4 (PetraProjectMigrator.EXE)
Make good backups of projects before migrating
Run a database repair, optimize, and pack on the desired projects
Select the desired projects in the old Petra Project Directory
Set the server address, port, and logon to the new database server
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Setup the Database Server (PetraServerAdminTool.EXE)
Set up database server list
Connect to the database server
Add users and roles

Open and Use v4 Projects
Log on to the database server
Migrate the private parameters, or create new private parameters
Select a location for the private folder
2.2.3

Upgrading to V4 (Private Mode Only)

Private Mode Quick Start Guide
Install Petra v4
For standalone Installations, run PetraStandalone.EXE
For server/client Installations run PetraServer.EXE on the desired server, and run
PetraClient.EXE on all client computers
Use Config.EXE to set up licensing and file structure.

Migrate Projects to v4 using the Private Mode Migration Tool
within Petra
Be sure to have good backups of projects before migrating
Select the desired projects in the old Petra Project Directory

Open and Use v4 Projects
After migrating, refresh the project list and select the project to open.
2.2.4

Concurrent v3 and v4 Installations
Important:
Changes to the old v3 project database after migration WILL NOT automatically
propagate to the newer v4 project.
Post-migration changes to the old v3 project must be exported and manually
imported into the newer v4 project.
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The key to concurrent installations is to bypass the v4 installer’s automatic uninstall
and overwrite of older versions of Petra Standalone, Client, and Server. Selecting
“No” on this window will leave the older v3 installation alone and create a separate
installation of v4 in a different location.

“Yes” installs over the existing copy of the Petra Server, while “No” installs v4 to a different location

The Petra v4 installer places bypassed installations by default into C:\geoplus4 (Petra
Standalone and Client) and C:\petrasrv4 (Petra Server) to avoid installing into older
versions of Petra’s default installation locations.

Default installations for Petra Standalone (Left) Server (Center) and Client (Right) when bypassing uninstall

2.3

Petra Licensing
Copies of Petra can run with two different licensing methods: a “bitlock” or a network
license manager. Config.EXE sets up licensing for both bitlock and network licenses.

Bitlocks
A bitlock (also known as a “dongle”) is a hardware device that that fits into the
computer’s USB port. Much like the key in a car, Petra will not start without this
device and will shut down when removed. Bitlock licensing is simple and works well
for offsite/field work, but can make sharing software licenses between different users
difficult since the physical bitlock needs to be shared around an office.

Network Licenses
With a network license, users obtain a license from a license manager program
running on the network. If a license is available, then Petra runs normally. If a license
is not available or there is no network connection to the server, Petra will not run. In
contrast to a bitlock, a network license manager requires a network connection to
work but can make sharing licenses between multiple users in different locations much
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easier.
The license manager does not have to be installed on the same server where the
Petra program files reside but must be visible from the user's workstation.

2.4

Config.EXE
Config.EXE changes the parameters of an individual standalone or client Petra
installation. This utility is automatically installed during the Petra client installation and
is located in the same subdirectory as the Petra client software. It automatically runs
as part of the client software installation, but can also be run later to change any of
the parameters.

Petra's configuration program, Config.EXE

System Path – This entry sets the location of the Petra executable files. By default,
this is C:\Petrasrv
Client Path – This entry sets the location for each client installation. By default this is
C:\Geoplus1.
Project Path – This entry sets the default location for newly created projects.
Parms Path – This entry sets the default location of user-specific private parameters.
Security Key Type – For bitlock-based licensing, this entry selects between a
RainbowNetC or a NetHASP license.
Obtain Petra License From – This option sets whether Petra looks for a license from
a network server or a bitlock/unlock code.
Obtain PetraSeis License From – This option sets whether PetraSEIS looks for a
license from a network server or a physical bitlock/unlock code.
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In the example below, the server software is on \\server1\petrasrv, the client software
is on c:\geoplus1, the default path for the public or shared part of the projects is \
\server2\geoplus\projects, and the default path for each individuals private parameters
starts at \\server2\geoplus1\users.

2.5

Geoplus.INI
Geoplus.INI stores user-specific data like window sizes, and the previous projects
opened. For standalone installations, this file will be in the installation directory. For
client\server installations, geoplus.INI will be in the client directory.

Figure 1: An example of a Geoplus.INI file

[STARTUP]
The Startup section modifies how Petra first loads up. Most users will never need to
change the variables in this section.
VerSize, WindoLeft, WindoTop, WindowD, WindoHT, WindoMax - These options set
the starting location of the Main Module.
PrevVer – This variable stores the previous installation‘s version number.
PrevProject - This variable stores the last opened project’s name.
CurrProject – This variable stores the current project name.
HideWelcome – Setting this option to “1” hides the Petra welcome screen.
ProjectListSortType – This option sets how Petra sorts the projects on the project
open screen. Setting this option to “0” sorts projects alphabetically, while setting this
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option to “1” sorts projects by the last used date.
ProjectListSortOrder – This option sets how Petra sorts the projects on the project
open screen. Setting this option to “0” sorts projects in an ascending order (A to Z,
recently used to less recently used), while setting this option to “1” sorts projects in
descending order (Z to A, less recently used to most recently used).
Editor –This option sets the executable for the default text editor.
SkipUpdateCheck– Setting this option to “1” forces Petra to skip looking for updates.
Example
[STARTUP]
VERSIZE=1
WNDOLEFT=1763
WNDOTOP=158
WNDOWD=1344
WNDOHT=675
WNDOMAX=0
PREVVER=3.6.0
PREVPROJECT=C:\geoplus1\PARMS\MEXICO.INI
CURRPROJECT=C:\geoplus1\PARMS\MEXICO.INI
HIDEWELCOME=0
PROJECTLISTSORTTYPE=0
PROJECTLISTSORTORDER=0
EDITOR=NOTEPAD.EXE
SKIPUPDATECHECK=0

[WMS]
The WMS section stores the URL, username, password, and layer of the last WMS
server accessed in the Map Module. This makes it easier for the user to reconnect to
the last server they were using. For servers that don’t need authentication, the user
and password remains blank.
Example
[WMS]
url=http://gaia.inegi.org.mx/NLB/mdm5.wms
user=
password=
LayerList=SATELLITE

[PLOT]
The Plot section controls how Petra plots maps and cross-sections.
HideDateStamp – Setting this option to “1” hides the date stamp at the bottom of
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maps and cross-sections.
Example
[PLOT]
HIDEDATESTAMP=0

2.6

PETRA.INI
Petra.INI stores installation-wide settings like notifications and licensing. Importantly,
this INI file also controls some important administrative functions, including
controlling who can delete wells or change map projections.
This file isn’t created automatically, so it’s necessary to either create it from scratch
or copy the sample Petra.INI located in the PetraSRV\PARMS folder. To affect only
a single project, save Petra.INI inside the project’s root directory. To affect every
project used on a Petra installation, save Petra.INI to the Petra installation directory.

An example of a Petra.INI file

[GENERAL]
The General section sets a few system-wide options on how Petra interacts with
external programs and services.
AllowRememberLogin – This option sets whether Petra provides an option to
remember the last user logon. Setting this option to “NO” disables caching the user
name and password.
ShowWebsite – By default, Petra has a link to the download website built into the
Help dropdown on the top of the Main Module. Setting this option to “NO” disables
this link.
Notify – Setting this option to “YES” hides the license expiration notice shown during
© 2014

82

PETRA Help

startup.

An expiration notice.

MJDelaySec – This option sets the length of time (in seconds) that Petra waits and
retries to receive direct connect raster logs from MJ LogSleuth
AdminPswd – This option sets a password on the entire project. Only users with the
password can open the project.
LICUncNames – Setting this option to “YES” forces Petra to use UNC (Universal
Naming Convention) paths rather than LFS (Local File System) when working with log
or map images. UNC syntax describes network paths with double slashes and names
(such as \\ComputerName\SharedFolder\Resource), while LFS syntax uses drive
letters.
UserApplName – Petra can launch an external application and pass the selected well
UWI to it. This option sets how the application’s name appears in Petra's menu. Note
that this entry has a maximum of 30 characters. This option can be overridden by a
client’s geoplus.ini file.
UserApplPath - This option sets the path and filename of the external application.
This option can be overridden by a client’s geoplus.ini file.
BingMap – This option overrides the default URL for Bing maps available on the
Location Tab of the Main Module. The default is http://www.bing.com/maps/
Bing_WGS84_DatumShift – Bing’s maps use the WGS84 reference datum. By
default, Petra recalculates the LatLons from the project reference datum into WGS84
before it sends the LatLon to Google maps. Setting this option to “NO” forces Petra
to send the raw LatLons directly from the project.
SaveDefaultProjection – Setting this option to “YES” prevents any user from creating
a system-wide default map projection file. Note that these files are kept in the system
parms folder as DefProjection.BIN or DefProjection1.BIN.
AllowUserProjection – Setting this option to “NO” prevents users from creating userdefined coordinate systems under the “Standard” Coordinate System Tab in the Map
Projection Settings window.
BkgndScan – Setting this option to “YES” will tell Petra to scan every project’s well
locations to compute the LatLon extents. These limits are stored in each project’s INI
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file.
BkgndScanTime – This option sets the amount of time (in minutes) Petra waits
between project extent scans. By default, Petra waits 30 minutes.
SkipUpdateCheck – By default, Petra checks for newer versions at every startup.
Setting this option to “YES” skips this check.
AllowPrivateMode - Setting this option to "YES" will allow users to run Private Mode
locally. Setting this option to "NO" will disallow private mode.
HideLoginDialog=YES/NO - Setting this option to "YES" will attempt to hide the Login
screen when possible, such as when the "Remember My Password" option is
selected or when using Active Directory. Note that the login screen will still appear
when Petra needs a username and password.
Example
[GENERAL]
SHOWWEBSITE=NO Prevents users from using link to www.geoplus.com WEB Site
; NOTIFY=NO Turns off Maintenance Expiration message
; MJDELAYSEC=15 – Sets Petra’s delay for MJ LogSleuth
; ADMINPSWD=SFTY3RD – Sets an administrative password for the project
; LICUNCNAMES=YES - Used to allow UNC names for LIC files.
USERAPPLNAME=Company Document Manager
USERAPPLPATH=\\geoapps\welldocs\software\mgr.exe
; MODIFYPLACESBAR=NO
; GOOGLEMAP= http://maps.google.com/maps
; GOOGLE_WGS84_DatumShift=NO
; SaveDefaultProjection=NO
; AllowUserProjection=NO
; BKGNDSCAN=YES
; BKGNDSCANTIME=30
; SKIPUPDATECHECK=YES

[USERSOURCE]
By default, Petra treats all users in a project equally. All users have the power to
delete or change all data and to change map projections – in short, all users have the
power to irreparably destroy a project. The UserSource section creates a system of
user source codes that effectively limits what an individual can do. Only
administrators can delete wells, change the reference datum or coordinate system,
globally delete data, or modify any tops other than their own.
To change user names while inside a project, select Project>Settings>Set User
Source Code… and enter the appropriate user name.
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Changing user source codes in Petra

Enabled – This option enables administrators and regular users. Set this to 1 to
enable administrators.
Blanks – This option controls how formation tops with blank source codes are
handled. When this option is set to 0, all users can modify a top with a blank source
code. When this option is instead set to 1, only administrators can modify a top with
a blank source code.
Adminlist – This line sets the user source codes for administrators. Administrative
users should be separated by commas with no spaces. In the example below, “tdw,
bob,hlm” sets three users as administrators: tdw, bob, and hlm.
Example
[USERSOURCE]
; BLANKS=0 - everyone can modify a top if it has a blank source code
; BLANKS=1 - no one can modify a top if it has a blank source code unless
; they are a member of the ADMINLIST
;
ENABLED=1
BLANKS=1
ADMINLIST=tdw,bob,hlm

[LOGARC]
This section onfigures how Petra retrieves logs with LogTech software.
Program –Normally, Petra uses the user registry to find the LOGARC retrieve
executable. This option overrides the pathway for the LOGarcve.exe
Example[LOGARC]
PROGRAM=\\geoapps\LOGARC\LOGarcve.exe

[NOTICE]
Petra can display a couple of different kinds of notices. The “broadcast notice”
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displays for a few seconds when Petra first starts up, while the “kill notice” warns
users for a few seconds before Petra forcibly shuts down.

User Broadcast Notice
Though most of the formatting like text size and color is controlled by the actual
document, Petra.INI has a few additional settings that change how the broadcast
notification works.
UBCWaitSec – This option sets the length of the notice in seconds. Users can close
the notice at any time with the “close” button on the bottom of the notice.
SoundFile – This option adds a sound file that plays whenever the notification opens.
Set the path and file name of the wave file, or just the name of the wave file if it’s in
the installation directory.

NotifyKill
Though most of the formatting like text size and color is controlled by the actual
document, Petra.INI has a few additional settings that change how the kill notification
works.
KillWaitSec – This option sets the number of seconds the kill notice will display before
closing Petra.
KillSound1 – This option sets the filename and pathway of the sound file that plays
when the notice first appears.
KillSound2 – This option sets the filename and pathway of the sound file that plays
once per second while the kill notice is counting down.
KillSound3 – This option sets the filename and pathway of the sound file that plays
when the kill notice closes and forcibly shuts down Petra.

General Notice Settings
Backcolor – This option sets the RGB values for both the kill notice and the broadcast
notice background. By default, this option is set to 255, 255, 255 for white. In the
example below, the values for other colors are added as comments.
Example
[NOTICE]
;SOUNDFILE=<wave file>
UBCWAITSEC=30
KILLSOUND1=<wave file> Sound file to play when notice appears
KILLSOUND2=<wave file> Sound file to play once per second
KILLSOUND3=<wave file> Sound file to play when removing notice
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KILLWAITSEC=30

Seconds to display user notice before closing

BACKCOLOR=255,255,255
; BACKCOLOR=250,0,0
; BACKCOLOR=250,40,70
; BACKCOLOR=0,255,0
; BACKCOLOR=0,0,255
; BACKCOLOR=255,255,0
; BACKCOLOR=40,135,250
; BACKCOLOR=212,212,212
; BACKCOLOR=255,255,255

Red
Pink
Green
Blue
Yellow
Light blue
Light Grey
White

[NETLOGIN]
The Netlogin section controls FlexLM licensing and stores a record of users entering
and exiting Petra projects.

FlexLM
FlexLM – Set this option to “YES” to enable a FlexLM license.
FlexLMLicPath – This option sets the FlexLM port and machine hostname.
FlexLMDataLic – This option enables Petra "data access" licenses for data transfer.
By default, data transfer occupies a Petra license.

Project Access Log
The project access log keeps a record of users logging into and out of the projects
used on the specific Petra installation. This file is ordered bottom to top, with the
most recent activity at the beginning of the file and the oldest activity at the bottom.
Note that this file can be easily cut and archived - Petra will create a new
"LogFileName" the next time someone logs in or out of Petra.
Example
Larry Harvey,8/28/2006 5:22:52 PM,Closed:
c:\geoplus1\projects\SoonerDemo
Larry Harvey,9/5/2006 3:43:02 PM,Opened:
c:\geoplus1\projects\SoonerDemo

LogProjectAccess – This option turns on the logging feature. Set this option to YES,
and establish a valid file pathway with the LogProjectAccess option to start logging.
LogFileName – This option sets the pathway for the Note all users must have read/
write access to this log file.
Example
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[NETLOGIN]
;-----------------------------------------------------; to enable network flexlm licensing use the following
; two keywords. Needed is the Port and machine hostname
; where flexlm is running.
;
FLEXLM=ENABLED
FLEXLMLICPATH=27000@petraserver
FLEXLMDATALIC=YES
;----------------------------------------------------; ****LOGIN LOG FILE****
; Network version login monitoring log file. This file
; will contain date-time stamp of each time a user
; acquires or is denied a Petra network license.
;----------------------------------------------------; uncomment and put path to common location that
; all users have read/write access to
;
LogFileName=\\server1\petrasrv\petralogin.txt
;
; set LogProjectAccess=YES to have the user's project name added to
; the login file to track opening and closing Petra projects
LogProjectAccess=YES

[IMPORT]
LASPath – This option sets the default folder path for importing LAS files.
RasterPath – This option sets the default folder path for importing raster logs and
calibration files.

IHS (US) raster logs
IHSLogNDXRootFolder - This option sets the path of the folder containing the LIC and
TIF files.
IHSLogNDXDBFolder – This option sets the path of the folder containing the IHS
catalog database files (tblLogs.dat and tblLogs.idx)

LICCat.exe
LicCatalog - This option sets the path and name of the catalog database file
(DBIsamdatabase with no extension) created by LICCat.exe. This catalog can be
used for batch import of LIC files.
Example
[IMPORT]
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LASPATH=
RASTERPATH=
IHSLOGNDXROOTFOLDER= H:\LOGDATA
IHSLOGNDXDBFOLDER=H:\LOGDATA\IHS_ENERGY\Rock Mountains\database\
LICCATALOG=

[MAPTEXT]
The MapText section sets a message that’s printed at the bottom of every Petraproduced map. This can be useful for displaying a copyright or disclaimer.
TextHt – This option sets height of the text. Petra uses 0.065 inches by default, which
works out to be about a 5 point font.
Position – This sets the relative position of the text along the bottom of the map. This
option accepts “LEFT”, “CENTER”, or “RIGHT.” By default, Petra uses “CENTER.”
Line1 – This option sets the actual text. Note that you can actually set several lines
(e.g. Line1, Line2, Line3…)
Example
[MAPTEXT]
TEXTHT=.1
POSITION=LEFT
LINE1=Property of XYZ Energy
LINE2=Copyright 2011
LINE3=All Rights Reserved

[ENERDEQ]
The ENERDEQ section controls how Petra accesses the US part of IHS Direct
Connect. These parameters are usually only needed for intranet installs of the data
server or if your company has a proprietary version of the IHS database.
URL – This option sets the URL of the IHS Web Services server.
Example
[ENERDEQ]
url=https://webservices1-2.ihsenergy.com/WebServices

[IHSCAN]
The IHSCAN section controls how Petra accesses the Canadian part of IHS Direct
Connect. These parameters are usually only needed for intranet installs of the data
server or if your company has a proprietary version of the IHS databases.
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WELLSERVER – This option sets the URL of the Canadian IHS Web Services server.
WELLPORT – This option sets the port address of the Canadian IHS well data
server.
SERVER – This option sets the server address of the Canadian IHS well data server.
PORT –This option sets the port address of the Canadian IHS well data server.
HIST22 – Canadian well locations can have slightly different locations based on
different versions of the Alberta Township System (for example, ATS2.6 vs ATS2.2).
By default, Direct Connect uses the most up-to-date grid. This option instead
requests well locations (when available) based on the older AST2.2 grid.
For NAD27 projects, when HIST22=NO (or is blank) Petra downloads the most recent
well locations based on the ATS2.6 grid for Alberta, the BC2.0 grid for British
Columbia, the MLI07 grid for Manitoba, and the STS25 grid for Saskatchewan.
Setting HIST22=YES will force Petra to download historical well locations based on
the ATS2.2 grid.
For NAD83 projects, well locations are only available in BCTS20 for British Columbia,
MST0305 for Alberta, MTS10 for Manitoba and STS25 for Saskatchewan. Setting
HIST22=YES does not apply for projects in NAD83.
Note that the HIST22 setting will be reported at the top of all log files for Canadian
Direct Connect well data downloads.
Example
[IHSCAN]
;SERVER=petra.ihsenergy.com
;PORT=5557
;WELLSERVER=petra.ihsenergy.com
;WELLPORT=555
;CANADACHGDATE=YES

[WMS]
The WMS section creates a predefined list of WMS servers. Petra can store multiple
server names, usernames, passwords, and descriptions in different “groups.” Each
group is separated by a numerical suffix at the end of each option (shown as a “#” in
the descriptions below). Put another way, for each different WMS server url,
username, password, and description, put a different number at the end of the option.
These numerical suffixes don’t need to be consecutive, in order, or start at 1; they
just need to be different for different servers.
URL# - This option sets the URL address of the WMS server.
Description# - This option creates a description of the server. This description can
be up to 256 characters.
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User# - This option sets the username for the WMS server. Many servers don’t
require a username or password authentication. When working with these servers,
leave the user name and password blank.
Password# - This option sets the password for the specified username for the WMS
server. Many servers don’t require a username or password authentication. When
working with these servers leave the user name and password blank.
ConnectTimeout - This option sets a timeout in msec when connecting to WMS
service.
Example
[WMS]
url1= http://130.88.200.176/ecwp/ecw_wms.dll?
request=GetCapabilities&service=wms
user1=RFROST
password1=SFTY3RD
description1=Image Web Server
url2= http://198.96.62.209/wms/cascader?REQUEST=getCapabilities&service=wms
description2=Fusion
ConnectTimeout=5000

[DEFAULT]
The DEFAULT section sets company-wide settings to control Petra Map Module
default settings. It’s sometimes necessary to reset the Map Module
(Project>Settings>ResetModule on the menu bar at the top of the Main Module)
before these options take effect in existing projects.
Map_DirSurvEnable – This option sets the default for how directional wells are
displayed in the Map Module. Setting this option to “TRUE” turns on directional wells,
while “FALSE” turns off directional wells. Note that an individual user can always
change their specific setting with Wells>Directional Survey>Enable on the menu bar at
the top of the Map Module.
Map_OvlyAutoSaveMins – This option sets the default length of time in minutes
between when Petra automatically saves the overlay file.
Map_OvlyAutoSaveLvls – This option sets the total number of backup autosaved
overlays.
Map_GridDir – This option sets the pathway to a default grid folder.
Example
[DEFAULT]
MAP_DIRSURVENABLE=FALSE

© 2014

Installing & Configuring Petra

91

MAP_OVLYAUTOSAVEMINS=60
MAP_OVLYAUTOSAVELVLS=1
MAP_GRIDDIR=c:\geoplus1\datanewgrid

[HTTP]
The HTTP section allows an administrator to set company-wide settings for accessing
the internet. These parameters are not required to be entered.
ConnectTimeout – This option sets an optional timeout when connecting. The default
is 60,000 msec.
SendTimeout – This option sets an optional timeout when sending request. The
default is 30,000. msec.
ReceiveTimeout – This option sets an optional timeout when receiving response.
Default is 30,000 msec.
Example
[HTTP]
ConnectTimeout=120000
SendTimeout=60000
ReceiveTimeout=60000
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Petra Projects
Petra stores all the data relevant to a particular geographical area in a single project.
When sharing projects, all concurrent users of the project have immediate access to
all changes made by all other users. Some spreadsheet displays contain a local copy
of the data, so it may be necessary to refresh the spreadsheet to see the latest
changes.
For single user projects, the project and parameter data may reside entirely on your
local disk if so desired.

How Does Petra Store Data?
Petra is a set of tools designed to work with a central project database. Petra stores
project data in database tables and in external folders. Users sticking with the default
file locations should have few problems with file structure.
For a much more detailed explanation, see Project Data Architecture.

What Data does Petra Store?
Wells
After setting a map projection and the units of measurement, adding wells is generally
the first step to importing data into a project.
Every well in the Petra database has a different "Unique Well Identifier" (UWI). The
UWI is a 1 to 20 character identifier and is typically the API number of the well.
When a well is imported into the Petra database, it's automatically assigned a unique
"Well Sequence Number" (WSN). The WSN is simply the order in which the well was
brought into the database; the first well imported has a WSN of 1, and the 1051st well
in the database has a WSN of 1051.
Selecting Wells

Prospects
A prospect is a smaller subset of the wells in a project, and are useful for focusing on
a smaller area of interest. Changes made to the database while in prospect mode
will affect the wider project as a whole. This includes adding or deleting wells,
modifying logs, editing zone information, importing data, or map projection changes.

Zones
Petra defines a “zone” as a specific interval defined by a discrete top and a base.
Usually a zone’s top and base are defined by specific formation tops so that the zone
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covers a consistent lithostratigraphic unit. Inside each zone, Petra stores a “Data
Item” such as isopach, net pays, or log measurements that relate to that zone. Since
zones and their data items are shared across all wells in a project, this method of
organizing data makes storing and mapping single-value data for a specific formation
much easier. As an example, mapping all the isopach values for a specific formation
is much easier when the values are all stored in one common zone data item for each
well.
Using the Zone Tab
Zone Maintenance

Three zones defined by four formation tops

Intervals
Interval data stores data to a specific depth interval that doesn’t fit well with the
traditional zone concept, such as data that is too fine (such as core descriptions) or
too coarse (such as mud weights or biostratigraphic information) to fit inside two
formation tops. Petra stores interval data in tables and fields similar to a
spreadsheet.

Logs
Log curves come in two major types - digital and raster. Digital logs are the actual
values for the curves, while raster logs are simply the depth calibrated scanned
images of paper logs. These curves can be displayed on the Cross Section and log
calibration modules, as well as used in some calculations. Users can administrate and
modify these logs on the Main Module's Rasters Tab and Logs Tab.

Formation Tops
Petra stores formation top data with a combination of name, source, depths, quality,
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and time. Petra attempts to calculate the SS and TVD based on the active datum and
directional survey data.

Production Data
Petra stores monthly production streams from the selected well on the well list. The
raw data can be viewed and edited on the Main Module's Production Tab. The
Monthly Production Analysis Module analyzes a single well's production stream and
estimates EUR from a decline curve. The Production Group Plot Module analyzes
multiple wells' production streams. The group plot tool can sum multiple wells
together, average them, or time-normalize multiple wells to a single starting date.

IP and Fm Tests
Petra stores Initial Pressure or Formation Tests in the database, and are available on
the Main Module's IP Tests Tab and the FM Tests Tab.

3.1

File Architecture
Petra stores project data in a series of tables, external public folders, and private
folders.

Project Tables
Petra stores each project’s internal database files in a series of tables named for the
data type. This data includes wells, digital logs, and zone data.
Petra uses a dedicated Windows database server that mediates how every user
reads and writes to the database tables. In Shared Mode, Petra uses an external
database server. In Private Mode, however, Petra uses an internal database server
built into Petra’s Main Module.

A Shared Project (left) and a Private Mode project (right) containing database tables

Public Folders
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Each project has a single master folder called the “Project Folder.” This project folder
is always named after the project, and contains several folders including GRIDS,
IMAGES, OVERLAY, and PARMS. These folders are Petra's default storage
location for shared external files.

A Private Mode project folder

Private Folders
Private files are external files created by an individual user that customizes Petra’s
behavior and appearance. This includes *.MAP and *.CSP files, import templates,
color bars, and WSN lists.

A user's private folder

3.1.1

Project Tables
Petra stores each project’s internal database files in a series of tables named for the
data type. These project database files are stored in a single project folder that
reflects the name of the project. In the screenshot below, the Tutorial project has a
“TUTORIAL” folder that contains all the table files.
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As an example, well data for a v3 project is stored in the WELL.EDBIDX, WELL.
EDBBLB, and WELL.EDBDAT files. A table index file (*.EDBIDX) keeps track of
where data is stored in a table’s associated data (*.EDBDAT) file. The Binary Large
Object (*.EDBBLB) actually contains the data.

A project folder containing database EDBBLB, EDBIDX, and EDBDAT files.

Petra reads and writes to these tables with a dedicated project database server.
This database server also performs project repairs and maintenance, establishes
users and permissions (“roles”), and delivers user settings.
3.1.2

Project Public Folders
Public files are often shared between users and are a common part of a project.
Related public files share a single folder for a project; overlay files in a project, for
example, often share a single OVERLAY folder for that project.
For clarity of terminology, Petra (by default) stores public files (like grids and raster
logs) in a set of “public folders.” Each project has a single master folder called the
“Project Folder.” This project folder is always named after the project. The network
location of the project folder is the “public path.”
The Public Project folder takes the name of the project, and contains several folders
including GRIDS, IMAGES, OVERLAY, and PARMS. The GRIDS folder is the default
location of all contour grids created in the Map Module. The IMAGES folder is the
default location for raster images and their associated *.LIC files. The OVERLAY
folder is the default location for Map Module overlay files. Importantly, the GRIDS,
IMAGES, OVERLAY, and SHAPES folders are optional; it’s perfectly reasonable to
establish alternate locations for this data.
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A Private Mode project folder

In addition, Petra creates the REPORTS and SHAPES folders when a relevant task is
performed in the project. More specifically, Petra creates a SHAPES folder when a
user opens the Import Shapefiles tool in the Map Module. Petra creates the
REPORTS folder when a user creates a report, such as during a LAS import.
For projects migrated from earlier versions of Petra, the Project Public File directory
will remain the same. For new projects created in Petra v4, the default directory is in
the PROJECTS folder inside the Petra installation folder.
3.1.3

Project Private Folders
Private files are external files created by an individual user that customizes Petra’s
behavior and appearance. This includes *.MAP and *.CSP files, import templates,
color bars, and WSN lists.
For clarity of terminology, Petra (by default) stores an individual’s private files in a
“private folder.” The network location of a user’s private folder is the “private path.”
Each private folder should be separated both by user and by project. Petra creates
an individual private folder named by project, so it’s generally best to create a
separate directory for each user. This will generally look something like USERNAME/
PROJECT. The private folder acts as the default location for *.MAP and *.CSP files,
import templates, WSN lists, and other user-created files.
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A user's private folder

For projects migrated from earlier versions of Petra, the user’s private pathway will
remain the same. For new projects created in Petra v4, the default directory is in the
PROJECTS folder inside the Petra installation folder; for multi-user projects, changing
this path to a different location is usually a good idea.

3.2

User Broadcast Notice
The User Broadcast notice message can be useful for notifying all users of
maintenance outages, users group meetings, or for a “tip of the day.” The notification
will close on its own after a user-defined number of seconds, or a user can select the
“close” button at the base of the notify screen.
To create a notice, create a Rich Text File document with Microsoft Word or
Microsoft Wordpad, and save the file as “Notify.RTF.” Placing this file in the
installation subdirectory (by default PetraSRV) will display the notification for every
user using that installation. Placing the notification file in the root folder of a project
will only display the message to users opening that specific project. The notification
message can be displayed at any time by selecting Help>Show Notice Message on
the menu bar at the top of the Main Module.

A notice message
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Though most of the formatting like text size and color is controlled by the actual
document, Petra.INI has a few additional settings that change how the broadcast
notification works.
UBCWaitSec – This option sets the length of the notice in seconds. Users can close
the notice at any time with the “close” button on the bottom of the notice.
SoundFile – This option adds a sound file that plays whenever the notification opens.
Set the path and file name of the wave file, or just the name of the wave file if it’s in
the installation directory.

3.3

NotifyKill
The Kill Notice forcibly closes Petra for all users, which is sometimes necessary for
project table maintenance. To create a notice, create a Rich Text File document with
Microsoft Word or Microsoft Wordpad, and save the file as “KillNotify.RTF.” Placing
this file in the installation subdirectory (by default PetraSRV) will shut down Petra for
every user on that installation. Placing the notification file in the root folder of a
project will shut down Petra users in that particular project. Petra will also refuse to
run (as shown on the example below on the right) while notifykill.RFT remains in the
project or installation folder. Note that Petra comes with a copy of XNOTIFYKILL.
RTF in the installation directory – removing the “X” from the beginning of the file name
enables the kill notice.

Figure 1: The default “kill notice” screen (left), and Petra refusing to run while
KillNotify.RTF is in the directory (right)

Though most of the formatting like text size and color is controlled by the actual
document, Petra.INI has a few additional settings that change how the kill notification
works.
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KillWaitSec – This option sets the number of seconds the kill notice will display before
closing Petra.

KillSound1 – This option sets the filename and pathway of the sound file that plays
when the notice first appears.

KillSound2 – This option sets the filename and pathway of the sound file that plays
once per second while the kill notice is counting down.

KillSound3 – This option sets the filename and pathway of the sound file that plays
when the kill notice closes and forcibly shuts down Petra.
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Main Module
Organized into a list of wells on the left and a series of tabs on the right, each tab
section displays details of a specific data type for the well. Clicking on different wells
in the well list provides the details in the tab sections. Any data in the tabbed sections
may modified by simply typing over the data. Each tab contains a "save" button which
must be clicked to change the data in the database. Petra will automatically prompt
you to save the data if you change data then click to a another well. Unlike other
modules, the Main Module is always open.

Petra's Main Module

Getting Started
Setting a Map Projection
Importing Data
Exporting Data
Selecting Wells
Using the Main Module Tabs
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Using the Main Module Toolbar

Opening Other Petra Modules
Map Module
Cross Section Module
Spreadsheet Module
Log Cross Plot Module
Z Cross Plot Module
Histogram Module
Monthly Production Analysis Module
Production Group Plot Module
Thematic Mapper Module
3D Visualizer Module
Slip Logs Module
Log Correlation Module
Directional Well Module

Advanced Tools
System Settings
Compute Functions
Advanced Volumetrics (Deterministic & Monte Carlo)

4.1

System Settings
Petra Program Options
System Colors
Reset Module
Tab Colors
Password Protect Project
User Source Code
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PETRA Program Options

Petra's Program Options control many of the details on how Petra runs. Note that
changing these aspects can change how all users interact with Petra.
To open the Program Options screen, select Project>Settings>Program Options on
the menu bar at the top of the Main Module, or select CTRL + O while the Main
Module is selected.

Petra Program Options

General Tab - This tab controls many of the details on how Petra runs.
Font/Graphics Tab - This tab controls how Petra displays text and "transparent"
colors.
Well List Synchronization Tab - This tab controls how Petra synchronizes wells
between different modules.
Files Tab - This tab controls how Petra interacts with external text and image files.
Locks Tab - This tab locks well data, locations, and the project map projection.
UWI Search Tab - This tab controls which characters Petra ignores when searching
for UWIs.
DBI Tab - This tab controls the amount of memory allocated to each module.
Public Tab - This tab controls how Petra works with multiple users.
4.1.1.1

General Tab

The General Tab changes a variety of settings for Petra as a whole. To open the
Program Options tool, select Project>Settings>Program Options on the menu bar at
the top of the Main Module. Alternatively, select CTRL + O when the Main Module is
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active.

The General Tab

Hide Start up Welcome Screen - This option hides the Welcome screen which allows
you to open the previously accessed project, open an existing project, or create a
new project. Instead, Petra will display the main screen in the closed project state.
To open a project or create a project, use the menus or speed buttons.
Hide Plot Date Time Stamp - By default, Petra plots a small label in the lower left
corner of all printed graphics showing the date and time the output was produced.
Use this option to enable or disable the date-time label.
Use Formation Top Aliases with Zone Definitions - This option determines whether or
not to apply top aliases when converting a zone interval to depths.
Remember Previous Directory Path For Import/Export - With this option selected,
Petra will remember the location of the last file imported or exported, and use that
pathway when the import or export dialog reopens.
International Project Area (Non-US) - With this option set, the main well and location
tabs will not show US state-county and location buttons.
Remember Previous Screen Positions - This option keeps dialog screens stay in the
previous location on the screen after moving them. This is particularly useful with dual
monitors.
Disable Well Symbol Translation During Import - The "SymTrans.DEF" file is used to
translate well symbol codes during data import. For example, a PI symbol code of
2GAS will be translated to simply GAS in the data base. Use this option to disable
such translation.
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Fast Well Deletions - When this option is deselected, Petra removes all records in all
database tables associated with the deleted well. Slow well deletions free up unused
space, but can take a long time to complete. The Fast Well Deletions option, on the
other hand, removes the reference to the deleted well (so it appears to be deleted),
but does not actually remove the records in the database so the database continues
to use the same amount of space on a hard drive.
Track Main Module Well Selection On Map - This option highlights the well selected in
the main module on the Map Module. This feature works best with dual monitor setup
where you have the main on one screen and the map on another.
Do Not Use "Blocks" for DXF Symbol Output - Check this option if you are creating
DXF files from a map or cross-section and the application that will read the DXF file
cannot handle DXF "blocks" generated for well symbols.
Force DB Buffer Refresh - This option disables the caching or buffering of database
table updates. Importing data can be slowing with this option enabled.
Enable Zone Item Aliases - Zone data item aliases are enabled when this option is
checked. Zone item aliases perform like formation top aliases, allowing multiple
sources of equivalent zone items to be searched based on a prioritized listed.
Disable Use of Logging File (PetraLog.txt) - Check this option to suppress writing
logging messages to the project's log file. Examples of logging messages are when
wells are deleted or when the map projection changes.
Use Public Parms Folder for Template Files - This option can be used to control the
default folder used when saving/loading various template files. Either the Private or
Public Parms folder will be used.
Suppress Save Prompt In Main - Check this option to suppress the prompt you
receive when changing between wells or tabs after changing data. Changes are saved
automatically.
Use Buttons on Main Tab - With this option checked, the main screen will display the
data "tabs" with a button style instead of the normal tabs. With buttons, it is
sometimes easier to see which tab you're on.
Disable Use of Logging File - By default, PetraLog.TXT stores a comprehensive log
file of changes made in the project. This list includes map projection changes, well
and seismic line deletions, and loading or saving overlays. This option disables this
log.
Display Lat-Lon and XY with Extended Precision - With this option enabled, the Main
Module will show LatLon and XY values with more more decimal places on the
Location Tab.
Substitute TD for Missing Zone Base Values - This option forces Petra to use the total
depth (TD) as a substitute for missing zone base values. This can have a significant
effect on calculations that use zone boundaries, including isopach and log calculations.

© 2014

108

PETRA Help

Always Start with All Wells Selected in Main and Map - By default, the Main and Map
Modules open with the same set of wells selected when the module was closed.
With this option selected, the Map Module and Main Module will start up with all wells
in the project selected.
Disable 10-12-14 Digit API Matching (Exact UWI Match Enforced) - During imports,
Petra normally attempts to match 10, 12, and 14 digit API numbers from the input file
with a 10, 12, or 14 digit well currently stored in the database. This will deactivate
they checking and require imported wells to match the UWI exactly.
Include Quality Code for Tops and Zone Items "Active Only" Mode - This is a display
feature for the Main module's Tops and Zones tab.
Allow Data Import While In Prospect Mode - This option allows Petra to import data
while a prospect is selected, rather than the full set of wells in the project.
Disable Open/Save Dialog "Favorites" Buttons - When importing data, the Windows
"open dialog" screen is used. Petra modifies this dialog to add "favorite" buttons that
allow you to quickly access the Desktop folder, the last used import folder, the Petra
project folder, and the project's PARMS folder. You should disable (Check this item)
this feature if your PC configuration causes a "place0 error"
Skip Petra Update During Startup - By default, Petra notifies users of available
updates. This option disables this notification.

Lat-Lon Displayed As
This option changes how latitude and longitude values are displayed. "Decimal
Degrees" will display as 25.00325, -95.34054, etc. "Deg-Min-Sec" displays as
25:00:11.7 and -95:20:25.95. Note that users can enter LaLlon values by typing in
either format.

Dates Displayed As
This option changes how dates are displayed. Dates can be displayed as MM/DD/
YYYY or DD/MM/YYYY
4.1.1.2

Font/Graphics Tab

The Font/Graphics Tab changes how Petra displays default text and lines. To open
the Program Options tool, select Project>Settings>Program Options on the menu bar
at the top of the Main Module. Alternatively, select CTRL + O when the Main Module
is active.
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The Font/Graphics Tab

Default Font - This dropdown sets the default font for plotted text.
Print WHITE Text As - Normally, white text on the screen is plotted as black when
printed. This option causes the white text to remain white when printed. Use this
option when you need white text to appear on top of images.
Generate Black & White Plots Only - This option overrides all color plotting to the
printer so that all colors are converted to black.
Transparent Color Fill Optimizer - This option controls how transparent color fill on top
of raster log images is handled by plotter drivers. Some plotter drivers cannot
transparent fill directly, so Petra has alternative methods to generate the fill. The "
Direct Fill" method should be used whenever possible. If problems arise in crosssection raster log pay intervals or tops shading, first try the "Indirect Fill" method, and
if that does not work, use the "Disabled" method. When the optimizer is disabled, plot
files will become significantly larger.
Graphics Character Set - This dropdown sets whether Petra uses an English or
Russian character set.
User Pen Sizes - These entry boxes set the line thickness for user pen sizes. These
pen sizes appear in the Map and Cross Section overlays.
4.1.1.3

Well List Synchronization Tab

The Well List Synchronization Tab controls how different modules share selected
wells. To open the Program Options tool, select Project>Settings>Program Options
on the menu bar at the top of the Main Module. Alternatively, select CTRL + O when
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the Main Module is active.

The Well List Synchronization Tab

By default, Petra's different modules can work with different subsets of wells in the
project. As an example, the Main Module can have all wells selected, the Map
Module can have only the wells below a certain depth selected, and the Cross Section
Module can have only a handful of wells along a dip line selected. This tab
establishes how different modules "send" and "receive" their list of selected wells.
Modules with a check in the "send" column will broadcast its list of selected wells to
modules with a check in the "recieve" column. Note that wells with both "send" and
"receive" selected will broadcast well lists to other modules, but will not change their
own selected wells when other modules change.
4.1.1.4

Files Tab

The Files Tab controls how Petra opens text files and saves image files (like raster
logs). To open the Program Options tool, select Project>Settings>Program Options
on the menu bar at the top of the Main Module. Alternatively, select CTRL + O when
the Main Module is active.
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The Files Tab

System Text Editor Name - This sets the executable file name of the text editor used
by Petra to view or edit various text files and reports. Typical choices here are
Notepad.EXE or Write.EXE.
Image Files - When the "Store Image Files With Full Path Name" option is selected,
Petra stores a full path and along with the image name. In contrast, when the "Store
Image Files As File Name Only and Use Search Path(s) Below" option is selected,
Petra will store only the file name in the database and resolve the full name using the
search path. The advantage to using a search path is that projects may be moved to
a different drive and still find the images.
Alternate Path For LIC Files - When the the "Store Image Files As File Name Only
and Use Search Path(s) Below" option is selected, Petra will automatically look for
LIC files in this same directory. This entry sets an alternate path for LIC files.
Image File Drive Mapping - This option performs completely replaces image location
drive letters. This can be useful when moving a project to a different network or when
standardizing drive mapping between two different workstations.
4.1.1.5

Locks Tab

The Locks Tab helps prevent changes to well data, locations, and the project map
projection. To open the Program Options tool, select Project>Settings>Program
Options on the menu bar at the top of the Main Module. Alternatively, select CTRL +
O when the Main Module is active.
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The Well List Synchronization Tab

Enable Well Data Field Locking - When this option is selected, users can lock specific
well data fields. Locked data items cannot be changed until they are unlocked. To
lock a zone data item, select the zone or zones and right click to select lock/unlock for
this well/all wells. Alternatively, locking also responds to keyboard commands.
CTRL + L - Lock item for this well
CTRL +U - Unlock item for this well
ALT + L - Lock item for all wells
ALT + U - Unlock item for all wells
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A "locked" TD field in red.

Enable Digital Log Locking - When this option is selected, users can lock specific
digital logs. Locked data items cannot be changed until they are unlocked. To lock a
digital log item, select the log or logs and right click to select lock/unlock for this well/
all wells. Alternatively, locking also responds to keyboard commands.
CTRL + L - Lock log for this well
CTRL +U - Unlock log for this well
ALT + L - Lock log for all wells
ALT + U - Unlock log for all wells
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A "locked" GR log in red.

Well Location Locking
Well locations can be locked for all wells or for individual wells. Once a well's location
is locked, it can not be changed, either by import or manual edit until the location is
unlocked.
Automatically Lock Location After Manually Modified - This option automatically locks
a well's location after it has been manually edited. This prevents later well location
changes due to importing data later.
Lock All Locations - This option locks all well locations in the project.
Unlock All Locations - This option unlocks well locations. The unlock function will
prompt you whether you to unlock all wells or only those wells that were not
individually locked. Here, selecting "Yes" will unlock all wells, including wells that were
locked with the global "Lock All Locations" button and wells that were manually
locked. Selecting "No" will only unlock wells that were locked with the the global
"Lock All Locations" button; wells that were manually locked will remain locked.

Unlocking all locations ("Yes") or only the wells not locked individually ("No")
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Lock Map Projection
This option locks the the project's map projection. This prevents a user accidentally
changing the projection with the Map Projection Settings tool or by importing a
importing a Petra Project File (*.PPF).
4.1.1.6

UWI Search Tab

This screen changes how Petra imports and sorts wells by UWI. To open the
Program Options tool, select Project>Settings>Program Options on the menu bar at
the top of the Main Module. Alternatively, select CTRL + O when the Main Module is
active.

The UWI Search Tab

Remove Special Characters from Imported UWIs to Match with DB UWIs - This
option sets special characters that should be removed from UWI values. These
values are removed during import.
Sort UWI Values As - This option changes how Petra sorts UWIs.
"Numeric" Sort: 1, 10, 11, 12, 2, 3, 4, 5, 6 7, 8, 9
"Alphanumeric" Sort: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
4.1.1.7

DBI Tab

The DBI Tab controls how Petra uses the available system memory. To open the
Program Options tool, select Project>Settings>Program Options on the menu bar at
the top of the Main Module. Alternatively, select CTRL + O when the Main Module is
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active.

The DBI Tab

DBI DataBase Client Cache Optimization - This option sets the the amount of memory
used by the DBI database engine for local (client-side) caching. The default value
(minimum setting) is usually sufficient. Be careful not to exceed your systems memory
capabilities. Over commitment of memory to the database cache could result in
extensive user of the system virtual memory, ie, swap file or create "out-of-memory"
errors during data import.
Do Not Cache Table Buffers on Client - This option improves performance only on
very old hardware. Any personal computer built after 1990 will run much better
without this option checked.
4.1.1.8

Public Tab

The Public Tab controls how Petra works in a multi-user environment. These options
will affect all users of a project. To open the Program Options tool, select
Project>Settings>Program Options on the menu bar at the top of the Main Module.
Alternatively, select CTRL + O when the Main Module is active.
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The Well List Synchronization Tab

Disable Overlay "File In Use" Feature - The overlay file-in-use feature is an overlay file
sharing notification mechanism. Activate the overlay file-in-use feature when you want
all users in a project to be notified if they load an overlay file that another user has
already loaded. When this feature is in effect, the first user that opens a particular
overlay file is considered to be the "owner" of the file. The owner is the only user that
can modify that overlay file, that is, there are the only user that can overwrite that file.
All other users in the project will be prevented from overwriting the overlay file. They
can, however, save their changes using a different overlay file name. Changes by nonowners are only allowed if the actual owner closes the file or exits Petra without
updating the overlay file.
Force Use of UPPERCASE Text for Database Items - This option forces zone
database items to all use uppercase text.
Disable Map Projection Convergence Angle Correction to Directional Survey Data This option disables the convergence angle correction for directional wells. When this
option is selected, Petra assumes all directional surveys are oriented to GRID
NORTH
Save New Raster Log "LIC" Files to Same Folder as Raster Image - Normally, Petra
users can save a raster's *.LIC file to any location on a network. This option forces
LIC files into the same location as the raster image.
Always Prompt for External File Lat-Lon Datum during Import/Export - When this
option is selected, Petra will always require the user to enter the external file's
reference datum during import. This can help prevent data from accidentally being
loaded with a different reference datum.
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Add New Well Limiter Feature - This global or public parameter can be used to
restrict or limit the maximum number of wells that can be added to a project during a
"session" by a user. (note - each time you open a project you are in a new session).
For example, if you activate this option and set the limit to 3 new wells, then you can
add 3 new wells but when you try to add the 4th new well, a warning message
appears and no more wells will be added. If you close and re-open the project, i.e., a
new session, you will be able to add 3 more new wells. When you set or change this
option, you must close and re-open the project before the changes will take effect.
Use this feature with caution as you might wonder why you are unable to add wells to
your project. This option could be used to prevent accidentally adding 1000's of wells
during an import process when you really only wanted to update wells.
Save System Map Projection - This option saves the current map projection as a
default for all future projects created on the installation.
4.1.2

System Colors

The System Color and Style Definitions window sets the color, line thickness, and
line style for "Picture Elements" in different Petra modules. These Picture Elements
include graph lines, titles, borders, and grids.
To open the System Color and Style Definitions window, select
Project>Settings>System Colors on the menu bar at the top of the Main Module.

The System Color and Style Definitions Window
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To change a Picture Element, select the specific line and select a screen color,
plotter color, thickness, and style.
Picture Element List - Petra's Picture elements are grouped by module. As an
example, map elements are listed seperately from cross-section elements. Choose
the picture element to customize by clicking on the Picture Element list box.
Screen Color - Change the element's screen color by clicking on one of the screen
palette color cells.
Plotter Color - Change the element's plotter color by clicking on one of the plotter
palette color cells.
Line Thickness - Choose the element's line thickness from "narrow", "normal", "wide"
or "extra wide".
Line Style - Choose the element's line style of "solid", "long dashes", "short dashes",
"dot-dashed", "dotted" or "alternating" (every other pixel).
4.1.3

Well Symbols

The Well Symbols window changes how Petra interprets and displays the codes
already assigned to the wells.
This changes how every symbol code in the project appears on the Main and Map
Modules. Note that this window does not change an individual well's symbol - to
change an individual well's symbol see the Main Module's Wells Tab.
A well symbol code is a 1 to 8 character value that encodes the general type of well.
In the screenshot below, gas wells have a well symbol code of "GAS." Petra uses
a set of "well descriptions" to assign well symbols and colors to different kinds of
wells on the Main and Map Module. In the screenshot below, Petra uses a "GAS"
description to draw a red gas well symbol.
To open the Well Symbols window, select Project>Settings>Well Symbols on the
menu bar at the top of the Main Module.
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The Well Symbols window

Current Well Description List - This list shows all the well descriptions currently in use
in the project.
Symbol Code - This box displays the currently selected well description's symbol
code.
Scale Factor - This box sets a scale factor for well symbols on the Map Module.
This option can range from 0 to 10, where 1 is a normally sized well symbol.
Description - This entry creates a brief description of the well symbol.
Available Symbols - This list displays the available well symbols. There are 315
available symbols.
Screen Color Selection - This option sets the display of the symbol on the screen.
Plotter Color Selection - This option sets the display of the symbol on the screen.
Restore - This button reload the screen with the last saved well symbol descriptions.
Save - This button saves the well descriptions to an external file.
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Load - This button loads an external well descriptions file into the project.
New Description - This button adds a "new symbol" well description at the bottom of
the Current Well Description List.
Drop Description - This button deletes the currently selected well description.

Modifying an Existing Well Symbol
To modify the well symbol descriptions, select the desired well symbols under the
"Current Well Descriptions" list box. The symbol code, description and symbol icon
are shown in the "Symbol Definition" on the right. Here, change the description, code,
scale factor, symbol, or colors. Click the APPLY button to replace the current
symbol description with the new values.

Adding New Well Symbols
To add a new well symbol description, click the New Description button to add a new
row to the current description list entitled "new symbol." Next, on the "Symbol
Definition" part of the screen, change the description, code, scale factor, symbol, or
colors. Click the APPLY button to replace the current symbol description with the
new values.

Deleting Well Symbols
Select the desired well symbol, and select the "Drop Description" button.
4.1.4

Reset Module
The Reset Module completely resets one or more Petra modules. This can be useful
for troubleshooting.
To open the Reset Module, select Project>Settings>Reset Module on the menu bar at
the top of the Main Module
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The Reset Module window

Resetting a module completely removes any user settings. If possible, it's a good
idea to attempt to save any user-created settings in an external template file (such as
*.MAP or *.CSP files).
To reset a module, select the desired module or modules and select the "Reset
Modules" button on the right of the screen.
4.1.5

Tab Colors
The Tab Colors window changes the Main Module's Tabs from a default grey to a
user-selected palate.
To open the Tab Colors window, select Project>Settings>Set Tab Colors on the menu
bar at the top of the Main Module
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The Tab Colors window (Left) and the Main Module with active tab colors (Right)

The Tab Colors window lists the Main Module's tabs in a list. Note that this tool
automatically opens with a default color scheme.
Clear Current - This button removes the current color from the currently selected tab,
and returns it to grey.
Clear All - This button removes the current color scheme from all tabs, and returns
them to grey.
System Defaults - This button resets the tabs to the default rainbow color scheme.
Load Template - This button loads an external tab color file.
Save Template - This button saves the current color scheme to an external tab color
file.
Interp. Missing - This button interpolates tab colors between the top and bottom color.
Note that this tool will not interpolate between a selected color and the default grey.
To change a color, first select and double-click the desired tab to open a color
selection window. Here, select the desired color either from the basic colors on the
left, or the extended colors on the right. Select "OK" to change the color and return to
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the Tab Color window. Again, select "OK" on the Tab Colors window to save the
changes.

Selecting a color for a tab

4.1.6

Password Protect Project
The Password Protect Project window adds a password to a project. Users cannot
open the project without the password.
To open the Tab Colors window, select Project>Settings>Password Protect Project
on the menu bar at the top of the Main Module.

The Petra Project Password window

Adding a Password - To add a new password, simply enter the new password into
both the "New Password" and "Confirm Password" entry boxes. Finally, select the
"OK" button.
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Adding a new password

Changing a Password - To change an existing add a new password, first select the
"Add or Change Project Password" option. Next, enter the new password into both
the "New Password" and "Confirm Password" entry boxes. Next, enter the old
password into the "Current Password" entry box. Finally, select the "OK" button.

Changing an existing password

Removing a Password - To remove an existing password, first select the "Remove
Project Password" option. Next, enter the old password into the "Current Password"
entry box. Finally, select the "OK" button.

Removing a password
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User Source Code
User source codes identify the user to the application. This can either control user
permissions (if enabled in Petra.INI) or just create default source codes for new
formation tops (default setting).
To change user names while inside a project, select Project>Settings>Set User
Source Code… and enter the appropriate user name.

Changing user source codes in Petra

Enabled in Petra.INI
Enabling user source codes separates individuals into two classes: administrators
and regular users. Only administrators can delete wells, change the reference datum
or coordinate system, globally delete data, or modify any tops other than their own.
Petra Database Server usernames override user source code privileges.

Not Enabled in Petra.INI
By default, all users are treated equally and can delete or change all data and change
map projections. User source codes only serve as a default source for new tops.

4.2

Importing Data
Petra projects can import a wide variety of different kinds of data from a variety of
formats.

Common Import Options
Selected Wells vs. All Wells
Fm Substitution Files
Elevation Translation Codes
Add New Wells and/or Update Existing wells
Locking and Unlocking Data Fields
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Protecting Data Fields

Working with Different Map Projections
Importing LatLon Data
Importing XY Data

Well Data
297 "Flat" File
IHS Direct Connect (US and Canada)
IHS Direct Connect (International)
Landmark Standard 29 Files
Generic ASCII Data

Production Data
298 File
IHS Direct Connect Production Data
Generic ASCII Data

Digital Logs
LAS
Batch LAS
LIS
Generic ASCII Data

Raster Logs
IHS Direct Connect
Uncalibrated TIF files

Interval Data
Tabular Data

Map Data
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Legacy Overlay Data
ASCII Overlay Data
ESRI Shape Files
Batch Overlay Import
WMS Data
4.2.1

Common Import Options
There are a few importing options that are common to different importing methods.
These tools are designed to better import imperfect datasets and to manage how
Petra treats overlaps between the database and the imported file.
Selected Wells vs. All Wells - Petra generally only updates the wells selected in the
Main Module. Before importing anything, make sure you know which wells are
selected.
Formation Substation Files - A formation substitution file converts formation top names
in the data file to a user-set name.
Elevation Code Translation Files - An elevation code translation file converts nonstandard elevation codes to standard elevation codes that Petra can read.
“Add New Wells” and “Update Existing Wells” - “Add New Wells” creates new wells
when the imported data has a UWI/API code that is not in the Petra database.
“Update Existing Wells” overwrites the project database with the imported data.
Locking and Unlocking Data Fields - Petra can selectively “lock” data items and fm
tops. Data inside locked fields cannot be changed at all, including by manually
overwriting the field, performing a calculation, or with importing new values.
Protecting Data Fields - Petra can selectively “protect” data items and fm tops. New
data will not overwrite a protected field during import. In contrast to a “locked” field,
“protected fields” can be overwritten by manually typing in new values or through
calculations.

4.2.1.1

Selected Wells vs. All Wells

Petra can work with any user-selected subset of wells at a time. Petra modules are
independent and can each work with entirely different sets of wells.
It’s possible for the Main Module to select every well in the project, the Map Module
to select only wells of a certain depth or greater, and the Cross Section Module to
work with only a few wells along a dip line.
When importing some kinds of data, it’s important to be aware of the wells that are
currently selected in the module you’re using.

© 2014

130

4.2.1.2

PETRA Help

FM Substitution Files

Commercial data sources and different interpreters can use a variety of different
names for the same formation. For simplicity, it’s sometimes useful to translate one
or more formation names into a single, preferred name during import. A "formation
substitution" file lists the preferred formation name followed by variations of that
name. As an example, listing DSAND with the variant 602DKOTD will change all
602DKOTD to DSAND. Importantly, any name not translated by the
substitution file will remain as is. Some importers can use the substitution
filter as a filter; formation tops not on the substitution file are skipped.
Substitution files are a simple text ASCII file, and can be created with a text editor
like Notepad or Wordpad. The file consists of a list of preferred names followed by
the variants of that name. Every line has a prefix of “1” or “2”, where "1" represents
the preferred name and “2” represents the variants.
1AAQP
200002
13675 SAND
20003675S
1ALMA & CROMWELL
2000AACL
1ANHYDRITE
2000ANDR
1ANHYDRITE 1
2000ANDR1
1ANHYDRITE STRINGER
2000ANDRS
A fm substitution file using IHS formation translations

Substitution files can also use the wildcard characters "*" and "?" to look for multiple
variations of a name. Similar to DOS and Windows, the “*” can stand in for any
number of characters, while the “?” can only stand in for one character. As an
example, “ABC*” will translate any name that begins with ABC to the preferred
name, while “ABC?” will translate only 4-letter names starting with ABC.
1COTTON VALLEY
2BOSSIER
2C V*
2COTTON VALLEY*
1JACKSON
2CADDELL
2EOCENE
1WILCOX
2CARRIZO
2WILCOX*
1CLAIBORNE
2COCKFIELD
2QUEEN CITY
2SPARTA*
2YEGUA
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A fm substitution file with wildcards

4.2.1.3

Elevation Translation Codes

The datum of a well can be important for accurately estimating subsea depths. There
are a few standard codes for the different elevation measurements, such as “KB” for
Kelly bushing, “DF” for derrick floor, “GR” for ground, and SEIS for the seismic datum.
Petra can correct for non-standard elevation codes during import with an elevation
code translation file. An elevation code translation file lists the standard elevation
codes followed by the non-standard variations reflecting the same actual elevation.
As an example, listing GR with the variant GL will change all GL to GR – thus
importing the datum value correctly into Petra. Importantly, any name not translated
by the substitution file will remain as is, and won’t necessarily be recognized by Petra
as a reference datum.
Substitution files are a simple text ASCII file, and can be created with a text editor like
Notepad or Wordpad. The file consists of a list of preferred names followed by the
variants of that name. Every line has a prefix of “1” or “2”, where "1" represents the
preferred name and “2” represents the variants.
1KB
2KB
1DF
2DF
2RF
2RT
2RB
1GR
2GR
2GL
2CF
1SEIS
2ES
An elevation code translation file

4.2.1.4

Add New Wells/Update Existing Wells

There are a couple of options on how Petra handles overlaps between the imported
data and the existing database. The “Add New Wells” option tells Petra to create
new wells where there’s no match between the UWI/API in the imported data and the
database. When this option is deselected, Petra will not create new wells during
import.
The “Update Existing Wells” option tells Petra to overwrite the database with the
imported data. When this option is deselected, Petra will not overwrite the database
with the imported information, including null values.
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Locking and Unlocking Data Fields

Before importing new data, it’s sometimes useful to selectively lock down data items
and formation tops. Locked data items and tops are highlighted in red, and will not
change until they are unlocked.
To lock a single data item or fm top, go to the Zones Tab or FmTops Tab on the Main
Module. Here, right-click the desired data item or top. The bottom of this pop-up
menu gives the option to lock or unlock the selected item or top for either the single
well or for all selected wells. The “selected wells” option will only work on the wells
selected in the main module, and not for all wells in the entire project.
Note that there are keyboard shortcuts for all these operations as well:
Ctrl + L - Lock Item for This Well
Ctrl + U - Unlock Item for This Well
Alt + L - Lock Item for Selected Wells
Alt + U - Unlock Item for Selected Wells

A locked KB elevation field

4.2.1.6

Protecting Data Fields

“Protecting” data fields is a good way to preserve the existing values in a project
database during an import. In contrast to “locked” fields that don’t change for any
reason, protected fields only resist being overwritten while importing data. It’s still
possible to change these values by manually overwriting values or by performing a
calculation.
To protect data fields, select Project>Import>Protect Data Fields from the menu bar
at the top of the Main Module. This screen provides a list of standard well header
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information including well name and number. To add tops or other zone data items
select the “Choose Items” button on the right side of the screen.
In this menu, select the relevant zone and data item and select the “>” button to add it
to the “Selected Zone Items” list on the right side of the screen.

Protecting Data Fields

4.2.2

Working With Different Map Projections
Importing data with a different LatLon reference datum
Importing data with a different XY coordinate system

4.2.2.1

Import New LatLon-Based Data

It’s fairly common that new data will use a different map projection than existing
project.
Fortunately, most oil and gas data are based on latitude and longitude. When
importing LatLon-based data, it only matters that the reference datums match. As a
reminder, Petra uses the project’s coordinate system to automatically calculate XY
values.
If these reference datums don’t match, it’s necessary to select the reference datum
of the new data. With the new data’s reference datum selected, Petra can account
for and automatically recalculate the imported data’s latitude and longitude to match
the project’s reference datum. To set the import data’s reference datum, select
Project>Settings>Set Datum Shift for Importing Data … Here, select the reference
datum for the incoming data.
In the example below, the incoming well data’s Lat-Lons are based on the NAD27
reference datum, while the project is based on the NAD83 datum.
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Importing NAD27 data into a NAD83 project

4.2.2.2

Import New XY-Based Data

As mentioned earlier, XY data has already gone through both steps of the projection
process. In other words, the location is calculated to a reference datum-dependent
LatLon and then to a coordinate system-dependent XY. Without latitude and
longitude, Petra can’t use the project’s coordinate system to recalculate correct XY
values. Therefore, when importing pure XY data, it’s important to make sure both
the reference datums and coordinate systems match.
Petra can recalculate the XYs of data inside a project including well locations, and
overlays. Instead of changing an entire project to the data’s projection only to import
the new XY data and change the entire project back to the old projection, a less
risky way is to create a new, temporary project in the new data’s projection.
First, create a new project using the new data’s map projection. This project
doesn’t need to include any of the old data from the old working project. Next,
import the new data into that temporary project. Petra now has the data and can
calculate LatLons from the XYs. Next, change the temporary project’s projection to
be compatible with your full project, making sure to recalculate the locations. Finally
export the data out of the temporary project. This leaves the new data in a usable
projection. Finally, import the newly-reprojected data into the full project.
4.2.3

Import IHS Well Data (297 File)
The 297 file is one of the most common well data formats. The 297 file is an updated
version of the legacy PI 197 Well Export format. Generally, these files are exported
from an IHS CD-ROM or database.
297 files contain a comprehensive set of well information, including well header
information and locations. 297 files also include IHS formation tops. These tops use
formation codes that combine a numerical code for the formation’s age and an
abbreviation of the formation name (see the appendix for more information). As a rule
of thumb, older (and usually stratigraphically lower) formations have larger numerical
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prefixes. As an example, 602TMPL is above 604SNNN. Petra stores this information
in an internal project database.
To import a 297 File, select Project>Import>IHS 297 Well Data (Fixed or Comma)…
on the menu bar at the top of the Main Module.
File Tab
Options Tab
IHS Source Codes Tab
FM Substitute Tab
IHS Tab
Misc Tab
Elev Trans Tab
Dir Survey Tab
4.2.3.1

297 File Tab

The 297 importer File Tab sets the basic parameters on the data loaded into the
project database.

The 297 file import File Tab

To open a file, select the “Browse” button and navigate to the desired file.
Scan File For Tops – This option examines the file for formation tops. Scanning tops
creates the FM Tops Tab, where the tops in the file appear.
Display Report Showing Imported Wells – This option generates a text file showing
the results of the import.
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297 Options Tab

The 297 importer Options Tab sets the basic parameters on the data is loaded into
the project’s database.

The 297 file import File Tab

Well Options – These boxes govern whether the importer adds new wells, or updates
selected wells already in the project database.
Data To Load - These options set which data is imported. The available data
includes:
General Well Header Data
Locations
Directional Survey
Datum Elevation
Gross Perfs from IPTests
Deptailed Perfs
Production Tests (IPs)
Formation Tests (DSTs)
Cored Intervals
Formation Tops
Cored Intervals
Ignore Source Codes – IHS formation tops are coded by their origin: 1 for driller
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tops, 2 for sample tops, 3 for log tops, and 4 for tops that have been modified by IHS.
As such, the same top name can occur a few different times with different sources.
This option only brings in a single copy of the top – generally the import will bring in
the highest source code with the highest quality.
Lat Lon Source – Particularly in Texas, IHS locations sometimes have a source code
that reflects the origin of the latitude and longitude. This option loads location source
data into the “Misc Location Information” field on the Main Module’s Location Tab.
All Other Data – IHS data has a catch-all field containing a variety of miscellaneous
information. This option loads location source data into the “Misc Location
Information” field on the Main Module’s Location Tab.
Put Lease in Well Name – This option adds the lease name as a suffix to the well
name.
Update Historical Operator – This option updates operator information. More
specifically, this option copies the operator to a null historical operator entry whenever
the operator changes.
Use Alt ID for UWI – IHS generates AltIDs for wells without a UWI number. This
option tells Petra to use the AltID when the regular UWI is missing, and is on by
default. Deselecting this option will prevent Petra from loading wells without UWIs
into the project.
Copy IPTests as Gross Perfs – This option copies the top and base of IP tests as a
perf interval. This can create very large “gross” perf intervals in the imported wells.
Copy Detailed Perfs From Treatments – This option copies the top and base of each
treatment as a perf interval. This can create a large number of small perfed intervals
in the well.
Load N.E. Locations – This option loads the NorthEast locations. This data is
available on the “US N.E. Loc” button on the Main Module’s Location Tab.
Compute LatLon from NE Ref Loc – This option uses the NorthEast location to
recalculate the well’s LatLon.
Update Blank Header Fields Only – By default, importing a 297 file overwrites all
header fields. This option only imports data from the file into blank header fields.
Load All Data into Initial Completion – This option loads information from multiple
completions (normally separated by the last couple digits of a 14 digit API number)
into the single primary completion.
4.2.3.3

297 IHS Source Codes Tab

IHS formation tops are coded by their origin: 1 for driller tops, 2 for sample tops, 3 for
log tops, and 4 for tops that have been modified by IHS.
Petra will only load tops with selected source codes. By default, all check boxes are
selected for import.
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The 297 file import IHS Source Codes Tab

4.2.3.4

297 FM Substitute Tab

This tab sets up a formation substitution file. For more information on formation
substitution files, please see Formation Substitution Files under Common Import
Options

The 297 file import FM Substitute Tab

4.2.3.5

297 IHS Tab

The IHS Tab sets a few more options on how Petra loads the 297 file.
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Figure 13: The 297 file import IHS Tab

Load DST Remarks – This option loads DST test miscellaneous comments in the DST
remarks fields.
Load Well Class and Lahee Class into Well Zone Table – This dropdown sets how
Petra loads the well class into the project. The “Do Not Load” option completely
ignores the well class, the “Load Code Descriptions” option loads the full description,
while the “Load Codes Only” option only loads the well class code.
Concatenate PI Remarks with Current Well remarks – This option leaves the current
well remarks in place and simply appends the PI remarks to the end. When this
option is deselected, Petra will overwrite the well remarks with the PI remarks. This
is particularly useful with the “Load Last Drilling Narrative into Zone Item” option,
which only loads the last line into the Well DREM data item.
Formation Top Repeats – This dropdown sets how the importer handles multiple
formation tops for a single well. The “Ignore” option will overwrite successive listings,
and only keep the first top in the file. “Rename” will add each repeated top with a
numerical suffix. “Add as Repeat Top” loads the multiple tops as a repeat tops
available on the Repeats Tab on the FmTops Tab in the Main Module.
Convert Depth Values from Feet to Meters – This option automatically converts all
depth measurements from feet to meters.
Load “Actual Bottom Hole Reference Location” (S1 Record) – This option loads the
bottom hole reference location from the S1 record.
Load “TVD Value” (S1 Record) – This option loads the TVD from the S1 record.
Load Direction Indicator to Well>DIR_IND – 297 files commonly have an indicator flag
for directional and deviated wells. This option loads the indicator flag to the
“DIR_IND” data item in the WELL zone.
Skip Blank Well Status Codes – When “Add New Wells” is selected, Petra will add all
new wells in the file that aren’t found in the database. This option skips wells with
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“LOC” and “START” well status codes, which keeps permitted wells out of the
database.
Skip Wells with no Surface Lat-Lon Location – With this option selected, Petra will not
import wells with without a surface Lat-Lon.
Load IP and DST Data with Missing Top-Base Depths – This option will force Petra to
load IP and DSTs with no tops and bases. You’ll have to add the top and bases
manually for these tests to show up on cross-sections.
Load Last Drilling Narrative into Zone Item – This option only loads the last line into
the Well DREM data item. This is particularly useful with the “Concatenate PI
Remarks with Current Well remarks” option, which will only update the drilling
narrative instead of completely overwriting it.
Add New Wells Using 14/12/10 Digit API Number – This option sets the API number
format for new wells. By default, Petra can recognize the same well in 14, 12, and 10
digit formats. Put another way, Petra won’t duplicate wells just because it has a
different API number format.
Default Dir Survey Orientation – This option sets the default directional survey
orientation to either “True North” or to “Grid North.”
Always Compute DIR Survey TVDs from Dip-AZM If Present – This option
recalculates the BHL location for directional and deviated wells from the directional
survey data. Note that this will overwrite the reported BHL.
Source for MISC IHS Zone Items – This option adds an IHS source code for other
IHS zone items created when importing the 297 file.
4.2.3.6

297 Misc Tab

The Misc Tab sets the source code for perfs loaded from the 297 file. By default, the
source code is blank.

The 297 file import Misc Tab
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297 Elev Trans Tab

This tab sets up an elevation substitution file. For more information on formation
translation files, please see Elevation Translation Codes under Common Import
Options.

The 297 file import Elevation Translation Tab

4.2.3.8

297 Dir Survey Tab

This tab sets the location of directional surveys imported from the 297 file.
By default, Petra can load the directional surveys into “Actual” or “Planned”, though
you can change the survey definitions with the “Survey Def Maintenance” button.

The 297 file import Dir Survey Tab

4.2.4

Import ASCII Data File

The Generic ASCII File tool is one of the most useful tools in Petra, since it can load
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a wide variety of data. Petra stores this information in an internal project database.
Especially for corrupted or oddly-configured datasets, it’s often useful to first work
with the dataset in a spreadsheet program like Microsoft Excel. The UWI (or API
number) field must be defined for every row of data. This tool can import data
from either tabular (fixed column) or character-delimited ASCII data files.
In addition to the file format, ASCII files can store data in two fundamentally different
ways. One method is to store all information about a single well on a single row,
where different columns reflect different pieces of information. In the example below
(left), each well is a single row, and the petrophysical measurements for that well
are in the columns to the right. The other method is to store each data item and
identifier in its own row, such that there can be multiple rows for a single well. In the
example below (right), each line has an API number, a top name, and a MD value.
Note that some wells have multiple rows for different Dakota Sand tops.
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ASCII file with a single well per row (Left) and with multiple rows per well (Right)

To open the Generic ASCII File, select Project>Import>Generic ASCII
(Spreadsheet)… on the menu bar at the top of the Main Module. Alternatively,
select CTRL + T when the Main Module is selected.

Import ASCII Data Window Tabs
Import File Tab
Data Format Tab
Options Tab
Locations Tab
Fm Substitution Tab
PDCum Tab
Pay Data Tab
Units Tab
Velocity Tab
Elevation Translation Tab
Protected Tab

How To Guides
Importing Log Curves from ASCII Files
Importing Monthly Production from ASCII Files
4.2.4.1

ASCII Import File Tab

The Import File Tab selects the desired file for import. Select the “Open File” button
and navigate to the desired file.
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The generic ASCII Import File Tab

4.2.4.2

ASCII Data Format Tab

The Data Format Tab establishes the link between data in the import file and the
project database. Put another way, this screen tells Petra how to read the file and
store the data in the appropriate place in the database.

The Data Format Tab

Data Record
Once a file is selected on the Import File Tab, the “Data Record” window on the
bottom of the screen shows a portion of the selected file. This section displays two
consecutive data records. You can scroll through the record window with the up and
down arrows on the right side of the screen. You can also scroll left or right through
the record with the scroll bar at the bottom of the record window.
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Number of Records Per Well - This option sets the number of data records pertaining
to a single well.
Records to Skip Before 1st Well - This option skips header or comment lines at the
beginning of the data file. Click the "Set Skip" button to set the number of skipped
records based on the record currently in the data record window.

Field Definitions
Select the appropriate file format on the File Format dropdown. Recall that this tool
can either use tabular (fixed column) or comma/tilde-delimited type ASCII data file.
Columnar files separate different data entries with empty space. Comma- and tildedelimited files, on the other hand, separate different data entries with characters.
Petra distinguishes between different entries on a row with specific start and stop
column numbers.

A comma-delimited file (left) and a columnar file (right)

To add a field definition for a comma- or tilde-delimited file, select the desired field in
the Data Record window. Note that Petra counts the number of commas to establish
a Field Number. Next, select the relevant data type on the set of dropdown menus on
the right. Select the “+” add button to add the definition to the "Field Definitions" list
box.
To add a field definition for a columnar file, swipe relevant data field on the Data
Record window. Note that Petra fills in the “Start Column” and “End Column.” Next,
select the relevant data type on the set of dropdown menus on the right. Select the
“+” add button to add the definition to the "Field Definitions" list box.
replace button to replace the
In both cases, to modify a field definition, use the
currently selected field definition with the selected entry on the import file and data
type. To drop a field from the list, select the desired definition and select the “-“drop
button.
"Implied Decimal Places" – This option scales imported values by multiples of 10. As
an example, a 1 here will divide the incoming data by 10 and a 2 will divide the
incoming data by 100. This is useful for changing values expressed as percentages
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(1-100%) into values expressed as decimals (0-1).

Saving and Loading Field Definition Templates
Since creating a long list of field definitions can be tedious, it’s a good idea to save
your work. Petra can save these column and field definitions as a template “Format
File” with a *.FMI extension. By default, Petra stores template files to the private
parms directory. To save a field definition template file, select the Save button. To
load a pre-existing format template, select the Load button.
4.2.4.3

ASCII Options Tab

The Options Tab controls how Petra loads overlapping data between the project and
the imported file.

The generic ASCII Options Tab

Over Write With Incoming Nulls – Normally, Petra won’t overwrite a value in the
database with a null from the import file. This option instead forces Petra to overwrite
a value in the database with nulls from the import file.
Update Blank Well Header Locations, Tops, and Zone Items Only – This option will
only copy data from the imported file into blank entries.
Replace Current Perfs, Cores, IPs, DSTs, and Casing with Imported Data - By
default, Petra attempts to only add new Perfs, Cores, IPs, DSTs, and Casing entries
to the project. This option instead completely erases all the existing entries in the
project and adds Perfs, Cores, IPs, DSTs, and Casing from the import file.
Append Well Remarks If Loaded – By default, Petra overwrites the well remarks in
the project with those from the import file. This option just appends well remarks
rather than completely replacing them.
Convert Canadian UWIs to Standard 16 Character Form – This option converts 14
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digit Canadian API numbers to 16 character API numbers during the import.
Load All Data To Primary Completion Well Only - With this option selected, Petra only
imports primary completions with API numbers ending in 0000. Data from other
completions (0001, 0002, etc) are merged with the primary completion. For 16character Canadian UWIs, the first 14 characters are used.
Add Multiple Top Values as Repeated Tops - This option saves multiple formation
tops for the same well as “repeat tops” in Petra database.
Well Update Mode - This dropdown selects how Petra loads new wells and treats
wells already in the local database. “Add New Wells to Database and Update
Selected Wells” will both create new wells, and overwrite the selected data for wells
already in the database. “Add New Wells Only” will create new wells, but will not
overwrite any data in wells already in the database. “Update Selected Wells Only”
will overwrite selected data for wells in the project, but will not create new wells.
Numerical “NULL” Values Are Indicated By – Petra recognizes the most common null
placeholder, “-999.25”, on its own. This option sets the non-standard strings of text
or numbers Petra should recognize as null values.
Date Format In Import File – This option sets the formatting of dates in the import file.
Remove the Following Characters From the UWI – API numbers are commonly
broken up by dashes, slashes, or other characters. This option removes nonstandard characters from the UWI before loading them into the project.
Load “Zone Item Name and Value” into ZONE – For datasets where each data item is
its own row, this option sets the destination zone for the selected data items. Note
that these datasets can only put data into a single zone at one time.
Print Hdr List – This option creates and prints a list of the well header items.
4.2.4.4

ASCII Locations Tab

The Locations Tab sets the format of location data, and how Petra calculates LatLons
and XYs. This tab also sets a few options for how Petra loads directional survey
data.
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The generic ASCII Locations Tab

Latitude-Longitudes are in SEPG1 format (DDDMMSSSS) - Normally, latitude and
longitude values are decimal degrees. This option imports LatLon values in the
SEGP1 standard format consisting of degrees, minutes and seconds
(DDDMMSSSSZ, where D=Deg, M=min, S=Sec, Z=N,S,E,W).
Convert Lat-Lon to XY – This option recalculates the XYs based on the imported
LatLons. This option is set by default. When both LatLon and XYs are imported,
Petra preferentially uses LatLons to overwrite XYs.
Convert XY to Lat-Lon – This option recalculates LatLons based on the imported XYs.
When both LatLon and XYs are imported, Petra preferentially uses LatLons to
overwrite XYs.
Compute Surface Lat-Lon When Importing NE Location Ref and Offsets – This option
recalculates surface LatLons based on the NE locations and offsets.
Positive Valued NW Location Offsets are Measured From - This option changes how
location offsets are measured. Positive XYS can either refer to “South and West” or
“North and East”

Directional Survey Data
Directional Survey Angles are DDMMSS Format – Normally, directional survey
inclinations are in decimal degrees with 0 as straight up and down and 90 as flat. This
option imports directional survey inclinations as degrees, minutes and seconds
(DDMMSS).
Extend Survey to TD During Import – This option projects the directional survey data
out to TD. For MD-DIP-AZI based surveys, Petra will project to TD using the last
survey’s dip and azimuth. For TVD-EW-NS based surveys, Petra will project to TD
using an average of several previous points to calculate an azimuth and inclination.
Calculate Bottom Hole Location From Survey – This option recalculates the bottom
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hole location from the directional survey data. Note that this will overwrite the
reported BHL.
Import Directional Surveys into: - This option sets the location of directional surveys
from the imported file. By default, Petra can load the directional surveys into “Actual”
or “Planned”, though you can change the survey definitions with the “Survey Def
Maintenance” button.
Load Directional Survey with Grid Orientation Set to - This option sets the default
directional survey orientation to either “True North” or to “Grid North.”
4.2.4.5

ASCII FM Substitution Tab

This tab sets up a formation substitution file. For more information on formation
substitution files, please see Formation Substitution Files under Common Import
Options.

The generic ASCII Fm Substitution Tab

4.2.4.6

ASCII PDCum Tab

The PDCum tabs controls how Petra imports and updates cumulative production data.
In general, Petra attempts to add to existing production cums by matching the name,
top and base in the imported data to cumulative values in the project. Without a good
match, Petra will add a new cumulative production line to the database.
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The generic ASCII PdCum Tab

Ignore Dates When Updating PDCUM Tables – By default, Petra uses dates to match
production data. This option instead forces Petra to ignore the PDCUM dates and
update the tables, potentially creating new PDCUM lines.
Use FmName Only to Match Existing Records – This option forces Petra to only use
formation name to match production cums in the imported data to production cums
already in the project.
Protect (Do Not Modify) ALTNAME on Existing Records – This option protects the
alternate name on the existing records and prevents it from being overwritten by the
imported data.
Substitute Top for Missing Base Values – This option copies the depth of the top of
the PDCum to the base when the base is missing.
Substitute Base for Missing Top Values - This option copies the depth of the base of
the PDCum to the top when the top is missing.
4.2.4.7

ASCII Pay Data Tab

The Pay Data Tab sets a source code for all imported pay intervals. This can be
useful for distinguishing between pre-existing pay intervals and those brought in during
the import.
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The generic ASCII PayData Tab

4.2.4.8

ASCII Units Tab

The Units Tab controls how Petra interprets feet and meters for directional survey
data and Fm Tops. If the units in your project are the same as the units in your data,
you can leave the defaults.

The generic ASCII Units Tab

Directional Survey Units
Change offset XYs – This option converts directional survey XY offsets in meters to
feet, or from feet to meters.
Change Depth Units –This option convert directional survey depths in meters to feet,
or from feet to meters.

Fm Top Depths
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Convert FmTops Depth Units – This option converts the depths in the imported file to
feet or meters. By default, Petra assumes that these units in the imported file are the
same as the units in the project and does not perform a conversion.
4.2.4.9

ASCII Velocity Tab

The Velocity Tab controls how the importer brings in seismic velocities. Note that
you can only bring in a single seismic velocity at a time.

The generic ASCII Velocity Tab

Depth Units – This option sets the units of the depths in the file to feet or meters.
Time Units – This option sets the specific format of the time. Time can either be 1way or 2-way, and can either be in seconds or milliseconds.
Import Data into Velocity Function – This option sets the destination of the imported
velocity function. The “+” button adds a new velocity function to the database.
Default Datum - This option sets the default datum for the seismic velocity. By
default this entry is set to 0.
Default Replacement Velocity – This option sets the default replacement velocity. By
default, this option is set to 5000.
Make this the ACTIVE Velocity Function – This option sets the imported velocity as
the “active” function.
4.2.4.10 ASCII Elevation Translation Tab

This tab sets up an elevation substitution file. For more information on formation
translation files, please see Elevation Translation Codes under Common Import
Options.
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The generic ASCII Elev Trans Tab

4.2.4.11 ASCII Protected Tab

This tab sets certain types of data in the project as “protected.” When importing
data, Petra will not overwrite protected data. Unlike “locked” data, protecting data
here is only relevant for importing data; protected data can still be manually
overwritten.

The generic ASCII Protected File Tab

4.2.4.12 Import Monthly Production From Tabular File Format

The import tabular monthly production file function is used to load monthly production
from a tabular or fixed column type ASCII data file. Files containing multiple records
per well can be imported. Data for multiple wells may be imported from a single file if
the file has a column containing the well's unique well identifier (UWI).
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Load Production Into Well This drop down box defines which well will receive the imported production data.
This is only required whenever the UWI field is missing from the imported data file.
File To Import Click the "Open File" button to select the import file using the standard Windows file
dialog.
Field Definitions One defines the data fields to be imported by setting the starting and ending column
numbers and record number. Then the field is associated with either a year, month
or a Zone data item. The Year and Month fields must be defined. Multi-well data file
must have the UWI# field defined.
add button. Fields can be
The field is then added to the list box by clicking the
modified by clicking the
replace button. Drop a field from the list by clicking the
drop button. Once the format (column and field definitions) has been defined, the
"Save" button will write the format to a disk file which can be used again by selecting
the "Load" button.
Loading Production By Producing Formation Name
You can load monthly production data streams for individual formation names into the
OIL, GAS and WTR or any user defined name. You must have the formation name
as one of the data columns. Select and identify the oil data column as "OIL", the gas
column as "GAS", the water column as "WTR". These are the predefined system
production streams. Set the "Prefix" values for each of the three stream types. The
oil, gas and water production streams will be loaded under a prefixed formation
name. For example, If the formation name data column contained the following (api,
fm,year,month,oil,gas,wtr):
03033123450000,HALE,2001,05,20,250,2
then the oil stream would be loaded into O_HALE, the gas into, G_HALE, and the
water into W_HALE.
For user defined streams, such as INJ, create a new stream item called INJ. When
the import pointed to this INJ stream, the actual stream name that is loaded is
INJ_fmname. In the above example, this would INJ_HALE.

Dragging the mouse across a scrollable data record can set columns. Two
records of the actual data file are shown.
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Data Record This section primarily is used to scroll through the data file and select data field
columns. Use the up and down arrows located to the right of the record window to
read foreword or backward in the file. The data record can be scrolled left or right
by placing the cursor in the record window and using the left or right cursor keys.

Records to Skip Before 1st Year - This option allows header or comment records to
be skipped at the beginning of the data file prior to the first true data record. Click
the "Set Skip" button to set the number of skipped records based on the record
currently in the data record window.

4.2.5

Import Landmark Standard 29 File
The Landmark Standard 29 format is a well data format associated with Landmark
interpretation software. Standard 29 files are almost always exported from a
preexisting Landmark project, rather than provided by data vendor. A Standard 29 file
is a defined format that includes well header data, tops, curves, location information,
and directional surveys. Petra stores this information in the project database.
To import a Landmark Standard 29 file, select Project>Import>Landmark Standard 29
Format on the menu bar at the top of the Main Module.

Options Tab
The Options Tab controls which data is brought into the project, as well as how Petra
loads overlapping data between the project and the imported file.
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The Landmark 29 Options Tab

Well Options – These boxes govern whether the importer adds new wells, or updates
selected wells already in the project database.

Data To Load
General Well Header Data - This option imports general well header data, which
includes well names and numbers.
Locations - This option imports location data from the file.
Directional Survey – This option imports directional survey data from the standard 29
file. Note that directional surveys can be brought in as TVD as well
Datum Elevation - This option imports well reference datum. This is most often used
to calculate top SS values.
Detailed Perfs - This option imports perf information from the file.
Formation Tops - This option imports the formation tops from the file.
Log Curves – This option imports digital log curves from the file. The “Rename
Duplicate Curves” option adds a “_1” suffix to repeat curves.

Misc Tab
The Misc Tab sets the source code for perfs loaded from the Standard 29 file. By
default, the source code is blank.

The Landmark 29 Misc Tab

Dir Survey Tab
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This tab sets the location of directional surveys from the 297 file. By default, Petra
can load the directional surveys into “Actual” or “Planned”, though you can change the
survey definitions with the “Survey Def Maintenance” button.

The Landmark 29 Dir Survey Tab

4.2.6

IHS Enerdeq Direct Connect
With an active subscription, Petra can use IHS's Direct Connect to download well
data, production data, and raster data. Direct Connect requires an Enerdeq License
(User ID and Password) authorized to access the Petra Direct Connect feature. This
access must be gained by contacting your IHS Account Manager. If you not know who
your Account Manager is then contact the one of the sources listed below:.
IHS Enerdeq Support - email CustomerCare@IHS.com or call 1-800-447-2273,
option 1

Direct Connect Well Data (US & Canada)
Direct Connect well data includes header information, FmTops, and other completion
information. This data is functionally equivalent to importing an IHS 297 file.

Direct Connect Well Data (International)
Direct Connect well data includes header information, FmTops, and other completion
information. This data is more variable due to different reporting standards.

Direct Connect Production Data
Direct Connect production data contains allocated and unallocated monthly production.
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This data is equivalent to importing an IHS 298 file.

Direct Connect Raster Data
Direct Connect rasters

4.2.6.1

Direct Connect Well Data (US & Canada)

The Direct Connect Tool is one of the easiest ways to import well data from IHS’s
well databases. With a subscription, an internet-connected computer can update the
existing wells in a project or populate a blank project with wells inside a rectangular
area. The end result of using Direct Connect is the same as importing a 297 file - the
only real difference is that this method always has the most updated information, and
there’s no need to manage 297 files.
Direct Connect data includes header information, FmTops, and other completion
information. Header information includes things like well name, operator, field name,
TD, and other data about the well. FmTops contain the definition and depths of
specific geological tops and other contacts encountered in the well. Completion
information includes data like casing diameters, tests, and perfed intervals.
Petra loads these values into the project database by each well’s Unique Well
Identifier (UWI). During importing, Petra compares the UWIs in the dataset to the
UWIs in the project. When Petra finds a match, (by default) it updates the well.
When there is no match, Petra (by default) creates a new well.
Direct Connect operates on two different databases (US and Canada, and
International) with two different tools. Even though the user interface is different
between the US and Canada Direct Connect and the International Direct Connect, the
functionality is very similar.
To open the Direct Connect import tools, select Project>Direct Connect>Import Wells
from IHS Direct Connect.

Direct Connect Well Data (US and Canada)
Selecting Wells or an Area of Interest
Import Options
Queries
Reports
Saving to a 297 File
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4.2.6.1.1 DC Wells and AOI Tab

Petra can either update pre-existing wells in a project or add completely new wells
inside a rectangular “Area Of Interest.” For the Direct Connect module to update
existing wells, the UWIs inside the project need to match the UWIs stored in IHS’s
database.

The US/Canada Direct Connect Wells and AOI Tab

Use MAP View to Set AOI and Download UWI List… - This option updates wells and
adds new wells inside a rectangular “Area Of Interest.” This option is probably the
most useful for new, blank projects or for expanding an existing project. Whether this
map covers Canada (Left) or the continental US (Right) depends on the “Project Area”
set in the Map Projection Settings.

The US/Canada Direct Connect Map AOI. Note that the area depends on the "Project Area.”

Make AOI and UWI list from Currently Selected Wells… - This option establishes an
AOI based on the extent of the currently selected wells. This option will search the
geographic AOI and add new wells not in the project’s database. This option is great
for updating a project to include wells drilled since the last update.
Make UWI List from Currently Selected Wells… - This option updates only the wells
currently selected in the Main Module. This option will not add new wells.

© 2014

Main Module

161

4.2.6.1.2 DC Import Options Tab

The Direct Connect Import Options Tab controls most of the details on what
information Petra imports into the project.
To open the Direct Connect import tool, select Project>Direct Connect>Import Wells
from IHS Direct Connect.

The US/Canada Direct Connect Import Options-General Tab

General Tab
Fm Tops Tab
Formation Substitution Tab
Source Tab
Elevation Translation Tab
Directional Survey Tab
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4.2.6.1.2.1 DC Import Options Tab - General

The US/Canada Direct Connect Import Options-General Tab

Well Update Mode
Well Update Mode – This section has two dropdown menus that govern how Petra
loads new wells and treats wells already in the local database. The top menu selects
between “Add New Wells to Database” and “Do Not Add New Wells to Database.”
The bottom menu selects between “Do Not Update Any Wells, Update Only Wells
Selected in Main Module, and Update Any Well in the Database.”
Add New Wells Using – This option controls the configuration of new well API
numbers. New wells can either have 10, 12 or 14 digit API numbers. Note that the
13th and 14th digit signify different completions; selecting 10 or 12 digit APIs will
merge data from different completions together.

Data to Load
This section provides a list of data types to be imported.

Misc Options
This section contains a list of additional data types and special conditions used during
import.
Restrict Wells by Last Update Date – This option restricts the update to only those
wells that have been updated since the “the "Last Change Date" shown on the "Wells
and AOI" Tab. Note that Direct Connect will download all selected wells from the web
server, but only those wells that have been updated by IHS since will actually be
imported into the project.
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Load Data Into Initial Completions Only – With this option selected, Petra only imports
primary completions with API numbers ending in 0000. Data from other completions
(0001, 0002, etc) are merged with the primary completion. For 16-character
Canadian UWIs, the first 14 characters are used.
Skip IC numbers (Load API Numbers Only) – This option forces Petra to only import
API numbers.
Use NAD83 Locations (Canada only) - If your project datum is set to NAD83 or NTV2,
then setting this option will read the NAD83 locations from the server. Otherwise, the
NAD27 locations are automatically converted to NAD83.
Update BLANK Header Fields Only - The following fields are updated when they are
blank in the project database:
Well Name and Well Number
Operator and Historical Operator
Lease Name and Lease Number
Fm at TD
Producing Fm
Field Name
TD and TVD
Elevation
Platform, Water Depth, Whipstock Depth
Geol Province
Directional Indicator
Spud Date, Comp Date, Permit Date, Rig Release Date
Abandoned Date, First Report Date, Last Activity Date
Lat Lon Source
Surface and Bottom Hole Lat and Lon

Update Historical Operator If Blank – This option copies the operator in the project
into the historical operator entry when updating the well’s operator. Note that this
option will only change blank historical operator entries.
Use Lease Name as Well Name – This option uses the well’s lease name as the well
name.
Store Well Name in Well Label – This option stores the well name field into the well
label field.
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Build Well Labels Using Predefined Template – This option uses the "Build Well
Labels" default template to create well labels in the project.
Load Last Drilling Remark into Zone Item (WELL.DRILLREM) – By default, Petra
completely overwrites the DRILLREM data item in the WELL zone. In contrast, this
option only stores the last drilling remark record. Note that the entire contents of the
DRILLREM item will be over written with the last remark.
Add CORE Remarks to Well Header Remarks – This option adds core record
remarks to the well remarks displayed on the main well tab.
Do Not Load Fm Bases – This option disables loading formation base values.
Use Fm Top Repeats – This option saves multiple formation tops for the same well as
“repeat tops” in Petra’s database.
Ignore Fm Top Source Codes – With this option, the project does not distinguish
between the different HIS source codes. If two sources are present for the same
top, the project will only keep the last one loaded.
Include Engineering Completion Detail Perfs (CANADA DB Only) – This option adds
"completion" records as detailed perfs.
Copy Production Tests Into Perfs (Gross) – This option uses the top and base of
each production test (IP test and others) to create a perf record in the database.
This can create large gross interval perfs.
Copy Treatments Into Perfs (Detail) – This option uses the top and base of each
production test treatment record to create a perf record in the database. This can
create detailed perfs.
Set PERF Source from IHS Data Source – This option adds source codes based on
the data type used for the perf interval.
GRSPRF

- Gross Perfs

DETPRF

- Detailed Perfs

IPTTST

- Perf created from IP or production test

TREAT

- Perf created from prod test "treatment" record

ENGCOMP - Perf from Engineering Completion record

Load IP and DST Data with Missing Top or Base - Normally, tests without a top and
base are not loaded into the project. This option brings all tests into the project.
Use Completion Date If Test/Perf Date is Missing - This option causes each test and
perf record to use the well's completion data for undated tests/perfs. All perfs
imported for a well at the same time will have the same completion date, which can
cause confusion when storing multiple completions in the same API number.
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Compute LatLon From NorthEast Footage Ref - This option only applies to area in the
United States that use the "NorthEast" location criteria. The surface Lat-Lon location
will be computed using NE footage locations.
Load Directional Indicator into Well->DIR_IND - Use this flag to store a value such
as V, D or H in the Well Zone item called DIR_IND.
Convert Depth Values from FEET to METERS – This option converts the depths from
feet to meters during import.
Store Untranslated Well Symbol Code in WELL.ORIGSYMCODE - The raw symbol
code text is stored in the Well zone item called ORIGSYMCODE.
Default Survey Orientation to GRID North instead of TRUE North - Normally, IHS
directional survey data is oriented toward True North. Use this option to set the survey
orientation flag to Grid North for all wells loaded.
Produce Detailed Load Report - The report file displayed at the end of the import
process will contain a very detail listing of all data imported.
4.2.6.1.2.2 DC Import Options Tab - Fm Tops

This screen restricts the formation tops brought into the project. Selecting the
"Download Top Selection List" creates a list of all Enerdeq’s formation top names for
the selected of UWIs. Depending on the number of wells, this request can take
several minutes to complete. Note that the list also shows the number of occurrences
for each formation top.

The US/Canada Direct Connect Import Options - Fm Tops Tab
4.2.6.1.2.3 DC Import Options Tab - Fm Subst

This tab sets up a formation substitution file. For more information on formation
substitution files, please see Formation Substitution Files under Common Import
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Options.

The US/Canada Direct Connect Import Options - Fm Subst Tab
4.2.6.1.2.4 DC Import Options Tab – Source

The Import Options Source Tab sets the source code for perfs, zones, and tops
loaded from the IHS database file. IHS formation tops are coded by their origin: 1 for
driller tops, 2 for sample tops, 3 for log tops, and 4 for tops that have been modified
by IHS. As such, the same top name can occur a few different times with different
sources. This option only brings in a single copy of the top – generally the import will
bring in the highest source code with the highest quality.

The US/Canada Direct Connect Import Options – Source Tab
4.2.6.1.2.5 DC Import Options Tab – Elev Trans

This tab sets up an elevation substitution file. For more information on formation
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translation files, please see Elevation Translation Codes under Common Import
Options.

The US/Canada Direct Connect Import Options - Elev Trans Tab
4.2.6.1.2.6 DC Import Options Tab – Dir Survey

The Import Options Dir Survey tab sets the location of directional surveys from the
297 file. By default, Petra can load the directional surveys into “Actual” or “Planned”,
though you can change the survey definitions with the “Survey Def Maintenance”
button.

The US/Canada Direct Connect Import Options - Dir Survey Tab
4.2.6.1.3 DC Queries Tab

The query tab uses queries created and saved by the Enerdeq Browser.
Importantly, Petra does not provide a direct link to create queries; it only accesses
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queries created with your userid.

The US/Canada Direct Connect Queries Tab
4.2.6.1.4 DC Report Tab

The Report Tab shows the progress of the import from Direct Connect.

The US/Canada Direct Connect Report Tab
4.2.6.1.5 DC 297 Tab

The 297 Tab saves a local copy of the data from the IHS database as a 297 file.
Select “Browse” to navigate to the destination of the file.
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The US/Canada Direct Connect Import Options - 297 Tab

4.2.6.2

Direct Connect Well Data (International)

Much like the domestic Direct Connect tool, the International Direct Connect Tool
populates projects with well data from IHS’s international database. This database
can either update the existing wells in a project, or populate a blank project with all
wells inside a rectangular area. It is important to set a reasonable quadrant and
map projection before using International Direct Connect.
To open the module, select Project>Direct Connect>International from the menu bar
at the top of the Main Module.

The International Direct Connect Well Tab

Petra can either update pre-existing wells in a project or add completely new wells
inside a rectangular “Area Of Interest.” For the Direct Connect module to update
existing wells, the UWIs inside the project need to match the UWIs stored in IHS’s
international database.
All wells in Petra Project - This option updates all wells stored in the currently selected
project. This option will not add new wells.
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Selected UWIs in Petra Main - This option updates only the wells currently selected in
the Main Module. This option will not add new wells.
Previously Saved UWI File - This option updates wells from an already existing UWI
file. To use this option, select the relevant button and navigate to the UWI file with the
“Browse” button.
Area of Interest - This option updates wells and adds new wells inside a rectangular
“Area Of Interest.” As such, this option is probably the most useful for new, blank
projects or for expanding an existing project. To use this option, select the “Area of
Interest” button and enter the latitude and longitude boundaries of the area of interest
(using the WGS84 datum).

Setting an "area of interest"

Note that selecting “OK” will close the “Area Of Interest” window, and return to the
Direct Connect tool. Petra will logon to IHS’s International Web services to count the
number of wells inside the area. In the example below, 33 wells are inside the area.
The report will read something like:

After setting an AOII, Petra gets a well count from the IHS database

After selecting the wells, the International Direct Connect tool will display the number
of selected wells. Selecting the “Import Wells” button will import the wells directly into
the project. The Direct Connect tool imports wells in blocks of 100 wells.
4.2.6.3

Direct Connect Production Data

The Direct Connect Tool is an easy way to import production data from IHS’s
databases into the wells in a project. Using Direct Connect to import production data
is very similar to importing a 298 file – the only difference is that Direct Connect’s data
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is always the most updated.
Petra loads these values into the project database by each well’s Unique Well
Identifier (UWI). During importing, Petra compares the UWIs in the dataset to the
UWIs in the project. When Petra finds a match, (by default) it updates the well.
To open the Direct Connect Production Tool select Project>Direct Connect>IHS US
Enerdeq or Canada>Import Production from IHS Direct Connect from the menu bar at
the top of the Main Module.
Method Window
General Tab
Totals Tab
Formations Tab
PdCums Tab
Leases Tab
P/Z Tab
Fm Subst Tab
Query Tab
4.2.6.3.1 DC Prod Method Window

The Method Selection screen sets how the Direct Connect Production tool selects
how the data should be imported.

Selecting wells to update with the Direct Connect Production tool

The options include using the wells selected in the Main Module, all wells in the
project, a preselected WSN list file, selecting by data criteria, or a stored Enerdeq
query. Note that it’s also possible to reselect the wells later.
This screen can also filter the wells based on when the production was updated. This
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can be useful for accelerating the process by only changing only wells that are actively
producing.
4.2.6.3.2 DC Prod General Tab

The General Tab sets which production streams are loaded into Petra.

The Direct Connect Production General Tab

Production Streams
Load Production into Standard OIL, GAS, WTR (WELL ZONE) – This option loads the
total production data into OIL, GAS, and WTR streams. Note that this option sums
production from all formations together into a single stream.
Load Production into Individual Formation Names – This option creates separate
production streams for each formation. The Formation Tab selects the imported
formation production streams, and the annotation for the individual oil, water, and gas
streams.

Type of Production Loaded
This dropdown sets which data are loaded into the project. Petra can import monthly
production streams, cumulative production values, or both.

Method to Apply Lease Production to Individual Wells
Load Production into First Well Only Listed in Lease - This option stores production
only to the first well listed in the lease. Only use this option if the 298 file only has
single-well leases.
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Load Production into Each Well in the Lease – This option divides the production for
the lease by the number of wells in the lease. As an example, in a lease containing 6
wells, each well receives 1/6th of the production.
Load Production into Each Well in the Lease – This option stores the total production
for the lease in every well in the lease. In a lease containing 6 wells, each well
receives all of the production – potentially multiplying the actual production.

Fluid Types (Streams) to Load
These boxes set which fluid types are loaded, and how they are named. Note that
Petra automatically creates streams named OIL, GAS, WTR. For a different
production stream names, select the
button, and create a new monthly
production definition.

Creating a new monthly production definition
4.2.6.3.3 DC Prod Options Tab

The Options Tab sets a few additional options for how Petra uses the production
data.

Figure 152: The Direct Connect Production Options Tab

Load Production into INITIAL COMPLETION Wells Only – By default, Petra brings in
production from different completions as different wells. This option instead stores
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production only to the primary completions (where the API number ends in 00).
Update OPERATOR and Save Current Operator as Historical Operator – When
there’s a difference between the current operator in the project and the current
operator in the 298 file, this option copies the operator in the project to the historical
operator field and overwrites the operator field with the data in the 298 file.
Load Producing Fm Name into Well Header – This option updates the database’s
producing formation (Prod. FM on the Well Tab in the Main Module) with the entry
from the production data.
Store Current Status into WELL Zone as PD STATUS – This option creates a data
item called “PD STATUS” in the WELL zone. This text field stores I for inactive wells
and A for active wells.
Update Well SYMBOL CODE with Primary Product Code – This option changes the
well’s symbol code displayed on the map based on the Primary Product Code in the
298 file.
Store GATHERER in WELL Zone as GATHERER – This option creates a data item
called “GATHERER” in the WELL zone. This text field stores the name of the gas
gatherer.
Skip Lease Name Checking – When updating production, Petra checks the entire list
of lease names when it can’t match based on formation name. This can take a long
time depending on the size of the data set. This option skips this process.
Display Detail Info in Report – This option displays all monthly production values on
the import report.
Update Non-Blank Lease Number with UNIT WELL SERIAL NUMBER – This option
overwrites lease numbers with unit well serial numbers.
Do not use “A” in prefix/suffix to designate Allocated Production – By default, Petra
adds an “A” to allocated production. This option drops the A, making allocated
production indistinguishable from regular unallocated production.
Use 12/10 Digits for Matching Initial Well Completions – This option matches the first
12 or 10 digits of the API/UWI when loading production from multiple completions into
the initial well completion.
4.2.6.3.4 DC Prod Totals Tab

The Totals Tab stores information from the production data to zone data items. Each
data item is a fluid type prefix and the formation name. As an example, the Oil from
the Dakota D is stored as “O_602DKOTD” by default.
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The Direct Connect Production Totals Tab

Zone for storing Totals – This dropdown selects the zone that will contain the
cumulative production data items.
CUM OIL – This option sets the prefix for cumulative oil values. By default it is “O.”
CUM GAS – This option sets the prefix for cumulative gas values. By default it is “G.”
CUM WTR - This option sets the prefix for cumulative gas values. By default it is “W.”
Lease Name – This option sets the zone data item for storing the lease name.
Lease Well Count - This option sets the zone data item for storing the lease well
count.
Prod ID - This option sets the zone data item for storing the production ID.
4.2.6.3.5 DC Prod Formations Tab

This tab lists the formations in the database and their production stream counts. This
tab also establishes the names used in the formation-specific production streams.
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The Direct Connect Production Formations Tab

The Count/Name list shows all the formations in the 298 file, and is populated after
scanning the file. If nothing appears here make sure to select the “Scan File” button
on the Files Tab. Note that Petra lists the formation production data base on total
number of streams. Petra will only load the formations selected here.
FM NAME From – This dropdown sets how the formation production streams are
named. These streams can use the standard IHS Fm Name Code, the description,
the age code, or the reservoir name.
Prod Stream Name Qualifier – This option sets the prefix or suffix used to signify the
different fluid types. By default, Petra uses O, G, W, and D to signify oil, gas, water,
and days on. Petra can set these qualifier characters as a prefix or as a suffix to the
name.
4.2.6.3.6 DC Prod PdCums Tab

This section allows the selections on how cumulative production values are loaded into
the PDCUM tab.
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The Direct Connect Production PdCum Tab

Do Not Store in PdCum DB - This will not store any data into the ProdCum tab.
Store in PdCum Data using ProdID as FmName - Cums are loaded by ProdID for
individual leases/wells. The ProdId is stored in the FMNAME column and the formation
name will be stored into the ALTNAME column under the ProdCum tab. Each lease
will have an entry regardless of formation name.
Store in PdCum Data using ProdID as AltName - CUMS are loaded by FMNAME for
individual leases/wells. The ProdId is stored into the ALTNAME column and the
formation name will be stored into the FMNAME column under the ProdCum tab. Each
lease will have an entry regardless of formation name.
Store in PdCum Data using FmName Only - CUMS are loaded by FMNAME. Any
duplication of the formation names will be summed together and stored as a single
entry. The ProdId is NOT captured in this selection.
4.2.6.3.7 DC Prod Leases Tab

The Leases Tab displays the available leases in the database file. Here, select the
lease names you want to load.
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The Direct Connect Production Leases Tab
4.2.6.3.8 DC Prod P/Z Tab

The P/Z Tab has a few options on capturing P over Z data for gas wells.

The Direct Connect Production P/Z Tab

Load P/Z Gas Cum Data – This option loads P/Z, Gas Cum, and BHP data. When
this option is deselected, these data streams won’t load into the project.
P/Z – This option sets the name for P over Z pressure.
Gas Cum – This option sets the name for the gas cumulative volume.
BHP – This option sets the name for the bottom hole pressure.
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4.2.6.3.9 DC Prod Fm Subst Tab

This tab sets up a formation substitution file. For more information on formation
substitution files, please see Formation Substitution Files under Common Import
Options.

The Direct Connect Production FmSubst Tab
4.2.6.3.10 DC Prod Query Tab

The Query Tab retrieves wells from saved IHS Enerdeq queries, and uses those wells
to import production data.

The Direct Connect Production Query Tab

Retrieve IHS Enerdeq Queries… - This option gets the saved Enerdqeq queries for
the current logon. In the example above, the “Sooner” query was saved in Enerdeq
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and now appears on the list.
Run Query – This option reruns the query in Enerdeq.
4.2.6.4

Direct Connect Raster Logs

On the Main Module, select Project>Direct Connect>IHS Logs>Raster… from the
menu bar at the top of the screen.

Downloading the Catalog
First, select the
button on the upper left hand side of the screen.
Petra compares the UWI/API numbers of the wells currently selected in the Main
Module to IHS’s raster database. Wells with matches are shown in the spreadsheet
taking up most of the screen, with different wells are separated out by color. Note
that main pass logs are in green, while shorter repeat passes are highlighted in red.
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This spreadsheet lists the available raster logs for each well with columns for UWI,
Service, Method, Log Type, Hole Type, Scale, Run, Top, Base, Units, Type, Date,
Cat ID, TifNumber and URL.
UWI – This is the Unique Well Identifier. For the US, this will generally be the well’s
API number.
Service – Service is the service name as recorded on the raster log header by the
service company. To save room in Petra, only the mnemonic is loaded into the Group
Name, but the long name is displayed inside [square brackets] for your reference.
Method – Method indicates which logging method was used to record the data. For
example, Neutron Porosity vs. Sonic Porosity.
Log Type – Log Type indicates the global type of log, for example resistivity or
porosity.
Hole Type – This field indicates whether the scanned log is an open hole or cased
hole log.
Scale – This is the inch scale of the scanned log. The most common scales are 1”,
2”, and 5” logs.
Run – For wells with multiple logging runs, this indicates whether the log is a main
pass (MP) or repeat pass (RP) log.
Top – This gives the top depth calibration point.
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Base – This gives the bottom depth calibration point.
Units – This indicates whether the log is measured in feet or meters.
Type – Type indicates whether the log is recorded in true vertical depth (TVD) or
measured depth (MD).
Date – This gives the logging date as recorded in the log header.
Cat ID, TifNumber, URL – These three columns are utilized by Petra to reference the
image.

Filters
This option filters the available logs by scale, hole type, units, and depth type. Note
that the “Depth Units” check boxes include logs recorded in the relevant depth unit.
As an example, clearing the “meters” box will drop all logs recorded in meters.
When both the Meters and Feet boxes are checked, logs recorded in both meters
and feet will be included.

Build Group Names From
In the top right-hand corner of the dialog, the “Build Group Names From:” option sets
how Petra will create the Group Names in the project. To avoid duplicate entries,
it’s best to be consistent with the naming convention. The available options
come from various combinations of Service, Method, Log Type, and Hole Type.
Service
Service + Method
Service + Method + LogType
Service + Method + LogType + HoleType (default)
Method
Method + LogType
Method + LogType + HoleType
LogType
LogType + Method
LogType + Method + HoleType

Overlapping Raster Log Names
Petra will use the naming criteria set in the “Build Group Names From” drop down
when comparing raster logs from this screen to what’s already in the Petra project.
Selecting a different group name method from this drop down will change what
constitutes an overlapping raster log name and how this drop down works. In all
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cases, using a different naming convention creates a large administrative headache.
Add New Calibrations Only (do not replace existing ones) - This option adds new LIC
files and does not replace any existing LIC files. Practically, this option preserves
changes made to existing raster log depth calibrations and headers/footers/scales,
while still loading in new raster logs. If the “Build Group names From” drop down is
different than how logs were previously imported, this option will create an entirely
new (though duplicate) set of raster logs, though the preexisting log images will not
change.
Add New and Replace Existing Calibrations - This option adds new LIC files and
replaces all existing LIC files. Put another way, this option erases all changes made
to raster log depth calibrations and headers/footers/scales in the project and adds
new logs. If the “Build Group names From” drop down is different than how logs
were previously imported, this option will create an entirely new (though duplicate)
set of raster logs and no existing calibrations will be replaced.
Replace Existing Calibrations (do not add new ones) - This option only updates
existing LIC files, but does not add any new logs. Practically, this erases all changes
made to the log depth calibrations and headers/footers/scales, but does not add new
logs. If the “Build Group names From” drop down is different than how logs were
previously imported, this option will not update any calibrations.

Downloading LIC files vs. Downloading LIC Files and Images
This drop down determines how Petra downloads and stores data. The two options
are: “Download LIC Files Only (Images Kept on IHS Server)” and “Download LIC
and IMAGES (Copy Images to Disk).”
Download LIC Files Only - This option delivers a copy of the image over the internet
as needed, and temporarily stores the image file in RAM until the project closes.
The only thing that remains stored in the project is IHS’s LIC file, which contains
depth calibration points as well as a “header” that generally covers the log scale on
the image. Importantly, adjustments made to the image’s depth calibration points or
to the header are preserved inside the project’s LIC file. Since the image file is
never permanently stored, however, changes to the image such as straightening and
rotating are not preserved.
The chief advantage of this method is that the large log image files remain on IHS
servers rather than being stored locally, which can save significant file space and
reduce the need for database management. This method, however, requires an
always active internet connection in order to download the images. Slow internet
connections and company networks can greatly degrade performance, translating to
long, frustrating waiting times.
Download LIC and IMAGES (Copy Images to Disk) - This option delivers a copy of
the image and LIC file and stores a permanent copy in the Petra project’s IMAGES
folder. All changes made to the LIC file (including depth calibration changes and
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headers/footers) and to the actual image file (including rotating and straightening) are
preserved.
The chief advantage of this method is that the log images are always available,
regardless of the internet connection. The fact that the logs are stored locally means
there is a greater demand for network storage space and a greater attention to
database management.

Downloading Selected Logs
Once the desired images have been selected and options have been set in the three
drop down boxes, click on “Import Logs”
to download either the LIC
files or the LIC files and image files to the Petra project. The raster group names will
be created and loaded into the Raster tab of your Petra project.

4.2.7

Import IHS Monthly Production (298 File)

The “EZ” loader is the IHS recommended tool for importing production data into a
Petra project.
For simplicity and to avoid errors, the EZ loader completely overwrites the
existing production streams and cumulative production values.
To open the 298 EZ Loader, select Project>Import>298 EZ Loader… from the menu
bar at the top of the Main Module.
Files Tab
General Tab
Options Tab
Totals Tab
Formations Tab
PdCum Tab
Leases Tab
P/Z Tab
Fm Subst Tab
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Status Tab

4.2.7.1

298 EZ Files Tab

The files tab selects the 298 file, and how the data should be imported. It’s possible
to load unallocated data, allocated data, or both allocated and unallocated data at the
same time. Selecting the type of import creates an entry box (or entry boxes) for the
298 file location.

The 298 EZ Files Tab

Load UN-ALLOCATED Production File Only – This option only loads unallocated data.
Selecting this option creates only a single entry box for the import file location.
Load ALLOCATED Production File Only –This option only loads allocated data.
Selecting this option creates only a single entry box for the import file location.
Allocated production will have a “A” prefix.
Load and SUM UNALLOCATED and ALLOCATED Production Files Together – This
option loads unallocated and allocated data simultaneously. There will be two entries
for the two files: Allocated and Unallocated.
When importing Texas data, use the “Allocated and Unallocated” option. For Texas
data, oil completions are only imported from the allocated data and gas completions
are only imported from the unallocated data. For wells completed as a gas well and
later recompleted as an oil well in the same formation, this import option will sum the
two together. Louisiana data can use either the “Allocated or Unallocated” option.
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298 EZ General Tab

The 298 EZ General Tab

Production Streams
Load Production into Standard OIL, GAS, WTR (WELL ZONE) – This option loads the
total production data into OIL, GAS, and WTR streams. This option sums production
from all formations together into a single stream.
Load Production into Individual Formation Names – This option creates separate
production streams for each formation. The Formation Tab selects the imported
formation production streams, and the annotation for the individual oil, water, and gas
streams.

Type of Production Loaded
This dropdown sets which data are loaded into the project. Petra can import monthly
production streams, cumulative production values, or both.

Method to Apply Lease Production to Individual Wells
Load Production into First Well Only Listed in Lease - This option stores production
only to the first well listed in the lease. Only use this option if the 298 file only has
single-well leases.
Load Production into Each Well in the Lease – This option divides the production for
the lease by the number of wells in the lease. As an example, in a lease containing 6
wells, each well receives 1/6th of the production.
Load Production into Each Well in the Lease – This option stores the total production
for the lease in every well in the lease. In a lease containing 6 wells, each well
receives all of the production – potentially multiplying the actual production.

Fluid Types (Streams) to Load
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These boxes set which fluid types are loaded, and how they are named. Note that
Petra automatically creates streams named OIL, GAS, WTR. For a different
production stream names, select the
button, and create a new monthly
production definition.

Setting a new fluid type

4.2.7.3

298 EZ Options Tab

The Options Tab sets a few additional options for how Petra uses the production
data.

The 298 EZ Options Tab

Load Production into INITIAL COMPLETION Wells Only – By default, Petra brings in
production from different completions as different wells. This option instead stores
production only to the primary completions (where the API number ends in 00).
Update OPERATOR and Save Current Operator as Historical Operator – When
there’s a difference between the current operator in the project and the current
operator in the 298 file, this option copies the operator in the project to the historical
operator field and overwrites the operator field with the data in the 298 file.
Load Producing Fm Name into Well Header – This option updates the database’s
producing formation (Prod. FM on the Well Tab in the Main Module) with the entry
from the production data.
Store Current Status into WELL Zone as PD STATUS – This option creates a data
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item called “PD STATUS” in the WELL zone. This text field stores I for inactive wells
and A for active wells.
Update Well SYMBOL CODE with Primary Product Code – This option changes the
well’s symbol code displayed on the map based on the Primary Product Code in the
298 file.
Store GATHERER in WELL Zone as GATHERER – This option creates a data item
called “GATHERER” in the WELL zone. This text field stores the name of the gas
gatherer.
Skip Lease Name Checking – When updating production, Petra checks the entire list
of lease names when it can’t match based on formation name. This can take a long
time depending on the size of the data set. This option skips this process.
Display Detail Info in Report – This option displays all monthly production values on
the import report.
Update Non-Blank Lease Number with UNIT WELL SERIAL NUMBER – This option
overwrites lease numbers with unit well serial numbers.
Do not use “A” in prefix/suffix to designate Allocated Production – By default, Petra
adds an “A” to allocated production. This option drops the A, making it
indistinguishable from regular unallocated production.
Use 12/10 Digits for Matching Initial Well Completions – This option is only used
when loading production into initial well completions only.
4.2.7.4

298 EZ Totals Tab

The Totals Tab stores information from the production data to zone data items.
Each data item is a fluid type prefix and the formation name. As an example, the Oil
from the Dakota D is stored as “O_602DKOTD” by default.

The 298 EZ Totals Tab

© 2014

Main Module

189

Zone for storing Totals – This dropdown selects the zone that will contain the
imported cumulative production data items.
CUM OIL – This option sets the prefix for cumulative oil values. By default it is “O.”
CUM GAS – This option sets the prefix for cumulative gas values. By default it is
“G.”
CUM WTR - This option sets the prefix for cumulative gas values. By default it is
“W.”
Lease Name – This option sets the zone data item for storing the lease name.
Lease Well Count - This option sets the zone data item for storing the lease well
count.
Prod ID - This option sets the zone data item for storing the production ID.
4.2.7.5

298 EZ Formations Tab

This tab lists the formations in the 298 file and their production stream counts. This
tab also establishes a formation substitution file and sets the names used in the
formation-specific production streams.

The 298 EZ Formations Tab

The Count/Name list shows all the formations in the 298 file, and is populated after
scanning the file. If nothing appears here make sure to select the “Scan File” button
on the Files Tab. Note that Petra lists the formation production data base on total
number of streams. Petra will only load the formations selected here.
Refresh with Translations – This option applies the active formation substitution file to
the formation names in the 298 file. Importantly, if a formation substitution file is
used once, it should always be used again.
FM NAME From – This dropdown sets how the formation production streams are
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named. These streams can use the standard IHS Fm Name Code, the description,
the age code, or the reservoir name.
Prod Stream Name Qualifier – This option sets the prefix or suffix used to signify the
different fluid types. By default, Petra uses O, G, W, and D to signify oil, gas,
water, and days on. Petra can set these qualifier characters as a prefix or as a
suffix to the name.
4.2.7.6

298 EZ PdCum Tab

This section allows the selections on how cumulative production values are loaded
into the PDCUM tab.

The 298 EZ PDCum Tab

Do Not Store in PdCum DB - This will not store any data into the ProdCum tab.
Store in PdCum Data using ProdID as FmName – This option stores cumulative
values by ProdID for individual leases/wells. The ProdId is stored in the FMNAME
column and the formation name will be stored into the ALTNAME column under the
ProdCum tab. Each lease will have an entry regardless of formation name.
Store in PdCum Data using ProdID as AltName – This option stores cumulative
values by formation name FMNAME for individual leases/wells. The ProdId is stored
into the ALTNAME column and the formation name will be stored into the FMNAME
column under the ProdCum tab. Each lease will have an entry regardless of
formation name.
Store in PdCum Data using FmName Only – This option stores cumulative values by
FMNAME. Any duplication of the formation names will be summed together and
stored as a single entry. The ProdId is NOT captured with this option.
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298 EZ Leases Tab

The Leases Tab displays the available leases in the 298 file. Here, select the lease
names you want to load. If nothing appears here make sure to select the “Scan
File” button on the Files Tab.

The 298 Leases Tab

4.2.7.8

298 EZ P/Z Tab

The P/Z Tab has a few options on capturing P over Z data for gas wells.

The 298 EZ P/Z Tab

Load P/Z Gas Cum Data – This option loads P/Z, Gas Cum, and BHP data. When
this option is deselected, these data streams won’t load into the project.
P/Z – This option sets the name for P over Z pressure.
Gas Cum – This option sets the name for the gas cumulative volume.
BHP – This option sets the name for the bottom hole pressure.
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298 EZ Fm Subst Tab

This tab sets up a formation substitution file. For more information on formation
substitution files, please see Formation Substitution Files under Common Import
Options.

Figure 138: The 298 EZ Fm Subst Tab

4.2.7.10 298 EZ Status Tab

The Status Tab displays the progress of the import.

Figure 139: The 298 EZ Status Tab

4.2.8

Import LAS Log Data File

The most common digital log format is the LAS file, which was codified as a
standard by the Canadian Well Logging society in 1990. LAS files store log data
about a single well in a single file with a multipart header at the top. The header has
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several different parts, each of which is prefixed by a tilde (~).
~V

- contains version and wrap mode information

~W

- contains well identification

~C

- contains curve information

~P

- contains parameters or constants

~O

- contains other information such as comments

It’s also not uncommon for LAS files to contain top information in a ~T section.
To import LAS files, select Project>Import Logs From>LAS File from the menu bar
at the top of the Main Module.
Import File Tab
Depths Tab
Options Tab
Import Headers Tab
Import Tops Tab
Units Tab

4.2.8.1

LAS Import File Tab

The Import File Tab shows the LAS header information and the available log curves in
the LAS file. Select the curves you want in the project on the “Select Curves To
Import” list on the right side of the screen. Note that you import any curve as a
different name by double-clicking the curve name.

The LAS Import File Tab
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LAS Depths Tab

The Depths Tab restricts the depth range, units of measurement, and sample rate of
imported log curves.

The LAS Import Depths Tab

Restrict Depths – This transformation sets the upper and lower limit of the imported
log data. Log data outside this range won’t be imported into the Petra project. The
depth interval can be specified in measured depth, TVD, or relative to formation tops.

To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TVD button. For MD and TVD, select the relevant
button and enter the adjacent depth in the entry field. For tops, select the desired top
from the “Fm Top Name” dropdown box. Notice that an offset can also be added or
subtracted to the fm top; this offset will include data points above or below the actual
fm top depth.
To set depths by a zone’s interval definition, select the desired zone on the “Set Upper
and Lower Depths From Zone” dropdown menu. Note that the WELL zone by default
covers -1M MD to +1M MD, so it should cover the entire footage of all wells.
Load Every N’th Sample – This option decimates the data to only keep every N’th
sample. Setting this value to 2, for instance, would only load every other sample.
Setting this value to 5 would only load every 5th sample. By default, this option is set
at 1 to load every sample in the curves.
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Resample to Sample Rate Below - This option resamples logs based on the number
of feet/meters per sample set in the “Imported Data Sample Rate” entry box. This
sample rate will use the depth units in the log curves. As an example, 5 feet per
sample results in one sample every 5 feet. Setting this field to 0.5 feet per sample
results in a sample every half foot.
Load Only Samples that are Multiples of Sample Rate Below – This option only loads
samples from the curves that are a multiple of the “Imported Data Sample Rate.” As
an example, with a sample rate of 1, Petra will only load data at 1 foot intervals.
Convert Depth Units and Load as – This dropdown imports the curves in a different
depth interval. “As Is” leaves the MD values as is and does not convert any depths.
The “Feet” option converts log curves measured in meters to feet. The “Meters”
option converts log curves measured in feet to meters.
4.2.8.3

LAS Options Tab

The Options Tab controls how Petra handles overlaps between curves already in the
database and the selected LAS file. This tab also enables a few options for loading
non-standard or oddly-formatted LAS files.

The LAS Options Tab

Import Mode – These options control how Petra handles overlaps between curves
already in the project database and the LAS file. The “Add or Replace” option
allows for the creation of new logs and will completely replace any overlapping curves
in the database with the LAS file data. “Add New Logs Only” only creates new logs;
when there’s an overlap between the database and the LAS file, the database won’t
change. “Merge into Existing Logs” does not create any new curves in the database,
and will merge data from the LAS file with the curves already in the database. This
merge operation can either prefer old values, non-null new values, or all new values.
“Add or Rename” allows for the creation of new logs, and will rename overlapping
curve names with a numerical suffix (like GR_1). For this example, select “Add or
Replace Logs.”
Load Complete LAS HEADER Section as a Text Block – This option stores the log
header as a block of text.
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Enable Sample Rate Round Off Correction Algorithm – Problems with rounding usually
cause missing depths in the curve. This option corrects for depth round off errors
caused by a non-standard sample rates (such as 0.1524), which are usually a
consequence of converting logs measured in one depth unit into a different depth unit.
Disable Error Scanning and Repair – By default, Petra scans for potential bad
characters in the curve data and looks for data that is not space delimited. These
conditions are not corrected if this option is checked.
Interpolate Missing Depths – This option interpolates values over missing intervals in
the LAS file. This interpolation simply repeats the last good value. Note that there
are more interpolation options inside Petra’s “preview” window available in the Main
Module.
Remove Special Characters From API Number - This option removes any nonnumeric
characters from the API number in the LAS file. Embedded blanks are converted to
underscores prior to matching wells in the database.
Scan Depths and Use Minimum Sample Rate Found – This option scans the depths
and determines the minimum sample rate.
Append Following Source To Curve Name – This option appends text to the end of the
loaded curves’ names.
4.2.8.4

LAS Import Headers Tab

The Import Headers Tab imports header information into the project zone data items.

The LAS Headers Tab

To use this tool, select an entry from the LAS file in the “LAS Header Data” list on the
left. Next, select the relevant well data entry or zone data item from the dropdowns
on the lower right corner of the screen. Next, select the “Add To List” button.
4.2.8.5

LAS Import Tops Tab

Some LAS files contain formation tops. The Import Tops Tab selects which tops are
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brought into the project.

The LAS Tops Tab

4.2.8.6

LAS Units Tab

This tab converts metric-imperial units for sonic and density logs, and decimal-percent
for porosity logs.

The LAS Units Tab

Convert Sonic (usec/ft) to usec/m - This option converts sonic logs in imperial units to
metric units.
Porosity Units Conversion – Percentages can be expressed on a 0-1 scale or on a 0100 scale, which can make calculations more difficult. This option converts curves
with PU, %, V/V, PCNT, PERC, or VOL. By default, the “Do Not Convert Porosity”
option is selected, which does not make any changes. The “Convert Porosity to
Percent (0-100)” multiplies the curve by 100; the “Convert Porosity to Decimal (0-1)”
divides the curve by 100.
Density Log Units Conversion – This option converts density units between imperial
and metric units. By default, the “Do Not Convert Density Logs” option is selected,
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which does not make any changes. The “Convert KG/M3 to gm/cc” converts metric
density curves to use imperial units. The “Convert gm/cc to KG/M3” converts imperial
density curves to use metric units.
4.2.9

Import Batch LAS
Petra can load in multiple LAS files in a single batch. This is useful for new projects,
but can lead to difficulty when a single well has multiple LAS files.
Files Tab
Options Tab
Depths Tab
Headers Tab
Tops Tab
Filter/Rename Tab
Units Tab

4.2.9.1

Batch LAS Files Tab

The Files Tab sets the list of LAS files that will be imported into the project. The
easiest way is to drag and drop the LAS files into the “Files To Import” window.
Selecting the “Explorer” button opens a Microsoft File Explorer window, while the
“Browse” button opens a dialog box to select one or more LAS files.

The LAS Batch File Tab

4.2.9.2

Batch LAS Options Tab

The Options Tab controls how Petra handles overlaps between curves already in the
database and the selected LAS file. This tab also enables a few options for loading
non-standard or oddly-formatted LAS files.
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The LAS Batch Options Tab

Curve Update Mode – These options control how Petra handles naming overlaps
between curves already in the project database and the LAS files. The “Add New
Curves and Replace Existing Curves” option allows for the creation of new logs and
will completely replace any overlapping curves in the database with the LAS file data.
“Add New Logs Only” only creates new logs; when there’s an overlap between the
database and the LAS file, the database won’t change. “Add New Curves and Merge
into Existing Logs” allows for the creation of new logs, and will merge data from the
LAS file with the curves already in the database. This merge operation can either
prefer old values, non-null new values, or all new values. “Add or Rename” allows for
the creation of new logs, and will rename overlapping curve names with a numerical
suffix (like GR_1). For this example, select “Add or Replace Logs.”
Enable Sample Rate Round Off Correction Algorithm – This option corrects for depth
round off errors caused by a non-standard sample rates (such as 0.1524), which are
usually a consequence of converting logs measured in one depth unit into a different
depth unit.
Disable Error Scanning and Repair – By default, Petra scans for potential bad
characters in the curve data and looks for data that is not space delimited. These
conditions are not corrected if this option is checked.
Interpolate Missing Depths – This option interpolates values over missing intervals in
the LAS file. This interpolation simply repeats the last good value.
Remove Special Characters From API Number - This option removes any nonnumeric
characters from the API number in the LAS file. Embedded blanks are converted to
underscores prior to matching wells in the database.
Scan Depths and Use Minimum Sample Rate Found – This option scans the depths
and determines the minimum sample rate.
Match UWIs if there is at Least a XX Percent Match – Since this tool can bring a large
number of LAS files at once, this tool allows some flexibility in matching UWI/API
numbers from the LAS files to those in the project. By default, Petra looks for an
80% match between the LAS UWI/API and the project well’s UWI/API.
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Read Headers as Version – This option sets the version number for the LAS files. For
reference, LAS version 1.2 was introduced in 1990, and LAS version 2.0 was
introduced in 2009. When in doubt, an individual LAS file’s version is listed at the
beginning of every file.
Load all Logs into Original Well Completions – By default, Petra loads the curve
names into the well that matches the LAS file’s API/UWI number. This option instead
loads the curves into the primary completion.
Append Following Source To Curve Name - This option appends text to the end of the
loaded curves’ names.
4.2.9.3

Batch LAS Depths Tab

The Depths Tab restricts the depth range, units of measurement, and sample rate of
imported log curves.

The LAS Batch Depths Tab

Restrict Depths – This transformation sets the upper and lower limit of the imported
log data. Log data outside this range won’t be imported into the Petra project. The
depth interval can be specified in measured depth, TVD, or relative to formation tops.

Setting depths

To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
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select the relevant top, MD, or TVD button. For MD and TVD, select the relevant
button and enter the adjacent depth in the entry field. For tops, select the desired top
from the “Fm Top Name” dropdown box. Notice that an offset can also be added or
subtracted to the fm top; this offset will include data points above or below the actual
fm top depth.
To set depths by a zone’s interval definition, select the desired zone on the “Set Upper
and Lower Depths From Zone” dropdown menu. Note that the WELL zone by default
covers -1M MD to +1M MD, so it should cover the entire footage of all wells.
Convert Depth Units and Load As - This dropdown imports the curves in a different
depth interval. “As Is” leaves the MD values as is and does not convert any depths.
The “Feet” option converts log curves measured in meters to feet. The “Meters”
option converts log curves measured in feet to meters.
Resample Incoming Curves to Common Rate – This option resamples incoming curves
to a single common sample rate. As an example, with a sample rate of 1, Petra will
resample the curve data to 1 foot/meter intervals.
4.2.9.4

Batch LAS Headers Tab

The Import Headers Tab imports header information into the project zone data items.

The LAS Batch Headers Tab

To use this tool, select the “Load Complete LAS HEADER Section as a Text Block”
button. Next, select the relevant well data entry or zone data item from the
dropdowns on the lower right corner of the screen. Next, select the “Add To List”
button.
4.2.9.5

Batch LAS Tops Tab

Some LAS files contain formation tops. The Import Tops Tab selects which tops are
brought into the project.
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The LAS Batch Tops Tab

4.2.9.6

Batch LAS Filter/Rename Tab

The Filter/Rename Tab sets how Petra uses a “curve translation” file to rename
incoming logs. Curve restriction lists establish a set of rules for how Petra renames
curves from the LAS files when they come into the project. This can be useful for
reducing the total number of digital log curve names in a project.
Curve translation files are relatively simple – they just establish the name of the curve
as it appears in the LAS files and the desired name in the project. As an example,
Reeves wireline logs name their gamma ray curves as “GRGC.” Creating the entry,
“GRGC=GR” will rename all “GRGC” as “GR.” The example below (right) shows a
curve translation file.

Setting a curve translation file (left) and an actual curve translation file (right)

Rename Curves – This option tells Petra to use the translation file to rename the
curves.
Restrict Import to Curves Listed in Translate File – By default, Petra will import all
curve names in all files, but will rename the curves on the curve translation file. This
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option makes the import more restrictive; only the curves on the curve translation file
are imported.
4.2.9.7

Batch LAS Units Tab

This tab converts metric-imperial units for sonic and density logs, and decimal-percent
for porosity logs. For the porosity curve decimal-to-percent correction, Petra uses
the units listed in LAS file header’s curve information.

The LAS Batch Units Tab

Porosity Units Conversion – Percentages can be expressed on a 0-1 scale or on a 0100 scale, which can make calculations more difficult. This option converts curves
with PU, %, V/V, PCNT, PERC, or VOL. By default, the “Do Not Convert Porosity”
option is selected, which does not make any changes. The “Convert Porosity to
Percent (0-100)” multiplies the curve by 100; the “Convert Porosity to Decimal (0-1)”
divides the curve by 100.
Density Log Units Conversion – This option converts density units between imperial
and metric units. By default, the “Do Not Convert Density Logs” option is selected,
which does not make any changes. The “Convert KG/M3 to gm/cc” converts metric
density curves to use imperial units. The “Convert gm/cc to KG/M3” converts imperial
density curves to use metric units.
4.2.10 Import Log Curves From ASCII File
Though most log curves are stored in the *.LAS format, some log curves are stored
as *.TXT or *CSV files. The Import Log Curves tool imports digital log curves from
non-LAS ASCII files. The format of the file can be either tabular in nature (fixed
column) or values separated by commas (comma delimited).
This tool can also handle isolated depth-value pairs (like sidewall cores), or "from-to"
intervals.
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File Tab
The File Tab sets the file, the destination well, update mode, and other basics of the
data import.

The Import Log Curves From Tabular File Format File Tab

Load Data Into Well - This drop down box defines which well will receive the imported
log data. This list will display all the wells currently selected in the Main Module.
File To Import - The "Open File" button opens a dialog box to select the desired file.
The selected file and pathway is displayed to the immediate right.

Curve Update Mode
This section defines the method for updating the existing log curve database.
Add or Replace Curves In Database - This option will add new log curves will be
added to the database and imported logs will overwrite existing log curves.
Add New Curves Only - This option will only add new logs to the database. Existing
log curves in the database will not be overwritten.
Merge Curves with Database Curves - This option will merge imported depth intervals
into the logs already in the database curve. Additionally, new log curves will be
added. The dropdown to the right controls which values are preferred.
On Merge, Old Values are Preferred - When old and new log data overlap, Petra will
keep the older values already in the database.
On Merge, Non-Null New Values are Preferred - When old and new log data overlap,
Petra will overwrite only nulls in the database with the newer values.
On Merge All new values are Preferred - When old and new log data overlap, Petra
will overwrite older values with the newer values.
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Original Data Is Sampled As
This entry determines the general type of data imported into the well.
Constant Sample Rate - This option imports data from the file into a continuous single
curve. This option is used for wireline logs, and also for "from-to" pairs that have a
continuous value "from" one depth "to" another depth (like mudweights).
Discrete Points - This option imports data from the file as disconnected data points.
This is useful for isolated petrophysical measurements or sidewall cores. When
loading discrete data, make sure to turn off the "Allow Resampling Mismatched
Depths" and the "Determine Sample Rate From Data" option. On the "Sample
Increment" entry, specify the smallest multiple of the depth interval. As an example,
samples at foot intervals should have a sample rate of 1. Samples measured at at
quarter foot intervals should have a sample rate of 0.25. For sample rates below
0.05, simply type in the desired number. Note that Petra can only handle 128000
discrete points in a curve. The curve will be truncated beyond the first 128000
samples.

Depths
The depth section defines the depth units and resulting sample increment of the
imported data.
Units - This option selects the depth units of the imported log curve.
Sample Increment - This option sets the sample rate of the curve in Petra's database
in depth units per sample. The increment must be equal to or less than the rate of the
imported data. If the specified rate is greater than the data rate, Petra will use the
data sample rate.
Allow Resampling Mismatched Depths - This option will resample data samples that
do not fall on even sample increments. Most commonly, uneven sample depths are
caused by converting MD/TVD from feet to meters or meters to feet. When
importing discrete data points, make sure this option is turned OFF.
Determine Sample Rate From Data - This option will search the input data file to
determine what the smallest sample increment should be to store the curve without
resampling it. Three methods are available:
Using Smallest Depth Increment - The smallest difference between any two samples
will be used as the sample rate. For example, given depths 1002.20, 1003.00,
1004.05, 1004.07, the chosen sample rate will be 0.02 (difference between 1004.05
and 1004.075).
Using Smallest Multiple of Depths - The smallest fractional portion of all the depths is
used as the sample rate. Given the above example, the sample rate will be 0.05.
Using Start-Stop Depths and Number of Points - The sample rate is computed by
(stop_depth - start_depth) / (num_pts-1).
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Data Tab
The Data Tab sets the specific fields and curves in the file for the import.

The Import Log Curves From Tabular File Format Data Tab

Log Curve - Data Record Field Definitions
Recall that this tool can either use tabular (fixed column) or comma/tilde-delimited
type ASCII data file. Columnar files separate different curves with empty space; for
these files, Petra distinguishes between different entries on a row with specific start
and stop column numbers. Comma- and tilde-delimited files separate different curves
with characters; for these files, Petra distinguishes between "fields" by counting the
number of commas.
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A columnar log file (Left) and a comma-separated log file (Right)

To add a field definition for a comma- or tilde-delimited file, select the desired field in
the Data Record window. Next, select the relevant data type on the set of dropdown
menus on the right. Select the “+” add button to add the definition to the "Field
Definitions" list box. Note that Petra counts the number of commas to establish a
Field Number. As an example, the Depth values are in field 1, while the GR curve
values are in field 3.

Importing a columnar log file

To add a field definition for a columnar file, swipe relevant data field on the Data
Record window. Note that Petra fills in the “Start Column” and “End Column.” Next,
select the relevant data type on the set of dropdown menus on the right. Select the
“+” add button to add the definition to the "Field Definitions" list box. Note that Petra
counts the number of commas to establish a Field Number. As an example, the Depth
values are in field 1, while the GR curve values are in field 3.
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Importing a columnar log file

In both cases, to modify a field definition, use the
replace button to replace the
currently selected field definition with the selected entry on the import file and data
type. To drop a field from the list, select the desired definition and select the “-“drop
button.
Depth 1 - Depth 1 (required) is the normal depth for single depth datasets and the
"from" depth for files containing "From-To" depths.
Depth 2 - Depth 2 (optional) is the "to" depth for files containing "From-To" depths.
Format - This dropdown specifies whether the data is Columnar or Comma Delimited.

Data Record
Format - This dropdown sets whether the data type is "columnar" and organized in
fixed columns, or "Comma Delimited" and separated by commas.
Null Value Indicator - Specify the text string contained in the input file that is to be
interpreted as a null value.
Missing Data Tool - Specify how missing data sections (gaps between depths) are
processed. Options are available to leave the gaps as null values, fill the gaps using
the previous non-null value, or to interpolate good values across the gaps.
Records to Skip Before 1st Depth - This option allows header or comment records to
be skipped at the beginning of the data file prior to the first true data record. Click the
"Set Skip" button to set the number of skipped records based on the record currently
in the data record window.
Data Window - This section primarily is used to scroll through the data file and select
data field columns. Use the up and down arrows located to the right of the record
window to read foreword or backward in the file. The data record can be scrolled left
or right by placing the cursor in the record window and using the left or right cursor
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keys.

Saving and Loading Field Definition Templates
Since creating a long list of field definitions can be tedious, it’s a good idea to save
your work. Petra can save these column and field definitions as a template “Format
File” with a *.FMI extension. By default, Petra stores template files to the private
parms directory. To save a field definition template file, select the Save button. To
load a pre-existing format template, select the Load button.

Options Tab
The Options Tab controls how Petra handles characters at the beginning of UWI/API
numbers in the file.

The Import Log Curves From Tabular File Format Options Tab

Remove the Following Special Characters From the UWI (or API#) - This entry sets
the characters that Petra ignores at the beginning of the UWI/API numbers.

Report Tab
The Report Tab displays the results of the import process. Before importing a log
file, this tab will be blank.
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The Import Log Curves From Tabular File Format Reports Tab

4.2.11 Import LIS Log Data File
LIS files are a fairly rare digital log format. This file format predates LAS and is
based on storing data on magnetic tape; individual well logs are separated by reel,
tape, and file numbers. Unlike LAS files, LIS files are binary files and can’t easily be
read as ASCII text in NotePad or WordPad.
Like all digital curves, Petra loads all the selected log curves into the project
database. As such, it isn’t necessary to maintain a network-accessible folder for
digital log curves like it is with raster log curves.
Logs Tab
Headers Tab
4.2.11.1 LIS Logs Tab

The Logs Tab sets the basics for importing LIS files.

The LIS Logs Tab

Load File Into Well
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On this dropdown, select the well in the project where the curves will be stored.

LIS File
To select the LIS file for import, select the “Browse” button and navigate to the file.
By default, Petra will automatically scan new files for logs and comments. To disable
this scan, select the “Auto Scan” button.

Depths
To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TVD button. For MD and TVD, select the relevant
button and enter the adjacent depth in the entry field. For tops, select the desired top
from the “Fm Top Name” dropdown box. Notice that an offset can also be added or
subtracted to the fm top; this offset will include data points above or below the actual
fm top depth.
To set depths by a zone’s interval definition, select the desired zone on the “Set Upper
and Lower Depths From Zone” dropdown menu. Note that the WELL zone by default
covers -1M MD to +1M MD, so it should cover the entire footage of all wells.
Load Every N’th Sample – This option decimates the data to only keep every N’th
sample. Setting this value to 2, for instance, would only load every other sample.
Setting this value to 5 would only load every 5th sample. By default, this option is set
at 1 to keep every sample in the curves.
Add or Replace vs. Merge Logs With Existing Data – These options control how Petra
handles overlaps between curves already in the project database and the LAS file.
The “Add or Replace” option allows for the creation of new logs and will completely
replace any overlapping curves in the database with the LAS file data. “Add New
Logs Only” only creates new logs; when there’s an overlap between the database and
the LAS file, the database won’t change. “Merge into Existing Logs” does not create
any new curves in the database, and will merge data from the LAS file with the curves
alreadyin the database. This merge operation can either prefer old values, non-null
new values, or all new values. “Add or Rename” allows for the creation of new logs,
and will rename overlapping curve names with a numerical suffix (like GR_1). For this
example, select “Add or Replace Logs.”
4.2.11.2 LIS Headers Tab

The Headers Tab loads header information from the LIS file into the well. Select the
“Scan File” button to find header information. Next, select the header information in
the window in the middle of the screen, and select the destination of the relevant
headers in the file.
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The LIS Headers Tab

4.2.12 Import AccuMap Data into PETRA
Export data from AccuMap into Petra using an automated process that prompts you
for AccuMap export details, launches Petra, and then prompts you for Petra import
details. The spatial extents of the data are defined by the bounding wells in the list.
Data includes well, production, grid, culture, Open Layers, and shapefile data in
NAD83 or NAD27 format.
Export functionality is available in AccuMap using either the Detail Map menu, or Well
List Manager.

Petra creates new projects by default in the directory specified in the registry. To
specify a different location, add the following to the Petra.ini file found in the Petra
installation location (either on the server for a network setup, or on the local machine
for a standalone setup):
[ACCUMAP]
PRIVATE_PATH=c:\Geoplus1\Projects
PUBLIC_PATH=c:\Geoplus1\Projects

To import AccuMap data into Petra using a well list
1. With the Petra application closed, using AccuMap and depending on whether you want to
use the Detail Map menu or Well List Manager, do one of the following:
Detail Map menu: Select Detail Map > Well Lists > Launch Petra, and using the Launch
Petra with Well Lists dialog box that appears, select the desired well list, and then click OK.
Well List Manager: Select Tools > Well List Manager.
The Well List Manager dialog box appears and the main menu bar options change to reflect
Well List Manager options.
Select Well List Manager > Well List > Open, and select the desired well list. Data is
exported using the datum option defined in the Datum Settings pane of the AccuMap
Defaults dialog box (Edit > Defaults menu). To select different options, from the Well List
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Manager menu, select Export > Coordinate Info.
Select Well List Manager > Export > Launch Petra.
2. Using the Petra Launch Options dialog box, select import options.

3. Select the types of data to include.
If you select Additional User Tops, in the left window, select a users database of tops
and click Add.
If you select Open Layers / Shapefiles, click Select Files to display the Select Open
Layers / Shapefiles for Petra Export.
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Select whether to display Open Layers and Shapefiles below the Available Files pane,
select the desired files, and then click Add (or simply click Add ALL to copy all files
displayed in the Available Files pane), and then click OK.
4. Using the Petra Launch Options dialog box, click OK.
Petra automatically launches and begins importing AccuMap data. Petra displays import
statistics and then prompts you to load the AccuMap data.
5. Select Yes.
The Import Petra AccuMap File dialog box appears.

Generally the default options are appropriate; however, click below for a description of the
various options on each tab:
Import Petra AccuMap File: Options
Import Petra AccuMap File: Fm Substitute
Import Petra AccuMap File: AccuMap
Import Petra AccuMap File: Misc
Import Petra AccuMap File: Elev Trans
Import Petra AccuMap File: Dir Survey
6. Click OK to dismiss the Import Petra AccuMap File dialog box and load the well data.
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The AccuMap Petra Production Import dialog box appears.

7. Select the desired production data to import, and ensure Convert Canadian UWIs from
"Display" to "Raw" Form is selected on the File tab.
Load all of the available production streams and cumulative production values in the
Production and Injection tabs. Click below for a description of the various options on each
tab:
AccuMap Petra Production Import: File
AccuMap Petra Production Import: Production
AccuMap Petra Production Import: Injection
AccuMap Petra Production Import: Gas Analysis
AccuMap Petra Production Import: Gas Composition
AccuMap Petra Production Import: AOF
8. Click OK to dismiss the AccuMap Petra Production Import dialog box, and then click OK to
dismiss the confirmation message and finish loading the well data.
The Petra Main Module appears when the data finishes loading.
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9. Using the Main Module, click the Mapping button (
load AccuMap grid and culture files.

), and click Yes when prompted to

The Import Cartographic Data dialog box appears.
10.Select the manner in which to process imported cartographic data, and then click Import.
Click below for a description of the various options on each tab:
Import Cartographic Data: File
Import Cartographic Data: Limits
Import Cartographic Data: Layers
Import Cartographic Data: MISC
Import Cartographic Data: T-R-S
Import Cartographic Data: Translate
If culture was included in the original AccuMap export, the Import Cartographic Data dialog
box appears a second time with AccuMap Culture File (CDF) displayed in the File Type
drop-down list on the File tab and additional tabs to review.
11.Select Replace Current Layer Data with the Imported Data in the Layer Update Mode
pane and select an unassigned layer (Layer #X, where X is a sequential number), and then
click Import.
The map appears.
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4.2.13 Import Uncalibrated Raster Logs
Working with images without depth-calibration points can be labor intensive, since
every image needs to depth calibrated and named.

Getting Ready
1. On the Main Module, select the Rasters Tab.
2. Select “Assign/Calibrate…” button on the lower left hand corner of the window to
open the “Calibrate Log Image” tool.
3. Here, select the
button on the toolbar. Alternatively, select File>Open on the
menu bar at the top of the screen. Next, navigate to folder containing the images
and select the desired image file. By default, Petra will look in the the project’s
IMAGES folder.

Opening a TIF image

It’s usually worthwhile to spend a few seconds scrolling up and down through the
image to see what’s actually there. Usually, raster images store a complete copy of
the scanned paper log, which can contain the same log at different scales as well as
repeat sections.

Adding Depth Calibration Points
4. A scanned log is just an image, so Petra needs a way to know how the image
corresponds to depth. Select the “Add” button on the right side of the screen; note
that this turns the mouse pointer into a line. Click right on the 1200’ marker, and
enter in the depth.
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Adding a depth calibration point to a raster

5. Scroll down the image to 5400’MD, and add another depth calibration point. Notice
that Petra automatically extrapolates depths between two depth points, which are
marked with thin black lines. Commercially depth-calibrated logs often have dozens
of calibration points, most of which are unnecessary. Well-scanned logs that
minimize image stretch really only need a few points. In our case, the calibration is
pretty good for most of the depth range, but could use improvement. Add more
depth calibration points where the calibration is off (around 2400’MD and
4900’MD).

User-created depth calibration point (in red) with extrapolated depth markers (in black)

6. Now that the top part of the well is calibrated, scroll to the 5” section, and add a
calibration point just a little below the 5400’MD line. Put the depth in as 5401’MD.
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Adding a Depth Calibration point

7. Add a point at the TD marker at 6424’MD and at a few more points to get a good
calibration to the image. Again, add depth calibration points where the black lines
are off the 100’ intervals on the log. Notice that Petra will add thick black lines in
the correlation – these are actually the tops we imported earlier.

Adding depth calibrations points on the 5" part of the raster log. Notice the DKOTD and SKCK tops.

8. Select the “-“ button to zoom out on the section. Right now, we have two sets of
depth calibration points over the image: a shallow set over the 1” log, and a deeper
set over the 5” log. In between, there’s a lot of extraneous information that we’d
rather just cut out. Select CTRL and click somewhere in the region between the
shallow and deep set of calibration points. Notice that the section goes dark,
signifying that it won’t display on cross sections. In our case, this will just keep the
entire section from being crammed into a tiny sliver between 5400’MD and
5401’MD, but this technique can be really useful to cut out other extraneous parts
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of an image. This technique is also useful for cutting out a repeat section between
one run and the next.

9. Select the “+” button to zoom back into the image. The next step is to add scales.
Petra can draw both an upper scale and a lower scale on the same cross-section.
Scroll to the bottom of the depth calibration points. On the “LwrScl” section, select
the “Top” and “Bottom” buttons to set the boundaries of the upper scale marker.
Next, scroll to the top of the image. On the “UprScl” section, select the “Top” and
“Bottom” buttons to set the boundaries of the upper scale marker.

10.Scroll to the very top of the image. Add the top and bottom of the header with the
“Top” and “Bottom” buttons in the “HDR” section.
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Setting a header

11.The final step is to add a group name. Group names usually describe the depthcalibrated part of the image – usually by describing the scaling or the curves. Right
now there’s only one group name – “DEFAULT.” On the menu bar at the top of the
screen, select Group>Add or Delete Groups.
From a user-perspective, group names are a way of comparing similar raster images
from one well to another. Though commercial vendors generate thousands of unique
group names for every combination of tool and scale, it’s usually better to have fewer,
more general group names rather than many excruciatingly exact ones. In the Image
Group Name entry, type in “Induction”, and select the Add button.

Adding the "Induction" group name

12.Select the Done button. Back in the Calibration tool, use the group name
dropdown and select “Induction.” Select the
button to save the calibration to
the group name. Behind the scenes, Petra’s actually creating a LIC file that saves
these calibration points – the location of which is shown in the “Save File As”
window.
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Saving the calibration to the "Induction" group name

4.2.14 Import Interval Data
New interval data can be brought into Petra either manually or by a tabular data
import.

Adding New Data Manually
To add new intervals manually, first select the correct well in the Main Module. On
the Interval Tab, select the right interval table. In the example below, the “LITH” table
is selected. Finally, select the “Edit details” button in the upper right on the Interval
Tab. This brings up the Edit Interval Data window for the selected interval table.
Continuing with the example, the Edit Interval Data window below shows the fields for
only the LITH table.

To add a new interval, enter in the Top and Base. Next, select the
the interval.

button to add
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With the interval now added, enter in the remaining interval details and select
button to save the changes to the interval. In the example below, the Quality,
Formation, and LITH Table specific fields are filled in.

To save the changes to the database, select OK. Here, Petra gives the option to
save or discard ALL changes made to the selected well’s interval table. All the edits
to all intervals will be ignored if you select CANCEL.

Importing Tabular Interval Data
Digital data where each row contains information about a discrete interval can be
easily imported into Petra. Before attempting to import interval data, check to see if
the data has a column dedicated to the UWI/API. Since Petra assigns interval data to
specific wells by comparing UW/API numbers, interval data without an identifying API/
UWI column can’t be imported. The easiest way to remedy this is to simply open the
interval data in a spreadsheet program, and add a new column for well UWI/API.
To import new digital interval data, select Project>Import>Import Tabular Interval
Data… on the menu bar at the top of the Main Module. This opens the “Import
Interval Data from Tabular File Format” box. Here, select the “Open File” button and
navigate to the interval data’s location.
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Once the file containing the interval data is opened, Petra switches to the Data
Format Tab. This tab essentially links the entries in the file to specific kinds of data.
The first step is to select the interval data file’s formatting under File Format. Files
can be imported into Petra in one of three formats: “Columnar”, “Comma Delimited”,
or “~ Delimited.” Columnar data organizes data into fixed columns, where Petra
imports data based purely on the number of characters from the left. The left
screenshot, on the other hand, shows the API number as defined by columns 1
through 14.
Comma and ~ delimited data, on the other hand have no fixed column size and are
instead separated by a comma or a tilde. With delimited data, Petra imports data
based on the “Field” defined by the delimiter. The example below shows the same
UWI/API field defined in two different ways. The right screenshot shows the API
number defined as “Field (1)”, i.e. it is separated by the first comma.

Be careful when importing text as a comma delimited file. If the text has a comma in
it, Petra will read that as the end of the field. The interval data stored as UWI, Top,
Base, Description such as:
05123187700000, 6295, 6998, Calcareous, micaceous, clay-rich siltstone
Would only be imported as:
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API: 05123187700000
Top: 6295
Base: 6998
Description: Calcareous
In other words, all the description past the first comma is cut off. This can also cause
bad imports when data is beyond the comma-filled text.
The next step is to establish field definitions. Essentially this step defines which part
of the file is which kind of interval data. The easiest way is to select and highlight the
specific data field in the “Data Record” part of the screen, then select the type of
interval data on the left. Petra can import fields for any interval table. In order to put
interval data with the correct well, the UWI or API # field must be defined.
When loading the TOP and BASE of the interval, Petra assumes that the depths are in
MD. To import other depths, such as SS or TVD, select the appropriate depth on the
“Field is not a Depth or is MD” dropdown when establishing a field definition.
For user-defined fields (Not the TOP, BASE, DATE1, DATE2, QUALITY, FM NAME,
UNITS fields), Petra can store a quality code. To import the quality code, select the
“Store Field Value” dropdown menu and set it to “Store Field Quality Code.”
To add the field definition, select the “+” button. The “-“ button drops the selected
field definition. To modify an existing field, make the appropriate changes and select
the

button.

The example below shows field definitions for the data file, which include the well API,
interval top, interval base, formation name, and description.
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To save the field definitions and options, select the “Save” button. This option saves a
*.FMI file. Selecting the "Load" button restores all the saved settings.
Most data files have some header or comments at the top. The “Records to Skip
Before 1st Well” option tells Petra to skip a set number of lines before importing any
well data. Click the "Set Skip" button to set the number of skipped records based on
the record currently in the data record window,

4.3

Exporting Data
Petra can export project data to a variety of data formats. Petra's export tools are
available at Project>Export> on the menu bar at the top of the Main Module.
Export Petra Project File
Export Petra Template File

Export Tabular ASCII File
Export ASCII Tops File
Kingdom Export
Export Zone Data
Landmark 29 File
Landmark OWX File
Export Log Curves
Monthly Production
Directional Survey
Top Definition
Perfs, Cores, Casing, Liner, IP, DST
Interval Data
SCA - MCS Z Data
GES Wellbase V2
Velocity Data
Well Remarks
4.3.1

Export Petra Project File
This tool exports the data in a project to a single Petra project file (*.PPF). This is a
good way of bundling a project's data into a single large file, which can be
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considerably easier to work with than an entire database file.
To create a PPF file, select Project>Export>Petra Project File (*.PPF) from the menu
bar at the top of the Main Module.
On the "Select Petra Project File to Export" window, select the file name and location
for the PPF file.

Data Tab
The Data Tab sets the location of the exported file, and the specific data to export
from the project data.

Export Project File To - This entry selects the location and PPF file name. To open
the windows explorer, select the "browse" button.
Optional Data to Export - This entry sets the specific data to include in the PPF file.
This can include most data in a Petra project. Note that the "None" and "All" select
none of the checkboxes and all of the checkboxes, respectively.

Dates Tab
The Dates Tab limits the some of the data included in the PPF file to data created or
changed within a specific range. This includes well header information, locations,
directional survey data, tops, zone data items, and digital logs. This can be useful for
creating update files or backups.
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Restrict Wells Exported Based On Change Date of Well header Data - This option
limits the file only to well data with a header change date inside the set range. This
change date is visible on the Main Module's Well Tab. Note that the export tool will
list that it's exporting all currently selected wells, even if it is only including a small
subset within the date range.
Export Well Data Items Based on Item's Change Date - This option will include all
wells in the project, along with all logs, tests, and production data. It will also include
all entries for all zone data items and formation tops, but these entries will only be
filled with data with a change date inside the date range. Note that the export tool will
list that it's exporting all currently selected wells, even if it is only including a small
subset within the date range.

From Date/Through Date - These entries set the actual date range for the export.
Note that this tool uses a MM/DD/YYYY format.

Dir Survey
Petra can store multiple directional surveys (both real and planned) for any well. This
tool can export any or all of the directional surveys for all wells. The Dir Survey Tab
sets the specific surveys exported to the file.
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Export All Surveys Available for Each Well - This option will include all surveys loaded
in the project, including all active and secondary surveys.
Export 'Active' Survey Only - This option will export only the active surveys.
Export Selected Survey From List Below - This will export only surveys with the
survey definition selected on the dropdown below.

Misc
The Misc Tab controls a few additional options for exporting data, including encryption
and memory uses.

Encrypt Well Identifiers - PPF files are plain text files. This option encrypts the well's
UWI, well name, number, label, operator and lease. This option does not encrypt
location data.
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An encrypted PPF file (left) and an unencrypted PPF file (right)

Number of wells to process at once - This dropdown sets the number of wells to
process before writing to the PPF file. Increasing this number will increase the
amount of memory used in the export.
4.3.2

Export Petra Template File
This tool exports the project database structure settings to a single Petra Template
File (*.PTF). In essence, a template file stores an empty shell of a project containing
empty zones, data items, top definitions, map projections, and other settings without
wells or any actual data.
To create a PPF file, select Project>Export>Petra Template File (*.PTF) from the
menu bar at the top of the Main Module.
On the "Select Petra Project File to Export" window, select the file name and location
for the PTF file.

Data Tab
The Data Tab sets the location of the exported file, and the specific data to export
from the project data.
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Export Project File To - This entry selects the location and PTF file name. To open
the windows explorer, select the "browse" button.
Optional Data to Export - This entry sets the specific data to include in the PTF file.
This can include most data in a Petra project. Note that the "None" and "All" select
none of the checkboxes and all of the checkboxes, respectively.

Dates Tab
The Dates Tab limits the some of the data included in the PTF file to data created or
changed within a specific range. This includes well header information, locations,
directional survey data, tops, zone data items, and digital logs. This can be useful for
creating update files or backups.

Restrict Wells Exported Based On Change Date of Well header Data - This option
limits the file only to well data with a header change date inside the set range. This
change date is visible on the Main Module's Well Tab. Note that the export tool will
list that it's exporting all currently selected wells, even if it is only including a small
subset within the date range.
Export Well Data Items Based on Item's Change Date - This option will include all
wells in the project, along with all logs, tests, and production data. It will also include
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all entries for all zone data items and formation tops, but these entries will only be
filled with data with a change date inside the date range. Note that the export tool will
list that it's exporting all currently selected wells, even if it is only including a small
subset within the date range.

From Date/Through Date - These entries set the actual date range for the export.
Note that this tool uses a MM/DD/YYYY format.

Dir Survey Tab
Petra can store multiple directional surveys (both real and planned) for any well. This
tool can export any or all of the directional surveys for all wells. The Dir Survey Tab
sets the specific surveys exported to the file.

Export All Surveys Available for Each Well - This option will include all surveys loaded
in the project, including all active and secondary surveys.
Export 'Active' Survey Only - This option will export only the active surveys.
Export Selected Survey From List Below - This will export only surveys with the
survey definition selected on the dropdown below.
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Misc Tab
The Misc Tab controls a few additional options for exporting data, including encryption
and memory uses.

Encrypt Well Identifiers - PPF files are plain text files. This option encrypts the well's
UWI, well name, number, label, operator and lease. This option does not encrypt
location data.

An encrypted PPF file (left) and an unencrypted PPF file (right)

Number of wells to process at once - This dropdown sets the number of wells to
process before writing to the PPF file. Increasing this number will increase the
amount of memory used in the export.
4.3.3

Export Tabular ASCII File

The Export Tabular ASCII File exports header and zone data items in a Petra project
to an external TXT file. This file can either be column or comma delimited.
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Data tab
The Data tab sets the specific zone data items for export.

The Export Tabular ASCII File Data Tab

Output File Group
This entry sets the name and location of the exported file. Select the Browse button
to navigate to the desired directory and to select the file name.

Data Columns To Output Group
This section displays the data items that will be exported to the file. To add items to
this list, use the Select Data Items
To add a data item, select the desired item in the Select Data window. Select the
“+” add button to add the definition to the "Field Definitions" list box.
To remove a data item, select the desired field in the Data Columns To Output
window. Select the “-” drop button to remove the item from the Data Columns to
Output list.
In both cases, to modify a field definition, use the
replace button to replace the
currently selected column with the selected entry on the Select Data list.

Select Data Group
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Well Header/Surface Locations/Bottom Hole Locations/Mechanical/
Miscellaneous
This section contains the various data types which can be exported. For each column
to output, select the data in the well header list or the Z data list and click the Add
button. You can change a previously selected column by clicking once on the Data
Columns to Output list box, changing the data options in the "Select Data section"
then clicking the Replace button. Columns can be dropped from the list using the
Drop button.
Formation tops may be exported as either measured depth or subsea depth. Check
the TVD Subsea Top option to export a subsea top.
The Column Width field allows you to specify the number of characters in each
column.
The Decimal Places option allows to numeric columns to define the number of digits
to the right of the decimal point.
The Numeric NULL Value field is used to specify a special character string to
represent NULL values in the output file. The default leaves a blank field for any
NULL values.
The objective is to define each column of the exported file in terms of which Petra
variable, column width and numeric representation. As each column is defined, it will
appear in the list box on the left. Choose the OK button when ready to export the
data.

Save - This option saves the export format to an external file.
Load - This option loads an export format from an external file.

Options Tab
The Options Tab controls a few additional parameters on how Petra creates the
external file.
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The Export Tabular ASCII File Options Tab

Export Tops Using Aliases - This option will use top aliases for the export.
Lat-Lon as Deg Min Secs - By default, Petra exports LatLons as degree decimals.
This option will instead export Latitude and Longitude as degrees:minutes:seconds.
Make File Comma Delimited - This option separates entries inthe export file with
commas rather than tabs.
Convert Double Single Quotes to Single Double Quote - This option converts two
single quotes into a double quote.

Include Perf Type with Pefs - This option adds an additional field for perf "Type"
column.
Include Perf Source with Perfs - This option adds an additional field for the perf
"Source" column
Include Perf "Nbr Shots" field - This option adds an additional field for the perf "Nbr
Shots" field from the Perfed Intervals detail tool.
Include Perf Remark with Perfs (first 40 chars) - This option adds an additional field
for the perf "Remarks" field from the Perfed Intervals detail tool.
4.3.4

Export Kindom File
This tool exports the well data in a project to a Kingdom Petra Link folder in a SMT
Kingdom project.
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To create a Kingdom well data *.asc file, select Project>Export>Kingdom Export from
the menu bar at the top of the Main Module.

Data Tab
The Data Tab sets the location of the exported file, and the specific data to export
from the project data.

Select Kingdom Project File (.tks) - This entry selects the location of the Kindom
project's *.TKS file. Selecting this project file will then populate the "Date Exported
To" location.
Data Exported To - This entry shows the location of the created well data file, which
will always be named "PetraData.asc"
Optional Data to Export - This entry sets the specific data to include in the well data
file. This can include most data in a Petra project. Note that the "None" and "All"
select none of the checkboxes and all of the checkboxes, respectively.
Select Tops - This entry selects the Select Zone Item List to add tops to the exported
data.

Options Tab
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Use "Common Name" From - This entry sets how Petra creates Kingdom's "Common
Name." Petra can use the database entry for Well Name, Well Label, Well Number,
UWI, or Lease Name.
4.3.5

Export ASCII Tops File

The Export Fm Top Names and Values tool exports the formation tops in a Petra
project to an external TXT file. This file can either be column or comma delimited.
To use the Export Fm Top Names and Values tool, select Project>Export>ASCII
Tops File (UWI, FmName, Value...) from the menu bar at the top of the Main
Module.

File Tab
The file tab contains the file name and export format options. Use the "Browse"
button to display the Window's file dialog box.

The Export Fm Top Names and Values File Tab

Output File - Use the "Browse" button to select or enter the name of the text file for
writing formation tops.
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Select Tops - This button opens the Select Zone Item List. Note that this list only
includes tops in the FMTOPS zone. To add tops to the file, select the relevant top
on the Zone Item list.
The ">" adds the highlighted top to the Selected Zone Item List.
The ">>" button adds all tops in the currently highlighted zone to the Selected Zone
Item List.
The "<" button drops the highlighted top from the Selected Zone Item List.
The "<<" button drops all tops from the Selected Zone Item List.

The Select Zone Item List

Use Aliases - This option uses formation top aliases. If a well's value for a top is
NULL, Petra will use the alias list to find a substitute "equivalent" top.
Output Tops if "Null" - Normally, NULL valued tops are not written to the export file.
This option writes the user-created null value to the top instead.
"Null" Value Indicator - This option sets the value that will be written to missing NULL
tops.
Format - This dropdown sets whether the exported file will have fixed columns or will
be separated by columns.

Options Tab
The Options Tab sets a few additional options on the specific columns in the
exported file.
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The Export Fm Top Names and Values Options Tab

Output Tops as - Petra can export tops as MD, SS, or TVD tops. For deviated
wells, the subsea value will be TVD subsea.
Include Tops Source Code - This option adds a column for the source code.
Include Quality Code - This option adds a column for the quality code.
Include Remarks - This option adds a column for the top remarks code.
Include Well Header Items - This option adds columns for the well name, number,
label, operator, lease name, datum, and TD.
Include XY Location of Each Top - This option adds a column for the xy position of
each top. For straight holes, this will be the surface location. For deviated and
directional wells, Petra will use the directional survey to calculate the XY location.
Include Top Description - This option adds a column for the top's description.
Include Change Date - This option adds a column for the date of any changes made
to the top.
Include Time - This option adds a column for the time of any changes made to the
top.
Suppress Column Headings - This option restricts the column headings from
appearing on the top of the file.
Include Repeats - This option includes all repeat tops.
Output Only Tops Modified Within Date Range - Petra records when tops in its
databases are changed. This option can restrict the export to only include log curves
that have been modified in between the "From Date" and the "Through Date."
4.3.6

Export Zone Data

The Zone Data Export tool creates an ASCII file containing one or more selected
zone items.
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To use the Export Zone Data tool, select Project>Export>Zone Data File from the
menu bar at the top of the Main Module.
This tool is a similar to the Export Tabular Ascii File tool - the key difference is this
tool's ability to store every zone data item in it's own row (Layout 2 on the Layout
Tab) rather than in sperate columns.

Data Tab
The Data Tab sets which zone data items are included in the exported file.

Output File - Use the "Browse" button to navigate to the desired location and enter
the name of the exported file.

Select Zone and Items To Export
First, select the desired zone from the dropdown menu. Once a zone is selected,
the list will show the data items in that zone.
The ">" adds the highlighted item to the Selected Items to Export List.
The ">>" button adds all items in the currently highlighted zone to the Selected Items
to Export List.
The "<" button drops the highlighted item from the Selected Items to Export List.
ed Items to Export List.
- This button sorts the sort the items in the Select Zone and Items to Export
List in alphabetical order.
The UP and DOWN arrows will move the highlighted item in the "Selected" list.

Options Tab
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The Options Tab sets some of the details on how Petra creates the file.

The Zone Data Export Layout Tab

Output File Format - This option sets whether the output file is "Fixed Width
Columns" (blank separated) or "Comma Delimited."
When To Write Column Headings - You can have the data columns labeled each
time the zone name changes or you can write the heading once at the beginning of
the file.
The "Write New Heading For Each Zone" option should be used whenever the zone
item names change from zone to zone. The "Write Heading for First Zone Only"
should only be used when the zone item names are the same in each zone and
selected in the same order.
Include Zone Item Remarks Field - This option will also export the "Text Item or
Remark" field along with the data item.

Layout Tab
The Layout Tab sets the specific format of the exported file: either column-wise
(Layout 1) or row-wise (Layout 2).
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The Zone Data Export Layout Tab

Layout 1 stores all information about a single well on a single row, where different
columns reflect different pieces of information. In the example below (left), each well
is a single row, with perf information (a flag, the total feet of perfs, the shallowest
and deepest perf depths) arranged in columns to the right.
Layout 2 stores each data item and identifier in its own row, with multiple rows for a
single well. In the example below (right), each line has an API number, the zone
name, the data item and the value. Every wells has multiple rows for different data
items.

Layout 1 that stores data with a single well per row(Left) and Layout 2 that stores a separate data item on each row
(Right)
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Export Landmark Standard 29 File
This tool exports Petra project data to a Landmark Standard 29 file format. This file
format will always include wells and well header information (like API, operator, etc),
but can also include other data in the project like locations, tops, directional surveys,
and curves.
To create a Landmark Standard 29 file, select Project>Export>Landmark Standard 29
Format from the menu bar at the top of the Main Module.

Export Project File - This entry selects the location and *.ASC file name. To open the
windows explorer, select the "browse" button.
Optional Data to Export - This entry sets additional data to include in the file beyond
well and well header information. This can include locations, tops, directional surveys,
and log curves.
4.3.8

Export Landmark OWX File
This tool exports the well data in a project to a Landmark OWX format.
To create a Landmark *.OXW file, select Project>Export>Landmark OWX Format
from the menu bar at the top of the Main Module.

Data Tab
The Data Tab sets the location of the exported file, and the specific data to export
from the project data.
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Export File - This entry selects the location of the exported file.
Optional Data to Export - This entry sets the specific data to include in the file. This
can include most data in a Petra project. Note that the "None" and "All" select none of
the checkboxes and all of the checkboxes, respectively.
Select Tops - This entry selects the Select Zone Item List to add tops to the exported
data.

Options Tab

Use "Common Name" From - This entry sets how Petra creates the "Common Name."
Petra can use the database entry for Well Name, Well Label, Well Number, UWI, or
Lease Name.
Deviation Survey Format - This entry controls how the file contains directional survey
data. OWX files can use either the "OWX2003" format or the "Kingdom Compatible"
format.
Kingdom Compatibility For Other Records - This option changes the file format
elsewhere to be compatible with Kingdom software.
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Export Logs

Petra can export digital log curves from the database for use in other systems.
To export a log from Petra, select Project>Export>Log Curves (LAS, LIS, etc)...
from the menu bar at the top of the Main Module.

File Tab
The file tab contains the file name and export format options. Use the "Browse"
button to display the Window's file dialog box.

The Export Logs File Tab

Output File Name
This entry sets the name and location of the exported file. Select the Browse button
to navigate to the desired directory and to select the file name.

Export Format
LAS - LAS is the most common industry standard log ASCII format. This format is
almost universally recognized by most oil and gas applications.
LIS - LIS is an older binary log format, and cannot be viewed in a text editor. LIS
files can contain curves from multiple wells in a single data file.
Tabular - This option creates a generic ASCII text file containing log values as data
columns. Petra creates *.DAT files by default, but these can be easily be renamed
to *.TXT.
MORE - This option creates files specifically formatted for the MORE simulator.
RC2 - This option creates files using RC2's ResPrep ASCII file format.

Logs Tab
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This tab selects the log curves that will be included in the file.

The Export Logs Logs Tab: Selecting the curves to export for a single well file (Left) and for a multi-well file (right)

Single well file formats (LAS, Tabular ASCII, MORE, and RC2) will have a dropdown
menu to select the desired well's logs. LIS files, on the other hand, can contain
multiple wells; logs selected on the "Select Log Curves To Export" will be exported
for all the wells selected on the Wells Tab.

Depths Tab
The depths tab sets the depth interval for the exported file, for export whether to
export all samples or decimate the output. Depths can be selected based on
measured depths, TV depths, or using formation tops. A "Sample Decimation Rate"
of 2, for example, would export every other depth sample. The depths tab is also
where the additional depth values are selected. Check the TVD, Subsea Depths,
and/or Subsea TVD options to include these depths as log curves.

The Export Logs Depths Tab

Set Depth Range
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This options opens the "Set Depth Range" tool, which controls the upper and lower
limits of the exported log file. Log data outside this range won’t be exported to the
file. The depth interval can be specified in measured depth, TVD, or relative to
formation tops.

The Set Depth Range

To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TVD button. For MD and TVD, select the relevant
button and enter the adjacent depth in the entry field. For tops, select the desired
top from the “Fm Top Name” dropdown box. Notice that an offset can also be
added or subtracted to the fm top; this offset will include data points above or below
the actual fm top depth.
To set depths by a zone’s interval definitions, select the desired zone on the “Set
Upper and Lower Depths From Zone” dropdown menu. Note that the WELL zone by
default covers -1M MD to +1M MD, so it should cover the entire footage of all wells.

Sample Decimation Rate - This option decimates the data to only export
every N’th sample. Setting this value to 2, for instance, would only export every
other data point. Setting this value to 5 would only export every 5th sample. By
default, this option is set at 1 to export every datapoint in the curves.

Additional Depth & Location Curves
Petra exports log curves as relative to measured depth. However, Petra can include
TVD, SubSea, and Subsea TVD depths in additional columns alongside the traces..
Include TVD Depths - This option uses the well's directional survey points to create a
curve that lists the TVD for every MD.
Include Subsea Depths - This option uses the well's active datum to create a curve
that lists the SS for every MD.
Include Subsea TVD Depths - This option uses the well's active datum and
directional survey points to create a curve that lists the SSTVD for every MD.
Include XY Location as a Curve - This option adds two columns for the X and Y
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position of the wellbore for every MD. This option is really only useful for deviated
and directional wells.
Correct Dir Survey to Grid North - This option applies the convergence angle
correction to the directional survey azimuth values. This option should only be used
where the the survey azimuth values are oriented towards true north, rather than grid
north.

Options Tab
The Options Tab sets a few additional options for LAS and Tabular formats,
including null values, column width, and decimal places.

The Export Logs Options Tab

ASCII File Null Value - This option specifies the value exported for null log values.
The null value for LAS files is -999.25.
Column Width - This option specifies the total width of the columns.
Number of Decimal Places - This option sets the number of decimal places to the
right of the decimal point.
Drop Null Records from Ascii File - This option removes curves with only null values
from the export. Curves containing a mixture of null and non-null values will still be
exported to the file.
Substitute Well Label for UWI in Ascii File - When exporting the log, Petra adds a
small header to the top of the file. This option swaps out the UWI for the entry in the
well label.

LAS Tab (LAS Only)
The LAS Tab adds zone data items to the LAS header, sets up batch LAS exports,
format allows one of more zone data items to be placed in the file header.
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Zone Header Data
Z values you want written in the ~Parameters section for the LAS file.
Include Zone Data in LAS Headers - This option toggles adding the additional zone
data items and tops to the LAS file. Toggling this option saves any changes made
on the "Select Zone Item List" tool, but will not include the items in the exported LAS
file.
Select Zone Data For Headers... - This button opens the Select Zone Item List. To
add data items and tops to the LAS file, select the relevant zone and item.
The ">" adds the highlighted item to the Selected Zone Item List.
The ">>" button adds all items in the currently highlighted zone to the Selected Zone
Item List.
The "<" button drops the highlighted item from the Selected Zone Item List.
The "<<" button drops all items from the Selected Zone Item List.

The Select Zone Item List

Write Tops to Special "~tops" Section - By default, Petra exports all data items and
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tops into the "~Parameter Block" in the exported LAS file. This option instead saves
tops to a new "~tops" section of the LAS file.

A LAS file with tops and items written to the "~Parameter Block" (Left) and with the tops written to a "~tops" section
(Right)

Multi Well LAS Export
Export Multiple Wells (One Well per File) - Each LAS file can only contain a single
wells' curves. This option creates the Wells Tab; for the multiple LAS files.
File Names Derived from - This option controls how Petra names the multiple LAS
files.
Prefix - This option adds a prefix to the beginning of the filename.
Well Seq Num - This option names LAS files based on the WSN in Petra.
API Series Num - This option removes the first five digits of the API number (the
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state and county code) to leave only the well series number.
Full API or UWI - This option names LAS filesby the full UWI code in Petra.
Well Label - This option names LAS files based on the UWI code in Petra.

Truncate Curve Names to 4 Chars Do Not "Wrap" Curve Data - This option forces Petra to write every depth onto a
single line, instead of wrapping onto a different line. Most applications that use LAS
files won't care, but this can be useful for working with raw curve data in a
spreadsheet application.
Write API into "WELL" Keyword - This option writes the well UWI/API into the LAS
file's "WELL" keyword, instead of the default well name entry
Substitute Label for UWI - This option writes the well label into the LAS file's "UWI"
keyword, instead of the default UWI entry.
Output Alias Name Instead of Raw Curve Name - This option attempts to rename the
selected curves in the exported file based on the project's log aliases. By default,
Petra exports aliased curves using the actual or "raw" curve name associated with
the exported well.
Export Only those Curves with a Sample Rate of - This option will only export curves
with the specified sample rate. Curves with a different sample rate will not be
exported to the file.
Use Top Aliases - This option uses top aliases for the export. In practice, this option
will attempt to replace the missing top with one of the other "equivalent" tops on the
alias list.

Wells Tab (LIS & LAS)
This tab appears when the LIS option is selected. Select one of more wells for
export. Wells which do not contain any of the selected logs will be not be written to
the output file(s). Also, only the selected logs with data will be exported for a given
well. Null data WILL NOT be output for missing logs.
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The Export Logs Wells Tab

LIS Tab (LIS Only)

The Export Logs LIS Tab

Header Remark - This option simply adds a remark in the file header. LIS export
format allows a comment to be placed in the file header.

MORE Tab
The MORE tab contains options used to export logs to the MORE simulator.
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The Export Logs MORE Tab

Write Well ID From - This option determines the well identifier written to the output
file. Options include UWI, well name, well number, well label, or WSN.

RC2 Tab
The RC2 tab contains options used when exporting logs in the RC2 ResPrep format.
The *.ASC files created can include directional survey data, formation tops, and log
curves.

The Export Logs RC2 Tab

Export Deviation Survey - This option includes directional surveys in the RC2 File.
Export Tops - This button opens the Select Zone Item List. Note that this list only
includes tops in the FMTOPS zone. To add tops to the RC2 file, select the relevant
top on the Zone Item list.
The ">" adds the highlighted top to the Selected Zone Item List.
The ">>" button adds all tops in the currently highlighted zone to the Selected Zone
Item List.
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The "<" button drops the highlighted top from the Selected Zone Item List.
The "<<" button drops all tops from the Selected Zone Item List.

The Select Zone Item List

Generate Well ID From - This option determines the well identifier written to the
output file. Options include UWI, well name, well number, well label, or WSN.

Output File Names Derived From
This option controls how Petra names and stores the RC2 files. Multiple wells are
exported with each well written to a different disk file.
Well Seq Num - This option names RC2 files based on the WSN in Petra.
API Series Num - This option names RC2 files based on the UWI code in Petra.
Prefix - This option adds a prefix to the beginning of the filename.

Dates Tab
The Dates Tab restricts the export of logs to only curves modified within a date
range.
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The Export Logs Dates Tab

Restrict Exported Logs to Those Modified Within Dates Below - Petra records when
log curves in its databases are changed. This option can restrict the export to only
include log curves that have been modified in between the "From Date" and the
"Through Date." This can be useful for performing a bulk update of log data in other
applications.
4.3.10 Export Monthly Production
Petra can export production data in the project to a few different file formats. Tabular
production data is the most general purpose file format, while Production Analyst and
MORE file formats are more specialized files that are most useful for the respective
programs.
To export data, select Project>Monthly Production To>... from the menu bar at the
top of the Main Module.
Export Tabular Production File
Production Analyst
MORE Simulator Recurrent Data
4.3.10.1 Export Tabular Production File

This tool exports the production data in a project to a tabular or comma-separated
file.
To create a file, select Project>Monthly Production To>Tabular File from the menu
bar at the top of the Main Module.

File Tab
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File To Export - This entry sets the name and location of the exported file. Selecting
the "Browse" button will open Windows Explorer.
File Format - This option sets the file format. Comma delimited files separate
individual values with commas, while fixed column files separate individual values with
spaces.

A comma delimited file (left) and a fixed column file (right)

Do Not Output Record When All Values Are Zero - By default, Petra will export all
values including months with all zero values. This option instead prevents these
months from being exported to the file.
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Format Date Field As - This option sets how the exported file records dates. Options
include YYYY and MO columns or a single YYYYMM column.

Production Tab
The production tab has two lists: the Select Production Streams To Export list, which
contains all the production streams in the project, and the Selected Streams To Be
Output list, which contains the streams that will be exported to the file.

> - This button adds the highlighted production stream to the Selected Streams to Be
Output list.
>> - This button adds all production streams in the project to the Selected Streams to
Be Output list.
< - This button drops the production stream selected from the Selected Streams To
Be Output list. This will remove the production stream from the export file.
<< - This button drops all production streams from the Selected Streams To Be
Output list.

Years Tab
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Export Production From/Through - This option limits the file only to only production
data inside the set range.
Include Year 0 - Some states record historical production in a single historical year
labeled "0." This option includes this historical year 0 data in the export file.
4.3.10.2 Export Production Analyst

This tool exports the production data in a project to a tabular or comma-separated
file.
To create a file, select Project>Monthly Production To>Export Production Analyst
from the menu bar at the top of the Main Module.

File Tab

File To Export - This entry sets the name and location of the exported file. Selecting
the "Browse" button will open Windows Explorer.
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Output "*NAME" Field Using - This dropdown sets the "Name" field for the PA file
format. Options include UWI or API Number, Well Name, Well Number, Well Label.

Production Tab
The production tab has the Select Production Streams To Export list, which contains
all the production streams in the project. Highlighted production streams will export to
the file.

Years Tab

Export Production From/Through - This option limits the file only to only production
data inside the set range.
4.3.10.3 Export More Simulator Recurrent Data

This tool exports the production data in a project to a tabular or comma-separated
file.
To create a file, select Project>Monthly Production To>MORE Simulator Recurrent
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Data from the menu bar at the top of the Main Module.

General Tab

Well Identifier Used By More
This dropdown selects the well identifier that the More simulator uses. The More
simulator can use UWI/API, Well Name, Well Number, or Well Label.

Year Range To Export
The "From" and "Thru" entries set the year range for the data. Data outside the range
will not be included in the file.

Averaging
1 Year Averages - This option averages an entire year of production.
6 Mo Averages - This option averages 6 months of production.
3 Mo Averages - This option averages 3 months of production.
Monthly - This option averages each production stream by a month.

Location
Surface Location - This option sets the well's location as the surface location.
Bottom Hole Location - This option sets the well's location as the bottom hole location.

MORE Simulator Recurrent File(s) Generated
WellLoc Plus MULTIPLE Rate Files Single COMBINED File © 2014
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Producers Tab

Enable Producer Phase Production Streams

Water Injector Tab

Enable Water Injection Phase Water Injection Stream MORE Component Name Date When Well Became Injector -
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CO2 Injectors Tab

Enable CO2 Injection Phase Injection Streams Date When Well Became Injector MORE Component Name -

Parameters Tab

Layers Tab
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Files Tab

4.3.11 Export Interval Data
This tool exports interval data to a comma separated value (*.CSV) file.
To export interval data, select Project>Export>Interval Data from the menu bar at the
top of the Main Module.
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Output File Name
This option sets the name and destination of the output CSV file. Select the "..."
button and navigate to the desired location.

Interval Table Dropdown
This dropdown selects the desired interval table. The selected dropdown will
populate the Selected Data Columns List immediately below.

Select Data Columns
This option controls which files get written to the output file. The file will only contain
the entries with checked data columns.
Include File Value Quality - This option includes a field for each entry's quality. Note
that this file value quality is different from the quality data field.
Include Lat-Lon Locat - This option will include entries for each well's LatLon in the
file.
Include XY Location - This option will include entries for each well's LatLon in the file.
Adjust Locations for Dev. Survey at "Top" depth - With deviated wells, an interval's
location down the wellbore can be thousands of feet away from the surface location.
This can be pretty significant for mapping. This option will use a well's directional
survey data to calculate the true location of the interval data for the "Include Lat-Lon
Locat" and "Include XY Location" options.
4.3.12 Export Directional Survey
This tool exports the directional surveys in a project to an comma separated value (*.
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CSV) file.
To create a directional survey file, select Project>Export>Directional Survey from the
menu bar at the top of the Main Module.

Export Directional Survey(s) To - This entry sets the name and location of the
exported file. Select the Browse button to navigate to the desired directory and to
select the file name.

Survey(s) To Export
Petra can store multiple directional surveys (both real and planned) for any well. This
tool can export any or all of the directional surveys for all wells. This section sets
which specific surveys to the file.
Export All Surveys Available for Each Well - This option will include all surveys loaded
in the project, including all active and secondary surveys.
Export 'Active' Survey Only - This option will export only the active surveys.
Export Selected Survey From List Below - This will export only surveys with the
survey definition selected on the dropdown below.

Survey Rotation Option For Survey Option
This tool controls how Petra applies the convergence correction to the exported
directional survey data.
Rotate Output Survey to GRID North - This tool exports the surveys relative to the
grid north. Grid north surveys are dependent on the map projection, and will only
project correctly on maps with the same reference datum and coordinate system.
Rotate Output Survey to TRUE North - This tool exports the surveys relative to the
true north. These will not plot correctly on a map unless the convergence correction is
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reprojected.
Output Survey Data As Is - This tool ignores the convergence correction and will
export the surveys "as is."
4.3.13 Export Top Definition File
This tool exports the formation top definitions in a project to an comma separated
value (*.CSV) file. This can be useful for standardizing formation tops across multiple
projects. This definition file only contains the top name, top source, and top
description set on the Add New Formation Top or Modify Zone Item Definition tools.
The definition file does not contain any of the actual top values.
To create a top definition file, select Project>Export>Tops Definitions... from the menu
bar at the top of the Main Module.

4.3.14 Export Perfs, Cores, Casing, Liner, IP, DST
This tool exports the perfs, cores, production tests, Fm or IP tests, casing, or liner
data to comma separated (*.CSV) files. Each tab exports a different csv for a
different data type.
To create a PPF file, select Project>Export>Perfs, Cores, Casing, Liner, IP, DST...
from the menu bar at the top of the Main Module.

Perfs Tab
The Perfs Tab exports the perfs in a project to a CSV file. Note that the Source Tab
restricts the exported perfs to only those with selected source codes.
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Cores Tab
The Cores Tab exports the cores in the project to an external CSV file.
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Prod Tests Tab
The Cores Tab exports the production tests in the project to an external CSV file.

IP Tests Only - This option restricts the exported tests to only IP Tests.
Choke Sizes are in 64th - This option exports choke sizes in 64th of an inch.

Fm Tests (DST) Tab
The Fm Tests Tab exports the Fm Tests in the project to an external CSV file.
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Choke Sizes are in 64th - This option exports choke sizes in 64th of an inch.

Casing Tab
The Casing Tab exports the casing information in the project to an external CSV file.

Liner Tab
The Liner Tab exports the liner information in the project to an external CSV file.
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Options Tab

WELL ID Columns To Include - By default, Petra only includes the UWI in the
exported CSV files. This entry controls which well header information is included in
the exported CSV files.

Source Tab
This tool restricts the perf export to only perfs with specific source codes. Note that
this tool does not affect cores, tests, or other data types on this export tool.
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Restrict Export to Follow Source Codes - This entry enables the perf source code
restriction. Only perfs with perf codes set on the entry box below will be exported to
the CSV file. To use multiple codes, separate the different values with semi-colons.
4.3.15 Export SCA-MCA Z Data
This tool exports Petra project data to a *.XYZ file for SCA's Mapping Contour
System.
To create a XYZ file, select Project>Export>Perfs, Cores, Casing, Liner, IP, DST...
from the menu bar at the top of the Main Module.

File Tab
This entry sets the name and location of the exported file. Select the Browse button
to navigate to the desired directory and to select the file name.

Z Data Tab
The Z Data Tab sets the specific zone data items and formation tops to include in the
SCA-MCA file.
© 2014

Main Module

273

First, select the desired zone from the Zones and Zone Data Items menu. Once a
zone is selected, the Selected Data Items list will show the data items that will be
included in the SCA-MCA file.
The "<" adds the highlighted item to the Selected Items to Export List.
The ">" button removes the currently highlighted data item from the Selected Data
Items list.
The ">>" button drops all items from the Selected Data Items list.
The UP and DOWN arrows will move the highlighted item in the "Selected Data
Items" list.

Faults Tab
The Faults Tab controls which tops will be in the SCA-MCA file. Highlighted tops will
be included, while non highlighted tops won't be included in the file.

Include Faults Selected Below - This option includes faults in the file. Deselecting this
option will retain all the highlighted faults, but will not include the faults in the file.
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All/None - The "All" button will highlight all faults in the project, while the "None" button
will remove the highlights from all faults.

Options Tab
The option controls how Petra writes formation tops. Formation tops can be in
measured depths, or in subsea TVD.

4.3.16 Export GES Wellsbase ASCII V2

4.3.17 Export Velocity Data
This tool exports the "active" velocity functions for the wells selected on the Main
Module. Note that a well's velocity function is set on the Main Module's Other Tab.
To create a top definition file, select Project>Export>Velocity Data from the menu bar
at the top of the Main Module.
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4.3.18 Export Well Remarks
This tool exports well remarks (visible on the Main Module's Well Tab) for the wells
selected on the Main Module. This tool will export the remarks to a comma separated
value (*.CSV) file. Note that this tool will save multiple remarks for a single well onto
multiple lines.
To export definition file, select Project>Export>Well Remarks from the menu bar at
the top of the Main Module.
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Map Projections

Introduction to Map Projections
A “map projection” is an attempt to portray the curved surface of the earth on a flat
piece of paper or computer screen. Put another way, map projections have two
parts: the reference datum and the coordinate system.

Reference Datum
A reference datum (pl: reference datums) is a known and constant surface used to
calculate latitude and longitude for a point on the Earth’s surface. A point’s longitude
is simply the angle of degrees the point is away from the Prime Meridian. A point’s
latitude, on the other hand, is the angle between the equatorial plane and a line that is
normal to the reference datum. It’s worth noting that since the earth is actually a little
flattened, this line actually intersects the equatorial plane a little bit away from the very
center of the Earth. Since different reference datums have different shapes, a single
point can have different latitude and longitude depending on the reference datum used
to make the measurement.
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Calculating latitude and longitude from a reference datum

Imagine digging a series of narrow canals across the world’s continents. The height of
the water inside these canals would be sea level at zero elevation. The global surface
described by this zero elevation is called the “geoid.” The geoid is actually fairly
bumpy due to unequal density distribution on Earth. The example below (from the
European Space Agency) shows an exaggerated model of the Earth’s geoid, where
red highlights a high geoid, and blue a low geoid. The closer the reference datum fits
the geoid, the more accurate the map. Fitting a single reference datum to these
bumps, however, has made the process of creating a single, accurate global datum
difficult.

An exaggerated model of Earth's geoid (from the European Space Agency)

Historically, the solution was to create a lot of different reference datums with
different shapes and origins – each of which is suited only for a specific region. The
figure below shows a couple of different datums relative to the Earth’s geoid. Notice
that the N. America datum in the example below closely models the geoid for North
America, but is wildly off for the rest of the world. Likewise, the European Datum
closely follows the geoid near Europe, but is greatly distorted relative to the geoid for
the rest of the world. Note also that the N. American and European datums both have
different shapes (known as ellipsoids) and origins.
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A N. American and European reference datum relative to the actual geoid

More recently, the trend has been towards creating more and more accurate global
reference datums that are applicable to the entire globe. The WGS 1984 datum
(used on GPS receivers) is a common global reference datum.
Recall that a point’s latitude and longitude are calculated from the reference datum.
In order to correctly plot a specific latitude and longitude on a map, it’s necessary to
know the reference datum of that LatLon point. Practically, this means that not all
LatLons are equivalent. A LatLon created with one reference datum won’t be
compatible with a LatLon based on another reference datum. Because of this,
whenever you import any LatLon data (such as well spots or overlay data), it’s
important that the reference datum of the project and new data are both known
and accounted for.

Coordinate System
The other part of the map projection is the coordinate system. The coordinate system
essentially is a set of coordinates that transforms latitude and longitude on a globe
into XYs on a flat map. The most common coordinate systems in North America are
the state plane systems and UTM zones.
In a sense, these two parts of a map projection (the reference datum and the
coordinate system) constitute two separate steps. First, the reference datum is used
to calculate LatLons for a location on a globe. Second, the coordinate system
converts this LatLon data into XYs for plotting on a flat map.

How a location on a globe becomes an XY point on a map

All coordinate systems, by virtue of trying to stretching a three dimensional globe onto
a flat map, inherently introduce some distortion. This distortion can change the
shapes of objects, distances between points, the azimuth between points, scales, or
areas. All map projections are a tradeoff between different types of distortion.
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As such, there is no one universal “best” projection suitable for all areas. Even for a
small area, the “best” projection is still arguable. An alternative way of selecting a
coordinate system is to look for a “useful” coordinate system. Things to consider
include the coordinate system any collaborators are using, the coordinate system
used by legacy maps of the area, and what projection your existing data uses.
4.4.1

"Standard" and "Custom" Coordinate Systems

The Map Projection Settings has two different coordinate system settings: Standard
and Custom. Both the Standard and Custom Tab set a new project’s coordinate
system and also reprojects an entire project to use a different coordinate system
(provided the reference datum stays the same). To switch between the two select
the appropriate button at the top of the screen (highlighted in red on the example
below).

Standard Coordinate Systems
The Standard coordinate system option contains a wide variety of coordinate
systems for much of the world. These coordinate systems are pre-made and are a
good option for most users. Selecting a standard coordinate system will change the
second tab to the "Standard Tab."

Custom Coordinate Systems
The Custom coordinate system mostly provides backwards compatibility for Petra
projects older than October 2008. Older projects with Custom coordinate systems
can either be left alone, or easily converted into the analogous Standard coordinate
system. Custom coordinate systems are also useful for handling obscure or custom
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coordinate systems not included in the Standard coordinate system list. These
options are provided for backward compatibility with older Petra projects. Selecting
a custom coordinate system will change the second tab to the "Custom Tab"

4.4.2

Map Projection Settings

A “map projection” is an attempt to portray the curved surface of the earth on a flat
piece of paper or computer screen. Map projections have two parts: the reference
datum and the coordinate system.
The reference datum is a model of zero elevation, which is used to calculate latitude
and longitude for a point on the Earth’s surface (see the Datum Tab help screen).
The coordinate system essentially is a set of coordinates that transforms latitude and
longitude on a globe into XYs on a flat map (see the Standard or Custom coordinate
system Tab help screen).
To view and change a Petra project’s map projection, in the Main Module select
Project>Settings>Set Map Projection… or select the

button on the Project Tab.

Details Tab
Custom (Coordinate System) Tab
Standard (Coordinate System) Tab
Datum Tab
Units Tab
Quadrant Tab
Map Rotation Tab
Convert Crds Tab
Lock/Unlock Tab
Advanced Tab
File Tab

4.4.2.1

Details Tab

The Details tab simply shows the project’s current map projection. The example
below shows that the NAD27 reference datum is selected, along with the Oklahoma
South state plane coordinate system.
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The Details Tab displays the current map projection for the project

4.4.2.2

Custom (Coordinate Systems) Tab

Petra contains two ways of selecting a coordinate system: “Custom” and “Standard.”
Both the Standard and Custom Tab set a new project’s coordinate system and also
reproject an entire project to use a different coordinate system (provided the
reference datum stays the same).
Most commonly, the Custom coordinate system provides backwards compatibility for
Petra projects older than October 2008. Older projects with Custom coordinate
systems can either be left alone, or easily converted into the analogous Standard
coordinate system.
Custom coordinate systems are also useful for handling obscure coordinate systems
not included in the Standard coordinate system list. Additionally, a custom coordinate
system can create a unique and highly accurate map projection for a small area. It’s
important to note, however, that XY locations based on a custom map projection will
not be compatible with XYs from standard map projections such as state planes. This
can cause difficulty in giving XY locations to drillers, for example.
The Custom Tab can create and modify coordinate systems in three ways: creating a
coordinate system from scratch, modifying an existing coordinate system, or creating
a coordinate system based on data limits.

Projection Tab
The Projection Tab sets the specifics of the map projection.
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Central Meridian - This option sets the longitude of the center of the map projection.
Latitude of Origin - This option sets the latitude of the center of the map projection
Northern Reference Latitude - This option sets the northern reference latitude.
Southern Reference Latitude - This option sets the southern reference latitude.
Scale Factor at Origin - The scale factor is the ratio between distances in the
projection and distances on the surface of the reference ellipsoid. This option sets the
scale factor at the origin.
False Northing (Meters) - This option specifies the Northing/Y coordinate at the origin
of the projection.
False Easting (Meters) - This option specifies the Easting/X coordinate at the origin of
the projection.

Elipsoid Tab
The Ellipsoid Tab selects the ellipsoid (spheroid) model to use with the projection. The
semi-major axis and inverse of the flattening are displayed. Please note that ellipsoids
are not used in XY mode.
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Petra stores its ellipsoid parameters in Ellipsoid.DAT, located in the installation's
PARMS subdirectory. This file can be modified if extreme care is taken to maintain the
format integrity.
AIRY, "Airy 1830",
AIRY, "Airy 1849",
APL49,"Appl Phys 1965",
AUST, "Australian National",

6377563.396,
6377340.189,
6378137.000,
6378160.000,

299.3249753
299.324964
298.25
298.25

Example text from Ellipsoid.DAT showing the code, name, semi-major axis, and flattening of several ellipsoids

State Plane Tab
On the State Plane Tab, set the appropriate name on the "Apply" button. Note that
the "Details" button can be used to view the parameters prior to selection. The State
Plane table contains parameter settings for both the North American Datum 1927
(NAD27) and the North American datum 1983 (NAD83).
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Coord Sys Tab
The Coord Sys Tab contains several coordinate systems from China and Israel. To
use one of these coordinate systems, select one from the list and click the 'Apply'
button.

Creating a Coordinate System from Scratch
After selecting a project reference datum (on the Datum Tab), select the Custom
Coordinate System. On the Elipsoid Tab, select the desired ellipsoid. Make sure the
projection and associated ellipsoid match the chosen Reference Datum.
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Selecting an ellipsoid for a custom coordinate system

Next, on the Projection Tab, select the specific projection type and projection
parameters such as central meridian. Petra will accept LatLon values in either
decimal degrees or as degrees:minutes:seconds. Note that the parameters listed will
depend on the specific projection type. As an example, only the UTM projection lists
UTM zones.

Selecting a projection for a custom coordinate system

Select “Save” to enact the changes. For new projects this will simply set the project’s
map projection. For existing projects, saving a different coordinate system means
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that the XYs of all the data will need to change as well. Make sure to select “Yes”
when Petra asks to recompute XY well locations using the new map projection. See
“Final Steps…” later in this help file to reproject grid files.

Changing the coordinate system changes the XY positions of wells. Select "Yes" to recompute the positions in the
database.

Modifying an Existing Coordinate System
The Custom Tab also contains the coordinate system settings for the US state plane
system (under the State Plane Tab) as well as Israel and China (under the Coord Sys
Tab). To modify one of these existing coordinate systems, select the coordinate
system from either the State Plane Tab or the Coord Sys Tab. In the example below,
the Oklahoma South (NAD27) state plane coordinate systems is selected. Once
you’ve selected the coordinate system to modify, Select “Apply” to temporarily set the
coordinate system.

Selecting an existing state plane populates the other tabs with the coordinate systems values

Going back to the Custom Tab shows that all the settings for the given coordinate
system are loaded in. Every one of these settings is now modifiable.
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The Projection Tab with the selected state plane's projection settings

Select “Save” to enact the changes. For new projects this will simply set the project’s
map projection. For existing projects, saving a different coordinate system means
that the XYs of all the data will need to change as well. Make sure to select “Yes”
when Petra asks to recompute XY well locations using the new map projection. See
“Final Steps…” later in this help file to reproject grid files.

Changing the coordinate system changes the XY positions of wells. Select "Yes" to recompute the positions in the
database.

Creating a Coordinate System Set by Data Limits
The “Set By data Limits” option creates a new map projection using the selected
projection type and the extents of the wells selected in the Main Module. This option
essentially “fills in the blanks” for the central meridian and latitude origin based on the
extents of the selected wells.
Select “Save” to enact the changes. For new projects this will simply set the project’s
map projection. For existing projects, saving a different coordinate system means
that the XYs of all the data will need to change as well. Make sure to select “Yes”
when Petra asks to recompute XY well locations using the new map projection. See
“Final Steps…” later in this help file to reproject grid files.
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Changing the coordinate system changes the XY positions of wells. Select "Yes" to recompute the positions in the
database.

Final Steps for Changing the Coordinate System on an Established
Project
After changing the coordinate system and the project’s map projection, there are a
couple more steps to reproject other data inside a project.
Reopen the map module, and verify that the well locations and overlay files line up
correctly. It might be necessary to reset the data limits to reflect the new locations of
the well and overlay data. To do so, select Display>Auto Scale Mode & Map Extents
From Wells.
The wells and overlay should now be lined up using the new coordinate system. The
final step here is to reproject the grids. Select Contours>Grids>Convert Grid Map
Projections.
The Grids Tab shows the grids contained inside the project’s GRIDS folder. To
change this directory, select the Dir Tab. Next, select the grids to reproject. The
MapProjection Tab shows the map projection of the grids on the left in green and the
new grid map projection on the right in blue. Notice that in this example, the grid was
Oklahoma North (NAD27) and will be reprojected to Oklahoma South (NAD27).

The Grids Tab (left) and Map Projection Tab (right)

The Options Tab gives a little finer control on how the grids will be reprojected. Petra
automatically stores backup copies of all reprojected grids. By default, Petra adds
“NEW” as a suffix to new grids. It’s possible to change it by entering new text, but
there needs to be some text here. This tab also controls how Petra resamples the
existing grids to fit the new projection. You can output the newly reprojected grids as
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rectangular or triangular grids.
The Dir Tab changes the directory of reprojected grids. This tool will only reproject
grids within this folder. If your grids are stored in multiple folders, it’s probably best to
perform this operation several times to get all different folders. To reproject the grids,
select OK. Petra will review the selected grids and generate a report.

The Options Tab (left) and Dir Tab (right)

4.4.2.3

Standard (Coordinate Systems) Tab

Petra can select a coordinate system in two ways: “Custom” and “Standard.” The
Standard Coordinate Systems contains a wide variety of coordinate systems
assembled by Blue Marble Geographics. This set of “Standard” coordinate systems
covers the vast majority of projections used in the oil and gas industry. Both the
Standard and Custom Tab set a new project’s coordinate system and also reprojects
an entire project to use a different coordinate system (provided the reference datum
stays the same).
The Standard Tab is primarily divided into two lists: the Coordinate System Types,
and the individual Coordinate System Names.
The Coordinate System Type list on the left shows all the different kinds of coordinate
systems available for the currently selected reference datum (the project’s reference
datum is selected on the Datum Tab). Selecting a specific coordinate system type
populates the Coordinate System Name list on the right with all the available
coordinate systems. In the example below, “US State Plane 1927” is selected, which
shows all available NAD27 state plane coordinate systems. In this example, the
Oklahoma South state plane coordinate system is selected from the Coordinate
System Name list. It’s also worth noting that the Standard Tab also has an option to
create a custom, or “User Defined” coordinate system. See the end of this help file
for more information on “User Defined” coordinate systems.
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The Standard Tab lists the available coordinate system types and specific coordinate systems for the selected
reference datum.

Select “Save” to enact the changes. For new projects this will simply set the project’s
map projection. For existing projects, saving a different coordinate system means
that the XYs of all the data will need to change as well. Make sure to select “Yes”
when Petra asks to recompute XY well locations using the new map projection.

Changing the coordinate system changes the XY positions of wells. Select "Yes" to recompute the positions in the
database.

Final Steps for Changing the Coordinate System on an Established
Project
After changing the coordinate system and the project’s map projection, there are a
couple more steps to reproject other data inside a project.
Reopen the map module, and verify that the well locations and overlay files line up
correctly. It might be necessary to reset the data limits to reflect the new locations of
the well and overlay data. To do so, select Display>Auto Scale Mode & Map Extents
From Wells.
The wells and overlay should now be lined up using the new coordinate system. The
final step here is to reproject the grids. Select Contours>Grids>Convert Grid Map
Projections.
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The Grids Tab shows the grids contained inside the project’s GRIDS folder. To
change this directory, select the Dir Tab. Next, select the grids to reproject. The
MapProjection Tab shows the map projection of the grids on the left in green and the
new grid map projection on the right in blue. Notice that in this example, the grid was
Oklahoma North (NAD27) and will be reprojected to Oklahoma South (NAD27).

The Options Tab gives a little finer control on how the grids will be reprojected. Petra
automatically stores backup copies of all reprojected grids. By default, Petra adds
“NEW” as a suffix to new grids. It’s possible to change it by entering new text, but
there needs to be some text here. This tab also controls how Petra resamples the
existing grids to fit the new projection. You can output the newly reprojected grids as
rectangular or triangular grids.
The Dir Tab changes the directory of reprojected grids. This tool will only reproject
grids within this folder. If your grids are stored in multiple folders, it’s probably best to
perform this operation several times to get all different folders. To reproject the grids,
select OK. Petra will review the selected grids and generate a report.

User Defined Coordinate Systems
© 2014

292

PETRA Help

Though the Standard Tab is primarily designed to handle a variety of standard
projections, it’s also fairly straightforward to create and save custom projections.
Select the “User Defined…” button on the left of the screen (highlighted in red).

This brings up the Create User Defined Coordinate System box. Here, select a name,
units, datum, ellipsoid, and specidic parameters for the map projection. Selecting
“Save Coordinate System” creates the new projection. In the example below, the
coordinate system is named “Custom Projection.”
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This saves the newly created user defined coordinate system inside Petra’s database.
User defined coordinate systems are listed under “User Defined” on the Coordinate
System Type list on the left of the screen. Selecting the custom coordinate system
will select it for the project. Select Save to save the projection for the entire project.

4.4.2.4

Datum Tab

The Datum Tab has two major functions: selecting a reference datum at the beginning
of a project, and selecting the reference datum for new data imports.
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The Map Projection Datum Tab

Project Datum Reference - This dropdown sets the project’s reference datum, which
is critical to correctly projecting all well, seismic, and overlay data. After changing the
datum, it’s necessary to select a coordinate system in order to save any changes.
It’s important to note that changing the project’s datum here does not reproject the
entire project. Really, the only time to use this option on the Datum Tab is when
setting up the project’s map projection before importing any data. To change the
datum of the project, select the Advanced Tab on the Map Projection Settings box.
Datum for Data Imports - This dropdown automatically recalculates the imported
data’s latitude and longitude to match the project’s reference datum. In the example
below, the incoming well data’s LatLons are based on the NAD27 reference datum,
while the project is based on the NAD83 datum.
Project Area - This option sets the list of available reference datums. The
“Contiguous US” option lists only the datums relevant to the US, while the
“International” option shows all available datums.

4.4.2.5

Units Tab

The Units Tab sets the units of measurement (US Feet or Meters) for the entire
projects. The XY (or map) coordinates and the depth units are independent of each
other.

© 2014

Main Module

295

The Map Projection Datum Tab

XY coordinates are in - This option sets whether the scales and distances in the Main,
Map and CrossSection Modules (between wellbores) are displayed in meters or in US
feet.
Default Depth Units - This option sets the depths on the CrossSection Module and
Main Module (depths on the FmTops Tab) as US feet or meters.

4.4.2.6

Quadrant Tab

The Quadrant Tab corrects incorrectly positive latitude and longitude values during
import. This is mostly used to change incorrectly positive longitude values for North
America.

Background
The spherical surface of the Earth is divided by east-west running lines of latitude and
north-south running lines of longitude. The equator that defines 0º latitude is defined
as the plane perpendicular to the Earth’s axis that also contains the Earth’s center of
mass. The Prime Meridian that defines 0º longitude is a arbitrary line that runs
through the Royal Observatory in Greenwich, London.
By convention, the equator is 0º latitude, with +90º at the North Pole and -90º at the
South Pole. The Prime Meridian is 0º longitude with positive longitude to the east and
negative longitude to the west. The equator and the Prime Meridian therefore divide
the Earth up into four quadrants. The signs of latitude and longitude distinguish
between the four qquadrants. Western Europe, Russia, China, and the Middle East
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have positive latitude and longitude. North America, on the other hand has positive
latitudes and negative longitudes. As an example, (+29.97, -95.35) is Houston, TX,
while (+29.97, +95.35) is Byai Zhen near the Tibet-India border.

Quadrants and LatLon Signs

Despite the convention, LatLon points (particularly in North America) are prone to
being reported as having positive longitudes when they should be negative. This error
can cause overlay data to grossly misalign, and to effectively “flip” the east and west
sides of the map. A mix of correctly and incorrectly formatted LatLons will strand
some data literally in the next hemisphere.

Using the Quadrant Tab
The Quadrant Tab automatically converts incorrect positive LatLon values to the
correct negative values for the selected quadrantduring import. This is primarily used
for projects in North America, where longitude values are commonly incorrectly
reported as positive. Selecting the NW quadrant, for example, will convert all
incoming positive longitude values to the correct negative longitudes, where the
incorrect (+29.97, +95.35) would convert to a correct (+29.97, -95.35).
Most latitude and longitudes for the rest of the world are reported correctly. As such,
users working on international projects should select the NE quadrant. This quadrant,
being north of the equator and east of the Prime Meridian, has both positive latitudes
and longitudes. When this quadrant is selected, no correction is made.
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The Quadrant Tab

4.4.2.7

Map Rotation Tab

If for purely aesthetic reasons you want to have straight section lines, it’s possible to
rotate the entire map projection. This process changes the map projection, and
consequently the XY coordinates of all the data inside that project.
It’s important to note that the XY coordinates of data inside a rotated project will not
be compatible with XYs of a project using the “same” but non-rotated projection. In
other words, the XY positions of data inside a rotated Colorado North (NAD27) state
plane project will not match other non-rotated Colorado North (NAD27) state plane
maps. This can cause difficulty in giving XY locations to drillers, for example

The Map Projection Map Rotation Tab

Map Rotation Angle - This option sets the angle of map rotation. Select the "Apply"
button to recalculate the XYs and reproject the project.
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Convert Crds

The Convert Crds Tab is a quick way to convert specific points on a map into different
forms and datums. More specifically, this tab converts LatLon points to the XY (using
the project’s coordinate system) and vice versa, as well as changing a single LatLon
point from one datum to the next. The Convert Crds Tab has two parts: the
Coordinate Projection section on the left, and the Datum Shift Sample Point section on
the right.

The Map Projection Convert Crds Tab

Coordinate Projection - This section simply converts a LatLon point to a XY point (and
vice versa) using the project’s saved map projection. In other words, selecting a new
projection on the datum and coordinate System tab without saving doesn’t change
how these numbers are calculated.
Datum Shift Sample Point - This section converts a LatLon using one reference datum
to a different reference datum.
Display Calculated Lat-Lon Values As - This option selects between LatLons as
Decimal Degrees and Degree, Minute, Seconds.
4.4.2.9

Lock/Unlock Tab

The Lock Tab prevents any changes from being made to the Petra project’s map
projection. This lock can also be password protected.
Locking the map projection saves the currently selected map projection, so be sure
to have the correct map projection selected before locking the project.
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The Map Projection Lock Tab

Lock Map Projection - This option locks the map projection.
Password Protect Lock - This option brings up additional dialogue boxes confirming
that you want to add a password and then to actually create and confirm the
password.

Setting a Map Projection Password

Notice that the tab’s name changes to “Unlock.” A locked map projection prevents
changes to the quadrant correction, datum, coordinate system, map rotation, and map
XY units. It’s still possible to change the import datum for correcting different
reference datum-created LatLon data, as well as change the default depth units.
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The Map Projection Unlock Tab

Unlocking the Map Projection - This option unlocks the map projection. If the project
is password protected, it’s necessary to know the password
4.4.2.10 Advanced Tab

The Advanced Tab is used to reproject the entire project to use a new reference
datum and coordinate system. This involves recalculating the LatLon and XY of every
wellspot, overlay layer, grid and other associated files. Make sure to have a
backup of the entire project before attempting this.

Background
Reprojecting a project is not trivial. Selecting a reasonable map projection at the
beginning of a project and simply correcting for the other reference datum-based data
with the Datum Tab will largely prevent the need to reproject an entire project.
A “map projection” is an attempt to portray the curved surface of the earth on a flat
piece of paper or computer screen. Map projections have two parts: the reference
datum and the coordinate system. The reference datum is a model of zero elevation,
which is used to calculate longitude and latitude. The coordinate system essentially is
a set of coordinates that transforms latitude and longitude on a globe into XYs on a
flat map.
In a sense, these two parts of a map projection (the reference datum and the
coordinate system) constitute two separate steps. First, the reference datum is used
to calculate LatLons for a location on a globe. Second, the coordinate system
converts this LatLon data into XYs for plotting on a flat map.
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Changing the reference datum of a project means that the old LatLon points need to
be reprojected in order to spot correctly on a map. Since the LatLon data changes,
Petra will apply the coordinate system to calculate new XY points.

Advanced Tab
Practically, changing a project’s reference datum is done in two parts. First,
recalculate the LatLon and XY of every well location, and then Petra will recalculate
the LatLon and XY of all “auxiliary files” including overlays, grids, XYZ files, and
LatLonZ files. The example will show changing a project from Oklahoma North
(NAD27) to Oklahoma North (NAD83).

Reprojecting Well Data and Overlays
The first step to changing a project’s reference datum is to select “Datum Shift Entire
Project…” (highlighted in red).

Here, select the new project reference datum. In the example below, the project is
currently using the NAD27 reference datum, while the new or “Destination” datum is
NAD83. As a reminder, the list of reference datums here is limited by the “Project
Area” dropdown on the Datum Tab. Select the new reference datum form the
dropdown menu and select “Continue” to set the new datum.
After selecting the new datum, Petra compares the current map projection on the right
to the new projection on the left. Notice that the window on the right is empty, as no
coordinate system is set. Next, select “Set New Projection…” (highlighted in red)
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This opens up the coordinate system window. This screen has two major lists: the
Coordinate System Types, and the individual Coordinate System Names. The
Coordinate System Type list (highlighted in blue) shows all coordinate systems
available for the currently selected reference data. In the example below, this list only
shows coordinate systems that use the NAD83 reference datum. Here, select the
type of coordinate system for the project. In the example below, “US State Plane
1983” is selected.
Selecting the coordinate system type populates the Coordinate System Name list with
specific coordinate systems (highlighted in green). In the example below, the
Oklahoma North state plane coordinate system is selected.

This brings up the comparison window again. This time, the window to the right is
filled in with both the current and new map projections. Select “Convert Project” to
continue (highlighted in red). Petra opens one final screen to confirm the changes.
Select OK.
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Reprojecting Overlay files, Grids, LatLonZ, and XYZ files
After converting the well locations, Petra automatically prompts you to apply the same
datum shift to overlay files, grids, XYZ files, and LatLonZ files. Since the well
locations have changed, it’s important to reproject the other data to match. Though
the example below has all auxiliary data checked, you only need to select data
appropriate for your project.

Reprojecting Overlay Layers
The next step is to select which overlay layers to reproject into the new map
projection. Clicking “Select Files” opens up the project’s OVERLAY folder in an
external Microsoft Explorer window. Drag and drop files from the Explorer window
into the “Input Overlay Files” window (highlighted in red). Petra also automatically
creates a backup of all overlay files when a datum shift is applied. The backup
filename simply appends a timestamp (YYYYMMDD_HHMMSS) between the overlay
name and file extension. You can also add a prefix to the backup file name. In the
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example below, the prefix of “BACKUP” is added. Select “Convert Overlay(s)” to
reproject the selected overlay files.

Reprojecting Grids
Next, select the Grids Tab. The Grids Tab shows a list of the grids to be reprojected.
By default, Petra looks in the project’s GRIDS directory. It’s worth noting that the
datum shift tool can only reproject one folder of grids. If your project has multiple grid
folders, you can either move them all into one folder or perform the “Datum Shift Aux
Files” function for each folder.
The Options Tab for the Grid Tab controls a few more options about datum shifting
grids. Petra automatically creates a backup of all grid files when a datum shift is
applied. The backup filename simply appends a timestamp (YYYYMMDD_HHMMSS)
between the grid name and file extension. It’s also possible to add a prefix to the
backup file name. In the example below, the prefix of “BACKUP” has been added.
This tab also controls how Petra resamples the existing grids to fit the new projection.
The grids can be output as rectangular or triangular grids.
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Reprojecting XYZ Files
External XYZ control points need to be reprojected in order to plot correctly on the
map. Under the XYZ Files Tab, select which XYZ files to reproject into the new map
projection. Clicking “Select Files” opens up the project’s root directory folder in an
external Microsoft Explorer window. Drag and drop files from the Explorer window
into the “Input XYZ Files” window (highlighted in red). Petra also automatically
creates a backup of all XYZ files when a datum shift is applied. The backup filename
simply appends a timestamp (YYYYMMDD_HHMMSS) between the XYZ file name
and file extension. You can also add a prefix to the backup file name. In the example
below, the prefix of “BACKUP” is added. Select “Convert Files…” to reproject the
selected XYZ files.

Reprojecting LatLonZ Files
External LatLonZ control points need to be reprojected in order to plot correctly on the
map. Under the LatLonZ Files Tab, select which LatLonZ files to reproject into the
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new map projection. Clicking “Select Files” opens up the project’s root directory
folder in an external Microsoft Explorer window. Drag and drop files from the
Explorer window into the “Input LatLonZ Files” window (highlighted in red). Petra also
automatically creates a backup of all LatLonZ files when a datum shift is applied. The
backup filename simply appends a timestamp (YYYYMMDD_HHMMSS) between the
LatLonZ file name and file extension. You can also add a prefix to the backup file
name. In the example below, the prefix of “BACKUP” is added. Select “Convert
Files…” to reproject the selected LatLonZ files.

4.4.2.11 File Tab

The File Tab saves specific map projections and establishes a default map projection
for all new projects.

Background
In a large multi-user environment, these administrative options are useful for
leveraging the geodetic expertise of a few and applying it to several projects or to the
company as a whole. Saving a map template can be useful for making a backup or
for propagating a specific map projection from one Petra project to another. Similarly,
setting a default system map projection can be useful when all Petra users are
working in a similar geographic environment.

Using the File Tab
Using Map Projection Template
Map Projection Templates simply store the settings of the currently saved map
projection in an external *.MPT file. Especially when using a non-standard custom
projection, template files are useful for making backups of Petra map projections as
well as quickly copying the map projection from one project to another. To save a
map projection template file, select the save button. To load an preexisting template,
select the load button.
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Setting a Default Map Projection
The best time to set a project’s map projection is at the very beginning. A default
projection ensures all new projects system-wide will automatically use one predefined
map projection.

To set a system-wide default projection, select the “Save System Map Projection…”
button under the File Tab of the Map Projection Settings window. This creates a new
file in the system-wide PARMS directory called DEFPROJECTION1.BIN. This file
contains the project’s current map projection. Setting a default projection can be
useful for companies or field offices that are focused on a specific basin where one
map projection is always applicable.
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When new projects are created, Petra will ask the user if they want to use the default
map projection.

4.4.3

Map Projection HowTo Guides

How to Reproject a Project to use a Different Reference Datum
How to Reproject a Project to use a Different Coordinate System (With the Same
Datum)
How to Import New LatLon Data
How to Import New XY data
How to Use Map Projection Administrative Options
4.4.3.1

Reproject an Entire Project to a Different Coordinate System (With Same Datum)

Reprojecting a project to use a new coordinate system is not a trivial task. Make
sure to have a backup of the entire project before attempting this.
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As stated above, Petra uses the project’s coordinate system to calculate XYs from
LatLons. Changing this coordinate system means it’s necessary to recalculate the
XYs. This example will show a project changed from Oklahoma North (NAD27) to
Oklahoma South (NAD27). In this case, both map projections use the NAD27
reference datum, but the coordinate system is different (Oklahoma North vs.
Oklahoma South).

Changing the coordinate system just changes location XYs, not LatLons

Reprojecting Well Data and Overlays
The first step to changing a project’s coordinate system is to open the Map
Projection Settings box. In the example below, the project is an older project with a
“custom” Oklahoma North (NAD27) projection.

A project with a custom map projection

The next step is to set the new coordinate system. The easiest way to do so is to
use one of the standard coordinate systems, so select the “Standard” coordinate
system radio button at the top of the screen and go to the Standard Tab (both
highlighted in red in the example below). This screen has two major lists: the
Coordinate System Types, and the individual Coordinate System Names. The
Coordinate System Type list (highlighted in blue) shows all the different kinds of
coordinate systems available for the currently selected reference datum. In the
example below, “US State Plane 1927” type is selected. Selecting the coordinate
system type populates the Coordinate System Name list with all the available
coordinate systems (highlighted in green). In the example below, the Oklahoma
South state plane coordinate system is selected.
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Setting a standard coordinate system

Select “Save” to enact the changes and convert the project. Since the coordinate
system has changed, the XYs will need to change as well. Make sure to select
“Yes” when Petra asks to recomputed XY well locations using the new map
projection.

Confirming the new map projection

Reprojecting Grids
Reopen the map module, and verify that the well locations and overlay files line up
correctly. It might be necessary to reset the data limits to reflect the new locations
of the well and overlay data. To do so, select Display>Auto Scale Mode & Map
Extents From Wells.
The wells and overlay should now be lined up using the new coordinate system.
The final step here is to reproject the grids. Select Contours>Grids>Convert Grid
Map Projections.
The Grids Tab shows the grids contained inside the project’s GRIDS folder. To
change this directory, select the Dir Tab. Next, select the grids to reproject. The
MapProjection Tab shows the map projection of the grids on the left in green and the
new grid map projection on the right in blue. Notice that in this example, the grid was
Oklahoma North (NAD27) and will be reprojected to Oklahoma South (NAD27).
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Selecting grids to reproject (Left), examining the old and new grid projections (Right)

The Options Tab gives a little finer control on how the grids will be reprojected.
Petra automatically stores backup copies of all reprojected grids. By default, Petra
adds “NEW” as a suffix to new grids. It’s possible to change it by entering new text,
but there needs to be some text here. This tab also controls how Petra resamples
the existing grids to fit the new projection. You can output the newly reprojected
grids as rectangular or triangular grids.
The Dir Tab changes the directory of reprojected grids. This tool will only reproject
grids within this folder. If your grids are stored in multiple folders, it’s probably best
to perform this operation several times to get all different folders. To reproject the
grids, select OK. Petra will review the selected grids and generate a report.

Setting the reprojected settings (Left), the directory of the grids to reproject (Right)
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Reproject an Entire Project to a Different Reference Datum

Reprojecting a project to use a new reference datum is not a trivial task. Make sure
to have a backup of the entire project before attempting this.
Since this process changes the reference datum on which all LatLon data relies,
Petra will recalculate the LatLons based on the new reference datum. Since the
LatLon data changes, Petra will apply a new coordinate system to calculate new XY
points. The example will show changing a project from Oklahoma North (NAD27) to
Oklahoma North (NAD83). While both these coordinate systems are named the
same (“Oklahoma North”), they are based on two separate datums so they calculate
XYs differently.

Changing the reference datum changes both LatLons and XYs

Practically, changing a project’s reference datum is done in two parts. First,
recalculate the LatLon and XY of every well location, and then recalculate the LatLon
and XY of all “auxiliary files” including overlays, grids, XYZ files, and LatLonZ files.

Reprojecting Well Data and Overlays
The first step to changing a project’s reference datum is to open the Map Projection
Settings box. In the example below, the project has a “Standard” Oklahoma North
(NAD27) projection.

A project with a Oklahoma North (NAD27) projection

The next step is to use the Datum Shift Utility to reproject well data to use the new
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reference datum. Go to the advanced tab, and select “Datum Shift Entire
Project…” (highlighted in red).

Selecting "Datum Shift Entire Project"

Here, select the new project reference datum. In the example below, the project is
currently using NAD27, while the new or “Destination” datum is NAD83. Select the
new reference datum form the dropdown menu and select “Continue” to set the new
datum.
After selecting the new datum, Petra compares the current map projection on the
right to the new projection on the left. Notice that the window on the right is empty,
as no coordinate system is set. Next, select “Set New Projection…” (highlighted in
red)

Selecting the new datum (Left), preparing to select the coordinate system (Right)

This opens up the coordinate system window. This screen has two major lists: the
Coordinate System Types, and the individual Coordinate System Names. The
Coordinate System Type list (highlighted in blue) shows all coordinate systems
available for the currently selected reference datum. In the example below, this list
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only shows coordinate systems that use the NAD83 reference datum. Here, select
the type of coordinate system for the project. In the example below, “US State
Plane 1983” is selected.
Selecting the coordinate system type populates the Coordinate System Name list
with specific coordinate systems (highlighted in green). In the example below, the
Oklahoma North state plane coordinate system is selected.

Selecting a standard coordinate system

This brings up the comparison window again. This time, the window to the right is
filled in with both the current and new map projections. Select “Convert Project” to
continue (highlighted in red). Petra opens one final screen to confirm the changes.
Select OK.

A comparison between the old and new projections (Left), confirming the datum shift (Right)

Reprojecting Overlay files, Grids, LatLonZ, and XYZ files
After converting the well locations, Petra automatically prompts you to apply the
same datum shift to overlay files, grids, XYZ files, and LatLonZ files. Since the well
locations have changed, it’s important to reproject the other data to match. Though
the example below has all auxiliary data checked, you only need to select data
appropriate for your project.
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Applying the datum shift to overlays, grids, XYZ files, and LatLonZ files

Reprojecting Overlay Layers
The next step is to select which overlay layers to reproject into the new map
projection. Clicking “Select Files” opens up the project’s OVERLAY folder in an
external Microsoft Explorer window. Drag and drop files from the Explorer window
into the “Input Overlay Files” window (highlighted in red). Petra also automatically
creates a backup of all overlay files when a datum shift is applied. The backup
filename simply appends a timestamp (YYYYMMDD_HHMMSS) between the
overlay name and file extension. You can also add a prefix to the backup file name.
In the example below, the prefix of “BACKUP” is added. Select “Convert Overlay(s)”
to reproject the selected overlay files.

Selecting the overlay to reproject (Left), setting the location of the reprojected overlay (Right)

Reprojecting Grids
Next, select the Grids Tab. The Grids Tab shows a list of the grids to be
reprojected. By default, Petra looks in the project’s GRIDS directory. It’s worth
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noting that the datum shift tool can only reproject one folder of grids. If your project
has multiple grid folders, you can either move them all into one folder or perform the
“Datum Shift Aux Files” function for each folder.
The Options Tab for the Grid Tab controls a few more options about datum shifting
grids. Petra automatically creates a backup of all grid files when a datum shift is
applied. The backup filename simply appends a timestamp
(YYYYMMDD_HHMMSS) between the grid name and file extension. It’s also
possible to add a prefix to the backup file name. In the example below, the prefix of
“BACKUP” has been added. This tab also controls how Petra resamples the existing
grids to fit the new projection. The grids can be output as rectangular or triangular
grids.

Selecting a grid to reproject (Left), setting the location of the reprojected grid (Right)

Reprojecting XYZ Files
External XYZ control points need to be reprojected in order to plot correctly on the
map. Under the XYZ Files Tab, select which XYZ files to reproject into the new map
projection. Clicking “Select Files” opens up the project’s root directory folder in an
external Microsoft Explorer window. Drag and drop files from the Explorer window
into the “Input XYZ Files” window (highlighted in red). Petra also automatically
creates a backup of all XYZ files when a datum shift is applied. The backup
filename simply appends a timestamp (YYYYMMDD_HHMMSS) between the XYZ
file name and file extension. You can also add a prefix to the backup file name. In
the example below, the prefix of “BACKUP” is added. Select “Convert Files…” to
reproject the selected XYZ files.
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Selecting the XYZ file to reproject (Left), setting the location of the reprojected XYZ file (Right)

Reprojecting LatLonZ Files
External LatLonZ control points need to be reprojected in order to plot correctly on
the map. Under the LatLonZ Files Tab, select which LatLonZ files to reproject into
the new map projection. Clicking “Select Files” opens up the project’s root directory
folder in an external Microsoft Explorer window. Drag and drop files from the
Explorer window into the “Input LatLonZ Files” window (highlighted in red). Petra
also automatically creates a backup of all LatLonZ files when a datum shift is
applied. The backup filename simply appends a timestamp
(YYYYMMDD_HHMMSS) between the LatLonZ file name and file extension. You
can also add a prefix to the backup file name. In the example below, the prefix of
“BACKUP” is added. Select “Convert Files…” to reproject the selected LatLonZ
files.

Selecting the LatLonZ file to reproject (Left), setting the location of the reprojected LatLonZ file (Right)

*This example essentially changes the map projection from the NAD 27 Oklahoma
North state plane to the NAD 83 Oklahoma North state plane. While both these
coordinate systems are named the same (“Oklahoma North”) and they share the
same north and southern latitudes, they are based on two separate ellipsoids so
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they calculate XYs differently.
4.4.3.3

Use Map Projection Administrative Options

While importing new data with a different projection into a project is fairly common,
changing an entire project’s map projection is usually rare. As such, the risks of bad
map projections will usually outweigh the rewards of all users being able to easily
work with the project’s map projections. Limiting access to changing map
projections is a good way to prevent accidents and ensure project stability.

Setting a Default Projection
The best time to set a project’s map projection is at the very beginning. A default
projection ensures all new projects system-wide will automatically use one
predefined map projection.
To set a system-wide default projection, select the “Save System Map Projection…”
button under the File Tab of the Map Projection Settings window. This creates a new
file in the system-wide PARMS directory called DEFPROJECTION1.BIN. This file
contains the project’s current map projection. Setting a default projection can be
useful for companies or field offices that are focused on a specific basin where one
map projection is always applicable.

Saving a default map projection

A new project using the default projection
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Locking the Map Projection
One the map projection is set, locking the project’s map projection is an easy and
quick way to prevent accidents. On the Lock Tab of the Map Projection Settings
window, select “Lock Map Projection…” Locking a project’s map projection disables
changing the project’s datum, coordinate system, or XY units (feet or meters). It’s
worth noting that any user can still change the import datum. Unlocking a project is
fairly easy and can be performed by all users in the project. Simply select “Unlock
Map Projection…” on the Unlock Tab.

Locking a project's map projection

Adding a password adds significantly more security as only users with the password
can change the map projection. On the same Lock Tab, select “Password Protect
Lock” option before locking the map projection. This saves the current map
projection, and prompts the user to set and confirm a new password. Again, this
disables changing the project’s datum, coordinate system, or XY units (feet or
meters). Any user can still change the import datum, however.

Setting Map Projection Administrative Privileges with Petra.
INI
Another way to limit the users able to modify map projections is with an
administrative list stored in a Petra.INI file. With this method, there are no
passwords to remember and the administrative list can be applied to either one
Petra project or to all Petra projects on a server.
Petra.INI is just a plain text file with an *.INI extension. This file isn’t created
automatically, so it’s necessary to either create it from scratch or copy the sample
Petra.INI located in the PetraSRV\PARMS folder. To limit access on a single project,
save Petra.INI inside the project’s root directory (e.g. H:\Projects\SMITH FIELD).
To limit access on every project on a server, save Petra.INI to the folder where the
Petra executables are located (by default, this is in the PetraSRV directory).
Once the file is placed in the proper spot, edit it using Microsoft Notepad or
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WordPad. The example below prevents normal users from saving default map
projections or changing a project’s existing map projection. To turn off each
individual limitation set the item to YES. As an example,
SAVEDEFAULTPROJECTION =YES allows all users to save default map
projections. The ADMINLIST sets up a specified list of users as admins. In the
example below, JHK and KHM are on the administrator list, so they can change map
projections or save default projections.
[GENERAL]
SAVEDEFAULTPROJECTION=NO
; This option prevents users saving default projections
ALLOWUSERPROJECTION=NO
; This option prevents users from creating "User Defined" coordinate systems under the ; standard tab.

[USERSOURCE]
ENABLED=1
ADMINLIST=JMK, KHM
; This sets the administrator list.

Users JMK and KHM are administrators.

Map projection settings as viewed by a normal user. Note the lack of a "Save" button.

An admin list relies on a set of user names. To change user names while inside a
project, select Project>Settings>Set User Source Code… and enter the appropriate
user name.

Changing the user name

For more information on using Petra.INI see “Petra Usage in Large Multiuser
Environments” available at: https://petraftp.ihsenergy.com/petramultienv.pdf
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Convergence Angle Correction

Convergence Angle Background
In the figure below, the 90° W, 100° W and 110°W longitude lines are highlighted in
red on top of a map of the US. The central meridian at 100° W is straight up and
down, while 90° W and 110°W are slightly curved towards the north pole.
Importantly, all three lines of longitude are perfectly north and south, but are curved
and distorted by being on a flat surface. “True north” is at the top of the page, but
away from the central meridian the local direction of north known as “grid north” will
be a little different. To better illustrate the difference, there are two sets of arrows on
the figure – one to the west in Utah and one to the east in Missouri. The longer arrows
on the figure show true north at the top of the map, while the shorter arrows following
the curved longitude lines reflect the local grid north. The difference between these
two directions is called the “convergence angle”, and is shown on the figure to the
right. Odds are good you’ve actually already run into this before – angled section lines
(common in west Texas and New Mexico) follow grid north rather than true north.

Directional wells need to be projected to your map’s grid north rather than true
north in order to plot on the map correctly. To better illustrate the point, a
directional well going due north should be parallel to the north-south section lines
The problem is that there’s no consistent standard for reported directional survey
convergence angle correction. While most companies report survey data relative to a
projection-dependant grid north, many directional companies report survey data
relative to true north. Failing to add a convergence angle to true north-based data or
adding a convergence angle correction to grid north-based data will both result in a
wellpath that’s plotted in the wrong place.
Every well stores a “flag” that tells Petra if the survey data stored in the database is
set to true north (and thus needs a convergence correction) or to grid north (which
does not need a convergence correction). By default, Petra assumes that the
directional survey is relative to true North. In other words, it automatically assumes
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that all survey data needs a convergence correction. If a well is already set to grid
north, it’s necessary to disable this correction.
There are two options for changing convergence angle corrections. One option is to
simply turn off all convergence angle correction, or it’s possible to change the well
convergence angle settings (or “flag”) for each well.

Turning off all Convergence Correction
The simplest way to turn off all convergence correction is to select the “Survey
Convergence Angle” button on the second toolbar on the Map Module. To open and
close this toolbar, select the “<<” button on the far right side of the regular toolbar

Turning off all convergence angle correction (currently active)

Turning on all convergence angle button (currently inactive)

This is a relatively quick way of turning off all convergence angle correction without
changing individual well flags.

Setting the Convergence Correction “Flag” for a Single Well
Odds are good, however, that the directional wells in any given project will be a mix of
grid and true north-based surveys. In order to correctly draw every well, Petra stores
a “flag” for each well. To change this convergence correction flag for a single well,
first select the correct well in the Main Module. Next, open the Directional Survey Data
tool by going to the Location Tab and select the Dir. Survey button. Finally, navigate
to the Advanced Tab on the Directional Survey Data box and select XY Grid North
(Never Rotate for Map Projection) under the Survey data Orientation section.

Setting the convergence correction for a single well
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Select Survey Orientation Function
This tool can recommend whether an individual well should or should not have a
convergence correction, as well as set the flags for all directional wells in a project to
either use grid or true north. The "analyze" tool calculates a BH location for the
survey data both with and without a convergence correction, and compares these
locations to the actual header-supplied BH location.
To open this tool select Compute>From Locations>Set Dev. Survey Grid Orientation
from the Main Module.

Reviewing convergence correction for all directional wells

Analyze Survey and Report Only - This tool will compare the actual BH location to BH
locations calculated from directional survey data, but will only generate a report called
"DEVFLAG" in the project directory. This report will include the well's WSN and UWI,
as well as the convergence angle at the well's location (calculated from the map
projection). This will also include the calculated XY locations for the BHL without a
convergence correction (true north), XY location for the BHL with a convergence
correction (grid north), and the actual BH location in the project.
In the example below, most wells' true north-calculated BH locations are close to the
actual BH locations, and the convergence correction is set correctly. The highlighted
well, however, shows that the current convergence correction is set to grid north,
while the true north BHL is closer to the actual BH location.
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A survey orientation report

Analyze Survey and Set based on BH Location - This tool will compare the actual BH
location to BH locations calculated from directional survey data, and change the
convergence angle correction flags in the project based on the recommendations.
Set All Flags to "GRID NORTH" (Never Rotate) - This option changes all directional
survey convergence angle flags in the project to "grid north." This effectively says that
all wells in the project already have the convergence correction applied to the
directional survey data.
Set All Flags to "TRUE NORTH" (Rotate) - This option changes all directional survey
convergence angle flags in the project to "true north." This will apply the convergence
correction to all wells in the project.

4.5

Main Module Toolbars
The Main Module's toolbar has links to most modules as well as links to opening and
closing projects.

The Main Module's Toolbar

Petra can also use custom, user-created toolbars with direct links to most functions in
Petra. For more information on custom toolbars, see here.
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- This button creates a new project.
- This button opens an existing project.
- This button closes the current project.
- This button opens the Select Wells by Data Criteria tool.
- This button opens the View/Edit Zone Data tool.
- This button opens the Map Module.
-This button opens the Cross-Section Module.
- This button opens the Spreadsheet Module.
- This button opens the Log Cross Plot Module
- This button opens the Z Cross Plot Module
- This button opens the Histogram Module
- This button opens the Decline Curve Analysis Module
- This button opens the Production Group Plots and Normalization Tool
- This button opens the Seismic Module
- This button opens PetraSeis. Note that this button will be grayed out if
PetraSeis isn't installed.
- This button opens the Thematic Mapping Module.
- This button opens the 3D Visualization Module.
- This button opens the Slip Logs Module
- This button opens the Log Correlation Module
- This button opens the Directional Well Module.
4.5.1

Custom Toolbars

In addition to the main Petra toolbar, Petra can use up to three custom toolbars at
the top or left side of the Main Module. Each of these custom toolbars can contain a
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number of buttons which correspond to over 200 available menu options.

Enabling Custom Toolbars
To add a custom toolbar, select View>Custom Toolbar 1>Enabled.
For Toolbar 2 or 3, select the relevant toolbar menu on the dropdown (View>Custom
Toolbar 2>Enabled enables toolbar 2, for example).
Next, select the location for the desired toolbar. Custom toolbars can either be at
the top of the Main Module (immediately below the main toolbar), or on the left side
of the Main Module.
View>Custom Toolbar 1>Dock Top or View>Custom Toolbar 1>Dock Left

Petra without a custom toolbar (left) and with a blank custom toolbar immediately below the main toolbar(right)
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To remove custom toolbars, either select the relevant "enabled" command, or select
View>Reset to Default View to remove all custom toolbars.

Opening the Custom Toolbar's Options
Once a custom toolbar is added to the Main Module, the next step is to add
commands. Select the
button on the empty custom toolbar, and select
Options>Customize Custom Toolbar #1.

Selecting the Customize Custom Toolbar button

This opens the customizer dialog for that particular custom toolbar.

Adding Commands to Custom Toolbars
The "Command Groups" drop shows the same structure as the Menu's at the top of
the main module. Selecting a menu populates the "Commands" list box with all
commands available for that menu. You can then select the desired command along
with a different icon (all default to the same) and add it to the "ToolBar Items".
Once a command is added to the "ToolBar Items" you can then change the Caption
and/or Hint. Selecting the "Show Caption" option will include the "Item Caption" on
the toolbar with the icon. Doing this for all desired commands results in a completely
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customized toolbar!

The Customizer modifies the command buttons on custom toolbars.

- This button moves the selected command to the top of the list. Commands at
the top of the list will be at the far left of toolbars docked at the top of the Main
Module.
- This button moves the selected command up the list. Commands at the top of
the list will be at the far left of toolbars docked at the top of the Main Module.
- This button moves the selected command down the list. Commands at the
bottom of the list will be at the far right of toolbars docked at the top of the Main
Module.
- This button moves the selected command to the bottom of the list. Commands
at the top of the list will be at the far left of toolbars docked at the top of the Main
Module.
- This button adds the selected command to the ToolBar Items list.
- This button adds a separator to the ToolBar Items list.
- This button removes the selected command from the ToolBar Items list.
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- This button clears all commands from the ToolBar Items list.

If All Else Fails
All custom toolbar settings are stored in the Client Parms folder in a file named
"tbSettingsMain.def". This file can be copied to other clients/computers if so desired.
Deleting this file will also return Petra to it's default state with no custom toolbars or
commands configured.

4.6

Main Module Tabs
The Main Module has several tabs that display data about the various kinds of data
loaded into the database. Each tab will display data relevant to the selected well on
the well list on the left side of the screen.

Project Tab
Well Tab
Location Tab
Formation Tops Tab
Zone Tab
Logs Tab
IP Tests Tab
FM Tests Tab
Cores Tab
Perfs Tab
Shows Tab
Production Tab
Prod Cums Tab
Rasters Tab
Other Tab
Scout Tab
View Tab
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Project Tab
The Project Tab displays and controls some of the basics of an entire Petra project,
including the description, parameters and project data directories, the total well count,
and the map projection.

The Project Tab displays project-wide information.

Project Description
The Project Description is used as a label on graphic displays. To modify the project
description, type over the description data that is displayed in the Project Description
field.

Parameters and Project Data Directories
Parameters Dir - This entry displays the location of the Private Parameters directory
for the currently selected user.
Project Data Dir - This entry displays the location of the Project Data Directory for the
project.

Well Count
© 2014

Main Module

331

Total Number of Wells In Project - This entry displays the total number of wells in the
project.
Number of Currently Selected Wells - This entry displays the number of currently
selected wells in the project.

Map Projection
This box displays some of the details on the Petra project's map projection, including
reference datum, coordinate system, and units of measurement. To change the map
projection select the

4.6.2

button.

Well Tab
The Well Tab displays and modifies information about the selected well on the well
list. Typing a value in the appropriate entry field will change that field.

The Well Tab displays header and symbol information about the selected well.

- These buttons change between the currently selected wells in the project.
Alternatively, select the left mouse button on the well list displayed on the left side of
the main screen.
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- This button saves any changes made to the database. Note that Petra also
prompts to save changes before selecting another well if any fields have changed.
- This option undoes the last changes made to the well if the button is displayed.

Header Information
The Well Tab displays a few well header basics, including UWI, well number, name,
operator, lease, and field.

Well Symbol and Description
This dropdown selects the map symbol displayed on the Map and Cross Section
Modules.

Active Datum
The active datum is the depth reference for the well. This is commonly used to
converted MD depths to SS depths. The dropdown selects the active datum for the
well.
KB = Kelly Bushing, DF = Drill Floor, GR = GRound, SEIS = SEISmic

Remarks
This field contains remarks about the well.

4.6.2.1

Build Well Labels

The Build Labels function can build a "label" string and store in either the Well Label
or Sort Key field using parts from other well header fields. This can be very useful in
project areas such as the Mid Continent where many wells have the same well name
or number in different locations. Building a label using section-township-range fields
makes well identification much easier. Well Labels may contain up to 32 characters.
To build new well labels, select Wells>Build Well Label from the menu bar at the top
of the Main Module.
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Data Tab
Well Label Components
The objective in building the well labels is to define each of the Well Label
Components. Each component is selected from the Select Component section along
with its length and starting position.
Well labels will be built for either "All Wells" or only the "Currently Selected Wells"
depending on the option selected.
Add - This button adds the selected component on the dropdown to the Well Label
© 2014

334

PETRA Help

Components list.
Replace - This button replaces the highlighted component on the Well Label
Components list with the component on the dropdown menu.
Drop - This button removes the highlighted component on the Well Label
Components list.

Start Column - This entry sets the starting position in the component field. For
example, if you wanted the API series number, set the start column to 6 and the
length field to 5.
Length - This entry sets the the number of characters extracted from the component
field.
Use Defaults - This option will create labels using the UWI for each well.
Build - This option builds the labels and writes the results to the database.

Template
You can save and load your well label component definition to a .BWL file using the
Template Save and Load functions. The template file contains the settings to rebuild
the labels using the same scheme as previously defined.

Custom Labels File
You can save a file containing the actual well label values using the Save and Load
functions under the Custom Labels File section.

Options Tab
Trim Leading Zeros From TRS Data - This option will trim leading zeros from
township, range and section values. For example, a value of 03 to be written as 3.
Drop Unnecessary Special Characters - If you use special characters as a
component, such as, "-", "/" of "#", it is possible because of other components being
blank, that you are left if leading, trailing or nothing but special characters. This
option will remove those characters.
Store Computed Label In - This option determines whether the computed label is
stored in the Well Label field or the Sort Key field in the database.
Presets - This section contains predefined component lists for your usage. These are
kept as .BWL files in the "parms" folder under the Petra program directory (typically
petrasrv\parms or geoplus1\parms). After selecting a Preset, click the "Load
Preset" button to load and see the component list.
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Location Tab
The Location Tab displays and controls individual well locations and directional
surveys, as well as the project-wide map projection.

The Location Tab displays location information about the selected well.

- This button saves any changes made to the database. Note that Petra
also prompts to save changes before selecting another well if any fields have
changed.
- This option undoes the last changes made to the well if the button is displayed.

Surface Location
These entries show the LatLons and XYs for the selected well's surface location.

Bottom Hole Location
These entries show the LatLons and XYs for the selected well's bottom hole location.
Note that these entries will all be 0's where there is no specific bottom hole location.
Make Bottom Hole Equal To Surface Location - This option overwrites the bottom hole
location with the location stored in the surface hole location.

Display Lat-Lon As
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This entry sets how Petra displays LatLons. LatLons can display either as degrees,
minutes, seconds or as decimal degrees.
- This button locks the currently selected well's location. A locked
well location won't change either my manual changes to the database or through data
imports. Note that project-wide location locking is enabled or disabled from the
Program Options tool's Locks Tab.
- For directional wells, this button uses survey data to calculate the
bottom hole location.

- This button opens the wells location in bing maps. This can be useful
for quickly checking conditions for future well locations, such as spotting a well in the
middle of a golf course or elementary school.
- This button opens the wells' directional survey data window. Deviated
wells are displayed in map form as a small triangle spotted at the surface location and
the well symbol spotted using the directional survey data and a user-specified depth
at which the well symbol is positioned along the projected borehole path or worm
track.
- This button opens the Congressional Location Information window
- This button opens the Offshore Location Information window.
- This button opens the Texas Location Information window.
- This button opens the NorthEast Location Details window.
- This option opens the Map Projection Settings window.
4.6.3.1

Directional Survey Data

Petra uses directional survey data to compute the positions of deviated and horizontal
wells for mapping, cross-sections, and calculations. Survey data from a directional
drilling company usually consists of some combination of measured depth (MD),
inclination (INC), azimuth (AZI) true vertical depth (TVD), North-South offset footage
(NS) and East-West offset footage (EW). To access a well’s survey data, select the
“Dir Survey” button on the Location Tab in the Main Module.

Data Conventions
The convention for inclination is 0 degrees for vertical and 90 degrees for flat.
Inclinations above 90 degrees are inclined up. As an example, an 86 degree
inclination is going down through section at 4 degrees below horizontal, and a 94
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degree inclination is going up through TVD at 4 degrees above horizontal.
Azimuth data is commonly measured in positive degrees measured clockwise from
north, where 0 degrees is north, 90 is east, 180 is south, and 270 is west. This
convention is sometimes called “unformatted.” Less commonly, azimuth data consists
of a numeric compass heading in degrees preceded by either the letter N or S and
followed by the letter E or W. As an example, N30E means 30 degrees east of north.
S60W means 60 degrees west of south. This convention is sometimes called
“formatted.” Petra can import and display azimuth data in either convention.
The convention for NS offsets is north offsets are positive and south offsets are
negative. Similarly, east offsets are positive, and west offsets are negative.
General Tab
Data Tab
Preview Tab
Import/Export Tab
Calc TVD Tab
Method Tab
Advanced Tab
Maintenance Tab

Working with Multiple Directional Surveys
Petra can store any number of survey data sets (both real and planned) for any well.
Multiple surveys are really intended only for proposed and actual surveys. It’s best
to keep each actual completion (even those from the same surface location)
separate and in different wells in Petra. Keeping multiple drilled laterals in the
same well greatly limits your ability to display in cross-section, map, and grid as well
as store any useful header info or petrophysical data. The multiple survey toolbar is
available on the bottom of every tab on the Directional Survey Data window.

The Multiple Directional Survey section of the Directional Survey Data window.
4.6.3.1.1 Grid & True North / Convergence Correction

Background
In the right figure below, there’s a flat, 2-D picture of the spherical, 3-D Earth. This
figure is, in effect, a crude map projection. The center of the image on the right is on
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the equator and 100° W. The lines of longitude at 90° W, 100° W and 110°W are
outlined.
On the right side of the figure, we’ve stripped out the picture of the globe to leave the
three longitude lines where one is straight, and two are curved. Since each one of
these lines represents a line of longitude, all three of these lines are straight
north and south. The curvature is the consequence of projecting the curved surface
of the earth onto a flat surface. The straight line in the center is the “central
meridian.” The central meridian defines the center of the projection and
consequently has the least distortion. Away from the central meridian, however, the
distortion increases and longitude lines start to curve - especially at higher latitudes.
N

110° W

100° W

90° W

S
A globe (modified from Google Earth, 2008) highlighting 110, 100, and 90 degrees longitude (Left), the same
longitude lines without the globe (Right). Modified form Dana (1999)

“True north” is at the top of the map, but away from the central meridian the
local direction of north known as “grid north” will be just a little different. To
better illustrate the difference, there are two sets of arrows on the figure – one to
the west in Utah and one to the east in Missouri. The longer arrows on the figure
show true north at the top of the map, while the shorter arrows following the curved
longitude lines reflect the local grid north. The difference between these two
directions is called the “convergence angle”, and is shown on the figure to the right.
Odds are good you’ve actually already run into this before – angled section lines
(common in west Texas and New Mexico) follow grid north rather than true north.
Looking closely at the Carter-Knox map shows that these section lines are angled
slightly as well. The difference between true north and grid north for this area with
the UTM Zone 14 projection is around 0.8 degrees.
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True North

Grid North

Convergence
Angle

Carter Knox Field with the same longitude lines highlighted (Left), a diagram of true north vs. grid north (Right)

Directional data need to be projected to your map’s grid north rather than true north
in order to plot on the map correctly. To better illustrate the point, a directional well
going due north should be parallel to the north-south section lines – even if the
section lines are angled like in the Carter Knox project.
The problem is that there’s no consistent standard for reported directional survey
convergence angle correction. While most companies report survey data relative to a
projection-dependant grid north, many directional companies report survey data
relative to true north. Failing to add a convergence angle to true north-based data or
adding a convergence angle correction to grid north-based data will both result in a
wellpath that’s plotted in the wrong place.

Turning off all Convergence Correction
The simplest way to turn off all convergence correction is to select the “Survey
Convergence Angle” button on the second toolbar on the Map Module. To open and
close this toolbar, select the “<<” button on the far right side of the regular toolbar

Turning off all convergence angle correction (currently active)

Turning on all convergence angle button (currently inactive)

This is a relatively quick way of turning off all convergence angle correction without
changing individual well flags.

Setting the Convergence Correction “Flag” for a Single Well
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Odds are good, however, that the directional wells in any given project will be a mix
of grid and true north-based surveys. In order to correctly draw every well, Petra
stores a “flag” for each well. To change this convergence correction flag for a single
well, first select the correct well in the Main Module. Next, open the Directional
Survey Data by going to the Location Tab and select the Dir. Survey button. Finally,
navigate to the Advanced Tab on the Directional Survey Data box and select “XY
Grid North (Never Rotate for Map Projection)” under the Survey data Orientation
section.

Setting the convergence correction for a single well

Setting the Convergence Correction “Flags” for All Directional
Wells
To change the convergence correction flags for all wells, select Compute > from
Locations > Set Dev. Survey Grid Orientation from the Main Module. Here, you can
select to disable or enable the convergence correction for all wells with the bottom
two options: Set All Flags to “GRID NORTH” or Set All Flags to “TRUE NORTH.”

Reviewing convergence correction for all directional wells

Petra’s “Analyze Survey” tool can shed light on whether a convergence angle should
or should not be applied to a particular well. Essentially, Petra calculates a BH
location for the survey data both with and without a convergence correction. These
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two BH locations can then be compared with the actual header-supplied BH location.
Based on this comparison, Petra can recommend whether an individual well should
or should not have a convergence correction. The example below shows a report
generated from the first option, “Analyze Survey and Report Only.”

The results of a Petra review of BHL locations and convergence corrections

In the example above, most surveys show that the true north BH is closer to the
actual BH, so the convergence correction is set correctly. The highlighted well,
however, shows that the current convergence correction is set to grid north, while
the true north setting is closer. Petra can either make just a report or change the
convergence flags for each well automatically.
4.6.3.1.2 Multiple Directional Surveys

Petra can store any number of survey data sets (both real and planned) for any well.
Multiple surveys are really intended only for proposed and actual surveys. It’s best
to keep each actual completion (even those from the same surface location)
separate and in different wells in Petra. Keeping multiple drilled laterals in the
same well greatly limits your ability to display in cross-section, map, and grid as well
as store any useful header info or petrophysical data. The multiple survey toolbar is
available on the bottom of every tab on the Directional Survey Data window.

Current View Dropdown
This dropdown sets the currently displayed survey definition. By default, Petra
creates two entries: “Actual” and “Proposed.” A “~” next to the definition signifies
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that the survey definition contains data.
Survey Def Maintenance - This button opens the Survey Def Maintenance tool, which
changes how Petra labels different sets of surveys.
4.6.3.1.2.1 Survey Definition Maintenance

Edit Survey Definitions Tab
By default, Petra creates two survey definitions for “Actual” and “Proposed” survey
data sets. Note that neither of these default entries can be deleted. This window
also modifies each survey definition’s default color, which can be displayed in the
Cross-Section Module.

The Edit Survey Definitions Tab allows for any number of different survey data sets to
be created, which is usually used for different proposed survey plans. To add a new
survey definition, select “Add Definition” and enter in the new survey definition’s name
and description. To delete a new survey definition, select the desired survey row and
select “Delete Definition.” Note that all survey information contained in the
deleted survey definition for all wells will be deleted.
The “Get well count for each definition” button counts the total number of all wells in
the project containing survey information in each survey definition.

Other Survey Options Tab
Import Options Tab
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By default, Petra loads new survey information into the “Actual” survey definition. The
Import Options tab sets which survey definition Petra stores new surveys by default.
Note that importers elsewhere in Petra have the option to change the destination of
new surveys.

Set Default Definiitons Tab
This tab sets the “Active” and “Secondary” definitions for all selected wells (selected
in Main Module). “Active” surveys will be the set displayed in the various modules, as
well as the survey used in all calculations requiring survey data. “Secondary” surveys
can be displayed alongside the “Active” survey in the Cross-Section Module and the
3d-Viz Module.
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Copy Survey(s) Tab
This tab copies survey data from one definition to another for the current well, Main
Module selected wells, or for all wells in the project. This option overwrites all survey
data in the destination definition. In the example below, “Actual” surveys will overwrite
all survey data in the “Proposed” definition.

4.6.3.1.3 Directional General Tab

The General Tab shows the units for both depths and XY offsets. Remarks can be
stored in the large “remarks” text box in the middle of the screen.
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Compute
This section quickly converts MD to TVD or vice versa. Note that while every MD has
only a single TVD, a single TVD can have multiple valid MD values; Petra will select
the first MD value with the desired TVD.

Calculating a MD's TVD (left), and calculating a TVD's MD (right)

Delete Survey... - This button is used to delete all survey data from memory. You
must then choose the OK button to permanently delete the survey from the database.
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Lock Survey - This button saves all changes to the database and prevents further
changes to the survey data. A well with a locked survey shows a red outline around
the well information on the top of the screen, on all survey information on the Data
Tab, and on the “Dir Survey…” button on the main Module’s Location Tab. To unlock
the survey, select the “Unlock Survey” button in the same location.
Disable Use of Survey For This Well - This option disables directional surveys for the
well. Petra will simply use the surface and bottom hole location on the Main Module's
Location Tab.
Horizontal well - This option flags the selected well as a "horizontal well." Petra can
use this flag in data searches and other operations.
4.6.3.1.4 Directional Data Tab

The Data Tab shows the actual survey points stored in Petra’s database in a
spreadsheet format. It will be blank for wells with no survey data. New data points
can be manually added or old values can be changed. While it’s possible to enter in
an entire wellbore’s survey points manually on the Data Tab, it’s almost always faster
to use the import utility on the Import/Export Tab.

The Directional Survey Data's Data tab showing the well's individual survey points.

XY Offsets Mode and Inc / Azimuth Mode
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Data values can either be viewed and edited by MD, TVD, INC, and AZI in "XY
Offsets Mode" or by MD, INC, EW, NS in “Inc/Azimuth Mode.” Petra will compute
EW and NS offsets from entered inclination and azimuth data but will not compute the
inclination and azimuth from offset data. From a user’s perspective, changing the
offset data deactivates inclination and azimuth data. Modifying each point’s MD, INC,
and AZI gives a little more flexibility later
Note that Petra can display or import azimuth data in either the formatted or
unformatted convention (e.g. “N25E” or “25”). By default, Petra displays the
“formatted” convention. Selecting the “Dec Deg Azimuth” button instead shows
azimuth in the “unformatted” convention.

XY and Depth Units
Set the "XY Units" and "Depth Units" combo boxes to indicate the units of the survey
data. Note that this option does not convert the data at all – it just tells Petra whether
the numbers used are in feet or meters.

Adding and Modifying Data in the Data Window
Moving around in the data spreadsheet is similar to other spreadsheet programs. The
arrow keys, clicking in different cells, and the tab key all navigate through the data
spreadsheet. To add a new row, select the down arrow on the last row or press tab
or enter keys in the last cell of the last row. To insert a row above the currently
selected row, press the Alt and Insert keys simultaneously or right-click the mouse
and select "Insert New Row." To delete the currently selected row, press the Alt and
Delete keys simultaneously or right-click the mouse and select "Delete Current Row."
After making changes, select the "Keep Changes" button to update the database.

Dec Deg Azimuth - This option instead displays azimuth directions in decimal degrees
rather than compass directions.
Print - This button sends the spreadsheet to the printer.

4.6.3.1.5 Directional Preview Tab

The Preview Tab displays projections of the wellbore’s path in three different planes:
EW vs. depth, NS vs. depth, and a map view. This tab also opens a 3D visualization
box with the outline of the wellbore.
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The Directional Survey Data's Preview Tab displaying two cross sections and a map view of a directional well

Data Range
The options in this box set maximum range for EW and NS offsets and vertical depth
for the plots. Select the "ReDraw" button after changing the data range.
3D View - This button opens a small visualization tool that displays the wellbore in a 3dimensional box. This box can be rotated around to illustrate the wellbore’s path or
easily spot bad survey points. The “Draw Axes” button in the lower right corner adds
scales for each axis of the box.
Smooth - This button smoothes the survey offsets slightly. Repeat the smooth
process for higher degrees of smoothing. Note that this option changes the survey
data.
Print - This button sends the display to the printer. The display should be printed in
landscape format for best results.
Redraw - This button redraws the plots with the selected data range.
4.6.3.1.6 Directional Import/Export Tab

The Import/Export Tab moves survey data into and out of Petra’s database. To
import survey data into a specific survey definition (such as “proposed” or “actual”),
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select the relevant definition from the “Current View” dropdown at the bottom of the
screen.

The Directional Survey Data's Import/Export Tab

ASCII Survey Files
Petra’s import and export is limited to ASCII survey files, such as TXT or LAS. Given
that directional companies provide survey data in a wide variety of formats and file
types, it’s often useful to first open the given file in a spreadsheet program, remove
extraneous header information and any extra formatting in between survey data
points, and export as a simple text file.

Survey Format
The dropdowns in this box set the format of the survey file both when importing and
when exporting. Along with a few special formats (like MMI, LAS, and DTI), most
survey files can be divided into two categories: keyword or columnar.
Keyword survey files have a line above the first survey point that tells Petra which
column is which survey element.
*WELL 0926421110000100
*XYUNITS F
*DEPUNITS F
*COLUMNS *MD
*TVD
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0.00
1.00
100.00
200.00
500.00
1000.00
2000.00
4200.00
5000.00
6000.00

0.00
1.00
99.00
190.00
450.00
996.00
1990.00
4000.00
5000.00
5990.00

0.00
12.44
41.55
76.19
109.42
165.02
208.90
240.02
288.00
309.35

0.00
24.47
80.67
140.90
184.71
235.52
263.81
283.86
322.65
339.45

Columnar survey files on the other hand simply have a delimited columnar or tabular
listing and can only contain a single well per file. When importing non-keyword
formatted files, set the units to indicate the units of the file. Petra has no way of
determining the units on non-key word files.
0.00
1.00
100.00
200.00
500.00
1000.00
2000.00
4200.00
5000.00
6000.00

0.00
1.00
99.00
190.00
450.00
996.00
1990.00
4000.00
5000.00
5990.00

0.00
12.44
41.55
76.19
109.42
165.02
208.90
240.02
288.00
309.35

0.00
24.47
80.67
140.90
184.71
235.52
263.81
283.86
322.65
339.45

When exporting data, set the XY units and Depth units to whatever units you want the
exported file to contain regardless of the actual units of the survey. Petra will make
the appropriate conversions.

Extend Directional Survey to TD During Import - This button projects the survey data
out to TD using the dip and azimuth of the last survey point.
Calculate Bottom-Hole Location During Import - This button recalculates the BHL
based on directional survey data.
4.6.3.1.7 Directional Calc TVD Tab

.A good percentage of survey data generated from directional companies starts at a
“kick off point” well below 0’MD. MD, INC, and AZI data by itself simply tells where
each successive survey is in relation to the previous survey - not in relation to the
surface location. The Calc TVD Tab computes the wellbore’s path from a userspecified “kick-off” point.
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The Directional Survey Data's Calc TVD Tab

Put another way, when loading only MD, INC, and AZI with no offset data from a
kickoff point, Petra needs to know where this data starts in order to calculate an
accurate model of the wellbore’s position. To use this utility, enter in the MD, TVD,
XOFFSET (E+W-), YOFFSET (N+S-), INC, and AZI of the kick off. Select the
“Compute TVD From MD” button to compute XOFF and YOFF data
4.6.3.1.8 Directional Method Tab

The method screen defines which algorithm is used when converting inclinationazimuth data to x-y offsets during import. The difference between these algorithms is
minimal with closely spaced survey points.
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The Directional Survey Data's Method Tab
4.6.3.1.9 Directional Advanced Tab

The advanced screen sets a couple of options for correcting for the convergence
angle and for reducing the number of survey data points.
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The Directional Survey Data's Advanced Tab

Survey Data Orientation
This section of the Advanced Tab sets the convergence angle correction for the
selected well. Projecting the curved surface of the earth onto a flat computer screen
inherently produces some distortion for all maps. Particularly in areas far from the
central meridian of the selected map projection, the lines of longitude running northsouth become angled – a common illustration is angled north-south section lines.
While “True North” is at the top of the map (or screen), “Grid North” is at a slight
angle due to this distortion. The angle between true and grid north is called the
"convergence angle."
It’s important to plot directional wells relative to grid north, rather than true north; the
BHL of a directional well plotted relative to true north can be hundreds of feet away
from its true location. When the survey is oriented toward True North (lat-lon), then
the survey path displayed on the map must be rotated to align with other features on
the map that have been converted from lat-lon to xy using a map projection. There is
no standard for directional surveys; azimuth survey data is reported both relative to
true north and to a grid north.
When there’s doubt about a convergence angle settings, the Main Module's “Analyze
Survey” tool (Compute>from Locations>Set Dev. Survey Grid Orientation) can shed
light on whether a convergence angle should or should not be applied. Essentially,
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Petra calculates a BH location for the survey data both with and without a
convergence correction. These two BH locations can then be compared with the
actual header-supplied BH location. Based on this comparison, Petra can recommend
whether an individual well should or should not have a convergence correction. Petra
can either simply make a report, or can change the wells in the project automatically.

The "Set Dev. Survey Grid Orientation" Tool on the Main Module

Decimate Data
This option erases survey data points by a user selected factor. More specifically,
this option keeps every Nth data points and erases the rest As an example, the
default 2 will keep only every other data point.
4.6.3.1.10 Directional Maintenance Tab

This tab changes directional well flags for all wells selected in the Main Module.
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The Directional Survey Data's Maintenance Tab

Reset all Wells to “Enabled” Survey Data - This options removes the Disable Use of
Survey For This Well” option on the Directional Survey Data’s General Tab for the
currently selected survey definition (on the “Current View” dropdown) for all wells
selected in the Main Module.
Reset all Wells to “Disabled” Survey Data - This option checks the “Disable Use of
Survey For This Well” option on the Directional Survey Data’s General Tab for the
currently selected survey definition (on the “Current View” dropdown) for all wells
selected in the Main Module.
Reset all wells to “INC Present” Indicator - Petra keeps track of which wells have
inclination and azimuth data. This information is available on the Misc Location
Information window on the lower right corner of the Location Tab on the Main Module,
and can also be used in well searches by data criteria. This option resets this
information for all selected wells.

4.6.3.2

Congressional Location Information

The Congressional Location Information window modifies and displays location
information based on the township and range system.
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The Congressional Location Information screen establishes a wells surface and bottom hole location with the
Township and Range System

4.6.3.3

Offshore Location Information

The Offshore Location Information window modifies and displays location information
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based on the well's offshore area and block.

The Offshore Location Information screen establishes a wells surface and bottom hole location

4.6.3.4

Texas Location Information

The Texas Location Information window modifies and displays Texas abstract and
survey information.
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The Texas Location Information screen establishes a wells surface and bottom hole location

4.6.3.5

NorthEast Location Details

The NorthEast Location Details window modifies and displays a wells footage calls.
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The NorthEast Location Details screen establishes a wells surface and bottom hole location using footage calls

4.6.4

Formation Tops Tab
The FmTops Tab displays and modifies the selected wells formation tops.
- This button opens the Zone Maintenance Tool.
- This button prints a hard copy of the tops and associated values for the
currently selected well.
- This button opens the Add New Formation Top tool.
- This button opens the Formation Top Aliases tool, which establishes a list
of "equivalent" substitute tops.
- This button opens the Display Order for Tops tool, which changes the
order that Petra displays tops. This can be useful for filtering out only the most
immediately relevant tops.
- This button opens the Show Tops By Source tool, which only displays tops with
a certain set of source codes.
- This button opens the Fault Cut Details tool, and is used for entering the depths
fo faults and the footage of any missing section.

Tops Tab
© 2014

360

PETRA Help

The FmTops Tab displays tops in a spreadsheet

Active Datum - This dropdown sets the active datum for the well.
Active Only - This option displays only the formation tops with active entries.
Especially in large multi-user projects with lots of tops, this can be useful for trimming
down the list of tops in the project.
Read Only - With this option set, the formation tops cannot be changed. This includes
manually typing in new values, picking tops in other modules, or being overwritten
during import.
Maintenance - This option opens the Zone Maintenance Tool, which also creates and
modifies formation tops.
Print - This option prints the currently selected well's formation tops.
New Top Aliases - This option opens the Define Formation Top Aliases Tool. This
sets how Petra will replace missing tops with other "equivalent" tops in the database.
Reorder - This option opens the Order Z Data Items Tool. This sets the desired
order that tops will appear on the Fm Tops tab and in other dropdowns in Petra's
modules.
Source - This option opens the Show Tops by Source Tool. Formation limits
Formation Tops to only the source or sources selected. This can be useful for only
displaying or modifying your tops in a large multi user environment.
Fault Cuts - This option opens the Fault Cuts Tool. Petra can store fault cuts and
throw to help in reconstructing the stratigraphic positioning of the lithology.
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Fm Tops Source Restriction

Petra can store a source code for every top. This source code is typically a user's
initials, but can also reflect the origin of the top (such as GRID in the example below
for formation tops sampled from a grid rather than correlated by hand.) Each source
code can be up to 32 characters long. By default, all users can modify tops of any
source code.
To restrict formation tops based on source code, select the
bottom of the Main Module's FmTops Tab.

button on the

The Show Tops By Source Tool limits how tops are displayed. Only the tops with the selected source codes display
anywhere in Petra.

Show all Sources - This option shows all tops for all sources in the project.
Show Tops For Selected Sources Below - This option only shows tops with the
selected source code or codes. Tops without these selected source codes WILL
NOT appear elsewhere in Petra, including the Map and Cross Section Modules.

FmTops Source Code Administrative Options
By default, all users with write access to the database server can modify all tops in
the database, regardless of source. By modifying the "Petra.INI" file, administrators
can set the project to only allow users to modify tops with their source code. When
this feature is active, users are prompted for their source code when they start up
Petra. It is kept in the registry, so they only need to enter it once. To implement the
top source restriction mechanism, modify Petra.INI with the following lines:
USERSOURCE]
ENABLED=1
BLANKS=1
ADMINLIST=<comma separated list of user's source codes>
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ENABLED= - This line enables (ENABLED=1) or disables (ENABLED=0) source code
restriction.
BLANKS= - This line controls whether users can modify tops with a blank source
code. When this option is BLANKS=0, all users can modify a top with a blank source
code. When this option is instead BLANKS=1, only administrators can modify a top
with a blank source code.
ADMINLIST= - This line sets up a comma-delimited list of user source codes who
have "administrator" rights.
4.6.4.2

Formation Top Aliases

Top aliasing assigns an ordered list of top names to the original, or aliased top.
These tops serve as a list of "equivalent" tops that fill in if the original top is absent.
Alias tops can function like the original top in many place in Petra, including gridding,
calculations, and on display in the Cross Section Module.
Choose the "Aliases" button at the bottom of the FmTops tab on the main screen.
Select the top to be aliased from the drop-down list at the top of the screen. Tops
that already have an alias definition assigned are highlighted in light blue. Aliases
should be specified in order of preference from highest priority at the top of the list to
lowest priority at the bottom of the list.
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An aliased top. Petra will look for the "2nd_Wall_Creel" top first, followed by "603WLCK2" and finally "2WC"

Set Aliases For Top - This dropdown selects the top that will store the aliases. This
should be the first choice, or top priority top. To add a alias, select the desired top
from the "Available Tops" list and use the ">" button to add it to the "Top Aliases" list.
The ">>" button adds all tops on the "Available Tops" list to the "Tops Aliases" list.
Be sure to include the top name of the top being aliased. To drop a specific top
from the alias, select the desired top on the "Top Aliases" list, and use the "<" button
to remove it. The "<<" button removes all tops from the the "Tops Aliases" list.
Save - This option saves the alias list to the database.
Remove Alias... - This option removes the alias definition for the top selected in the "
Set Aliases For Top" dropdown.
Done - This option returns to the Main Module.

FmNam Alias File
This option applies formation top aliases to PdCums, and the ProdFM and the
FMatTD well entries.
Use Default Alias File - This option uses the aliases currently active in the Petra
project.
Use File - This option uses an external file to set the aliases for the PdCum names,
and ProdFm and FMatTD entries. The file itself is a simple text file with two types of
entries: a formation name with a "1" prefix", and alias names for the formation with a
"2" prefix. In the example below, formations 404HFNR+, 404MRRS, 404PCKS, and
404TSSYB are alias names for 404HFNR. And, formations 603DKTD, 603DKTDU
and 603DKTDL are alias names for D_SAND.
1404HFNR
2404HFNR+
2404MRRS
2404PCKS
2404TSSYB
1D_SAND
2603DKTD
2603DKTDU
2603DKTDL

FmName Alias File Update
Do not Over Write This File - This option keeps a pre-existing external alias file as-is.
Select this option to use the external file.
Create FmName Alias File From Top Aliases - This option creates a new formation
alias file, or overwrites the file selected in the entry box.
Note: For information on copying Alias Tops, see here.
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Repeat Tops

Horizontal wells can cross a single formation top multiple times. In the example
below, the horizontal well crosses Top A multiple times at different MD depths. To
capture this information, previous versions of Petra required the creation of additional
formation tops like A_1, A_2, and A_3 as shown in the example below on the left.
With Version 3.2.3.0 and above, these multiple tops can now be stored as repeats
for Top A as shown on the example below on the right. This makes viewing, picking,
analyzing, and gridding horizontal and deviated wells much simpler and faster.

Repeat Tops are also useful for storing estimated tops in horizontal wellbores. In
addition to the above situation, repeat top values can also be located directly above
or below the bore-path. Say a top does not cross a horizontal well, but rather it just
dips close to it; you can now pick that top in space at a vertical offset above or
below the actual bore-path. This will be better explained/visualized below when
discussing the Cross-Section Module.

Active Datum - This dropdown sets the active datum for the well.
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Active Only - This option displays only the formation tops with active entries.
Especially in large multi-user projects with lots of tops, this can be useful for trimming
down the list of tops in the project.
Read Only - With this option set, the formation tops cannot be changed. This
includes manually typing in new values, picking tops in other modules, or being
overwritten during import.
Current Top - This tool sets the active repeat top. The left and right buttons scroll
through the tops list.

MD - This entry stores the MD value of the top.
SS - This entry stores the SS value of the top.
TVD - This entry stores the TVD value of the top.
MD/TVD Linked - This option allows repeat tops above or below the bore-path. This
can be used to estimate a top that's a known distance above or below a feature
intersected by the horizontal wellbore. These estimated tops can be useful for Since
the XY aerial location of the top is know, these "unlinked" tops can be useful for
adding additional control points for mapping and gridding.
Quality - This option stores a quality code for the specific top. This can be useful for
recording the confidence in the top or the method used to create the top.
Time (MS) - When the well has a velocity function, this entry stores the time of the
top.
Hole Angle - When the well has a directional survey stored, this entry stores the
inclination of the wellbore at the top's MD.
Change Date - This entry records the change date of the top.
Remark - This entry stores any additional remarks about the well.
New Repeat Top - This option adds a blank row to the repeats tab.
Delete Selected - This option deletes the currently selected row.
Maintenance - This button opens the Repeat Top Maintenance Tool.

Using Repeat Tops in the Map Module
Using Repeat tops in the Cross-Section Module
Using Repeat Tops in the Raster Log Calibration
Using Repeat Tops in the Slip Logs Module
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4.6.4.3.1 Maintenance

This dialog merges selected formation tops into a single top as repeats.
Storing multiple repeated formation tops in previous versions of Petra required the
creation of additional formation tops. In the example below, a horizontal well passing
through the same stratigraphic surface three times needed three distinct tops (A_1,
A_2, and A_3) as shown in the example below on the left. This dialog allows you
copy those repeated values them into Top A as repeats, as shown on the example
below on the right.

To open the Repeat Tops Maintenance Tool, select the
the bottom of the Main Module FmTops Tab Repeats Tops Tab.

button on

Source Tops - This list sets the multiple tops that all reflect the same actual lithologic
boundary.
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Target Top - This dropdown sets the single repeat top that will store the multiple
source tops.

Keep Source Tops When Done - After Petra collapses the multiple tops into a single
repeat top, this option will keep the original entries in the source formation tops.
Delete Source Tops When Done - After Petra collapses the multiple tops into a
single repeat top, this option will remove the entries in the source formation tops.
4.6.4.4

Add New Formation Top

This tool adds a new formation top to the database. To open this tool, select the
button on the Main Module's FmTops Tab.

Name - This option sets the formation top's name.
Source - This option sets the formation top's source. This is most commonly the
interpreter's initials, but can really be anything that reflects the origin of the tops.
Petra has several tools that filter formation tops down by source, so it's usually worth
spending the time to use this entry.
Description - This sets the description of the formation top, and can be more
descriptive than the formation top's name. This can be particularly useful for
documenting your work in a project, so that when you return to it 6 months later you
don't have to reinvent the wheel.
Decimals - This option sets the desired decimal place precision for the top. A 0
decimal precision will store to the nearest whole integer depth unit (depending on the
settings on the Map Projection Settings Units Tab). Given the inherent uncertainty in
wireline logs, there's not much benefit in anything above 1 or 2 decimal place
precision.
Remarks - This stores an unlimited box of text for the formation top. This can be used
to document the top's origins, technique, history, or anything else relevant to the
formation top.
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Fault Cuts

Petra stores well fault cuts in the database. Fault cuts can be useful for restoring
missing section on stratigraphic cross-sections.

To modify an existing fault cut, highlight the old fault cut, change the information, and
select the

button.

To add a new fault cut, enter the desired information and select the "+" button.
To drop an existing fault cut, highlight the desired fault cut and select the "-" button.
Name - This entry sets the fault cut's name.
Source - This entry sets the fault cut's source. Generally this will be the user's initials.
Depth of Fault Cut - This entry sets the depth of the fault cut. Note that this depth can
be in MD or TVD.
Amount of Section Missing - This entry sets the amount of section missing.
Color - This sets the color of the fault cut. To change the fault cuts's color, select the
colored box.
All - This option applies the currently selected color to all fault cuts in the well.
Name or Comment - This entry stores remarks or comments about the fault.
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Zone Tab
Petra defines a “Zone” as a specific interval in a well that can be defined by a top and
a base. Inside each zone, Petra stores “Data Items” that relate to that zone. The
Zones Tab displays and modifies zone information for the selected well and for the
project as a whole.

The Zones Tab displays both "zones" and "data items".

- This button opens the Zone Maintenance Tool.
- This button opens the View/Edit Zone Data Tool.
- This button creates a new data item in the selected zone with the New
Data Item Tool.
- This button opens the Pay Interval Data Tool.
- This button prints a list of the data items and values for the currently selected
well.
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Printing a list of the zone data items for the currently selected well.

- This button opens the Assign Zone Item Aliases Tool

4.6.5.1

Zone Maintenance

The Zone Maintenance tool adds, changes, or deletes zone and zone data items.
This tool has three tabs: Zones Data Items, and Interval Definition. The zone
selected on the Zones Tab controls the data displayed in the other tabs. For
example, to view the interval definition of zone "A", first click the cursor on the row
containing the "A" name and description, then click the Interval Definition tab to see
the depth interval data.

Zones Tab
This tab displays a list of the zones in the project . Typing over the existing text can
modify the zone name and description.

© 2014

Main Module

371

The Zone Maintenance Zones Tab

- This button opens the New Zone Definition window.
- This button opens the Modify Zone Definition window.
- This button deletes the currently selected zone, along with all the data
items inside that zone. This is irreversible.
- This button opens the Reorder Zone Names tool.
- This option sets a highlight color for the selected zone. This color will
only appear on the individual user's copy of Petra, and not to all users in a project.
- This option removes a highlight color for the selected zone.
- This box displays the selected zone's highlight color

Data Items Tab
The Data Items tab adds, modifies, reorders and deletes the data items for a
selected zone.
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The Zone Maintenance Data Items Tab

- This button opens the New Data Item window
- This button opens the Modify Data Item window
- This button opens the Select Display Order for Data Items & Tops
window
- This button removes all data from the selected data item. Note that the
empty data item will remain in the database.
- This button removes all remarks from the selected data item. Note that
the empty data item will remain in the database.
- This button erases the selected data item and the data contained inside
the data item.
- Thus button sets the number of decimals displayed for the data item.
The default is zero.
- This button saves a comma separated values (*.CSV) spreadsheet with
columns for data item name, source, and description.
- The "Save" button saves the current zone's data items to a template (*.
USR) file. The "Load" button loads a template file as a system template. Petra can
sue a system tamplate to populate newly created zones.
- The print button prints a list of the data items in the currently selected
zone.
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- This button adds a user-selected color highlight to the selected data
item.
- This button removes a user-selected color highlight.
- This option locks or unlocks the selected data item. Once an item is
locked, users cannot change the values, either through importing new data or
manually typing entries into the database.
- This option deletes data items based on well count. Petra will delete
data items that have a well count equal-to or less than a specified number of wells.
As an example, setting this value to 5 will eliminate data items with active values in 5
or fewer wells. This can be useful for pruning out low-value, low-well count items.
- This button performs a Find/Replace operation on data item source
codes.

Interval Definition
The Interval Definition Tab defines the upper and lower depth limits of a zone, either
by a specific MD/TVD depth or with FmTops. Many of Petra’s tools are based
around the concept of zones, so taking a moment to establish the interval definitions
of zones is a good investment of time.
The upper and lower depth can each be defined using a fixed measured depth or
TVD subsea depth. More typically, the upper and lower depth can also be defined
using formation tops with optional footage offset. The formation tops method defines
a true geologic zone with depths varying from well to well.
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4.6.5.1.1 New/Modify Zone Definition

The New Zone Definition window creates new zones for the project. Generally,
zones are defined by a stratigraphic interval between two tops.

The New Zone Definition Window

Zone Name - The Zone Name is a 1 to 30 character name of the zone of interest.
The system automatically will convert the name to upper case and any intermediate
blanks to underscores.
Description - Enter a short zone description such as the formation top names used
for depth interval definition.
Remarks - Enter any pertinent remarks up to 4096 characters.

Templates
By default, the new zone will be created but will not contain any item names.
However, you can create the new zone and copy the item definitions from a
"template" zone.
Create Without Items - This default option creates the new zone without any data
items.
Create Items From Zone Below - This option copies data item definitions from a
user-selected zone (on the dropdown immediately below the "Create Items from
Zone Below") into the newly created zone. Note that no data will be copied - only
the empty data items and definitions.
Create Items from System Template - This option creates the new zone with the
data items loaded into Petra's system template. To set up a system template, see
the "Save Template"/"Load Template" buttons on the Zone Maintenance Data Items
Tab.
4.6.5.1.2 Reorder Zone Names

The Reorder Zone Names Tool reorders the zones in a project. This tool can also
filter out irrelevant zones.
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The Reorder Zone Names Tool

Current Display Order - This list shows every data item in the zone.
New Display Order - This list shows the reordered zone names. Use the < and >
keys to add and subtract group names to the New Display Order list, and the up and
down arrow keys to change the order of a selected zone.
- This button adds the selected zone from the Current Order list to the New Order
list.
- This button adds all zones from the Current Order list to the New Order list.
- This button removes the selected zone from the New Order list.
- This button removes all zones from the Current Order list.

- These buttons change the order of the selected zone on the Reordered New
Order list. Selecting the up arrow moves the selected zone higher, while the down
arrow moves the selected zone lower on the list.
- This option resorts the zones on the Current Order list in ascending
alphabetical order (A to Z).
Show Listed Items Only - By default, Petra will show the zones items on the New
Order list first, followed by all other zones. This option instead restricts Petra to show
ONLY the zones on the New Order list. With this option selected, zones not on
the New Order list will never show up elsewhere in Petra.
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4.6.5.1.3 New/Modify Data Item

Item Name - This entry sets the name of the new data item.
Source - This entry sets a source code for the new data item. Generally, source
cores designate the user creating the data item or the method used to create the data
item.
Units - This dropdown sets the units for the new data item.
Decimals - This entry sets the number of decimals for the data item. It's sometimes
useful to trim trailing digits for easier display.
Data Type - This section sets the general type of the data item. Numeric items store
numbers with a set of digits, Text items store a string of text, and Date items store a
specific date that can be used in minimum and maximum date search.
Description - This entry sets the description for the data item.
Remarks - This entry sets the remarks for the data item.
4.6.5.1.4 Display Order for Data Items & Tops

Formation Tops and Zone data items can be displayed in a preferred order rather
than the default order in which the data fields were defined.
To reorder Zone Data Items, select the
Tool's Data Items Tab.
To reorder Formation Tops, select the
Module's FmTops Tab.

button on the Zone Maintenance
button on the bottom of the Main
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Reordering the WELL Zone Data items (Left) and formation tops in the FMTOPS Zone (Right)

Order Tab
Current Order - This list shows every data item in the zone.
New Order - This list shows the reordered raster group names. Use the < and >
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keys to add and subtract group names to the New Order list, and the up and down
arrow keys to change the order of a selected raster group.
- This button adds the selected data item from the Current Order list to the New
Order list.
- This button adds the all group names from the Current Order list to the New
Order list.
- This button removes the selected group name from the New Order list.
- This button removes all group names from the Current Order list.

- These buttons change the order of the selected data item on the Reordered
New Order list. Selecting the up arrow moves the selected data item higher, while
the down arrow moves the selected group name lower on the list.
- This option resorts the data items on the Current Order list in ascending
alphabetical order (A to Z).
- This option resorts the data items on the Current Order list in descending
alphabetical order (Z to A).
- This option resorts the data items on the Current Order list by the data
items source code.
Count - This button sorts the data items by the number of wells containing the data
item. This option is particularly useful for sorting through low well-count formation
tops. With a large project and lots of data items, this can take a long time.
Only show items listed. Never show others - By default, Petra will show the data
items on the New Order list first, followed by all other data items in the zone. This
option instead restricts the data items in Petra to ONLY the items on the New Order
list. Items not on the New Order list will never show up elsewhere in Petra.

Import/Export Tab
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Reorder Using Petra Order List
This option saves and loads data items to a Zone Order List file or *.ZOL.

Order Using External File (STRAT TABLE)
This option saves and loads data items to a Strat Table (*.DAT).
4.6.5.2

View/Edit Zone Data

The View/Edit Zone Data displays and modifies zone data items in a project.
To open this tool, select View/Edit All... button at the bottom of the Main Module's
Zones Tab, or select Zones>View/Edit on the menu bar at the top of the Main
Module. Additionally, there are a few links to this dialog in other tools.
The left side of the screen contains a nested list of the zones and data items. Use the
"+" button to the left of the desired zone to expand the tree, and then select the
desired data item.
The right side of the screen displays a a list of all the wells in the project along with a
column for the selected data item's values. Note that entries here can be edited as
well.
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The View/Edit Zone Data tool with no data item selected (left) and with a data item selected (right)

4.6.5.3

Assign Zone Item Aliases

Zone Data Item aliasing assigns an ordered list of data items to the original, or
aliased item. These items serve as a list of "equivalent" items that fill in if the original
item is absent. Alias items can function like the original zone data item in many place
in Petra, including gridding, calculations, and on display in the Cross Section Module.
To set up zone data item aliasing, select Zones>Zone Item Aliases... on the menu bar
at the top of the Main Module.
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Selecting the data item to alias (left), and setting "equivalent" data items for the data item (right)

Assign Zone Item Aliases
This tool simply selects the desired data item. Select the zone and zone data item to
store the alias definition, and select the "Assign Zone Aliases..." button to set the
equivalent alias data items. Note that data items that already have an alias definition
assigned are highlighted in light blue on the Zone Items list..

Select Zone Item List
This tool sets the aliases for the selected data item. Aliases should be specified in
order of preference from highest priority at the top of the list to lowest priority at the
bottom of the list.
Zone - This list shows the available zones in the project. If a zone isn't showing up,
make sure the "Show Listed Only" option on the Reorder Zone tool is off.
Zone Item List- This list shows every data item in the zone. If a data item isn't
showing up, make sure the "Show Listed Only" option on the Display Order for Data
Items tool is off.
Selected Zone Items List - This list shows the aliased data items. Use the < and >
keys to add and subtract group names to the Selected Zone Items list, and the up and
down arrow keys to change the order of an individual data item.
- This button adds the selected zone from the Zone Item list to the Selected Zone
Items list.
- This button adds all zones from the Zone Item list to the Selected Zone Items
list.
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- This button removes the selected zone from the Selected Zone Items list.
- This button removes all zones from th Selected Zone Items list.

- These buttons change the order of the selected data item on the Selected Zone
Items list. Aliases should be specified in order of preference from highest priority at
the top of the list to lowest priority at the bottom of the list.
4.6.5.4

Zone Item Hyperlinks

A hyperlink is any text string that represents a full filename or URL web address.
When the hyperlink is activated, the application that Window's associates with the
extension is launched. For example, if a hyperlink has an .XLS extension, Excel is
launched to view the hyperlink data file.
Hyperlink text can be entered as the text item or remark portion of a zone item on
the zones tab.The hyperlink is activated when you right-click on the zone item name
and select the "Jump to Hyperlink" from the pop up menu.
Hyperlinks can also be activated from the map module. First, right-click on a well (on
the map) and select your "user favorites" to include a text zone item containing a
hyperlink. Anytime you right-click on a well, and select the menu item containing the
hyperlinked item, the hyperlink will be activated.
A special "@folder:" notation can be used to allow hyperlinks to be stored within
the project. For example, you could create a folder under your project's root folder
called "LINKS". Then, you would enter a hyperlink text as @LINKS:
MyWellDrillingReport.xls. Petra would look for the file called MyWellDrillingReport.xls
under the "links" folder and activate the hyperlink process.
4.6.6

Logs Tab
The Logs Tab displays and modifies the digital log curves for the selected well.
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The Logs Tab displays project-wide information.

The log tab screen provides options pertaining to the well logs for the current well. All
available logs for the well are listed and can be selected. The selected lops can then
be viewed graphically by clicking the Preview button. Additionally, the log values
(digits) can be edited by choosing the log name from the drop down list box. The
Depths option can be used to restrict the logs for previewing or editing.
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Delete - This option deletes the currently selected log or logs. By default, this only
erases the log from the selected well. By selecting "All", Petra will delete the
displayed log curve from all wells in the project.

Deleting a log curve from the database

Rename - This option renames the selected curve to use another name already in the
database.
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Renaming a curve

Depths - By default, the preview window on the right side of the Log Tab displays the
curves or values for all depths of the currently selected log curve. This option sets the
minimum and maximum depths for the preview window based on MD, TVD, or
formation top.
Maintenance - This option opens the Log Maintenance Tool
Scale - This option sets the default scale for the selected log curve. Petra will use
this scale as the default for cross sections and other log displays.
Preview - This option opens the Logs Preview Tool
Aliases - This option opens the Define Log Curve Aliases Tool.

4.6.6.1

Log Maintenance

The Log Maintenance Tool creates, deletes, and renames log definitions. This tool
can also change the default log scales and lock/unlock a curve for the entire
database.

The Log Maintenance Tool
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Delete... - This option deletes the log definition and all associated data for all wells in
the database.
Rename... - This option changes the name and descriptive text for a log definition.
Scale... - This option sets the default scale for the log.
New... - This option creates a new log definition. Note that the new definition will
have no log data (0 wells) associated with the new log definition. Generally, this
option is best for renaming a log trace to a new name. After creating the new log
definition, use the Logs Tab's "Rename..." option to change the log to the new name.
Wells... - This option displays the "Select Wells" screen with the wells containing the
highlighted log.
Lock/Unlock - This option globally locks or unlocks the selected log definition.
Print - This option prints the curve information on this screen.
Close - This option closes the Log Maintenance Tool and returns to the Main
Module's Log Tab.

Display Filter
Set Display Filter... - This option opens the Filter Log Curve Names tool. When the
curves are in the "Filtered Curve List" on the right side of the screen, only those
selected curves will display in Petra.
To move a curve to the Filtered Curves List, select the ">" button to bring over a
single selected curve, or the ">>" to bring over all curves on the Available Curve List.
To drop a curve from the Filtered Curves List, select the "<" button to remove a
single selected curve, or the "<<" to drop all curves on the Filtered Curve List.
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The Filter Log Curve Names Tool. Note that only the curves on the Filtered Curve List will show up elsewhere in
Petra.

Apply Display Filter to Maintenance List - This option applies the filter established in
the "Filter Log Curve Names" tool on the Maintenance List.
4.6.6.2

Log Curve Aliases

Different naming conventions between wireline companies and tools mean that one
type of digital log curve can have a variety of different names. As an example, within
the same project a gamma ray curve can be named GR, GRD, GRN, GRR, GRS,
GAMMA, and so on.
Generally, we want Petra to treat all these curves as the same. Rearranging a
dozen log curve names for display on a cross section can be tedious, and performing
a calculation with multiple logs with different names can be almost impossible.
Digital log aliasing is a great way to get around these naming problems by
establishing a list of curve names that are equivalent. In other words, if the curve
name isn’t present, Petra will look down the list to find another curve name as a
substitute.
The alias list is a list of log curves to be searched only if the original log curve
(aliased curve) is missing for a well. If the original log is present, it will be
used.
To Define log aliases, select Logs>Define Aliases on the menu bar at the top of the
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Main Module, or select the "Aliases..." button on the Main Module's Logs Tab.

Aliases Tab
First, use the “Chose Log to be Aliased” dropdown to select the digital log curve
name that will store the aliasing. In the example below, the GR log will store the
alias list for all gamma ray curves. Since Petra will always start at this curve name,
the selected name should be your top choice for the curve in question.
Next, select other curves to add to the list, and use the “>” arrow to add them tot he
Log Aliases list. You can reorder the list by using the up and down arrow keys.
Since Petra goes down this list from top to bottom, the order here should reflect the
relative priority or quality of the logs with the best logs at the top.
When you’ve completed the aliasing, click the “Store Aliases” button to save the
changes to the database. Click “Done” to leave the aliasing screen and return to the
Main Module.

The Aliases Tab

Choose Log to be Aliased - This dropdown selects the digital log curve name that will
store the aliasing.
Store Aliases - This button saves the existing alias list for the log name selected on
the "Chose Log to Be Aliased" dropdown.
Help - This option opens the help file.
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Done - This option closes the Define Log Curve Aliases Tool. If you Select “Done”
before storing the aliases, Petra will not save your alias list.
Delete - This option deletes the currently selected alias list on the "Chose Log to Be
Aliased" dropdown

File Tab
Petra can store log alias lists to an external file. The format of this file is listed at the
bottom of the File Tab. This can be useful for transferring log aliases between
projects, or for trying out different log alias schemes.

The Define Log Curve Aliases' File Tab

Assign Alises Using an Alias Definition File - This option loads an alias file from an
external definition file. Use the "Browse" button to navigate to the desired file. Use
the "Edit" button to open a text editor to modify the file.

Replace Method
Replace Only Aliases Listed in Def File (keep all others) - This option replaces only
the aliases specifically listed in the external alias file.
Delete All Current Aliases and Replace With New Ones From Def File - This option
first deletes all aliasing in the project, effectively replacing the aliasing in the project
with the aliases from the file.
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Add New and Merge With Existing Aliases - This option adds new log aliases.
Where log definitions in the project and in the external file overlap, Petra will attempt
to merge the
two.
Create Log Alias file from Current Log Aliases - This option creates a new alias file
based on the log aliases currently stored in the project.

Report Tab
The Report Tab creates a text file that shows which wells will be affected by the
currently selected log alias.

The Define Log Curve Aliases Report Tab

Report - This button runs the alias through the currently selected wells and generates
a text file with each well and the substituted curve. With large projects, this can take
considerable time.
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Log Preview

The log preview function provides an interactive display containing selected logs
displayed side-by-side. Logs can be quickly evaluated for quality control. Irrelevant
logs can be deleted and multiple log runs can be merged to form one complete log
trace. The log preview function displays and correlates formation tops.
The log preview screen operates in either Log Mode or Tops Mode. When logs are
active, you can edit logs. When tops are active you can correlate tops. The top
mode is active whenever tops are displayed.
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The Log Previewer Tool

Setting The Log Scale
By default, log data is automatically scaled to either linear or logarithmic (log10).
Logs displayed on a logarithmic scale are indicated with an asterisk following the log
name. To manually set the scale, select Logs>Set Track and Scale to open the Set
Log Track Scale and Data Correction Tool.
Setting The Depth Range (Zooming) The default depth range is that range set on the "Logs" tab screen. The depth range
can be modified using two methods: The "Depths-Set Depth Range" menu is used to
manually set the range to defined by depths or formation tops. The depth range can
also be "zoomed" graphically using the mouse. To start the depth selection process,
either click the small depth tool button
or hold down the Shift key then click and
hold the left mouse button at the minimum depth. Drag the mouse over the desired
depth interval and release the button at the maximum depth. Once in zoom mode,
you can scroll the screen up or down by 1/3 of the screen height. A pop up menu
displayed with a right mouse button click provides additional zoom and scrolling
options.

Log Mode
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Note: The log database is not actually modified (with one exception) until you exit the
log preview screen. Then you are prompted whether or not to update the log
database. The one exception is if you delete a log, in which case the log is deleted
immediately after verification. Once deleted, a log cannot be recovered. Use the
"Drop" function to remove unwanted logs from the display without deleting them.

Mouse Controls
Many options are provided via a "pop up" menu displayed by clicking the right mouse
button.
Curve Color - This option changes the color of the curve on the Log Curve Previewer.
This does not change the logs' display color for the cross-section or anywhere else
in the project.
Previous Zoom - This option returns to the last zoomed view.
Zoom In By 2X - This option zooms in on the upper part of the log curves.
Zoom Out By 2X - This option zooms out.
Scroll Up - This option scrolls up through the logs.
Scroll Down - This option scrolls down through the logs.
Default Depth Range - This option resets the depth range to the defaults set on the
Main Module's Logs Tab.
Show Curve Header Info - This option displays some log information, including the
depths, the step interval, total number of data points, depth units, and some
statistical measurements.

The Curve Header Info box

Set Log Curve Scale - This option opens the Set Log Track Scale and Data
Correction Tool
Corrections and Rescale - This option opens the Set Log Track Scale and Data
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Correction Tool
Stats Histogram - This option displays a frequency histogram of the selected log
showing data range, mean, standard deviation, mode, and sample counts.
Query Depths - This option displays a small window with the start and stop depth,
step increment, and the total number of points in the well.

Using the Depth Query option

Delete Log Curve - This option deletes the selected log from the project database.
Merge Log Curves - This option merges the data from a "Source" log into a "Target"
log. Follow the prompts at the bottom of the screen to first click the left mouse
button on the "source" and then the "target" log. To cancel the merge operation,
click the right mouse button.
Copy Curve - This option creates a copy of the curve with a different name.

The Copy Curve option

Draw Curve - This option draws in a log curve. After selecting this option, the curser
turns to a pen icon. Click once to start drawing, and again to add successive points.
Right click to stop drawing points.
Draw Curve Shift - This option graphically moves the selected log curve.
Interpolate Nulls - Linear - This option interpolates between null values by simply
drawing a straight line between the adjacent data points.
Interpolate Nulls - Cubic - This option interpolates between null values by fitting a
curve to the nearest adjacent data points.
Null Curve Section - This option sets log digit values to a null over a given depth
interval. The depth interval is defined using the depth range selection technique
described earlier.
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Shift Curve Starting Depth - This option can be used to shift the starting depth of a
log up or down by a given amount. A positive shift amount shifts the log deeper while
a negative value shifts the log shallower.
Shift Using Depth Pairs - This option shifts the log curve's depths with a set of drawn
depth pairs. Note that Petra will stretch and squeeze the log in order to
accommodate multiple depth pairs.

Establishing a set of Depth Pairs

Smooth Log Curve - This option smoothes or filters the selected log digits with a
triangular smoothing filter. The number of filter coefficients can be set from 3 to 25
by selecting Logs>Set Smoothing Strength on the menubar at the top of the screen.
De-Spike Curve - This function clips anomalous data outside a rectangular region
drawn on a curve. The user draws a rectangle over the curve section that defines
the depth range and low and high amplitude values allowed. Curve values falling
outside the rectangle (either to the left or right side) are first set to null then new
values are interpolated for each of the null values using the remaining good data
samples.
Change Depth Units - This option changes the depth units of the selected well. Note
that this will affect all curves with the logs definition.
Alter Sample Rate - This option changes the sample rate of the selected curve.
Cutoff Line - This option simply draws a straight line at the specified value. This can
be useful for evaluating curves or for finding anomalous values. To remove the line,
enter a cutoff of "0."
Drop Curve From Display - This option removes the selected log from the screen.
This option does not delete the curve from the database.
Move Curve Left 1 Track - This option moves the curve one track to the left.
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Move Curve Right 1 Track - This option moves the curve one track to the right.
Restore Original Curve - This option restores the the original log digits from the log
database. Any changes made to the log are not saved.

Formation Top Mode
In Formation Top Mode, the Log Curve Previewer can correlate the formation tops
that are in the project. To enter Formation Top Mode, select the "Show Formation
Tops" option at the top of the screen. Alternatively select Tops>Show Tops/Hide
Tops from the menu bar at the top of the screen.

Selecting The Formation Tops To Display
To select the tops that appear on the Formation tops dropdown menu, select
Tops>Select Tops on the menu bar at the top of the screen. Here, add tops to the
"Selected Zone Items" list by selecting th e">" button to add a selected top, or the
">>" button to add all tops. To drop a top from the "Selected Zone Items" list, select
the desired top and select the "<" button. To drop all tops from the "Selected Zone
Items" list, select the "<<" button.

Setting the formation tops to display on the Log Curve Previewer

Changing Formation Top Values
Moving an existing top
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Tops already in the database are displayed as a single line drawn across the depth
track. As the cursor is moved over the top's line, the line turns white to indicate it is
active. While a top is active (white), it can be dragged up or down on the depth axis
by clicking and holding down the left mouse button. The top is redrawn at its new
depth value when the right mouse button is released.

Correlating a new top
To correlate a new top, select the desired top in the tops dropdown box at the top of
the screen. Next, select the
button or Tops>Correlate on the menu bar at the
top of the screen. The cursor will jump to the center of the screen with the
correlation line. Position the cursor at the appropriate depth and click the left mouse
button. The screen will redraw with the new top value. The correlation can be
canceled by clicking the right mouse button instead of the left button.
Top values are not stored back to the database until (1) you reselect tops, or
(2) you exit the log preview screen. In either case, you are prompted before
the database is updated.
Round Tops Values - When checked, this Tops-Menu option causes top values to be
rounded to the nearest whole foot or meter. This option only affects values that are
changed using the cursor procedure described above.
4.6.6.3.1 Log Preview Scales

The Set Log Track Scale and Data Correction Tool sets the log scale in the Log
Curve Previewer Tool and performs some simple corrections to log curves.
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Log Track Display Scale
Automatic - This option automatically attempts to set a reasonable track minimum
and maximum based on the data.
Linear - This option sets the track to use a linear track scale.
Log10 - This option set the track to use a logarithmic track scale.
Log Curve Defaults - This option scales the track to the log curve's default scale.
Track Min/Max - These entries set the left and right boundaries for the track when
the "Use Track Min-Max Values" option is selected.
Use Track Min-Max Values - This option sets the track minimum and maximum from
the "Track Min" and "Track Max" entry boxes.
Use Log Data Range for Track Range - This option uses the minimum and maximum
values from the log curve for the track minimum and maximum.
Plot as Discrete Points - By default, Petra attempts to connect log curve data points.
This option instead plots the data as individual, unconnected data points.
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Log Data Correction
Set the scale mode to automatic, linear or log10 and the minimum and maximum
scale range.
The log scale option also provides the means to "correct" the log digits using simple
math functions. The digits of the selected log can be added, subtracted, multiplied,
or divided by a specified constant value.
This section applies a simple mathematical function to the can be applied to the log
such as adding, subtracting, multiplying by or dividing by a constant. To apply a
correction, change the correction type from "No Correction" to the appropriate math
function. Next enter the constant value to be applied.
Add/Subtract/Multiply By/Divide By Constant - These options perform a simple
mathematical operation using the value in the "Correction Constant" entry box.
Re-Scale using Min-Max Range - This option rescales the selected log tot eh
minimum and maximum set on the "Track Min" and "Track Max" entry boxes. This
can be useful for rescaling a log to a 0-100 scale.
Add/Subtract/Multiply By/Divide By Correction Curve - In contrast to using a single
correction constant, this option instead performs a simple function using an additional
log curve selected by the "Correction Curve" dropdown. Note that the value of the
curve will be set to null where the the correction curve is also null.
Apply Correction to All Log Depths - This option will perform the log data correction
to all log depths.
Apply Correction To Only Those Depths Currently Displayed - This option will
perform the log data correction only to the depths currently displayed on the Log
Curve Previewer.
4.6.6.3.2 Set Depth Range

The Set Depth Range screen defines the upper and lower depth range based on a
formation top, measured depth, or true vertical depth, or zone definition.
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The Set Depth Range window

Formation Top and Offset - This option sets the depth interval to vary from well to
well based on the values of the formation tops. Select the formation top reference
from the drop down list and optionally set a numeric offset value. The offset provides
for such intervals as 100 feet above and below a given top.
Measured Depth - If the entire well interval is desired, set the upper depth to 100000.0 and the lower depth to +100000.0 .
TVD SS - This option can be used to set the depths to a vertical interval for deviated
wells that contain survey offset data.
Set Upper and Lower Depths From Zone - This option sets the upper and lower
limits based on a zone's interval definition.

4.6.7

IP Tests Tab
The IP Tests Tab displays and modifies information about the selected well on the
well list. To change an entry, double click the relevant test. To enter a new test,
select the "Details" button.
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The Well Tab displays header and symbol information about the selected well.

Show combined Well Completions - This option forces Petra to display test data for
all well completions, even when projects store separate completions as separate
wells.

Production Test Details Window
The details button opens the Production Test Details window. This displays more
specific information about the tests. To add a new test, enter the relevant data for
the test and select the "+ Add" button. To modify an existing test, select the "Update"
button.

PD Test Tab
This tab displays and modifies production test data for the selected well. The upper
dropdown menu displays different tests.

© 2014

402

PETRA Help

The Production Test Details PD Test Tab

Modifying Tests
Update - This option applies any changes made to the entries and saves them to the
database. These changes overwrite the currently selected test.
Add - This option applies any changes made to the entries and creates a new test to
the database.
Delete - This option deletes the currently selected production test

- The arrow buttons cycle through the selected wells' tests.
Add to Perfs - This option adds the currently selected tests top and base to the well's
perfs.
Clear Fields - This option clears the test's fields.

Treatments Tab
This tab displays and modifies treatment data for the selected well. The upper
dropdown menu displays different tests.
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The Production Test Details Treatments Tab

Update - This option applies any changes made to the entries and saves them to the
database. These changes overwrite the currently selected test.
Add - This option applies any changes made to the entries and creates a new test to
the database.
Delete - This option deletes the currently selected production test

- The arrow buttons cycle through the selected wells' tests.
Clear Fields - This option clears the test's fields.

Maintenance Tab
The maintenance tab deletes tests for the currently selected well or all wells, and
changes the units flags.
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The Production Test Details Maintenance Tab

Delete All Tests for this Well... - This option deletes all IP tests for this well.
Delete All Tests for All Wells In DB- This option deletes all IP tests for all wells in the
project.
Set All PD Test UNITS Flags to Current Project Units - This option resets all
production tests to use the current project units of measurement.

Options Tab
The options Tab just changes how the Production Test Details window displays
choke.
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The Production Test Details Options Tab

Display Choke in 64th of Inch - This option forces Petra to display choke in 64ths of
an inch.
4.6.8

FM Tests Tab
The Fm Tests Tab displays and modifies formation test information about the selected
well on the well list. Typing a value in the appropriate entry field will change that field.
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The Main Module's Fm Tests Tab

Production Test Details Window
The details button opens the Production Test Details window. This displays more
specific information about the tests.

Fm Test Tab
This tab displays and modifies production test data for the selected well. The upper
dropdown menu displays different tests. To add a new test, enter the relevant data
for the test and select the "+ Add" button. To modify an existing test, select the
"Update" button.

The Production Test Details PD Test Tab

Modifying Tests
Update - This option applies any changes made to the entries and saves them to the
database. These changes overwrite the currently selected test.
Add - This option applies any changes made to the entries and creates a new test to
the database.
Delete - This option deletes the currently selected production test

- The arrow buttons cycle through the selected wells' tests.
Add to Perfs - This option adds the currently selected tests top and base to the well's
perfs.
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Clear Fields - This option clears the test's fields.

Recoveries Tab
This tab displays and modifies recovery data for the selected well. The upper
dropdown menu displays different tests.

The Production Test Details Treatments Tab

Update - This option applies any changes made to the entries and saves them to the
database. These changes overwrite the currently selected test.
Add - This option applies any changes made to the entries and creates a new test to
the database.
Delete - This option deletes the currently selected production test

- The arrow buttons cycle through the selected wells' tests.

Maintenance Tab
The maintenance tab deletes tests for the currently selected well or all wells, and
changes the units flags.
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The Formation Test Details Maintenance Tab

Delete All Tests for this Well... - This option deletes all IP tests for this well.
Delete All Tests for All Wells In DB- This option deletes all IP tests for all wells in the
project.
Set All PD Test UNITS Flags to Current Project Units - This option resets all
production tests to use the current project units of measurement.

Options Tab
The options Tab just changes how the Formation Test Details window displays choke.

The Formation Test Details Options Tab

Display Choke in 64th of Inch - This option forces Petra to display choke in 64ths of
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an inch.

Maintenance Tab
The maintenance tab deletes tests for the currently selected well or all wells, and
changes the units flags.

The Formation Test Details Maintenance Tab

Delete All Tests for this Well... - This option deletes all IP tests for this well.
Delete All Tests for All Wells In DB- This option deletes all IP tests for all wells in the
project.
Set All FmTest UNITS Flags to Current Project Units - This option resets all formation
tests to use the current project units of measurement.
4.6.9

Cores Tab
The Well Tab displays and modifies information about the selected well on the well
list. Typing a value in the appropriate entry field will change that field.
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The Well Tab displays header and symbol information about the selected well.

Cored Interval Details
This tab displays and modifies core data for the selected well. The list on the left side
of the screen displays different tests. To add a new core interval, enter the relevant
data for the core and select the "+ Add" button. To modify an existing core, select
the "Update" button.
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The Cored Intervals Details displays and modifies more detailed information about a single core.

Type - This entry displays the general type of core. "CONV" and "SDWL" are
common abbreviations for conventional and sidewall cores.
Date - This entry displays the date of the core.
Side Wall Core - This option toggles the flag for a side wall core.
Top - This entry sets the top of the cored interval.
Base - This entry sets the base of the cored interval.
Recovered (Ft or Mts) - This entry sets the total recovered footage.
Quality or Show - This entry sets the quality of the core, or reports the show of the
core.
Lithology Desc - This entry describes the lithology of the core.
Formation - This entry reports the formation of the core.
Remarks - This entry stores any additional remarks about the core.

4.6.10 Perfs Tab
The Perfs Tab displays and modifies perf information about the selected well on the
well list. Double clicking a specific perf entry or the empty perf field will open the
Perfed Intervals Tool.

© 2014

412

PETRA Help

The Perfs Tab displays perf and bridge plug about the selected well.

Perfed Intervals Tool
The Perfed Intervals Tool displays more specific information about each perf. The
list on the left side of the screen displays different perfs. To add a new test, enter the
relevant data for the test and select the "+ Add" button. To modify an existing test,
select the "Update" button. Once you've made all the desired changes, select the
"Save Changes and Exit."
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Source - This entry sets the source of the imported perfs.
Date - This entry sets the date of the original perf.
End Date - This entry sets the end date of the perf.
Perf Type - This dropdown sets the general type of perf. Note that this also includes
bridge pugs, squeezed intervals, and junk.
Top Depth - This entry sets the top of the perfed interval.
Base Depth - This entry sets the base of the perfed interval.
Nbr of Slots - This entry sets the number of slits for the perfed interval.
Diameter - This entry sets the diameter of the interval.
Method - This entry sets the method used for the interva.
Completion Type - This entry sets the completion type of the interval.
Remarks - This field stores any additional remarks or comments about the interval.
4.6.10.1 "Problem" Perfs

Petra projects often contain duplicate or redundant perf intervals. These “problem”
perfs can be divided into two major sets: gross interval perfs, or duplicate perfs.
Petra automatically recognizes these perf intervals and color-codes them. Gross
interval perfs are coded as red, while duplicate perfs are classified as blue.

Gross Interval Perfs (RED)
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Commercial data vendors originally copied perf information from reported IP tests.
Additionally, Petra also has an option to import IP tests as gross perfs. When one IP
test covers multiple perfs, this method records one large “perf” that covers the entire
gross interval. These gross intervals obscure the actual perfs in a well and invalidate
most perf footage calculations.

Duplicate Perfs (BLUE)
Duplicate perfs occur when the same perf interval is repeated in the database. Just
like gross intervals, this can come from commercial data sources, or from reimporting
data into a Petra project.
In the example below, you can see that there are only four actual perfed intervals:
1150-1158, 1164-1169, 1229-1236, and 1240-1245. The remaining perfs are either
gross intervals or duplicates. Notice that Petra color codes these intervals both on
the list and the graphical diagram of the perfs.

A well with both gross and duplicate "problem perfs"

Petra had a few tools for dealing with these duplicate and erroneous perf intervals
that are more efficient than erasing them manually. For more detailed information,
see "How to fix Problem Perfs."

4.6.11 Shows Tab
The Shows Tab displays and modifies show information about the selected well on the
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well list. Double clicking a specific show entry or the empty show field will open the
Shows Details Tool.

The Perfs Tab displays perf and bridge plug about the selected well.

Shows Details
The Shows Details Tool displays more specific information about each show in the
well. The list on the left side of the screen displays different shows. To add a new
test, enter the relevant data for the test and select the "+ Add" button. To modify an
existing test, select the "Update" button.
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The Shows Details tool displays and modifies detailed information on the shows stored in the project

Top - This entry sets the top of the show interval.
Base - This entry sets the base of the show interval.
Show Type - This field stores the type and other general remarks for the show.
Shows - This entry stores the general type of show. Options include oil, gas, water,
and other.

4.6.12 Monthly Production Tab
The Monthly Production Tab displays monthly production streams from the selected
well on the well list.
For information about importing ASCII Monthly Production data, see here.
For information about importing PI Monthly Production data into a project, see here.
For related information about computing monthly production variables from other
production data using equation transform, see here.
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The Production Tab displays the selected well's monthly production data.

Options... - This button selects the displayed streams, production variables, and the
axes on the chart.
Print - This button prints the production plot shown on the Main Module.
Data - This button opens a spreadsheet to display and modify the monthly production
data.
Maintenance - This option opens the Monthly Production Maintenance tool, which
controls the names of the production streams and establishes naming aliases. Thsi
tool also deletes production streams.
Live... - This option displays a small window outlining the production streams for the
selected well.
Quick Set - This option adds a set of three dropdowns to the bottom of the Production
Tab: OIL, GAS, and WTR. These dropdowns select production streams displayed in
green, red, and blue, respectively. The Quick Set is a quicker way of switching
between different production streams than using the Options menu.
Locked - This option locks the selected well's monthly production data. Locked
production data cannot be changed, or overwritten.
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Show Daily Rates - This option converts monthly production rates into daily rates by
dividing by 30.
4.6.12.1 Monthly Production Chart Options

The Prod 1 and Prod 2 Tabs set the production data shown on the production chart.

Data 1/Data 2 Tab
Years Tab
Options Tab
Z-Data Tab

© 2014

Main Module

419

4.6.12.1.1 Monthly Production Chart Prod1/2 Tab

The Prod 1 and Prod 2 Tabs set the production data shown on the production chart.

Production Stream - This dropdown selects the individual production stream. By
default, the OIL, GAS, and WATER and water streams are set in green, red, and
blue. Select "None" to disable the graph.
Cumulative Values - This option displays cumulative values for the selected stream at
the bottom of the plot.
Auto Scale - This option automatically scales the selected production stream to use
the desired logarithmic decades set on the Options Tab.
Linear - By default, Petra plots production values on a logarithmic scale. This option
forces Petra to instead use a linear scale.
Manual Y-Max - This entry specifies a maximum for the selected production stream.
Values above this plot will be off the top of the chart. Note that the minimum will be
determined by the number of log cycles.
Color Box - This bar sets the color of the stream on the plot. To change the color,
select the color box, and select a new color on the
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Changing the production stream color

Suppress Y Axis - This option suppresses the labels on the Y axis.
4.6.12.1.2 Monthly Production Chart Years Tab

The Years Tab sets the extents of the X axis

Automatic - This option sets automatic scaling for the X axis of the production chart to
the first and last month of production.
Manual - These entries set limits on the duration of production data. By default, Petra
displays data from 1900 through 2100, which will be much too big a range for most
applications.
Include Historical Production in Manual Mode - Some states record historical
production in a single historical year labeled "0." This option includes this historical
year 0 in when years are set manually.
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4.6.12.1.3 Monthly Production Chart Options Tab_2

The Options Tab sets some of the details and scaling for the monthly production charts.

Number of Log Cycles on the Y-Axis - This entry sets the number of logarithmic
decades.
Use Common Scale On All Graphs - This option forces all 3 graphs to use the
maximum computed scale.
Use Aliases - This option uses monthly production name aliases.
Draw Through Null Values - This option will draw a line to connect all values. By
default, months with no production have gaps in the graph line.
Position Relative to Well Symbol - This option sets the location of the monthly
production plot around the well symbol.

Load Template - This button loads previously saved production options settings from a
*PDO file.
Save Template - This button saves the production options settings to a *PDO file.
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4.6.12.1.4 Monthly Production Chart Z Data Tab

The Options Tab sets some of the details and scaling for the monthly production charts.

Post Z Data Zone Items on Chart - This option allows zone data items to be plotted
on the production chart.
Select Zone Items - This button selects the desired zone data items for display on the
production chart. Here, select the desired zone and data item on the first two lists,
and selec tthe ">" button to bring the data item over to the "Selected Zone Items" list.

Selecting a data item for display on the Production Tab

4.6.12.2 Modifying Monthly Production Data

The Modify Monthly Production Data" edits the selected wells production streams
with a spreadsheet.
Every-time this dialog is closed, the view settings (including displayed streams) are
saved as private parameters. You can also choose to save a default view (press
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"Save Default View"). When a default view is saved, you can now change the view to
"Use Default View" for any well in that project.

Single Stream View
The production variable is selected from a drop down list of all defined variables.
Each year of production is displayed as a row of values. Columns are labeled JAN
through DEC. If the well does not contain any data, you are prompted for the first
and last year of production to define the rows of the spread sheet.

"Column" or Multi-Stream View
Check the "Column View" check box to view more than one production stream as
columns in the table. You can select the desired streams from the list on the right
that appears in the "Column View." The far most left column displays the date in the
format Month/Year. Inserting and Deleting years works the same as in the normal
view, except it is done one year at a time (you cannot insert or delete individual
months within a year).
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0 = Null - This option treats zero values as nulls.
Active Only - This option displays only months with values
Column View - This option changes the single stream view to column or multi-stream
view
Locked - This option locks the selected well's production data. While locked, it
cannot be overwritten or changed.
Read Only - This option sets the production data to read only. While in read only
mode, data cannot be overwritten or changed.
Show Prior Cum - Older wells have production prior to data recording, which is
typically stored in the monthly production in a special year "0" entry. This option
displays these historical records, which can be important for calculating production
cums.

View
Use Last View - This option uses the last view selected on the Modify Monthly
Production Data tool.
Use Default View - This option uses the default view saved by the user.
Save Default View - This option saves the current settings on the Modify Monthly
Production Data tool. Selecting the Use Default View option will always display
these settings.

Years Displayed
Start Year - This entry sets the starting year of the displayed data.
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End Year - This entry sets the ending year of the displayed data.
Display Data Range - Selecting this option shows all data for the selected well,
regardless of the Start and End Year entry boxes.
Display Custom Range - This option limits the data only to the Start and End Year
entry boxes

Modifying Data
The Modify Monthly Production Data tool works much like any other spreadsheet.
To modify entries, select the desired field and overwrite the existing data.
Use the pop up menu (right mouse click) to invoke many functions.
Copy & Paste - Copy and Paste are now available on the pop-up menu (right click)
as well as accessible through the keyboard shortcuts (Copy-CTRL+C, PasteCTRL+V). Pasting is only allowed if the "Read Only" checkbox is unchecked. This
feature is intended to be used for getting data into or out of an Excel spreadsheet.
Adding New Rows (Years) - Rows are added to the top or bottom of the spread
sheet if you hold down the Shift Key and use the Up or Down Arrow key to move
beyond the first or last year of production.
Deleting A Row (Year) - Delete a row by pressing the Alt-Delete key combination or
from the pop up menu. Year 0 cannot be deleted.
Inserting A Row (Year) - Insert a new row above the current row by pressing the AltInsert key combination or from the pop up menu. The year of the inserted row is 1
less than the current row.
Show Graph - A simplified production chart can be displayed by activating this
option.
Save and Load Templates - Templates store the current view settings to/from an
external file with a *.MPD extension.

4.6.12.3 Monthly Production Maintenance

The monthly production maintenance screen is used to add, modify, and delete
monthly production database variables.
Production Database Items Select one of the existing production variables to modify the name, units or
description or delete production.
Definition
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Name - A 1 to 10 character string to identify the production variable. Examples are
OIL, GAS or CO2.
Units - An optional 1 to 8 character code to identify the units of the production data.
Examples are BBL (barrels) or MCF (thousand cubic feet).
Description - A 1 to 40 character string to describe the production variable in more
detail.
Add - Adds a new production definition to the production database.
Modify - Changes the name, units or description of an existing production variable.
Delete - Deletes the production definition and all associated data from the production
database.
4.6.13 Prod Cums Tab
The Prod Cums Tab displays and modifies cumulative production values for the
selected well on the well list. To modify an entry, select the "Details" button.
Prod Cum data by itself isn't easily mappable or used in calculations. It's often useful
to use the Extract PdCum Data To Zone tool to copy some of these variables to a
zone data item.

The ProdCums Tab displays the selected well's cumulative production
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The PdCum Details Tool changes the data in an individual well and column names for
the entire project. This tool also deletes all production cums from the project.

Data Tab
The Data Tab changes individual data for a specific well. This includes changing the
formation name, top and base, dates, and production cums.

The Data Tab modifies the selected well's PdCum data

Fixed Column Labels
The Fixed Column Tab changes the names of the columns as they appear on the Prod
Cums Tab. Most users will want to leave these alone.
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The Fixed Colum Labels Tab modifies the columns that appear on the Man Module's Prod Cums Tab.

User Column Names
The User Column Names Tab sets the column definitions for the user column names.
Here, select the desired column and change the name and type. Note that numerical
fields can have a set number of decimal places.

© 2014

Main Module

429

The user Column Names modifies additional column name in the project database.

Options
The Options Tab sets a couple of additional options for name substitution and date
format.

The Options Tab controls how Petra replaces missing ALTNAME entries and displays dates

Substitute FMNAME when ALTNAME is BLANK - This option replaces missing entries
for altnames with the formation name.
Date Format - This dropdown selects how Petra displays dates. By default, Petra
uses mm/dd/YYYY

Advanced Tab
The Advanced Tab performs a couple of additional maintenance tasks, including
global PdCum deletion and locking wells.
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The Advanced Tab deletes PdCums with a specific formation name, locks PdCum data, and modifies PdCums with "0"
tops and bases.

Global Deletion - This option deletes all PdCum entries with a set FmName. Note that
the name must match exactly.
Locks - This option locks and unlocks the PdCum entries for the selected wells.
Set ZERO Top and Base Values to NULL - This dropdown replaces PdCum tops and
bases with "0" values to a null. This can be useful for eliminating erroneous
calculations involving depths.

Report Tab
The Report Tab creates CSV file of PdCum data.
To add a data column to the report, simply double-click the desired data field in the
"Available Columns" list.
To remove a column, double-click the desired data field in the "Report Columns" list.
To rearrange the list in the Report Columns list, select the desired field, and use the
up and down arrows to move the individual data field up or down. Entries on the top
of the list will appear first (and to the left) on the CSV.
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The PdCum Tab creates *.CSV reports of production data

To create the file, select the "Create Report..." button. This opens an entry to select
the desired name and location of the file. As a CSV file, the report can be opened in
most spreadsheet programs.

An example CSV PdCum report

4.6.14 Rasters Tab
The Rasters Tab displays and modifies the calibrations for scanned wireline paper
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logs, known as "raster logs."

The Rasters Tab

- This option displays a small window on the selected raster's
group and file locations.
- This button opens the Pay Interval Data Tool.
- This option opens the Raster Image Calibration Tool. This tool
depth-registers the image and sets its group name. This tool also has a few image
processing tools and can straighten and despeckle the image files. This tool can pick
tops, pay, and digitize the log images.
- This button opens the Group Maintenance tool.
- This tool opens the Neuralog Scanner Interface tool. The "Group
Name Indicating Log Type" sets the raster group name for the scanned log. The
"Store Scanned Image and 'LIC' File in Following Folder" option sets the location for
the scanned image file and LIC created by the neuralog scanner.
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The Neuralog Scanner Interface window

- The button opens the Raster Log Correlation tool.
- This button removes the raster log group name from the project
database. This option does not erase the image file or the LIC file.
- This button merges two or more selected log groups.
- This option creases a brief text file containing a summary of the selected raster
group names.

A Raster List File

4.6.14.1 Raster Image Calibration

The Raster Image Calibration tool adds depth calibrations to raster logs, straightens
images, adds pay intervals, and creates digital logs.
To open the Raster Image Calibration tool, select the
button on
the Rasters Tab. This opens the “Calibrate Log Image” screen. Notice that the well’s
UWI and name appear on the screen.
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An Introduction to Image Groups
The Cross Section and Log Correlation Modules display log images for a given well by
referencing group names. For example, you might display images from the "GR"
group in track 1 and images from the "Default" group in track 2.
Petra predefines one group called the "Default" group. You can create as many
groups as you have different images for a well. Groups names should normally have
something to do with either the log curves they contain or the sample rate of the log, i.
e., "5-inch logs".
Each well can have only one image in a group. However, there is no limit on the
number of different groups you can define. Therefore, if you have 5 different log
images for a well, you must have 5 different image groups defined. The well will have
1 image in each of the 5 groups.
The Petra database has a table containing a reference to log image calibrations. Each
record in the table contains a well sequence number (WSN), image group number
(IGN) and a path to the calibration file. This scheme allows an unlimited number of
images to be referenced for any given well.

Assign A Group Name
Select the appropriate image group from the "Image Group Name" drop-down list or
add a new group using the "Group>Add or Delete Groups..." menu.

Assign A Well
If a well has not been assigned, choose the "Well>Assign Image To Well" menu to
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select the well from a list. The image and calibration file will be associated with this
well.

Open an Image File
Use the "File>Open Image" menu item and select the log image file. It will be loaded
into memory and displayed on the screen.

Raster Image Calibration Toolbar
- The "Save Calibration As" overwrites the calibration file (*.LIC) for the current
raster image. This will save the depth calibration points, headers and footers, and
scale markers set on the raster image to a specific "group name."
- The "Save Image As" saves the changes made to the image file (such as image
editing or image straightening). Like any other file, you can permanently overwrite the
existing image file or create a brand new copy. Note that overwriting the existing file
may make pre-existing depth calibration points and groups inaccurate.
- The "Cut Out Section" tool removes a portion of the image file and splices the
image back together. This can be useful for removing extraneous portions of the log.
For more information, see log image editing.
- The "Crop At Depths" tool removes the image file beyond the uppermost and
lowermost depth calibration points, header, footer, or scale markers. For more
information, see log image editing.
- The "Crop At Edges" tool removes the image file beyond the left and right most
track edge. For more information, see log image editing.
- The "Add Straight Edge" button adds a straight edge for raster image
straightening. Users adjust this line to reflect
- This "Straighten Image" tool uses the straight edge to straighten the log image.
- This tool rotates the entire image. For more information, see log image editing.
- The "Show Image Details" tool displays more detailed image about the image
file, including bits/pixel and image size.
- This button opens the Raster Test Indicators tool. This can plot perfs, formation
and IP tests, and other test data on the Raster Image Calibration tool.
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Getting Started
Adding Depth Calibration Points, Edges, Header/Footer/Scales
Straightening Log Images
Plotting Test Indicators
Displaying and Picking Tops
Log Image Editing

Advanced Tools
Digitizing Raster Log Curves

4.6.14.1.1 Depth, Header, and Scale Calibration

Raster logs are scanned copies of paper logs saved as image files. In order to plot
the correct part of the picture at the right depth on a cross section, Petra requires
computer-recognizable depths to be assigned to depths printed on the original log.
This tool can set headers, footers, and scales, as well as left and right edges. Petra
saves these calibration points to a associated (*.LIC) text file for every group name.

Depth Calibration Toolbar
The depth calibration toolbar is probably the easiest way to rapidly work with depth
and other calibration points.
To display this toolbar, select View>Depth Calibration Toolbar.
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Scroll to Top and Base
These buttons simply jump to the shallowest or deepest depth calibration point.
To jump to the top calibration point, select either the "T" or up arrow button.

The scroll to top and scroll to base buttons

Adding, Changing, and Dropping Depth Calibrations
Depth calibration points translate depth marks on the image into depths that Petra
can use. The portion of the image that can be displayed on the cross-section is only
the section within the range of the calibration depths. Portions above the shallowest
depth and below the deepest depth will not be displayed.
To add a depth point, select the "Add" button on the toolbar, or Depths>Add Depth
Point on the menu bar at the top of the Calibration Tool Bar. Note that Petra will
draw a horizontal cursor over the image. Position the horizontal cursor over the
desired image exactly at the depth you wish to pick, then click the left mouse button.
Finally, enter the depth value. After entering the depth value, the screen will redraw
showing the new calibration depth point. Repeat the process for each depth
reference point.
To change the location of the depth, click and drag the depth marker using the left
mouse button.
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To edit the value of an existing depth, click on the depth line with the right mouse
button and enter a new value.
To delete an existing detph calibration point, select Depths>Delete Depth" option
menu or the Delete button located at the top of the Calibration Tool Bar. After
invoking the delete function, click the left mouse button on the depth marker to be
deleted. The screen will redraw once the marker is deleted.
You can also delete all depth references using the Depths>Delete All Depths...

Automatically Interpolating Depths
This tool automatically creates depth points by a given interpolation increment
between the uppermost and lowermost calibrated depths. Since Petra already
scales between registered depths, automatically adding a lot of new points
does not aid in the overall calibration of the raster log. Creating a bunch of
extraneous depth calibration points is often more trouble than it's worth - it's
generally better to look for the small black interpolated depth lines, and add new
depth points where necessary. Most rasters only need a few depth calibration
points, and even extremely distorted ones usually won't need more than a dozen.
To automatically create depth points, select the "Interp" button on the toolbar or
select Edit>Interpolate Depths. Here, select the depth increment - Petra will
interpolate between depth calibration points using the set footage.

Before (left) and after (right) depth point interpolation. Note the automatically interpolated depths in thin black lines
remain unchanged.
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Decimating Depth Calibrations
This tool decimates depth calibration points in between the upper- and lowermost
points. This can be useful for removing unnecessary calibration points created by
the interpolation tool or an overzealous interpreter.
To decimate depth points, select the the "Interp" button on the toolbar or select
Edit>Interpolate Depths. Here, select the depth increment - Petra will interpolate
between depth calibration points using the set footage.

Before (left) and after (right) decimating every third depth point

Left & Right Edges
The left and right edges set the useful boundaries of the group image. These
boundaries can be useful for trimming extra white space on the sides of the image.
To set the left and right edges, select the "Left" or "Right" button on the toolbar, or
select Edit>Set Left-Most Edge or Edit>Set Right-Most Edge on the menu bar at the
top of raster calibration tool.
Next, position the line at the relevent part of the image and left click. For the left
side, for example, set the edge on the left side fo the image. Note that the edges
will have a blue triangle pointing inward. If the triangle is pointing out away from the
center of the image, it's on the wrong side.
To change the location of either edge marker, click and drag the marker using the
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left mouse button.

Blue left and right edges added to a raster log. Note the small triangles pointing inward.

Upper & Lower Scale
The scales help define what the curves on the raster log actually represent. Scales
can be plotted in the raster image's track on both the Cross Section Module and Log
Correlation Tool.
To set the scales, select the "Top" button on either the "UprScl" or "LwrScl" section
of the the toolbar, or select Edit>Upper Scale Header>Set Upper Scale Top /
Edit>Lower Scale Header>Set Lower Scale Top on the menu bar at the top of the
raster calibration tool. Position the line at the upper part of the scale, and left click.
Note that Petra will draw a green line on the image.
Next,select the "Bottom" button on either the "UprScl" or "LwrScl" section of the the
toolbar, or select Edit>Upper Scale Header>Set Upper Scale Bottom / Edit>Lower
Scale Header>Set Lower Scale Bottom on the menu bar at the top of the raster
calibration tool. Position the line at the bottom part of the image, and left click.
Petra will draw the section in between the two lines with a green overlay. Note that
this overlay is just for positioning, and won't appear on cross sections.
To change the location of either edge marker, click and drag the marker using the
left mouse button.
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A lower scale set at the bottom of an image

Headers
Headers designate the part of the image occupied by the image's header, which
usually contains well information, dates, and other relevant wireline information.
To set the header, select the "Top" button on the "HDR" section of the the toolbar, or
select Edit>Log Header>Set Log Header Top on the menu bar at the top of the
raster calibration tool. Position the line at the upper part of the scale left click. Note
that Petra will draw a green line on the image.
Next, select the "Bottom" button on the "HDR" section of the the toolbar, or select
Edit>Log Header>Set Log Header Bottom on the menu bar at the top of the raster
calibration tool. Position the line at the upper part of the header left click. Petra will
draw the section in between the two lines with a pale blue overlay. Note that this
overlay is just for positioning, and won't appear on cross sections.
To change the location of either header marker, click and drag the marker using the
left mouse button.
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Display Gaps
The portion of an image interval between 2 calibrated depths can be hidden during
cross-section display if that interval is tagged as a "display gap". Gaps can result
when calibration files are merged and there is a gap between the sections being
merged. You can manually define a depth interval to be a gap by clicking the left
mouse button between 2 calibration depths while holding down the control key. Each
time you click, the gap is toggled on or off. Display Gaps are shown in the
calibration screen as a "grayed out" portion of the image.

Saving the Calibration File
Choose the "File>Save Calibration As..." menu to save a file containing the
calibration data, image name, depth references, etc. This will also update the Petra
database with a reference to the calibration file which is now associated with the
current well.
The "File>Save Calibration" will save the current calibration being modified.
Log Image Calibration files have a file extension of ".LIC"
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Loading a Calibration File
You can load and modify a previously saved calibration file using two methods.
First, the "File>Load Calibration File" menu allows you to choose the specific
calibration file to be loaded. The image name will be read from the calibration file and
the image will be opened and displayed.
Secondly, the "File>Load Calibration For Group" menu will retrieve the name of the
calibration file from the Petra database which is associated with the current well and
image group name.
4.6.14.1.2 Log Image Calibration Net Pay - Cross Section

Scanned raster log images, displayed in the cross section module, can show one or
more color-filled intervals representing zones of "pay." Also, the pay thickness for
these intervals can be stored in the Zone database where they become available for
posting or contouring.
The pay intervals are defined in the Log Image Calibration screen. The user picks the
top and base depths of each pay interval. A vertical guide line can be added and
used as a visual aid to show where the log curves cross over the desired "cutoff"
value.
Each defined interval is associated with a "pay number" and color. Pay numbers
range from 1 to 100. For example, a log image might have 5 intervals picked, with
two intervals making up pay zone 1 and the other three belonging to pay zone 2.
Petra will compute and display the thickness of each of the 5 intervals and will store
the sum for all pay zone 1 intervals in the zone database. Likewise, the sum for all
pay zone 2 intervals can be stored in the zone database. Optionally, the total
thickness of all pay zones (pay 1 plus pay 2) can be stored in a total pay zone item.

Pay Toolbar
Select Pay Number
Click the left or right arrows
to decrease or increase the pay number
respectively. The pay number will appear in the "Pay and Color Indicator" (see
below). All intervals with similar pay numbers will be summed together as a single
pay value stored in the zone database.

Pay Number and Color Indicator
This rectangle indicates the current settings for the pay number and color. It can
also be dragged and dropped onto an existing interval to set that interval's number
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and color.

Select Pay Interval Color
Click the Pay Color icon to display the system color dialog screen. Choose the color
you want to use for shading the pay interval. The color will appear in the "Pay and
Color Indicator" (see above). Ideally, all intervals with similar pay numbers should
have the same color.

Pick Cutoff Guide Line
Use the cutoff guide line icon to add a vertical line to the log image marking the
desired log curve cutoff. Position the vertical cursor at the appropriate cutoff value
and click the LEFT mouse button. You may click on and drag the cutoff guide line to
reposition it at any time.

Pick Pay Intervals
Use this icon to begin picking one or more intervals for the current pay number and
color. First, position the horizontal cursor at the TOP of the interval, at the point
where the log curve intersects the cutoff guide line. Click the LEFT mouse button to
record the top of the pay. Next, position the horizontal cursor at the BASE of the
interval, at the point where the log curve intersects the cutoff guide line. Again, click
the LEFT mouse button to record the base of pay. You may repeat this process for
other intervals within the pay zone , or click the RIGHT mouse button to end.

Delete Pay Interval
Use this icon to delete an interval. Click on the icon then click between the top and
base of the interval to delete. Alternately, you can delete an interval using the "rightbutton" pop up menu. Click the RIGHT button over the interval to delete, then choose
the "Delete Selected Pay Interval" menu option.

Clear All Pay Intervals
Use this icon to delete all pay intervals from memory.

Store Pay In Database
Use this icon to store pay thickness values in the Zone database. Totals for each
numbered Pay zone will be stored separately as well as a single total pay thickness.

Steps to Pick Pay Intervals

© 2014

Main Module

Step 1 - Define the Cutoff Guide Line using the
Step 2 - Set the Pay Number using the
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icon.

icon.

Step 3 - Set the Pay Color using the

icon.

The Pay Number and Color indicator

will show the settings.

Step 4 - Click the Pay Interval
icon to start picking intervals. Pick the TOP of
the interval, then the BASE of the interval. Next, either pick the top and base for
another interval or click the RIGHT mouse button to end.

Adjusting Pay Interval Depths
The top and/or base of an interval can be moved using the LEFT mouse button.
Click, hold and drag the LEFT mouse button on the top or base marker. Move it to
the new position and release the mouse button.

Changing Pay Interval Number and Color
You can change the Pay Number and Color of any previously defined interval by
onto the pay
dragging and dropping the Pay Number and Color rectangle
interval image. Alternatively, you can right-click on the pay interval (anywhere
between the top and base depths) to display the pop up menu. Choose the menu
entitled, "Apply Pay Number and Color To Current Interval".

Changing Color for All Similar Pay Numbers
For example, you need to change the color for all intervals making up Pay #2. Click
the RIGHT mouse button over any interval of Pay #2, to display the pop up menu.
Choose the menu entitled, "Apply Color to All of Same Pay Number".
4.6.14.1.3 Raster Test Indicators

The Raster Image Calibration tool can plot tests, shows, production and formation
tests, casing, and cores.
To add test indicators, select View>Plot Test Indicator on the menu bar at the top of
the Raster Image Calibration tool.

Options Tab
© 2014

446

PETRA Help

Display
This section sets which test indicators are plotted on the Raster Image Calibration.
Checked entries will be plotted.

Symbol Position
These sliders sets the location of the test indicators relative to the raster image.
Symbol Width - This entry sets the size of all test symbols on the Raster Calibration
Tool.
Size Scale Factor - This entry sets the size of the test indicators. 1 is the default size
of the symbols, 0.5 is 1/2 the normal size of the symbol, and 5 is 5 times the size of
the symbol.
Skip Items Flagged as "Do Not Plot" - Petra's database stores "do not plot" flags for
all test indicators. This option will not plot any tests with these flags enabled.

Perfs/Shows/Pd Tests/Fm Tests/Casing Cores Tab
The Raster Test Indicators tool has several additional tabs that set the color and line
width of the different test indicators.
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Use Default Colors(s) - This entry uses the default color for the relevant test.
Use Color - This entry sets a user-selected color for the test.
Line Width - This dropdown sets the width of the line used to draw the test on the Log
Calibration tool.

4.6.14.1.4 Log Image Editing

The Log Calibration tool includes a few additional tools for editing the raw log image
files. This process modifies your image file, so be sure not to save over the original
image file and have a backup. To restore the filtered lines select File>Reload Original
Image.
This can be useful for cleaning up images for digitizing raster logs. Since the tracing
algorithm looks for adjacent dark pixels, it can easily get confused by vertical scale
lines and horizontal depth lines. The Log Calibration tool can filter out straight
horizontal and vertical lines that can confuse the auto-digitzing function. Log imaging
editing isn't foolproof - using filters can reduce the clarity of the curves as well,
especially where the curves intersect the filtered horizontal or vertical lines.

Rotate Image
Scanning can sometimes subtly rotate image logs. The easiest way to spot this is
tilted depth/scale lines or by zooming out. Note that this can increase the margins to
the left or right the actual image. It's often useful to use the "Crop at Edges" can
remove extra white space created by rotating the image.
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To use this tool, select the
button on the toolbar. Alternatively, select Edit>Rotate
Image on the menu bar at the top of the Raster Image Calibration tool. Positive
numbers rotate the image clockwise, and negative numbers rotate the image counterclockwise.

The original image (left) and after using the "Rotate Image" tool (right)

Flip Black and White
This tool flips the colors of the loaded image. For monochrome images, this will
simply flip the black and white. Note that this tool will also flip the colors of color
images as well.
To use this tool, select Edit>Flip Black and White on the menu bar at the top of the
Raster Image Calibration tool.
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The original image (left) and after using the "Flip Black and White" tool (right)

Crop at Edges
This tool removes the image file beyond the "Left-Most Edge" and "Right-Most Edge"
in blue.
To use this tool, select the
button on the toolbar. Alternatively, select Edit>Crop at
Edges on the menu bar at the top of the Raster Image Calibration tool.
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The original image with blue edge markers (left) and after using the "Crop at Edges" tool (right)

Crop at Depths
This tool removes the image file beyond the uppermost and lowermost depth
calibration points, header, footer, or scale markers.
button on the toolbar. Alternatively, select Edit>Crop at
To use this tool, select the
Depths on the menu bar at the top of the Raster Image Calibration tool.

Cut Out Section
This tool removes a part of the image file between a user-selected top and bottom.
Petra will automatically splice the image back together to form a continuous image.
To use this tool, select Edit>Cut Out Section on the menu bar at the top of the Raster
Image Calibration tool. Next, set the top and bottom of the section to remove from
the image. Note that Petra will add a blue box and outline over the selected area.
Next, select "OK" to remove the section.
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The original image with the top and bottom set in blue (left) and after using the "Cut Out Section" tool (right)

Auto Trim Edges
The Auto Trim Edges tool attempts to automatically remove blank space around the
image. Manually using the "Crop at Depths" and "Crop at Edges" tool is often better,
but slower.
To use this tool, select Edit>Auto Trim Edges on the menu bar at the top of the
Raster Image Calibration tool.

Remove Vertical Lines
This tool attempts to filter out vertical lines from the images. This tool works best on
straightened images where the vertical lines are perfectly straight. Even slightly
curved vertical lines won't be recognized by this process. To use this tool, select
Edit>Filter>Remove Vertical Lines on the menu bar at the top of the Raster Image
Calibration tool.
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The original image (left) and after using the "Remove Vertical Lines" tool (right)

Remove Horizontal Lines
This tool attempts to filter out vertical lines from the images. This tool works best on
perfectly horizontal lines. To use this tool, select Edit>Filter>Remove Horizontal Lines
on the menu bar at the top of the Raster Image Calibration tool.
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The original image (left) and after using the "Remove Horizontal Lines" tool (right)

De-Speckle Image
This tool attempts to remove isolated dark spots on the image. To use this tool,
select Edit>Filter>De-Speckle Image on the menu bar at the top of the Raster Image
Calibration tool. Enter the maximum dot size in pixels and select "OK." A smaller
"Maximum Dot Size" setting will be more conservative, while a larger setting will
remove more dots.

The original image (left) and after using the "De-Speckle Image" tool (right)

Color to Monochrome
Some raster images are saved as color files, even though they are scanned copies of
black and white paper logs. This tool will convert color images to monochrome, which
can decrease file size.
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To use this tool, select Edit>Color To Monochrome on the menu bar at the top of the
Raster Image Calibration tool.

Convert Image Bits per Pixel
"Color depth" indicates the number of bits that describe a single pixel's color in an
image file. This is usually expressed in bits per pixel: 1 (monochrome), 8 (8-bit color)
, 16 (high color), or 24 (true color) bits per pixel. Higher color depths represent finer
color gradation, but take up more file space. Generally, raster images don't need
high color depth to represent lithology. Note that this tool will only work on images
with color depths above 1.
To use this tool, select Edit>Convert Image Bits per Pixel on the menu bar at the top
of the Raster Image Calibration tool.

4.6.14.1.5 Straightening Images

Raster logs often have curved or distorted images from paper stretch or
misalignment of the original paper log during the scanning process. Crooked images
can create problems when displaying raster images on the Cross-Section or Log
Correlation modules.

Getting Started with Depth Calibration Points
Petra uses depth calibration points as "nodes" that set the location of the straight
edge. When you straighten an image, you generally want the header and scale
information to be straightened as well. Since image straightening works at each
depth calibration point, it’s a good idea to add a “fake” depth point above the header
and below the footer information before straightening. Once the image is
straightened, you can always delete these fake depth calibration points. Depending
on the image, you can use a couple of different strategies.
First, create a good set of depth calibration points - generally, most images will only
need a few points to accurately capture the depths. Next, add a fake depth
calibration point above the header and another fake point below the footer. This
ensures that when we straighten the image, we also straighten the header and
footer. For raster logs with multiple runs and scales, you'll need a set of depth
points over the entire raster log.

Adding a Straight Edge
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To straighten an image, select the
button on the on the toolbar or select Edit>Add
Track Straight Edge… on the menu bar at the top of the Raster Image Calibration
tool.
The straightening process involves defining a "Track Straight Edge" along the
leftmost track edge. This straight edge is a multi-segmented line connected to each
calibration depth marker.
The Track Straight Edge is identified with a series of control points located at the
intersection of each calibration depth. You can, and should, move these control
points to align the boundary segments with the image tracks. The control points can
be moved using the left mouse button. Now you see why we generated a small
number of depths. We only need enough depth points to define the track straight
edge segments. You can always add more depth points if the track straight edge
can not be manipulated to align completely with the image.
Next, click to set a straight vertical line on top of one of the vertical lines printed in
the raster image. Though this tool suggests the left side of the depth track, any
consistent vertical line will work. Petra will generate a straight line with node points
at every one of the depth calibration lines.
Next, drag each node point so that it accurately covers the crooked line on the log; if
you find that you need more nodes, simply add another depth registration point.
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Finally, click on the “Straighten Image” button on the toolbar at the top of the
screen:
or go to Edit>Straighten Image Edges… on the menu bar.
In the example below, notice how the image is crooked. The crooked interval is
bracketed off with depth markers at 6188’ and 6190’, and a straight edge is added.

Next, the straight edge nodes are moved to fit the left track edge.
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Finally, by clicking “Straighten image”, Petra moves parts of the image to bring the
straight edge into alignment.

Saving your changes
Straightening the image makes changes to the image file. Depending on the
situation, you can either overwrite the existing image file or create a new version. To
save an image, select the
button on the toolbar, or select File>Save Image As…
on the menu bar.
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To add the Track Straight Edge, choose the Edit->Add Track Straight Edge menu
option. Align the vertical cursor with the left edge of the LEFTMOST log track and
click the left mouse button.
The straightened image must be saved back to disk as a TIFF file. You should
create a new file. Do not write over your original image
At this point you may choose to clear the artificial depth calibrations and proceed
with normal calibration. Refer to the Depth Calibration section for details. Or you
can exit without saving your calibrations. What ever you do, DO NOT save over a
good calibration file with the artificial depths used for straightening.
4.6.14.1.6 Digitizing Raster Logs

The raster log image calibration screen can also be used to digitize log curves and
store them in the digital log database. Digitizing a curve involves using the mouse to
trace over the curve on the image. Points are picked along the curve which identify
each deflection of the curve values. You may start and stop the process as many
times as necessary to digitize the interval of interest. Each start-stop or continuestop sequence will generate a "curve segment". Curve segments may overlap and
can be edited or deleted independent of other curve segments. These curve
segments can be saved to a file as your "work-in-progress" and loaded at a later
time to continue. Once the entire curve section has been digitized and edited to your
satisfaction, they are stored in the project log curve database under a specified
curve name. Existing database curves can either be replaced or appended with the
newly digitized section.
IMPORTANT - Only one curve trace can be digitized at once. If you have several
curve traces to digitize, then you'll need to digitize and store the first curve, "clear",
then begin digitizing the second curve trace.
Before You Start!
1. You must open an image or previous calibration file.
2. The image must be depth calibrated over the interval to be digitized. Refer to the
Depth Calibration section for details.
3. Activate the "Curve Digitizing Tool bar" option located under the View menu.
4. Click the Set Curve button to enter the log curve name and scale.
5. Define the track boundaries of the track containing the curve to be digitized.
6. Adjust the track boundaries to remove skew.
Setting the Curve Name and Scale
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Digitizing Tool after setting a "linear" scale of 0 to 100.
Defining the Track Boundaries
The Digitizing Tool bar contains a "Track" section with a Left and Right button. To
add the Left track boundary, click the Left button. Align the vertical cursor with the
left edge of the track and click the left mouse button. Repeat the process using the
Track Right button to define the right side of the log track.
Logs can only be digitized within the calibrated depth range.
Adjusting the Track Boundaries To Remove Skew
Many times, the edges of the log tracks are curved due to paper stretch or slippage
while being scanned. The left and right track boundaries are identified with a series
of control points located at the intersection of each calibration depth. You can, and
should, move these control points to align the boundary segments with the image
tracks. The control points can be moved using the left mouse button. Aligning the
segments will remove skewing and result in more accurate digital curve values.
Entire images can be straightened using the Straighten Image function.
Start Digitizing
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Start by identifying the curve you wish to digitize by clicking the "Set Curve" button at
the top of the digitizing tool bar. Select an existing curve or enter a new curve name.
You must also specify the curve values for the left and right sides of the track
boundary.
The Digitize Tool bar contains a section called "Digitize". To begin digitizing a
section, click either the 'Start" or "Continue" button under the "digitize" tool, or click
the "Manual" button under the "Auto" tool. If you click the "Start" button you will be
prompted for the curve name and range information.
To digitize the curve section, position the cross-hair cursor at the uppermost depth
on the curve trace to be digitized and click the left mouse button. Repeat by clicking
at each significant deflection of the curve. IF YOU MAKE A MISTAKE, you can either
STOP and edit the bad point(s), or continue and edit them later.
You can also use a continuous "stylus" mode option by activating the stylus mode in
the curve definition screen. In the stylus mode, curve points are continuously
recorded as you hold down the left mouse button and draw over the curve. You may
temporarily activate the stylus mode by holding down the Alt key as you digitize.
Stop Digitizing
You can stop the digitizing process by clicking the right mouse button or by clicking
on the "Stop" button on the Digitize Tool bar.
Auto Tracing
The section under "Auto" toolbar allows automatic digitizing of simple, bold, welldefined curves. You begin by clicking the "Start" button under the "Auto" section,
then on the uppermost point on the curve to be digitized. The auto tracer will attempt
to follow the densest portion of the log beginning at the selected point. You may
press the ESC key or click the left mouse button to stop the auto tracer. The
"Manual" button allows you to manually re-digitize over section not properly handled
by the auto tracer. The "Set" button displays a screen for setting properties
controlling the auto tracer.
Changing the Track Scales (Linear Curve Scale Wrapping)
Whenever the log image curve reaches a track edge, the scale will "wrap" and the
curve will reappear on the opposite side of the track. At this point, you will need to
STOP digitizing, change the scale, and then CONTINUE digitizing. The current left
and right side track scale is displayed near the top of the Digitize Tool bar. Each
curve scale range will be displayed in a different color beginning with red for the
base scale. There are 6 colors defined above and below the base scale.
To increase the scale range, i.e., wrap the curve to the right, click on either the ">"
button or on the right side scale value. To shift the scale to the left, click on either the
"<" button or on the left side scale value.
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The auto tracer will attempt to detect the track edge. It will stop the auto trace and
request if you want it to automatically adjust the curve scale to account for the wrap.
Editing a Curve Segment
Selecting a Curve Segment Any of the digitized curve segments can be edited by first clicking the "Select" tool
bar button and clicking on a curve segment or by simply double-clicking the curve
segment. Selection is detected by a mouse click close to one of the control points
make up the segment. The "selected" segment will be identified by small rectangles
drawn at each control point of the curve. A right mouse click will deselect the curve
segment.
Changing Curve Scale Range If you digitize a curve segment with the wrong scale range, select the segment, set
the scale range at the top of the digitizing toolbar, then click the "Scale" button in the
"Edit" section.
Moving Curve Segment Points Any of the selected curve segment points can be repositioned using the left mouse
button. A right mouse click will deselect the curve segment to show the edited curve.
Deleting a Curve Segment Click on the "Delete" tool bar button in the Edit section to delete the selected curve
segment. You can also simply press the Delete Key to delete the selected curve
segment.
Breaking a Curve Segment You may break a segment into two segments. First, select the segment. Then, hold
down the CTRL-key and click on a segment control point. All points ABOVE the
picked point will become unselected. They are now part of a different segment.
Breaking and Deleting Part of a Segment You may break a segment into two segments then delete the bottom portion. First,
select the segment. Then, hold down the CTRL and ALT-keys together and click on
a segment control point. All points BELOW the picked point will be deleted.
Using the Delete Rectangle You can use a Delete Rectangle to delete intermediate points of the selected curve
segment. To begin, select a curve segment. Hold down the SHIFT-key and click-anddrag the left mouse button to form a rectangle. All points within the depth range of
the rectangle will be deleted. The segment will be de-selected and two new
segments will be formed.
Deleting ALL Curve Segments © 2014
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Click on the "Clear" tool bar button in the Edit section to delete all curve segments
that have been digitized.
Merging of Curve Segments Normally, when a curve segment is digitized over the same depth interval as a
previous curve segment, the new segment is automatically merged into the earlier
segment. Merging prevents having multiple segments over the same depth interval.
Segments will not be merged when the auto-trace function is used or when the
"wrap" settings are different. You can manually merge segments by first selecting a
curve segment then press the F5 function key.
Saving Your Work-In-Progress
You can save the digitized curve segments to a file. If you think you may need to
modify the curve segments at a later time, you should save them BEFORE you store
your curve in the database.
Storing Your Curve In The Database
Storing the curve in the database makes a digital curve available for other function in
Petra. When a curve is stored, the curve segments are resampled to the specified
sample rate and merged together. When segments overlap in depth, earlier
segments are replaced by later ones, i.e., the last segment you digitize overwrites
the first segment you digitized (assuming there is overlap).
You may also load a digital log curve from the database using the "Load" button
under the "Curve" section.
Starting Another Curve
If you want to digitize more than one curve, you will need to use the "Edit>Clear"
button on the toolbar. This will remove previously digitized segments from memory so
they don't get stored as part of the new curve.
Digitizing Non-Linear Scales
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Example of Non-Linear Scale Details

Setting the Non-Linear Scale Points and Values
The non-linear scale is defined as a series of value-pixel pairs (max=100).
To begin picking the scale points, click the "Start" button (shown above). You will be
prompted to begin the process.

Click the left-most scale point of the scale bar and enter it's scale value.

(If your scale uses a value of "infinity", enter a scale value of 1E20 or some other
large number less than 1E30)
Proceed by clicking and entering values for each of the other scale points, working
your way from left to right.
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Terminate the process by clicking the "End" button or simply right-click the mouse.
Petra will display each of the digitized scale values.

Note how the non-linear scale is displayed on the image and the left and right-most
values are denoted on the toolbar.

Proceed with curve digitizing as described above.
Warning - There is no scale "wrapping" with non-linear scales.
4.6.14.1.7 Formation Tops

Selecting and Displaying Tops
To display tops, select Tops>Select Tops from the menu bar at the top of the Raster
Image Calibration tool.
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Edit Mode
To edit formation tops, select the green "Start Top Editing" radio button on the Tops
toolbar (highlighted in red).

4.6.14.1.7.1 Repeat Tops

Repeat Tops occur when the same lithologic interval is encountered multiple times in
the same wellbore. This is most common in directional wells, though is also possible
with structurally complex areas with overturned beds and folds.
To add repeat tops in the Raster Image Calibration tool, select Tops>Enable Repeat
Tops.
When editing formation tops, you can now pick, move, or delete repeat values as
well. First ensure that under the Tops menu, ‘Show Repeat Tops’ is checked. This
should display any tops along with their repeat values if any exist in the visible range.
When in editing mode, there is a new check box and button on the Edit Fm Tops
dialog. If the ‘Pick Repeat Tops’ dialog is checked then holding down the CTRL key
while clicking adds a repeat of the selected top at that depth. ALT clicking deletes a
repeat top. You can also click and drag any top to adjust its position. The ‘Set
Repeats’ button opens a grid showing you the value of all repeats for the given top.
From here you can edit, add, or delete values.
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4.6.14.2 Raster Group Maintenance

The Raster Group Maintenance Tool controls image group names, establishes raster
group aliases, and performs other raster group maintenance tasks.
To open the Raster Group Maintence tool, select the
the bottom of the Main Module's Raster Tab.

button on

Details Tab
The Details Tab displays and modifies group names and group description.

The Log Image Group Maintenance Details Tab

Image Group Name - This entry sets the selected image group name.
Image Group Description - This entry sets the image group description.
To add a new group name, enter the desired group name and description
- This button adds a new group image using the entries in the group name
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and description entry boxes.
- This button overwrites the currently selected image group's name and
description with the entries in the relevant boxes.
- This button erases the currently selected image group on the Log Image
Groups list. Petra's link to all the image and LIC files will be severed, but the actual
files themselves will not be erased.

Aliases Tab
The Aliases Tab establishes raster log group names. In practice, this option will
attempt to replace a missing group with one of the other "equivalent" raster group on
the alias list.
The fundamental problem with log data is the proliferation of log names created by
different commercial data vendors and individual users. The same general type of
raster log (such as gamma ray and resistivity curves) can have hundreds, if not
thousands, of different names in a single project.

The Log Image Group Maintenance Alias Tab

Rename Tab
This option renames all members of a selected group name to a new group name.
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The Log Image Group Maintenance Rename Tab

Misc & Tools Tab
The Misc & Tools Tab performs multiple maintenance tasks for the raster groups in
the Petra Project.

The Log Image Group Maintenance Misc & Tools Tab

Print Group List - This tool creates a simple list of all the raster group names in the
project.
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An example of the print group list

Misc Maintenance Tasks
Export Summary Report CSV File - This option creates a *.CSV file for every raster in
the project. This includes fields for UWI, TD, group name, top (depth1), base
(depth2), the directory containing the raster's LIC and TIF files, and a comment field.
This can be particularly useful for dealing with directory changes due to moving a
project or raster data. One great technique is opening the *.CSV file in a
spreadsheet, and sorting by comment to isolate which directories no longer work.

A Summary Report CSV File

Delete Groups With No Images - This option deletes groups with no associated
images. This can be useful when cleaning up a project.
Delete All Groups - This option deletes all groups from the project. More specifically,
this removes the references in the project database to the LIC and TIF files. The LIC
and TIF files are not erased, and can be reimported into a Petra project.
Delete Selected Groups - This option deletes groups selected on the "Log Image
Groups" list from the project. More specifically, this removes the references in the
project database to the LIC and TIF files. The LIC and TIF files are not erased, and
can be reimported into a Petra project.
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Resolve Image Paths - This option uses the search criteria established by
ImageSearch.TXT to permanently fix the project database. Note that this method will
attempt to find every missing LIC and TIF file in a project; depending on the number of
missing files and the specificity of the search criteria, this can take a very long time.
Clear MJ LogSleuth Flags - This option clears the MJ LogSleuth Flags in the project
database.
Add Missing Well Records To LIC - This option adds missing well header information
to LIC files.
Repair/Synchronize LIC File Groups Find/Replace LIC/TIF Path Prefixes - This tool performs a "find and replace” operation
on the LIC and TIF pathways in Petra's database. This is useful for changing the first
part of a path, or "prefix" when the folder containing the rasters has moved.

The Find/Replace LIC/TIF Path Prefixes will replace the anything with the prefix of “C:\geoplus1\Projects\SOONER
DATA CLASS\IMAGES” with "N:\Rasters\Sooner"

Delete Uncalibrated Rasters - This option removes group names without any depth
calibration points.
Change Blanks to Underscores in LIC and Image Names - This option converts any
blanks in the LIC and image filenames to underscores. As an example,
"49025103990000 Resistivity.TIF" would be renamed to
"49025103990000_Resistivity.TIF"
Resolve Duplicate LIC References Set MJ LogSleuth Flags - This option changes the MJ LogSleuth Flags in the project
database.
Delete Association if LIC/TIF Files Can Not Be Found - This option removes group
names from the project if the LIC and TIF files are missing.
Delete Pay Data From LIC Files - This option removes pay information from the final
line of LIC files.
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Export Image Counts CSV File - This option creates a *.CSV file that displays the well
count versus group name for the project. This can be useful for eliminating group
names with low well counts.
Convert File References to UNC Names - This option converts local file system
references to use universal naming convention. As an example, this tool converts file
names like H:\Images to reflect \\Server\Images
Create Report Showing Groups That might Be Merged Replace LIC/TIF Paths - The biggest difference is that, instead of replacing the first
part of the path or “prefix”, this tool replaces the only the specific path given. This
tool leaves subfolders alone, making it a much more specific tool.

The Find/Replace LIC/TIF Path will replace ONLY the path “C:\geoplus1\Projects\SOONER DATA CLASS\IMAGES” with
"N:\Rasters\Sooner"

Change LIC "HEADERTOP/BOT" References to "LOGHEADERTOP/BOT" - Old
projects sometimes store the scale section of the raster image as the header rather
than as a scale section. This option renames the section stored as the log header
Disassociate All MJ Rasters - This option removes all references to the MJ LogSleuth
raster logs.
Set Image Source for Selected Groups and Wells -

Copy Tab
The Copy Tab copies the image files from their original location to a specified path.
Does this change which file Petra points to?
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The Log Image Group Maintenance Copy Tab

Reorder Tab
The Reorder Tab sets the order of the log image groups.

The Log Image Group Maintenance Reorder Tab
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The Reorder Raster Groups Names tool

Available Raster Groups - This list shows every raster group in the project.
Reordered Raster Group - This list shows the reordered raster group names. Use
the < and > keys to add and subtract group names to the Reorded Raster Group list,
and the up and down arrow keys to change the order of a selected raster group.
- This button adds the selected group name from the Available Raster Groups list
to the Reordered Raster Group list.
- This button adds the all group names from the Available Raster Groups list to
the Reordered Raster Group list.
- This button removes the selected group name from the Reordered Raster Group
list.
- This button removes all group names from the Reordered Raster Group list.

- These buttons change the order of the selected group name on the Reordered
Raster Group list. Selecting the up arrow moves the selected group name higher,
while the down arrow moves the selected group name lower on the list.
- This option resorts the group names on the Available Raster Groups list in
alphabetical order.
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Translate Tab

The Log Image Group Maintenance Translate Tab

4.6.14.3 ImageSearch.TXT

ImageSearch.TXT is useful for resolving problems when images are spread over
multiple locations. ImageSearch.TXT file establishes a set of criteria where Petra will
automatically search additional paths if the images are not found in their original
locations.
Importantly, this method is only temporary. This method doesn’t make any
changes to the database, so it searches for the images and LIC files every redraw.
Consequently, this method can draw significant network resources and computer time,
and should only be used as a short-term fix. The Resolve Image Paths tool available
on the Log Image Group Maintenance Misc & Tools Tab uses the search criteria set
by IMAGESEARCH to permanently update the TIF and LIC pathways in the project
database.
The ImageSearch file itself contains a list of folder or drive names where the images
and/or calibration files are located. Note that Petra looks in the project’s IMAGES
directory first, before using ImageSearch.TXT, so it’s not necessary to add that folder
to the list. By default, Petra looks in every subfolder of the listed paths, but adding a
“-“ forces Petra to only look in the designated folder.
When setting up the pathways, be as specific as possible. Searching an entire drive
or server will search every subdirectory, which can take a very long time.
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An example of IMAGESEARCH.TXT

To perform the search in every project, place ImageSearch.TXT in the Petra program
folder.
Alternatively, to perform the search in a single project, place the file in the project's
images folder.
4.6.14.4 Pay Interval Data

Petra stores "Pay" intervals in the database. These are usually graphically picked off
raster logs. "Pay" intervals usually represent a productive interval, but can also be
used to simply highlight lithology or other intervals of interest.
button on the Main
To open the Pay Interval Data tool, select the
Module's Rasters Tab. Alternatively, select Logs>Pay Data Maintenance... on the
menu bar at the top of the Main Module.
Displaying Interval Data on the Cross Section Module
Using the Pay Data Toolbar to Pick Pay Intervals on a Cross Section

General Tab
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Name - This entry sets the pay's name.
Source -This entry sets the source code of the pay name.
Description - This entry sets the pay name's description.
Pattern - Though it's off by default, Petra can draw patterns inside pay intervals. The
left up/down button sets the pattern, while the slider bar to the right sets the density
of the pattern. To turn on pay interval patterns, select the "Plot Pay PATTERN
Symbols" option on the Pay Data Display Options tool's Options Tab.
Comments - This entry stores comments about the pay name. This is a good place to
store cutoffs used in creating the pay.

Data Tab

© 2014

Main Module

477

Top/Base - These entries set the top and base of a pay interval.
Data Units - This option sets the data units for the pay interval.
Shift - This option shifts the top and base of a selected pay interval up or down by a
specified footage.
View Data as - This option sets the

View Tab
The View Tab simply displays a graphical representation of the available pay intervals
for the well selected on the Main Module. Note that Petra adds the MD extents of the
view at the top and bottom of the rectangle.
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Zone Tab
The Zone Tab saves the footage of the selected pay interval to a zone data item.

Store Pay Total In Zone Item
Zone - This dropdown sets the desired zone. Note that this dropdown controls the
data items in the "Item" dropdown immediately below.
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Item - This dropdown sets the data item that will contain the stored pay totals. Note
that this will overwrite any stored data in the data item.
Source - This entry sets the source for the zone data item.
Apply TVD Correction - This option attempts to correct for the difference between MD
and TVD based on directional survey data.

Export Tab

Export Pay Intervals to the Following File - This entry sets the location of the pay file.
Include Pay Source in Export File - This option includes the pay source in the exported
file.

Maintenance Tab
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Delete Single Pay For Selected Wells - This button deletes the selected pay intervals
for the wells selected in the Main Module. This option keeps the pay names intact.
Delete ALL Pay For Selected Wells - This button deletes ALL pay intervals for the
wells selected in the Main Module. This option keeps the pay names intact.
Delete Single Pay Name for ALL Wells In DB - This button deletes the selected pay
name and all its intervals for ALL wells in the project database.
Delete All Pay Names For ALL Wells in DB - This button deletes ALL pay names for
ALL wells in the project database.

ReOrder Tab
By default, pay intervals will appear in the list in the order they are created in Petra.
This tab changes the order of pay to a user-selected order.
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- This button adds the selected pay interval to the Selected Item list.
- This button adds all pay intervals to the Selected Items list.
- This button removes the pay highlighted on the Selected Items List.
- This button removes all pay on the Selected Items List.

- These buttons change the order of the highlighted pay interval on the Selected
Zone Items list. Pay on the top of the list will appear first.
4.6.15 Other Tab
The Other Tab displays and modifies fault cuts, production symbols, well history, liner
and cement details, velocity data, and pay data.
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The Other Tab modifies additional information on the selected well

Fault Cuts - This button opens the Fault Cuts window.
Pd Sym - This button opens the Pd Sym tool.
Well History - This button opens the selected well's well history, which is a simple *.
TXT file. If the well doesn't currently have a well history file, Petra will prompt the
user to add one.
Liner Details -This button opens the Liner Details window.
Cement -This button opens the Cement Details window.
Velocity - This button opens the Depth-To-Time Functions window.
Pay Data - This button opens the Pay Interval Data window.
4.6.15.1 Production Symbols

Production Symbols are depth referenced well symbols stored in each well. These
well symbols can be plotted on cross sections on the depth track it indicate various
producing zones. Optionally, each well symbol can have a remark posted beside it
on the cross section.
To change the size of the production symbols, select the System Color and Style
Definitions tool with Display>Colors on the menu bar at the top of the Cross Section
Module. here, change the size of the "XSect Prod Symbols" option.
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To modify an existing production symbol, highlight the old production symbol, change
the information, and select the

button.

To add a new production symbol, enter the desired information and select the "+"
button.
To drop an existing production symbol, highlight the desired production symbol and
select the "-" button.
Depth - This entry sets the depth of the production symbol.
Depth Symbol - This dropdown sets the symbol that will appear on the well's depth
track.
Color -This option sets the color for the symbol.
Remark - This entry stores any additional remarks for the production symbol.

Posting Production Symbols On The Cross Section
In the Map Module, select Wells>Plot Test Indicators on the menu bar at the top of
the screen. Here, select the "Prod Symbols" option. The production symbols will be
plotted in the center of the depth track.
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The Select Test Indicators To Plot window with the "Prod Symbols" option selected (left), a production symbol added
to a well's depth track (right)

4.6.15.2 Liner Details

To modify an existing liner entry, highlight the old entry, change the information, and
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button.

To add a new liner entry, enter the desired information and select the "+" button.
To drop an existing liner entry, highlight the desired liner entry and select the "-"
button.
Top - This entry sets the top of the liner.
Base - This entry sets base of the liner.
Size - This entry sets the size of the liner.
Units - This entry sets the units of measurement.
Date - This sets the date of the liner.
Comment - This entry stores remarks or comments about the liner.
4.6.15.3 Cement Details

To modify an existing cement entry, highlight the old entry, change the information,
and select the

button.

To add a new cement entry, enter the desired information and select the "+" button.
To drop an existing cement entry, highlight the desired cement entry and select the "-"
button.
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Top - This entry sets the top of the cement.
Base - This entry sets base of the cement.
Date - This sets the date of the cement.
Comment - This entry stores remarks or comments about the cement.
4.6.15.4 Depth-To-Time Functions

Petra stores depth-to-time functions internally in the project database. This tool adds,
modifies, and deletes velocity functions in the project
To open the Depth-To-Time Functions tool, select the "Velocity" button on the Main
Module's Other Tab.

General Tab

Data Tab
The Data Tab shows the actual velocity function values for the selected function.
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Depth to Time Function - This dropdown selects the desired depth to time function
loaded into the project.
Velocity Function Datum Replacement Velocity Set As Active
Export CSV -

Preview Tab
The Preview tab displays a graph of the selected depth-to-time function.
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Depth to Time Function - This dropdown selects the desired depth to time function
loaded into the project.
Show Time vs. Depth Plot - by default, the graph shows interval velocity, RMS
velocity, and average velocity. This option instead displays a single time vs. depth
plot of the selected function.
Show X-Axis As - This option changes the horizontal axis to depth or time.
Set As Active - This button sets the currently selected velocity function as the "active"
function for the well.
Print - This option prints the plot on the screen.

Import Tab
The Import Tab imports new time-to-depth functions and overwrites existing functions
with revised data.
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Depth To Time Function - This dropdown selects the location of the loaded time-todepth function. Selecting an existing function will overwrite the function with the data
from the file by default, but the "Append to Current Function" option will instead
append new data to the end of the function in the project database. To add a new
function name, select the "Create New Name..." button.

Format
The Format Section tells Petra how to load the file correctly.
Columns - This dropdown sets the format of the imported file. Options include
"Depth, Time", "Time, Depth", "Velocity Databank LAS", and "PetraSeis 'ftn' file."
Depths - This option sets the depth units of the depths in the selected file.
Time - This option sets the time units of the times in the selected file. Petra can
import any combination of seconds/milliseconds and one-way/two-way.
Datum - This option sets the datum for the imported file.
Replacement Velocity - This option sets the replacement velocity for the imported
data.
Set as Active Depth to Time Function - This option sets the imported function as the
active function for the selected well.
Append to Current Function - By default, importing a depth-to-time function into an
existing function will overwrite the function with the data from the file. This option
instead appends new data to the end of the function in the project database

Extend Tab
The extend tab
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Copy Tab
The Copy Tab copies a Depth-To-Time function

Copy Depth to Time Function
This tool copies the active function to a set of wells. This can be significantly easier
than manually importing the Depth-To-Time function for multiple wells.
Copy and Make It the Active Depth to Time Function - This option copies the function
to the wells selected on the "Wells To Receive the Depth to Time Function", and
makes it the active function.
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Copy and Make It the Active Depth to Time Function IF No Active Function Is Set This option copies the function to the wells selected on the "Wells To Receive the
Depth to Time Function", and makes it the active function only if the well doesn't have
an active function.
Copy Depth to Time Function - This option copies the function to the wells selected on
the "Wells To Receive the Depth to Time Function", but does not change any of the
settings regarding the active function. Wells with an existing active function will retain
their active function. Wells without an active function will just have the copied function
in the database; it won't be set to the active function.
Make Function Active (do not copy) - This option doesn't actually copy the function
from one well to another. Instead, this function sets the selected function to be the
active function in wells where it is present in the database.

Wells To Receive the Depth to Time Function
All Selected Wells - This option will copy the function to all wells currently selected in
the Main Module.
Wells From WSN List Below - This option will only copy the function to the wells on a
WSN list. Select the "Browse" button, navigate to the desired *.WSN file, and select
OK.

Copy Function from Another Well to This Well
This tool just copies the function from another well. Simply enter the WSN of the well
to receive the currently active depth-to-time function, and select the "Apply Function
From Other Well."

Convert Tab
The Convert Tab just has a utility for converting depth and time using the currently
active function.
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To use this tool, simply enter the desired time or depth, and select the relevant "Time
To Depth" or "Depth To Time" button.
Seismic Datum - This option sets the seismic datum for the calculations.
Include Well Datum In Calculations - This option includes the well's active datum (set
on the Main Module's FmTops Tab) in the calculation. By default, this is on.
4.6.16 Scout Ticket Report
The Scout Tab displays and modifies information about the selected well on the well
list. Typing a value in the appropriate entry field will change that field.
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Figure 1: The Well Tab displays header and symbol information about the selected
well.

A scout ticket report is a well report showing selected data items for each well in the
project. Several options are available to filter what data actually gets included in the
report.

Options Tab
Include The Following Optional Data Groups - This section lists several check box
items each of which enables or disables a particular data group. For example, to
include formation tops in the report, click the "Formation Tops" check box so that it is
"checked". Use the ALL button to quickly check all items.
Choose Z Data... - This button invokes a screen for selecting a list of Z data items.
You may choose one or more zones and zone items to include in the scout ticket
report.
Suppress NULL Tops and Z Data Items - When this option is checked, only tops and z
data values which contain non-null values will be included in the report. If not checked,
then all tops and selected z data values will be listed. A blank field in the report
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indicates null values.
Print To File For Preview - Check this option to have the report written to a temporary
file and displayed using the system text editor. When this option is not checked, the
report will go directly to the printer.
Print With Small Font - Checking this option allows more lines per page.

Wells Tab
Wells To Report On - The report can be generated for all wells in the project or only
those wells which are currently selected in the main screen well list. Choose "All
Wells" or "Currently Selected Wells".
Sort Wells By - This option determines the sort order of the reported wells. Wells can
be listed by "UWI (API No.)", "Well Label", or "WSN".
Start Each Well On A New Page - This option applies when the report is sent directly
to the printer. Each well can start at the top of a new page. This option has no effect
when the report is printed to a file for previewing.
4.6.17 View Tab
The Well Tab displays and modifies information about the selected well on the well
list. Typing a value in the appropriate entry field will change that field.
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The Well Tab displays header and symbol information about the selected well.

4.6.18 Intervals Tab
Interval data stores data to a specific depth interval that doesn’t fit well with the
traditional zone concept, such as data that is too fine (such as core descriptions) or
too coarse (such as mud weights or biostratigraphic information) to fit inside two
formation tops.
Petra stores interval data in tables and fields similar to a spreadsheet. The “table”
stores related interval data in a spreadsheet, where each interval is stored as a
separated row. In the example below, the project has the default tables LITH, CORE,
and PALEO.
Inside the table, each interval is stored as its own row, and information about that
interval is stored in “fields”, or columns in that row. All tables come with a few fields,
TOP, BASE, DATE1, DATE2, QUALITY, and FMNAME, but you can add user-defined
fields containing numbers, dates, or text. In addition to the standard fields, the LITH
table in the example below contains the field “Desc” which stores lithologic
descriptions.
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Creating, Modifying and Deleting Tables
Creating, Modifying and Deleting Fields
Reordering Tables & Fields
Adding Interval Data
Changing Interval Attributes, Markers, and Patters
Find/Change Data...
Using Interval Filters
Storing Interval Thickness to an Interval
Gaps, Overlapping Interval Data, and Bulk Shifts
Calculations with Interval Data
Graphing Interval Data
Setting Default Tables and Fields

4.6.18.1 Creating, Modifying, and Deleting Tables

An interval data “table” stores interval data in a spreadsheet, where each interval is
stored as a separated row. Since every interval row in the table shares the same
fields (as columns), it’s a good idea to keep different types of data in different tables.
To create, modify, or delete tables in a Petra project, select the “Maintenance” button
on the bottom of the Interval Tab on the Main Module.
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- This option adds a new interval data table. Selecting this option brings up a
dialogue box to add the new table’s name and description. A newly created table
contains no new fields.
- This option edits just the name and description of an existing interval data table.
To edit the fields inside the interval, select the “Data Fields” option on the
Maintenance screen.
- This option deletes the entire interval data table, along with all the fields and data
contained within the table.
4.6.18.2 Creating, Modifying, and Deleting Fields

In an interval table, each interval is stored as its own row, and information about that
interval is stored in “fields”, or columns, in that row. To create, modify, or delete
fields in a Petra project, select the “Maintenance” button on the bottom of the Interval
Tab on the Main Module.
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- This option adds a new interval field to the selected interval data table. Selecting
this option brings up a dialogue box to add the new field’s name, description, and
attributes. The Kind dropdown box sets the kind of data the interval field stores: a
Real Field, Date Field, or String Field. Real Fields simply store numbers, such as
porosity or permeability. Dates store calendar days as MM/DD/YYYY. String values
store text like core descriptions. For Real fields, the Units box sets the displayed
units of measurement, while the Decimal Places for Display option sets the displayed
trailing decimals.

- This option modifies the name, description and attributes of the selected field.
- This option deletes the selected field.
4.6.18.3 Reordering Tables & Fields

By default, interval tables show up in the order they’re created. Especially in large
multi-discipline, multi-user projects with many different kinds of data, it’s often useful
© 2014

Main Module

499

for a user to reorder and filter the interval tables to only show relevant data. To
reorder the Interval tables, select the “Order...” button on the Interval Tab on the Main
Module. This brings up the “Filter Interval Data Table Names” box. Here, use the “>”
button to bring a single selected table from the Available Internal Table List on the left
to the Filtered Interval Table List on the right. The “>>” button brings over all available
tables. Once on the Filtered Interval Table List, use the up and down arrows to
change the order of the shown tables. Tables at the top of the list will be shown
before tables on the bottom of the list. To drop a selected table from the Filtered list,
select the “<” button, and to drop all tables from the filtered list, select the “<<”
button. If there are any tables on the Filtered Interval Table List, only those
tables will be shown.

Reordering and Hiding Fields
By default, interval fields show up in the order they are created. To reorder the
Interval fields, select the desired table and select the “Columns...” button on the
Interval Tab on the Main Module (highlighted on the left figure below). This brings up
the “Interval Data Column Display Properties” window. This screen shows the list of
the table’s available fields on the left, the displayed fields on the upper right, and the
selected field’s properties are shown in the lower right. This window changes the
order of the displayed fields, hide and show specific fields, and changes field
properties.
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Reorder the specific fields
To reorder a field, select the column at the top of the screen and drag it to the
desired position. In the example below, the “TOP” column has been dragged to be
before the “QUALITY” column.

Hide and show specific fields
To drop a specific field, select the column at the top of the screen and select the “-“
button. To add a specific field, select the field name from the list on the left side of
the window and select the “+” button.

Change the field properties
The “Column Properties” on the lower right shows name, justification, shown decimals,
the label style (Name or Name and Units), and the data property (Value or Quality).
Changing these settings changes how the selected field will be shown.

4.6.18.4 Adding Interval Data

New interval data can be brought into Petra either manually or by a tabular data
import.
Adding New Data Manually
To add new intervals manually, first select the correct well in the Main Module. On
the Interval Tab, select the right interval table. In the example below, the “LITH” table
is selected. Finally, select the “Edit details” button in the upper right on the Interval
Tab. This brings up the Edit Interval Data window for the selected interval table.
Continuing with the example, the Edit Interval Data window below shows the fields for
only the LITH table.
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button to add

With the interval now added, enter in the remaining interval details and select
button to save the changes to the interval. In the example below, the Quality,
Formation, and LITH Table specific fields are filled in.

To save the changes to the database, select OK. Here, Petra gives the option to
save or discard ALL changes made to the selected well’s interval table. All the edits
to all intervals will be ignored if you select CANCEL.
Importing Tabular Interval Data
Digital data where each row contains information about a discrete interval can be
easily imported into Petra. Before attempting to import interval data, check to see if
the data has a column dedicated to the UWI/API. Since Petra assigns interval data to
specific wells by comparing UW/API numbers, interval data without an identifying API/
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UWI column can’t be imported. The easiest way to remedy this is to simply open the
interval data in a spreadsheet program, and add a new column for well UWI/API.
To import new digital interval data, select Project>Import>Import Tabular Interval
Data… on the menu bar at the top of the Main Module. This opens the “Import
Interval Data from Tabular File Format” box. Here, select the “Open File” button and
navigate to the interval data’s location.

Once the file containing the interval data is opened, Petra switches to the Data
Format Tab. This tab essentially links the entries in the file to specific kinds of data.
The first step is to select the interval data file’s formatting under File Format. Files
can be imported into Petra in one of three formats: “Columnar”, “Comma Delimited”,
or “~ Delimited.” Columnar data organizes data into fixed columns, where Petra
imports data based purely on the number of characters from the left. The left
screenshot, on the other hand, shows the API number as defined by columns 1
through 14.
Comma and ~ delimited data, on the other hand have no fixed column size and are
instead separated by a comma or a tilde. With delimited data, Petra imports data
based on the “Field” defined by the delimiter. The example below shows the same
UWI/API field defined in two different ways. The right screenshot shows the API
number defined as “Field (1)”, i.e. it is separated by the first comma.
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Be careful when importing text as a comma delimited file. If the text has a comma in
it, Petra will read that as the end of the field. The interval data stored as UWI, Top,
Base, Description such as:
05123187700000, 6295, 6998, Calcareous, micaceous, clay-rich siltstone
Would only be imported as:
API: 05123187700000
Top: 6295
Base: 6998
Description: Calcareous
In other words, all the description past the first comma is cut off. This can also cause
bad imports when data is beyond the comma-filled text.
The next step is to establish field definitions. Essentially this step defines which part
of the file is which kind of interval data. The easiest way is to select and highlight the
specific data field in the “Data Record” part of the screen, then select the type of
interval data on the left. Petra can import fields for any interval table. In order to put
interval data with the correct well, the UWI or API # field must be defined.
When loading the TOP and BASE of the interval, Petra assumes that the depths are in
MD. To import other depths, such as SS or TVD, select the appropriate depth on the
“Field is not a Depth or is MD” dropdown when establishing a field definition.
For user-defined fields (Not the TOP, BASE, DATE1, DATE2, QUALITY, FM NAME,
UNITS fields), Petra can store a quality code. To import the quality code, select the
“Store Field Value” dropdown menu and set it to “Store Field Quality Code.”
To add the field definition, select the “+” button. The “-“ button drops the selected
field definition. To modify an existing field, make the appropriate changes and select
the

button.

The example below shows field definitions for the data file, which include the well API,
interval top, interval base, formation name, and description.
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To save the field definitions and options, select the “Save” button. This option saves a
*.FMI file. Selecting the "Load" button restores all the saved settings.
Most data files have some header or comments at the top. The “Records to Skip
Before 1st Well” option tells Petra to skip a set number of lines before importing any
well data. Click the "Set Skip" button to set the number of skipped records based on
the record currently in the data record window,
4.6.18.5 Changing Interval Attributes, Markers, and Patterns

Every interval stores a set of colors, markers, and patterns that can be displayed on
the cross-section module. It’s possible to change these settings for every interval
individually, or with multiple intervals at a time.

Setting a Single Interval’s Attributes, Markers, and Patterns
First, select the desired interval by clicking on the graphical representation of the
interval on the right side of the screen. The selected interval will be marked with a
black triangle on the right side of the interval (highlighted in the example below). Next,
select the Attributes Tab. Here, select the interval’s line and fill color. In the example
below, the first interval (a calcareous siltstone interbedded with sandstone) will be
drawn with a light blue fill. Notice that the selected color appears on the list of
intervals on the far left as well as on the graphical representation of the intervals on
the far right.
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Next, select the Markers Tab. Select the marker from the list of available markers,
set the style and color, and select the
button to post the marker symbol. In
the example below, the “X” signifies a lack of porosity from the core description.
Single - A single symbol is plotted
Tiled - Multiple symbols are plotted like wallpaper.
Column - Multiple symbols are stacked vertically in a column
Row - Multiple symbols are aligned horizontally in a row
Stretch X - A single symbol is plotted with its width stretched to fit the interval width
Stretch Y - A single symbol is plotted with its height stretched to fit the interval height
Stretch XY - A single symbol is plotted with its width and height stretched to fit the
interval rectangle
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Finally, select the Patterns Tab. This sets a wide variety of lithologic patterns. Select
one of the available patterns and a size from the list and select the
button. Note
that the “size” of the pattern governs the density of the pattern’s display. The
example below shows the interbedded sands and shales from the core description.

Setting Multiple Intervals’ Attributes, Markers, and Patterns in
a Single Well
First set a single interval to the desired attributes, markers, and patterns. Next,
select the
button on the “Defaults” section on the Attributes Tab (highlighted
below). This stores the current scheme of colors and patterns as a “default” attribute
so it can be used later on different intervals.

The next step is to select the multiple intervals that will have this default attribute
scheme. To select multiple intervals, select the “Set Tabs” button:
or hold down
the CTRL key. Next, select the desired intervals on the graphical representation of
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the intervals on the right side of the screen. Note that the selected or “tagged”
intervals have a small black triangle on the far right (highlighted in the example below).
In the example below, all the very fine grained sandstones have been tagged.
To tag all intervals in the well, select the
button.

button. To drop all tags, select the

Finally, select the
button on the Defaults section of the Attribute Tab. This
applies the current “Default” scheme of colors, markers, and patterns to all tagged
intervals.
The

button only applies the default scheme to the currently selected

interval, while the
well.

button applies the default scheme to all intervals in the

To add another “default” scheme, simply set a single interval to the desired colors,
markers, and patterns and select the the
button on the “Defaults” section on the
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Attributes Tab. In the example below, there are three default schemes based on
lithology: the blue interbedded siltstone/sandstone, the pale yellow very fine grained
sandstone, and the bright yellow fine grained sandstone.

Even after adding default schemes, it’s easy to go back and modify individual intervals
to display different information. In the previous example, three different default
schemes reflected lithology and grainsize from core descriptions. To carry this
example one step further, markers can also be added to signify porosity. Recall that
for the sandstone/siltstone, an X marked low porosity. To add markers for an
individual interval, select the interval and go to the Markers Tab. Select the marker
and the marker’s color, and select the
button. In the example below, red stars
have been added for all intervals with porosity above 10%, and a black X for all
intervals with porosity below 10%.

To save the changes to the database, select OK. Here, Petra gives the option to
save or discard ALL changes made to the selected well’s interval table. All the edits
to all intervals will be ignored if you select CANCEL.

Setting Multiple Intervals’ Attributes, Markers, and Patterns in
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Multiple Wells
The previous methods change the display of intervals for one well at a time. This can
work well for a small number of intervals in a few wells. Even a modest Petra project
can contain a large amount of intervals spread out over many wells; changing intervals
one well at a time would be very tedious and time-consuming.
Petra’s Find and Replace Interval Data can apply one of the “Default” attribute color
and pattern schemes to all intervals in the selected wells that meet a set of search
criteria. For more information see the Find/Change Data section.
4.6.18.6 Find/Change Data...

The Find and Change Data function searches intervals by data criteria and either
changes the intervals’ color and pattern fills, or changes field data entries.
To perform a search on interval data, select the “Maintenance” button on the bottom
of the Interval Tab on the Main Module. Next, under the Data tab (highlighted in blue)
select the “Find/Change Data…”

Setting Basic Interval Search Criteria
Select the interval data table to search under the TABLE dropdown. Next, select the
interval field that will be searched under the FIND DATA IN dropdown menu. On the
WHERE dropdown, select the style of the search. Petra can search inside data fields
in a few different ways; select the condition (such as Data is Equal to value) and the
appropriate value, range, or text string to find. The example below shows a search
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for intervals containing the phrase “very fine grain.”

Limiting the Interval Search to a Zone
This search can be further limited by zones on the Options Tab. Since a zone can be
defined by a set of formation tops or depths, this can be a powerful way of limiting the
search to intervals that have footage inside a specific stratigraphic interval. In the
example below, only intervals intersecting the DSAND zone will be used.

Using a Filter in the Interval Search
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With a Find and Replace operation, filters provide a finer control over which intervals
are changed. Intervals that do not meet the filter criteria are not changed. To create
or modify a set of filters, select the “Set Filters…” button on the Options tab.
Filter criteria are shared between different functions, making it easier to use the
same subset of interval data for different applications. Deselecting this box in any
part of Petra does not erase the filter criteria; it simply inactivates the filters. For
more information on filters see the “Using Filters” section of this document.

Setting the Color and Patterns for the Interval Search
Using the Find and Replace Data method to change color and patterns applies a
“default” attribute scheme to intervals meeting search criteria. This method’s key
advantage is that it can be applied to multiple wells in a project. As a reminder, a
“default” attribute is created in the Edit Interval Data window. For more information
on creating a default attribute scheme, see the above section on “Setting Multiple
Intervals’ Attributes, Markers, and Patterns in a Single Well.”
Once the search criteria are set, select “Set Interval Attributes.” This tells Petra to
change the color and pattern attributes of the intervals that meet the search. On the
CHANGE INTERVAL ATTRIBUTES TO dropdown menu, select the appropriate
default attribute scheme. The example below shows that the lithologic description
field “Desc” in the LITH table will be searched. Recall that in earlier examples, very
fine grained sandstones were given a pale yellow color fill with a sandstone lithologic
pattern. In the search shown below, intervals containing the phrase “very fine grain” in
the lithologic description will be given this same color and fill pattern.

Setting the Data Change for the Interval Search
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Using the Find and Change Data function changes field data entries in intervals
meeting search criteria. This method changes a selected field value for every interval
meeting search criteria. This method’s key advantage is that it can be applied to
multiple wells a project.
Once the search criteria is set, select “Change Data Values.” This tells Petra to
change a specific field on the intervals that meet the search. On the CHANGE DATA
IN dropdown menu, select the appropriate field and data value. The example below
shows that the lithologic description field “Desc” in the LITH table will be searched. In
the search shown below, intervals containing the phrase “very fine grain” will have
their Qual field changed to “B.”

4.6.18.7 Using Interval Filters

Filters limit the intervals used in a particular process. Filters give more control over
which intervals are displayed on map and cross sections, which intervals are used in
calculations to create zone and log curves, and which intervals are used in Find/
Replace operations.

In all these cases, filters add an additional set of search criteria. Intervals that do not
meet the filter criteria are not used for that particular task. For example, intervals that
don’t pass the filter criteria in the Map Module are not plotted on the map. Filter
criteria are shared between different functions, making it easier to use the same
subset of interval data for different applications. Unchecking this box in any part of
Petra does not erase the filter criteria; it simply inactivates the filters. To create a
new set of filters, select the “Set Filters…” button. The examples below show the
“Set Filters…” for displaying intervals in the Map Module and for calculations in the
Main Module.
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The Interval Data Selection filters can be divided into two parts. The upper half of the
screen builds and modifies filters, while the lower half shows the active filters and the
“pass” relationship between different filters.
To create a new filter, select the table and field for the filter from appropriate
dropdown menus. The example below filters intervals in the LITH table by data in the
DESC data field.
Next, select the filter’s “Search Type.” With one exception (“Interval Thickness In
Range”) the search type tells Petra what the filter should look for inside a field:

Not Equal to Value
Equal to NULL
Not Equal to NULL
Value in Range
Field Contains String
“Interval Thickness in Range” eliminates intervals that are thicker or thinner than a
given range. Finally, select the “Add” button to add the filter to the “Current Filters”
list at the bottom of the box. In the example below, the filter is set to include only
intervals that contain the words, “very fine grain”
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Up to 10 filters can be active at once. There are two options for how to combine
multiple filters: “Pass Filter when ANY conditions are met” and “Pass Filter when ALL
conditions are met.” The choice of these two options can have a significant influence
on which intervals are plotted on the cross-section. For more on combining multiple
filters, see Appendix 2.
Pass Filter when ANY conditions are met – this will pass any interval where at least
one of the conditions is met. This is the more permissive option, since only one of the
filter criteria needs to be met to pass.
Pass Filter when ALL conditions are met – this will pass any interval only when all
conditions are met. This is the more restrictive option, since all filter criteria need to
be met to pass.
4.6.18.8 Storing Interval Thickness to an Interval Field

This operation stores each interval’s thickness to a specified field in that interval.
Select the “Maintenance” button on the bottom of the Interval Tab on the Main
Module. On the Table tab, select the interval field that will store the interval thickness.
In the example below on the left, the “Recov” field on the CORE table is selected.
Next, under the Data tab (highlighted in blue on the example to the right) select “Store
Interval Thickness” (highlighted in red).
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The example below shows that the sidewall core thicknesses (in this case given a
thicker interval) all store thicknesses of 2 feet in the “Recov” field.

4.6.18.9 Gaps, Overlapping Interval Data, and Bulk Shifts

Interval data is often at the wrong depths, or contains overlapping intervals or gaps.
Though interval data is designed precisely to handle this incomplete and contradictory
data, it’s often useful to convert interval data into one continuous chain for display or
calculations. Interval data can also become out of sync with other well data; moving
interval data up or down with a bulk shift easily remedies the discrepancy.

To perform these operations on a single well, select the “Edit Details” button on the
upper right corner of the Interval Tab on the Main Module. Next, Edit dropdown on
the menu bar at the top of the window, select “Make Intervals Continuous” button or
“Resolve Internal Overlaps”, or “Bulk Shift.”
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Make Intervals Continuous
This option eliminates overlaps where two different intervals cover the same footage.
With this option, Petra moves the base of the upper interval to match the top of the
lower interval, as shown in the example below.

Resolve Internal Overlaps
This option eliminates gaps between intervals. With this option, Petra moves the base
of the upper interval to match the top of the lower interval to cover the gap, as shown
in the example below.

Bulk Shift
This option adds or subtracts a specific number to all interval depths. A negative
number moves all intervals up, while a positive number moves all intervals down.
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4.6.18.10 Calculations with Interval Data

Petra can perform basic calculations on interval data columns, zone data items, or
constants. This operation is performed on all intervals in selected interval table in
either the current well or for all wells selected in the Main Module. To calculate a new
interval data column from another, select the appropriate interval table on the
appropriate well, then select the “Calculate Column…” on the Interval Tab
First, establish where the output will be stored. Petra can store data to a new or
preexisting column in the selected data table. To store data to a new column, select
“Create New Column” and enter in the new column’s name. To use a column that’s
already in the data table, select “Use Existing Column”, and select the column from
the underlying dropdown menu. Be careful when using an existing column, as this
operation can overwrite any data already entered.
Next, enter an equation using variables and mathematical operators. For a list of
available operators and sample equations, see appendix 3. The variable on the left
side of the equal sign is the result variable. Note that the variables here are just text
and will be assigned later, so they can be either specific (“porosity”) or general (“A”).
Note that equations can be saved and loaded again at a later date with the “Save”
and “Load” buttons on the right side of the screen. In the example below, porosity
data is being used to calculate a permeability value.
Now that the equation is entered, select “Assign Vars.” This populates the Variable
List in the bottom left corner of the window with the variables written in the equation.
Select a variable from the Variable List, and select a column, zone data item, or
constant from the relevant dropdown menus on the right. Select the “Assign” button.
This will change the entry in the Variable List box to reflect the correct variable.
The Options Tab has a few more controls over the calculation. The calculation can be
performed on only the currently selected well in the Main Module, or on all wells
selected in the main module. Petra stores a null value whenever there’s a missing
variable in the calculation, but the “Save ZERO value to Database” can overwrite this
null value with a zero. By default, Petra overwrites all interval data fields during the
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calculation. Deselecting the “Overwrite Existing Database Values with Calculation
Result” forces Petra to leave existing database numbers alone, limiting the calculation
to only filling in null values. To perform the calculation, select the OK button.

4.6.18.11 Graphing Interval Data

Petra can plot any numerical interval “real value” versus depth or another real value.
This can be particularly useful for quickly seeing how a quantity such as mud weight
changes with depth, or understanding the relationship between two different kinds of
data like porosity and permeability.
To view an interval graph, first select the correct well in the Main Module. On the
Interval Tab, select the right interval table. In the example below, the “CORE” table is
selected. Finally, select the “Edit details” button in the upper right on the Interval Tab.

On the Graph Tab, select “Depth vs Z” or “X vs Z” on the first dropdown menu.
“Depth vs Z” shows the selected values for the interval fields selected on the Z1, Z2,
and Z3 dropdown menus on the vertical axis relative to depth on the horizontal axis.
© 2014

Main Module

519

The example below shows how porosity varies with depth.

“X vs Y” shows a scatter plot for the two interval fields selected on the X and Y
dropdown menus. The X value is plotted on the horizontal axis, and the Y value is
plotted on the vertical axis. The example below shows how permeability varies with
porosity

4.6.18.12 Setting Default Tables and Fields

Changing these default interval tables can be useful from an administrative
perspective. Changing these tables ensures that all new projects will be created with
the same interval tables and fields, though these can always be changed inside Petra.
When creating a new project, Petra looks at a file called INTDATA.DEF located in the
program’s Parms directory. On most standalone installations, this will be located in C:
\geoplus1\Parms. This file contains the default tables and fields that will be created in
a new project.
It’s important to not edit the default interval table file (INTDATA.DEF). Instead, copy
the INTDATA.DEF file to a new file called INTDATA.USR. Make all new changes to
the new file called INTDATA.USR. Petra first looks for INTDATA.USR before it looks
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for INTDATA.DEF.
The default version of this file contains three tables: LITH, CORE, and PALEO.

Table: LITH - Lithology
Field: Desc - Description

Table: CORE - Core Interval Data
Field: Poros - Core Porosity
Field: Perm - Core Permeability
Field: Recov - Amt of Core Recovered

Table: PALEO - Paleo Data
Field: FmName - Formation Name
Field: Bug - Fossil Name
Field: Age - Age of Zone
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Petra reads the INTDATA file and builds interval data based on comma-delimitated
values.

TABLE, TABLE NAME, “Table Description”
FIELD, KIND, NAME, SRC, “Field Description”, UNITS, DECIMALS

TABLE – This signifies that the entry is for a new table.
Table Name – This is the name of the table. It’s a good idea to separate tables
based on genetically related data, such as mudlogs, core descriptions. Remember
that tables, unlike zones, are completely independent of stratigraphy, so it is probably
easier to lump all related data together rather than break out intervals based on
specific formations.
“Table Description” - This sets a brief description of the Table. In the example, the
“LITH” field’s description is “Lithology Data.” Remember to put quotation marks
around the description.
FIELD – This just signifies that the entry is for a new field. Make sure all new field
entries are prefaced by “FIELD.”
Kind – Fields can store three kinds of data: Real Values, Date Values, or String
Values. The letter here tells Petra what kind of data this field will store – “R” for Real
values, “D” for Date values, and “S” for String values. Real values simply store
numbers, such as porosity or permeability. Dates store calendar days as MM/DD/
YYYY. String values store text, like core descriptions.
Name – This is the name of the field.
SRC – This sets the user source for the specific field. User sources are useful for
distinguishing between different user’s interval data in a multiuser environment.
“Field Description” – This sets a brief description of the field. In the example, the
“Recov” field’s description is “amt of core recovered.” Remember to put quotation
marks around the description.
UNITS – This sets the units of the field.
DECIMALS – This sets the number of decimals shown for real value (numerical) data.
Though it’s a good idea to set this value to 0 for string and date fields, it’s not
necessary

4.7

Selecting Wells
It's often useful to trim the wells selected in a project module only to a relevant
subset of wells. To change the wells in any given module, select Wells>Select on
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the menu bar at the top of the module.
Prospect Mode might be useful if you're regularly working with a smaller subset of
wells in a larger project.
All Wells - (CTRL + A) This option selects all wells in the project. While Petra is in
Prospect Mode, selecting "all wells" will only select all the wells in the prospect
rather than all wells in the entire project.
Current Well Only - (CTRL + W) This option selects only the currently highlighted well
in the project.
By Data Criteria - This option opens the Select Wells By Data Criteria tool. This is
an incredibly useful tool for nested and complicated searches based on well
attributes or database information.
Wells From a WSN List - This option selects wells based on a pre-existing WSN list.
For more information on creating WSN lists, see here.
From a List of Well names - This option opens the Well List Selection tool. This tool
selects wells from a sortable well spreadsheet of wells' UWI, WSN, Label, and
names.
Primary Completions Only - This option selects only wells with "0000" at the end of
the UWI.
Map Selected Wells - This option selects the wells currently selected on the Map
Module.
Cross Section Wells -This option selects the wells currently selected on the Cross
Section Module.
Log Cross Plot Well - This option selects the wells currently selected on the Log
Cross Plot Module.
PetraSeis Wells - This option selects the wells currently selected in PetraSeis.
Synchronize Modules to Main - This option forces all open Modules (except the
Cross Section Module) to use the wells selected on the Main Module.
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Prospects

Prospects are a subset of wells from a larger project database. When working in
the prospect mode only wells inside the prospect are visible; Petra ignores all other
wells in the original project. Selecting "all wells" in prospect mode will only
select the wells that are in the prospect.
Prospect mode only acts as a filter on the visible wells - there still is only one copy of
the well data. Any changes made to a prospect will be reflected in the original
project and any other prospect containing the modified wells. Adding or deleting a
well to the database while in the prospect mode will also add/delete the well in the
prospect. Likewise, be careful about changing the map projection while in prospect
mode. Map projections are global to the original project database. Changing the
projection could interfere with other people's prospects made from the same project.
Petra's prospect files (*.PRO) are simple text files that contain the prospect
description, aerial extent, update timestamp, and a list of the wells in the prospect.
Note that prospects keep track of wells with well serial numbers (WSN), which just
reflects the order a well was loaded into the project. Since a well's WSN is specific
to a project, it won't necessarily reflect the same well in two different projects. If
you wish to give someone a list of wells in a prospect, save a UWI list instead.

A *.PRO prospect file with the prospect's description, extents (in the SW and NE corner), update timestamp, and
WSNs

When a prospect mode is active, Petra will display the prospect description on the
Petra window header.

The Petra window header in Project Mode (left) and in Prospect Mode (right)

Main Module
All the Main Module's prospect tools are available on Project>Prospect>... on the
menu bar at the top of the screen.
© 2014

524

PETRA Help

Save Prospect Well List... - This option saves the wells currently selected wells
listed in the Main Module. Next, select file name and location and then a prospect
file description. Note that saving a prospect can directly put Petra into Prospect
mode.
Load Prospect Well List... - This option enables prospect mode with the wells
contained within a selected *.PRO file.
Exit Prospect Mode and Use Project Mode... - This option exits prospect mode, and
return to the default project mode where all wells are available. Note that this will
either select all wells in the project, or continue to use the wells selected in the
prospect.

Exiting prospect mode in the Main Module

Map Module
All the Map Module's prospect tools are available on Wells> on the menu bar at the
top of the screen.
Create New Prospect>From Current Limits - This option saves the wells inside the
current map data limits. Petra will draw a red rectangle to show the exact extent of
the data limits. Next, select file name and location and then a prospect file
description. Note that saving a prospect can directly put Petra into Prospect mode.
Create New Prospect>Prospect from User-Drawn Rectangular Area - This option
selects wells based on a user-drawn rectangle.
Open Prospect - This option enables prospect mode with the wells contained within
a selected *.PRO file.
Close Prospect Mode - This option exits prospect mode and uses the previously
selected wells.
Close Prospect Mode - This option exits prospect mode and uses all wells in the
project.
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Prospect AOI>Show Prospect AOI Limits - This option displays the prospect extents
as a red rectangle on the Map Module. Selecting this option toggles this rectangle
on and off.
Prospect AOI>Search for Wells in Prospect AOI - This option searches the
prospect's aerial extents. This option can be useful for
Search Entire Project for Wells in AOI - This option finds all wells in the project
inside the prospect's aerial extents. Since this method will search all wells in the
entire project, this tool can be useful for updating a prospect after importing wells,
drilling new wells, or otherwise changing the data in the project.
Search Current Prospect Wells for Wells in AOI - This option searches for wells
inside the prospect's aerial extents. This search will only include wells that are
currently included in the prospect.
Do Not Change Prospect Well List - This option only performs the search.
Prospect AOI>Modify Prospect AOI - This option changes the extents of the
prospect's AOI, and gives the user a chance to update the prospect with the wells
inside the new borders.
Search Entire Project for Wells in AOI - This option finds all wells in the project
inside the prospect's aerial extents. Since this method will search all wells in the
entire project, this tool can be useful for updating a prospect after importing wells,
drilling new wells, or otherwise changing the data in the project.
Search Current Prospect Wells for Wells in AOI - This option searches for wells
inside the prospect's aerial extents. This search will only include wells that are
currently included in the prospect. This can be useful for shrinking a prospect,
Do Not Change Prospect Well List - This option only performs the search.

Search AOI options for both the "Search for Wells in Prospect AOI" and "Modify Prospect AOI" tools
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Select Wells By Data Criteria

The Select Wells By Data Criteria tool is a powerful way to concentrate on a group
of wells based on a variety of selection criteria.
To search for wells meeting a specific data criteria, select the item from the list box
and click the Search... button or simply double-click the listed item. Depending on the
search criteria, you may be presented with another dialog box to specify the detailed
search criteria.
Search - This option checks the well list against the selected search criteria.
Accept - This option selects the well list for the relevant application. As an example,
the accept button can deliver the selected wells to the Map Module.
Cancel - This option cancels the well search and returns to the relevant application.
Help - This option opens the Help Menu.

Selecting wells based on data criteria

Combining Multiple Criteria
The "Combine Using" option combines multiple search criteria to create more
sophisticated search lists.
AND - This option requires all criteria to be satisfied in order to pass.
OR - This option requires only one criteria to be satisfied in order to pass.
NOT - This option requires that the well pass the first criteria, but fail any additional
criteria.
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To better illustrate nesting multiple searches, we'll apply the criteria “Object is
yellow” and “Object is smaller than a breadbox” to three objects: a banana, an apple,
and a schoolbus.
"Object is yellow" AND “Object is smaller than a breadbox” - Only the banana is both
yellow and small, so it fulfills the criteria.
"Object is yellow" OR “Object is smaller than a breadbox” - All three objects fit the
criteria. The schoolbus is yellow, the apple is small, and the banana is both yellow
and small.
"Object is yellow" NOT “Object is smaller than a breadbox” - Only the schoolbus fits
the criteria. Both the banana and the schoolbus are yellow, but the NOT excludes
the small banana.

Search Criteria
Global
All Wells In Database - This option merely reverts the selected wells back to all wells
in the project.
Original Well List - This option reverts the selected wells back to the list of wells
which were selected when the Search option was initiated.
WSN List File - This option selects wells inside a previously saved WSN (*.WSN) file.
UWI List File - This option selects wells inside a previously saved UWI (*.UWI) file.
Well List - This option brings up a list of the currently selected wells. This list can be
sorted by UWI, WSN, Well Label, or Well Short Name.
WSN Range - This option selects wells based on a range of WSN numbers. Since
Petra assigns WSN numbers based on import order, this can be useful for selecting
wells imported at a specific time.
Locked Data Fields - This option selects wells based on locked data fields in one or
more parts of the data base.
Pseudo Wells - This option selects wells marked as "Pseudo" wells
Invert Selection List - This option changes the well selection list by selecting all wells
which are not selected. For example, if 10 out of 100 wells meet particular selection
criteria, then inverting the list would select the other 90 wells that did not meet the
criteria.

Well Header
Well Identifiers - This option searches one or more well header fields, such as, UWI,
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Well Name, Operator, etc. The search can look for fields containing a string, and
exact match, or mask specifier. For much more detail on this tool see "Select Wells
By Well Identifiers."
Multiple Completions - This option works with multiple completions, which are usually
stored in Petra's database as additional wells with an appended number on the 1314th digit of the API number. The "All completions for the Current Well Set" adds
well completions for the currently active set of wells. The "Only Wells Containing
Multiple Completions" selects only wells with multiple completions - singe well
completions are ignored.
Operator - This option selects wells based on a list of unique operator names.
Well Name - This option selects wells based on a list of unique well names.
Lease Name - This option selects wells based on a list of unique lease names.
Field Name - This option selects wells based on a list of unique field names.
Symbol Code - This option selects wells with one or more well symbol codes.
Date Data Was Changed - This option finds wells that had data changed within a
range of dates. This can include well header data, locations, formation tops, zone
data, or digital log data. This tool can be useful for isolating wells with a particular
vintage of data, or for repairing bad imports.

Datum
By Active Datum - This option finds wells with the active datum (either KB, GR, DF,
or SEIS) between a minimum and maximum depth.
With No Active Datum - This option finds wells with no active datum. Since the active
datum is used in calculating SS and SSTVD depths, this can be very useful for
troubleshooting data in a project.

TD - This option searches wells with a total depth within a given range.
FM at TD - This option selects wells based on a list of formations in the "Fm at TD"
entry. Note that this entry is set on the Main Module's Well Tab.

Well History Present - This option selects wells that have a well history
loaded into the database. Note that a well's history is set on the Main
Module's Other Tab.

Geology
Any Tops - This option selects wells that have any loaded formation tops.
Tops Data - This option finds wells by the presence or absence of formation tops
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and quality codes. For more detail on this tool, see Select Wells by Tops.
By Top Source - This option finds wells with formation tops with a specific source
code.
Any Fault Cuts - This option selects all wells containing any fault cut records.
Any Raster Pay - This option selects all wells containing any pay intervals.
Formation penetrated at TD - This option selects wells based on the "FM at TD" field
on the Well Tab.
Velocity Data - This option selects wells by the presence or absence of an assigned
velocity function.
Unassigned Tops/Correlations - This option selects wells with unassigned tops or
unassigned correlations.
Interval Data - This option searches wells that have interval data inside a zone. Note
that the zone's Interval Definition must be set.

Zones
Zone or Tops Data - This option selects wells by tops or data items criteria. For
more information on this tool, see Select Wells By Zone or Tops Data.
Zone Text Item - This option selects with specific text string in a data item's remark
field or quality code. For more information on this tool, see Select Wells By Zone
Text Item.
Any Tests in a Zone - This option searches wells that have test data inside a zone.
Note that the zone's Interval Definition must be set. For more information on this
tool, see Select Wells With Tests In A Zone.
Interval Data - This option searches wells that have interval data inside a zone. Note
that the zone's Interval Definition must be set.

Production
Any Monthly Production - This option selects wells that contain any monthly
production data.
NO Monthly Production- This option selects wells that contain NO monthly production
data.
Producing Fm Name - This option selects wells based on a list of unique formations.
Wells with with the selected formation in the "Prod. FM" field on the Well Tab will be
selected.
Production Stream Names - This option selects wells that contain one or more
production streams.
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Pd Cum Data - This option selects wells that contain one or more production
cumulative data based on formation name, or with values inside a zone's interval
definition
Any Perfs - This option selects wells containing any perfs.
Any Shows Data - This option selects wells containing any show records.

Tests
Any Perfs - This option selects wells containing any perforation records
Any Production Tests (IP) - This option selects wells with an IP or other production
test.
Any Formation Tests (DST) - This option selects wells with any formation tests.
Any Tests in a Zone - This option selects wells with IP test, DSTs, perfs, cores, etc.
in a selected zone. Note that the zone's Interval Definition must be set.
Prod Tests by Fm Name - This option selects wells based on the loaded production
test formation names. These names are set on the "FmName" field on the Main
Module's Fm TestsTab..
Fm Tests by Fm Name - This option selects wells based on the loaded IP test
formation names. These names are set on the "FmName" field on the Main Module's
IP Tests tab.

Mechanical
Any Perfs - This option selects wells containing any perforation records.
Any Casing Data - This option selects wells with any casing records.
Any Cored Intervals - This option selects wells containing any cored interval records.
Any Shows Data - This option selects wells containing any shows.
Casing, Liner and Cement - This option selects wells based on size, depth, and
dates of casing, cement, and liner data.

Locations
Lat-Lon or XY Limits - This option selects wells inside a Lat-Lon or XY box.
Sec-Twn-Rge Limits - This option selects wells inside a box set by sections.
Wells with Directional Survey - This option selects wells containing directional
surveys.
Any Horizontal Wells- This option selects wells with the "Horizontal Well" switched
on the Directional Survey Data window's General Tab.
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Distance Btwn Surface and BH Loc - This option selects wells based on the distance
between the surface and bottom hole location established on the Main Module's
Location Tab. This tool selects wells with a distance greater than or equal to a userselected value.
Wells within a Radius - This option selects wells within a user-selected radius from
the currently selected wells.
Wells with BH Spot Location Data - Ths option selects wells with a bottom hole
location set on the Main Module's Location Tab.
Wells in Offshore Block (Surface) - This option selects wells with a surface location
set inside a specific area/block. This information is set in the Offshore Location
Information window available from the Main Module's Location Tab.
Wells in Offshore Block (Btm Hole) - This option selects wells with a bottom hole
location set inside a specific area/block. This information is set in the Offshore
Location Information window available from the Main Module's Location Tab.

Logs
Digital Logs
Log Curves - This option searches for wells containing one or more selected log
curves. For more information on this tool, see Select Wells By Logs.

Raster Logs
Calibrated Rasters - This option selects wells based on the calibrated raster logs in
the database. For more information on this tool, see Select Wells with Raster Log
Images
Any Raster Pay - This option selects wells with any raster log group names.

Interval Data
Intervals in a Zone - This option searches for wells that have intervals inside top and
base set by the the selected zone's interval definition. Note that the zone's Interval
Definition must be set.
4.7.2.1

Select Wells By Well Identifiers

This well selection criteria searches the well header data fields for matches on one
or more text strings. Matches may be based on an exact match of the well data and
the search string or on a partial match with the well data. Also, the search string can
represent a mask containing the wild card characters "*" and "?" similar to the way
DOS uses masks.
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Data Tab
This section defines the well data fields to search, each corresponding search string,
and search condition. Enter the search string for each well data item to be searched
and select the appropriate corresponding search condition.

The Search By Well Identifier Data Tab

Data Field List
Place a check beside each well data field to search on. The following fields may be
searched:
UWI (API#)
Well Name
Well Number
Well Label
Operator
Historical Operator
Lease Name
Lease Number
Field Name
Prod Fm
Remarks
County
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State
Well Date

Text String To Search For
Enter the string, substring or mask to search for next to each data field to be
searched.
The following are examples of mask wild cards:
Mask
*

Matching Results
All text

A*

All text beginning with the letter A

*-1

All text ending with -1, e.g., A-1, C-1

*ABC*
A??
ABC??XYZ

All text containing the letters ABC
All 3 letter text beginning with A
Text fields such as, ABCDEXYZ, ABC88XYZ

Search Conditions
Is Equal To - Well is selected when the well data field must match the search string
exactly.
Is Not Equal To - Well is selected when the well data field must not match the search
string exactly.
Contains - Well is selected when the well data field contains the search "substring".
Does Not Contains - Well is selected when the well data field does not contain the
search "substring".
Matches Mask - Well is selected when the well data field matches the mask wild
card pattern.
Does Not Match Mask - Well is selected when the well data field does not match the
mask wild card pattern.
String Length - Well is selected when the well data field item length is equal to (=),
greater than (>), or less than (<) a particular value. The length is specified in the
"Text String to Search For" field. The length can be preceded by a condition code (=,
>,<) to indicate length condition to match. For example, to find all wells with API
number less than 14 characters, enter "<14" in the search text field. (do not type the
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quotes ). If no condition code precedes the length, then "equal to" is assumed.

Options Tab
The Options Tab sets how Petra handles multiple well identifier criteria in the search.
Note that the "combine conditions" option here only applies to the well identifier
search, and not to the broader "Select Wells By Data Criteria" search.

The Search By Well Identifier Options Tab

AND - This option requires all criteria to be satisfied in order to pass.
OR - This option requires only one criteria to be satisfied in order to pass.

To better illustrate nesting multiple searches, we'll apply the criteria “Object is
yellow” and “Object is smaller than a breadbox” to three objects: a banana, an apple,
and a schoolbus.
"Object is yellow" AND “Object is smaller than a breadbox” - Only the banana is both
yellow and small, so it fulfills the criteria.
"Object is yellow" OR “Object is smaller than a breadbox” - All three objects fit the
criteria. The schoolbus is yellow, the apple is small, and the banana is both yellow
and small.
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Select Wells By Formation Penetration

This function looks at the Formation at TD "well header" data field (FM@TD) and
compares it with an ordered list of formation names. Formation names can come
from the FMTOPS table or from an external "strat table" file.

Selection is performed by finding a match of each well's FM@TD value with the
formation list. If the FM@TD is in the list and it is equal to or follows after the
specified formation name in the ordered list, then the well is considered to
"penetrate" the specified formation.

Select Wells Which Penetrate the ... - Select the formation name for which a well
must penetrate to be selected. The formation drop down list is loaded with names
based on the "Stratigraphy Is Defined By" option (see below).

Stratigraphy Is Defined By
This option determines the ordered list of formation names and therefore the
stratigraphic sequence or formations.
The Project's Formation Tops - This option uses the the formation list from the
formation tops display order. The order is set with the Select Display Order for
Data Items tool.
"STRAT" Table Data File - This option uses an external file of formation names. The
file or "strat table" must contain the formation names as one name per record and
organized from shallowest to deepest, i.e., the first record is the shallowest
formation. Use the "Browse" button to select the strat table file. The file can be
viewed or modified using the "Modify Strat Table" button. Use the "Reload" button to
reload the table after any modifications. To create a strat table file from a Petra
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project, see the "Order Using External File (STRAT TABLE)" section of the Select
Display Order for Data Items help document.

4.7.2.3

Select Wells By Zone or Tops Data

This function selects wells by data item criteria. As an example, this tool can search
for wells with TD greater than 8000, cumulative gas 100,000 mcf or greater, and a
completion date in the range of 1/1/90 to 12/31/99.

Z Data Tab

Selection Mode
Select Wells when ANY Criteria Is Found - This option returns wells with at least
one of the zone data items tests falls within the minimum and maximum. This is a
more lax criteria, and will return more wells.
Select Wells When ALL Criteria Is Found - This option returns wells only when ALL
of the wells' selected data item values fall within the minimum and maximum. This is
a more stringent test criteria, and will return fewer wells.

Zone Data Selection Criteria
This section specifies up to 6 conditions for selecting wells.
Use? - This option enables the specified condition. Note that deselecting this
checkbox does not erase the zone, item, or min/max.
Zone - This dropdown selects the desired zone for the condition.
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Item - This dropdown selects the desired data critera for the condition. This
dropdown will only contain data items from the zone selected immediately to the left.
Minimum/Maximum - This entry sets the minimum and maximum for the selected
item. These fields can use scientific notation (such as 1E30, -1E30, 1E-30) very
large or very small values. For dates, enter the minimum and maximum values as
month/day/year, such as 9/23/65 or 01/01/1999.
Select When Null - Instead of using the minimum and maximum values, this option
overrides the condition to only look for wells with a NULL In the data item.
Use SSTVD Tops - By default, Petra looks for MD values on formaiton tops. This
option instead specifies the minimum and maximum top as SSTVD tops.
Use Top Aliases - This option enables top aliasing.
Use Zone Aliases - This option enables zone aliasing. When the original data item is
blank, Petra will attempt to look down the list of equivalent zone data items.

Dates Tab
The Dates Tab limits the text search to only text items changed within a specific date
range.

Include Date Range Search - The "From" and "Through" entries set the calendar
date range. Only items changed within the selected timeframe will be selected.

Quality Tab
The Quality Tab adds an additional quality code search.
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Include Quality Code Search - This option restricts the search to only the wells that
have the selected quality code. This tool can use multiple quality codes - just
separate the different codes with semicolons (;).
When working with multiple conditions and a quality code search, the ALL or ANY
selection mode set on the Z Data Tab controls how Petra returns wells. With an ALL
search, all of the conditions need to have one of the quality codes. With an ANY
search, only one of the conditions needs one of the quality codes.
4.7.2.4

Select Wells By Zone Text Item

This well selection option searches a text-type zone data item or the remark field of
a numeric zone data item for one or more values.

Data Tab
The Data Tab controls how Petra searches for text.
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Select Zone and Item To Be Searched
Choose the desired zone and data item name for the search.
View/Edit - This button opens the View/Edit Zone Data tool.
Use Aliases - This button allows the search to use data item aliases.

Search Method
Search For Items Listed Below - This method selects wells from a list of the unique
remarks in the selected data item. This option is best used for text fields with a
relatively small number of unique values, such as a source code or flag. Text fields
like comments, on the other hand, can have a totally unique entry for every well; the
Keyword search is a much better option for text fields like this.
To use this method, select the "Get Data" button on the bottom of the tool. Here,
Petra will load the list box with all unique values from the current wells. Select the
desired text box and select "OK" to search all wells containing that exact entry.
Search For Wells Containing Keyword(s) - This option searches the text values or
remarks for specific words or phrases. Separate keywords by a comma. Phrases
containing blanks must be enclosed in double quotes. Click the OK button to begin
the search.

Data Fields To Examine
This section sets the individual parts of the data item for the text search. Note that
the search can include the "Text Item or Remark" field and/or the "Quality Code"
field. for the data idem.
Examine Text Item or Remarks - This option instructs the search to look inside the
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"Text Item or Remark" field.
Examine Quality Code - This option instructs the search to look inside the "Qual"
field.

A "Text" Zone Data Item

Choose One or More Data Values To Select Wells By
This list is only used with the "Search For Items Listed Below" search option. Select
the "Get Data" button to load all unique values for the selected zone data item using
the currently selected wells. Highlight one or more data values and click OK to begin
the search. With a large number of wells and a large number of unique text strings,
this proces can take a considerable amount of time. Avoid using this option for data
items with large number of unique text strings, like well comments.

Dates Tab
The Dates Tab limits the text search to only text items changed within a specific date
range.

Include Date Range Search - The "From" and "Through" entries set the calendar
date range. Only items changed within the selected timeframe will be selected.

4.7.2.5

Select Wells With Tests In A Zone

This well selection option will examine a selected zone interval for the occurrence or
one or more data criteria consisting of IP or production tests, formation tests (DST),
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perfed intervals, cored intervals, and shows.

Zone to examine for tests - This option searches for wells that have tests inside the
top and base set by the the selected zone's interval definition.

Look for wells with the following test information
IP Tests
Other Prod Tests
Fm (DST) Tests
Perfs
Shows
Cores

Options
Select Wells when ANY Criteria Is Found - This option returns wells with at least one
of the selected tests falls within the zone interval. This is a more lax criteria, and will
return more wells.
Select Wells When ALL Criteria Is Found - This option returns wells only when a well
as ALL selected tests within the zone interval. This is a more stringent test criteria,
and will return fewer wells.

Options Tab
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IP and Prod Tests Must Contain Treatments Containing the Following Text - This
option adds an additional search criteria in the "Treatments" section of tests.
Restrict By Perf Source - This option restricts the search to only the wells that meet
the Perf Source.
4.7.2.6

Select Wells By Tops

The Select Wells By Tops tool selects wells by the presence or absence of tops and
quality codes. This tool can also isolate wells based on the formation top's
modification date.

Options Tab
The Options Tab sets the tops and search criteria.

When Is A Well To Be Selected
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Select Well if ALL of the Selected Tops Meet the Requirements - This option returns
only wells with ALL the digital curves selected on the "Choose Logs for Well
Selection" list.
Select Well if ANY of the Selected Tops Meet the Requirements - This option returns
wells with at least one of the digital curves selected on the formation" list .
Select Well if NONE of the Selected Tops Meet the Requirements - This option
returns wells that do not have any of the digital curves selected on the "Choose Logs
for Well Selection" list.

Selection Requirements
If Top is Present in the Database - This option returns wells that have the selected top
or tops.
If Top is NOT Present in the Database - This option returns wells that do not have the
selected top or tops.
If Top Was Modified Within the Specified Date Range - This option returns wells that
have been modified within the date range set by the Dates Tab.

Quality Tab
The Quality Tab adds an additional quality code search. When working with multiple
conditions and a quality code search, the ALL, ANY, or NONE selection mode set on
the Options Tab controls how Petra returns wells. With an ALL search, all of the tops
need to have one of the quality codes. With an ANY search, only one of the tops
needs one of the quality codes. With a NONE search, Petra will return only the wells
that do not have a formation top with any specified quality codes.

Include Quality Code Search - This option restricts the search to only the wells that
have formation tops with a specific quality code. This tool can use multiple quality
codes - just separate the different codes with semicolons (;).

© 2014

544

PETRA Help

Dates Tab
The Dates Tab limits the text search to only text items changed within a specific date
range.

Include Date Range Search - The "From" and "Through" entries set the calendar date
range. Only items changed within the selected timeframe will be selected.

Repeats Tab

4.7.2.7

Select Wells With velocity Function

The Select Wells With Velocity Function tool finds wells with loaded, active, or
missing velocity functions
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Search method
Find Wells With Selected Velocity Functions - This option selects wells based on the
velocity functions selected on the "Choose Velocity Functions For Well Selection" list.
Note that this tool also uses the "Selection Mode" option, which can change how Petra
searches for wells.
Find Wells With ANY Velocity Functions - This option selects wells that have a velocity
function.
Find Wells With ANY Velocity Functions - This option selects wells that do not have a
velocity function.
Find Wells With Selected Velocity Functions as Active - This option selects wells
based on the ACTIVE velocity functions selected on the "Choose Velocity Functions
For Well Selection" list. Note that this tool also uses the "Selection Mode" option,
which can change how Petra searches for wells.

Selection Mode ("Find Wells With Selected Velocity
Functions" Search Method Only)
Select Well if ALL of the Selected Functions Are Present - This option returns only
wells with ALL the velocity functions selected on the "Choose Velocity Functions for
Well Selection" list.
Select Well if ANY of the Selected Functions Are Present - This option returns wells
with at least of the the velocity functions selected on the "Choose Velocity Functions
for Well Selection" list.
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Select Well if NONE of the Selected Functions Are Present - This option returns wells
that do not have any of the the velocity functions selected on the "Choose Velocity
Functions for Well Selection" list.
4.7.2.8

Select Wells By Casing, Liner, or Cement

Casing Tab

Search By Casing Depth - This option returns wells with any casing inside the set
depth range.
Search By Casing Size - This option returns wells with any casing sizes within the
range.
Any Casing Data At All - This option returns wells with any loaded casing data,
regardless of depth or size.

Liner Tab

Search By Liner Depth - This option returns wells with any liner inside the set depth
range.
Search By Liner Size - This option returns wells with any liner sizes within the range.
Search By Liner Dates - This option returns wells with liner dates between the set
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range.
Any Liner Data At All - This option returns wells with any loaded liner data, regardless
of depth, size, or date.

Cement Tab

Search By Cement Depth - This option returns wells with any cement inside the set
depth range.
Search By Cement Dates - This option returns wells with cement dates between the
set range.
Any Liner Data At All - This option returns wells with any loaded liner data, regardless
of depth, size, or date.

Options Tab

When ALL Conditions Are Met - This option returns wells only when ALL of the
selected casing, liner, and cement values meet the selected conditions. This is a more
stringent test criteria, and will return fewer wells.
When ANY Conditions Are Met - This option returns wells with at least one of the
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selected casing, liner, and cement values meet the selected conditions. This is a
more lax criteria, and will return more wells.
4.7.2.9

Select Wells By Logs

This tool selects wells based on digital log curves.

Logs Tab

Selection Mode
Any Curves At All - This option returns wells that have any digital curves within the
depth ranges set on the Depths Tab.
Select Well if ALL of the Selected Logs Are Present - This option returns only wells
with ALL the digital curves selected on the "Choose Logs for Well Selection" list.
Select Well if ANY of the Selected Logs Are Present - This option returns wells with
at least one of the digital curves selected on the "Choose Logs for Well Selection"
list .
Select Well if NONE of the Selected Logs Are Present - This option returns wells
that do not have any of the digital curves selected on the "Choose Logs for Well
Selection" list.

Choose Logs For Well Selection
This list shows all logs names and definitions stored in the project database. Click
this list to highlight and thus select one or more logs you want the selected wells to
contain.
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Select All - Click this button to highlight and select all logs in the selection list.
Select None - Click this button to deselect all logs in the selection list.
Use Aliases - This option enables log aliasing.

Depths Tab
The Depths Tab sets up a depth range for the log curve search. With this option
enabled, Petra will only return wells with at least a single log value inside this depth
range. Note that the selection mode (any curve or ALL/ANY/NONE selected wells)
will affect how the depth range works. As an example, the "Select Well if ALL of the
Selected Logs Are Present" option, on the other hand, will only return wells with all of
that have all of the curves on the well selection list inside the depth range.

Restrict By Logs Within a Depth Range - This option enables and disables the depth
range search.
Select Well if ANY of the Selected Logs Are Present - This option returns wells with
at least one of the digital curves selected on the "Choose Logs for Well Selection"
list .
Select Well if NONE of the Selected Logs Are Present - This option returns wells
that do not have any of the digital curves selected on the "Choose Logs for Well
Selection" list.

Set Depths - This button opens the "Set Depth Range" tool. Note that the desired
interval can be set to a formation top, MD, or TVD. For MD and TVD, select the
relevant button and enter the adjacent depth in the entry field. For tops, select the
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desired top from the “Fm Top Name” dropdown box. Notice that an offset can also
be added or subtracted to the fm top; this offset will include data points above or
below the actual fm top depth.

Logs Must Cover Enitre Depth Range - By default, Petra will return wells with at
least one log curve-depth value in the depth range. This option restricts the search
to only logs that completely cover the interval.
Find Only Curves with Depth Units Equal to: - This option restricts the search to wells
with log curves set in the desired depth unit (feet or meters).
Find Only Curves with Sample Rate - This option restricts the search to wells with a
specified sample rate.

Other Tab
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Log must have an LAS Header Associated with it - This option only returns wells with
a loaded LAS header stored in the database.

4.7.2.10 Select Wells with Raster Log Images

Raster Logs Tab

Search Method
Find Wells With Selected Rasters - This option returns wells that have the raster
group names selected on the Choose Logs for Well Selection" list . Note that the
"Raster Selection Mode" section further controls how the search handles multiple
group names.
Find Wells with ANY Rasters - This option returns wells with at least one raster log
group.
Find Wells With NO Rasters - This option returns wells with at no raster log groups.
Find Wells with MJ Associated Rasters - This option returns wells that have the MJ
Associated group names selected on the Choose Logs for Well Selection" list . Note
that the "Raster Selection Mode" section further controls how the search handles
multiple group names.
Find Wells with IHS (Direct Connect) Rasters - This option returns wells that have the
IHS Direct Connect group names selected on the Choose Logs for Well Selection" list
. Note that the "Raster Selection Mode" section further controls how the search
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handles multiple group names.

Raster Selection Mode
Select Well if ALL of the Selected Logs Are Present - This option returns only wells
with ALL the digital curves selected on the "Choose Logs for Well Selection" list.
Select Well if ANY of the Selected Logs Are Present - This option returns wells with
at least one of the digital curves selected on the "Choose Logs for Well Selection" list
.
Select Well if NONE of the Selected Logs Are Present - This option returns wells that
do not have any of the digital curves selected on the "Choose Logs for Well Selection"
list.

Options Tab

Use Aliases - This option uses the list of "equivalent" raster group names or aliases
established on the Raster Log Maintenance's Aliases Tab.
Search For Uncalibrated Rasters Only - This option ignores raster logs with depth
calibration points, and only selects wells with uncalibrated raster groups. This can be
useful for troubleshooting a project, or for finding wells that need more work.
Select When Source Contains - This option limits the search only to raster group
names with a source code. This tool can use multiple quality codes - just separate
the different codes with semicolons (;).
When working with multiple conditions and a quality code search, the ALL or ANY
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selection mode set on the Raster Logs Tab controls how Petra returns wells. With an
ALL search, all of the group names need to have one of the quality codes. With an
ANY search, only one of the group names needs one of the quality codes.

Depths Tab
The Depths Tab sets up a depth range for the log curve search. With this option
enabled, Petra will only return wells with at least a single raster calibrated depth
inside this depth range. Note that the selection mode (any curve or ALL/ANY/NONE
selected wells) will affect how the depth range works. As an example, the "Select
Well if ALL of the Selected Logs Are Present" option, on the other hand, will only
return wells with all of that have all of the groups on the well selection list inside the
depth range.

Restrict By Logs Within a Depth Range - This option enables and disables the depth
range search.
Set Depths - This button opens the "Set Depth Range" tool. Note that the desired
interval can be set to a formation top, MD, or TVD. For MD and TVD, select the
relevant button and enter the adjacent depth in the entry field. For tops, select the
desired top from the “Fm Top Name” dropdown box. Notice that an offset can also
be added or subtracted to the fm top; this offset will include data points above or
below the actual fm top depth.
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4.7.2.11 Run Bulk Query

This "Select Wells By Data Criteria" feature provides a method to re-run several
"query history files" and save each resultant well list as a WSN file.
This screen provides a series of buttons to fill a 2-column grid defining the query
history file on the left and the associated wsn list file on the right.

Run Bulk Query From File
Select a file name to load or save the query/wsnfile criteria
Load - Load a previously saved bulk query file (BWQ file extension)
Save - Save a bulk query file (BWQ file extension)
Run Bulk Query - Run each query history and save resultant wsn lists. A report is
created showing the results of each file.
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Add Row - Click this button to add a row to the grid
Delete Row - Deletes the row pointed to by the grid row cursor
Delete All Rows - Deletes all grid rows with an "are you sure" prompt.
Set Query File - Displays a file dialog for choosing the query history file to be placed
in the left side of the grid at the current grid row cursor.
Set WSN File - Displays a file dialog for choosing the WSN list file to be placed in the
right side of the grid at the current grid row cursor.
4.7.3

Well List Selection

This tool selects wells from a simple list of wells in the project.
To open this tool, select Wells>Select>Wells from a List
Wells can be selected for display or various processing from a list containing the .
Select wells by clicking and highlighting the well entry in the list box. Two modes of
selection are provided. The "Extended Selection Mode" allows selection by dragging
the mouse cursor over the items similar to using Windows Explorer. You must hold
the control key down to select individual wells. Disable the extended mode selection
by clicking on each well while holding down the Ctrl. key.

Sort Wells By
This dropdown determines how Petra sorts and displays the well list. Petra can
display wells by UWI, WSN, Label, and Well Short Name. Selecting the UWI entry,

© 2014

556

PETRA Help

for example, will sort the well list in an ascending UWI numbers and will displays will
display the fields with the UWI value first.

Choose From
This section defines which well list is displayed.
Selected Wells - This option limits the available well list to only the wells currently
selected in the Main Module.
All Wells - In project mode, this option will display all wells in the project. In
prospect mode, this option will only display the wells selected in the active prospect.

Well List
This list contains the wells available for selection. This list will behave a little
differently depending on whether the "Extended Selection Mode" option on the
bottom of the screen is selected. Note that toggling the "Extended Selection
Mode" option will deselect all wells on the well list.

"Extended Selection Mode" OFF
This option is best for selecting a small set of wells. Clicking on a well highlights and
selects it. Clicking on a well again deselects it.

"Extended Selection Mode" ON
When the "Extended Selection Mode" option is selected, you can click and drag to
select multiple adjacent wells. To select additional wells, hold down CTRL and drag
over the additional well names.

Load - This option will highlight the list of wells from a UWI list.
Save - This option will save the currently highlighted wells to a UWI list.
Save WSN - This option will save the currently highlighted wells to a WSN list.

Invert List - The "Invert List" option changes the status of each selected well to
nonselected and each nonselected well to selected well.
Select All - This button will highlight all wells on the available well list.
Select None - This button will deselect all wells on the available well list.

4.8

Compute Functions
Petra contains many compute functions, largely divided up by the general type of data
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analyzed.
To open any of Petra's compute tools, select Compute> from the menu bar at the top
of the Main Module.

Using Log Curves
Using Zones or Tops
From Production Data
Using Locations
Using Test Data
Using Interval Data
4.8.1

Using Log Curves
To open any of Petra's log compute tools, select Compute>From Logs from the menu
bar at the top of the Main Module.

Footages (Reservoir Properties)
Statistics
Equation Expression
Substitution
Pay Flag Curve
Normalization
Pay Continuity
Advanced Transforms
Pay Report
Sum Raster Pay Within Zone
Extract Log Stats to Int Data
4.8.1.1

Log Footage Summation

The Log Footage Summation function calculates log footage and reservoir
parameters using digital logs. Essentially, the Footage Summation function analyzes
digital logs and sums up the footage that meets a set of user-defined criteria. This
footage is stored as a zone data item.
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These summed footages and reservoir parameters can be computed for one or
more zones simultaneously. The calculation can be done for all selected wells in the
main module or on only the currently selected well in the main module.
As an example, Petra can calculate net pay in the D sand by computing how much
section has GR below 60 API, porosity above 10%, and resistivity above 10 ohms
between the top and bottom of the D sand. As shown in the following log, only the
interval from 6346' to 6353' fits all three criteria, and will calculate as "Net."

Calculating a Gross footage, a Net footage, and a Net/Gross ratio will generate a
set of data items that look like this:

To open the Log Footage Summation tool, select Compute>From Logs> Footage
(Reservoir Properties)… from the menu bar at the top of the Main Module.

Data Tab
All the curve drop down boxes on the lower half of this tab have two names. The
"Porosity" drop down box is also "Condition 1."
The first through fourth Log Curve drop down boxes, "Porosity", "Water Sat",
"Permeability", and "Gamma Ray" only need to be filled with the named log (a
density porosity log in the "Porosity" slot, for example) if you are calculating the
reservoir statistical measurements Poros Ft, Perm Ft, Hydrocar Ft, Avg Porosity,
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Avg Perm, or Avg SW. The first three footage types, Gross, Net, and Net/Gr,
completely ignore these named definitions.
The Gross calculation sums footage in the Gamma Ray/(Condition 4)'s drop down
box. You can easily put an SP or resistivity curve as your "Condition 4" and calculate
Gross feet on that. Similarly, the Net calculation sums footage that satisfies
conditions on all checked drop down boxes regardless of curve drop down box
name. In the screenshot above, a Net calculation will sum log footage that has
density porosity (DPHI) between 0.10 and 1, gamma ray (GR) between 0 and 100
API, and a deep induction (LLD) between 10 and 9999. In the example above,
putting the LLD curve into the Permeability/(Condition 3) drop down box will still have
the same result.

Compute Footages For (Enter Zone Field Name)
First, select the type of footages to calculate by checking the small box beside each
reservoir parameter. Each of these footage parameters will be stored as a data
item in the zone selected in the Depth Zones Tab. Default names for the data items
are provided for each parameter, but these names can be changed by simply typing
over the name. As an example, you can change "GROSS" to "D_SAND_GROSS."
Gross - Gross footage is computed using one of two methods selected in the
Options Tab. It is either the isopach thickness based on the zone's upper and lower
depth or it is summed using the GR/(Condition 4) log curve cutoff condition.
Net – Net footage is the summation of the total number of feet where the Porosity /
(Condition 1) curve passes its cutoff criteria. All checked log curve drop down
boxes cutoffs are used as cutoff criteria.
Net/Gr (NGR) - Ratio of the Net divided by Gross. You must compute Net and Gross

© 2014

560

PETRA Help

in order to compute Net/Gr.
Poros Ft (PHIH) - Summation of each sample interval multiplied by each Porosity/
(Condition 1) curve value passing all cutoff criteria. You must also select Net with
this option.
Perm Ft (KH) - Summation of each sample interval multiplied by each Permeability/
(Condition 3) curve value passing all cutoff criteria. You must also select Net with
this option.
Hydrocar Ft (SOPHIH) - Hydrocarbon Feet is the summation of each sample interval
multiplied by each Porosity/(Condition 1) times 1.0 - Water Sat/(Condition 2) passing
all cutoff criteria. Requires porosity and water saturation curves.
Avg Poros (PHIA) - Arithmetic mean value of all Porosity/(Condition 1) curves values
passing all cutoff criteria.
Avg Perm (KA) - Arithmetic, geometric, or harmonic mean value of all Permeability/
(Condition 3) curve values passing all cutoff criteria. Select the method of averaging
in the Options Tab.
Avg SW (SWA) - Arithmetic mean value of all Water Sat/(Condition 2) curve values
passing all cutoff criteria.
User Ft - Summation of the total number of feet where all cutoff criteria are meet.

Log Curves and Conditions
This section is used to select the log curves and their cutoff criteria for the
summation. Check the small box to the left of each curve drop down box list to
indicate selection. Unselected boxes are not used as cutoff criteria.
Porosity Log - This log is used for all Net calculations as well as for PHIH, HPV, and
PHIA calculations. You may select any type of log here to be used in a generic Net
calculation.
Water Saturation - When used for HPV calculations, this log must specify a water
saturation curve. For generic Net calculations, specify any log type.
Permeability - When used for KH and KA calculations, this log must specify a
permeability log. For generic Net calculations, specify any log type.
Gamma Ray - When used for "Gross Sand" calculations, this log should specify a
gamma ray, vshale, or other sand indicating log curve. Otherwise, you may specify
any conditional curve for net calculations.
User Log - Any additional log curve and condition you want to use.

Cutoff Criteria
For each log selected for use, enter the cutoff limits as the minimum and maximum
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allowed values. The curve "passes" the conditional test whenever its value falls within
the minimum and maximum range. Be careful of values expressed as a
percentage, like porosity. 5% porosity can be expressed as "5" or as "0.05."
Make sure to check your logs for consistency.
View Zone Fields... - This button brings up the "View/Edit Zone Data" dialog where
you can check computed results.

Depth Zones Tab

Compute Footages Over Zones
Petra reads the top and bottom depths defined on the selected zone's interval
definition, and will calculate footages over that interval. In this example, the D_Sand
zone is defined by the D_SAND fm top as the top, and BASE_D_SND fm top as the
base. This interval can be further constrained with the Filter Tab. Since the limits of
the calculation come from each zone definition, you can select one or more zones for
the reservoir footages calculation.
If your zone intervals are defined by the default -99999.0 to +99999.0 MD - You will
need to either define the zone, or specify a top and bottom with the Filter Tab.
Otherwise, Petra will calculate log footage from -99999 to 99999 MD. Since any
limits will come from the Filter Tab, you can only select one zone to calculate
reservoir footages.
After the summation, each selected zone will contain new data items for each
reservoir summation checked and named in the Data Tab.
Source Code for Output Zone Items – This adds a source code to newly created
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reservoir data items. Changing the Source Code when repeating a log footage
summation will create an entirely new set of data items with the new source code.

Options Tab

Correct Footages For TVD - Check this option if you wish to use True Vertical
Depths instead of Measured Depths. This will have an effect only on wells with
survey data.
Use Log Curve Aliases - This option causes log aliases to be used. When a
specified curve is missing, an alias log will be used. This is very useful for large
projects. Log curve names are aliased under the Log Tab in the main module.
Store Errors in Remarks Field - Use this option to store a remark in the zone item
containing the reason a well could not be computed.
Substitute WELL TD When Missing Base of Zone Interval - Use this option to use the
TD value as the base of the zone interval whenever the interval top is present but the
interval base is missing (null). The TD value must be stored in the WELL zone and
TD zone item. The quality code field of the computed value will contain a code of
"TD" to indicate that the TD was substituted for the base. This can generate
anomalously high results if there is more log section below the interval of interest, or
anomalously low results if the well does not completely penetrate the interval.
Write Warnings to Report File – this generates a report file called "FOOTSUM.TXT"
in the project's PARMS directory. This will report errors due to missing tops or
incomplete log sections.
Correct for Fractional Depths - This option determines whether a full or fractional
amount of the sample rate is accumulated for the first and last depth sample. For
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example, if a zone started at fm top 4100.5 ft and the curve sample rate was 1.0,
with values at 4100.0 and 4101.0, then checking this option would sum only 0.5 ft for
the first sample, instead of 1.0 because only half of the data falls within the zone.
When this option is unchecked, any sample that passes the conditions gets a full
sample rate accumulated.
Flag Quality with "+" If Any Nulls Found in Zone – This generates a "+" sign in the
quality field if any null values are found in any curve used for a log footage
calculation. This is a sign that part of the curve was not used, so the footage
reported is a minimum.

GROSS Calculation Method
This section determines how "GROSS" is computed for each zone.
Gross Interval Thickness Only - This option subtracts the upper interval depth from
the lower interval depth. Interval depths are defined by the zone reference depths. If
the log curves define a smaller interval, i.e., the log data does not extend over the
entire zone, then the Gross value will reflect the smaller interval thickness.
"Gross Sand" Thickness (Passes GR/(Condition 4) Condition Only) - This option
must have a Gamma Ray/(Condition 4) curve specified and the resulting Gross value
is the number of feet where the curve passes its cutoff condition. Any log, such as
an SP or resistivity log, can be placed in the Gamma Ray/(Condition 4) drop down
box for this calculation.

Average PERM (KA) Calculation Mode
This selects the method of computing average permeability.

Compute For
This simply chooses whether a footage summation is for calculated for all selected
wells in the main module, or only for the currently selected well in the main module.

If Depths or Any Logs Are Missing
This tells Petra how to deal with missing log curves or depths.
Do Not Overwrite DB – This option will not write anything to the database. Use this
if you have already done work in these exact zone data item fields.
Store Zero – This option will overwrite the data item with a zero. A missing GR
curve does not mean that there is no pay, so use caution with this option.
Store Null – This will overwrite a value in the data item with a null.

If Cutoff Conditions Are Not Met
This tells Petra how to handle logs that do not meet the petrophysical cutoff
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conditions outlined in the Data Tab.
Do Not Overwrite DB – This option will not write anything to the database. Use this
if you have already done work in these data item fields.
Store Zero – This will overwrite the database with a zero. A full suite of logs that
does not meet the cutoff conditions probably does mean that there is zero net pay.
However, odd log scaling or percentages stored as integers (5% as "5") can result in
curves not meeting cutoffs when they should.
Store Null – This will overwrite the data item with a null.

Capture Tab
The Capture Tab allows you to collect other data about the footage operation.

"Pay" Counts - This section allows you to capture the number of "pay" intervals that
passed the cutoff criteria within each computed zone. The number of "pay" intervals
will be stored in the specified Zone Item name. There will be a count for each zone
interval selected for calculation. Higher pay counts can reflect multiple pay intervals
within a zone, or more variable reservoir quality.
Percent Interval Covered – This section allows you to capture the percentage of the
zone covered by logs. Petra reads the upper depth of the shallowest log curve and
the lower depth of the deepest log curve, and compares these to the zone definition
to calculate a percentage. If your zone is defined by the default -99999 to 99999
MD, this will be a meaningless number.
Pay Flag Curve – This section generates an additional log curve that reflects the Net
log footage summation. Pay and Non-Pay can be defined as any number or null
values. Usually, Pay is defined as 1 and Non-Pay as 0 or Null.

© 2014

Main Module

565

In the D sand example, the pay zone at 6350' defined by GR, LLD, and DPHI is
clearly shown by the PAY curve at the far right. In addition to simply showing pay
intervals, these curves can be useful in log calculations. For example, to selectively
erase a curve everywhere but over a pay zone you can multiply porosity by a pay
curve where pay is 1, and non-pay is null.

Filter Tab
The filter tab sets controls on what log interval inside the zone definition is
considered during the footage summation.

Depth

Bounds

Setting Depth Bounds allows you to set upper and lower limits on the interval inside a
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zone used for a log footage calculation. These limits can be from a discrete MD or
TVD depth, or from fm tops. How this works will depend on how you have defined
your zone.
If your zone intervals are defined by tops and are selected in the Zones Tab
Setting a limit in the Filter Tab can only limit the interval inside zone-defined top and
bottom as limits. This can be useful if your selected zone is defined as a large
interval, and you want to calculate footages over a relatively smaller interval inside
that zone.
If your zone intervals are defined by the default -99999.0 to +99999.0 MD Specify a top and bottom with the Filter Tab. Otherwise, Petra will calculate log
footage from -99999 to 99999 MD.
Use Top Aliases –. This tells Petra to use top aliases in setting limits. Top aliases
are set in the Main module under the FmTops Tab.
Use TD if Missing Lower Top - Use this option to use the TD value as the base of the
zone interval whenever the interval top is present but the interval base is missing
(null). The TD value must be stored in the WELL zone and TD zone item. The quality
code field of the computed value will contain a code of "TD" to indicate that the TD
was substituted for the base. This can generate anomalously high results if there is
more log section below the interval of interest, or anomalously low results if the well
does not completely penetrate the interval.
Use Depth Bounds even if Zone Depths Are Missing – This tells Petra to use the
depth limits set in the Filter Tab if the tops that define the Zone are absent (see
above). If your zone intervals are set to the default -99999 to 99999 MD, this button
has no effect.

Thickness Restriction
This sets a minimum and maximum pay thickness that will be added to the
summation. Without this restriction, an interval with 15 two foot thick uneconomic
stringer sands will add up to 30' of pay.

File Tab
The File Tab allows you to save log footage settings and recall them later. This is
useful if you are working with multiple pay zones or with running multiple
petrophysical cutoffs. Saving templates is also useful for running batch footage
summations with the Batch Tab.
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Load Template - This button loads an external log footage template file.
Save Template - This button saves the current settings to an external log footage
template file.

Export Tab
The Export tab allows you to export a comma delimited spreadsheet file (*.CSV) that
contains the top and base of each log interval meeting the log criteria. This can be
very useful for developing an inventory of uphole pay zones behind pipe.
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This CSV exports UWI, Name, Number, Label, Top in MD, Base in MD, Top in
SSTVD, and Base in SSTVD.
For the D Sand example above, a Net footage export looks like this:

Of the types of footages, only the Net and Gross intervals have a top and a bottom;
the rest, like Net/Gr, are statistical measurements of reservoir quality. When a
Gross interval alone is calculated, this export will be gross interval. When a Net
interval alone is calculated, this export will be the net interval. If Gross and Net are
simultaneously calculated, the export will be the net interval.

Store Top-Base Intervals to Pay Database
This option allows you to save the intervals to the raster pay database.

Batch Tab
The Batch Tab allows you to run multiple log footage summation templates (see
FILE TAB above) as a batch. This is particularly useful for areas with multiple pay
zones, or for running summations on the same zone in different ways with different
curve conditions. You change the queue either by using "Select Files" or by using the
add "<", drop ">", or clear all items ">>" buttons

Select Files - This button adds multiple template files from the same location. Click
"Select Files" and navigate to the location of your template files. Next, highlight the
template files by left clicking and dragging the mouse or by using SHIFT+Left click or
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CTRL + Left click. It is important that template files are all in the same place. Using
"Select Files" again will replace any already selected template files.
Using the Add and Subtract buttons is faster for adding multiple files in different
locations. Click the add button "<", and navigate to the location of your template file.
You can only add one template at a time this way. The subtract button ">" will drop
a selected template file. The drop all templates button ">>" will clear the list.

4.8.1.2

Log Statistics Calculation

The Log Statistics function computes simple statistics on a selected log for one or
more zones. The results are stored in the zone items database. The calculation will
be done for all currently selected wells on the Main Module.
To open the Compute Log Statistics tool, select Compute>From Logs>Statistics
from the menu bar at the top of the Main Module.

Data Tab
The Data tab selects the digital log curve and the statistics to derive from the log.

The Compute Log Statistics Data Tab
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Select Log Data From
This section sets the log for the statistical calculation. The dropdown menu contains
a list of every digital log curve in the project.
Use Alias Logs - This option uses log curve aliases when the the selected curve is
absent. Disabling this option will force petra to only use the exact curve name.

Compute Items
The Compute Items section selects the desired statistical calculations, controls a
couple of options on the statistics, and sets the data item that will store the result in
each well. By default, Petra names each data item by the statistic and the curve
name. Calculating the Sum on the ABHV curve (as in the screenshot above) creates
a default data item Sum_ABHV. These names are defaults only; to change the
name, simply overwrite the existing
Sum - This option simply adds all the curve values together. Note that this
calculation can be affected by the curve's sample rate - the "Compute 'Sum' Using"
option on the Options Tab helps to normalize sums by sample rate.
Minimum - This option simply finds the minimm
Maximum - This option finds the maximum value for the curve.
Mean - This option finds the mean or average for the curve. The "Mean Calculation"
option below sets whether the mean is Arithmetic, Geometric, or Harmonic.
Std Dev - This option finds the standard deviation for the curve.
Percentile N = - This option finds the value of the curve at the selected percentile.
By default, Petra looks for the 10th and 90th percentiles. To change the percentile,
simple type in the desired number between 0 and 100.
Depth - This option calculates the depth at which the Minimum or Maximum log value
occurs in the zone.

View Zone Data... - This button opens the View/Edit Zone Data tool. This can be
useful for checking computed results without closing the Log Statistics Calculation
Tool.

Compute For Zones
This list selects the zones used in the calculation. Petra uses Zones to both set the
data item's location and the depth interval over which the log statistics are computed.
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As an example, selecting the "D_Sand" zone will put the calculated data items into
the D Sand Zone, and use the zone's interval definition to limit the calculation to only
the log curve inside the D Sand zone.
This tool requires the Zone's interval definitions to be set - the default -99999 to

Source Code For Results
This option adds a source code to the statistics data items.

Options Tab

The Compute Log Statistics Data Tab

Compute "Sum" Using - A curve with a sample rate of 0.5' has twice as many values
as a curve with a 1' sample rate. Even with identical curve profiles, the 0.5' sample
rate curve will have a sum twice as high as the 1' sample rate curve. This option
multiplies the computed curve sum values by the curve sample rate.
Zone Item Discriminator – This option uses a numerical zone data item to filter the
calculated statistics. When this option is selected, Petra will check every curve value
against this number and ignore values that meet the criteria. As an example, this tool
can set an upper limit on porosity values, so wash-out induced porosity spikes are
ignored.
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Log Curve Discriminator – This option uses a discriminator curve to filter the
statistical data. At depths where the discriminator curve contains a 0 or null value,
the corresponding depth will be skipped in the statistical calculation. If this box is
checked and the log is absent, the statistics will not be calculated.

4.8.1.3

Log Equation Transform

This function allows you to compute a log curve from one or more logs by specifying
a generalized equation transform. After the equation is written, you assign equation
variables to database variables. Equation variables may be logs, zone data items
(including fm tops), numeric constants, or curve depths.
To open the Log Equation Transform tool, select Compute>From Logs>Equation
Expression… from the menu bar at the top of the Main Module

Equation Tab
In the Equation Tab, you can enter an equation using variables and mathematical
operators. The variable on the left side of the equal sign is the result variable.

Variables
Variables are just text, which can either be very specific (“GAMMARAY” or
“FORMATION_TEMPERATURE”) or general (“A” or “B”).

Mathematical Operators
Petra recognizes a wide variety of mathematical operators:
+ Addition
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- Subtraction
* Multiplication
/ Division
** Exponent
ABS(x)

- Absolute value of x

ACOS(x)

- Arccosine of x (in radians)

ASIN(x)

- Arcsine of x (in radians)

ATAN(x)

- Arctangent of x ( in radians)

COS(x)

- Cosine of x in radians

COSH(x)

- Hyperbolic cosine of x (radians)

EXP(x)

- e to power of x

INT(x)

- Truncated value of x

LOG(x),LN(x)

- Natural Log of x

LOG10(x)

- Log based 10 of x

MAX(x,y)

- Maximum of x and y

MIN(x,y)

- Minimum of x and y

ROUND(x)

- Rounded value of x

SIN(x)

- Sine of x in radians

SQRT(x)

- Square root of x

SQR(x)

- x squared

SINH(x)

- Hyperbolic sine of x (radians)

TAN(x)

- Tangent of x in radians

TANH(x)

- Hyperbolic tangent of x (radians)

Operator Order
1 Exponent
2 Multiplication and division
3 Addition and subtraction
Use of parentheses can change the order of precedence.
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Example Equations
GRN=GR - MEAN_GR + MEAN
LOGNRM = LONORM+(LOG-PICKLO)*(HINORM-LONORM)/(PICKHI-PICKLO)
LOGNRM = LOG+ LOGPICK - GOODPICK
SW = ( RW/(RT * (PHI**M)))**(1/N)
R = ((A+B*(C-1.0))/100
R = X*SIN(A)+Y*COS(B)
R = LOG10(X)
R = X*X or R = SQR(X)
R = X**Y (x raised to the y power)

Load and Save Buttons
You can save equations in the system equation file and load them at a later date. A
number of useful equations come packaged with Petra.

Options Tab
The Options Tab limits the calculation to a set depth or to a subset of wells in the
© 2014

Main Module

575

project.

Restrict Depths – You can restrict the operation to be performed only on a certain
depth range based on tops or on depths.
Null Results if Unable to Evaluate – This option will tell Petra to overwrite an existing
log with null values if it is unable to evaluate the equation.
Apply Log Transform To - This simply chooses whether the log calculation will be
performed for all selected wells in the main module, or only for the currently selected
well in the main module.

Once the Equation and Options Tabs are filled out, click the “Next” button at the
bottom of the dialogue box. This causes Petra to parse the equation, and bring up
the Log Equation Variable Assignments Tab.

4.8.1.3.1 Log Equation Assignments

After creating the log equation, the next step is to assign specific logs, zones,
constants, or log depths to the variables.

Assignments Tab
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Now that the equation is parsed, you can assign your output log and variables.
Output Log - Petra will create a log curve that uses the same variable name to the
right of the equation if that curve does not exist. In the example above, Petra will
create a new curve named “DPHI.” Alternatively, click the drop down box and assign
the output curve to an existing curve name.
Equation Variable Assignments - This is where you tell Petra what logs, constants, or
zone data items you want included in the equation. Click on a variable in the
“Equation Variable Assignments” box. Next, click on a Log, Zone, Constant, or Log
Curve Depth button in the “Assign Variable To” section. Click on the associated drop
down box and find the specific log or data item or enter a constant. Finally, click on
assign. This will change the Equation Variable Assignments box to reflect the correct
variable. Using the exact curve names in the equation tab will cause Petra to
“guess” at the variable assignments, which can save time.

Options Tab
Remember that fm tops are data items in the FMTOPS zone. Under the Options
Tab, you also have the option of using MD, TVD, or SSTVD depths in the equation.
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Log Curve Substitute

This log function performs a conditional data substitution using "if-then-else" type
logic. You specify the source log to be evaluated along with the logical condition to
test the source log against. In addition, you specify what output results you want
when the test evaluates to true and what output results you want when it is false.
An example of this logical test might be; "If GR is equal to NULL then set GR to
GR_NRM, else set GR to GR". This operation would substitute the GR_NRM curve
for any NULL values found in the GR and replace GR curve in the database.
To open the Log Curve Substitute tool, select Compute>From Logs>Substitute from
the menu bar at the top of the Main Module
This function can be used to fill in NULL sample values from another log, or set
specific values to NULL or some other value.
The substitute function will be applied to all currently selected wells, i.e., those wells
showing in the main window list.
Select the desired options then click the OK button to perform the substitute function.
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Log To Evaluate (source)
This dropdown sets the log curve to evaluate.

Condition
This section contains the logical condition to test the source log against. Available
conditions are:
EQUAL TO
LESS THAN
LESS THAN OR EQUAL TO
GREATER THAN
GREATER THAN OR EQUAL TO
NOT EQUAL TO

Compare To
This list box contains all available logs in the project. Select the data to compare the
source log to. You may select another log curve, test against a constant value, or
test the source curve for a NULL or missing value.

When True, Result Is
This list box contains all available logs in the project. Select the data you want the
results to contain when the condition evaluates to TRUE. You may elect another log
curve, test against a constant value, or test the source curve for a NULL or missing
value.
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When False, Result Is
This list box contains all available logs in the project. Select the data you want the
results to contain when the condition evaluates to FALSE. You may select another
log curve, test against a constant value, or test the source curve for a NULL or
missing value.

Store Output Log In (results)
This list box contains all available logs in the project. Specify the name of the log
curve you want the output results to be stored in. You may select an existing log or
type in a new log name for which you will be prompted for the new log description.

Delete If Missing Any Logs - Check this option if the output log should be deleted if
any of the logs used in the comparison are missing for the well.
Restrict Depth Range... - The log substitute function can be applied to the entire log
depth range or restricted to a specific depth interval. The depths can be set using a
constant range or variable range based on the formation tops.

4.8.1.5

Compute Pay Flag Curve

The Compute Pay Flag Curve function generates a binary log curve that shows
where log curves meet a set of user-defined criteria. In other words, Petra creates
a log that distinguishes between pay and non-pay based on log parameters. In the
curve, pay and non-pay can be defined as any number or null values. Usually, pay is
defined as 1 and non-Pay as 0 or Null.
As an example, Petra can distinguish pay in the D sand by GR below 60 API,
porosity above 10%, and resistivity above 10 ohmm between the top and bottom of
the D sand. As shown in the following log, only the interval from 6346' to 6353' fits
all three criteria. The pay curve on the right demonstrates this interval.
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In addition to simply showing pay intervals, these curves can be useful in log
calculations or to show contacts. For example, to selectively erase a curve
everywhere but over a pay zone you can multiply porosity by a pay curve where pay
is 1, and non-pay is null.
To open Compute Pay Flag Curve Tool, select Compute>From Logs>Pay Flag
Curve from the menu bar at the top of the Main Module.

Input Curves Tab

Curves and Cutoffs This section is used to select the log curves and their cutoff
criteria for the curve calculation. Select the curve name and establish the condition
and cutoff value.
Available conditions are:
EQUAL TO
LESS THAN
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LESS THAN OR EQUAL TO
GREATER THAN
GREATER THAN OR EQUAL TO
NOT EQUAL TO
For each log selected for use, enter the cutoff limits as the minimum, maximum, or
exact value. Log curves can also be selected as a variable cutoff. As an example, a
“gas effect” cutoff can be established so pay is only where neutron porosity is less
than density porosity. Unselected boxes are not used as cutoff criteria.
Use Log Curve Aliases - This option causes log aliases to be used. When a
specified curve is missing, an alias log will be used. This is very useful for large
projects. Log curve names are aliased under the Log Tab in the main module.
All/Any Condition Met - In the example above, the pay curve criteria is GR below 60,
LLD above 10, and DPHI above 10%. An interval that has fits all these criteria will
be flagged as pay. You also have the option to select whether any conditions are
met. This would flag any interval where any of these criteria pass as pay.

Output Curve Tab
The Output Curve sets the name and specific values of a pay curve.

Output PAY Flag as Curve - By default, Petra will create a log curve called PAY.
Alternatively, enter a new curve name.
Curve Value when PAY - This entry sets the curves value when the criteria on the
Input Curves Tab is satisfied. By default, pay is 1.
Curve Value When NON-Pay - This entry sets the curves value when the criteria on
the Input Curves Tab isnot satisfied. By default, non-pay is zero
Set to NULL - This entry box will assign null values to non-pay.
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Update/Replace Existing Pay Curve – When the pay curve named above already
exists and you are replacing it inside a certain depth range (see below in the DEPTH
TAB), you have the option of updating the curve or replacing the curve. Updating the
curve will merge the new pay curve into the existing one, leaving the pay curve
outside of the depth limits untouched. Replacing the curve, on the other hand, will
null the rest of the pay curve outside of the depth limits.

Depths Tab
The Depths Tab allows you to set limits on the extents of the pay curve calculation.

Set Depths… - This button opens the to set limits based on discrete MD or TVDSS
depths, fm tops, or from zone definitions. In the Set Depth Range box, select the
relevant top, MD, or TVD button. For MD and TVD, select the relevant button and
enter the adjacent depth in the entry field. For tops, select the desired top from the
“Fm Top Name” dropdown box. Notice that an offset can also be added or
subtracted to the fm top; this offset will include data points above or below the actual
fm top depth.
In the example above, the pay curve will only be calculated from the top of the D
sand to the base of the D sand.

Filter Tab
This sets a minimum thickness filter both for pay and non-pay.
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Apply Minimum Bed Thickness Filter - This option enables and disables the minimum
bed thickness filter.
In the example above, any interval that calculates as pay that is below 1' thick will be
set to non-pay. Likewise, any non-pay intervals thinner than 1' will be set to pay.
This is useful for “chattering” logs and washouts.

Pay Data Tab
This option allows you to save the pay curve-calculated intervals to the raster pay
database.

Wells Tab
The calculation can be done for all selected wells in the main module or on only the
currently selected well in the main module.
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Cross Over Flag Curve

A Cross Over Flag Curve is a binary curve that shows where one log crosses over
another. One of the most useful applications of this function is to calculate a “gas
effect” curve from neutron and density porosity curves. This curve is useful for
petrophysical calculations like log footages.
To open the Cross Over Flag Curve tool, select Compute>From Logs>Cross Over
Flag Curve from the menu bar at the top of the Main Module.

Data Tab
The Data Tab is used to select log curves and their scales. Petra scales the curves
to these values and calculates where one curve crosses another. In other words,
cross over is calculated as if the curves were actually plotted. In the example below,
cross over is established when neutron porosity (NPHI) is to the right of density
porosity (DPHI) even though NPHI is on a 0-30 scale and DPHI is on a 0-0.3 scale.
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Store Output Flag Curve As - The Output Curve sets the name and specific values of
a pay curve. By default, Petra will pick the first alphabetized curve name in the
database. Click the drop down box and assign the output curve a new curve or type
in a name. In this example, the output curve will be named “Crossover.”
Use Log Curve Aliases - This option causes log aliases to be used. When a
specified curve is missing, an alias log will be used. This is very useful for large
projects. Log curve names are aliased under the Log Tab in the main module.

Options Tab
The Output Curve Values section sets the specific values of a cross over curve.

When Cross Over Condition - This entry sets the curves value when the criteria on
the Input Curves Tab is satisfied. By default, pay is 1.
When Not Cross Over Condition - This entry sets the curves value when the criteria
on the Input Curves Tab isnot satisfied. By default, non-pay is zero
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Make NULL - This entry box will assign null values to non-pay.
Output Curve Update Mode – When the cross over curve named above already
exists, you have the option of updating the curve or replacing the curve. Updating the
curve will merge the new pay curve into the existing one, leaving the pay curve
outside of the depth limits untouched. Replacing the curve, on the other hand, will
null the rest of the pay curve outside of the depth limits.

4.8.1.7

Log Curve Normalization

The process of log normalization calibrates curves for several wells to a common
scale. Typically, curves are calibrated using one of two methods; base line shift or
scale range adjustment sometimes called sensitivity calibration. A base line shift
adjusts the curves to a common scale by subtracting out the curve's current baseline
and adding back in the desired base line value. Scale range adjustment attempts to
calibrate the curves to have a common minimum and maximum value over the over
the normalization depth interval.
For a longer discussion of log normalization, see the Log Normalization Overview.

Data Tab
The data tab section contains the input and output log curve selections and the
normalization depth Zone.
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Curve To Normalize - This dropdown selects the curve to normalize. This original
curve will remain unchanged, and the normalized version of the curve will be copied
to the "output curve selected below.
Use Log Aliases - This option uses log curve aliases for the input log curve to
normalize. In practice, this option will attempt to replace the missing log curve name
with one of the other "equivalent" logs on the alias list.
Normalized (Output) Curve - Select or enter a new curve name which will contain the
results of the normalization.
Normalization Depth Zone - This option sets the upper and lower limit of the
normalization based on a zone's interval definition. Ideally, this zone should restrict
the normalization to a lithologic package in which the log curves have a common
reading from well to well. Large depth intervals can skew results.

Method Tab
The method section determines which type of calibration is done. The Options Tab
section sets more details for each method.

Base Line Shift - This method adjusts each curve by adding or subtracting a constant
to the curve's values. In other words, this option simply shifts the curve left or right in
order to fit each curve to a specified baseline. This baseline can either be a
computed average or a user-set value. This method only changes the magnitude of
the curve values, the shape of the curve remains the same.
In the example below, well A's original curve (blue) is very close to the overall
baseline (in the middle of the track) while well B's original curve reads high and to the
right relative to the baseline set in the middle of the track. Well A's normalized curve
(red) doesn't shift too much, while well B's normalized curve shifts to the left.
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A Base Line Shift applied to two curves in two wells (A and B). The original curves are in blue, and the normalized
curves are in red

Scale Range (High-Low) - This method adjusts each curve to have a common
minimum and maximum value. This option effectively stretches and squeezes the
curves to use a new range, which can change both the magnitude and shape of the
curve. This method is best used to normalize old, less sensitive logs with newer,
more sensitive logs. This method can adjust the curves to the computed average
minimum and maximum values of all curves or to a user-defined range. This method
can produce a "blocky" curve that often benefits from the Advanced Transform
Module's Smooth Logs tool.
In the example below, well A's original curve (blue) covers most of the range set by
the left and right edges of the track, while well B's original curve covers a smaller
range. Well A's normalized curve (red) expands a little so that the maximum and
mimimum reach the edges of the track, while well B's normalized curve expands and
shifts a lot more.

A Scale Range Shift applied to two curves in two wells (A and B). The original curves are in blue, and the
normalized curves are in red

Percentile Range - This method adjusts each curve such that two given percentiles
have a common minimum and maximum value. By using a percentile rather than the
absolute maximum or minimum, this method is lest prone to anomalous effects
caused by washouts or other data spikes. This option effectively stretches and
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squeezes the curves to use a new range, which can change both the magnitude and
shape of the curve. This method is best used to normalize old, less sensitive logs
with newer, more sensitive logs. This method can adjust the curves to the computed
average minimum and maximum values of all curves or to a user-defined range.
In the example below, well A's original curve (blue) covers most of the range set by
the left and right edges of the track, while well B's original curve covers a smaller
range. Well A's normalized curve (red) expands a little so that the P5 and P95 reach
the edges of the track, while well B's normalized curve expands and shifts a lot
more. Notice that the minimum and maximum extend beyond the set ranges.

A Percentile Range Shift applied to two curves in two wells (A and B). The original curves are in blue, and the
normalized curves are in red.

Options Tab (Base Line Shift Method)
The Base Line Shift method provides two choices for normalization.

Normalize Mean Values to Average Of All Means - This option shifts curves to the
computed average value for all wells.
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Normalize Mean Values To - This option shifts curves to a user-defined value.

Store Computed Means In Zone Variable Name - This option stores the computed
mean values for the original curve in a data item in the zone selected on the Data
Tab. This can be useful for for mapping or troubleshooting later. By default, Petra
will store the mean in a data item called "MEAN_GR." To change this data item,
enter a new data item name.

Options Tab (Scale Range Method)

Normalize Scale Range to the Average Computed High and Low Values - This
option stretches the curves so that the maximum and minimum of each curve
matches the average maximum and minimum curves of all curves.
Normalize Scale Range to the Low and High Values Below - This option stretches
the curves so that the maximum and minimum of each curve are the "Scale Low
Value" and "Scale High Value" entries.
Store Data Low and High values In Zone DB As - This option stores the computed
high and low values for the original curve in two data items in the zone selected on
the Data Tab. This can be useful for for mapping or troubleshooting later. By
default, Petra will store the high and low values in data items called "LOW_NORM"
and "HIGH_NORM." To change this data item, enter new data item names.

Depths Tab
This tab controls how Petra limits the normalization process to a specific depth
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interval, and how Petra overwrites existing log curves.

Restrict Depths
This options opens the "Set Depth Range" tool, which controls the upper and lower
limits of the normalization process. The depth interval can be specified in measured
depth, TVD, or relative to formation tops.

The Set Depth Range

In the Set Depth Range box, select the relevant top, MD, or TVD button. For MD
and TVD, select the relevant button and enter the adjacent depth in the entry field.
For tops, select the desired top from the “Fm Top Name” dropdown box. Notice that
an offset can also be added or subtracted to the fm top; this offset will include data
points above or below the actual fm top depth.
To set depths by a zone’s interval definitions, select the desired zone on the “Set
Upper and Lower Depths From Zone” dropdown menu. Note that the WELL zone by
default covers -1M MD to +1M MD, so it should cover the entire footage of all wells.

Output Curve Update Mode
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This option controls how Petra overwrites curves already in the database. This can
be important for normalizing the same curve over two or more different intervals.
Replace Curve - This option completely replaces the curve in the database with the
latest normalized curve.
Append to Curve Currently In Database - This option simply adds the newly
normalized curve to the existing curve. Where the new curve overlaps the existing
curve, the new curve will overwrite older curve data.

Wells Tab
The Wells Tab specifies which wells will have their curves normalized.

All Selected Wells - This option will normalize the curves for all wells currently
selected in the Main Module
Current Well Only - This option will normalize the curves only on the single well
highlighted in the Main Module.
4.8.1.7.1 Log Normalization Overview

Introduction
Well logs provide the largest source of information available about the variation in
lithology and fluid content within the subsurface. As the computational power
available to the geological community has increased in recent years, the ability to
process and map various rock properties based on digital log data has become
easier. Mapping of these rock properties, either for a reservoir model or a regional
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exploration play, can identify areas where the data does not make any sense in view
of the other subsurface information. Further study may reveal that some rock types,
such as anhydrite, that should have identical properties in all wells, actually has
differing readings in some of the wells. This does not mean that this data should be
eliminated from the study, but only that a higher degree of accuracy is needed for
mapping. The process of log normalization adjusts the log data, in all of the wells, to
have the identical response in an identical lithology; thus making the log data
compatible with each other.
There are numerous reasons why the logging tools do not always provide identical
readings in similar lithologies. These may include, but are not limited to: differing
vintages of logs, differing logging companies, tool design, borehole environment, onsite tool miscalibration, tool malfunction, and improper scaling.

Goals and Philosophy
Prior to any log normalization, one should always keep in mind the final goal of the
project, and ask the question 'how critical is the data to the final interpretation?' For
example, if you are mapping a regional porosity trend which is truncated by erosion,
with no seismic data to support the truncation edge, is it necessary to have the
porosity data to within 1 porosity unit, probably not. If on the other hand, you are
asked to provide the pore volume of a reservoir for an economic analysis for a
potential CO2 flood, then the time would be well spent.
The objective of well log normalization is to improve the dataset, not create it. The
final results using the normalized data are only as valid as the variation (locally and
regionally) in the interval used to normalize the data. If the interval used to normalize
the data turns out to be less consistent than what you originally thought it to be, then
you may end up warping the data to make it consistent with a lithology in one area,
which in reality is erratic in nature across the area. In other words, if you are not
sure that normalization will improve the quality of the data in a particular well, then
leave it alone.
Situations arise which make the normalization process more of an art form than
science. Regional shales that are frequently the only available high gamma ray and
high neutron calibration lithology may have wide variations due to hole enlargement,
or a shaly sand section may not have any suitable low response 'clean' lithology. It
is best that one takes some time in deciding how much variation is in deed present
across the study area, by laying out some logs scattered across the area. How
consistent are the lithologies? Of the consistent lithologies available, do they
represent both the high and low curve readings seen on the logs? Do the high and
low log readings occur near to each other, or are they widely separated in the
wellbore? Do these lithologies extend across the study area? Is it necessary to
correlate only certain zones for data display or is it sufficient just to display the entire
digital dataset? You might consider computing the average gamma ray value over
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the normalization interval using the Compute - From Logs - Statistics menu
contouring the results.
It is best to keep good records, documenting your process of log normalization. One
of the best places to do this is in the project - remarks file. This way, others can
follow your steps in the future, or you can review your methods, when something
doesn't go well. Always create new log curves, leave the original log curve intact.
Sometimes one has to rethink the process and start over. In general, it is best to let
well enough alone and use the results from your best attempt. If the process is
unsuccessful, define your next try in terms of changing the original raw data, not
another attempt on the already manipulated data.
If there are reasonably good normalization lithologies present in the wellbore, then
you should be able to remove approximately 85% of the errors and other 'noise' in
the data (Sheir, 1991). The remaining 15% of the 'noise' could be due to local
changes in lithology, tool inaccuracies, or errors in normalization assumptions.

Which Logs?
Logging tool responses vary, some are consistently more accurate than others. Dan
Shier (1991), indicated in a general terms the percentage of well log types, which
needed to be normalized. The table is reproduced below:

Log Curve
SP
Gamma Ray
Sonic (Compensated)
(Uncompensated have higher values)

% Needing Adjustment
100%
90%
3%

Density
Compensated/Sidewall Neutron

25%
20%

Old Neutron

100%

Induction

<2%

It can be seen that with the SP, gamma ray, and old neutron logs it is best to
normalize all of the logs. For curves like the sonic and induction it is best just to go
through the dataset and select only those wells which are anomalous and set them
aside for later study.
For the intermediate group of logs, including the density and the compensated/
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sidewall neutron logs, the first task is to identify the wells in the study which appear
to be consistent and to be correct. These are the 'type' wells. The other, more
questionable wells are then compared to the nearest 'type' well and accepted as-is
or set aside for normalization.

Method Overview
The objective of normalization work is to adjust all log curves so that they give an
identical reading in an identical lithology. Because we will be re-scaling and shifting
the curve response during normalization it is imperative that the curve be edited for
any cycle skips, spikes or any other digitization errors before anything else is done.
Usually two different 'normalization lithologies' are used, one that has relatively high
amplitude readings, and the other that has relatively low amplitude readings on the
curve to be normalized. These two lithologies need not be found in a single
contiguous zone. The zone(s) containing these 'normalization' lithologies, may or
may not be separate from the 'objective' zone in which maps will be eventually be
made.
The 'normalization intervals' should be correlated through all of the logs and the
'normalization zones' defined (if the entire curve is not be used as the normalization
interval). If there are a number of curves to be normalized, it is better to define a
normalization zone in the database, where all of the separate log 'picks' can be
placed, keeping the general well zone from getting cluttered with data items.
Once these zone(s) have been defined in each well, a value representing the high
and low log reading must be obtained. There are several methods were these
values can easily be obtained:

Method 1:
Display a histogram of the curve to be normalized over the depth range of the
normalization interval. (Histogram-Logs- Set Axes and Scales) The histogram shows
the character of the log and is an excellent tool for picking the mode, mean, and the
edges of the data accurately. Set axes and scales for the appropriate curve. Define
the 'pick' by creating a high and low data item for the curve (example: highgr, lowgr,
highsp, lowsp, etc.). Make the curve part of the data item name, especially if more
than one curve is to be normalized.
Display the log curve to the right of the histogram, this will help when the 'pick' is
made, to eliminate picking any data 'glitches'. Start picking the values in the
histogram by hitting the start button located on the tool bar. With the curve
displayed, pick from the histogram the 'high pick' in the high amplitude interval and
the 'low pick' from the low amplitude interval, by toggling in the drop down menu
between the various data items. Right click on the mouse to have the pop-up screen
to either redraw the screen or to go on to the next well. It is best to do all of the
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wells first, and then come back and review your picks, making any changes as
needed. To reduce the time required to perform this task, you may want to proceed
through all wells doing all of the 'high picks', followed by doing all of the 'low picks'.
After all of the picks have been made, display a frequency plot of each pick (main
panel - zone - view/edit - norm. zone - high (low) - display stats). With the statistics
displayed, record the mean high and the mean low curve values. These two
numbers are the regional high and low normalization values used to normalize the
individual well log in the study.
In the general case, log normalization requires that the log curve be shifted and
scale adjusted at the same time. This is accomplished by applying a linear equation
to each data point on the curve. The basic equation to normalize any curve is:

CRVNRM= LONRM + (CURVE- PICKLO) * (HINRM - LONRM)/ (PICKHI PICKLO)

CRVNRM
CURVE

=
=

Normalized value
Raw value

HINRM
=
individual well's high values)

Regional high normalization value (mean of all

LONRM
=
individual well's low values)

Regional low normalization value (mean of all

PICKHI
zone.highsp)

Well's high normalization value (i.e. zone.highgr, or

PICKLO
zone.lowsp

=
=

Well's low normalization value (i.e. zone.lowghgr, or

Compute the normalized log curve (compute-logs-equation expression either loading
the normalization equation from the saved equations or enter the expression).
Assign values to the equation with the regional high and low values entered as a
constant and assign the well's high and low values from the appropriate zone.
Create a new curve name for the curve that is being normalized, i.e. grnorm, or
spnorm.

Method 2:
This method is very similar to the previous method. A PICKHI and a PICKLO are
computed for each individual well instead of being picked from a histogram. Over
the defined normalization interval, the statistical mean of the curve at the 90th
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percentile (high) and 10th percentile (low) are computed. (Compute-log-statistics,
check the nth percentile and n = 10 or 90 and compute the arithmetic mean over the
normalization interval)
Using the 10th and 90th percentile also eliminates any spurious data due to data
spikes or cycle skips which were not originally edited out of the data. The mean of
the histogram of these values become our regional low normalization value (mean of
10th percentile) and high normalization value (mean of 90th percentile). These high
and low picks can be displayed and modified using the histogram module as the
starting point for method 1 described above. Compute the normalized curve in the
same manor using MEAN90 and MEAN10 for the individual well's normalization
values.

Method 3:
In this method, the normalization interval should include both the high and low curve
readings. Compute the mean and standard deviation of the curve over the interval.
Histogram the mean and the standard deviation computed from all of the wells.
Record the mean of each (i.e. mean of the mean, MEANT, and mean of the standard
deviations, SDT). These 'means' become our regional or type value. The equation
for normalization using the mean and standard deviation is:

CRVNORM= (MEANT- 2*SDT) + (SDT/SDI)*(CURVE-MEANI+2*SDI)

CRVNRM

=

Normalized value

CURVE

=

Raw value

MEANT

=

Regional mean normalization value

SDT
value
MEANI
SDI
or zone.sdsp)

=
=

Regional standard deviation normalization
Well's mean value (i.e. zone.meangr, or zone.meansp)

=

Well's standard deviation value (i.e. zone.sdgr

Checking the Results:
It is a good practice to review the newly normalized curve. Histogram the new curve,
over any interval, and step through the wells, displaying the curve distribution. Note
any well that doesn't fit the general histogram pattern for the interval, and inspect
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them for any obvious problems. These problem wells may have to be re-normalized.

Special Problems
Cased and Open Boreholes
Wells with log runs over both cased and open hole intervals have to be considered
separately. This is especially true with the old neutron logs. In these cases the well
has to be separated into cased and open hole sections and the log normalized over
each portion separately.

Compaction related changes
Differences in compaction history can affect log response. This is not much of a
problem in passive subsidence, but in areas of complex history, this could present to
be a problem. Few sedimentary rocks change little with increasing burial depths,
most notably low porosity carbonates and anhydrite. If these rock types can be
used as normalization lithologies, generally effects of compaction can be ignored.
In sand/shale sequences most rocks display a systematic change with depth. Both
sands and shales become more resistive, higher in density, lower in apparent
neutron porosity and lower in travel time. In these cases, it is best to work with the
shale and the shaly siltstones if at all possible.
Density compaction gradients are in the order of one porosity unit per 2000 feet of
burial. If the structural relief is 2000 feet or less within the area, compaction
changes between wells are not a significant concern. In areas of uniform dip, a
linear trend surface generally provides the best regional pattern to which each well
can be adjusted. If however, the residuals from that surface are non-random, further
investigation is needed.

Comments on Various Log Types
SP Log
The best procedure with dealing with the SP log is to rescale it in units of percent
deflection, where a 0% deflection represents the maximum right hand deflection
(maximum shale) and a 100% deflection represents the maximum left hand deflection
(clean sand). The first step is to establish a shale base line for each SP log. This is
easily picked interactively from the cross section module (logs - pick baseline cutoffs). When this data item is subtracted from the digitized curve, the resulting curve
should ideally have no drift. If the salinity of the formation water does not change
over the digital interval, a histogram of the newly formed driftless curve should
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provide the needed clean (low) and high (shale) picks. This assumes that a clean
sandstone is present within the interval. In cased where only shaly sandstones are
represented, then it is best to set their maximum left hand deflection (clean) at 70%
or some other arbitrary value (i.e. thick submarine fan sections).

Gamma Ray Logs
As a rule regional shale sections are chosen as high-pick gamma ray normalization
zones. Highly radioactive uranium-bearing shales such as the Barnett Shale does not
make a good normalization interval. These shales usually have values, which lie
outside the range of some of the older gamma ray detectors for which they were
designed for (Shier, 1991).
Old gamma ray logs should be converted into API units per the listed chart, prior to
normalization.
Old gamma Ray Log Conversion Units (Hilchie, 1979)

Service Company
API Units
Schlumberger
16.5

Conversion Units
1 ug Ra equiv./ton

Lane Wells
Series 400 (scintillation)
2.16
Series 300 (geiger counter)

1 radiation unit
20.2 counts/minute

1.0
Series 200 (ionization ch.)
216.0

1 standard unit

PGAC
Type F (geiger counter)
14.0
Type T (scintillation)
15.0
McCulloough
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hr.

10.4

Sonic Logs
Sonic logs are not subject to sensitivity problems, where only curve shifting is
required for normalization. The best lithology is to chose a non-porous (limestones
or anhydrites), low travel time interval (lithology) for the normalization lithology.

Neutron Logs
All neutron logs are based on the relationship that porosity is inversely proportional to
the log of the counts/second. A relatively small error in calibration at the wellsite
corresponding to the high porosity lithology leads to large errors in the apparent
porosity of reservoir rocks. A relatively large error the counts/second in tight
lithology produces a small inaccuracy in porosity. In many cases, the zero porosity
is correct, but the high porosity end is off and a scaling factor must be applied.

Old Neutron Logs
Old neutron curves require one additional step, which is not needed for any other
curves (Shier, 1991). This step converts a linear scale of counts/second (but
logarithmic with respect to porosity) to one that is linear with respect to porosity.
Shier (1991) describes the method as picking the PICKHI and PICKLO first from
modern compensated neutron logs. These same high and low values are recognized
on the old neutron logs and recorded. These four data items are entered into the
following equation:

CVNORM = The antilog of:
(Curve*(log Rhp-log Rlp)+(Whc*log Rlp)-(Wlc* log Rhp)) / (Whc-Wlc)

CVNORM
CURVE

=

Normalized neutron porosity in percent porosity

=

Raw neutron porosity in counts/second, etc.

Rlp
percent porosity

=

Regional value of low porosity lithology in

Rhp
percent porosity

=

Regional value of high porosity lithology in

Wlc
second

=

Low porosity lithology for the well in counts/
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High porosity lithology of the well in counts/

Note, if only a few old neutron logs are in the study it is probably best to simply
ignore them for mapping purposes.

Density Logs
Nearly all of the non-porous rocks encountered in the petroleum industry have
densities in the 2.6 to 2.9 gm/cc range. Coal and anhydrite are the exceptions.
Within this density range it's usually possible to establish one good normalization
lithology. Establishing a second reliable normalization lithology at a lower density
level usually proves to be impossible, due to the fact that these lower densities are
affected by hole enlargement and are also frequently blurred by overlapping lithologic
variations. Log normalization is done strictly by curve shifting. This lack of
establishing a reliable low-density lithology does not introduce the inaccuracies that
might be expected because the reservoir beds are not very different in density than
the normalization lithology that was used (Shier, 1991).

Resistivity Logs
It is generally best not to normalize any of the resistivity curves. Use them as-is in
standard log analysis, correcting for mud resistivity, etc. as needed.
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4.8.1.8

Pay Continuity

This function can be used to compute the percentage of pay that is "continuous"
between a well and its neighbors.
Pay in each well is represented by a selected "pay flag" (0 or 1) digital log curve
over one or more Zone intervals. Depth matching in wells is determined by Zone tops
and bases. Pay is considered “continuous” between two neighboring wells when both
zones contain a non-zero pay flag value. The continuity calculation computes the
percentage of total shared pay footage to total pay footage, with adjustments made
for differences in thickness between wells.
Petra compares the amount of continuous pay between a “node” well and its
“neighbor” wells. For each well, pay continuity is computed between the well and its
nearest neighbors. The value stored in each well zone item is the distance-weighted
average of the continuity values computed for each neighboring well.
The utility of a continuity calculation is only as good as the constraining zone
definitions. This calculation works best on a zone with fairly tight depth limits and
with few washouts. A thick zone definition containing multiple pay streaks will
generate worthless numbers.
To open the Log Curve Substitute tool, select Compute>From Logs>Substitute from
the menu bar at the top of the Main Module

Compute Tab
Check the boxes and set the names of the zone items you want to compute.
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Pay Continuity (%) - Zone Item Name for storing pay continuity percentages.
Continuity values range between 0.0 and 1.0.
Avg Continuous Pay - Zone Item Name for storing average number of feet (or
meters) of continuous pay in the "node" well.
Neighborhood Count - Zone Item Name for storing the count of the number of
neighbors used in the calculation for the "node" well.
Total Pay - Zone Item Name for storing total number of feet (or meters) of pay in the
"node" well.
Method of Continuity - Select method 1 or 2 as described above. Method 1
calculates continuity as a percent of the sum of the pays in both wells, while Method
2 calculates continuity as a percent of the total pay in the node well.
Source Code for Computed Items - Enter the source code for storing any zone
items.

Method 1
This method computes continuity as a percent of the sum of the pays in both “node”
well and “neighbor” well.
CONTINUITY = (AC+BC)/(AT+BT)
Where
AC = #ft continuous pay in "node" well A
BC = #ft continuous pay in “neighbor” well B
AT = total #ft of pay in "node" well A
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BT = total #ft of pay in “neighbor” well B

In the above example, Zone I is 100% continuous between wells A and B. Zone II is
discontinuous, i.e., 0% continuous. Zone III would be (10'/15') or 66% continuous.
For well A, total continuity, for zones I, II and III, would be 66%.
Where, AC=10, BC=10, AT=20, BT=10 CONT=(10+10)/(20+10)=20/30=0.66666

Method 2
his Method computes continuity as a percent of the pay in the “node” well only.
CONTINUITY = (AC)/(AT)
Where
AC = #ft continuous pay in "node" well A
AT = total #ft of pay in "node" well A

In the above example, Zone I is 100% continuous between wells A and B. Zone II is
discontinuous, i.e., 0% continuous. Zone III would be (5'/10') or 50% continuous. For
well A, total continuity, for zones I, II and III, would be 50%.
Where, AC=10, AT=20 CONT=10/20=0.50

Zone Tab
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Select one or more zones for which you want pay continuity computed. Petra uses
zone interval definitions to limit the interval calculated. If your zone intervals are
defined by the default -99999.0 to +99999.0 MD, you will need to define the zone in
the Main Module.

Options Tab

Distance Search (Radius) for Neighboring Wells - This section allows to limit the
minimum and maximum distance between a "node" well and its neighbors. This limit
is in XY map units.
Maximum Number of Nearest Neighbors Used - set the upper limit on the number of
neighboring wells used to compute values at each node well. For example, if 8 is
specified the 8 nearest wells to the node well are used. The neighbors must also
meet the min-max radius condition. In other words, if a well is too far or too close
than the minimum or maximum distances, it will be ignored.
© 2014

606

PETRA Help

Store NULL If Compute ZERO Value - Check this option when you want null values
stored in place of zero pay values. Normally, if a well's pay flag curve accurately
reflects the logs and has no pay, the computed values should be ZERO.
Report Info – Petra can generate a report of the continuity calculation called
CONTINUITY.TXT in the projects “Reports” folder. This controls the level of report
information generated and can be set to minimum, detailed, or no report.

Pay Curve Tab
Choose the pay flag curve used to represent pay in each wells. A pay flag curve
should have values of 0 for non-pay and 1 for pay. Only wells containing this curve
will be used.

Export Tab
This section allows for the export "control point" files for Pay Continuity, Avg
Continuous Pay, and Total Pay. There will be one set of files for each zone selected.
Each file contains Wsn, Lat, Lon, Z values for the computed data. Points are
computed at the mid-point between a node well and each neighboring well.
These files can be loaded into the map module for posting and contouring using the
"external control point" option.
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Folder To Store LatLonZ File - Click the "Browse" button to select the folder where
the control point files will be saved.
Prefix - You may enter a text string that is used to prefix each of the file names.
Files names are generated using the following format: Prefix_ZoneName_ItemName.
xyz

Reference: "Improved Techniques for Evaluating Carbonate Waterfloods in West
Texas", by George and Stiles, SPE, Nov 1978.

To calculate Pay Continuity, in the main module go to Compute>From Logs>Pay
Continuity…

4.8.1.9

Advanced Transforms

The Log Transformations Module performs a variety of calculations on digital log data.
These calculations range from relatively simple spike clipping and curve splicing to
generating brand new curves and complex petrophysical modeling. Though many of
these tools exist in an abbreviated form in the Log Curve previewer, the tools in the
Log Transformations Module can operate on multiple wells at once and with easier
control over depth ranges.
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To open the Advanced Transform module, select Compute>From Logs>Advanced
Log Transformations from the menu bar at the top of the Main Module

Available Calculations
Amplitude Clipping
Depth Clipping
Copy Curve
Depth Log
Resample Logs
Smooth Logs
TVD Logs
User Model
Facies Log
Cumulative Log Curve
Merge Log Curves
Convert Directional Survey to Curves
Generate Curve from Scratch

Selecting Wells
It’s often useful to only work with a small subset of wells in a project. The dropdown
menu at the top of the module displays the currently selected wells. The Log
Transformations Module can select wells in a few different ways available from Wells
menu bar at the top of the screen.
“Current Well From Main” selects the single well currently selected in the Main
Module. “All Wells” selects all wells available in the project. “By Data Criteria” selects
wells based on a set of nested criteria including well header information, logs, or zone
data. “Wells from Main” selects all wells currently selected in the Main Module.
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Setting Depths
It’s often useful to limit a log transformation to a specific interval of interest.
Calculations can be constrained by zone definition, tops, or by a specified depth (MD
or TVD). On the menu bar at the top of the screen, select Depths> Depths Range
from the menu bar at the top of the screen. This opens the Depths Tab on the
Histogram Data Definition screen.

To set depths by a zone’s interval definitions, select the desired zone on the “Select
Zone(s)” list. Note that the WELL zone by default covers -1M MD to +1M MD, so it
should cover the entire footage of all wells.
To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TVD button. For MD and TVD, select the relevant
button and enter the adjacent depth in the entry field. For tops, select the desired top
from the “Fm Top Name” dropdown box. Notice that an offset can also be added or
subtracted to the fm top; this offset will include data points above or below the actual
fm top depth.
The example above is limited only to the area defined by two tops – 20’ above the
2ND_WALL_CREEK and 20’ below the 2ND_WALL_CREEK_BASE.

4.8.1.9.1 Amplitude Clipping - Log Transform

This transformation clips spikes in the data outside a given minimum and maximum
value. This transformation can also replace a specific data value with a null, which
can be useful when curves contain non-standard null values (such as “-9999” or “0”
instead of the more common “-999.25”). This log transformation is available on the
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Advanced Transforms tool.

Log To Clip – This dropdown selects the name of the log curve to be clipped. This
option permanently changes the selected log curves, so it’s usually best to retain a
backup set of curves and perform this operation only on a set of copied logs. In the
example above, the GR curve is selected.
Minimum Amplitude Allowed – This option sets the lower limit for clipping. Curve
values below this value will be set to a null value. The default value of -1E30 is so
low that Petra will not perform a minimum clipping. In the example above, GR values
below 0 will be set to a null value.
Maximum Amplitude Allowed – This option sets the upper limit for clipping. Curve
values above this value will be set to a null value. The default value of -1E30 is so
high that Petra will not perform a maximum clipping. In the example above, GR
values above 200 will be set to a null value.
Set to NULL if log is equal to – This option replaces a single value with a null value.
Put another way, all log values equal to the entered data value will be converted to
nulls. This option is most commonly used to correct data that was imported with nonstandard null values like “-9999” or “0.” This function can be used independently of
amplitude clipping.

In the example below, the original curve is on the left and the clipped curve on the
right. Note that the gamma ray values in the clipped curve above 200 API and below
0 have been replaced with null values.
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4.8.1.9.2 Depth Clipping - Log Transform

This transformation erases all log data beyond a specified depth range. The depth
interval can be specified in measured depth, TVD, or relative to formation tops. This
function is useful to reducing log data to just the interval of interest. This log
transformation is available on the Advanced Transforms tool.
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Select Logs To Depth Clip - This dialogue box shows the names of the logs in the
database. Select one or more logs to depth clip. The “All” button selects all logs in
the project, while the “None” button deselects all logs. Remember that this option
permanently changes the selected log curves, so it’s usually best to retain a backup
set of curves and perform this operation only on a set of copied logs. In the example
above, the GR curve is selected.
Set Depths... – This button opens the “Set Depth Range” box. The settings here are
already populated from the Log Transformation module, but can be changed here as
well.

In the example below, the original curve is on the left and the depth clipped curve is
on the right. The GR curve outside these depths 2ND_WALL_CREEK and
2ND_WALL_CREEK_BASE fm tops have been erased.

4.8.1.9.3 Copy Log - Log Transform

This log data transformation creates a copy of a log. It is useful in creating a backup
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copy of a log before doing other transforms. This log transformation is available on
the Advanced Transforms tool.

Log To Copy – This dropdown selects the source log curve that will be copied. In
the example above, the GR curve is selected.
Copy Log To – This dropdown/entry field selects the name of the copied log, which
can be either an existing log or a new log name. In the example above, the GR
curve will be stored to GRD.
Apply Depth Shift To Log Copy – This option shifts the copied log up or down by a
specified footage. Select the check box, and enter a positive shift value to shift the
copied log deeper or a negative amount to shift it shallower.

In the example below, the copied log is displayed next to the original gamma curve.
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4.8.1.9.4 Depth Log - Log Transform

This log data transformation is used to create a depth log matching the depths of a
selected source log. Depth logs have the same depths as the source log in either
measured depth or true vertical depth. Depth logs can be useful for cross plotting or
for working with horizontal wells. This log transformation is available on the
Advanced Transforms tool.

Source Log – This dropdown list selects the source log curve for the depth curve.
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In the example above, the GR curve is selected.
Computed Depth Log – This dropdown/entry field selects the name of the copied log,
which can be either an existing log or a new log name. Note that selecting a preexisting log will overwrite the curve. In the example above, the depth log will be
written to DEPTH. The example below shows a depth curve’s values (on the right)
relative to the original MD (on the right).
In the example below, the source log’s depths are copied exactly to the depth curve.

4.8.1.9.5 Resample Logs - Log Transform

This transform resamples one or more log curves to use a specified sample rate.
This is most commonly used to ensure all logs have the same sample size during log
calculations or models. This function can also convert logs from feet to meters or
vice versa. The Resample Logs tool has two tabs: the Curves Tab and the Options
Tab. This log transformation is available on the Advanced Transforms tool.
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Curves Tab
Function to Perform – This dropdown selects the actual calculation for the selected
log(s). There are five total options. In the example above, the “Resample Logs to
New Sample Rate (Rate is Samples Per Foot or Mtr)” is selected.
Resample Logs to New Sample Rate (Rate is Feet or Mtrs per Sample) – This
option resamples logs based on the number of feet/meters per sample. As an
example, 5 feet per sample results in one sample every 5 feet.
Resample Logs to New Sample Rate (Rate is Samples Per Foot or Mtr) - This
option resamples logs based on the number of feet/meters per sample. As an
example, 5 samples per foot results in a sample every 0.2 feet.
Convert Units Only (Do Not Resample) – This option does not change the sample
rate, but instead converts the MD values to use a different depth unit.
Set Units Flag (No Conversion, No Resample) – This option does not change MD
values or resample, but instead changes the log curve’s units flag.
Interpolate Nulls Only (Do Not Change Sample Rate) – This option interpolates over
gaps in the data, but does not resample the curve.
Select Logs To Resample – This dropdown menu selects one or more log curves
that will be resampled. The “All” button selects all logs in the project, while the
“None” button deselects all logs. In the example above, the GR curve is selected.

Options Tab
New Sample Rate – This option selects the new sample rate, which can be 0.1, 0.2,
0.25, 0.5, 1.0, or 2.0. Note that what this number actually represents is controlled by
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the “Function to Perform” dropdown on the Curves Tab. In the example above, the
sample rate is set to “5”, reflecting “5 feet per sample” as set on the Curves Tab.
The example below shows how a decreased sample rate reduces the number of
points on the gamma curve.
Depth Units – These two dropdowns select the current depth unit of the log and the
desired depth unit of the log.
Curve Start Depth - The “Adjust to Multiple of Rate” option adjusts the first depth of
the curve to ensure that it is a multiple of the new sample rate. To leave the first
depth alone, select “Do Not Adjust.”
Curve Bottom Depth – The “Adjust to Multiple of Rate” option adjusts the last depth
of the curve to ensure that it is a multiple of the new sample rate. To leave the last
depth alone, select “Do Not Adjust.”
Method - This dropdown determines the specific algorithm used to resample the
logs.
Spline Interpolation – This method fits a curve to the data points and extrapolates the
newly resampled data points from this curved line.
Linear Interpolation - This method fits a straight line between every two data points
and extrapolates the newly resampled data points from this straight line.
Linear/No Interpolation - This method simply copies the last data point over the newly
resampled data points, and does not actually reinterpolate through missing samples.
This option works best on discrete data where there are single values separated by
nulls such as core data.

The example below shows the original curve on the left, and a greatly resampled
curve on the right. Note that the resampled curve only has one sample every 5 feet,
greatly degrading the information in the original curve.
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4.8.1.9.6 Smooth Logs - Log Transform

This transformation applies a few different filters to a selected log curve, including a
smoothing filter, a square wave (or box) filter, and a derivative filter. This tool can
apply any combination of the three filters. When multiple filters are selected, Petra
will apply them in the order they are listed from top to bottom. This log
transformation is available on the Advanced Transforms tool.
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Input Log Curve – This dropdown menu selects the desired input log. In the example
above, the GR curve is selected.
Output Log Curve – This dropdown/entry field selects the name of the copied log,
which can be either an existing log or a new log name. It’s usually a good idea to
either make a backup of the original curve or to filter only a copy of the original data.
Note that selecting a pre-existing log will overwrite the curve. In the example above,
the output log will be written to GR_SMOOTH.

Smoothing Filter
The smoothing filter is a rolling average that tends to decrease small scale jitters in
the curve. The filter itself is a rolling average, meaning that for every data point in
the curve Petra examines a number of points above and below. A five-point rolling
average, for example averages the 2 points before the data point, the actual data
point, and the two points after the data point. Petra can apply anywhere from a 3
point rolling average to a 999 point rolling average.
Apply Smoothing Filter - This check box actually applies the smoothing filter to the
logs. Note that the smoothing filter can be applied in combination with the other
filters.
Smoothing Filter Strength - This section controls the details of the smoothing filter.
The “Smoothing Filter Strength” slider bar establishes the number of points used in
the smoothing process: the minimum of 3 points translates to a relatively small
smoothing effect, while the maximum of 999 points greatly smoothes the data –
probably unrecognizably so for most data sets.
Petra makes a distinction between “Triangular” and “Block Average” smoothing. A
triangular filter is a weighted average, where points in the rolling average closer to
the actual data point have more weight than points more distant from the data point.
A “Block Average” filter, on the other hand, gives all data points all equal weight in
the average regardless of its distance from the data point.

The example below shows a smoothing filter with a strength of 35 on the right
relative to the original curve on the left.
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Square Wave (Box) Filter
The square wave filter looks for parts of the curve with rapid changes from high to
low values, and replaces these with flat, boxy interfaces.
Apply Square Wave (Box) Filter – This checkbox actually applies the square wave
filter to the data. Note that the square wave filter can be applied in combination with
the other filters.
The example below shows the box filtered gamma curve next to the original curve on
the left.
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Derivative Curve
A derivative curve highlights the rate of change for a curve to highlight inflection
points in the data; similarly, the second derivative calculates the rate of change of the
derivative to further highlight the differences between inflection points.
Derivative Curve – This checkbox actually applies the derivative filter to the data.
Note that the derivative filter can be applied in combination with the other filters.
Derivative - This section controls the details of the derivative curve filter.
1st and 2nd - The “1st” button calculates a 1st derivative of the input log, and the
“2nd” button calculates a 2nd derivative of the input log.
Window - This entry box sets the width of the derivative calculation; by default, Petra
analyzes a 1 foot/meter window around any specific data point. Larger windows
increase the effect of larger multi-foot transitions and decrease the influence of small
scale changes in the curve.
Abs Value – This button sets the derivative curve to only use positive values. By
default, the derivative curve calculates positive values for positive changes in the 1st
or 2nd derivative, and negative values for negative changes in the 1st or 2nd
derivative.
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The examples below show a 1st derivative curve relative to the original log on the
left, and a 2nd derivative curve relative to the original log on the right.

4.8.1.9.7 Convert TVD Log - Log Transform

This transformation function converts Measured Depth (MD) logs to True
Stratigraphic Depth (TVD) logs, and vice versa. This tool also calculates True
Stratigraphic Depth (TSD) logs from MD logs. This log transformation is available
on the Advanced Transforms tool.
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Log To Convert – This dropdown selects the log that will be converted. In the
example above, the GR log is selected.
Convert From – This option selects the specific calculation. Options include MD to
TVD, TVD to MD, SSTVD to MD, and MD to TSD
New Log - This dropdown list selects the source log curve for the depth curve. In
the example above, the GR curve is selected.

MD to TVD
This option converts a MD log into a TVD log based on the directional survey data
loaded in Petra’s database. Wells without directional surveys will not have a TVD log
calculated.

TVD to MD / SSTVD to MD
This option converts a TVD or SSTVD log into a MD log based on the directional
survey data loaded in Petra’s database. Wells without directional surveys will not
have a log calculated.

Convert MD to TSD Log
This option converts a measured depth log to a TSD (true stratigraphic depth) log. A
TSD generates an estimate of true bed thickness log by accounting for the effect of
a well passing through dipping stratigraphy. The resulting TSD log will have a
starting depth equal to the TVD of the first log sample. Note that selecting this
calculation creates the Structure and Depths Tab.

Structure Tab
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The MD to TSD calculation requires an estimation of bed dip and azimuth. The
values can either be zone items, constants, or logs. Dip is measured in degrees
from horizontal where positive numbers are dipping downward; a flat dip is 0, a slight
downward dip is 1, and a slight upward dip is -1. Azimuth is measured in degrees
measured clockwise from north where North=0, East=90, South=180, and West=270
degrees.

To use zone data, select the appropriate zone and the specific data items containing
dip and azimuth. The advantage of using zone data is that each well’s dip and
azimuth can be individually tailored.
To use a constant dip and azimuth, enter the relevant numbers into the “Dip” and
“Azimuth” fields. Practically, using a constant dip and azimuth suggests a rigid
monoclinal dip over all wells in the calculation. In the example below, the dip is 15
downward with an azimuth of 67 degrees.
To use log data, select the well names for the dip and azimuth curves. This method
is probably the most precise, though it is limited only to wells with dipmeter logs.
Values are Apparent Dip and Azimuth – This option sets the bed dip equal to the
borehole dip.

Depths Tab
Set Depths... – This button opens the “Set Depth Range” box. The settings here are
already populated from the Log Transformation module, but can be changed here as
well. In the example below, the interval between the 2ND_WALL_CREEK and
2ND_WALL_CREEK_BASE fm tops are selected – Petra will not calculate a TSD
curve outside these depths.
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4.8.1.9.8 User Model - Log Transform

User models can perform log analysis functions such as computing clay volume, water
saturation, effective porosity or any other calculation involving one or more log curves.
The model is executed one time through for each depth or sample increment in the
selected depth interval. Users should be familiar with programming languages such
as FORTRAN before attempting to create or modify a user model file. All models
must end in a .TXT extension.
This log transformation is available on the Advanced Transforms tool.
User Model File – This dropdown lists the existing user models in Petra’s USERMOD
subdirectories. For standalone licenses, both the “Shared” and “Private” directories
are C:\geoplus1\USERMOD by default. The network location of the USERMOD folder
will depend on the installation. Commonly, for network licenses, the “Shared”
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directory will be in the PetraSERV\USERMOD directory, and the “Private” directory
will usually be in the client geoplus1\USERMOD directory.
Compile Model – This button loads the model into Petra’s memory and populates the
Input and Output Tabs with variables.
Execute Model – Once the model is compiled and all input and output variables are
assigned, this button actually runs the user model.

Model Tab
View Model – This option opens a read-only text editor with the currently selected
model. Changes made here cannot be saved.
Modify Model – This option opens a text editor with the currently selected User
Model. Changes made to the model can be saved.
New Model – This option attempts to open C:\geoplus1\USERMOD\Untitled.TXT with
the computer’s default text editor.
Refresh List – This option refreshes the User Model File dropdown list at the top of
the User Model Transform tool.
Delete – This option deletes the currently selected User Model.
Copy As… - This option copies the currently selected User Model with a userselected name.
Copy to Private Dir – This option saves the user model to the private directory. Once
in the private directory, the specific user model can be accessed by the user in any
project.
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Copy to Public Dir – This option saves the user model to the public directory. Once in
the public directory, the specific user model can be accessed by any user in any
project.

Input Variables Tab
User Models can use log curves, constant values, zone data items, 'NULL' values,
'DEPTH' or 'STEP' values as input variables. Each input variable should be assigned
to the appropriate database entity.
To assign a model variable, select the variable name listed in the “Input Variable
Assignments" list. Next, select the relevant log, zone item, constant, or "Other" item
(including nulls, depth values, sample rates, TVD or SSTVDs). Select the “Apply”
button to set the assignment and add it to the ”Input Variable Assignments” list.
Load Assignments – This option loads a saved set of input variable assignments.
Save Assignments - This option saves the existing set of input variable assignments.
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Output Variables Tab
The model stores one or more output log curves stored in the log database. These
logs can be either be existing logs or new log names.
To assign an output model variable, select the variable name listed on the "Output
Variable Assignments" list and select the desired output log. To create a new log
name, type the log name in the "Log" drop down list. Click the Apply button and the
log definition dialog screen will prompt you for the log units and description. Output
logs computed in the model but not stored back in the database can be specified as
"UNASSIGNED".
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Options Tab
The Options Tab sets how Petra handles missing curves and establishes a depth
range for the calculation.
If well is missing an input log – This dropdown establishes how Petra handles missing
values. Petra can either skip wells missing any input values, or can simply assign
missing values a NULL value.
Set Depths... – This button opens the “Set Depth Range” box. The settings here are
already populated from the Log Transformation module, but can be changed here as
well. Deselecting the “Restrict Model to Depth Limits” will run the user model over the
entire depth range of the well.

Messages Tab
The Messages Tab provides the results of the user model, including which wells failed
to go through the model due to missing data.
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Creating User Models
User models are text files that contain the programming logic to perform complicated,
multi-line equation and conditional operations on logs. The User Model Transform sets
the input and output variables, establishes how Petra handles missing or incomplete
data, and runs the models.

Statements
Each statement in the model consists of variables, operators, and keywords. Each
statement in the model is terminated with a semicolon (;). Statements may be
continued over more than one line. An operator or delimiter, such as a space or
parenthesis separates constants, variables, and numbers. Statements which control
the flow of the program logic contain keywords "GOTO", "IF...THEN...ELSE", or
"BEGIN...END". Branching is done using statement LABELS placed on a line prior to
the point of continued processing. Each label consists of a character string
terminated by a colon (:). Examples of labels are LABEL1:, L999: and DONE:.

Variables
Variables can be named up to a maximum of 40 characters.

Log Definitions
LOGDEF statements precede all other declaration statements, and define the log’s
name, units, and descriptions. Log definitions use the syntax:
LOGDEF NAME(logname) UNITS(units) DESC(description);
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Example:
LOGDEF NAME(GRTEMP)

UNITS(API) DESC(GAMMA RAY);

Comments
An exclamation mark (!) or double forward slash (//) defines the beginning of a
comment. A ! or // in column one will comment an entire line, while a ! or // comment
text following the semicolon (;) will create an in-line comment.
Examples:
! this is a commented line.
A= B + C; ! this is an in-line comment.
// this is a comment as well
X = Y/Z;

// and so is this

Symbols and Keywords
(;)

End of statement terminator

(!)

Comment indicator (start comment)

(:)

Label terminator

Space

Delimiter

IF

Test control word

THEN

Continuation of test

THEN BEGIN
ELSE BEGIN
GOTO

Starts "TRUE" condition of test
Starts "FALSE" condition of test
Branch to a label

CONSTANT

Declare constant

LOG

Declare curve

LOGDEF

Defines new curve in database

IN

Declare LOG curve as input only

OUT

Declare LOG curve as output only

UPDATE
and

Declare LOG curve as input but may be modified
stored back in the DB
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DO

Do loop

END

End THEN BEGIN or ELSE BEGIN section

ENDDO

End Do Loop

ENDMOD

Terminates the model

Functions
Function

Keyword

Example

------------

------------

-------------

Add

+

A+B

Subtract

-

A-B

Multiply

*

A*B

Divide

/

A/B

Exponential

** or ^

A**2 or A^2 (A squared)

Assign
Compare equal

=

A = 1.0
= or .EQ.

IF(A=B) THEN...

or

Compare not equal

.NE.

IF(A.NE.B) THEN

Logical AND

.AND.

IF( A=B) .AND. (C=D))...

Logical OR

.OR.

IF((A=B).OR.(C=D))...

Greater than

> or .GT.

IF(A.GT.B)...

Less than

< or .LT.

IF(A<B)...

Greater or equal

>= or .GE.

IF(A.GE.B)...

IF(A.EQ.B) THEN...

Less or equal

<= or .LE.

E to power of X

EXP(x)

Log (natural)

LN(x)

Log (base 10)

LOG10(x)

Absolute value

ABS(x)

Square of X

SQR(x)

Square root of X

SQRT(x)

Negative (-x)

NEG(x)

Truncate to integer

TRUNC(x)

IF(A.LE.B)...
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Sign of number times 1
BEGIN;

SIGN(x

IF(SIGN(x)=-1) THEN

Round to 2 dec places

ROUND(x)

Maximum of x and y

MAX(x,y)

Minimum of x and y

MIN(x,y)

Remainder of x / y

MOD(x,y)

Sine of x

SIN(x)

x is in degrees

Cosine of x

COS(x)

x is in degrees

Tangent of x

TAN(x)

x is in degrees

Arcsine of x

ASIN(x)

angle returned is in degrees

( -1 >= x <=1 )
Arccosine of x

ACOS(x)

angle returned is in degrees

( -1 >= x <=1 )
Arctangent of x

ATAN(x)

angle returned is in degrees

( -1 >= x <=1 )
Ternary Interpolation Functions
A = ATERN(Ax,Ay,Bx,By,Cx,Cy,x,y);
B = BTERN(Ax,Ay,Bx,By,Cx,Cy,x,y);
C = CTERN(Ax,Ay,Bx,By,Cx,Cy,x,y);
SW = INTERN(Ax,Ay,Bx,By,Cx,Cy,x,y);
or
SW = TERNIN(Ax,Ay,Bx,By,Cx,Cy,x,y);

Ternary iterpolation functions can be used to solve a triangular phase diagram defined
by the vertices, AxAy, BxBy, and CxCy. Given the point x,y:

ATERN computes the percentage of A from 0-100,
BTERN computes the percentage of B from 0-100, and
CTERN computes the percentage of C from 0-100.
INTERN or TERNIN returns 1 if xy is inside the ternary triangle and 0 if outside.
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Parenthesis
Binary operators are defined as an expression enclosed within parentheses, such as,
(x+y) or (x*y). Statements require parentheses only when more than one binary
operation is used or when you wish to force the evaluation precedence. The normal
operator precedence from lowest to highest is:
+ and * and /
**
unary - (minus sign)
The expression A+B*C**D/E-F is equivalent to (A+((B*(C**D))/E))-F and would be
evaluated in the following steps. Intermediate expressions are shown in braces.

K = C**D

[A+B*K/E-F]

L = B*K

[A+L/E-F]

M = L/E

[A+M-F]

N = A+M

[N-F]

O = N-F

Parenthesis force the sub-expression enclosed to be evaluated first, as illustrated
below.
(A+B)*C**D/(E-F)

K = A+B

[K*C**D/(E-F)]

L = C**D

[K*L/(E-F)]

M = K*L

[M/(E-F)]

N = E-F

[M/N]

O = M/N

Declaration Statement
The declaration section is the first part of a model program in which the input and
output logs and constants are defined. Each declaration statement consists of a
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"type" keyword, a variable name, and a "use" keyword. It is not necessary to
declare temporary variables; temporary variables are defined for the first time with an
assignment statement.
Examples:
LOG SW

IN;

LOG RHOB

OUT;

CONSTANT

SAND

CONSTANT

NULL;

2.5;

! value is optional
! assumed to represent NULL log value

Executable Statement
An executable statement is any statement in which an equation type calculation is
performed or an assignment is made. The general form is:
ASSIGNMENT_VARIABLE = executable_statement;

Examples:
x = a * b;
x = (a*(b+c))/(x-y);
Note that each line is terminated with a semicolon (;) and the equal sign (=) is
required. Variables appearing on the right side of the equation must either be
declared as constants, logs, or be temporary variables defined as the result of an
earlier assignment statement.

GOTO and Label Statement
The "GOTO" keyword and following label is used to branch to another part of the
program.
Example:
IF ( x > 0.0 ) THEN GOTO DIVIDE;
y = 0.0;
GOTO MORE;
DIVIDE:
y = y / x;
MORE:
statement;
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statement;
etc.

IF-THEN Statement
The IF-THEN statement conditionally executes a single assignment statement, GOTO,
or BEGIN-END group based on the results of a logical comparison.

Example:
IF( GR = NULL ) THEN GOTO DONE;
IF( B .NE. 0.0 ) THEN C = A / B;
IF( SW > 0.75 ) THEN BEGIN;
SW3 = (1-SW)**3;
SW = 1-(16/3)*SW3*(5-128*SW3);
END;

IF-THEN-ELSE Statement
The IF-THEN-ELSE compound statement provides conditional processing in a clear
and efficient manner without the use of a GOTO.

Example:
IF ( logical expression ) THEN BEGIN;
statement;
statement;
etc.
END;
ELSE BEGIN;
statement;
statement;
etc.
END;
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DO-LOOP Statement
The DO loop statement is used to repeat a section of the model a set number of
times.
The general format of the DO loop is:

DO counter = first TO last;
statement;
statement;
etc.
ENDDO;

Example:
The following example sums values from 1 to 10. "A" is summed when K is even and
"B" is summed when K is odd.
SUM = 0.0;
N = 10;
DO K = 1 TO N;
IF( MOD(K,2)=0) THEN BEGIN;
SUM = SUM + A;
END;
ELSE BEGIN;
SUM = SUM + B;
END;
ENDDO;
4.8.1.9.9 Facies Log - Log Transform

This transform uses log crossplot polygons to create new logs based on
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petrophysical criteria. The Log Crossplot Module plots log curve values from the
same depth together on a XY scatter plot or a ternary diagram. Regions on this
crossplot, when outlined by polygons, represent specific combinations of two or
more logs. Petra refers to these polygons as “facies.” This transform creates a
new log based on the crossplot facies; when the log data fits inside a polygon, the
polygon’s facies value is stored to the log. Facies logs can represent anything from
pay flags to complete lithology descriptions.
As an example, the crossplot below shows gamma and resistivity curves. The
polygon drawn on the log data represents the productive interval where gamma is
lower than lower than about 90 API units and resistivity is above 10 ohmm. The
polygon outlining the region has a facies value of 1. A facies curve transform applies
this polygon to other wells. The depths were the gamma and resistivity curves fall
inside this polygon are assigned the polygon’s facies value of 1, and the parts of the
well where the gamma and resistivity curves fall outside this polygon remain a null
value.
This log transformation is available on the Advanced Transforms tool.

This transform requires a set of polygons. These files are created in the cross plot
module and have a *.XPP file extension. When opening the Facies Transformation
tool, Petra by default opens the current project’s PARMS directory. Select the
desired polygon file. In the example below, the GR PAY.XPP file is selected.
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Petra then opens the Facies Log from Cross Plot Polygons tool. This tool is divided
into several different tabs.

File Tab
The File Tab displays the selected polygon file, as well as the polygon file’s
comments. To change the selected polygon file, select the “Browse” button. By
default, facies polygon files are stored in the project parms directory.

Logs Tab
The Logs tab sets the logs used in the facies curve calculation.
X-, Y-, and Z-Axis – These dropdown menus change the logs used in the crossplot
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calculation. By default, Petra will load the logs from the facies polygon. Changing
the logs will keep the polygon cutoff values the same. In the example below, the GR
and ILD curves are loaded in the X and Y axis.
Use Log Aliases – The transformation is picky about the exact curve name; if any of
the X, Y, or Z logs are missing for a well, no output log is computed. This option
tells Petra to use log aliases during the transformation.
Output Facies Log – This option his window also changes the name of the output
facies curve; by default this is set to “FACIES” as in the example below. To change
the name, just enter in a new curve name.

Facies Tab
The Facies Tab sets the actual values used in the facies curve.
Default Facies Value – This option sets the value assigned to the output log when the
cross-plotted point does not fall in any of the polygons. Set a numeric value or enter
the word NULL the use a null value for the default. In the example below, it’s set to
0.
Log Values For Each Facies Polygon – This window lists each of the polygon names
along with their respective facies values. By default, Petra uses each polygon’s
“facies value” created in the Log Crossplot Module. To change a polygon, select the
polygon name on the list, and change the value on the “Edit Value” box. Select the
“Change Value” button to accept the changes. In the example below, depths where
the gamma ray and deep resistivity fall into the “PAY” polygon will be coded as 1 on
the facies curve, while all other depths will be set to zero.
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Discriminators Tab
The Discriminators tab filters data points by log criteria. To set a discriminator
curve, select up to 5 curves and set the scale using the minimum and maximum entry
boxes. Data points that fall outside of these data criteria are not included in the
facies curve and will be given the default facies value entered on the Facies Tab.
To use a discriminator, first select a log curve, enter the min and max values. Be
sure to click the "Use" box beside the log name. The particular discriminator will not
be used unless this option is checked.

The example below shows the original log on the left and the output facies curve on
the right. The facies curve is plotted on a 0- 2 scale, with everything above 0 filled in
with red. The depths where the gamma and resistivity curves fall within the polygon
are set to 1 and plotted as red, while the depths where the gamma and resistivity
curves fall outside the polygon are set to zero and don’t show on the log.
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4.8.1.9.10 Cumulative Log - Log Transform

This transformation generates a curve in which each curve sample is the summation
of all previous curve samples. This log transformation is available on the Advanced
Transforms tool.

Standard Summed Curve
The “Standard Summed Curve” simply adds all preceding curve samples. This
summation can start at the top and go down, or start at the bottom and go up.

Cumulative Probability Curve
The “Cumulative Probability Curve” calculates the probability for every value on the
curve that another point has a higher value. An as example, a depth with a
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cumulative probability of 0.10 means that the corresponding curve has a 10%
chance that points will be greater than or equal to that value. In the examples below,
the original depth vs. gamma ray curves is on the left, and the depth vs. cumulative
probability curve is on the right.

In more detail, Petra calculates the cumulative probability curve in three steps:
1. Sort the curve from low to high value. Assign a sort number to each value
starting from 1.
2. Divide each point’s sort number by the total number of sort values (n) plus 1. In
the example below
3. Re-sort the data by depth, storing the probability to the output curve

Cumulative Curve Type – This option chooses between the “Standard Summed
Curve” or the “Cumulative Probability Curve.”
Summation Direction - This option selects whether the summation will add values
from top to bottom, or from bottom to top.
Apply Sample Rate to summed Values – This option corrects for different sample
rates in the logs. A well with a 0.5’ sample rate will have twice as many values and
twice the total summation as a well with a 1’ sample rate. Put another way, this
option multiplies the curve values by the curve sample rate during summation.
Log Curve To Convert – This option selects the input log. Note that, unless the log is
selected as the “New Cumulative Curve”, this log does not change in any way. In the
example above, the GR curve is selected.
New Cumulative Curve – This option selects the name of the newly created
cumulative log.
The example below on the left shows the original log next to the cumulative curve on
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the right. The scale for the cumulative curve ranges from -110 to 5630, reflecting the
high sum of all gamma ray values. The example below on the right shows the
original log next to the output cumulative probability curve. Note that the gamma
curve is on a 0-200 scale, while the probability curve is on a 0-1 scale.

4.8.1.9.11 Merge Log Curves Transform

This transformation splices together several log curves into a single log. This can be
particularly useful for combining several different log runs into a single curve in Petra.
This log transformation is available on the Advanced Transforms tool.
Source Curves to Merge – This option selects the curves to splice together.
Target Curve (Merge Into) – This option selects the destination curve.
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This tool obeys a couple of rules when two or more logs have overlapping non-NULL
values. Petra always preserves the target curve’s values, and won’t write overwrite
values from any of the source curves. In the example above, Petra won’t overwrite
any values already in the “Combined” target curve. Additionally, when two or more
source curves overlap, Petra will use the first source curve listed. In the example
above, Petra will use RUN1’s values over RUN2, and RUN2’s values over RUN3.
To reorder the Source Curves to Merge list, go to the Logs Tab on the Main Module.
Here, select the Maintenance button to open the Log Maintenance window. Select
“Set Display Filter.” Here, reorder the log curve names as desired.

.
4.8.1.9.12 Directional Survey To Log Curves

This transformation generates new curves relative to MD based on directional survey
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data. Petra generates an X and Y curve automatically. This log transformation is
available on the Advanced Transforms tool.

X-Offset Log Curve – This option sets the name of the X Offset Curve. By
convention, offsets to the north are positive and offsets to the south are negative. By
default, Petra will name this curve “XOFFSET”; to change the filename enter a new
name or select a different curve from the dropdown box. There is no option to turn off
this curve.
Y-Offset Log Curve - This option sets the name of the X Offset Curve. By convention,
offsets to the east are positive and offsets to the west are negative. By default,
Petra will name this curve “YOFFSET”; to change the filename enter a new name or
select a different curve from the dropdown box. There is no option to turn off this
curve.
TVD Curve – This option creates a True Vertical Depth (TVD) curve relative to MD.
By default, Petra will name this curve “TVD”; to change the filename enter a new
name or select a different curve from the dropdown box. The option box to the left
toggles this curve’s creation on and off.
MD Curve - This option creates a Measured Depth (MD) curve relative to MD. By
default, Petra will name this curve “MD”; to change the filename enter a new name or
select a different curve from the dropdown box. The option box to the left toggles this
curve’s creation on and off.
DIP Curve - This option creates a wellbore dip/inclination curve relative to MD. By
default, Petra will name this curve “DIP”; to change the filename enter a new name or
select a different curve from the dropdown box. The option box to the left toggles this
curve’s creation on and off.
AZM Curve - This option creates a wellbore azimuth curve relative to MD. By default,
Petra will name this curve “DEVI”; to change the filename enter a new name or select
a different curve from the dropdown box. The option box to the left toggles this
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curve’s creation on and off.

4.8.1.9.13 Generate Curve From Scratch

This transformation generates a new log with a single selected value over a set depth
range. This log transformation is available on the Advanced Transforms tool.

Output Curve – This option sets the name of the newly created log. This option can
select an existing curve in the database, or create a new name. Setting the name to
an existing curve name will completely overwrite the old curve. In the example below,
the tool will create a new curve called “TEST.”
Depth Range – The “Set Depth” option establishes the upper and lower range of the
new curve. These depths can be set by FmTops, MD, or TVD. In the example
below, the new curve will start at 300’ MD and go to 500’ MD.
Sample Rate – This option sets the spacing between data points, or sample rate, of
the data in samples per foot/meter. In the example below, the sample rate is set to
1, so the curve will have a data point at every foot.
Curve Value – This option sets the value actually saved versus MD. In the example
below, the curve will read as a solid string of 1s all the way from top to bottom.
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4.8.1.10 Pay Report

The Pay Report generates a listing from digital log curve data over one or more
selected user zone intervals. The report shows a foot-by-foot listing of the curve
values as report columns. The user may define a "summary type" for each column,
such as, average value, total, cumulative, etc.
To open the Pay Report tool, select Compute>From Logs>Pay Report from the
menu bar at the top of the Main Module

Zones Tab
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Select Zones To Report Pay - Choose one or more zone intervals for which you want
the pay report.
Report Wells - The report can list all selected wells or just for the current well.
Depth Increment for Report - This option controls the sample rate for the foot-byfoot listing. You can either use the sample rate for the log curves or specify a
different sample rate. For example, if you have curves sampled at 0.25 feet, you
might create a report and list only every 1 foot. The sample rate is given in feet/
sample (or meter/sample).

Log Curves Tab

Report Column Definitions - This section displays the report columns. Each column is
associated with a log curve and shows the curve name, the column title for the
report, the column width in characters, the number of digits to the right of the decimal
point, and summary type.
Use Aliases - This option allows Petra to use log curve aliases.

Sum Type
Summary type can be changed by clicking the left mouse button on the "sum type"
cell for a specific column. Available types are:
None - Column will have no summary values.
Total - The column summary will show the total sum of the curve values.
Total (weighted by rate) - The total sum will be multiplied by the sample rate. For
example, if the curve in the column was a "pay flag" and the sample rate was 0.5,
the total "pay" would be the 1/2 of the total count which would reflect the actual
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number of feet of pay.
Average - The average curve value is displayed.
Average (non-zeros only) - Zero-valued curve samples are excluded from the
average calculation.
Cumulative - The running total is displayed for each sample.
Minimum - The minimum curve value is listed at the bottom of the column.
Maximum - The maximum curve value is listed at the bottom of the column.

Discriminator Curve
This option uses a discriminator curve to filter the statistical data. At depths where
the discriminator curve contains a 0 or null value, the corresponding depth will be
skipped in the pay report. If this box is checked and the discriminator log is absent,
the pay report will not be calculated.

Available Curves List
To Add a Curve as a Report Column - Select the curve in the "available curves" dropdown list. Chick the "Add Curve" button. Set the "sum-type".
To Replace a Curve - Select the curve in the "available curves" drop-down list. Click
in the curve title cell for the column to replace. Then click the "Replace Curve" button.
To Drop a Curve Column - Click in the curve title cell for the column to replace. Then
click the "Drop Curve" button.

File Tab
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Load Template - This button loads an external Pay Report temPlate (*.PRP) file.
Save Template - This button saves the current color scheme to an external Pay
Report temPlate (*.PRP) file

EXAMPLE REPORT

======================================================
Well: 42201077770000 A-1 1 1 [1]

Zone Summaries
DEPTH
-----------------

GRPAY
--------

GR

--------

GR

--------

GR

--------

GR

--------

6671.00- 6743.00

41.00

69.56

5703.86

43.18

97

: AB

6743.00- 6765.82

15.00

72.84

2185.30

39.59

87

: BC

-----------------

--------

--------

TOT(WT)

--------

AVG

-------CUM

-------MIN

Zone : AB "A" 6671.0000 to "B" 6743.0000

DEPTH
--------
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GRPAY
--------

GR

--------

GR

--------

--------

GR

GR

--------

6671.00

1.00

77.75

77.75

77.75

78

6671.50

1.00

67.60

145.35

67.60

68

6672.00

1.00

56.72

202.08

56.72

57

6672.50

1.00

45.21

247.29

45.21

45

6673.00

1.00

44.04

291.33

44.04

44

6673.50

1.00

44.02

335.35

44.02

44

6674.00

1.00

44.46

379.81

44.46

44

6674.50

1.00

45.21

425.02

45.21

45

6675.00

1.00

45.50

470.53

45.50

46
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6675.50

1.00

47.52

518.05

47.52

48

6676.00

1.00

48.04

566.09

48.04

48

6676.50

1.00

48.94

615.03

48.94

49

6677.00

1.00

51.77

666.81

51.77

52

6739.00

1.00

86.85

5373.71

86.85

87

6739.50

1.00

80.84

5454.56

80.84

81

6740.00

1.00

75.52

5530.07

75.52

76

6740.50

1.00

76.40

5606.47

76.40

76

6741.00

1.00

97.39

5703.86

97.39

97

.
.
.

--------

-------41.00

--------

--------

69.56

TOT(WT)

--------

5703.86

AVG

--------

43.18

CUM

MIN

Zone : BC "B" 6743.0000 to "C" 6765.8167

DEPTH
--------

GRPAY
--------

GR

--------

GR

--------

--------

GR

GR

--------

6746.50

1.00

98.07

98.07

98.07

98

6747.00

1.00

92.33

190.40

92.33

92

6747.50

1.00

89.07

279.47

89.07

89

6748.00

1.00

88.87

368.34

88.87

89

6748.50

1.00

90.19

458.53

90.19

90

6749.00

1.00

95.99

554.52

95.99

96

.
.
.
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6764.50

1.00

90.52

2009.91

90.52

91

6765.00

1.00

88.87

2098.78

88.87

89

6765.50

1.00

86.51

2185.30

86.51

87

--------

-------15.00

--------

--------

72.84

TOT(WT)

AVG

--------

2185.30
CUM

653

--------

39.59
MIN

4.8.1.11 Sum Raster Pay Within Zone

The Sum Raster Pay Within Zone tool adds pay intervals within a zone together, and
stores the value in a zone data item. This can be useful for net pay mapping.
To open the Sum Raster Pay Within Zone tool, select Compute>From Logs>Sum
Raster Pay Within Zone from the menu bar at the top of the Main Module

Zones Tab
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Select Zones For Depth Interval
This list displays all the zones in the project. Selecting a zone will set the location of
the data items calculated (the computed value and the pay count) as well as set the
upper and lower limits of the calculation. By default, this tool searches for pa intervals
within the top and base set by the the selected zone's interval definition. To ignore
the zone's interval definition, make sure to select the "Use Bounds Depths Even if
Zone Depths are Undefined" option on the Depths Tab.

Select Type of Pay Value To Compute
Total Pay Thickness - This calculation returns the summation of all pay intervals in the
zone.
Average Pay Thickness of Each Pay Interval - This calculation returns the average
thickness of all pay intervals in the zone.
Maximum Thickness of Any Pay Interval - This calculation returns the thickness of the
thickest pay interval in the zone.
Minimum Thickness of Any Pay Interval - This calculation returns the thickness of the
thinnest pay interval in the zone.

Zone Item To Store Computed - This entry sets the data item that will store the
computed value. Petra automatically attempts to create a data item name based on
the type of pay value computed. Note that this data item will be located inside the
zone selected on the "Select ZONES For Depth Interval" list.
Zone Item To Store Pay Count - This tool can also calculate the number of pay
intervals in the zone for each well. This entry sets the name of the data item that
stores this count. Leaving this entry blank will disable the count.
Zone Item Source Code - This entry adds an additional source code to the calculation.
Substitute TD if Bottom of Zone Is Missing - Petra uses the selected zone's interval
definition to establish the depth window for the raster pay calculation. By default, if
the lower boundary is missing, Petra will return a null value. This option instead
substitutes the TD of the well for wells missing the base of the zone.
Apply TVD Correction - This option attempts to correct for deviated and horizontal
wells by converting raster pay intervals picked in MD into TVD footage.
Store NULL Instead of Zero When No Pay is Picked - By default, Petra stores a 0
when no raster pay exists within the interval. This option instead stores a null value.
Do Not Overwrite Zeros With Nulls - Generally, Petra overwrites the selected data
item whenever this calculation is run. With this option selected, Petra will not
overwrite wells with a 0 value in the data item with nulls.
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Pay Tab

Select Pay Interval To Sum - This list displays all the raster pay names in the project.
Here, select one or more pay names for the calculation.
Source - This dropdown limits the pay names to only those with a selected source
code. This can be useful for filtering out extraneous or irrelevant pay names.

Filter Tab

Depth Bounds
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Limit Depths within a Zone to the Interval Below - This option enables additional depth
bounds for the raster pay summation.
Const Depths - The upper and lower entries set bounds on the summation by a simple
MD or SS depth range.
Fm Tops - The upper and lower boundaries within the zone are set by two formation
tops.
Use Tops Aliases - This option allows Petra to use log curve aliases.

Use Bounds Depths Even if Zone Depths are Undefined - This option ignores the
selected zone's interval definition, and only uses the depth bounds set on the Filter
Tab.
4.8.1.12 Storing Log Curve Statistics to an Interval

It’s sometimes useful to extract numerical data from log curves to an interval. More
specifically, this tool calculates statistics over a selected log curve between the top
and base of each interval and stores the result as a interval data field. This statistical
measurement is stored to a data field in a selected interval table. When stored as
interval data, log curve statistics can be easily used in petrophysical calculations or
compared with other interval data fields.
To open the Log Stats To Interval Data tool, select Compute>From Logs>Extract Log
Stats to Int Data… from the menu bar at the top of the Main Module

Select Log Data From
First, select the desired log curve from the dropdown menu at the top of the screen.
In the example below, the GR curve is selected. Note that this tool will calculate log
statistics on aliased curves, as well.
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Interval Data Tables
Next, select the desired interval table from the “Interval Data Table” on the lower left
side of the screen. In the example below, the LITH” table is selected, so the statistics
measured will be stored in interval data fields in the LITH table

Stats to Extract
Finally, select the desired statistics and the desired location. In the example below, a
mean (or average) will be calculated for the GR log. The calculated average will be
stored in a interval data field called “GammaStat.” Petra stores statistics out to 7
decimal places, even though the interval data field may only show fewer trailing
decimals.

4.8.2

Using Zones
To open any of Petra's zone compute tools, select Compute>From Zones from the
menu bar at the top of the Main Module.

Isopach
TST and TVT
Equation Expression
Substitute
Substitute TD for Missing Zone Base
Z Summation
Multiple Regression Analysis
Neighbor Statistics
4.8.2.1

Isopach Calculation

Isopach thickness can be computed for one or more defined zones simultaneously.
To calculate an isopach from the zone definition, select Compute-From ZonesIsopach from the menu bar at the top of the Main Module.

Method Tab
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Zone Definitions - This option calculates isopach thicknesses using zone interval
definitions defined in the Main Module. By using interval definitions, Petra can
calculate multiple isopach values at one time.
Formation Tops - This option calculates isopach thicknesses using two formation
tops. This method can only calculate the thickness of a single interval at one time.

From Zones Tab (Calculating from Zone Definitions)
This tab appears when the "Zone Definitions" method is selected on the Method Tab.

Output Name for Computed Isopach Variables
These options set the details on the data items that contain the calculated isopach
value. When multiple zones are selected, Petra will create data items in every zone
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that have the same name, source, and description.
Name - This option sets the name of the data item that will contain the computed
isopach values.
Source - This option sets the source code for the isopach zone data item.
Description - This option adds a description source code for the isopach zone data
item.

Select The Zones for Isopach Calculation
This section lists the names of all user-defined zones. Use the mouse to highlight
those zones for which you want the isopach variable computed. The "All" button
selects all user-created zones, while the "None" button deselects all zones.

From Tops Tab (Calculating from Formation Tops)
This tab appears when the "Formation Tops" method is selected on the Method Tab.

Top of Isopach - This dropdown selects the top of the desired interval.
Base of Isopach - This dropdown selects the base of the desired interval.
Store Computerd Isopach Values In - This entry sets the data item that will contain
the computed isopach values. The upper dropdown sets the desired zone, and the
lower dropdown sets the desired data item.

Use Top Aliases - This option uses top aliases for the calculation. In practice, this
option will attempt to replace the missing top with one of the other "equivalent" tops
on the alias list.
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Make Isopach Zero When Top Quality Code Is - This option sets the isopach to zero
when the top's quality code matches the entry box.
Make Isopach Null When Top Quality Code Is - This option sets the isopach to a
NULL when either formaiton top's quality code matches the entry box. This can be
useful for reducing the effect of uncertain or marginal formation tops.

Options Tab

Apply TVD Correction to Isopach - By default, Petra calculates the isopach thickness
from MD depths. This option instead uses the formation tops' true vertical depths.
Make sure to use this tool when working with deviated or horizontal wells.
Apply Fault Gaps to Isopach - This option will incorporate "fault gaps" in the isopach
thickness. The "missing" section of any fault gap falling within the isopach interval
will be added to the thickness. The final isopach value will be the sum of the
difference in the fm tops plus all included fault gaps. Fault gaps falling outside the
interval defined by the upper and lower tops will not be used.
Set to NULL if Fault (Gaps) within Zone - This option sets the isopach thickness to a
NULL when the desired interval contains a fault cut.
Treat Tops as "Missing" if Top Quality Code Contains - This option forces Petra to
ignore tops with the user-specified quality code. Note that the entry box can handle
multiple quality codes separated with a ";".

When Upper or Lower Fm Top Is Missing
Store a NULL Value - When either the upper or lower formation top is missing, this
option stores a NULL value.

© 2014

Main Module

661

Store a Zero Value - When either the upper or lower formation top is missing, this
option stores a zero value.
Do Nor Replace Current Database Value - When either the upper or lower formation
top is missing, Petra will leave the existing value in the database alone. For brand
new data items, this option will leave null values for wells without tops.

Force Isopach Value to be Zero if ISOPACH Quality Contains - This option forces
Petra to store a zero when the destination isopach data item has the entered quality
code. Note that this is only relevant to pre-existing data items; brand new data items
will not have any quality codes.
4.8.2.2

Compute TST & TVT

The TST and TVT calculation is used to compute actual thickness of a zone by taking
into account the regional or local structural dip and azimuth and directional well
surveys.
To open the Compute TST & TVT tool, select Compute>From Zones>TST and TVT
from the menu bar at the top of the Main Module.

Variables To Compute
Zone - This dropdown selects the zone for the TST and TVD calculation. Petra will
use the upper and lower extents selected on the zone's interval definition.
TST - This dropdown sets the desired zone data item that will contain each well's
calculated true stratigraphic thickness. You can select an existing zone item or enter
a new name.
TST - This dropdown sets the desired zone data item that will contain each well's
calculated true vertical thickness. You can select an existing zone item or enter a
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new name.

Structural Dip and Azimuth
This section defines the structural dip and azimuth used in the TST and TVT
calculation. The structural setting can either be constant or individually set for each
well with zone data items.
Zone Data - This option uses zone data items for dip and azimuth for each well. Wells
without dip or azimuth entries will not have a TST or TVT calculation.
Constant - This option instead uses a constant, regional dip and azimuth for all wells
in the calculation.
Values are Apaprent Dip and Azimuth - This option changes the calculation to use
apparent dip and azimuth. Note this option will use borehole azimuth instead of the
bed azimuth for deviated and horizontal wells.

4.8.2.3

Zone Data Equation Transform

This function allows you to compute one zone variable from one or more zone
variables using a generalized equation transform. Equation variables can zone data
items (including fm tops), numeric constants, or datum elevations.
To open the Z data Equation Transform tool, select Compute>From Zones>Equation
Expression… from the menu bar at the top of the Main Module

Load and Save Buttons - You may save equations in the system equation file and
load them at a later date.
Zone Containing Equation Variables - While this equation can use data items from
any zone, this dropdown selects the zone that will contain the computed zone data
item.
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Enter Transform Equation Below
This entry sets the equation used in the data item calculation. Equations are made
of variables and mathematical operators.

Variables
Variables are just text, which can either be very specific (“POROSITY” or
“FORMATION_TEMPERATURE”) or general (“A” or “B”).

Mathematical Operators
Petra recognizes a wide variety of mathematical operators:
+ Addition
- Subtraction
* Multiplication
/ Division
** Exponent
ABS(x)

- Absolute value of x

ACOS(x)
ASIN(x)
ATAN(x)
COS(x)
COSH(x)
EXP(x)

- Arccosine of x (in radians)
- Arcsine of x (in radians)
- Arctangent of x ( in radians)
- Cosine of x in radians
- Hyperbolic cosine of x (radians)
- e to power of x

INT(x)

- Truncated value of x

LOG(x),LN(x)
LOG10(x)

- Log based 10 of x

MAX(x,y)

- Maximum of x and y

MIN(x,y)

- Minimum of x and y

ROUND(x)

- Rounded value of x

SIN(x)

- Sine of x in radians

SQRT(x)
SQR(x)
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SINH(x)
TAN(x)

- Hyperbolic sine of x (radians)
- Tangent of x in radians

TANH(x)

- Hyperbolic tangent of x (radians)

Operator Order
1 Exponent
2 Multiplication and division
3 Addition and subtraction
Use of parentheses can change the order of precedence.

Example Equations
R = ((A+B*(C-1.0))/100
R = X*SIN(A)+Y*COS(B)
R = LOG10(X)
R = X*X or
R = X**Y

R = SQR(X)
(x raised to the y power)

4.8.2.3.1 Z Data Equation Assignments

This screen assigns equation variables to the equation written on the Zone Data
Equation Transform. Petra will attempt to match equation variables to relevant zone
data items, but it's always a good idea to validate each variable. Variables without a
match will simple be assigned a constant with a value of zero.
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Now that the equation is parsed, you can assign your output data item and variables.
First, establish your output data item. Petra will create a data item in the that uses
the same variable name to the right of the equation. In the example above, Petra will
create a new data item named “NGR.” Alternatively, click the drop down box and
assign the output data item to an existing zone and data item.
Next, assign your variables. In other words, this is where you tell Petra what zone
data items, constants, and elevations you want included in the equation. Click on a
variable in the “Equation Variable Assignments” box. Next, click on a Zone,
Constant, or Log Curve Depth button in the “Assign Variable To” section. Click on
the associated drop down box and find the specific data item or enter a constant.
Finally, click on assign. This will change the Equation Variable Assignments box to
reflect the correct variable.

4.8.2.4

Zone Data Substitute

This Z data function performs a conditional data substitution using "if-then-else" type
logic. The substitute function will be applied to all currently selected wells in the
Main Module. This tool compares a zone data item to another zone data item,
constant, or null. When the criteria is TRUE, this tool will write a zone data item,
constant, or null to selected data item. When the criteria is FALSE, this tool will
write a different zone data item, constant, or null to selected data item.
In the example below: Evaluate the D_Sand ISOPACH data item when it's equal to a
NULL. When this is TRUE, store a 0. When this is FALSE, store the D_Sand
ISOPACH value. Write these results to the D_Sand ISOPACH data item.
To open the Zone Data Substitute Tool, select select Compute>From
Zones>Substitute from the menu bar at the top of the Main Module.
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The Zone Data Substitute Tool (left) and annotated to illustrate the logic (right)

Evaluate
This section sets the data item that will be evaluated. In other words, this is the
specific data item Petra will read and compare to the criteria set below. In the
example above, Petra will examine the ISOPACH data item in the D_Sand zone.

Condition
This dropdown selects the logical condition for the criteria. In the example above,
Petra will look for wells where the ISOPACH is equal to the "Compare To" section.
Other options include:
EQUAL TO
LESS THAN
LESS THAN OR EQUAL TO
GREATER THAN
GREATER THAN OR EQUAL TO
NOT EQUAL TO

Compare To
This section sets the specific search criteria for the substitution. Petra can compare
the data item selected in the "Evaluate" section to another data item in the project, a
constant, or a null/missing value. In the example above, Petra will look for wells
where the ISOPACH data item is equal to a null value.

When True, Result Is
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This section sets what result will be written when the evaluated data item meets the
search criteria. This tool can write the value of another data item in the project, a
constant, or a null/missing value. In the example above, where the ISOPACH data
item is equal to a null value, Petra will write a 0 value.

When False, Result Is
This section sets what result will be written when the evaluated data item DOES
NOT meet the search criteria. This tool can write the value of another data item in
the project, a constant, or a null/missing value. In the example above, where the
ISOPACH data item is NOT equal to a null value, Petra will write the ISOPACH
value.

Store Results In
This section sets the destination data item of the substitution. Selecting the same
data item as the "Evaluate" section will permanently overwrite the entries in the
database..

Treat NULLS As
This section controls how Petra handles null values in the database. As an example,
imagine comparing an isopach value to a constant 100; the TRUE condition is greater
than 100, and the FALSE condition is equal to or below 100.
Large Positive Values - When this option is selected, Petra will treat null values as a
large positive number. In the example above, null values will be treated as above
100 and therefore TRUE.
Zero Values - When this option is selected, Petra will treat null values as zero values.
In the example above, null values will be treated as below 100 and therefore TRUE.
Ignore Null Values - When this option is selected, Petra will ignore wells with null
values and will not perform the substitution operation. In the example above, null
values will be ignored, so no substitution will take place.

4.8.2.5

Substitute TD for Missing Zone Base

This tool copies a well's TD into missing formation tops that define the base of a zone
defined by the interval definition screen.
To open the Substitute TD for Missing Zone Base tool, select Compute>From
Zones>Substitute TD for Missing Zone Base from the menu bar at the top of the Main
Module.
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To use this tool, select the desired zone and select "OK." Petra will overwrite null
values in the formation top that defines the base of the zone with the well's TD. Note
that this tool will also add a "TD Subst" in the quality code for all wells with a
substituted TD.

4.8.2.6

Zone Summation

This tool sums multiple zone data items together. This tool can also give a count of
the total number of data items summed.
To open the Substitute TD for Missing Zone Base tool, select Compute>From
Zones>Summation from the menu bar at the top of the Main Module.
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Z Items To Sum
Z Items To Sum - This button opens the "Select Zone Item List" tool. Items on the
"Selected Zone Items" list on the far right of the screen will be summed together.
The ">" adds the highlighted item to the Selected Zone Item List.
The ">>" button adds all items in the currently highlighted zone to the Selected Zone
Item List.
The "<" button drops the highlighted item from the Selected Zone Item List.
The "<<" button drops all items from the Selected Zone Item List.
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Store Results Into
This entry sets the destination zone and data item of the summation. You can select
an preexisting data item, or enter a new one. Selecting a preexisting data itemwill
overwrite any data already in the project.

Store Number of Items Summed Into
In addition to a straight summation, this tool can also store a count of the total number
of items summed.
Store Count - This option enables or disables the count being stored to the database.
This entry sets the destination zone and data item of the summation. You can select
an preexisting data item, or enter a new one. Selecting a preexisting data item will
overwrite any data already in the project.

Store NULL for Zero Results - This option stores a null value when the summation is
equal to zero.
Store NULL When All Data is NULL - By default, this tool stores a zero when attempts
to sum a set of null values. This option instead stores a null value for a full set of null
values.
Do Not Replace Current Value if Can't Compute a Well - When this tool cannot
successfully sum a set of data items, it normally overwrites the existing entry with a 0
(or a null if the Store NULL When All Data is NULL" option is selected). This option
instead leaves the preexisting value alone when it cannot compute a summation.
Treat Zero Values as NULLS - This option changes how
© 2014

Main Module

671

Include All Well Completions

Zone Summation with Zero and Null values
By default, this tool treats null values as a zero, so that summing a value with a null
equals the value. Changing the options changes how Petra sums zeros and nulls especially so with multiple options selected at once.

4.8.2.7

Multiple Regression Analysis

This tool applies a multiple regression analysis for one or more zone items. This can
be useful for attempting to better understand relationships between related data
items, and for prediction.
To open the Multiple Regression Analysis tool, select Compute>From Zones>Multiple
Regression Analysis from the menu bar at the top of the Main Module.

Data Tab

© 2014

672

PETRA Help

Select Dependent Variable - This section sets the "Y" of the equation. Select the
desired zone and data item.
Select and Add Independant Variables (Xs) To List Below - This section adds the
multiple variables used in the regression. Select the desired zone and data item, and
"+" to add the data item to the "Selected Independent Variables" list. To remove a
data item, highlight it, and select the "-" button.
Selecting the "OK" button runs the analysis.

Report Tab
The Report Tab provides the results of the regression analysis, including the
coefficients, correlation coefficient, and the goodness of fit. The Report Tab also
displays the difference between the actual dependent variable and the predicted
dependent variable for the wells used in the calculation.
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Neighbor Statistics

Z Data Tab

Zone Item To Analyze - These dropdowns set the zone and data item for the
statistics.
Zone to Store Results In - This dropdown sets the destintion zone for the calculated
statistics. In the example above, Petra will store the computed KB average in the
WELL zone.

Compute
Item name - This entry sets the name of the data item that will contain the calculation
result.
Source - This entry sets an optional source for the data item.
Compute Statistics For - This dropdown sets the specific statistical calculation.
Entries include:
Average Value
Sum
Min Value
Max Value
Avg Distance To Wells
Min Distance To Wells
Max Distance To Wells
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Difference From Average Value
Neighboring Well Count

Location Type
The Location Type determines whether Petra defines neighbors in terms of surface
locations or bottom hole locations.
Surface - When this option is selected, Petra will use wells with surface locations
within the search radius.
Bottom Home - When this option is selected, Petra will use wells with bottom hole
locations within the search radius.

Neighbors Tab

Radius of Search for Neighboring Wells - This entry sets the radius of the search for
the calculation. Note that the entry is in XY map units - if the project uses US feet,
this search will be in feet.
Include "Selected" well as a Neighbor - This entry sets whether a well's own value is
used in the statistical calculation. When this option is deselected, the neighbor
calculation will exclude a well's own value from the statistics.

Time Tab
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Present Day Apparent Spacing - This option uses all wells in the neighbor calculation,
regardless of the time drilled.
Spacing at Time Drilled - This option attempts to ignore the effects of wells that didn't
exist when the examined well was drilled.
4.8.3

From Production
To open any of Petra's production compute tools, select Compute>From Production
from the menu bar at the top of the Main Module.

Cumulative and Average Production Rates
Equation Expression...
Average or Cumulative Production Stream...
Sum "Field" Production Stream...
Sum Production Streams...
Extract PdCum Data To Zone
Rename Production Stream...
Time-Normalize Production...
4.8.3.1

Compute Cumulative Production

The Compute Cumulative Production Rate Tool extracts production data to a zone
data item. As a zone data item, these values can be used in other calculations or
mapped. This tool can extract several different kinds of production data, including:
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Cumulative Production
Average Production Rate
Number of Years Produced
Number of Days Produced
Date of First Production
Date of Last Production
To open the Compute Cumulative Production Stream tool, select Compute>From
Production>Average or Cumulative Production Steram from the menu bar at the top
of the Main Module.

Data Tab
The Data Tab just sets the production stream to be analyzed.

Compute Values Using Following Monthly Production Stream - This dropdown
defines the monthly production stream used in the calculations.
Include Historical Cum (Year 0) - This option includes include production prior to
recording monthly values. This production is stored in year zero (0).

Time Tab
It's often useful to examine a specific time frame of production data. The Time Tab
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Date Range
Compute for Constant Date Range - This option computes the statistics over a
specific timeframe, specified by the "From" and "Through" entries to the immediate
right.
Compute for Zone Date Range - This option computes the statistics over the
timeframe specified by a "From Zone Item" and a "Through Zone Item." Unlike the
"Compute for Constant Date Range", this option can compute a different range for
every well.
Compute for Months - This option computes the statistics over range in the life of
the well, specified in number of months. As an example, setting this to 3 and 6 will
calculate the statistics from the third to sixth months of production for each well.
Since this option looks at the individual life of each well, rather than a specific date,
this can be useful for comparing lifecycle production from well to well.

First/Last Production Range
Compute for First - This option computes the statistics over the first specified
number of months of production data. Note that this option can be limited to
producing months only, rather than including non-productive months that can bring
down the average production.
Compute for Last - This option computes the statistics over the last specified number
of months of production data. Note that this option can be limited to producing
months only, rather than including non-productive months that can bring down the
average production.

Time Period Range
Use Time Period When Prod is At Maximum Value - This option calculates production
statistics for a set number of months around the highest production.
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Use Time Period When production is At Minimum Value (non-zero) - This option
calculates production statistics for a set number of months around the lowest nonzero individual production value.
Range for Min-Max Period in Months - This dropdown sets the range for the or the
"Time Period" ranges. As an example, setting this option for 7 with a "Use Time
Period When Prod is At Maximum Value" will calculate the statistics over the interval
3 months before and after the highest producing month.

Method to Determine Min-Max Prod
Cum Prod Within Range Max or Min Prod Within Range -

Cum Prod Tab
The Cum Prod Tab control how this tool saves cumulative production values to a
zone data item.

Store Cumulative Production In
Compute Cumulative - This option enables or disables the cumulative production
summation. When this option is enabled, Petra will store the cumulative production
to the specified zone data item.

When Cum Result Is Zero
This section how this tool treats zero cumulative production values.
Store NULL Value - This option stores zero cumulative production values as null
values.
Store Zero Value - This option stores zero cumulative production values as zeros.
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Avg Prod Tab
The Avg Prod Tab control how this tool saves cumulative production values to a zone
data item.

Store Average Production Rate In
Compute Average Rate - This option enables or disables the average rate
computation. When this option is enabled, Petra will store the average rate to the
specified zone data item.

When Avg Result is Zero
This section how this tool treats zero average values.
Store NULL Value - This option stores zero average values as null values.
Store Zero Value - This option stores zero average values as zeros.

Method To Compute Average Rate
Compute Single Monthly Average - This option computes a simple average monthly
production rate with total production divided the total number of months.
Compute DAILY Average using Days per Month - This option computes a daily
average monthly production rate by dividing the average monthly production by the
number of days in a month.
Compute Daily Average Using "DAYS ON" Production - The Days On stream simply
records the number of days of production in a month. This option computes the daily
average by dividing the production stream by the number of days of recorded
production. This option can be more accurate, given good records.
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DAYS ON Production from - This option sets the "Days On" production stream for
the "Compute Daily Average Using "DAYS ON" method.
When DaysOn Values Are Missing - This option controls how the tool handles
missing "Days On" values. This tool can either skip the month (which can skew the
statistics), or use the number of days in the month (which effectively assumes full
production).

High-Low Tab
The High-Low Tab stores the highest and lowest production rates to a zone data
item.

Show Highest Production Rate In
Compute Highest Production Rate - This option stores the highest production rate
over the range specified on the Time Tab to the zone data item specified below.

Show Lowest (non-zero) Production Rate In
Compute Lowest Production Rate - This option stores the lowest production rate
over the range specified on the Time Tab to the zone data item specified below.

First-Last Tab
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Store Date of First Prod - This option stores the date of first production to the zone
data item specified below.
Store Date of Last Prod - This option stores the date of last production to the zone
data item specified below.
Store Cum at First Prod Date - This option stores the cum at the first production
date to the zone data item specified below.
Store Cum at Last Prod Date - This option stores the cum at the last production date
to the zone data item specified below.

Capture Tab
The Capture Tab stores total years and days of production.

Capture Total Years Produced In
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This option stores the total number of years of production used to compute the cum
value.
Do Not Compute Total Years - This option disables the year calculation.
Total First To Last Month Produced - This option Check this option to count all
months beginning with the first month of production to the last month of production.
Total Productive Months Only - Check this option to count all months beginning with
the first month of production to the last month of production but months of zero
production will not be included.
Total First To Last Produced - Check this option to count whole years beginning with
the first production value through the last year of production.

Capture Date of First and Last Production In
This section will capture and store the first and/or last dates when production
occurred, i.e., of the production range specified on the Time Tab.

Capture Number of Days of Production
This section will capture and store the total number of days used to compute the
daily average production rate.

4.8.3.2

Monthly Production Equation Transform

This function computes a monthly production stream from one or production variables
using a generalized equation transform.
To open the Monthly Production Equation Transform tool, select Compute>From
Production>Equation Expression... from the menu bar at the top of the Main Module.
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In the Equation Tab, you can enter an equation using variables and mathematical
operators. The variable on the left side of the equal sign is the result variable.

Variables
Variables are just text, which can either be very specific (“OIL” or
“2_Wall_Creek_GAS”) or general (“A” or “B”).

Mathematical Operators
Petra recognizes a wide variety of mathematical operators:
+ Addition
- Subtraction
* Multiplication
/ Division
** Exponent
ABS(x)
ACOS(x)
ASIN(x)
ATAN(x)
COS(x)
COSH(x)
EXP(x)
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- Absolute value of x
- Arccosine of x (in radians)
- Arcsine of x (in radians)
- Arctangent of x ( in radians)
- Cosine of x in radians
- Hyperbolic cosine of x (radians)
- e to power of x
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INT(x)

- Truncated value of x

LOG(x),LN(x)

- Natural Log of x

LOG10(x)

- Log based 10 of x

MAX(x,y)

- Maximum of x and y

MIN(x,y)

- Minimum of x and y

ROUND(x)

- Rounded value of x

SIN(x)

- Sine of x in radians

SQRT(x)

- Square root of x

SQR(x)

- x squared

SINH(x)

- Hyperbolic sine of x (radians)

TAN(x)

- Tangent of x in radians

TANH(x)

- Hyperbolic tangent of x (radians)

Operator Order
1 Exponent
2 Multiplication and division
3 Addition and subtraction
Use of parentheses can change the order of precedence.

Load and Save Buttons
You can save equations in the system equation file and load them at a later date.
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4.8.3.2.1 Monthly Production Equation Assignments

Now that the equation is parsed, you can assign your output log and variables.
Output Production Data - This dropdown sets the name of the calculated production
stream. Click the drop down box and assign the output curve to an existing
production stream.
Equation Variable Assignments - This is where you tell Petra what production
streams, constants, or zone data items you want included in the equation. Click on a
variable in the “Equation Variable Assignments” box. Next, click on a Prod, Zone, or
Constant button in the “Assign Variable To” section. Click on the associated drop
down box and find the specific strean or data item or enter a constant. Finally, click
on assign. This will change the Equation Variable Assignments box to reflect the
correct variable. Using the exact names in the equation tab will cause Petra to
“guess” at the variable assignments, which can save time.
When all equation variables are correctly assigned, click the OK button to proceed
with the calculations.
4.8.3.3

Compute Average or Cumulative Production Stream

This function computes an average or cumulative production stream from monthly
production data.
To open the Compute Average or Cumulative Production Stream tool, select
Compute>From Production>Average or Cumulative Production Stream... from the
menu bar at the top of the Main Module.
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Source Production Stream - This dropdown sets the productions stream used in the
average calculation.
Compute Average Production As - These two dropdowns set the output production
curve and type of average. To create a new output curve, simply enter a new name
into the dropdown box.

Annualized Daily Rate - This option computes the computes a simple average
production rate based on the total number of days in a year.
DAILY Rate using Days per Month - This option computes a daily average monthly
production rate by dividing the average monthly production by the number of days in a
month.
Daily Rate Using 'Days On' From - The Days On stream simply records the number of
days of production in a month. This option computes the daily average by dividing the
production stream by the number of days of recorded production. This option can be
more accurate, given good records.
Monthly Averages - This option sets the "Days On" production stream for the
"Compute Daily Average Using "DAYS ON" method.

Treat Months With No Production - This option controls how the tool handles months
missing production. This tool can treat the missing production as zero production
(which will bring the average down) or skip the month (which will ignore it's effects on
the average). Put another way, this is the decision to treat a missing value as a zero
or null, and will be affected by your database.
4.8.3.4

Sum "Field" Production Streams

This function sums production streams from multiple wells into a into a single well's
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production stream. This can be useful for comparing one group of wells' production
(such as an individual field) to another group of wells.
To open the Sum Production Streams tool, select Compute>From Production>Sum
"Field" Production Streams... from the menu bar at the top of the Main Module.
The Production Group Normalization Tool can be a great alternative to summing
production to a single well. This module doesn't require pseudo wells, can work with
dynamic data, and has more options.

Field Well - This dropdown selects the well that will contain the summed production.
This will overwrite the named production stream in the selected well, so it's a
good idea to use a "pseudo" or placeholder well rather than an actual well.
Select Production To Sum - This dropdown selects the production stream to sum.
Data Normalization - This option attempts to
Include Historic Production Generate Associated "Well Count" Stream 4.8.3.5

Sum Production Streams

This function sums multiple production streams into a single production stream.
To open the Sum Production Streams tool, select Compute>From Production>Sum
Production Streams... from the menu bar at the top of the Main Module.
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Data Tab
Sum Production in New Stream -This dropdown selects the production stream that will
contain the sum. Select an existing production stream or enter a new name. Note
that selecting an existing production stream will overwrite the production stream in the
database.
Select Streams to be Summed - This list selects the production streams to sum
together. Use SHIFT to select multiple successive streams, or CTRL to select
streams individually.

Options Tab
Scale Factor for Computed Stream - This option multiplies or divides the production
stream by a constant. This can be useful for changing the production stream's order
of magnitude. The default "(none)" option does not change the data.
Cumulative Production Value - This option stores a cumulative production value to a
selected zone data item.
Generate an Associated "Count" Stream - This opten creates a count stream that
stores the number of streams contributing to the summed production. Petra will store
a stream that appends "_CNT" to the name of the new stream. In the example above,
the count stream will be named "OIL_WC-NB_CNT"

Load/Save Settings - These buttons save and load the settings on the Sum Production
Streams tool to an external *.SPS file. This can be useful for running the same
calculation multiple times.
© 2014

Main Module

4.8.3.6

689

Extract PdCum Data To Zone

The Extract PdCum Data to Zone Tool extracts production cum data to a zone data
item. As a zone data item, these values can be used in other calculations or mapped.
To open the Extract PdCum Item to Zone Tool, select Compute>From
Production>Extract PdCum Data to Zone from the menu bar at the top of the Main
Module.
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Data Tab
Depth Selection Method
This section determines how the tool finds pd cums for the zone data item.
Extract Within Zone Depths - This option finds pd cums that are within the interval
definition for the zone selected on the "Zone" dropdown.
Extract Matching Formation Name - This option finds pd cums that match the
formation name or names selected on the "Formation Names(s)" list to the right.
Extract Within Zone Depths and Matching Fm Name - This option finds pd cums that
both match the formation name or names selected on the "Formation Names(s)" list
AND are within the interval definition for the zone selected on the "Zone" dropdown.

Formation Name(s)
When either the "Extract Matching Formation Name" or "Extract Within Zone Depths
and Matching Fm Name" depth selection methods are used, this tool will use the prod
cums that match the names selected on this list.

Zone
This dropdown sets the zone that will contain the data item extracted from the
production cum. When either the "Extract Within Zone Depths" or "Extract Within
Zone Depths and Matching Fm Name" depth selection methods are used, this tool will
use the zone interval definition set on the Zone Maintenance Tool.

Select Variables to Extract
This list selects the variables to write to the selected zone.

Options Tab
This section determines how the tool handles multiple production cums that match the
criteria set on the Data tab.
Choosing the First PdCum Record (not by date) - This option only uses the first pd
cum in the database. This won't necessarily be the earliest record or even the best
record - only the first in the database.
Summing CUMS fom Multiple Matching Records - When this option is selected, Petra
will sum the cumulative values together.
Storing Each matching Record in a Different Zone Item - This option will store multiple
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PdCum records in multiple data items. Petra will automatically append "_1", "_2", and
on to the multiple zone data items.
Choosing PdCum With most Recent Date - This option will only store the data from
the production cum with the most recent date.
Use FmName (AltName) for Zone Item Name Substitute TD if Missing Zone Base - This option forces Petra to use the total depth
(TD) as a substitute for missing zone base values. This can have a significant effect
on calculations that use zone boundaries, including isopach and log calculations.
4.8.3.7

Rename Production Stream

This function renames a monthly production stream for either a single well, or for all
selected wells.
To open the Rename Production Stream tool, select Compute>From
Production>Rename Production Stream... from the menu bar at the top of the Main
Module.
4.8.3.8

Time-Normalize Production

This function normalizes a production stream by shifting its start date back to the year
1900. This can be useful for comparing different wells with different start dates.
To open the Monthly Production Equation Transform tool, select Compute>From
Production>Equation Expression... from the menu bar at the top of the Main Module.
The Production Group Normalization Tool can be a great alternative to this tool. This
module doesn't require maintaining additional production streams in the database, can
work with dynamic data, and has more options.

Input Production Stream - This dropdown selects the production stream to be
normalized.
Output Time-Normalized Production Stream - This dropdown selects the name of the
new normalized production stream. You can either select an existing production
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stream name, or enter a new one. Selecting an existing production stream will
overwrite the preexisting data.

A normalized oil stream that starts at the year 0

4.8.4

Using Test Data

To open any of Petra's test compute tools, select Compute>From Tests from the
menu bar at the top of the Main Module.

Extract PD Test Z Data
Extract Fm Test Z Data
Flag Zones with perfs, cores, DSTs or shows
Flag Wells with Tests...
Find Producing Zone
Copy Prod Tests To Perfs
Remove "Problem" Perfs

4.8.4.1

Extract Mappable Z From Production Test

Production test data items such as IP volumes are not directly mappable. However,
this function can be used to select important tests and copy selected attributes into
the zone database where they can be mapped. Data will be extracted for the
currently selected wells on the Main Module.
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To open the Extract Mappable Z from Production Test tool, select Compute>From
Tests>Extract PD Test Z Data... from the menu bar at the top of the Main Module.

Data Tab
Depth Selection Method - Test records can be selected by zone depth
interval or formation name.
Extract Tests Using Zone Depths - This option will look for tests within the interval
definition of the zone selected on the "Select Zone For Results" list. This method
depends on having a zone itnerval definition along with good coverage of formation
tops. This method can be good for filtering out erroneously named tests in the
database, or for tests only within a specific lithologic package.
Extract Tests Which match Formation Name - This option looks inside the tests'
"FmName" entry for text set on the "Formation Name" entry. This method only uses
the database entry, rather than formation tops.

Select Zone For Result
For the Zone Depths mode, this dropdown specifies the search interval and the zone
that will contain the computed zone data items. For the Formation Name mode, this
dropdown just specifies the location of the computed results.

Formation Name
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For the Formation Name method, this entry sets the text string that Petra will look for
inside the tests' FmName entries. The "Exact" option is more strict, and requires
that the entry match the specified text exactly, while the "Contains" option only
requires that the test contain the text somewhere inside the database entry.

Select Variables to Extract
This section selects the specific data within the test to extract to a zone data item.
This includes various volumes, pressures, and other test information. Petra will
extract the value and save it to a data item in the zone selected in the "Select Zone
For Results." Petra will only extract highlighted entries; left-click an entry to highlight
it. Hold down CTRL to select multiple items. Note that SHIFT-click will select all
items in between two successive mouse clicks.

Select Test Matching Test Types
This section restricts the search to specific test types. Petra's database includes:
IPT, IPF, IPP, IPS, PDT, PDF, PDP, PDS

Depth Tolerance Beyond Zone
By default, the Zone Depths mode limits tests to only those with at least some
footage inside the zone interval. This option adds an additional buffer at a set
footage beyond the exact zone intervals. For tight zone definitions, this can increase
the chances of catching a test inside the zone.
Accept Only IP Test - Check this option if you only want to examine IP test types. All
other production test types will be ignored.
Must Have Oil - This option ignores production tests without an oil volume.
Must Have Gas - This option ignores production tests without an gas volume.

Options Tab
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Store Zeros as NULL - By default, Petra will store zeros in the zone data item with
the test entry is zero. This option replaces zeros with null values.
Combine Well Completions - By default, Petra treats multiple completions as sperate
wells. This option will store test information from recompletions in the primary well's
zone data item.
Store Upper and Lower Test Interval As Fm Tops - This option enables the
"Formation Tops To Store Test Interval" section.

Formation Tops To Store Test Interval
This tool stores the top and base of the test interval as a formation top. Selecting a
preexisting top will overwrite the values already in Petra's database. To add a new
top, select the "New Tops" button.
Upper Top - This dropdown sets the formation top that will store the top of the test
interval.
Lower Top - This dropdown sets the formation top that will store the top of the test
interval.

Ignore "Preferred Test" Flag - Petra's database can store a single test as a
"preferred' test. This tool normally attempts to use "preferred" tests first, but this
tool will ignore this flag and treat each test equally.
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Resolve Multiple Matches By
Choosing Only Preferred of the First Pd Test Record - This option will first attempt
to use the tests with the "preferred" flag set. If no flags are set, then Petra will use
the first production test entry.
Storing Each Matching Record In a Different Zone Item - This option stores a result
for each test by creating multiple zone data items. Different zones have a "_1", "_2",
and so on appended to the end.
Also Create Multiple Tops/Bases for Each Match - When the "Store Upper and
Lower Test Interval As Fm Tops" option is selected, this option stores a top for each
top and base by creating multiple tops items. Different tops have a "_1", "_2", and
so on appended to the end.
4.8.4.2

Extract Mappable Z From Formation Test

Formation test data items such as formation pressures are not directly mappable.
However, this function can be used to select important tests and copy selected
attributes into the zone database. where they can be mapped. Data will be
extracted for the currently selected wells, i.e., those wells listed on the main screen
well list.
To open the Extract Mappable Z from Formation Test tool, select Compute>From
Tests>Extract Fd Test Z Data... from the menu bar at the top of the Main Module.

Test Data Tab
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Depth Selection Method - Test records can be selected by zone depth
interval or formation name.
Extract Tests Using Zone Depths - This option will look for tests within the interval
definition of the zone selected on the "Select Zone For Results" list. This method
depends on having a zone itnerval definition along with good coverage of formation
tops. This method can be good for filtering out erroneously named tests in the
database, or for tests only within a specific lithologic package.
Extract Tests Which match Formation Name - This option looks inside the tests'
"FmName" entry for text set on the "Formation Name" entry. This method only uses
the database entry, rather than formation tops.

Select Zone For Result
For the Zone Depths mode, this dropdown specifies the search interval and the zone
that will contain the computed zone data items. For the Formation Name mode, this
dropdown just specifies the location of the computed results.

Formation Name
For the Formation Name method, this entry sets the text string that Petra will look for
inside the tests' FmName entries. The "Exact" option is more strict, and requires
that the entry match the specified text exactly, while the "Contains String" option only
requires that the test contain the text somewhere inside the database entry.

Select Variables to Extract
This section selects the specific data within the test to extract to a zone data item.
This includes various volumes, pressures, and other test information. Petra will
extract the value and save it to a data item in the zone selected in the "Select Zone
For Results." Petra will only extract highlighted entries; left-click an entry to highlight
it. Hold down CTRL to select multiple items. Note that SHIFT-click will select all
items in between two successive mouse clicks.

Recovery Description Text
This section restricts the search to specific text inside the recovery entry. The
"Exact" option is more strict, and requires that the entry match the specified text
exactly, while the "Contains String" option only requires that the test contain the text
somewhere inside the database entry.
Append Desc To Item Name - This option appends the recovery description text to
the created zone item name.

Depth Tolerance Beyond Zone
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By default, the Zone Depths mode limits tests to only those with at least some
footage inside the zone interval. This option adds an additional buffer at a set
footage beyond the exact zone intervals. For tight zone definitions, this can increase
the chances of catching a test inside the zone.

Options Tab

Also Store Recovery Text Field - When extracting recovery amounts, you may also
store a text-type z variable with the amount, units, and description. The name of the
variable is FMT_RECOV_TXT. This variable can be used for data posting instead of
the Z value.
Store Zeros as NULL - By default, Petra will store zeros in the zone data item with
the test entry is zero. This option replaces zeros with null values.
Combine Well Completions - By default, Petra treats multiple completions as sperate
wells. This option will store test information from recompletions in the primary well's
zone data item.
Store Upper and Lower Test Interval As Fm Tops - This option enables the
"Formation Tops To Store Test Interval" section.

Formation Tops To Store Test Interval
This tool stores the top and base of the test interval as a formation top. Selecting a
preexisting top will overwrite the values already in Petra's database. To add a new
top, select the "New Tops" button.
Upper Top - This dropdown sets the formation top that will store the top of the test
interval.
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Lower Top - This dropdown sets the formation top that will store the top of the test
interval.

Resolve Multiple Matches By
Choosing Only Preferred of the First Pd Test Record - This option will first attempt
to use the tests with the "preferred" flag set. If no flags are set, then Petra will use
the first production test entry.
Storing Each Matching Record In a Different Zone Item - This option stores a result
for each test by creating multiple zone data items. Different zones have a "_1", "_2",
and so on appended to the end.
Also Create Multiple Tops/Bases for Each Match - When the "Store Upper and
Lower Test Interval As Fm Tops" option is selected, this option stores a top for each
top and base by creating multiple tops items. Different tops have a "_1", "_2", and
so on appended to the end.
Extract All Recovery Records -

Test Type Tab
This section restricts the search to specific test types.

4.8.4.3

Flag Zones Containing Perfs, Cores or Shows

This tool stores information to zone data items based on the tests in a project. This
tool samples test information including perfs, cores, shows, DSTs, IP, PdCums, and
faults.
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To open the Flag Zones Containing Perfs, Cores, or Shows, select Compute>From
Tests>Flag Zones with perfs, cores, DSTs or shows... from the menu bar at the top
of the Main Module.

Select Zones To Compute
This list displays the zones in the project. Selecting a zone sets both the interval to
examine, and the location of the created data item. Petra will use the test
information whenever the test's top or base overlaps the zone interval definition top
or base.

Perfs Tab

Perf Items To Compute
Choose which items you want to compute by placing a check in the appropriate box.
You can use the default item names or enter your own name. The item name will
become the zone item variable in the zone database.
FLAG=1 If Perfed In Zone - This variable will contain a value of 1.0 if any perf depth
range overlaps the zone depth range. Otherwise, the values will be 0.0. If no perf
records are found for the well, the value will be NULL.
Total Ft(mtrs) Perfed In Zone - This item will store the sum of all perf data falling
within the zone depth range. The perfed top and base depths are clipped at the zone
depths before summing.
MIN Depth Perfed In Zone - This item will store the minimum measured depth of all
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perfs falling within the zone depth range. This value will not be less than the zone
upper depth.
MAX Depth Perfed In Zone - This item will store the maximum measured depth of all
perfs falling within the zone depth range. This value will not be greater than the zone
lower depth.

Select Only Perf Types
This section allows inclusion or exclusion of individual perf types. Only those records
with the selected types will be analyzed. Note that this option depends on updated
records in the project database.

Cores Tab

Core Items To Compute
Choose which items you want to compute by placing a check in the appropriate box.
You can use the default item names or enter your own name. The Item name will
become the zone item variable in the zone database.
FLAG=1 If Zone is Cored - This variable will contain a value of 1.0 if any cores
depth range overlaps the zone depth range. Otherwise, the values will be 0.0. If no
core records are found for the well, the value will be NULL.
Total Ft(mtrs) of Cores - This item will store the sum of all core data falling within
the zone depth range. The top and base depths are clipped at the zone depths
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before summing.
MIN Depth of Cores - This item contains will store the minimum measured depth of
all cored intervals falling within the zone depth range. T his value will not be less than
the zone upper depth.
MAX Depth of Cores - This item contains will store the maximum measured depth of
all cored interval falling within the zone depth range. This value will not be greater
than the zone lower depth.

Shows Tab

Show Items To Compute
Choose which items you want to compute by placing a check in the appropriate box.
You can use the default item names or enter your own name. The Item name will
become the zone item variable in the zone database.
FLAG=1 If Zone has Shows - This variable will contain a value of 1.0 if any show's
depth range overlaps the zone depth range. Otherwise, the values will be 0.0. If no
core records are found for the well, the value will be NULL.
Total Ft(mtrs) of Shows - This item will store the sum of all show data falling within
the zone depth range. The top and base depths are clipped at the zone depths
before summing.
MIN Depth of Shows - This item will store the minimum measured depth of all shows
falling within the zone depth range. This value will not be less than the zone upper

© 2014

Main Module

703

depth.
MAX Depth of Shows - This item will store the maximum measured depth of all
shows falling within the zone depth range. This value will not be greater than the zone
lower depth.

Select Only Show Codes
This section allows inclusion or exclusion of individual show codes. Choices are oil,
gas, water, and other. Only those records with the selected codes will be analyzed.

DSTs Tab

DST Items to Compute
Flag=1 if Zone has DST - This option writes a "1" to the data item when the zone
contains a DST. The entry to the left sets the name of the data item.
Total Ft(mtrs) of DST - This option writes the total footage or meterage of the DST
inside the zone. The entry to the left sets the name of the data item.
MIN Depth of DST - This option writes the shallowest depth of the DST to the data
item. The entry to the left sets the name of the data item.
MAX Depth of DST - This option writes the deepest depth of the DST to the data
item. The entry to the left sets the name of the data item.
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DST Flag Curve
This option creates a log curve that shows the presence or absence of a DST.
Intervals in the well with a DST will have a 1, while intervals without a DST will be left
null. Flag curves can be useful for limiting log calculations. The entry box sets the
name of the flag curve item.

IP Tab

IP Test Items To Compute
Flag=1 if Zone has IP - This option writes a "1" to the data item when the zone
contains a IP. The entry to the left sets the name of the data item.
Total Ft(mtrs) of IP - This option writes the total footage or meterage of the IP inside
the zone. The entry to the left sets the name of the data item.
MIN Depth of IP - This option writes the shallowest depth of the IP to the data item.
The entry to the left sets the name of the data item.
MAX Depth of IP - This option writes the deepest depth of the IP to the data item.
The entry to the left sets the name of the data item.

IP Flag Curve
This option creates a log curve that shows the presence or absence of a IP.
Intervals in the well with a IP test will have a 1, while intervals without a IP will be
left null. Flag curves can be useful for limiting log calculations.
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Search Options
Any and All PD Test Records - This option allows Petra to search through all IP and
PD tests
IP Tests Only - This option restricts the search to only IP tests.
Selected Types - This section restricts the search to specific test types. Petra's
database includes: IPT, IPF, IPP, IPS, PDT, PDF, PDP, PDS

PdCum

PdCum Items to Compute
Flag=1 if Top-Base within zone - This option writes a "1" to the data item when the
zone contains a PdCum. The entry to the left sets the name of the data item.
Top Depth From PdCum - This option writes the top of the PdCum inside the zone to
a data item. The entry to the left sets the name of the data item.
Base Depth From PdCum - This option writes the base of the PdCum inside the zone
to a data item. The entry to the left sets the name of the data item.
Fm Name from PdCum - This option writes the deepest depth of the DST to the data
item. The entry to the left sets the name of the data item.

DST Flag Curve
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This option creates a log curve that shows the presence or absence of a DST.
Intervals in the well with a DST will have a 1, while intervals without a DST will be left
null. Flag curves can be useful for limiting log calculations. The entry box sets the
name of the flag curve item.

Fault Cuts Tab

Flag=1 if Flt Cut within Zone - This option writes a "1" to the data item when the zone
contains a fault cut. The entry to the left sets the name of the data item.
Total Ft(mtrs) of FltCuts in Zone - This option writes the total footage or meterage of
the fault cut inside the zone. The entry to the left sets the name of the data item.
Nbr Flt Cuts in Zone - This option writes the total number of fault cuts inside the
zone. The entry to the left sets the name of the data item.

Options Tab
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Combine Well Completions - By default Petra treats multiple completions as
separate wells. This option instead will add data items and curves to the primary
completion instead of to the recompletion well.
Substitute TD When Bottom of Zone is Missing - By default, Petra skips the flag
calculation when it is missing the fm top that defines the bottom of the zone interval
definition. This option instead forces Petra to substitute the well's TD for the missing
base. This can be useulf for wells that do not completely penetrate the zone of
interest.
Overwrite Good Values When Unable to Determine Zone Depths - When this tool
can't determine the zone interval from the zone interval definition, it will not overwrite
good values with null values. This option instead tells Petra to overwrite good
values.
Store Flag=Null Instead of Zero - This option changes what this tool stores for zones
that don't meet the search criteria. Instead of writing a zero, this option forces Petra
to write a null value instead. This can have big implications for calculations using
these flags, as multiplying something by 0 is different than multiplying by a null.

Sample Rate for Flag Curves in Ft (mtr) Per Sample - This sets the sample rate for
the flag curves. Generally, you will want this to match the sample rate of other
wireline logs.
Replace Current Flag Curves With New Calculations - This option completely
overwrites the existing flag curves.
Treat Top=Base As 1ft Thickness - When the top of the zone interval definition
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equals the base, this option forces the tool to treat it as a 1 foot thick boundary.
This tool will return positive flags and curves if the relevant perfs, cores, or shows
are within that one foot thick interval around the top/base.
Source Code for Output Zone Items - This entry sets a source code for all calculated
zone data items.

Restrict Log Curves to Following Depths
This option restricts the calculation to only a set of MD values, or a MD value and
each well's TD. This can further restrict the calculation inside a zone interval
definition.

4.8.4.4

Flag Wells with Tests

Enter topic text here.
4.8.4.5

Find Producing Zone

This tool uses a well's perf data to store the formation name of the "producing zone."
This can be useful for quickly filtering out producing wells to a relevent formation
based on user-created formation tops rather than relying on database entries.
To open the Find Producing Zone tool, select Compute>From Tests>Find Producing
Zones... from the menu bar at the top of the Main Module.

Data Tab
The Data Tab sets the zones, search criteria, and output zone data items.
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Select Producing Zones From the Following
This list contains all the zones in a project. Petra will look for perfs within the zone
depth intervals, and store the zone in the selected output zone data item.

Zone Depth Criteria
This section defines how Petra selects perf intervals.
Shallowest Producing Zone - When this option is selected, Petra will store the zone
containing the shallowest producing zone.
Deepest Producing Zone - When this option is selected, Petra will store the zone
containing the deepest producing zone.
Largest Perfed Interval - When this option is selected, Petra will store the zone
containing the deepest producing zone.

Output Producing Zone Name To
This section sets the zone and data item that will contain the producing zone name.

Perfs Tab
The Perfs Tab sets a few options to limit the calculation to perfs with specific types
and source codes.
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Use Following Perf Types
The "Use Following Perf Types" tool restricts the search ton only a specific type (or
types) of perfs in the database. The utility of this tool is dependant on an up-to-date
database with appropriate settings. The available types include:
Active
Inactive
Open Hole
Bridge Plug
Packer
Proposed
Squeezed
Frac Plug
Junk

Limit Perfs By Source Code Below - This option limits the search only to perfs with a
specific user-set source code.
4.8.4.6

Copy Prod Tests To Perfs

Sometimes data sets only include production tests, but not perfed intervals. This tool
copies the top and base of production tests into the project's perfs.
To open the Copy Prod Tests To Perfs tool, select Compute> From Tests>Copy Prod
Tests To Perfs... on the menu bar at the top of the Main Module.
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Copy All Production Tests - This option copies the top and base of all production tests
into the project's perfs.
Copy IP Tests Only - This option copies the top and base of only the IP tests into the
project's perfs.
4.8.4.7

Remove "Problem" Perfs

Petra projects often contain duplicate or redundant perf intervals. You can deal with
“problem” perfs in two ways – permanently deleting them with the Remove Problem
Perfs Tool, or by keeping them in the database and filtering them out of Cross-Section
displays and calculations. Deleting “problem” perfs permanently changes the
database. Be sure to have a backup and to check the perfs that will be deleted.
Petra stores information like start and end date for each perf, so make sure this data
is captured in the remaining perfs.
To open the Delete Problem Perfs tool, select Compute> From Tests>Remove
“Problem” Perfs on the menu bar at the top of the Main Module.

Delete RED Perfs - This option removes only gross-interval perfs.
Delete BLUE Perfs - This option removes only duplicate perfs.
Delete RED and BLUE Perfs - This option removes both gross-interval and duplicate
perfs.
Report RED and BLUE Perf Counts - DO NOT DELETE - This option creates a simple
summary of the number of duplicate and gross perfs in the selected wells. This tool
can create an optional set of WSN lists for wells containing duplicate or gross perfs,
as well.
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Selecting the optional WSN summary (left), the location of the two WSN lists (center), and the actual summary (right)

4.8.5

Using Formation Tops
To open any of Petra's formation tops compute tools, select Compute>From FmTops
from the menu bar at the top of the Main Module.
Isopach
Copy Alias Tops
Deviation Hole Angle
FmName Alias File...
Round Top Values
Fm Substitution
Extract Fault Gaps to Fm Tops
Copy Tops From Another Source
Copy/Merge Tops...

4.8.5.1

Copy Alias Tops

The Copy Alias Tops tool can consolidate all tops associated with a particular top
alias. This tool will copy the first found top off the alias list into the aliased top's value.
This function can be used to create a new formation top containing the "best" picks for
a given top. For example, you could define an alias that has your picks as the first
choice, and PI picks for the second choice. Copying the alias tops would result in your
picks being copied if present, with PI tops chosen only if you hadn't picked the top.
To open the Copy Alias Tops Tool, select Compute>From FmTops>Copy Alias
Tops... from the menu bar at the top of the Main Module.
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Top Alias - Select the top alias you want to copy to.
4.8.5.2

Deviation Hole Angle...

The Deviation Hole Angle tool samples the hole angle at a specific point in a deviated
well (usually a picked formation top) to a zone data item. This tool requires directional
survey data to work.
To open the Deviation Hole Angle tool, select Compute>From FmTops>Deviation Hole
Angle... from the menu bar at the top of the Main Module.

Compute at Depth
This section sets the location of the deviation angle calculation.
Top - This entry sets a specific depth at a formation top.
Well TD - This entry selects the well's TD

Show Hole Angle In
This section sets the zone and data item that will contain the calculated deviation
angle.

Angle to Compute
This section sets the specific type of calculation. Petra can calculate the inclination or
the azimuth.
Inclination of Borehole From Vertical - This option calculates the borehole's
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inclination.
Azimuth Direction of Borehole - This option calculates the compass azimuth of the
borehole.

Compute Angle From Depth Point to Surface - This option calculates the overall angle
from the depth point set on the "Compute at Depth" option to the surface point.
Compute Local Angle at Depth Pt - This option only calculates the angle at the desired
depth point set on the "Compute at Depth" option.
4.8.5.3

FmName Alias File...

This tool copies the formation top aliases in the project to an external text file,
FMALIAS.TXT. This can be useful for taking formation top aliases created in one
project into another project.
To open the Save FmName Alias File tool, select Compute>From FmTops>Copy Alias
Tops from the menu bar at the top of the Main Module

4.8.5.4

Round Top Values

This tool simply rounds the selected formation tops to the nearest foot or meter.
To open the Round Formation Tops tool select Compute>From FmTops>Round Top
Values from the menu bar at the top of the Main Module
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Simply select the desired formation tops from the list, and click the "Round Tops.."
button. Note that this operation is irreversible, so be careful when using this tool.
4.8.5.5

Fm Substitution

The Fm Substitution Tool can substitute a single formation top for one or more
formation tops.
To open the Fm Substitution tool, select Compute>From FmTops>Fm Substitution...
from the menu bar at the top of the Main Module.

Data Tab
The Data Tab sets the specific formation top substitution file, as well as the specific
formation top names in the project that will be changed.

Apply Fm Substitution To The Following Data Types
ProdFm and FMatTD - This option applies the formation substitution to the well's
"Prod. Fm" and "Fm at TD" entries displayed on the Main Module's Well Tab.
Fm Tops - This option applies the formation substitution to the project's formation tops
available on the Main Module's FmTops Tab.
Projected FM - This option applies the formation substitution to the project's PROJFM
data item in the WELLS zone.
DSTs - This option applies the formation substitution to the project's DSTs, available
on the Main Module's Fm Tests Tab.
IP Tests - This option applies the formation substitution to the project's DSTs,
available on the Main Module's IP Tests Tab.
Interval FMNAME - This option applies the formation substitution to the FMNAME
column for all the project's interval tables. This will include the default LITH, CORE,
PALEO tables, as well as any user-created interval tables.
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Cores - This option applies the formation substitution to the "Formation" entries in the
project's Cores, available on the Main Module's Cores Tab.
Prod Cum Data - This option applies the formation substitution to the "FMNAME"
column in the project's Prod Cums, available on the Main Module's Prod Cums Tab.
Zone Cum Data - This option applies the formation substitution to the Zone Cumulate
Production data items created by the Compute Cumulative Production tool.

Info Tab
The info tab simply illustrates the proper formatting for formation substitution files.
These files can be created manually, or by using an existing project's formation top
aliases with the Save FmName Alias File tool.

4.8.5.6

Extract Fault gaps To Fm Tops...

Enter topic text here.
4.8.5.7

Copy Tops From Another Source

This tool copies the name and depths of tops from one source to another source.
To open the Copy Tops From Another Source Tool, select Compute>From
FmTops>Copy Tops From Another Source... from the menu bar at the top of the Main
Module.
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Copy Tops FROM The Following Source - This dropdown sets the source of the tops
that will be copied.
Copy Tops TO The Following Source - This dropdown sets the source of the tops that
will receive the copied tops.

Options
The Options section controls how the tool handles overlaps between the "from" tops
and the "to" tops. To be more specific, this section handles when the destination "to"
tops already has a formation top name that is exactly the same as the "from" tops.
Do Not Replace Existing Values in the "To" Tops - This option will create new
formation tops and values, but will not overwrite any values (including nulls) in the
destination "to" tops.
Replace "To" Tops Only When "To" Top is NULL - This option will create new
formation tops and values, but will not overwrite non-null values in the destination "to"
tops.
Replace ALL Values in the "To" Tops - This option will create new formation tops and
values, and will completely overwrite all values in the "to" tops.
Create Tops But DO NOT COPY Data - This option will only create the formation tops
with the "to" source code. This option will not write any values to the tops.
4.8.5.8

Copy/Merge Tops...

This tool copies the values from one top to another top. This can be very useful in
merging two separate tops in a database that actually reflect the same lithologic
boundary.
To open the Copy/Merge Tops Tool, select Compute>From FmTops>Copy/Merge
Tops... from the menu bar at the top of the Main Module.
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From Top - This dropdown sets the formation top will be copied.
To Top - This dropdown sets the formation tops that will receive the copied top
depths.

Data Merge Rules
This section controls how tool handles overlaps between the "from" tops and the "to"
tops.
Update Values (Allow Overwrite Of Existing Values) - This option will overwrite
formation tops in the "to" tops.
Add New Values - This option will only write depths where the "to" tops are blank. It
will not overwrite any existing formation top depths.

Copy/Merge For
Petra can perform the copy/merge operation on all the wells in the project, or only the
wells currently selected in the Main Module. Note that this section will be greyed out
when all wells are currently selected in the Main Module.
Selected Wells Only - This option performs the copy/merge only on the currently
selected wells in the Main Module. Wells not currently selected will retain both the old
"to" and "from" formation top depths.
All Wells - This operation performs the copy/merge on all the wells in the project.

Copy/Merge Tops
This section controls how Petra treats the "from" tops after the copy.
Copy (Leave Source Top Entries Intact) - This option retains the "from" tops after the
copy.
Merge (Remove Source Top Entries After Copy) - This option deletes the "from" tops
after the copy. Note that this is irreversible, so be careful when selecting this option.
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Using Locations

To open any of Petra's location compute tools, select Compute>From FmTops from
the menu bar at the top of the Main Module.

Calc XYs From LatLons & Calc LatLons from XYs
Duplicate Location Report...
Compute Well Lat-Lons From Spot Calls
Set Secondary Well Locations to Primary Well Location
Compute Distance From Surface to BH Location...
Spot Well Using Reference Well
Set Recompletion Locations to Original Hole Location

Calc Surface or Bottom-Hole Loc From Dir Survey
Pseudo Dir Surveys
Rotate Dir Surveys
Set Dev. Survey Grid Orientation
Extend Dir. Survey To Total Depth
Set Horizontal Well Flag
Set Survey XY Units Flags
Set Survey Depth Units Flags...
Convert Survey Depths/Offsets to System Units...
Fix Dir Survey Header Records

Clear Misc Location Data
Fix Bad T-R-S Values...

Lock/Unlock Selected Well Locations
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Calc XYs from LatLons / LatLons from XYs

Petra stores every well's location in a two different ways - latitude and longitude, and
XY. The "Calculate Well XYs from LatLons" and "Recompute Well Lat-Lons from
XYs" functions recalculate and replaces one set of locations with another.
To recompute well LatLons in the project from the XYs, select To open the Fm
Substitution tool, select Compute>From Locations>Calc LatLons from XYs... from the
menu bar at the top of the Main Module.
To recompute well XYs in the project from the LatLons, select To open the Fm
Substitution tool, select Compute>From Locations>Calc XYs from LatLons... from the
menu bar at the top of the Main Module.

4.8.6.2

Duplicate Location Report

This tool looks for surface locations that are close to each other. This can be useful
for finding duplicate well locations, or other location problems.
Petra will create a file called DUPLOC.TXT in the project's REPORTS directory. This
file will contain the details of the distances between wells, their WSNs, and the
wellspot symbols.
To use the Duplicate Location Report Tool, select Compute>From
Locations>Duplicate Location Report.
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The Duplicate Location Report Tool (left) and the DUPLOC.TXT report on locations (right)

Minimum Distance - This entry sets the distance that Petra will record a possible
duplicate. Wells closer than this limit will be reported; wells further than this limit will
not be reported.
Skip Multiple Completions - Petra treats multiple completions as sperate wells with
the same location. By default, this tool will report multiple locations as duplicate wells.
This tool specifically excludes multiple completions.
Save Reported Wells To WSN List - This option saves the closely spaced wells to a
WSN list. Selecting the "..." button sets the WSN filename and pathway.
Compare Wells with Symbols/With Wells with Symbols - These two lists control how
Petra uses well symbols in the search. Setting a well symbol on the left "Compare
Wells with Symbols" sets the wells Petra will search around, while the "With Wells
with Symbols" is list sets the well symbols that Petra will look for. As an example,
setting a Oil symbol in the left and a gas well in the right will restrict the search to only
oil wells with close gas wells.
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Compute Lat-Lons From Footage Calls

This function can be used to compute Latitude-Longitude coordinates for a group of
selected wells using footage calls or "spot calls" referenced to a Township-RangeSection or Texas Survey-Block-Section land grid file. Several land grid files can be
selected and processed simultaneously.

Special processing has been added to handle Texas Locations using survey, block
and section. In this case, the TMC Texas format file is used as land grid files. A
problem that Petra addresses is the ability to equivalence mismatched survey names
between IHS well data and TMC land grid files. For example, IHS might have the
survey name as "UNIV LDS" while TMC has it as "UNIVERSITY LANDS". Petra
provides for the use of an equivalence file to match these survey names. Petra can
scan the TMC files and build a list of mismatched survey names which the user can
then assign matches and save them to the equivalence file.

Data required for this function is:

1. Petra well database populated with footage calls, i.e., 1520 FNL, 660 FWL, or
quarter "Spot Calls", i.e., NESW in the Location>Township or Location>Texas
information.

2. A land grid file containing section boundaries in latitude-longitude. Petra supports
the following formats of land grid data sets:

Tobin Infobase
Topographic Mapping Company (TMC)
Platte River (same as TMC)
Whitestar Data in TMC format
TMC Texas format

After selecting the appropriate options, click the "Compute" button the process the
wells. After viewing or printing the report, exit the screen by clicking the "Done"
button.
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Data Tab
Land Grid File(s)
Use the browse button to select one or more data files containing land grid
information. All files selected must be of the same format. See valid formats above.
Scan For Survey Name Match... - If using TMC Texas locations format, you will have
this optional button. First, you should specify the "Survey Equivalence File" (see
below) before clicking this button. It will process all land grid files and find any well
data survey names that do not match the land grid files. A new tab will appear
labeled "Survey Name Match" for you to assign matches. (See Assigning Survey
Name Matches)

DB Records Containing Footages
Select which database records have been populated with footage values. Areas
outside Texas normally use the "Township Records" option while projects in Texas
will normally use the "Texas Location Records" options.

Texas (TMC) Locations Survey Name Match
This section contains options for matching Texas survey names when using Texas
TMC land grid files.
Percentage Compare - Well data survey names are first compared with the land grid
survey names using a "percentage" matching technique. You may enter a value from
1-100%. Higher numbers mean the names must match more precisely.
Use Survey Equivalence File - This file contains survey names and alias or equivalent
names that aid in matching survey names. Each survey equivalence is represented
by 2 (or more) records. The first record begins with a "1" and identifies the survey
name at it appears in the well data base. This is followed by one or more alias
records which begin with a "2". The alias name is the name as it appears in the land
grid file. The format of this file is as follows:
1SURVEYNAME
2SURVEYNAMEALIAS
2SURVEYNAMEALIAS
1SURVEYNAME
2SURVEYNAMEALIAS
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...
Edit Equiv. File...
The survey equivalence file can be viewed or modified using a text editor if you wish.
Care must be taken not to alter the format of the items listed in the file.

Options Tab
Wells Which Get Locations Computed
This option can be used to restrict which wells will have their locations computed.
The "All Selected Wells" will attempt to compute locations for all wells currently
selected in the main module. The "Only Wells With Zero-Valued Lat-Lons" option will
skip any selected well that does not have a latitude and longitude of zero.

Calculate Locations For
This option determines with location is computed. Choose either "Surface Locations"
or "Bottom-Hole Locations" option.

Backup Original Locations
This option can be used to save old well lat-lon values to a file prior to computing
new locations. Check the "Create Backup File" option and use the browse button to
select or enter a file name. It is highly recommended that you make a backup of
the original well locations during this process. The backup file is an ASCII file
containing the UWI (or API#), Latitude and Longitude as a comma separated format.

Method Tab
Location Source
Either footage call values or spot calls, such as, "NE SE NW" can be used.
The current version of this function will compute locations for full sections when the
"footage reference" value is blank or contains the string "SEC". When the reference
value contains one or more occurrences of the keyword "QTR", then the footages
are interpreted as being from a quarter section line and not from the section line. In
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this case, the section polygon is converted to a "regular" 640-acre section then
subdivided into the appropriate quarter. If the reference contains QTR QTR then the
quarter subdivision is repeated a second time. Also, this quarter subdivision relies on
having a valid spot call which ends in values such as NE, NW, SE or SW, etc.

Use Spot Call if footages can not be used...
Check this option to force the use of spot calls if the footages do not reference a full
section.

Output Mode
This option is critical and determines what happens with newly computed locations.
Use this option to preview or test the calculations prior to modifying the locations in
the database. All options generate a process summary report (see report tab for
details).
Generate Report Only (Do Not Modify Locations) - This option computes new
locations but does NOT UPDATE the database with them.
Compute new Locations In the Database - This option computes new locations and
UPDATES the locations in the database. It is wise to create a backup file of the
original locations when using this option (see data tab for details)
Export New Locations to an ASCII File - This option will write the new locations to a
data file but will NOT UPDATE locations in the database. Enter a file name or use
the browse button to define the output file.

Report File
A report file called SPOTWELLS.TXT in the project's "reports" directory records a
summary of the location calculation process. Each well is listed showing its
processing status. Wells with new locations computed will show the new Lat-Lon
values and the distance in feet or meters, depending on the map projection, from the
original location (if non-zero). The location line is prefixed with a letter indicating how
the location was computed. The prefixes are "F" for footage from section line, "Q"
for footage from quarter section line, and "S" for spot call calculation.
The report is displayed in NOTEPAD and can be printed or saved to a new file. Note,
this file is overwritten with each execution.

© 2014

726

PETRA Help

Survey Name Tab
This tab is displayed after scanning for survey name matches using Texas TMC
files. The left side shows the well data survey names that Petra could not match with
any of the TMC land grid file survey names shown on the right.
Assigning Survey Name Matches
You can assign alias or equivalent survey names by choosing one or more items
from the right side list that match with a single item from the left side list. Once
you've made your assignments, add them to the survey equivalence file by clicking
the "Add To Equiv. File" button.

Editing the Survey Equivalence File
You may view or edit the equivalence file at any time by clicking the "Edit Equiv. File"
button. Just be careful not to alter the format of the items listed in the file.

4.8.6.4

Set Secondary Well Location to Primary Well Locations

Petra stores a vertical pilot hole and directional well combination as a separate
"primary" and "secondary" wells. Generally, the primary vertical well have a 14 digit
API number ending in 0000, while additional directional wells from teh same pad will
simply append 0001, 0002, 0003, and so on. This tool overwrites these recompleted
wells' locations with the primary location's location.
To move secondary locations to the primary location, select Compute>From
Locations>Set Secondary Well Locations to Primary Well Location from the menu bar
at the top of the Main Module.
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Surface Options
Set Surface Location Only - This option simply moves the secondary wells' surface
locations. Bottom hole locations will remain unchanged.
Set Surface Location and Shift BH Location By Same Amount - This option moves the
secondary wells surface location to the primary well's surface location. This option
also moves the recompletion's bottom hole locations by the same amount.

For deviated wells copy the survey data from the primary well into the secondary well
- This option will copy the directional survey data from the primary well into the
secondary wells.
4.8.6.5

Compute Well Borehole Length

This tool calculates the length of boreholes inside the project and stores the length
and optional azimuth to user-selected zone data items.
To calculate well borehole length, select Compute>From Locations>Compute
Distance from Surface to BH Location from the menu bar at the top of the Main
Module.
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Borehole Length Calculation Method
This option controls how the tool calculates the length of the borehole.
Horizontal Distance From Surface to BH Location - This method just calculates the
distance from the surface location's LatLon to the bottom hole location's LatLon. This
method does not factor in any depths.
XYZ Distance From Surface to BH Location at TD - This method calculates the direct
linear distance between the surface and bottom hole location at depth.

Borehole Azimuth Calculation Method
Azimuth Btwn Surface and BH Location - This method uses the azimuth between the
surface location and the bottom hole location. This option is a good choice for most,
but can be skewed by a sudden deviation at the end of the lateral.
Local Azimuth Near BH Location - This method uses the azimuth immediately around
the bottom hole location.

Compute For
All Selected Wells - This option attempts to calculate borehole lengths for all selected
wells in the Main Module.
Deviated Wells with Dev Survey - This option limits the borehole length calculation to
only wells with a directional survey.
Deviated Wells Without Dev Survey (use BH Location) - This option limits the borehole
length calculation to wells without directional survey data. This option will only use BH
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locations listed on the Main Module's Location Tab.
Use BH Location Only (ignore Dev survey) - This option will perform the borehoe
length calculation to any well with a difference between the surface and bottom hole
location. Note that this method will ignore directional survey data, and will only use
bottom hole locations.

Output Results To
These entries set the zone and data item to store the output borehole length.
Zone - This dropdown selects the zone that will store the length (and optionally the
azimuth) data item. By default, this is the WELL zone.
Length - This dropdown selects the data item that will contain the length data item.
Note that you can select an existing data item, or enter the name of a new data item.
By default, this dropdown is set to BHLEN.
Azimuth - This dropdown saves the azimuth used in the calculation to a data item.
This will reflect the "Borehole Azimuth Calculation Method" selected above. Leaving
this dropdown blank will not save the azimuth value.

4.8.6.6

Spot Well using Reference Well

This tool changes the location of a selected well to a location that is a set XY distance
and azimuth from another reference well. This can be useful for updating well
locations with data from surveys.
This tool will change the location of the selected well on the Main Module, so make
sure to select the desired well before starting this tool.
To use the Duplicate Location Report Tool, select Compute>From Locations>Spot
Well using Reference Well.

Next, enter the WSN of the reference well.
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Next enter the distance between the reference well and the respotted well.

Finally, enter the azimuth of the direction from the reference well and the respotted
well.

4.8.6.7

Set Recompletion Locations to Original Hole Location

Petra stores recompletions as separate wells. Generally, the primary completion will
have a 14 digit API number ending in 0000, while additional recompletions will simply
append 0001, 0002, 0003, and so on. This tool overwrites these recompleted wells'
locations with the primary location's location.
To move recompletion locations to the primary location, select Compute>From
Locations>Set Secondary Well Locations to Primary Well Location from the menu bar
at the top of the Main Module.
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Surface Options
Set Surface Location Only - This option simply moves the recompleted wells' surface
locations. Bottom hole locations will remain unchanged.
Set Surface Location and Shift BH Location By Same Amount - This option moves the
recompleted wells surface location to the primary well's surface location. This option
also moves the recompetion's bottom hole locations by the same amount.
4.8.6.8

Compute Location from Deviation Survey

This tool recalculates wells' bottom hole locations or surface locations from directional
survey data. This can be useful particularly for replacing reported BHLs with a bhl
calculated from directional survey data.
To recalculate either the surface or bottom hole locations, select Compute>From
Locations>Calc Surface or Bottom-Hole Loc From Dir Survey from the menu bar at
the top of the Main Module. Note that this tool will work on all selected wells.

Compute BOTTOM HOLE Location - This option recalculates the bottom hole location
using the surface location and the directional survey data.
Compute SURFACE Location - This option recalculates the bottom hole location using
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the bottom hole location and the directional survey data.
4.8.6.9

Pseudo Dir Surveys

This tool calculates a pseudo directional survey from the surface location, bottom hole
location, and TD.
To recalculate either the surface or bottom hole locations, select Compute>From
Locations>Calc Surface or Bottom-Hole Loc From Dir Survey from the menu bar at
the top of the Main Module. Note that this tool will work on all selected wells.

2 Pts Method
The 2 points method creates two directional survey points - one at the surface
location, and one at the BH location. Note that Petra will assume a straight line the
two using the well's TD as a distance. Importantly, this method will grossly
misrepresent directional wells
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Longitude or X Coord - These dropdowns select the zone and data item containing the
longitude, X coordinate, or offset of the kick off point. The dropdown at the bottom of
this window will set what the selected data item represents.
Latitude or Y Coord - These dropdowns select the zone and data item containing the
latitude, Y coordinate, or offset of the kick off point. The dropdown at the bottom of
this window will set what the selected data item represents.
Depth Option - This option sets the kickoffpoint's depth. This entry can be either set
to a formation depth, constant value in measured depth, or the well's TD.

Location Zone Dropdown
Location Zone Items are Lat-Long Values - This dropdown sets the kickoff points as
latitude and longitude values.
Location Zone Items are X-Y Coordinates - This dropdown sets the kickoff points as
X and Y
Location Zone Items are XY Offsets From Survey Location - This dropdown sets the
kickoff points as X and Y offsets from the surface point.
Kick Point Same as Surface Location - This dropdown sets the kickoffpoint as being
directly beneath the surface location.
4.8.6.10 Rotate Dir Surveys

This tool rotates directional surveys around the surface location. Generally, this tool
should not be used to apply a convergence angle correction to directional wells.
To recalculate either the surface or bottom hole locations, select Compute>From
Locations>Rotate Dir Surveys from the menu bar at the top of the Main Module. Note
that this tool will work on all selected wells.
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4.8.6.11 Extend Dir Surveys

On a directional tool string, the survey tool is behind the bit. As such, the survey will
always be just short of the well's TD. Some directional surveys will include the
projection to bit, but others will just end at the final actual survey point. This tool
simply projects the active directional survey data out to the total depth. This tool can
also recalculate the bottom hole location using the bit projection.
To extend the directional survey, select Compute>From Locations>Extend Dir Surveys
from the menu bar at the top of the Main Module. Note that this tool will work on all
selected wells.
4.8.6.12 Set Horizontal Well Flag

Petra has a dedicated "Horizontal Well" entry for every well in the project database.
This entry, or "flag", simply records whether the well is a horizontal well. This flag can
be useful for searches and calculations elsewhere in Petra, such as in the Search
Wells by Data Criteria tool.
This flag can be set individually in the Directional Survey Tool's General Tab, but this
tool can set the flag for all selected wells at once.
To set the horizontal well flag for multiple wells, select Compute>From Locations>Set
Horizontal Well Flag from the menu bar at the top of the Main Module. Note that this
tool will work on all selected wells.
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4.8.6.13 Set Survey XY Units Flags

The Set Survey XY Units Flags
To set the XY Units Flags, select Compute>From Locations>Set Survey XY Units
Flags from the menu bar at the top of the Main Module.

4.8.6.14 Convert Survey Depths/Offests to System Units

Enter topic text here.
4.8.6.15 Fix Dir Survey Header Records

Enter topic text here.
4.8.6.16 Clear Misc Location Data

Enter topic text here.
4.8.6.17 Fix Bad T-R-S Values

Enter topic text here.
4.8.7

Using Interval Data
To open any of Petra's interval compute tools, select Compute>From FmTops from
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the menu bar at the top of the Main Module.

Extract Interval to Zone
Extract Interval to Curve
Find and Replace Data
4.8.7.1

Extract Interval Data to Zone

It’s sometimes useful to extract data from intervals to a zone. Zones are easily used
in calculations and mapping.
To save zone data to intervals, select Compute>From Interval Data>Extract Interval
Data To Zone from the menu bar at the top of the Main Module.

Data Tab

Extract Interval Data From
This section selects the desired interval table and field, as well as what will actually
be saved to the zone.
Table - This dropdown selects the desired interval data table. The selected table
will control the available fields in the next dropdown.
Field - This dropdown selects the desired interval field.
Method - This tool can either extract the interval field data or the interval thicknesses.
In the example above Petra will calculate an average of the “RW from SP” interval
data. Since a single zone can contain multiple or overlapping intervals, there are a
few different ways to extract this field or interval thickness data:
First/Last value
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Min/Max of values
Average of values (weighted or unweighted by thickness on the Options Tab)
Sum of values
Count of values
Sum of interval thicknesses
Average of Thicknesses
Count of intervals

Extract To
This section selects the zone and data item where the interval data will be stored.
Note that this tool uses the selected zone’s definitions (where fm tops or depths
define the top and base of the zone) to limit the extraction only to intervals
intersecting the zone. A default zone definition of -99999’ to 99999’ will include every
interval in the wellbore.

When
Petra can store the interval data meets the following criteria:
When the item is present – This option stores the interval field value to the zone data
item when the interval data contains a value. This is useful for most applications,
such as storing a petrophysical value to a zone.
Item is absent – This option stores the value when the interval data field is null.
Practically, this option is only useful when extracting the sum/average of interval
thicknesses or interval counts. As an example, extracting a count of intervals when
the porosity interval data is absent generates a well-by-well count of intervals
missing porosity values.
Range – This option stores the interval field value when the field value falls between
a minimum and maximum value.
Contains text – This option stores the interval field data when the interval field
contains specified text.
Matches text - This option stores the interval field data when the interval field exactly
matches the specified text.

Options Tab
The Options Tab contains further options for limiting the intervals used in the
extraction.
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Restrict Intervals By Selected Zone - By default, Petra only uses intervals that
intersect the selected zone’s definitions (where fm tops or depths define the top and
base of the zone). Note that undefined zones extend from -99999’ to 99999’ MD,
which includes every interval in the wellbore. Deselecting “Restrict Intervals By
Selected Zone” will not limit intervals by zone definitions. Alternatively, intervals can
also be limited by interval quality codes or FmName fields.
Method to Compute Average Values - When computing an average value for the
interval, Petra normally uses weighted averages, where thicker intervals contribute
more to the average than thin intervals. Selecting “Compute UnWeighted Average”
gives equal weight to all values regardless of interval thickness.
Set Computed Values of Zero to NULL - Remember that a null is not equal to zero.
Mistaking the two can generate spurious maps and calculations. The “Set Computed
values of zero to null” sets extracted values of zero to a null value.
Use Filter to Restrict Intervals - Filters provide more control over which intervals are
used in the zone extraction. Intervals that do not meet the filter criteria do not
contribute to a zone data item. To create or modify a set of filters, select the “Set
Filters…” button on the Filters tab. For more information on filters see the “Using
Filters” section of this document.
4.8.7.2

Extract Interval Data to Curve

It’s sometimes useful to extract numerical data from intervals to a log curve. Logs
curves are easily displayed on cross sections and can be used in petrophysical
calculations to create new composite curves.
To create curves from interval data, select Compute>From Interval Data>Extract
Interval Data To Curve from the menu bar at the top of the main module.
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Data Tab
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Extract Interval Data From
This section sets the interval table and field that will create the log curve. In the
example above, the “RW from SP” interval data is selected from the “Petrophysics”
table.

Extract To Log Curve
Petra extracts an interval field data value and applies it to that interval’s
corresponding footage on a log curve. As an example, an interval from 1500 to 2000’
with a RW of 0.06 will translate into a log curve with a repeating RW of 0.06 from
1500 to 2000’, as shown in the example below.
Intervals often have gaps and overlaps between intervals. Gaps between intervals
are simply stored as null values on the curve. Where log intervals overlap, the bottom
interval overprints the upper interval. To resolve these gaps and overlaps in the data,
see Resolving Gaps and Overlaps in this document.

Under the Extract Interval Data from dropdown menus, select the appropriate interval
table and field. Next, select the name of the log curve. In the example below, the
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“RW from SP” from the “Petrophysics” table will be stored as a new “RW” curve.
These curves can be stored at any sample rate, though 1 foot- and ½ foot-spacing
are the most common.

Options Tab
The Options Tab sets an additional filter to limit the intervals used in the extraction.
Filters provide more control over which intervals are used in the zone extraction.
Intervals that do not meet the filter criteria do not contribute to the log curve. To
create or modify a set of filters, select the Set Filters button.

4.9

Advanced Volumetrics
The Advanced Volumetrics Module is a straightforward way to calculate volumetrics
with a set of specific reservoir and fluid properties using either a deterministic model
or a probabilistic Monte Carlo model.
A deterministic model uses a fixed set of inputs and generates a single calculated
volume. A Monte Carlo simulation, on the other hand, uses a range of inputs to
calculate a large number of possible reservoir volumes. The outputs are then
arranged to give a probability density and cumulative distribution. Practically, both
these Monte Carlo simulation plots show the likelihood for a different hydrocarbon
reserves based on the range of possible reservoir parameters.
To open the Advanced Volumetrics Module, select Tools>Advanced Volumetrics…
from the menu bar at the top of the Main Module.

When to use the Advanced Volumetrics Module
Mathematically, the Advanced Volumetrics tool calculates reservoir volumetrics based
on a single set of averaged reservoir and fluid properties inside a cube with a defined
volume. The Monte Carlo simulation performs this same deterministic calculation with
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values selected from a possible range of these same average values. This
simplification is ideal for “back-of-the-envelope” calculations or for estimations of
exploratory reservoirs.
Well-drilled fields with large amounts of petrophysical data are better served by
a grid-based volumetrics calculation. In contrast to the deterministic method,
Petra uses grids of mapped thickness, water saturation, and porosity to calculate
reservoir properties for heterogeneous reservoirs. For more information on using
grids, see here.

Units Setup
The first step is to select the desired units for the volumetrics calculation. This tool
can import and export in different units.
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The Units Setup window before (Left) and after (right) setting the desired units

More about Oil Volumetrics.
More about Gas Volumetrics.
More about Monte Carlo Simulation.

4.9.1

Oil Volumetrics
To use the Advanced Volumetrics Module, enter all the relevant numbers for your
reservoir. Petra creates a report on the right side of the screen. This report screen
is automatically updated to reflect the most recent volumetric parameters entered.
While some entries are necessary for the calculation (like TVD), other values are
optional and exist only to override values Petra calculates automatically (such as the Z
Factor). An “*” next to the entry name signifies mandatory entries.
Once all the entries are set, Petra automatically performs the reservoir calculation and
displays a report on the right side of the screen.

1 - Reservoir Info
Though it’s optional, the first step is to enter the name of company, the field, the
reservoir, and the county. These entries show up on the top of all reports.

© 2014

Main Module

745

2 - Reservoir Properties
Drive Mechanism* -This dropdown menu governs how Petra treats reservoir depletion
due to production.
Water Drive (100 Percent Pressure Maintenance) – Use this method when an
underlying aquifer is strong enough to replace a barrel of oil produced with a barrel of
water, or when the rate of production is very small relative to the rate of water influx.
Importantly, this method assumes no pressure loss with production. If the reservoir
experiences a pressure drop with production, use a combination drive mechanism
instead.
Solution Gas Drive (Volumetric Depletion) – Use this method with undersaturated
volumetric reservoirs with no water drive. Solution gas drive reservoirs have two
stages of production: the liquid expansion stage from initial discovery pressure to the
bubble point and the gas expansion stage from bubble point to abandonment
pressure. This method assumes that all solution gas is either produced or remains in
the pore space; there is no provision for the formation of a secondary gas cap. The
solution drive dive reserves calculation particularly depends on the accuracy of the Kg/
Ko vs. gas saturation curve.
Gas Cap Drive – Use this method when an expanding gas cap forces the oil lower in
the formation with production.
Combination Drive (Solution + Gas Cap + Water) – Use this method with reservoirs
that do not produce exclusively by one of the previously discussed drive mechanisms.
Average TVD of Reservoir* - Enter the average true vertical depth of the horizon.
Petra accepts values between 300 and 35000’.
Initial Reservoir Pressure* - Enter the average reservoir pressure at initial conditions.
Petra accepts values between 14.7 and 20,000 psia.
Abandonment Reservoir Pressure* - Enter average reservoir pressure at final
conditions. Petra accepts values between 14.7 and 500 psia. This entry is not used
for water drive reservoirs because abandonment reservoir pressure equals the initial
reservoir pressure.
Temperature* - Enter the temperature of the producing horizon. Petra accepts values
between 40 and 500 degrees.
Connate Water Saturation* - Enter the connate water saturation of the producing
horizon in percent. Petra accepts values between 1 and 99.99 percent. Remember
to use whole numbers instead of decimal percentages.
Vertical Conformance Factor - Enter the efficiency of the water sweeping the oil zone.
By default, Petra assumes 85 percent efficiency. Remember to use whole numbers
instead of decimal percentages. Note this box is grayed out for gas cap and solution
gas drives, since they assume no water drive.
© 2014

746

PETRA Help

Average Porosity* - Enter the volume-weighted average porosity of the producing
formation in percent. Petra accepts values between 0.01 and 100 percent.
Remember to use whole numbers instead of decimal percentages.
Residual Oil Saturation* – Enter the residual oil saturation after production. Petra
accepts values between 1 and 100 percent. Remember to use whole numbers
instead of decimal percentages. This entry is grayed out for gas cap and solution gas
drives.
Net Interest* - Enter the company's working interest before royalty. Petra accepts
values between .01 and 100 percent. Remember to use whole numbers instead of
decimal percentages.

3 - Oil Reservoir Volumes
Total Reservoir Volume* – Enter the size of the reservoir in acre-feet.
Water Invaded Volume* - Enter the size of the water-invaded part of the reservoir in
acre-feet.

4 - Oil Fluid Properties
PVT correlation* – This dropdown governs the fluids in the system expand or contract
under different PVT conditions.
Standing – This option uses the Standing PVT correlation. This correlation is based on
data points from 22 California crudes of gravities ranging from 16.5 to 63.8°API.
Glaso – This option uses the Glaso PVT correlation. This correlation is based on 45
oils (mostly from the North Sea) with gravities ranging from 22.3 - 48.1°API.
Vazquez and Beggs – This option uses the Vazquez and Beggs PVT correlation. This
correlation is based on an extensive amount of data, with oil gravities ranging from
15.3 to 59.5°API.
Separator Gas Gravity* - Enter specific gravity of the solution gas relative to air.
Petra accepts values between 0.55 and 10.
Separator Oil Gravity* - Enter specific gravity of the oil. Petra accepts values
between 1 and 200º API.
Initial Z-factor - Enter the initial z-factor to override the internally-calculated value. By
default, Petra calculates the z-factor with the Hall-Yarborough correlation, based on
the Starling-Carnahan equation of state. This method agrees very well with the
Standing-Katz chart. The program does not make corrections for impurities. Petra
accepts values between 0 and 200.
The Hall-Yarborough correlation uses the following equations.
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where:
Pr = Pseudo-reduced pressure
t = Reciprocal pseudo-reduced temperature
y = "Reduced” density
The “reduced density” or “y” term comes from the Newton-Ralphson technique:

Reference Pressure* - Enter the standard reference pressure for delivery point
measurements. Petra accepts values between 14 and 20 psia.
Oil Compressibility - Enter the oil compressibility to override the internally-calculated
value. Petra accepts values between 0 and 10,000 1/psi E-6. By default, Petra uses
the following Mobil Correlation chart.
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Water Compressibility - Enter the water compressibility to override the internallycalculated value. Petra accepts values between 0 and 200 1/psi E-6. By default,
Petra calculates water compressibility using Meehan’s correlation.
where:
Cw = Water compressibility in microsips (psi-1 * 10-6)
A1 = - 0.00014765 * Pi + 3.916801021
B1 = (6.379 * 10-7)Pi - 0.011441478
C1 = (-1.3536114 * 10-10)Pi + 4.238314 * 10-5
Pi = Initial reservoir pressure, psia (Where does this show up in the equation?)
T = Temperature

Formation Compressibility - Enter the formation compressibility to override the
internally-calculated value. Petra accepts values between 0 and 200 1/psi E-6. By
default, Petra calculates formation compressibility using Hall's method.
where:
Cf = Formation compressibility, microsips
φo = Oil zone porosity, fraction

Bubble Point Pressure* - Enter the bubble point pressure (Pb) for the reservoir. Petra
accepts values between 14.7 and 3000 psia. Typically, the ranges for Pb depend on
drive type:
100% Water Drive: 14.7 < Pb < Pi (psia)
Solution Drive: 14.7 < Pb < Pi (psia)
Gas Cap Drive: This entry is not available for Gas Cap Drive because Pb = Pi is set
automatically and the corresponding GOR at Pb is calculated.
Combination Drive (no gas cap): 14.7 < Pb < Pi (p150sia)
Combination Drive (with gas cap): Pb = Pi (where Pi is the Initial Reservoir Pressure)

5 - Gas Cap Properties
Gas Cap Porosity* – Enter the average porosity of the rock containing the gas cap.
Petra accepts values between .01 and 100 percent. Remember to use whole
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numbers instead of decimal percentages.
Gas Cap Volume – Enter the volume of the gas cap.
Gas Produced from Gas Cap – Enter the volume of gas produced from the gas cap.

6 - Oil Cumulative Production
Oil* - Enter the total oil production from the discovery date to the date of reserve
determination.
Gas* - Enter the total solution gas production from the discovery date to the date of
reserve

Relative Permeability Input
The relative permeability input governs how the reservoir model handles the relative
permeability of gas and oil versus different gas saturations. Petra comes with three
default curves, which are typical for unconsolidated south Louisiana sandstone. To
use a different curve, select the Corey Equation option, and enter in values for Eo,
Sro, Smo, No, Eg, Srg, Smg, and Ng. Select “Calculate” to calculate the Corey
equation and use the values in the volumetrics calculation.
4.9.2

Gas Volumetrics
To use the Advanced Volumetrics Module, enter in the relevant numbers for the
reservoir. Petra creates a report on the right side of the screen. This report screen
is automatically updated to reflect the most recent volumetric parameters entered.
While some entries are necessary for the calculation (like TVD), other values are
optional and exist only to override values Petra calculates automatically (such as the Z
Factor). An “*” next to the entry name signifies mandatory entries.
Once all the entries are set, Petra automatically performs the reservoir calculation and
displays a report on the right side of the screen.

1 - Reservoir Info
Though it’s optional, the first step is to enter the name of company, the field, the
reservoir, and the county. These entries show up on the top of all reports.

2 - Reservoir Properties
Drive Mechanism* -This dropdown menu governs how Petra treats reservoir depletion
due to production.
Volumetric –Use this method for reservoirs that are driven by volumetric expansion of
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gas after a drop from initial reservoir pressures. The effects of water and formation
compressibility are also included in this method.
Water Drive (100 Percent Pressure Maintenance) – Use this method when all gas
recovery is due to water sweeping the entire drainage area. Importantly, this method
assumes no pressure loss with production. Initial and abandonment pressures are
assumed to be equal.
Partial Water Drive – Use this method with a mixed system of volumetric and water
drives. This method assumes two-part depletion: a volumetric depletion to
abandonment pressure and then an additional recovery in the water-swept zone.
Average TVD of Reservoir* - Enter the average true vertical depth of the horizon.
Petra accepts values between 300 and 35,000’.
Formation Pressure Gradient* - Enter the formation pressure gradient. Petra accepts
values between 0.05 and psi/ft.
Average Porosity* - Enter the volume-weighted average porosity of the producing
formation in percent. Petra accepts values between 0.01 and 100 percent.
Remember to use whole numbers instead of decimal percentages.
Formation Compressibility* – Enter the average compressibility of the formation.
Petra accepts values between 0.01 and 200 1/psi(E-6).
Connate Water Saturation* - Enter the connate water saturation of the producing
horizon in percent. Petra accepts values between 1 and 99.99 percent. Remember
to use whole numbers instead of decimal percentages.
Residual Gas Saturation - Enter the residual gas saturation to override the internallycalculated value. By default, Petra calculates the residual gas saturation with the
Legatski-Katz correlation for clean sands. This entry is only used for 100% Water
Drive and Partial Water Drive reservoirs. Remember to use whole numbers instead of
decimal percentages.

where:
Sr = Residual gas saturation, percent
φ = Porosity, percent

Initial Pressure* - Enter average reservoir pressure at final conditions. Petra accepts
values between 14 and 20,000 psia.
Abandonment Pressure* - Enter average reservoir pressure at final conditions. Petra
accepts values between 14.7 and 500 psia. This entry is not used for water drive
reservoirs because abandonment reservoir pressure equals the initial reservoir
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pressure.
Reservoir Temperature* - Enter the temperature of the producing horizon. Petra
accepts values between 40 and 500 degrees.
Vertical Conformance Factor - Enter the vertical conformance factor, which is a
measure of the uniformity of vertical permeability. It is usually calculated as
volumetric sweep efficiency divided by the areal pattern efficiency, and is assumed to
equal the fraction of waterswept portion of the reservoir actually contacted by water.
In a sense, it is a measure of water-drive efficiency.
Net Interest* - Enter the company's working interest before royalty. Petra accepts
values between .01 and 100 percent. Remember to use whole numbers instead of
decimal percentages.

3 – Gas Reservoir Volumes
Total Reservoir Volume* – Enter the size of the reservoir in acre-feet. Petra accepts
values between 0.01 and 1xE13 acre-feet.
Water Invaded Volume* - Enter the size of the water-invaded part of the reservoir in
acre-feet. Petra accepts values between 0.01 and 1xE9 acre-feet.

4 - Gas Fluid Properties
Type of Gas Gravity* – This dropdown governs how Petra handles gas gravity.
Wellstream Gas Gravity – This option indicates the gas gravity was measured at the
wellstream.
Separator Gas Gravity – This option indicates the gas gravity was measured at the
separator.
Gas Gravity* - Enter specific gravity of the solution gas relative to air. Petra accepts
values between 0.55 and 10.
Condensate Loss Method* - In the absence of PVT information, this option helps to
account for the effect of retrograde condensate on ultimate recovery.
Eaton-Jacoby – The Eaton-Jacoby uses a series of curves to estimate the
percentage of production lost to retrograde condensate. It is limited to reservoirs
between 4,000-12,000 psi, 160-290 f, 2,500 to 60,000 scf/STBO, and 5-65 oil
gravities.
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Modified Eaton-Jacoby – The original Eaton-Jacoby method was modified by Amoco
to better suit reservoirs in the Gulf of Mexico.
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Condensate Yield – Enter the ratio of condensate produced per MMSCF. Petra
accepts values between 1 and 200. Setting this yield to zero sets the fractional
retrograde loss to zero.
Condensate Gravity - Enter the condensate gravity. Petra accepts values between 1
and 200.
Condensate Gas Equivalent - Enter the condensate gas equivalent. .Petra accepts
values between 0 and 1000000.
Fuel Factor* - Enter the percent of the separator gas used to power process
equipment. Petra accepts values between .01 and 100 percent. Remember to use
whole numbers instead of decimal percentages.
Nitrogen - Enter the mole percent of nitrogen in the produced gas. Petra accepts
values between 0 and 90 percent. Remember to use whole numbers instead of
decimal percentages.
Carbon Dioxide - Enter the mole percent of carbon dioxide in the produced gas. Petra
accepts values between 0 and 90 percent. Remember to use whole numbers instead
of decimal percentages.
Hydrogen Sulfide - Enter the mole percent of hydrogen sulfide in the produced gas.
Petra accepts values between 0 and 90 percent. Remember to use whole numbers
instead of decimal percentages.

5 - Gas Cumulative Production
Gas at Separator* - Enter the total amount of separator gas produced from the
discovery date to the date of reserve determination. Make sure to include gas used
as fuel.
Condensate* - Enter the total condensate from the discovery date to the date of
reserve.
4.9.3

Monte Carlo Simulation
A Monte Carlo simulation calculates probability of recoverable gas in place using a
range of inputs for variable volume, porosity, gas saturation, recovery factor, and gas
formation volume factor. The Monte Carlo Simulation is a standalone tool, and does
not use any of the options entered on the Gas or Oil Volumetrics Tab.

Simulation Models
For oil reserve simulation, Petra uses the following model:
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For gas reserve simulation, Petra uses the following model:

Reservoir Options
Volume – Enter the range of possible reservoir volumes in acre-ft.
Porosity – Enter the range of possible reservoir porosities. Remember to use whole
numbers instead of decimal percentages.
Gas Saturation – Enter the range of possible gas saturations. Remember to use
whole numbers instead of decimal percentages.
Recovery Factor – Enter the range of possible recovery factors. Remember to use
whole numbers instead of decimal percentages.
Gas Formation Volume Factor – Enter the range of possible gas formation volume
factors in RB/MSCF.

Reservoir Option Ranges and Probability
Each of the reservoir parameters can vary in a few different probability distributions.
For more detail on using probability distributions as well as strategies on estimating
standard deviation, see the appendix at the end of this document.
Uniform – In a uniform distribution, all values between the minimum and maximum
vales are equally likely. To use a uniform distribution, simply enter the minimum and
maximum values.
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A Uniform Distribution

Triangular – In a triangular distribution, the “most likely” value has the highest
probability with a gradually decreasing probability towards the minimum and
maximum. To enter a triangular distribution, enter the minimum, maximum, and most
likely values. The most likely value will be treated with the highest probability, with a
linearly decreasing occurrence of values towards the minimum and maximum values.

A Triangular Distribution

Normal - In a normal distribution, values are more probable around a single arithmetic
mean, or average. This creates a “bell curve” where values closer to the mean are
more likely, where the standard deviation measures the average difference of the
values from the mean. To use a normal distribution, simply enter the mean and
standard deviation
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A Normal Distribution

Log-Normal – In a log-normal distribution, values are more probable around a single
mean with an even distribution of the logarithms of surrounding values. Log-normal
distributions are common when there is multiplication of two or more normally
distributed factors. To use a log-normal distribution, simply enter the mean and
standard deviation.

A Lognormal Distribution

Constant – A constant distribution actually has no variability at all and only contains a
single value. An example of a constant is the ultimate mortality rate, which is holding
steady at 100%.

Monte Carlo Outputs
A Monte Carlos simulation generates many different possible reserves values, some
of which are more likely to occur than others. Petra displays these statistics in a few
different ways on tabs next to the Monte Carlo tab.
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Report Output
The report output tabs shows recap of the initial reservoir parameters, a percentile
breakdown of the simulation results (P10, P50, P90, mean reserves, and expected
reserves), and a cumulative distribution table.
The summary gives a brief statistical breakdown of the probability of different
calculated reserves. There is a 10% chance that the reservoir is equal to or less than
the P10 value, a 50% chance the reservoir is equal to or less than the P50 value, and
a 90% chance that the reservoir is less than the P90 value. The mean reserves value
is a simple average of all the calculated reserves values, while the expected reserves
value instead weights results by probability.
The cumulative distribution table expands the calculated percentiles to cover every
5%. Each percentile gives the chance of the reservoir being equal to or less than the
calculated reserves. As an example, there is a 55% chance that the reservoir is equal
to or less than the reserves value across from cumulative distribution of 55.
Probability Plot
This plot displays the probability density on the Y axis versus the range of possible
reserves on the X axis. Low reserves estimates on the left side of the graph are the
result when everything goes wrong; this includes when the total volume, porosity, oil
saturation, etc. are all on the lower end of the possible ranges. Since the probability
of all these different factors going wrong is low, the corresponding probability of these
low end reserves is low. The high side of the graph with large reserves, on the other
hand is the result of everything going well, which also has a correspondingly low
probability. The bump in the middle of the graph corresponds to the highest
probabilities; these are the outcomes of the more common reservoir parameters.
Cumulative Distribution Plot
This plot displays the cumulative probability on the Y axis versus the range of possible
reserves on the X axis. Each point on the line reflects the probability of the reservoir
being equal to or less than the calculated reserves. As an example, there is a 55%
chance of the reservoir being equal to or less than the reserves value across from
accumulative distribution of 55.
4.9.4

Drive Configurations

100% Water Drive

The 100% water drive reservoir calculation is best suited for reservoirs in which
no pressure loss occurs with production. Any pressure drop that occurs with
production affects the calculation accuracy. Use combination drive if a pressure
drop occurs.
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Oil Recovery
The initial discovery reservoir pressure must be greater than or equal to the
bubble point pressure of the reservoir oil. This calculation assumes total
pressure maintenance by the aquifer such that recovery is given by:

The oil recovery as calculated above is applied to the water invaded zone. This
method of calculation implies that the aquifer must be strong enough to replace
a barrel of oil produced with a barrel of water influx, or the rate of production
very small relative to the rate of water influx.

The total oil recover is calculated using:

The recovery factor is calculated using:
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Solution Gas
The solution gas produced is equal to the gas that comes out of solution as the
oil is produced and brought to the surface. It is calculated by the following
equation:

The total gas production is calculated using:

The gas recovery factor is calculated using:

Gas Recovery
100% water drive recovery is best suited for reservoirs where very little
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pressure loss occurs with production. This calculation assumes total pressure
maintenance by the aquifer such that recovery is given by:

The recovery factor calculated above applies to the entire hydrocarbon zone.
This method of calculation implies that the aquifer must be very strong or the
rate of production very small relative to the rate of water influx.

Solution Gas (Depletion) Drive
The solution drive mechanism is applicable to undersaturated volumetric
reservoirs.

Initial reservoir pressure must be at or above the bubble point pressure.
Production from the initial discovery pressure down to the bubble point
pressure is by liquid expansion and results in a rapid decline in reservoir
pressure. Typical recoveries for this stage of the production life of the reservoir
are a fraction of a percent to a few percent of the original oil in place. The gasoil ratio remains equal to the initial gas-oil ratio.

Below the bubble point, gas liberates in the reservoir pore space. The reservoir
then produces by gas expansion, as indicated by a slower rate of pressure
decline and increasing produced gas-oil ratios. Typical recoveries are 10 to 25
percent of the original oil in place.

The oil volumetrics calculator makes the following assumptions for solution drive
mechanism:
All gas that comes out of solution is either produced or remains in the same
pore space where it was liberated. The calculator makes no provision for
additional production due to the formation of a secondary gas cap.
No water influx
Uniform gas saturation throughout the oil zone
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The recovery factor for solution drive has two parts:
Recovery factor from discovery pressure down to bubble point pressure (if
the initial pressure is greater than bubble point pressure)
Recovery factor from bubble point pressure down to abandonment pressure

Recovery Factor from Discovery Pressure to Bubble Point Pressure
The recovery factor from discovery pressure down to bubble point pressure (if
the initial pressure is greater than bubble point pressure) is calculated by:

The above fractional recovery is calculated as the fraction of a stock tank
barrel of oil that is recovered by the expansion of that barrel due to a pressure
drop from the initial pressure down to the bubble point pressure.

Recovery Factor from Bubble Point Pressure to Abandonment Pressure
The recovery that occurs from bubble point pressure down to abandonment
pressure is calculated using Tracy's material balance method. The iterative
procedure calculates the recovery fraction for each 200 psia drop in reservoir
pressure and keeps a running total of the recovery fraction down to
abandonment pressure. The calculation procedure is discussed below along
with Tracy's PHI function. Tracy rearranged the general material balance
equation by defining three functions of fluid properties dependent on reservoir
pressure. This permitted the estimation of change in produced gas-oil ratio,
rather than incremental oil production, for each pressure step. Performance
calculations are made in a series of pressure steps from known reservoir
conditions at the previous pressure to calculated conditions at the next lower

© 2014

762

PETRA Help

pressure. The calculated results then become the "knowns" at the next lower
pressure. This calculation sequence is repeated until abandonment pressure is
reached.

The following steps trace the calculation used to determine the recovery factor
for solution drive:

The equations for Tracy's functions are:
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The following lists definitions and equations for undefined variables:

Probably the one most important factor in the solution drive calculations is the
Kg/Ko vs. gas saturation curve. You must verify the three curves stored in the
program before you use them. A relatively small change in the curve can
change the recovery by 5 to 8 percent. The default curves are typical for an
unconsolidated south Louisiana sandstone.

Total Fractional Recovery
The total fractional recovery is calculated using the following equation to
combine the recovery fraction above and below the bubble point.

Oil Recovery
The oil recovery for the solution drive method is calculated by the following
equation:
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The total recovery is determined by:

Gas Recovery
The solution gas recovery is calculated by:

Total gas recovery is determined by:
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Gas Cap Drive

Use the gas cap drive mechanism for reservoirs with a gas cap. Oil
accumulations often occur in which there are greater volumes of light
hydrocarbons present than would dissolve in the oil at reservoir temperature
and pressure. Over time, these light materials migrate to the top of the
reservoir to form a gas cap.

There are two sources of energy, due to the pressure drop caused by oil
production, that produce a gas cap drive reservoir:
Expansion of the gas cap gas
Expansion of the dissolved gas as it is liberated

In the gas cap drive reservoir, the oil level in the reservoir falls as oil production
occurs due to the expanding gas cap forcing the oil lower in the formation. Gas
cap drive reservoirs tend to maintain higher pressures than solution drive
reservoirs. The pressure decline rate is inversely related to the volume of gas in
the gas cap. The larger the volume of gas in the gas cap, the less the pressure
declines as oil is produced. Recovery fractions for this type of reservoir
normally range between 20 and 40 percent of the original oil in place.

The oil volumetric calculator calculates oil recovery due to both gas cap
expansion and solution gas expansion. It does not take into account gravity,
which can significantly increase oil recovery in steeply dipping reservoirs. Also,
well placement in the reservoir can affect the expected oil recovery. This can
happen when wells are completed up-dip and must start producing the
advancing gas cap due to early breakthrough. Note: The calculator does not
account for migration of reservoir oil into the gas cap.
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The volumetrics calculator allows entry of a produced gas from gas cap. You
could possibly use this feature in a one well reservoir where either the well
cannot be recompleted in a lower interval or it is not economical to do so.

Note: Production of gas cap gas from a gas cap drive reservoir reduces the oil
recovery and therefore is NOT the recommended way to produce the reservoir.

The method used for gas cap drive assumes that the oil saturation at any time
step is uniform throughout the original oil zone and that gas cap gas expansion
across the original gas-oil contact immediately spreads uniformly through the oil
zone. The calculated gas-oil ratios will be too high before gas breakthrough to
the wells and too low after breakthrough, which will reduce the reliability of the
reserve estimates.

Tracy's Method
The same iterative procedure used to calculate solution drive production is used
in the gas cap drive with a few additional parameters in Tracy's method. The
calculation procedure is repeated below with the gas cap parameters included.

© 2014

Main Module

The equations for Tracy's functions are:

© 2014

767

768

PETRA Help

The following lists definitions and equations for the variables listed earlier:

Oil Recovery
The oil recovery for the gas cap drive method is calculated by:

Total oil recovery is determined by:

Gas Recovery
The solution gas recovery due to gas cap drive is calculated by the following
equation:
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The gas cap production is the total gas cap production as input. The gas cap
gas production for each 200 psia decrement is calculated as a function of the
change in Z/P for the 200 psia reservoir pressure drop to the total change in Z/
P from initial conditions to abandonment condition. This gas cap gas production
scheme skews the gas cap production toward the end of the reservoir
production life to approximate actual production practice.

The formula for delta GPC is:

Combination Drive
Few oil reservoirs produce exclusively by one of the previously discussed drive
mechanisms. In most cases, the reservoir uses at least two or possibly all
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three of the mechanisms. The combination drive mechanism allows you to
specify any combination of the water drive, solution drive, and gas cap drive for
a recovery calculation.

Note that for a partial water drive with a gas cap, the water invasion zone
cannot extend into the gas cap. If this occurs the gas cap expansion is set to
zero and the water invaded volume is set equal to the total oil in place volume.
Gravity effects are ignored.

In order for oil volumetrics calculator to calculate a recovery for each specific
drive mechanism to include in the recovery calculation, you must input a volume
for each drive mechanism. To allow a gas cap drive, the initial discovery
pressure must be equal to the reservoir bubble point pressure. The program
displays a warning message if these pressures are not equal and will not allow
you to input gas cap parameters. All recovery calculations are carried out at in
the specific drive calculations with the exception of water drive.

The modified water drive recovery equation is:

The total recovery for a combination drive reservoir is:
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Use of SOL.RECOVER or GC.RECOVER is dependent on whether gas cap
drive is included as part of the combination drive.

The fractional recovery for the combination drive is:

Partial Water Drive
The following two factors affect partial water-drive recovery:
Strength of the associated aquifer
Residual gas saturation

Because the gas volumetric calculator does not perform time-step calculations,
it makes certain simplifying assumptions to calculate partial water-drive
recovery. First, the entire reservoir is assumed to undergo volumetric depletion
to abandonment pressure. At this time, determining any additional recovery in
the water-swept zone accounts for the effect of water influx.
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After the residual saturation is determined, separate recovery factors are then
calculated for volumetric and water drive performance of the reservoir:

The volumetric recovery factor is multiplied by the total reservoir volume while
the water-drive factor is applied only to the estimated volume swept by water.
Because no water-influx is assumed to occur until abandonment pressure is
reached, this method is most applicable if the rate of water influx is low relative
to the rate of gas withdrawal from the reservoir.

Total recovery from partial water drive reservoirs is thus calculated as the sum
of the volumetric and water drive recoveries:

Acre-ftv refers to the entire existing hydrocarbon zone, while acre-ftw
represents the anticipated portion of acre-ftv that will be swept by water.
Recovery efficiency is therefore considerably affected by the quantity acre-ftw.
Naturally, if the water-swept portion is set equal to the volumetric (total)
volume, the theoretical maximum recovery will be calculated.

Estimation of the reservoir volume swept by the advancing aquifer is difficult.
Unless the water-drive is extremely weak, it is recommended that the waterswept zone be taken as the volume down-dip of the highest well on the
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structure. If formation stratigraphy indicates a potential for coning, this volume
must be adjusted downward.

Aquifer response also represents an important factor in determining ultimate
recovery due to the effect it has on the absolute quantity of gas left in the
reservoir. The trapped gas saturation has been found to be largely independent
of the pressure at which the gas is trapped, but generally ranges from 30% to
50% of the pore volume. Although this trapped saturation is essentially
independent of pressure, it can be shown that identical saturations can
represent vastly different quantities of gas through use of the ideal gas law.

Applying the ideal gas equation to the gas trapped in one cubic foot of pore
volume behind the front, we have:

Because Sgr is independent of pressure and the RT term remains constant if
the reservoir produces isothermally, the actual moles of trapped gas is directly
proportional to pressure:

Thus, high pressure maintenance due to rapid water-influx will lower ultimate
recovery significantly due to the high molar-density of residual gas. In cases of
strong pressure maintenance, it is reasonable to assume a 10% pressure loss
if no other information is available. Sometimes you can make better estimates
by analogy with similar reservoirs, but you should exercise careful judgment in
order to select a reservoir with similar characteristics.
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Map Module
The Map Module creates maps of a wide variety of Petra data. The Map Module
also creates grids and displays contour maps based on those grids. Importantly, the
Map Module is only available when there is at least 1 well in the project.
To open the Map Module, select Tools>Mapping from the menu bar at the top of the
Main Module, or select the
icon on the Main Module's Toolbar.

The Map Module

Getting Started
Plotting Well Symbols
Adding Culture and Annotations with Overlay Data
Posting Data around Well Symbols
Creating Grids and Contour Maps
Adding Attribute Maps
Adding Bubble Maps
Adding Symbol Highlights
Adding Drainage Ellipses around Well Symbols
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Displaying Log Curves under Well Symbols
Adding Production Charts around Well Symbols
Displaying Seismic Lines on the Map
Adding Dip Symbols
Posting IP/DST around Well Symbols
Addinng LatLon and XY Ticks to the Map
Adding WMS Aerial and Satellite Imagery
WMS Imagery
Working with Deviated Wells
Setting the directional well's symbol location
Displaying interval data on deviated well paths
Formation tops on deviated well paths
Adding dip-azimuth arrows on deviated well paths

Keyboard Shortcuts
ESC Key - While redrawing the screen, terminates drawing and returns control to the
mouse.
Space Bar - While redrawing the screen, terminates current map element and begins
drawing the next element.
F1 Key - Snaps mouse cursor to nearest well.
F2 Key - Snaps mouse cursor to nearest overlay line control point with 0.1"
tolerance.
F3 Key - Snaps mouse cursor to nearest quarter section grid intersection.
F4 Key - Hot key to activate moving posted data-by-well.
F5 Key - If an overlay line is selected, F5 shows the next overlay line sharing the
common location.
F9 Key - Toggles on/off a readout of the XY or Latlon coordinates of the cursor
location.
CTRL+F9 - Toggles between approximate and true screen scaling mode.
"+" Key - While in zoomed mode, pressing the "+" key zooms in by 1/4 of the
zoomed map extents.
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"-" Key - While in zoomed mode, pressing the "-" key zooms out by 1/4 of the
zoomed map extents.
Delete Key - Drop last well picked during cross-section well selection, deletes the
currently selected overlay line or text item, drops last point while drawing an overlay
line
Shift+Arrow Keys - Scroll the map while in zoom mode.
Alt+Arrow Keys - Move cursor one pixel on screen.
Control Key - Hold down the control key when doing a quarter section auto snap to
find polygons containing more than 5 pts.

Mouse Shortcuts
Left Mouse Button
Single click on a WELL symbol to select the well for moving, deleting, etc.
Double click on a WELL symbol to jump to the Main module and SHOW WELL DATA
for the well.
Double click on a Contour CONTROL PT to modify or delete it.
Single click, hold and drag to move a selected OVERLAY LINE control point.
Single click on a well while holding down the CTRL-Key will choose the next well that
is plotted in the exact location, such as, with multiple
completions which post on top of each other.
While SEISMIC LINE DIGITIZING, click while holding down the CTRL-Key to skip
the next shotpoint.
Double-click while holding down the CTRL and ALT keys to edit a posted GRID
NODE VALUE.
While moving posted well data, if the SHIFT-Key is held down, then the other posted
blocks of text move by the same xy delta as the selected block.
Single click while holding down the SHIFT+CTRL keys to select multiple overlay line
or text items

Right Mouse Button
Single click on a WELL to show a popup menu containing general well information.
Single click while holding down the SHIFT KEY to search for and display the nearest
SEISMIC shot point number.
Single click while holding down the ALT KEY to move an OVERLAY LINE or TEXT
item.
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Single click while moving posted well text to reset the text to the default location.

5.1

Map Quick Lists
The Map Module's Quick List modifies the active features on a map. Relative to
selecting the "active" button for each feature, the Quick List is a much faster way of
changing elements on the map.
To display the Quick List Panel, select the
icon on the tool bar, or select
View>Quicklist>Show on the menu bar at the top of the Map Module.
To hide the Quick List Panel, select the
button on the upper right corner of the
Quick List Panel, or select View>Quicklist>Show on the menu bar at the top of the
Map Module.
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The Map Module's Quick List

Map Data Section
The Map Data section toggles and modifies various map display features.
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The Quick List's Map Data Section

Double-clicking any item in the list will bring up the appropriate dialog box to set the
display parameters for that item.
Double-clicking on the "Wells" item brings up the "Select Wells by Data Criteria"
search function.

Overlay Layers Section
The Overlay Layers section toggles the layers inside the currently loaded overlay file.

The Quick List's Overlay Layers Section

- This option refreshes the map to reflect any changes to the selected overlay
layers. Select this option after adding or removing checks to the listed overlay
layers.
- This option reloads the overlay file. Any changes made to the overlay will be
lost.
- This option saves the overlay file. This will overwrite the old file with any
changes made in the Map Module.
- This option adds a check to all overlay layers. You'll still need to refresh the
map in order for the changes affect the Map Module.
- This option removes the checks from all all overlay layers. You'll still need to
refresh the map in order for the changes affect the Map Module.
Show Overlay - This option toggles the overlay layer.
Active Layer - This option sets a specific overlay layer as the "active layer." Only
items in this can be selected with the mouse. If the active layer is a read-only or
associated layer, you will NOT be able to select any items.
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WSN Well Lists Section
The WSN List section manages well selection using multiple WSN list files. This tool
toggles selections of wells in the one or more WSN list files.
Using any of the "Select Wells" menu functions will cause the WSN List files to be
"unchecked."
Also, when the list is cleared or when all items are "unchecked", the map reverts
back to a "default" well list that was established prior to selecting WSN list files.

The Quick List's WSN List Section

- This option refreshes the map to reflect any changes to the selected overlay
layers. Select this option after adding or removing checks to the listed overlay
layers.
- This option adds a WSN List to the WSN List Section. In the "Select One or
More WSN List Files" section, navigate to the desired directory and select the
relevant WSN files.

Adding a Saved WSN List to the WSN List section

- This option drops the selected WSN list off the WSN List section. Note that this
does not delete the WSN list.
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- This option drops all WSN lists off the WSN List section.

Imagery Section

The Quick List's Imagery Section

- This option opens the WMS Imagery Settings tool.
- This option refreshes the WMS Image from the WMS Server
Map Image Active - This option toggles the WMS Image on the Map Module.

Map Navigation Section
This section displays a small thumbnail picture of the map. When zoomed in, this
section will display a red rectangle outlining the extents of the area shown on the
screen relative to the entire map area. Moving this red rectangle will pan the area
displayed on the Map Module. Resizing the red rectangle will change the area
displayed on the Map Module.
For more information, see Map Navigation.

Inactive Map Navigation

Capturing a Map Screenshot with the Green "Open" button

- This option captures a screenshot of the Map Module for the Map Navigation
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section. The Map Module must be completely zoomed out before selecting this
button.

Active Map Navigation
With a screenshot, Petra draws a red rectangle or "Zoom Window" on the Map
Navigation window to show the extents of the current screen relative to the full extent
of the map. Zooming in and out will change the dimensions of this rectangle.
Dragging the zoom window will scroll around the full map. Resizing the zoom window
will change the zoom on the Map Module.

The Quick List's Map Navigation Section

- This option closes the Map Navigation section.
- This option refreshes the map.
- This option zooms in by 2X.
- This option zooms out by 2X.
- This option zooms out to the full extent of the map.
5.1.1

Map Navigation Tool
This section displays a small thumbnail picture of the map. When zoomed in, this
section will display a red rectangle outlining the extents of the area shown on the
screen relative to the entire map area. Moving this red rectangle will pan the area
displayed on the Map Module. Resizing the red rectangle will change the area
displayed on the Map Module.

Inactive Map Navigation
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Capturing a Map Screenshot with the Green "Open" button

- This option captures a screenshot of the Map Module for the Map Navigation
section. The Map Module must be completely zoomed out before selecting this
button.

Active Map Navigation
When active, Petra draws a red rectangle or "Zoom Window" on the Map Navigation
window to show the extents of the current screen relative to the full extent of the map.
Zooming in and out will change the dimensions of this rectangle. Dragging the zoom
window will scroll around the full map. Resizing the zoom window will change the
zoom on the Map Module.

The Quick List's Map Navigation Section

- This option closes the Map Navigation section.
- This option refreshes the map.
- This option zooms in by 2X.
- This option zooms out by 2X.
- This option zooms out to the full extent of the map.
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Resizing the Zoom Window

5.2

Map Right Mouse Button
The right mouse button acts as a shortcut to many functions on the Map Module.
Spending a couple of minutes learning these commands can save a huge amount of
time and effort.
This tool is context-sensitive. Clicking the right mouse button over a well brings up an
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additional set of options that pertain to the well.

The Right Mouse Button menu (left) and the right mouse button when used on a well (right)

Layers - This option opens the Overlay Layers tool
Active/Inactive Options... - This option opens the Disable and Enable Map Options,
which enables and disables different map elements.
Show Well Data (selected well only) - This option opens the selected well on the Main
Module.
User Favorites (selected well only) - This option displays the user favorites dropdown
display. The specific well header and zone data is set by the individual user.
Change Symbol Size... (selected well only) - This option changes the well symbol size
of the selected well relative to the default well symbol size.
Add Well to Cross-Section - This option adds the selected well to the end of the cross
section in the Cross-Section Module.
Add Well to Log Correlation - This option adds the selected well to the end of the
cross section in the Log Correlation Module.
Disable Well (do not plot) (selected well only) - This option disables the selected well
on the Map Module. Disabled wells do not plot, but are still honored during gridding.
To re-enable wells, select Wells>Enable Wells Single Wells By WSN or Wells>Enable
All wells that have been Disabled on the menu bar at the top of the Map Module.
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Save Disabled Wells to File - This option saves the disabled wells to a WSN list.
Load Disabled Wells from File - This option disables the wells on a WSN list.
Bing Map at Location - This option opens a Petra Map Browser window with a
satellite map around the location at the cursor.
Copy Location Lat/Lon to Clipboard - This option copies the cursor location's lattitude
and longitude to the clipboard. This can be useful for copying into other software
packages or for planning new wells.
Well Information (selected well only) - This option displays well header information at
the bottom of the right mouse menu. This includes the WSN, UWI, well label, and
other information.

5.3

WMS Imagery

WMS
WMS stands for “Web Mapping Service”, which is a protocol for requesting and
downloading georeferenced map images over a computer network. A WMS server
stores map data, assembles map images based on specific requests from client
computers, and delivers these images back to the clients over a network. While
some companies have their own in-house WMS servers, most users will be
downloading images from a server on the Internet.

WMS imagery underneath wellspots in the Map Module

WMS and Petra
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Petra’s Map Module acts as the client that requests data from a WMS server. With
a WMS connection active, Petra sends a request for a map to the WMS server
every time the user moves the screen, zooms in/out, or redraws, Petra requests a
new map from the server. The WMS assembles a map based on the requested
layers, map boundaries, and map projection and sends it back to Petra. Petra then
draws the received WMS map in the map module. Since each image is already
georeferenced, Petra can display these maps in the proper scale and place
automatically. Petra draws WMS images underneath other map features such as
landgrids and wellspots. Importantly, these images are only stored temporarily.

WMS and Map Projection
Just like all other geospatial data, WMS data rely on map projections to convert
information on the round shape of the earth to a flat image on a computer screen or
piece of paper. WMS data store map projection information for each image in a
series of “EPSG codes.” Each EPSG code records the reference datum and
coordinate system used to create the image. Similarly, a Petra project’s reference
datum and coordinate system can also be described as an EPSG code.
Both the WMS EPSG code and the Petra project’s EPSG code need to match for
WMS data to plot correctly. Petra actually requests a map based on the location of
the NW and SE corners of the map. The more precisely the WMS and Petra agree
on the location of these two points, the more accurate the WMS data is in the Map
Module. If Petra and the WMS server can agree on an EPSG code with both a
reference datum and coordinate system, Petra can request images with foot/meter
precision. Conversely, If Petra and the WMS server can only agree on an EPSG
code with a reference datum but not a coordinate system, Petra can request images
with LatLon precision. Note that Petra will try to find the best common map
projection on its own.

Standard Coordinate Systems
Petra projects using “standard” (Blue Marble) map projections tend to have the best
results with WMS data. Standard projections already have EPSG codes, so the
translation is more precise, assuming there’s an equivalent EPSG code available on
the WMS server. In this case, Petra and the WMS will both use the same reference
datum and coordinate system, so the XY values of the boundaries of the map will
agree.

Custom Coordinate Systems
Petra projects with “custom” map projections are usually older Petra projects
created before the Blue Marble map projection system was implemented. For
custom coordinate systems, Petra will use the reference datum’s ESPG code.
Without agreement on the coordinate system that converts LatLons to XYs, Petra
and the WMS can only use LatLons to establish the boundary of the requested map
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image. This method is less precise.

When there is no Match
Remember that not all WMS Servers support all map projections. Occasionally,
Petra and the WMS just won’t have an EPSG code in common.
Important: Petra does not re-project WMS maps out of the original projection since
the task of repeatedly downloading and re-projecting every pixel on the image would
simply take too long. The only solutions are to contact the WMS administrator to
support the Petra project’s projection, or re-project the entire Petra project to use
one of the available WMS projections.
Some servers do not publish all the projections they support in the capabilities file.
By disregarding error messages, Petra will still request the map using the best
EPSG code it can resolve with the server.
The EPSG registry at http://www.epsg-registry.org/ provides a lookup feature to
search for EPSG codes by location or name, or to translate EPSG codes directly
into datum and coordinate systems.
Related Topics:
Configuring WMS
Add/Edit WMS Servers
Image Layer Thumbnails

5.3.1

Configuring WMS
Selecting and configuring WMS servers and image layers is done through the Imagery
Settings dialog box.
From the Imagery Settings dialog you can:
Add or remove WMS servers
Enter or edit WMS server settings and credentials
Select order of server images and image layers on the Petra map
Restore default order of layers as defined in the Petra or GEOPLUS.INI file

Accessing the WMS Imagery Settings
There are two ways to access the WMS Imagery Settings dialog box:
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From the Map Module menu, Display>WMS Imagery Settings
Clicking the blue wrench icon
Quick List.

on the “Imagery” section of the Map Module's

The WMS Imagery Settings Dialog

WMS Imagery Performance Options
Petra’s default WMS settings are designed to find a balance between image detail
and speed. WMS performance largely depends on the connection to the WMS
server. However, there are options to change how Petra downloads and displays
WMS data.
Do Not Refresh Images During Zoom – By default, Petra downloads a new copy of
the image every time you zoom in on the map. With this option selected, Petra
resizes the existing image without downloading another copy. This can reduce waiting
times.
Store Images to Temp Folder/Store Images to PriParms Folder – This dropdown
simply sets where Petra stores the temporary copies of the WMS images. Some
network administrators limit access to the PriParms directory. If you’re having trouble
with WMS downloads, try switching to use a Temp directory.
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Do Not Display Wait Image During Image Download – By default, Petra displays a
“Wait” message while it is downloading images from the WMS server. This option
simply turns that off.
Image Resolution – On the “Normal” setting, Petra downloads a downsampled copy
of the original WMS image. By only downloading half the detail, loading time is
greatly accelerated at the cost of some image blurriness. Setting this option to “Fine”
tells Petra to download the entire image, which increases both image sharpness and
load times.

Related Topics
WMS Imagery
Add/Edit WMS Servers
Image Layers

5.3.2

Add/Edit WMS Servers

Add WMS Servers
1. Display>WMS Imagery Settings
2. Click the Add button next to the Servers list.
3. Select either:
Add from List
Displays the list of WMS servers in the WMS section of either the Petra.INI (Shared
Mode) or GEOPLUS.INI (Private Mode) file.
1. Select desired WMS server(s) for your project.
2. Click OK.
Add New
Displays the Web Map Service dialog box.
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Their are two options to add a WMS server in the Web Map Service dialog box. You
can:
Click on the Get Spatial Energy button to add a WMS server provided by IHS
Petra partner Spatial Energy. See "Image Layer Thumbnails" below.
Enter a URL directly.
IMPORTANT: WMS server URL's end in a “?”, it may be necessary to delete text
past the question mark from the end of a provided URL.
For example:
http://www.earth.com/ecwp/ecw_wms.dll?request=GetCapabilities&service=wms
should be:
http://www.earth.com/ecwp/ecw_wms.dll?
4. Click OK.

Image Layer Thumbnails
Adding a WMS server using the Add New option will populate the Web Map Services
dialog box with thumbnail images once the WMS server is contacted. To select
layers, click on a thumbnail once. Selected layers will be indicated with a yellow
border. When all the desired layers are selected click OK .
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Edit WMS Server settings
Available server settings include:
User defined server description
Users credentials
ESPG Code
Timeouts
Image opacity

1. From the Map Module menu, Display>WMS Imagery Settings.
2. Select desired servers checkbox(s) from the Servers list.
3. Click the Edit Server Settings button.
4. Make edits.
5. Click OK.
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Related Topics
WMS Imagery
Configuring WMS
Image Layers
5.3.3

Image Layers

Selecting and Sorting Order of WMS Layers
Once linked to the WMS server, Petra compares the project’s EPSG code with the
server’s available data’s EPSG codes and displays the WMS layers that are available.
If multiple layers are requested, the WMS server stacks these layers into a single
image and delvers it to Petra. One of the complications of multiple layers is that it’s
often necessary to manually change the drawing order. As an example, reordering
might be required to put vector data (like pipelines and roads) on top of non-vector
data (like aerial and satellite photos).

To select and change the order of available layers
Display>WMS Imagery Settings
1. Select the desired WMS server(s) from the Servers list.
2. Double click, or use the controls to move desired Layers from the Layers Available
to the Layers Selected list box.
3. Select individual layer in the Selected Layers list box and use the UP or Down
controls to arrange order of layers.
4. Click OK.
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IMPORTANT: Layers on the top of the list are drawn before (and below) layers on
the bottom of the list.

Related Topics
WMS Imagery
Configuring WMS
Add/Edit WMS Servers

5.4

Graphics Plotting Order
The Select Graphics Plotting Order tool changes how Petra Draws elements on the
Map Module. Items at the top of the list are drawn first. Practically, items at the top
of the list will be below items at the bottom of the list.
To change the list order, select the desired element and drag and drop it to the
desired position on the list. Conversely, use the arrows to move the element.
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The Select Graphics Plotting Order Tool

Reset - This option resets the items to the default graphics plotting order. This is
generally a good choice for most maps.
Use Default Order - This option overrides the graphics plotting order list, and uses a
default plotting order.
Plot Overlay as Single Pass using Layer Order Only - This option draws every layer in
the overlay at one time. This option overrides the order of overlay-specific items like
"Overlay Filled Areas" and "Overlay Filled Contours."

5.5

Map Data Limits
Data limits define the maximum aerial extent of the data that Petra keeps in memory
and can display. Put another way, data limits define how far you can zoom out.
Data limits can be set to automatically extend to cover the selected wells, the overlay,
or an arbitrary area from XYs or Lat-Lons.
To change the data limits, select Display>Data Limits>....
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Auto Limits From Data - This option sets the data limits around the wells displayed on
the Map Module. Note that this option isn't affected by disabled wells. This option is
on by default, and is a great choice for most interpretation work. Selecting a different
set of wells can change the extents of the map module.
Set/Enter Limits - This option manually sets the map limits by either LatLons or XYs.

Set Mid Pt and Scale - This option manually sets the center of the map and the map
scale. First, select the center of the map, and then manually set the map scale in ft/
inches.

Load Limits - This option replaces the currently set limits with the limits from an
external *.LIM file.
Save Limits - This option saves the current limits to an external *.LIM file.
Save Limits for PetraSeis Limits - This option saves the current limits to an external *.
LIM file, suitable for use in PetraSeis.
Use Overlay Extents - This option sets the limits based on the extents of the elements
in the loaded overlay file. Note that this option will use the extents of al elements in
the overlay, whether they are displayed or not. Some culture data (like country
outlines) are huge and will zoom very far out.

5.6

Data Border Gap
The data border gap establishes a space between the extent of the wells and the
border. Without a gap, wells would fall right on the border, making them difficult to
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see.
To establish a data border gap, select Display>Data Border Gap on the menu bar at
the top of the Map Module.

No border gap (Left) and a 10% Border Gap (Right)

The Data Border Gap Tool
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Map Margins and Preferences
The Map Margins and Preferences tool controls how Petra displays map, especially
on paper.
To establish a data border gap, select Display>Options on the menu bar at the top of
the Map Module.

General Tab
The General Tab controls a few of the details on how Petra displays data on the Map
Module

The Map Margins and Preferences General Tab

Data Extents
This section sets how the Map Module treats data limits. To rapidly switch between
the two modes, select CTRL + W in the Map Module.
Extend Data to Border Frame - This option will expand the map to fill the Map Module.
This option will sometimes draw the map beyond the data limits.
Clip data at Margin Limits - This option limits the border to only the data limits.
Depending on the shape of the data limits, this can leave a fair amount of white space
on the Map Module.
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The "Expand Data to Border Frame" (left) and "Clip Data at Margin Limits" (right) options

Miscellaneous
Hide Lower Right Corner Map Scale Bar - This option turns off the scale bar in the
lower right corner of the screen. With this option selected, the map scale will not plot
on the screen or on paper.
Hide Map Title - This option turns off the map title at the top of the screen.
Hide Map Border - When the "Show Margin Frame On Screen" option is selected on
the Margins Tab, this option disables the Map Border (Data Limits + Margin) frame.
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Disable Clipping - This option disables contour clipping polygons set on the Overlay
Line Attributes tool.
Show Overlay Name - This option displays the name and location of the currently
loaded overlay file in the lower left corner of the Map Module.
Measure Tool Shows XY instead of LatLon - By default, the Map Module's Measure
Tool displays the endpoint's location in latitude and longitude. This option instead
displays the endpoint in XY units.
Measure Tool Shows MILES or KM - By default, the Map Module's Measure Tool
displays the distance between the start and endpoints in feet or meters. This option
instead displays the distance in miles or kilometers.
Hide Boundary Polygon - This option hides the outlines of boundary polygons on the
Map Module.
Hide Well Info at Mouse - By default, hovering the cursor over a well symbol displays
the well's WSN and UWI in the lower left corner of the Map Module. This option
disables the display.
Show well list for Xsect Selection Map Scale bar Offsets from Corner - These options set the spacing of the scale bar
away from the lower right corner

F9 "Fly By" Position - The F9 button superimposes the cursor's location in XY or
LatLon. This dropdown sets the location of the text above, below, left, or right of the
cursor.

Margins, Gutter, Cut Line Tabs
The Margins, Gutter and Cut Line Tabs set the extents of margins on paper maps.
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The Margins Tab, Gutter Tab, and Cut Line Tab

Margins can be used in place of the Data Border Gap to specify and exact amount of
space between the well or seismic data and the border. Overlay data will plot in the
margin area. It is recommended that the Data Border Gap be deactivated when a
margin is added.
The Gutter is like a "picture frame" around the map margins. Overlay data will not
extend into the gutter area unless the user allows it.
The Cut Line only appears on a plotted map and provides a box, or "cut line" around
the whole map. The Cut Line is required if the map title block is to placed in the lower
right-hand corner, below the map (position 8).

© 2014

804

PETRA Help

Margins, the Gutter, and the Cut Line relative to Data Plotted on the Map Module

North Arrow Tab
The North Arrow Tab controls how the north arrow plots on the Map Module. The
north arrow serves to illustrate the effect of the convergence angle. In other words,
when the project area is away from the map projection's central meridian, the north
arrow will always point at the local grid north.
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Show North Arrow When Convergence Angle is Not Zero - This option only displays
the north arrow when grid north (defined by the location relative to the map projection
's central meridian) is different than true north (at the top of the screen). The
difference between the two is the "convergence angle."
Always Show North Arrow - This option always shows the north arrow, even when
grid north and true north are both directly at the top of the screen.
Do Not Show North Arrow - This option disables the north arrow on the map.
Position - This dropdown sets the location of the north arrow on the map. Options
include the NW, NE, SW, and SE corners of the map.

5.8

Highlight Wells
The Highlight Wells tools quickly distinguishes between different sets of wells with a
colored circle. This tool can distinguish wells based on data criteria, wells selected on
the cross-section Module, or wells selected on the Cross Plot Module.
This tool is available under Wells>Highlight Wells>...
To change the well highlight color, change the "Well Map Highlight" option under
Display>Colors.
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Select Wells by Data Criteria - This selects wells using the Select Wells by Data
Criteria tool.
Cross-Section Wells - This option highlights the wells currently selected in the CrossSection Module
Cross-Plot Wells - This option highlights the wells currently selected in the Log CrossPlot Module
None - This option disables the well highlight.
Set Symbol Well Factor - This option sets the diameter of the well highlight symbols
scaled to the size of the well symbol The default size of 1 is just a little bigger than
the well symbols.

5.9

Move A Well Location On The Map

Moving Vertical Wells
First, select the well to move by clicking the left mouse button on the well symbol.
The symbol will become highlighted to indicate it is selected.
Select Well>Edit>Move Well Location on the menu bar at the top of the Map
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Module.
The cursor will change to a cross hair and a "rubber band" line will connect the
cursor to the selected well symbol.
Move the cursor to the new well location and click the left mouse button. You will be
prompted to confirm the new well location. After updating the location in the
database, the map will be redrawn.

Moving Deviated and Directional Wells
Wells contain a surface and a bottom hole location in the database. When you move
a well the coordinates updated are determined by the well display mode. If you are
plotting surface locations only, then only the surface location will be updated. If you
are plotting bottom hole locations only, then the bottom hole location will be updated.
If you are plotting surface and bottom hole locations, the bottom hole location will
become the location at the cursor and the surface location will be adjusted by the
same amount of movement.
The location of the selected well can be moved using the mouse to select the new
location.
Note: Directional survey data must be disabled before you can edit well locations.
Survey data is enabled whenever the "Well>Directional Survey>Enabled" has a
check mark by it. Click this menu to toggle the survey option off.

5.10

Data Offsets File Manager
In fields with tightly packed wells, label overposting can be a problem. When a user
moves a well's labels, Petra stores the new location in the project database. These
offsets can also be saved to an external file. It can be useful to store multiple data
offset files for different maps.
To open the Data Offsets File Manager, select Wells>Data Offsets File Manager
from the menu bar at the top of the Map Module.

Enabled - This option enables the Data Offsets File Manager.
Disabled - This option disables the Data Offsets File manager.

Load Offsets File - This button loads an existing offsets file (*.OFF).
Save Offsets File - This button saves the current offsets to an eternal offsets file.
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Clear Offsets - This option removes all user-created label offsets, and restores the
labels to the default position.
Copy DB Offsets - This option copies the offsets from the project database.

5.11

Well Symbol Style
The Wells Symbol Style window sets how the Map Module draws well symbols and
establishes a simple well labeling system. The well label is a single line of text and
can be used as an alternative to using Data Posting.
To open the Well Symbol Style Screen, select Wells>Symbol Location and Size...
from the menu bar at the top of the Main Module.

Symbol Tab

The Well Symbol Style's Symbol Tab

Symbol Size
These settings control how the Map Module displays well symbols.
Small - This sets the well symbol size to 0.05 inches.
Medium - This sets the well symbols to 0.075 inches.
Large - This sets the well symbols to 0.12 inches.
Custom - This option sets the well symbols to a specified size. This size can be set
in inches or XY units on the Options Tab.
Enlarge with zoom - This option enlarges well symbols as you zoom in.
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Limits - The Min and Max entries set the minimum and maximum size in inches for the
well symbol. Setting this entry to "0" turns off the limit.

Symbol Location
This option sets the location of the well symbol. This also sets the default location of
data points along deviated wells for some gridding applications.
Surface Location Only - This option displays the well symbol only at the surface
location.
Bottom Hole Location Only - This option displays the well symbol only at the bottom
hole location.
Surface & B-Hole w/ Symbol at B-Hole - This option plots the well symbol at the
surface location with the "BH Marker" at the bottom hole location
Surface & B-Hole w/ Symbol at Surface - This option plots the well symbol at the
bottom hole location with the "Surface Marker" at the surface hole location

Symbol Color
Use Default Color Only - This option draws all well symbols using the "well symbol
default color" defined in the System Color and Style Definitions tool.
Use Symbol Definitions - This option draws well symbols using each wells' symbol
definition specified on the Main Module. These defaults can be modified with the
Well Symbol Descriptions section.

Annotation Tab
This tab sets up simple well labeling around all wells. It only appears when the "
Allow Simple Well Labeling" option is selected on the Options Tab.
This annotation system is independent from the more elaborate and comprehensive
data posting system.

© 2014

810

PETRA Help

The Well Symbol Style Annotation Tab

Well Label - This option sets the label that will appear around each well. Options
include:
No Label (Suppress the well label)
Unique Well Id (UWI or API Number)
API Series No. (5-digit series number or the UWI)
Well Short Name
Well Label
Well Seq No. (WSN)
Font - This option sets the desired font for the label.
Position - This option sets the position of the label to above, below, left or right of the
well symbol.
Label Size - This option sets the size of the label. Options include:
Small - This sets the text size to 0.05 inches.
Medium - This sets the text size to 0.075 inches.
Large - This sets the text size to 0.12 inches.
Enlarge with zoom - This option enlarges the annotation text as you zoom in.

Options Tab
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The Well Symbol Style's Options Tab

Custom Sizes Are Specified As
Inches - This option sets the symbol custom size in inches.
XY Map Units - This option sets the symbol custom size in XY map units.

Flag "Unknown" Symbol Codes with X - This option will draw an X on all of the open
circle well symbols that do not have a description defined for the symbol code. By
default, Petra draws an open circle for these wells, which is identical to the "LOC"
symbol.
Use Opaque Symbols - This option causes open wells symbols, such as a gas or dry
hole symbols, to be plotted using the background color (normally white) to fill the
interior of the symbol. Use this option when you wish the well symbols to stand out
against a colored background.
Disable Mouse Selection of Wells That Are Not Initial Completions - This option
prevents recompletions from being selected on the Map Module. With this option
turned on you will not be able to select a well if the UWI does not have 14 characters
or it does not end in 00.
Allow Simple Well Labeling - This option allows simple
Plot Wells Even if Location is Outside Limits Exclude "Pseudo" Wells When Loading Wells Zoom Factor When Hilite Well from Main (0-200) Surpress Detailed Deviation Surveys for Scales >... -
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Wells Tab
The Wells Tab establishes "Primary" and "Secondary" wells. Secondary wells are
grayed out and can be plotted at half scale. This can be useful for distinguishing
between the relevant wells in a project and wells that are too shallow or otherwise
lack useful information.

Wells Tab

Spot All Wells With Normal Size and Color - This option plots all wells normally.
Spot Primary Wells In Normal Mode with Secondary Wells Plotted 1/2 Size and
Grayed Out - This option plots wells NOT in the WSN list at the bottom of the screen
at half size and grayed out.
Spot Primary Wells in Normal Mode with Secondary Wells Plotted Full Size and
Grayed Out - This option plots wells NOT in the WSN list at the bottom of the screen
at full size and grayed out.

5.12

Overlay Graphics
Overlay files contain lines, shapes, text, or images drawn on top of other data drawn
on a map. Commonly, overlays represent leases, contours, roads, aerial photos, or
comments. Overlay layers can also include geological information like contour lines,
fault lines/polygons, or unconformities.

"Overlays" and "Layers"
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Petra stores overlay data in a single overlay file (*.OVL). Each overlay file can
contains up to 256 different layers of data. Usually, every layer contains a set of set
of data that's somehow related. single layer of data. You might want to think of a
layer file as a single layer exported from an overlay file. Layer files can be loaded into
any overlay file (actually loaded into memory and saved to an overlay file).
Layers can be turned on or off easily by either using the Overlay Preferences (menu
or toolbar icon) and double clicking specific layers, or by clicking on individual layers in
the Quick List. Petra draws items at the top of the layer list first with items lower in
the list being drawn last; in other words, layers at the top of the list will be covered by
layers at the bottom of the list.
Layers can also be saved to an external file and read as an Associated Layer Files,
which can make keeping data updated in a multi-user environment much easier.
While well and seismic data is drawn dynamically from the project database, other
graphics, such as, land grid lines, lease outlines, culture, rivers and roads are
displayed from layers in the overlay. Individual layers in Petra can be shown or hidden
depending on the desired displayed.

Overlay Files and Multiple Users
Don't share overlay files between multiple users. Every user should have their
own file.
Graphics in the overlay are loaded into memory. Once loaded, the overlay file is not
accessed again unless the user saves the overlay back to the same file. Additions and
changes to the overlay data are made to the memory copy of the data. Other users
sharing the same project, each have their own copy of the original overlay file in their
memory. So everyone's changes are isolated from each other. This is analogous to
several people loading the same spreadsheet file, making changes, then saving back
to the same file. Only the last changes are kept. One great way around this problem
is to use Associated Layer Files.

Getting Started
Importing Cartographic data into the Overlay
Using the Overlay Tool Bar
Editing Individual Lines, Text and Images
Modifying the Lines and Text in Entire Overlay Layer
Loading Overlay Layer Files (*.LAY), Saving Overlay Layer Files
Sharing Data between Users with Associated Layer Files
Using the Auto Save Feature
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Advanced Tools
Using Overlay Contours to Guide Gridding
Color Filling Overlay Contour Lines
Lineament Analysis and Rose Diagrams

5.12.1 Importing Overlay Data

Petra can import and display cartographic data from a variety of sources. This can
include "culture" data like roads, or geological data like contour lines. This data is
stored in the open overlay file.
To import overlay data, select Overlay>Import from the menu bar at the top of the
Map Module.

File Tab
The file tab sets the location of the file, and how the data will be stored in the
overlay.

Selecting a file, file type, and destination overlay layer with the File Tab

File To Import - This option selects the desired file to import. Select the "Browse"
button to navigate to the desired file.
Layer Update Mode - This option sets how Petra treats data in the destination
overlay layer. "Merge with Current Layer Data" will add the data from the file into
the overlay layer, while "Replace Current Later With The Imported Data" will
completely erase the selected overlay layer and overwrite it with the imported data.
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File Type - This dropdown selects the file type of the imported data.
Load Into Layer - This option sets the overlay layer that will store the imported data.
The "Rename Layer" button will rename the currently selected overlay layer.
Load into Specified Layer - This option brings all the imported data into a single
layer.
Load Separate Layers - This option attempts to differentiate between the different
overlay items in the imported file and place them into separate layers.

Limits Tab
Importing irrelevant data such as particularly detailed road and subdivision outlines
can dramatically slow performance and redrawing. The Limits Tab sets the limits of
the import, which are shown by the longitude and latitude boxes.

The Import Cartographic Data Limits Tab

Do Not Restrict Data By Limits –The entire file is loaded, regardless of location.
Use Full Data Limits – This option only imports data inside the area defined by
selected wells in the map module.
Use Current Border Limits – Data inside the current, completely zoomed out data
limits (set in the Map Module under Display>Data Limits>Set/Enter Limits) is loaded.

Misc Tab
The Misc Tab deals with some of the tweaks necessary for certain data types.
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The Import Cartographic Misc Tab

Auto Close Polygons – this automatically closes all polylines in a layer during import.
This can be useful when importing polygons like contours or lease polygons.
Create Labels for Polygons for CDF Files - This automatically creates overlay text
labels for CDF Culture files.
Create Volumetrics Labels – This creates appropriate volumetric polygon names
that are accessible in the Overlay Line Attribute box under the "Volm" tab.
File is Old Tobin XY Format – Old (mid 1980's) Tobin files have a different file
format. This option helps with backwards compatibility.
ZMap Contour File is Really Lat-Lon Data with XY Headers – This tells Petra to
ignore bad header data in a ZMap file and import Longitude and Latitude data as
such.

Translate Tab
Some file formats encode specific information about each entity in the file. Petra can
use a "translation file" to sort the cartographic data in a file directly into specified
overlay layers.
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Use Entity Code Translation File - This entry enables sorting by the translation file.
Note that if a translation file is enabled, only entities matching the file will be imported
into the overlay file. Data not translated by the file will not make it into the overlay
file.
Translation File Name - This entry sets the location of the translation file.

File Types
Tobin Land Grid (TBRBM)
Tobin Infobase
Plat River Assoc. TwnRgeSec
Z-Map Plus Vertex
Z-Map Plus Text
Contour SegID
Digitized Contours (X,Y,Z) and (Lon,Lat,Z)
Z-Map Plus ASCII Contours
Landmark ASCII Metafile
TMC Township/Range Format
TMC Texas Landgrid
GES Cartographic Data Format (CDF)
Z-Map Fault File (X,Y, SegID)
ESRI Shape File (LatLon) and (XY)
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AutoCAD DXF (LatLon) and (XY)
InfoPipe MID-MIF
GeoQuest CPS-3 Contours
MapInfo MID-MIF
Petra ASCII Overlay File
SMT Planimeter File
WhiteStar CartoBase File
Tobin GII
AccuMap Grid File (GRD)
AccuMap Culture File (CDF)
5.12.1.1 Batch Import Into Map Overlay

The Map Module's "Overlay>Load>Import" function allows for the batch import of
similar type cartographic files. Each file to be imported in batch mode is listed in an
external "batch file". The batch file is in comma delimited format. Each line in the
batch file contains a file name and optionally, a layer name and layer number. The
layer name is optional. The layer name is only entered if you wish to rename the
layer which the file is loaded into. The layer number is normally required but can be
dropped if you wish to use the layer selected from the import screen (see example
below).
The following example shows 4 files to be imported. Any line with a "!" in column 1 is
a comment line.
!Example Overlay Batch Import File
"c:\data\culture\actlease1.cdf","Active Leases",3
"c:\data\culture\actlease2.cdf",,3
"c:\data\culture\sections.cdf",,4
"c:\data\culture\townships.cdf"

The first file, "actlease1.cdf", is loaded into layer 3 and layer 3 is renamed to "Active
Leases".
The second file, "actlease2.cdf", is also loaded into layer 3 (note the double commas
where the layer name is not entered).
The third file, "sections.cdf", is loaded into layer 4 (note the layer is it not renamed).
The forth file, "townships.cdf", is loaded into the default layer selected from the
import screen.
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5.12.1.2 Import ASCII Overlay File - Map

The import ASCII Overlay File function is used to load land grid lines or text, and
digitized contours, faults, or polygons from a tabular (fixed column) ASCII data file.
All items in the file must be of the same data type, i.e., Lines, Text, Polygons,
Faults, or Contours.
Overlay>Load File>Generic ASCII File
Select the appropriate options then click the OK button to begin loading the file.
FILE TAB
Specify the input data file, file contents, coordinate type, and text units.
File To Import
Enter the complete path name or use the "Browse" button to search for the file to be
imported.
File Data Contents
Choose one of the data types you are importing. Options are:
LINES - Normal line segments such as section lines. Line records can include one or
two coordinate pairs.
TEXT - Names of places to be posted in the map. Text records can include one or
two base line reference points, a height and angle.
FAULTS - Same as lines but get flagged and treated as faults.
POLYGONS - Same as lines but get flagged and treated as closed polygons.
CONTOURS - Contours must have a Z value for each coordinate pair.
File Coordinates Are
Choose Lat-Lon if the data file contains latitude and longitude coordinates. Choose
X-Y if the coordinates are XY map units. XY coordinates MUST BE THE SAME as
those of the map, ie, if your map is a UTM map, the XYs imported must also be
UTM.
Text Height Is Specified In
The text height read from the file can be either inches or map units. When inches are
used, the height is assumed to be the text size on a 1"=8000' map scale. Text
heights specified in map units are scale independent.
FORMAT TAB
Select Data Columns
One defines the data fields to be imported by setting the starting and ending column
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numbers and which data type the column is associated with.
Each field is selected for import when it is added to the "Select Data Columns" list
box by clicking the
add button beside the "Data Column Type" list. Fields can be
modified by clicking the
replace button. Drop a field from the selection list by
clicking the ">" drop button or clear all selected fields by clicking the ">>" button.
The "# Implied Decimals" option allows imported data fields to be scaled by a factor
or 10 as they are read in. For example, a value of 1 will divide the incoming data by
10, a value of 2 will divide the incoming data by 100, etc. Implied decimals are
especially useful for data fields which do not contain a decimal point but include digits
right of an implied decimal point.
Data Column Type
Use this list to choose the type of data each column of the input file contains. Use the
X1 and Y1 fields for files with a single coordinate pair per record. Specify X1,Y1 and
X2,Y2 when you have a file with two coordinate pairs defining line segments or the
baseline for text. Text height will default to 0.1 inches if no height field is selected.
Text angle can be read from the file or computed when X1,Y1-X2,Y2 mode is used.
Otherwise, a text angle of zero will be set. Use the SEGMENT ID field to control
grouping or data points into a single polyline or to determine when to break a contour
line into separate segments. Refer to the line delimiter section on the Options tab for
more about controlling how lines are grouped.
Dragging the mouse across a scrollable data record can set columns. Two
records of the actual data file are shown.
Data Record This section displays two consecutive data records and provides scrolling through the
data file for data field or column selection. Use the up and down arrows located to
the right of the record window to read foreword or backward in the file. The data
record can be scrolled left or right by placing the cursor in the record window and
using the left or right cursor keys.
Number of records to skip before 1st data record - This option allows header or
comment records to be skipped at the beginning of the data file prior to the first true
data record. Click the "Set Skip" button to set the number of skipped records based
on the record currently in the data record window,
Saving Your Work - Once the format (column and field definitions) has been
defined, the "Save" button will write the format to a disk file which can later be used
by selecting the "Load" button.
OPTIONS TAB
Load Data Into Layer
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Select the overlay layer into which the imported data will be stored. Also specify
whether you want the imported data to be merged with the other data stored in the
overlay or if you what to replace it with the imported data.
Auto Close Polygons
Check this option to have the program close all polygons loaded to insure there is not
a gap between the first and last point in the polygon.
Lines Delimited By
Select the method in which lines, polygons, faults and contours are separated into
groups of points called polylines. Some options check the input file against a usersupplied "Delimiter Value". When the value is read, a new line, polygon, fault, or
contour is started and the record is discarded.
Segment ID - This option breaks the lines whenever the segment ID value changes.
X Coordinate - This option checks the X1 or LON1 value against the Delimiter Value.
Y Coordinate - This option checks the Y1 or LAT1 value against the Delimiter Value.
Z Value - This option checks for a change in the Z Value.
Distance Btwn Points Exceed Value - This option computes the distance between
consecutive data points and starts a new segment if the distance exceeds the
Delimiter Value.

5.12.1.3 Importing Shape Files

Overlay Shape File Import and Direct Connect Grid & Culture
Import
Overlay>Import Shape Files function allows ESRI shape files to be imported and
colorized using predefined templates. The primary purpose of this option is a "Direct
Connect" download and import of IHS grid and culture data. Of course, you will need
the appropriate licensing to access this data (contact your local IHS sales rep for
details).
This function can also be used to load any shape files copied to the "Shapes" folder of your
project.
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Customers with Direct Connect access and entitlements to IHS Grid and Culture
data can use a new method to retrieve and import shape file data into the Petra Map
Overlay. Users may also copy custom shape files into the Shapes folder of the
project for direct import into the overlay. Map menu Overlay->Import Shape File.

Import Grid and Culture Data – upon entry all shape files contained in the current
project “Shapes” folder will be displayed in the Current Shape Files list box. Custom
shape files may be copied into the Shapes folder manually or selected and copied
using the Browse to Shape Files button.
Click the (IHS Direct Connect) Download Grid and Culture button to view the layers
that are available from IHS Direct Connect. Note that the user must have
entitlements to this data and that not all geographic areas have all possible shape
layers.
Select the appropriate Quick Set button for rapid selection of the most common
shape layers. Other layers may be selected as desired. Click OK to download the
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layers from IHS Direct Connect.

Upon retrieval of the shape files an information dialog will show the shape files that
were available and downloaded.

The shape files are now shown in the Import dialog with default attributes. These attributes
may be customized as desired by the user.
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Shape File Import
Attributes Tab
User selection of import line attributes, fill attributes, and text attributes of the
selected shape file. Text attributes are applied to the data extracted from the shape
DB file fields. The text is made by concatenating the fields specified by the Assign
Fields dialog that is shown on the Fields edit box.

Layers Tab
Set the overlay layer for each shape file to be imported. More than one shape file
may be imported into the same overlay layer. The buttons at the top assign the
selected shape file or files to the layer or layers.

Misc. Tab
Set Lat/Lon extents for the Direct Connect shape file request

Path
Set the desired shape file path if other than the project Shapes folder.

Preview
Shows a preview of selected shape file using the extents of the shape file

Volumetrics
Sets a shape DB field value for associated polygon. Can be used for later Map
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volumetrics calculations.
Press Import button to import the checked shape files into the overlay. The
attributes and settings are saved as part of the import process. Note that only the
checked shape files are imported into the overlay.

5.12.1.4 CDF Entity Code Translation

Certain file formats have entity codes that can sort different elements into different
overlay layers during import. Petra uses a translation file to map the entity codes to
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overlay layer numbers. If a layer translation file is used, only codes listed in the
translation file will be loaded. Items without entity codes in the translation file will not
be imported.
Petra comes with a few sample translation files in the installation's parms directory.
By default, this is located at C:\geoplus1\parms\ These files are just intended as
examples to explain the format and as a template to be modified by the user to
meet their specific demands.
Tobin Layer Translation.dat
GES Layer Translation.dat
AccuMap_CDF_TRANSLATION.dat
Translation files are comma-delimited and consist a layer definition section and a
entity code translation section. Records beginning with an "!" are considered
comments.

Layer Definition Section
The Layer Definition Section is an optional part of the file that just renames one or
more of the Petra's overlay layers. When present, this section must precede the
entity code section. Each record has the following format:
LAYERDEF,LayerNumber,LayerName
Where:

LAYERDEF is a key word
LayerNumber is a layer number from 1 thru 256
LayerName is the name of the layer (NO EMBEDDED

COMMAS)

Examples:

LAYERDEF,1,Roads
LAYERDEF,2,Rivers
LAYERDEF,3,Populated Place Names

Entity Code Section
The Entity Code Section follows the layer definitions and is in the following format:
LayerNumber,MajorEntity,MinorEntity,Comment
Where:

LayerNumber is overlay layer number from 1 thru 256
MajorEntity is the 3-digit major entity code

© 2014

Map Module

827

MinorEntity is the 4-digit minor entity code (may be -1)
Comment is an optional comment (not read)

Examples:

1,32,3020,Major City
1,32,5240,Populated Place Names
2,50,-1,All Rivers and Streams (see note 1 below)

Note 1: A minor entity code of -1 means the program will to only check the major
code. All entity codes matching the major code will be loaded into the specified layer.
Place -1 codes at the end of the translation list.
Example File:
! Example Petra Layer Translation File.
!
LAYERDEF,1,ROADS
LAYERDEF,2,RIVERS
LAYERDEF,3,BOUNDARIES
!
1,32,-1,All Roads
1,32,-1,All Roads
2,50,-1,All Streams
3,90,-1,Boundaries

5.12.2 Overlay Tool Bar - Map

The overlay tool bar contains icons to manipulate overlay lines and text.

Select overlay line or text item.
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Show attributes of the selected item.
Add a line, polygon, contour, or fault to the map.
Activates the "Auto Set Polygon" function. After clicking this button, the user then
clicks inside an overlay polygon. The attributes (style) of the polygon is then set to
predefined settings These predefined settings are set using the 'Overlay>>Edit>>Set
"Auto Set Polygon" Attributes' menu.
Add text to the map. Click 3 points. First point is the start of text baseline,
second point is the end of text baseline, third point indicates text size.
Add a "text box" by drawing a rectangle on the map. A text box contains multiple
lines of horizontal text.
Add a box or rectangle to the map.
Add a circle to the map. Click once for center, then drag mouse to enlarge circle,
then click to set the radius.
Add an Image reference to plot a Windows metafile or bitmap file. Click and drag
to draw a rectangle to define the position and size of the image.
Add an Arrow to the map. Click once at the start of arrow head, then click again
for arrow tail. Use the line attributes of area fill for a solid arrow. Use the Text tool to
label the interior of the arrow.
Smooth the selected line, contour, or fault by creating a new control point
between each of the current control point.
Simplify the selected line, contour, or fault by reducing the number of control
points making up the item.
Break a line, contour or fault at the exact point where the item was selected.
Connect the selected line, fault or contour to its nearest neighbor.
Change the plotting order of the selected item so that it plots on top of all
others.
Change the plotting order of the selected item so that it plots behind of all
others.
Clip all graphics items that fall inside a selected rectangle.
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Clip all graphics items that fall outside a selected rectangle.
Delete one or more control points from the selected item. After selecting an
item, click the left mouse button on one or more control points, then click the right
mouse button. The indicated control points will be removed.
Add one or more control points to the selected item. After selecting an item,
click the left mouse button between one or more control points, then click the right
mouse button. New control points will be added between the original points.
Display the area enclosed by the selected line.
Undo the last edit or deletion.
Delete the selected item.
Clip all visible and non-read only items outside of a user-defined polygon. Click
the left button to define the polygon. Click the right button when all points are
defined.
Copy the selected item into the overlay clipboard function.
Paste the item from the overlay clipboard onto the screen.
Displays this help screen.
Display Layer & Preferences screen which provides global editing options.
Imports an Overlay File from disk.
Saves the Overlay in memory to an overlay file on disk.
Load a "layer file" from disk. A layer file contains a single layer exported from
another overlay.
Saves (exports) a single to a layer file on disk.
Constructs filled polygons from a layer of contour lines.
Used to find and highlight a particular text string on the map.
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5.12.3 Editing Overlay Lines, Text, and Images

All of the following instructions are based on the use of the Overlay Tool Bar. To
hide or show the Overlay Tool Bar, select Overlay>Show/Hide Tool Bar from the
menu bar at the top of the Map Module.

Lines
Creating New Lines
To set lines in Petra, select on the
button on the toolbox. Next, click where you
want the beginning of the line to start. Clicking the left mouse button again will add
further control points, while clicking the right button will end the line. The DELETE
key will remove the last node point. After you finish adding control points on the line,
the Overlay Line Attributes dialogue box will pop up.

Drawing an Arrow
To add an arrow, simply click on the arrow icon on the mapping toolbox. This will
change your mouse to a crosshair. To add the arrow, first click on position for the
head of the arrow, and then click again to place the tail.

Editing Existing Lines
To select and edit lines, depress the SHIFT KEY and then click on pre existing lines
with the left mouse button. Another method of selecting lines is to first click on the
red arrow on the toolbar, which brings up a crosshair for your mouse on the map
module, and then select the line you wish to edit with one click of the left mouse
button. In either case, selecting a line changes the color of your line to blue and
shows all the control point points in the line. Occasionally after making many
changes to lines, it is necessary to redraw the screen to see the changes or to
continue editing.
Moving individual control points - change the location of any blue boxed "control
point" on the line by clicking and dragging it to a new position.
Moving whole lines - To move a whole line unchanged, press the ALT KEY and click
on the line with the RIGHT MOUSE button.
Adjusting sections of line - To move entire sections of a line, press the CTRL KEY
and choose two points on the line using the LEFT MOUSE button. Depressing the
CTRL KEY and moving any section of the line in between the two selected points will
stretch that entire section of the line.
Adding control points - select the "Add Ctrl. Point" button that looks like

and add
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control points where necessary.
Dropping any control point - select the "Drop Ctrl. Point" button that looks like
and click on existing control points for the selected line.
Increasing or decreasing the total number of control points to the line - choose
"Smooth" or "Simplify" on the toolbar. "Smoothing" the line or polygon will place a
new control point between every existing point, while "simplifying" the line or polygon
will reduce the number of control points.
Copying a line - click on the copy button that looks like
on the

. To paste the line, click

button and place the text.

Text
Creating Text
To set text, click on the "abc" icon button on the toolbar. Petra first asks you to
establish a baseline that shows where you want the text and then builds a rectangle
to establish the height of the text.

Editing Text
To edit pre existing text, first depress shift and then click on the text you wish to edit.
Another method of editing text it to click on the red arrow button on the toolbar,
which brings up a crosshair for your mouse on the map module, and then click on the
text you wish to edit with one click of the left mouse button. Either method brings up
a blue box around your text and allows you to edit the text. Sometimes after
manipulating a piece of text multiple times, it may become necessary to refresh the
screen to see the blue box that highlights text.
Editing Text Boxes - double click anywhere inside the blue box. This brings up the
Overlay Text Attributes dialogue box that allows you precise control over features,
including degree of angle and text height.
Changing the location of the text - press the ALT KEY and click the RIGHT MOUSE
button somewhere inside the box and drag it to the new location.
Changing the angle of the text manually - press the ALT KEY and click the RIGHT
MOUSE button on one of the original control points that established the baseline on
the bottom of the blue box.
Copying a text box - click on the copy button. To paste the text, click on the button
and place the text

Working with Multiple Lines/Text Boxes Simultaneously
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Multiple line or text items can be selected and edited as a group. To select a group
of items, click the LEFT MOUSE button on each item while holding down the SHIFT
and CTRL keys. You can select multiple lines as a group or multiple text items as a
group, but not lines and text together. Once a group of items is selected. The
"attributes" dialog can be used to edit properties such as color, layer, font, etc.
Group selection of lines is limited to similar type of lines. For example, if the first line
selected is a fault, then all other selected lines must be a fault. The same can be
said for contour lines.

Images
Importing an Image File
To add an image file, simply click on the "Add Image File" button on the toolbar that
. After clicking this, Petra will ask you to establish a rectangle on the
looks like
map screen where the image file will be placed. Then, Petra will ask you for the
location of the file and the layer you want it to go into. Various scaling options are
available under the "Options" tab.

Working with GeoTIFF Files
To insert a Geo-referenced image, click on the "Options" tab and then on "GeoTIFF
World File". A dialogue box will pop up asking you for the name and location of the
file (*.tfw).
Before importing a Geo-referenced file, make sure your project is in the UTM map
projection. (For more information on how to do this, see Map Projections)

Clipping an Overlay
To concentrate on a specific area or exclude map data that isn't relevant to your
interests in a specific field, use the clipping tools to remove superfluous information.
Clipping an area in the map module will cut lines and drop text anywhere within that
area, but will leave images alone.
Remove all overlay data inside a user-defined rectangle - select the "Clip Inside"
tool.
Removing all overlay data outside of a user defined rectangle - select the "Clip
Outside" tool.
To remove all overlay data outside of a user defined polygon - select the "Clip
Outside Polygon."
Note: All of these are permanent to your overlay lines and text - Undo isn't
available after clipping the overlay data.
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5.12.3.1 Overlay Line Attributes - Map

Every overlay line has a series of attributes that define the type of line and its
appearance.
To edit a line's attributes, select the red arrow button, and double-click a node on the
desired line.

General Tab
The General Tab sets the basics of the line, including its layer and class.

The Overlay Line Attributes General Tab

Layer - This dropdown sets the layer that will contain the line. Since the Map
Module can selectively display or hide entire layers, related lines (such as land grid
or lease outlines) should generally be in the same layer. Each set of contour lines
should have its own layer.

Line Class
While normal lines are just for displaying visual information (like section outlines or
roads), contour, unconformity, and fault lines can also be used to influence the
gridding process.
Normal Line - Normal lines have no specific attributes beyond a color and fill. Normal
lines are useful for display purposes, including lease lines and arrows.
Contour Line - Contour lines have a specific value, and are useful for modifying
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Petra's gridding process. Selecting the "Contour Line" class enables the Contour
Tab, which sets the specific line's value. For more information on using contour lines
during gridding see the "Hybrid Method" under "How to Make a Contour Map."
Unconformity Line - Unconformity lines illustrate an unconformable surface contact
with a squiggly line on the map.
Fault Trace - Fault traces break grids into two separate parts. Selecting the "Fault
Trace" class enables the Faults Tab, which sets the strength and appearance of the
fault. For more information on using fault lines during gridding see the "Hybrid
Method" under "How to Make a Contour Map."

Line Width - This dropdown sets the line widths for drawing the line. Line widths
range from narrow to extra-wide. This dropdown also can select the 4 custom
"User-1" through "User 4" line widths. These line widths can be modified on the
Petra Program Options' Font/Graphics Tab in the Main Module.
Line Style - This dropdown sets the line to use one of the predefined drawing styles
to draw a solid or dashed line.
Smooth Line Points - By default, Petra draws a straight line between the node points
that make up a line. This option instead draws a smoothed line through the line's nod
points.
Closed Polygon - This option forces the starting and ending points to match when
drawing polygons. This switch should be specified when using area fill options.
Contour Clipping Polygon - This option tells Petra to use the polygon to clip gridded
contours. Grids outside the polygon will not plot. This can be useful for trimming off
anomalous or otherwise bad parts of grids.
Allow in Map Gutter - This option allows the line or polygon to be plotted in the
gutter, which is set on the Map Module's Data Map Margins and Preferences tool.
Line is Invisible - This option prevents the line from displaying on the Map Module,
even when the layer containing the line is visible. Invisible lines can still affect
gridding, and can still be selected.

Colors Tab
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The Overlay Line Attributes General Tab

Line Color - This dropdown sets the color of the line. For closed polygons, this will
set the shape's outline. To change the available colors on this dropdown, select the
"Palette..." button. To restore the default colors, select the "Default" button.
Fill Color - This dropdown sets the color of the fill inside a polygon. To change the
available colors on this dropdown, select the "Palette..." button. To restore the
default colors, select the "Default" button.

Drawing Mode
Normal - This option draws the line or polygon element with an opaque color. Lines
or polygons with a normal drawing mode will cover elements that are below them.
Transparent - This option draws the line or polygon with a transparent color. With a
transparent drawing mode, other elements will be visible through the line or polygon.
Combine Colors - This option will display overlapping lines and polygons with a
different color. In practice, this option is a great way to demonstrate regions of
overlap on the overlay.

The blue circle on top with Normal (Left), Transparent (Center) and Combine Colors (Right) drawing modes
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Patterns
Petra can draw patterns inside polygons. The left up/down button sets the pattern,
while the right up/down button sets the density of the pattern.

Pattern Color - This dropdown sets the color of the pattern inside a polygon when
the "Use Pattern Color" option is selected.

Pattern Line Mode
Use Thin Black - This option draws the selected pattern using thin black lines. This
option will override the "Pattern Color" dropdown.
Use Line Color & Width - This option draws the selected pattern using the line color
(selected on the Colors Tab) and thickness (selected on the General Tab). This
option will override the "Pattern Color" dropdown.
Use Pattern Color - This option uses the color set by the Pattern Color dropdown
immediately to the left.

Pattern Filled polygons with "Use Thin Black" (Left), "Use Line Color & Width" (Center), and "Use Pattern
Color" (Right)

Area Fill Tab
The Area Fill Tab controls how Petra fills polygons.
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The Overlay Line Attributes Area Fill Tab

Do Not Fill - This option will turn off any polygon fill.
Fill Interior - This option will fill the polygon with the "Fill Color" selected on the Colors
Tab.
Frame Fill Only - This option will only fill the outermost edge of a polygon. The
thickness of this fill is set by the "Frame Width in Map Units" option.
Frame Dashed Outline Only - This option will create a dashed outline inside the
polygon. The distance between the outer edge of the polygon and the inner dashed
fill is set by the Frame Width in Map Units option.
Frame Width in Map Units - This option determines the option determines the width
of the shading inward from the polygon borders. The frame width is specified in the
currently selected map units (feet or meters). This is commonly used to display
partial ownership of a lease.

The Frame Fill Only option (Left) an the Frame Dashed Outline Only (Right)

Volm Tab
The Volm Tab sets up a closed polygon as a volumetric polygon. Petra can use
these polygons during volumetric calculations.
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Volumetrics Polygon Name - This entry sets the name of the volumetric polygon.
Generally, this will be the lease name.
Plot Polygon Name - This option plots the volumetric name in the center of the
polygon.
Working Interest Applied to Volumetrics Calculations - This option sets the working
interest of the polygon. Petra can multiply the volumetrics calculation by the working
interest set here.
Designate a Well to Store Computed Volume for this Polygon - This entry sets a
"designated well" that will store the computed volume for the polygon. Note that this
entry uses the WSN rather than API/UWI numbers.
Note that volumetric polygons can also have an area plotted on their label. See the
Overlay Layer Preferences' Misc Tab for more information.

Contours Tab
This section sets individual contour line values and settings. This section is only
available when the "Contour Line" class is selected on the General Tab.

The Overlay Line Attributes Contours Tab

© 2014

Map Module

839

Contour Value - This entry sets the value for the contour line.
Label Contour Line - This option ensables or disables contour line labeling.
Label Height - This option sets the height of the contour label in inches.
Hachures - This option adds hachures to inside or outside of a contour line.

Faults Tab
This section controls how Petra handles a fault line. This section is only available
when the "Fault" class is selected on the General Tab.

The Overlay Line Attributes Faults Tab

Fault Strength - The strength of a fault affects gridding. The more transparent a fault
trace is, the less effect it has on the grid. Totally opaque faults do not allow the
gridding process to use data points which are on the opposite side of the fault from
the grid node being computed. Set the fault strength somewhere between
Transparent and Opaque.
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Fault strength's effect on throw and fault drag

Fault Throw Dies Out At Starting Point - The starting point of a fault is the first point
digitized. Set this option if the throw is zero at the starting point.
Fault Throw Dies Out At Ending Point - The ending point of a fault is the last point
digitized. Set this option if the throw is zero at the ending point.
If the throw does not die out at either end point, the gridding algorithm treats the fault
as totally opaque.
Fault Symbol Style - This option adds fault symbols to the line. Note that the size of
the fault symbols can be increased or decreased by the slider bar on the right side of
the window. Importantly, these fault symbols are purely cosmetic and have no
bearing on the gridding process.
Fault Direction - This option controls how Petra draws fault symbols on the line.
"Down to the Left" and "Down to the Right" are relative to the starting point and the
ending point. A rule of thumb is to assume you are standing on the start point and
looking out towards the first segment - what is on your left is left, and what is on
your right is right. Importantly, these fault symbols are purely cosmetic and have no
bearing on the gridding process.are purely cosmetic and have no bearing on the
gridding process.

Arrow Tab
This section allows arrow heads to be added to the line end points. Note that Petra
can only draw arrows on lines with a "Normal Line" line class selected on the
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General Tab.

The Overlay Line Attributes Faults Tab

Arrow Type - This dropdown sets the appearance of the arrow. Note that the
arrows are directional. An arrow pointing to the right will put the arrowhead at the
end of the line, while an arrow pointing to the left will put the arrowhead at the
beginning of the line.
Size - This option sets the size of the arrow in map XY units.

Misc Tab
The Misc Tab controls a couple of additional options relating to overlay contour color
fill and shifting an individual polygon.

The Overlay Line Attributes Misc Tab

Contour Fill Control Line Type
This section controls how the selected line is used with the Color-Fill Overlay
Contours tool.
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None - This option specifies that the selected line isn't a control or join line. Most
lines shoudl keep this option.
Control Line - Control lines connect multiple contour lines.
Join Line - Join lines connect two otherwise disconnected contour lines to create a
polygon.

Shift Location
This tool moves the selected line or polygon.
DX and DY - This tool shifts the line or polygon a set number of map XY units. For
DX, positive numbers are east and negative numbers are west. For DY, positive
numbers are north and negative numbers are south.
Distance and Angle - This tool shifts the line or polygon a set number of map XY
units in a compass direction. The Distance is in map XY units, and the angle is in
compass values (E=0, N=90, W=180, and S-270). This tool does not rotate the
item.

Label Tab
This tab adds a single label without using a dedicated text box.

The Overlay Line Attributes Label Tab

Label Text - This entry contains the line's label for labeling the line. LEAVE BLANK
for not labeling the line.
Stretch Label Over Percentage of Line Length (1-100%) - This determines the
overall length of the plotted annotation. Large values will cause the text to be stretch
out while small values will make the text appear compressed.
Text Height - This entry sets the height of the text in in XY map units.
Text Color - This option sets the text's color. The "Line" button sets the text to
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match the line color.
Position - This dropdown sets the placement of the line label as Above, Below, or On
the Line.
Font - This dropdown sets the desired font for the annotation text.
5.12.3.2 Overlay Text Attributes - Map

This section defines the attributes associated with an overlay text element.

The Overlay Text Attributes Window

Text - This entry sets the text for the text box. The Map Module can accommodate
up to to 255 characters.
Height in Map Units - This entry sets the height of the text in XY map units. Since the
height is specified in a map scale, the text will enlarge as you zoom in and out of the
map.
Text Angle - This entry sets the angle of the text box. Note that entry will reflect how
the text box was drawn on the Map Module. Flat is 0 degrees.
Layer - This dropdown sets the layer that will contain the text. Since entire layers
can be made visible or invisible, related text should generally be placed in the same
layer.
Text Color - This dropdown sets the color of the text. To change the available colors
on this dropdown, select the "Palette..." button. To restore the default colors, select
the "Default" button.
Justification - Text justification can be set to a combination of Top/Middle/Bottom and
Left/Center/Right.
Opaque Background - Set this option to draw the text using the map background
color as the background of the text. Opaque text will cover up underlying data.
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Allow in Map Gutter - This entry allows the text box to plot in the gutter. Note that the
gutter is set on the Map Margins and Preferences' Gutter Tab

5.12.4 Load Overlay Layer File

To load an existing overlay file, select Overlay>Load File>Overlay Layer File… on
the menu bar at the top of the Map Module.

Data tab

The Load Overlay Layer File Data Tab

Load Layer File As
Normal Overlay Data - This option copies the layer into the overlay file.
Associated (Read Only) Layer - This option stores a link to the layer file. As an
associated layer, Petra loads information from the external layer file, rather than
from the overlay layer. This is a good choice for shared data that is frequently
updated.

Layer File To Load
Browse - This button navigates to the Overlay Layer File (*.LAY) to import.

Load Into Layer
The Load Into Layer dropdown menu , click the drop down box to select the layer
where Petra is to store the layer File.
Replace Current Data in Layer - This option completely clears the selected
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destination layer before importing the layer file.
Merge File with Current Data In Layer - This option adds new data to the overlay
layer without erasing any old data in the layer.

Options Tab
The Options tab gives further control over how Petra imports these Layer Files. For
most imports, leave these on the default settings shown below.

The Load Overlay Layer File Options Tab

Recompute XY's from LatLons During Load – This option uses the LatLons from the
overlay layer file to recalculate the XY position. When the LatLons from the file use
the same reference datum as the project, this option ensures that the XYs are using
the correct map projection. This option is on by default, and should be left on for
most layer files.
Rename Layer Using Layer Name In File – This option renames the active overlay
layer to use the layer name from the origin overlay file. Deselecting this option
leaves the layer name as is.
Replace Overlay Palette with Palette From Layer File – Overlay Palettes are the
sets of colors Petra uses to draw overlay features. There is one set for lines and
text, as well as one set for fill colors. Changing colors in the palette will change all of
one color to another color. For example, replacing red with green in the line and text
color palette will change all red text and lines in the overlay to green. This option will
tell Petra to replace the existing Palette of colors with those stored in the overlay
layer file.
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5.12.5 Save Overlay Layer File
Overlay Layer Files (*.LAY) store the data from a single overlay layer to an external
file. This can be useful for sharing data between , or for setting up an associated
layer for multiple users.
In the Map Module, select Overlay>Save File(s)>Overlay Layer File from the menu
bar at the top of the screen.

Layer File - This entry sets the location of the saved layer file. When creating
associated layers, make sure to save this file is a location accessable to all users,
such as on a network.
Password Protect Layer File - This option adds an additional password to the overlay
file. This can be useful when working with proprietary or sensitive information.
Save Data From Layer - This option sets the overlay layer that will be exported to the
external file.
5.12.6 Associated Layer Files

Unlike regular layers, which are stored inside overlay files (*.OVL), associated layers
are read from an external layer file (*.LAY) that is stored elsewhere. As this external
layer file changes, so does every other associated layer tied to that file. As such,
associated layers are a great way to make sure that multiple users in the same
project all have access to the most current overlay data. This is especially useful in a
multi-disciplinary environment where one person updates a specific piece of
information that is useful to the whole team.

Saving an overlay Layer
Select Overlay>Save File(s)>Overlay Layer File… to export the individual overlay
layer to a *.LAY file. Since this file will be accessed by multiple other users, it’s
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important to save this file in an accessible and safe location. If this external file is
moved or deleted, all associated layers tied to that file will be empty. Any changes in
a layer must be re-saved to the exact same Overlay Layer File (*.LAY) for other
users to see the changes.

Saving a overlay layer to a layer file (*.LAY)

Loading a Layer File as an Associated File
Now that the Layer File is saved on a network, any other user can load this Layer
File as a read-only Associated File. In the Map Module, Overlay>Load File>Overlay
Layer File…
This brings up the Load Overlay Layer dialogue box. Choose the layer file that
contains the data you want to read. Click the Associated (Read Only) Layer radio
button, and load the Layer File into a selected layer.

Loading the layer file as an associated layer.

Other Notes on Associated Files
The Overlay Preferences and Layers' Misc Tab has a couple of additional option to
change how the Map Module works with associated layers.
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The Overlay Preferences and Layers' Misc tab

Keep Assoc Layers in Memory – This option can accelerate redrawing when turning
Associated Layers off and on. Normally, Petra refreshes Associated Layers from
the network every time the layer is turned off and back on. With a large Layer File
and a slow network, this can translate to slow redrawing. This option tells Petra to
load the Layer File once and keep it in local memory rather than continually
refreshing the Layer File from the network. By eliminating waiting on the network,
this option accelerates redrawing. With this option selected, Associated Layers are
only refreshed manually (see below) or by closing and reopening the Overlay File.
Refresh All Associated Layer Files -This forces Petra to re-read all Layer Files into
Associated Layers. Use this if changes have been made to Layer Files. Petra also
brings up a dialogue box to find and re-tie missing or deleted Layer Files.
Convert Associated Layer to Normal Layer - This reads and imports an Associated
Layer File to a regular Layer File in the same layer. This saves a little time rather
than the normal loading overlay Layer File process.
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5.12.7 Auto Save Feature

The Map Module automatically saves the active overlay to a set of backup files at a
set interval.
This "Auto Save" feature is designed to help backup any changes made, and is
enabled by default. This features only creates a backup file if changes have been
made since the previous automatic backup. Note that Petra also attempts to save
the overlay immediately after each data import.
To quickly disable or enable this function, select the Auto Save icon located near the
bottom of the Overlay toolbar at the right edge of the map.

The AutoSave Button at the bottom of the Overlay Toolbar

To modify the Auto Save options, select Overlay>Set Auto Save... form the menu
bar at the top of the Map Module.

Options Tab

Auto Save Overlay Options Options Tab

Auto Save Active - This option enables and disables the Auto Save.
Audible Sound During Save - When this option is selected, Petra will play a sound
every time it automatically saves the overlay file.

Interval Tab
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Auto Save Overlay Options Interval Tab

Interval Between Saves - This option changes the interval (in minutes) between
attempts to save the overlay.
Number of Revisions to Keep - This option sets the total number of backup files. By
default, Petra stores 5 backup files.

Path Tab

Auto Save Overlay Options Path Tab

Save Overlay Backup Files In Directory - This option sets the location of the overlay
backup files. By default, Petra stores these backup files in the user's private parms
folder. To minimize the time for saving the file, you might consider pointing the Auto
Save Path to a folder on your local drive.
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InterAction Tab
This option changes the level of user involvement.

Auto Save Overlay Options InterAction Tab

Fully Automatic with No User Interaction - With this option, the Auto Save function
just saves files with no additional input from the user.
Prompt User during each cycle to Allow continuation of Save - This option prompts
the user before every automatic save attempt.

Backup File Name Conventions
Method 1:
If you load an existing overlay file, then backup files will use the overlay file prefixed
with ~$. In other words, if you loaded an overlay called MyData.OVL then the
backup files would be named;
~$MyData_1.Ovl, ~$MyData_2.Ovl, ~$MyData_3.Ovl, etc. up to the "file count"
setting.
Method 2:
When you start without an overlay and begin to import or manually add data, the
backup files will be named; ~$Auto Save_1.Ovl, ~$Auto Save_2.Ovl, ~$Auto
Save_3.Ovl, etc. Once you save your overlay with a filename, the backups will
created using method 1.
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5.12.8 Overlay Preferences & Layers
The Overlay Layers tool enables and disables individual layers, sets the layer plotting
order, and performs other high-level changes to the currently loaded overlay file.
To open the Overlay Layers Tool, select Overlay>Preferences & Layers from the
menu bar at the top of the Map Module. Alternatively , double-click "Overlay" on the
Map Data part of the Quick List, or double-click a single layer on the Overlay Layers
section of the Quick List.

Opening the Overlay Layers window with the Quick List

The Overlay Layers' Layers Tab (Properties Tab)
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Layers Tab (and Group View)
Options Tab
Update Layer Data Tab
General Tab
Move/Copy Tab
Images Tab
Contours Tab
Faults Tab
Misc Tab
Volm Tab

5.12.8.1 Layers Tab

Layers Tab
Layer Name List
Visible for both Properties and Preview Tabs, the list box shows all layer names in the
open Overlay file.
This list selects the currently active layer - as an example, to change the state outline
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color to red, you'd need to select the "State" overlay layer here first.
The Layer Name List displays the current status of all the layers in the overlay file.
Layers which are not currently visible are indicated by a small symbol. The layer's
default color, which is the color assigned to newly added items, is shown on the right
edge of the list.

Interpreting a layer name on the Layer Name List

The Layers Tab has two tabs: Properties and Preview. The Properties Tab changes
layer visibility, layer names, and update status. The Preview Tab displays a quick
preview of the data inside the specified layer. These two tabs are on the upper right
corner of the Overlay Layers tool.
Group View - This button toggles to the Group Tab, a slightly different way of working
with groups of related layers.

Layers Tab (Properties)
The Layers Tab sets a few of the basics for the layers in the overlay file. This
includes changing layer names, visibility, and update status.
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The Overlay Layers' Layers Tab (Properties Tab)

Layer Properties
Layer Name - To change the name of a layer, first select the layer in the Layers lists.
Type a new layer name and click the "Apply" button.
Layer Default Color - To change the default color of a layer, first select the layer in
the Layers list. Select a new color from the drop down color list and click the "Apply"
button.
Layer Visibility - Use this section to "Show" or "Hide" individual layers. Double clicking
the layers list will toggle a layer's visible state.
Layer Update Status - This section toggles the status of the selected layer. A "Read
Only" layer cannot be changed or edited, and has a red "R" beside the layer name on
the Layer Name List. "Modify" layers can be edited and changed.
Plot All Items In This Layer - This option changes how Petra handles overlaps
between overlay objects and the wells on the Map Module. "Before Wells" will plot
objects before (and below) well symbols, while "After Wells" will plot the overlay
objects in the the selected layer on top of well spots. Generally, most users will want
to use the default "Before Wells" option.

- This button opens an Information window about the selected overlay layer.
This displays information on the total number of items, including lines, text boxes, and
images. This window also displays the total range of the selected overlay in both XY
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map units and latitude and longitude.
- This option can be used to delete all data associated with the
selected layer. You will be prompted to verify the clearing process. Data is only
removed from memory. It does not effect any saved overlay files unless you overwrite
them with the modified overlay.

Layers Tab (Preview)
The Layers Tab displays a quick preview of the data in the selected layer.

The Overlay Layers' Layers Tab (Preview Tab)

Preview Layer - This option displays a preview of the selected overlay layer in the
main part of the window.
Refresh - This option redraws the preview based on the latest version of the overlay
file.
Use Full Overlay Extents - By default, the preview window zooms in on the data in the
selected overlay layer. This option instead zooms out to use the full overlay extents.
This can be particularly useful for troubleshooting overlay data, such as data with a
different reference datum.
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5.12.8.2 Groups Tab

The Groups Tab displays overlay layers in nested groups.
Layer View - This button toggles between Layer View described on this page, and
Group View.
To move a layer into (or out of) a group, simply drag and drop the layer into the
relevant group folder. Alternatively use the "Move Items" tool described below.

The Overlay Layers' Layers Tab (Properties Tab)

Add New Group - Enter a text string in the entry field and click the Add New Group
button. The new group will appear at the bottom of the list.
Rename Group - This option renames the selected layer group
Delete Current Group - This button deletes the currently selected group. Overlay
layers inside the deleted group will be moved into the previous group. You cannot
delete the last group.
Rename Layer - This option renames the currently selected layer. Note that this
option is greyed out when a group is selected.
Include Group Name When Renaming - This option adds the group name to the
beginning of the layer name whenever the layer is renamed.
Do Not Show Layer Number - This option hides layer numbers.
Toggle Read Only Status - This option changes the status of an individual layer.
Make Default Groups - This button creates a single group called Default and includes
all layers.
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Move Items - Select one or more layers using the left mouse button along with the
control or shift keys. Click the Move Items button. Finally, click on the layer to move
items into.

Load Template - This option saves the overlay groups to a template (*.OVG file).
These files can be useful for applying similar grouping to other overlay files.
Save Template - This option restores the overlay groups from a template file. The
groups loaded from this file will overwrite

RIGHT MOUSE POPUP MENU
Move Layer to Top of Group - Moves the selected layer to the top position of its
group.
Show Layer(s) - All selected layers are activated.
Hide Layer(s) - All selected layers are de-activated.
Expand All Showing Data - Any group that contains a visible layer is expanded.
Move Items to Another Group - Same as Move Items button.
Hide All Layers in Group - All layers in the group are activated.
Show All Layers in Group - All layers in the group are de-activated.
Sort by ICON - The list is sorted so that activated layers appear at the top of the
group, followed by de-activated layers, and finally empty layers.

5.12.8.3 Options Tab

Options Tab
The Options Tab hides all text and contour labels for the selected layer, or adds grid
lines to the polygons in the layer.
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The Overlay Layers' Options Tab

Suppress Text - This option hides text in text boxes in the selected layer. This option
does not erase text, and deselecting this option will display the text again.
Suppress Contour Labels - This option turns off all contour line labels in the selected
layer. This option does not erase text, and deselecting this option will display the text
again.
Auto Fill With Grid Tool - This tool automatically puts grids inside the selected layer's
polygons. This can be useful for automatically subdividing township and range
sections in the overlay. Options include Quarter Section Grid, Canadian Target Area
1, Canadian Target Area 2, and Canadian Legal Sub Div (LSD)

Quarter Section Grid (left), Canadian Target Area 1 (center left), Canadian Target Area 2 (center right), and Canadian
Legal Sub Div/LSD (right)

Simplify Lines & Polygons - This option applies reduces the number of node points in
the layer's lines. This will smooth and simplify the lines in the layer - note that the
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option cannot be undone. Make sure to save your overlay before using this tool, so
you can restore the lines if necessary.
5.12.8.4 Update Layer Data Tab

Update Layer Data Tab
The Update Layer Data changes all overlay lines, text boxes, and polygons within a
layer. This tool is useful for changing the appearance (color, thickness, fills, etc) of
simple lines and polygons and for changing the behavior of lines (changing line class).
This tab is only available when a modifiable layer is selected on the Layers Tab
; this tab will not appear when a "Read Only" layer is selected.
This tool is divided into several tabs, each of which applies to a specific type of object
in an overlay layer.
Once you've set the changes to the overlay layer, select the "Update Layer..." button
in the upper right corner of the Tab.

The Overlay Layers' Update Layer Tab

Updating Lines
Updating Polygons
Updating Text
Updating Contours
Updating Faults
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Miscellaneous
5.12.8.4.1 Lines Tab

The Update Layers Lines Tab

Line Color - This dropdown sets the color of the line. For closed polygons, this will
set the shape's outline. To change the available colors on this dropdown, select the
"Palette..." button. To restore the default colors, select the "Default" button.
Line Thickness - This dropdown sets the line widths for drawing the line. Line widths
range from narrow to extra-wide. This dropdown also can select the 4 custom "User1" through "User 4" line widths. These line widths can be modified on the Petra
Program Options' Font/Graphics Tab in the Main Module.
Line Style - This dropdown sets the line to use one of the predefined drawing styles to
draw a solid or dashed line.

Drawing Mode
Normal - This option draws the line or polygon element with an opaque color. Lines or
polygons with a normal drawing mode will cover elements that are below them.
Transparent - This option draws the line or polygon with a transparent color. With a
transparent drawing mode, other elements will be visible through the line or polygon.
Combine Colors - This option will display overlapping lines and polygons with a
different color. In practice, this option is a great way to demonstrate regions of
overlap on the overlay.
© 2014

862

PETRA Help

The blue circle on top with Normal (Left), Transparent (Center) and Combine Colors (Right) drawing modes

Clear All Line Labels - This option removes all line labels (set on the Overlay Line
Attributes' Label Tab). This is permanent - all lines in the selected layer will lose their
labels.
Clear "Invisible" Flags - This option
Auto Close All Line Segments - This option forces the starting and ending points to
match when drawing polygons. This switch should be specified when using area fill
options.
Smooth Line Points - By default, Petra draws a straight line between the node points
that make up a line. This option instead draws a smoothed line through the line's nod
points.
Unsmooth Lines

Arrows
Do Not Change Arrows - This default option does not change any lines in the selected
layer.
Change Arrow Type for Existing Arrows Only - This option only modifies lines in the
selected layer that already have an arrowhead.
Change Arrow Type for All Lines - This option modifies all lines in the overlay layer.

Arrow Type - This dropdown sets the appearance of the arrow. Note that the arrows
are directional. An arrow pointing to the right will put the arrowhead at the end of the
line, while an arrow pointing to the left will put the arrowhead at the beginning of the
line.
Size - This option sets the size of the arrow in map XY units.
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5.12.8.4.2 Polygons Tab

The Update Layers Polygon Tab

Fill Color - This dropdown sets the color of the fill inside a polygon.

Patterns
Petra can draw patterns inside polygons. The left up/down button sets the pattern,
while the lower scrollbar button sets the density of the pattern.

Pattern Color - This dropdown sets the color of the pattern inside a polygon when the
"Use Pattern Color" option is selected.
Pattern Mode
Use Thin Black - This option draws the selected pattern using thin black lines. This
option will override the "Pattern Color" dropdown.
Use Line Color & Width - This option draws the selected pattern using the line color
(selected on the Colors Tab) and thickness (selected on the General Tab). This
option will override the "Pattern Color" dropdown.
Use Pattern Color - This option uses the color set by the Pattern Color dropdown
immediately to the left.
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Pattern Filled polygons with "Use Thin Black" (Left), "Use Line Color & Width" (Center), and "Use Pattern Color" (Right)

Do Not Fill - This option will turn off any polygon fill.
Solid Fill Polygons - This option will fill the polygon with the "Fill Color" selected on the
Overlay Line Attributes' Colors Tab. Selecting a different fill color here will override
every polygon's current fill color.
Frame Fill Only - This option will only fill the outermost edge of a polygon. The
thickness of this fill is set by the "Frame Width in Map Units" option.

A Frame Fill Polygon

Label Volume Polygons - This option displays the volumetric polygon names for all
polygons in the selected layer.
Don't Label Volume Polygons - This option hides all volumetric polygon names in the
selected layer.
Working Interest - This option applies a set working interest to all volumetric polygons
in the layer.
Auto-Create Volumetric Polygon Names - This option automatically creates volumetric
polygon names to all polygons in the selected layer. Petra will use creation order of
the polygon - the first polygon created will be named "1", the second will be named
"2", and so on. Note that this tool can have a prefix added to the beginning of the
volumetric names.
Re-Classify as Contour Clipping Polygons - This option sets all polygons in the
selected layer as contour clipping polygons. Contour clipping polygons clip contoured
grids; grids otuside the polygons do not show on the Map Module.
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5.12.8.4.3 Text Tab

The Update Layers Text Tab

Text Color - This dropdown sets the color of the text. To change the available colors
on this dropdown, select the "Palette..." button. To restore the default colors, select
the "Default" button.
Text Size - This entry sets the height of the text in XY map units. Since the height is
specified in a map scale, the text will enlarge as you zoom in and out of the map.
Text Font - This option sets the text font.
Scale Text By - This option changes all the text in the specified layer by a scale
factor. Setting this option to 0.5 will decrease the text by 50%, for example.
Text Angle - This entry sets the angle of the text box. Note that entry will reflect how
the text box was drawn on the Map Module. Flat is 0 degrees.
Text Justify - Text justification can be set to a combination of Top/Middle/Bottom and
Left/Center/Right.
Opaque Text - This option sets how Petra handles text overlapping other elements in
the Map Module. Opaque text will cover up underlying data.
5.12.8.4.4 Contours Tab
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Update Contour Lines - This option allows contour lines in the layer to be updated and
changed.
Contour Smoothing - This option adds an additional smoothing to contour lines.
Contour Labels - This option displays and hides contour line labels for all contour lines
in the selected layer.
Change All Contour Lines to Normal Lines - This option changes all contour lines in the
selected layer to a "Normal Line" line class. This option will erase all the contour line's
contour values.
5.12.8.4.5 Faults Tab

The Faults Tab converts lines to and from the "Fault Trace" line class, and sets some
fault symbol options for all faults in the selected overlay layer.
For more information on line classes, see Overlay Line Attributes.
For more information on using fault and contour lines during gridding see the "Hybrid
Method" under "How to Make a Contour Map."
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The Update Layers Faults Tab

Convert All Lines in Layer to FAULTS - By itself, this option converts "Normal Line"
and "Unconformity Line" lines to "Fault Trace" lines.
Including Contours This option also converts "Contour Line" line classes to "Fault
Trace" lines.
Convert All Faults in Layer to be Normal Lines - This option converts "Fault Trace"
lines to "Normal Line" lines.
Change All Fault Symbol Types to - This option changes the fault symbols of all "Fault
Trace" lines in the selected layer. Available fault symbols include normal, reverse,
vertical, or none. Importantly, these fault symbols are purely cosmetic and have no
bearing on the gridding process.
Change All Fault Directions To - This option changes how Petra draws fault symbols
for all "Fault Trace" lines in the selected layer. "Down to the Left" and "Down to the
Right" are relative to the starting point and the ending point. A rule of thumb is to
assume you are standing on the start point and looking out towards the first segment what is on your left is left, and what is on your right is right. Importantly, these fault
symbols are purely cosmetic and have no bearing on the gridding process are purely
cosmetic and have no bearing on the gridding process.
Change All Faults to Default Strength and Throw Dies at both EndPts - This option
restores all faults in the overlay layer to the default "semi-transparent" strength. At
this default strength, Petra's gridding allows the grid to flex a little across the fault,
rather than be completely unchanged by a transparent fault or completely broken by a
opaque fault.
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Fault strength's effect on throw and fault drag. The default strength effectively creates some fault drag during
gridding.

This option also sets the fault throw to zero at both the starting and end points of all
faults in the layer. Effectively, Petra will attempt to connect data points around the
ends of fault lines.
Reset Fault Symbol Scale Factor - This option resets the fault symbols for all "Fault
Trace" lines in the selected layer.

5.12.8.4.6 Misc Tab
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Make All Layer Items Use Layer Default Color - This option resets all items in the
selected overlay layer to use the default color set on the Layers Tab.

Shift Location
This tool moves every overlay object in the selected layer.
DX and DY - This tool shifts the line or polygon a set number of map XY units. For
DX, positive numbers are east and negative numbers are west. For DY, positive
numbers are north and negative numbers are south.
Distance and Angle - This tool shifts the line or polygon a set number of map XY units
in a compass direction. The Distance is in map XY units, and the angle is in compass
values (E=0, N=90, W=180, and S-270). This tool does not rotate the item.
5.12.8.5 Layer Order Tab

The Layer Order tab changes how Petra orders objects in different layers. Layers at
the top of the list are plotted before (and underneath) layers coming later in the list.
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The Overlay Layers' Layer Order Tab

- These buttons move the selected overlay layer up or down in the list.

- These buttons move the selected overlay layer to the top or bottom of the list.
- This button resets the view order to reflect the layer order. As an
example, this will move layer 1 to the top of the list, layer 2 to second place, and so
on.
5.12.8.6 General Tab

The General Tab changes how Petra works with colors, sets the size of overlay
object control points, and a couple of other high-level options.
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The Overlay Layers' General Tab

Modify Line and Text Color Palette
This tool changes the color palette used by text boxes and lines. Changing red to
green, for example, will change every red line and text box to use green.
To change a color, use the dropdown to select the color to change. Next, select the
button to open the color dialog. Here, set the desired color to replace the
color selected in the dropdown.

Modify Area Fill Color Palette
This tool changes the color palette used by area fill polygons. Changing red to green,
for example, will change every red filled polygon to green.
To change a color, use the dropdown to select the color to change. Next, select the
button to open the color dialog. Here, set the desired color to replace the
color selected in the dropdown.

General
Control Point Size - This entry sets the size of overlay line, polygon, and text control
points. Larger control points can be useful for more easily modifying overlay objects,
but can overlap at a higher control point densities.
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The same selected polygon with control point sizes at the default 0.05 inch (left) and at 0.2 inches (right)

Smooth Line Scale Factor - The smooth line factor changes how Petra applies the
"Smooth Line' option on the Overlay Line Attributes window. Generally, a scale factor
at or below 1 will smooth pointed corners, while a scale factor above 1 will
increasingly simpllify the line. In general, it's a better bet to spend your time manually
editing and modifying polygons rather than attempting to modify the polygons with this
factor.

A polygon with multiple smooth factors

Calculate Polygon Text Location Using Simple Centroid to Avoid Errors - This option
uses a simple centroid to plot a polygon's text in the center.

5.12.8.7 Move/Copy Tab

The Move/Copy Tab moves and copies selected overlay objects from one layer to
another.
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The Overlay Layers' Move/Copy Tab

Move Data FROM LAYER - This dropdown sets the overlay layer containing the
objects to be moved or copied.
Move Data TO LAYER - This dropdown sets the destination for the moved or copied
overlay objects.

Data Types To Be Moved
This section sets which types of overlay objects are moved or copied from one layer
to another. This can be useful for separating out a specific kind of overlay element.
Lines - This option moves lines with the "Normal Line" line class set on the Overlay
Line Attributes tool.
Polygons - This option moves "Normal Line" and "Unconformity Trace" lines with the
"Closed Polygon" option set on the Overlay Line Attributes tool. This option will not
move "Fault Lines" or "Contour Trace" lines.
Text - This option moves text boxes.
Contours - This option moves lines with the "Contour Line" line class set on the
Overlay Line Attributes tool.
Faults - This option moves lines with a "Fault Trace" line class set on the Overlay Line
Attributes tool.
Images - This option moves only images from one layer to another. Remember that
the overlay only keeps a link to an external image file, and not the image itself. Once
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you move or copy an image from one layer to another, the external file still needs to
be accessible by the computer running Petra.

Move Data - This option moves the overlay objects. Moved objects do not remain in
the original overlay layer.
Copy Data - This option copies the overlay objects. Copied objects remain in the
original overlay layer, as well as in the destination overlay layer.
5.12.8.8 Images Tab

The Images Tab controls how the Map Module displays image files on the overlay.
This tab is most useful for reducing RAM/bandwidth-heavy visibility options and fixing
broken links to external image files.

The Overlay Layers' Images Tab

Visibility
Plot Image Contents - This option plots images on the Map Module.
Plot Frame Outline Only - Large aerial or satellite image files can use a large amount
of computer resources and network bandwidth. This option plots a frame outline of
the image extents rather than the image itself.
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Use Screen Plot Technique When Printing - This tool changes how Petra sends
images to the printer. Use this option if images are not appearing correctly in printed
maps.
Display Warning Messages While Drawing - This option enables or disables drawing
warning messages. It's sometimes useful to disable these for frequent errors.

Image File Names List
It's important to remember that Petra doesn't actually store any images in the overlay
file. Instead, it simply keeps a link to the external file.
List Image File Names - This option displays the list of linked image files and their
paths.
Rename - This option changes the name and pathway of the selected file. This is
useful for keeping the same settings (such as GeoTIFF locations) while replacing the
name. This can also be useful for fixing bad or outdated pathways.
Find File... - This option instead opens a window to navigate to the new location of the
selected file. Note that Petra will retain the old settings for the image.
Drop - This option drops the existing image file from the list. Petra will not retain the
link to the image file, but will not delete any files off the network or local hard drive.
Locate Images - This option uses the search criteria established by ImageSearch.TXT
to permanently fix the links to the image file. Depending on the number of missing
files and the specificity of the search criteria, this can take a very long time.

5.12.8.9 Contours Tab

The Contours Tab Controls a few additional high-level options for contour lines in the
selected overlay layer.
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The Overlay Layers' Contours Tab

Options
Suppress "Averaging" Filter During Smoothing Disable Clipping Polygons - This option prevents the Map Module from using clipping
polygons
Hide Clipping Polygons - This option hides clipping polygons so that they don't show
up on the map. This can be useful for plotting out presentation maps.

Color Fill
Color Fill Closed Contour Polygons - This option applies a color fill to all closed
contour lines. This is a simpler version of the Color-Fill Overlay Contours tool, which
can handle faults and better work with open contour lines.
Color Fill - This option opens the Color Interval Definition window to set the individual
colors and intervals.
Compute Range - This option opens the Color Interval Definition window to set the
individual colors and intervals. In contrast to the "Color Fill" option, this tool attempts
to automatically calculate a range for the displayed contour lines on the Map module.
Contour Sorting - This option changes how
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Labeling
Contour Label Size -This option sets the height of the contour label in map XY units.
When this value is set to "0", Petra will automatically calculate a decent value.
Distance Between Labels - This option sets the distance between contour labels in XY
units. When this value is set to "0", Petra will automatically calculate a decent value.
Label Contour if Multiple of - This option sets a multiple for labeling contour lines. As
an example, when this value is set to "5", Petra will only label every 5th contour line.
When this value is set to "0", Petra will label all contour lines.
Bold Contour If Multiple of - This option sets a multiple for drawing thicker, bold
contour lines. As an example, when this value is set to "5", Petra will draw every 5th
contour line thicker. When this value is set to "0", Petra will not bold any contour lines.
Number of Decimals - By default, Petra trims trailing zeros off contour line labels.
This option instead forces Petra to leave additional decimal points on contour line
labels.
Use Line Color For labels - By default, Petra draws contour line labels in black. This
option instead forces Petra to use the line color.
Hachure Distance - This option sets the distance between hatchures in XY units.
When this value is set to "0", Petra will automatically calculate a decent value.
Hachure Size - This option sets the height of the hachures in map XY units. When this
value is set to "0", Petra will automatically calculate a decent value.
5.12.8.10 Faults Tab
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The Overlay Layers' Faults Tab

Distance Between Symbols (Map Units) - This option sets the distance between fault
symbols for all faults in the selected layer.
Symbol Size - This option sets the size for fault symbols for all faults in the selected
layer.
Solid Fill Normal Fault Symbols - This option adds a solid fill to normal fault symbols.
Deselecting this option keeps the normal fault symbols empty.

A solid fill normal fault symbol (left) and a non-solid fill normal fault symbol (right)

Fill Reverse Fault Symbols - This option adds a solid fill to normal reverse fault
symbols. Deselecting this option keeps the reverse fault symbols empty.

A solid fill reverse fault symbol (left) and a non-solid fill reverse fault symbol (right)

Fault Polygon Angle Tolerance 5.12.8.11 Misc Tab

The Misc Tab controls a couple of additional options for associated layers, autolabels, and exporting a list of the overlay layers.
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The Overlay Layers' Misc Tab

Keep Assoc Layers in Memory – This option can accelerate redrawing when turning
Associated Layers off and on. Normally, Petra refreshes Associated Layers from the
network every time the layer is turned off and back on. With a large Layer File and a
slow network, this can translate to slow redrawing. This option tells Petra to load the
Layer File once and keep it in local memory rather than continually refreshing the
Layer File from the network. By eliminating waiting on the network, this option
accelerates redrawing. With this option selected, Associated Layers are only
refreshed manually (see below) or by closing and reopening the Overlay File.
Method to Auto-Label Polygons with Area - This option adds an area label to
volumetric polygons. Note that this label can be in square feet/meters, square miles/
kilometers, or acres.
Export Layer List - This option exports a simple text file called Layers.TXT that
contains a list of the layers in the open overlay file.

Layers.TXT, exported by the "Export Layer List" option

Refresh All Associated Layer Files - This forces Petra to re-read all Layer Files into
Associated Layers. Use this if changes have been made to Layer Files. Petra also
brings up a dialogue box to find and re-tie missing or deleted Layer Files.
Convert Associated Layer to Normal Layer - This reads and imports an Associated
Layer File to a regular Layer File in the same layer. This saves a little time rather
than the normal loading overlay Layer File process.

5.12.8.12 Volm Tab

The Volm Tab controls a few options on how the Map Module displays volumetric
polygon information.
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The Overlay Layers' Volm Tab

Disable Plotting Working Interest Values With Polygon Names - This option prevents
polygon working interests (set on the the Overlay Line Attributes tool's Volm Tab)
from plotting on the map.
Plot Volume WSN Values with Polygon Name - This option plots the WSN of the
polygon's designated well inside the polygon.
Volume Polygon Name Scale Factor - This option sets the volume polygon label's
scale factor. This number is multiplied by the normal label height - setting this value to
0.5, for example, will decrease the size of the label by 50%.
5.12.9 Color-Fill Overlay Contours

By themselves, contour lines aren't filled in. This tool creates a set of color-filled
polygons based on an set of contour lines.
To add a color fill to a set of overlay contours, select the
Toolbar

button on the Overlay
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A set of contour lines before (Left) and after (Right) adding a overlay contour color-fill

Contours Tab

The Color-Fill Overlay Contours Contours Tab

Overlay Layer Containing Contours To Fill - This dropdown selects the overlay layer
containing the contour lines. Note that Petra will use all contour lines in the overlay
layer.
Overlay Layer to Receive Color-Filled Polygons Built from Contours - This option
selects the overlay layer that will contain the color-filled polygons. It's usually a good
idea to store these in a different layer than the original contours.
Overwrite Layer With New Polygons - This option completely overwrites the layer
with the color-filled polygons. Any data in the overlay layer selected in the "Overlay

© 2014

882

PETRA Help

Layer to Receive Color-Filled Polygons Built from Contours" dropdown will be
completely erased.

Colors
Color Fill - This option opens the Color Interval Definition window to set the individual
colors and intervals.
Load Template - This option saves the current color-fill settings to an external file.
Save Template - This option replaces the current color-fill settings with those from an
an external file.

Faults Tab

The Color-Fill Overlay Contours Faults Tab

Overlay Layer Containing Faults - This dropdown selects the overlay layer containing
the fault lines. Note that Petra will use all fault lines and polygons in the overlay
layer.
Use Faults Layer - This option simply toggles the use of the fault lines. When this
option is deselected, Petra will not use any fault lines in creating the color-fill
polygons.

Control Tab
Complex contour lines can confuse the contour color-fill algorithm, and lead to odd
color fills. The Control Tab sets the layer containing Control and Join Lines that help
better constrain the color-fill process.
Overlay Layer Containing Control and Join Lines - This dropdown selects the overlay
layer that contains the control and join lines.
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Use Control Layer - This option simply toggles the use of the control and join lines.

Using Control and Join Lines
Control lines
Control lines connect multiple (in red) were drawn as normal lines with "control"
option set in misc tab of line attributes screen along the ends of the group in the SE
corner.
In the example below, the color-fill process has gotten confused around the 0'
contours in the lower SW corner of the map. In the center figure, control lines
(drawn in red) connect multiple contour lines to create filled polygons. After running
the color-fill again, Petra recognizes that the contour lines mark off three seperate
intervals, and should be filled with the colors specified on the Contours Tab.

A color-fill with no control lines (Left), adding control lines (Center), and a revised color-fill using the control lines
(Right)

Join Lines
Join lines connect two different contour lines. This effectively creates a closed
polygon for the color-fill.
In the example below, the SW corner of the map has a blank spot bound by two
disconnected 0 contour lines (marked with an X on the center figure). In the center
figure, the two 0 contour lines are connected with two join lines (in blue) that connect
the two lines and form a closed polygon. After running the color-fill again, Petra
recognizes that the region is should be filled with a blue color.

A color-fill with no join lines (Left), adding join lines (Center), and a revised color-fill using the join lines (Right)
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5.12.10 Lineament Analysis and Rose Diagrams

This feature analyzes line data from an overlay layer and generates rose diagrams
illustrating orientation and coverage of the lineament features on a regional basis.

Lineament Analysis on the Map Module

Region Grid Cells
Lineament or fracture data in an overlay layer is subdivided into a series of regional
grid cells. The outlines of the grids can be seen in Figure 1. The total length of lines
within each cell is summed and a histogram is built based on the orientation of each
line segment. Only the portion of a line lying within a cell is considered in these
calculations.
Area Coverage Values
Each regional grid cells is, in turn, subdivided into a series of 10x10 grid cells. This
sub-grid is used to determine the percent of area coverage by lineaments of
fractures. If a line crosses a subgrid cell, then the area of the subcell, or 1% of the
regional grid cell, is summed as "area coverage" value and can be posted. These
values are indicated as A:nnn.
Length Values
Values can be posted that provide a relative length of lines in a regional grid cell.
These values are computed as follows. The total length of all lines inside a regional
cell are totaled. Then, the maximum of these lengths is found. The "length value" for
a cell is the percent of the cell's length to the maximum length. These values are
indicated as L:nnn.
Dominant Angle Values
The dominant angle of orientation for each regional grid cell can be posted above the
rose diagram. The dominant angle is the "mode" of the histogram, i.e., the orientation
that has the longest line segments.
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General Tab

The regional grid is defined as a rectangular box in XY map units. The cell size of
increment also defined in XY map units. If you wish to have the region divided into a
10 rows by 10 columns, simply enter 10 in the "NxN" field and click the "Set" button.
The appropriate x and y increment will be computed.
There are two button to set the grid extents to the current screen limits or the limits
defined by the well data on the map.

Layers Tab

Analyze Lines From Layer - This dropdown sets the overlay layer containing all lines,
fractures, lineaments, etc. used to compute the rose diagrams.
© 2014

886

PETRA Help

Store Results In Layer - This dropdown contains the layer name of the layer
receiving the rose diagrams, text and other graphics. Petra will completely replace
the contents of this layer before storing new data. This layer can not be in a
read-only mode. The "R" button renames the output layer.

Rose Tab
The Rose Tab sets a few additional details on how the rose diagram plots.

Line Color - This option sets the overlay color for the rose diagrams' outline.
Fill Color - This option sets the overlay color for the rose diagrams' interior fill.
Maximum Diameter (XY Map Units) - This option sets the size of the largest rose
diagram. It's best to set this values no larger than the grid cell size.
Rose "Petal" Width (1 to 90 Degrees) - This option sets the the angle increment
used when building orientation histograms.
Include Grid Cell Lines - This option plots the regional grid outlines on the Map
Module.
Include "Dominant Angle" Text (Deg) - This option plots the lineaments' dominant
angle above each rose diagram.
Include "Length" Text (%) - This option posts the relative length of lines within each
cell.
Include "Coverage" Text (%) - This option posts the area covered by fractures in
each cell.
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Well Data Posting
The Map Module can post well header info, zone data items, or production data
around the well symbols.
To open the Data Posting tool, select the
button on the toolbar at the top of of the Map
Module, or select Options>Data Posting on the menu bar at the top of the Map Module.

Data Tab
Options Tab
Wells Tab
PdCum Tab
Misc Tab
Overposting Tab and Moving Posted Data

5.13.1 Moving Posted Data

Moving Posted Data
1) Left-click on the well
2) Hit F4 or click the

button on the toolbar at the top of the Map Module

3) Left-click on the text "block" to move
4) Move the mouse to the new position
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5) Left-click the new position

Resetting a Posted Data Text Box to its Original Position
1) Left-click on the well
2) Hit F4 or click the move posted data icon
3) Right-click on the text "block" to reset it to the default position
5.13.2 Data Posting Data
The Data Posting Data Tab controls how data is posted around the well symbols on
the Map Module.
To open the Data Posting tool, select the
button on the toolbar at the top of of the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.

Available Data Items
To add an item to the data posting, select the desired well header, zone data item, or
pd cum value on the Available Data Items List and select the
button immediately
to the right. Note that there are three buttons - the upper button adds the item
selected on the "Well Header Items" dropdown, for example.
Well Header Items - This dropdown selects well header info to add to the data
posting box. This is most commonly used to add well identifier information, such as
well name and number.
Zone Data Items - These two dropdowns select the zone and data item to add to the
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data posting. The upper dropdown selects the specific zone, while the lower
dropdown selects the data item in the selected zone. Note that Petra treats formation
tops as a zone - to add a formation top, select the "FMTOPS" zone on the upper
dropdown and the desired top on the lower dropdown. The
button resorts the
items on the lower data item dropdown into alphabetical order - this can be helpful for
large numbers of tops.
Pd Cum Items - This dropdown adds cumulative production data, visible on the Main
Module's Prod Cum Tab. This includes formation names, tops/base, and cumulative
values.

Selected Data Items
This list box displays all the well data items displayed on the Map Module.
or
- Petra display items on the selected data items from top to bottom. The up
and down buttons change the order of a selected data item by moving the item up and
down.
- This item removes the selected data item on the Selected Data Items list.
- This item removes all items from the Selected Data Items list.

Data Posting Tabs
Style Tab
Each posted data item contains posting attributes including the position relative to the
well symbol, text color and size, number of numeric decimal places and how the value
is labeled. Additional attributes can be set for formation tops including whether to use
alias names and whether to post subsea values. All Z values can have the "quality"
code and "units" posted following the value.

Post Quality Code - Check this option to have the quality code posted following a
zone data or top item. Null values will show only the quality code.
SS Datum = 0 If Null - This option is used in conjunction with the subsea tops option
and causes posted subsea tops to be computed using a datum value of zero if the
datum is null. Otherwise, the subsea top value will post as a null value when the datum
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is null.
Post Subsea Top - Use the option when posting formation tops and you want to see
subsea values. Subsea values are computed as: SS=Datum-Top.
Post Times - This option appends the seismic time (ms) to the posted depth value.
Times are calculated using the active velocity function for each well (from the "other"
tab in main).
Suppress Source - This option suppresses the display of the source portion of the
item name when the Label Style includes the name.
Use Aliases - If you have defined aliases, use this option to have the aliases searched
for when posting a value.
Post Units - This option causes the units value to be posted following the zone or top
value.
Post Remarks - This option causes the remark field associated with the top or zone
value to be posted.
Text Height - This section sets the text height for the selected data item. Text heights
or sizes are specified in either inches or map XY units, e.g., feet, depending on the
size option located on the Options Tab. When using XY map units, text will vary in
height depending on the map scale. When specified in inches, text is also the specified
height, regardless of the map scale. Inch text heights will enlarge slightly when you
zoom in if the "Enlarge With Zoom" option is selected. Click the ALL button to set all
text to the same height.
Position - Text items can be posted in four positions around the well spot. Select the
position to place the text item Above, Below, Left or Right of the well symbol on the
map.
Decimals - Set the number of decimal places to the right of the decimal point for
numeric values. Whole numbers will still post as integer numbers. Only values with
fractional parts will show the number of specified decimals.
Text Color - Each text line item can be plotted in a different color. Choose from the
palette provided by clicking on the color cell. Click the ALL button to set all text to the
same color.
HiLite By Quality - This section allows you to highlight individual lines of text based on
the quality code associated with the zone or tops data value. You may specify one or
more text strings, separated by a semicolon (;), that will be search for in the quality
code field. When the quality code is found, the line that one well will be highlighted
using the selected color as the text background color.
Font - Each line item can have a font specified from the font list.
Label Style - Several labeling styles are provided and control whether variable names
are posted along with the value.
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Scaling Tab
This option scales a displayed data item. This can be useful for displaying production
in 1000s of barrels or changing imperial to metric units. Note that this option does not
change the data in the database - it only changes the value for display.

Do Not Scale Value - This option leaves the values displayed as is. This option is on
by default.
Scale Factor (Multiply By) - This option multiplies the selected data item by a
constant. Multiplying a constant less than 1 will divide the data item.
Scaled Value Units - This changes the value units displayed on the map module.
Convert Zone or Tops Units - This section converts imperial and metric units. The
"Apply To All" will convert all displayed zones and tops to use the selected unit.

Misc Tab

Truncate to First Word Only - This option only posts the first word in the data item.
Suppress Commas in Values - By default, Petra puts commas at every third decimal
point. This option removes commas in the values. Note that this option will not affect
text items.
Suppress Source In Posted Name - The "Zone: Item - Value" and "Item Name Value" options post the source code for posted formation tops. This option removes
the source in the posted name.
Flag Aliased Tops By Appending an * to the Value - This option distinguishes between
actual top and aliased tops. Petra will add an "*" at the end of the formation top
value.
Skip Posting if Quality Code Is - This option prevents the selected label's plot when
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the data item's quality code matches one of the quality codes inside the entry box.
Separate multiple quality codes with a semi-colon.
Display Zero Top Values and Zone Item Values as NULLS (blanks) - This option posts
tops or zone data items with zero values as a blank. This option only affects the item
highlighted on the Selected Data Items list. Note that this tool only affects the display
on the Map Module, and does not change the values inside the database.
5.13.3 Data Posting Options
The Data Posting Options Tab controls how well data is posted around the well
symbols on the Map Module.
To open the Data Posting tool, select the
button on the toolbar at the top of of the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.

Active - When the "Active" option is checked, data will be posted by each well.
Uncheck the option to disable data posting.
Enlarge With Zoom - Check this option to have the posted text enlarged when you
zoom in.
Drop Missing Data Lines - Check this option to suppress posted data lines that are
blank due to missing data. Blank lines added as data lines are not suppressed.
Opaque Text - Check this option for posting text with an opaque background.
Opaque text is useful when posting over color-filled contours.
Combine Perfs For Completions - This option is used when the depths for perfed
intervals are posted. Only the initially completed wells, designated by a 14-digit API
number ending with "00", will be posted. Perfs from all other completions will be
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included in the listed perfs.
Post Only Primary Completions ("00" wells) - This option will only post a well if is a
14-digit API number ending in "00".
Gap Btwn Well And Data - Enter the height of the gap between the well symbol and
the posted data items. Enter a value that is relative to the "Sizes" option discussed
below.
Line Spacing - Enter the height of the gap between each posted text line. Enter a
value that is relative to the "Sizes" option discussed below.
Global Scale Factor - Enter a multiplying scale factor greater than 1.0 to enlarge all
text or less than 1.0 but greater than 0.0 to reduce the text.
All Sizes Are In - Select the mode for specifying text heights. You can enter sizes in
inches or in the xy units of the map, such as, feet or meters. Using the "inches" mode
will cause the posted text to maintain the same size regardless of the map scale.
Using the "Map XYs" option produces text heights dependent on the map scale.
Save Template and Load Template - Frequently used selected items list can be saved
to disk using the "Save" button. Saved lists can later be reloaded using the "Load"
button.
5.13.4 Data Posting Wells
The Data Posting Wells Tab limits the well data posting to only specific wells. This
tab also sets up "Primary" and "Secondary" wells. "Primary" wells post well labels at
full size, while "Secondary" wells either have their labels posted smaller and grey or
skipped completely.
button on the toolbar at the top of of the
To open the Data Posting tool, select the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.
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Wells To Be Labeled (Primary Wells)
This section controls how Petra selects primary wells.
All Wells On Map - This option posts all wells as primary wells. All well labels are
plotted at full size. This option is on by default.
Highlighted Wells - This option sets highlighted wells (Set on the Wells>Hilite Wells) as
primary wells. This option works whether highlighting is enabled or disabled.
Wells From a WSN List - This option uses a WSN well list to select the primary wells
for posting. To create a WSN list, select Wells>Select Wells>By Data Criteria. Be
sure to save a WSN list and not a UWI list.

Secondary Wells (Wells Not Selected As Primary)
This section controls how the Map Module draws secondary well labels.
Do Not Post Secondary Wells - This option just drops labels on the secondary wells.
Post Secondary Wells As Background - This option posts the labels on secondary
wells at 1/2 the specified size and with a grey color.
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The "Do Not Post Secondary Wells" (left) and the "Post Secondary Wells As Background" (right)

5.13.5 Data Posting PdCum
The Data Posting PdCum Tab controls how well data is posted around the well
symbols on the Map Module.
To open the Data Posting tool, select the
button on the toolbar at the top of of the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.

Combine PdCum Top and Base as Single Line Posting - When the "PdCum - TOP"
data item is on the Selected Data Items list, this option appends the base to the data
posted. Note that this does not affect the "PdCum - BASE" data entry.
Combine From and To Dates as Single Line Posting - When the "PdCum - FROM
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DATE" data item is on the Selected Data Items list, this option appends the "TO
DATE" to the production cum. Note that this does not affect the "PdCum - TO DATE"
data entry.
"Not Available" Indicator - This entry sets the text that will substitute in for missing
production cum data.
5.13.6 Data Posting Misc
The Data Posting Misc Tab controls how well data is posted around the well symbols
on the Map Module.
To open the Data Posting tool, select the
button on the toolbar at the top of of the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.

Zone Items Legend Option
This section sets the specific text on the "Posted Well Data" part of the Map Module's
title block.
Post Zone-Item-Description - This option plots the active zone and item on the title
block.
Post Item Description Only - This option plots only the item description on the title
block.
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The "Post Zone Item Description" option (left) and the "Post Item Description Description Only" option (right)

Legend Text Size Multiplication Factor - This option sets the size factor for the legend.
Wrap Zone Text Items to - This option sets the wordwrap for the title block.

Well Symbol in Legend - This dropdown sets the specific well symbol displayed on the
title block.
5.13.7 Data Posting Overposting
The Data Posting Overposting Tab controls how well data is posted around the well
symbols on the Map Module.
To open the Data Posting tool, select the
button on the toolbar at the top of of the
Map Module, or select Options>Data Posting on the menu bar at the top of the Map
Module.
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Manually Shifted Text Options
Petra's default data posting can sometimes create overlapping or illegible text blocks.
This section controls how Petra handles manually shifted text sometimes plot (above,
below, left, and right) can be moved or repositioned relative to the well spot using the
mouse. To manually move data posting, select the well and click the
toolbar to reposition the data posting box.

button on the

Disable Shifted Text - This option disables all manual data shifting, but retains the
settings in the database. Petra will draw the data posting text boxes in the default
locations.
Use Offsets From DB - This option uses the data shifting saved in the project
database.
Use Offsets From Offset File - This option uses the data offsets from the Data
Offsets File Manager.

Automatic Overpost Resolution
This tool automatically shifts data post boxes to resolve over posting conflicts.
None - This option turns off the automatic resolution, but retains the settings in the
database. Petra will return the data post boxes to their original locations.
Resolve All Overposting Automatically - This option changes all overposted data post
boxes.
Resolve Overposting for Items Not manually Shifted - This option moves only the text
that hasn't been moved manually. This can be useful for moving the some of the text
yourself, and have Petra move the rest.
Maximum Distance To Move Data From Well - This sets the maximum distance that
Petra will move the data overposting. Setting this entry too high can move data
posting very far away.

Clear DB Shifted Text - This option removes all the database shifting stored in the
project.

5.14

Grids and Contours
Petra generates and shows a computer-generated grid in two different steps. The
first step is to create a grid, and the second step is to display contours or color fills
based on that grid. Grids can also be used in calculations, are easily used in
volumetric estimations, and can quickly highlight different aspects of the same map by
modifying colorbars.
For a more general guide, see "How to Make a Contour Map."
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Getting Started
Creating a grid from well data
Adding color contours and/or contour lines to a grid
Adding interpretation to a grid
Adding a grid to a cross-section profile

Advanced Tools
Exporting a grid to ASCII, Exporting a grid to other file formats
Resampling a grid
Performing a simple arithmetic and curvature analysis on a grid
Calculating an isopach from two grids
Applying an equation to one or more grids
Advanced modeling with grids
Interpolating seismic values from a grid
Calculating volumetrics from a grid
5.14.1 Create a Grid

For more information about editing contours in the map module, see here.
For a more general guide, see "How to Make a Contour Map."
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Create Contour Grid Tool

Data Tab
Method Tab
Trend/Bias Tab
Limits Tab
Advanced Tab
Triangulation Tab
Misc Tab
Tops Tab
Interval Data Tab
5.14.1.1 Create Contour Grid - Data Tab

Click Here for a "How-To" guide on creating Contour Grids
The Data Tab selects the specific data that will be used, as well as the new grid’s
name and location on a local computer or network.

The Create Contour Grid Data Tab

Grid Folder - This box shows the currently selected grid folder, where any created
grids will be stored. Selecting the “…” button on the right of this box changes the
grid folder’s path. By default, Petra looks in the active project’s GRIDS directory.
Grid Title - This option sets the title for the grid. This title will be placed in the grid
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file header and displayed as the map title whenever a contour map is generated from
the grid. A default title is created whenever well data items or seismic z values is
selected.
Output Grid File Name - This is the external file name for the computed grid file.
Petra creates a default file name when well data items or seismic z values are
selected. The file extension for grid files is .GRD.

Zone Data To Grid
Making a map often means using different kinds of data. When making a grid, Petra
can use well data, external control points, seismic data, and drawn contour lines and
faults. Petra can use any one or combination of these different data sets to create a
single grid.
Zone Data – This option selects well data visible from the Zones Tab on the Main
Module. Simply select the zone and the appropriate zone data item. The
“FMTOPS” zone includes all created fm top data. The adjacent drop down selects
whether the fm top will be gridded as a MD, SS, SSTVD (if directional surveys are
loaded and enabled), or Seis Time (if velocity functions are loaded). A grid using this
data will use well data from for every selected well on the Map Module. Wells that
have been dropped from the map will not be used in the grid.
Disabled wells, on the other hand are still honored when gridding, even though they
don’t appear on the map. To disable a well, first select the well in the Map Module
with the left mouse button. Then, right click and select “Disable (Do Not Plot”). If
disabled wells contain bad data points, Petra will still try to grid using that data,
which may result in bulls eyes or other anomalies.
View Data - This option opens the View/Edit Zone Data tool.
Well Dist – This option calculates some basic statistics about well spacing, which can
be particularly useful when establishing grid spacing. This tool will calculate distance
statistics between all wells displayed on a map without discerning if they have data
or not. In other words, if you have a large number of closely spaced wells but only a
few of those wells have data, this well distribution box will give you an average
distance that is too small.
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Seismic - This option grids Z values stored in each shot point. This option only is
available if 2D shot points are loaded into Petra. The "Active Lines Only" option
restricts gridding to only use seismic lines currently set as active. Remember that
Petra will attempt to grid all checked data types, which can lead to bizarre maps if
formation tops (stored in the thousands of feet or meters) are gridded along with
seismic (stored in only a few seconds). When gridding only seismic data, be sure to
uncheck the Zone Data option.
Overlay Contour Lines –This option uses ALL VISIBLE overlay contour lines on the
map module to influence the gridding. Overlay contour lines are a powerful way of
adding human geological knowledge to an otherwise completely computer-driven
process. When drawing a contour line in the Map Module, setting a the overlay line’s
Line Class to “Contour Line” reveals the Contour Tab, where the contour line’s value
is set and can be edited.

Since Petra will use all visible contours during gridding, it’s a good idea to keep
different sets of contours separated into different overlay layers. Before gridding,
make sure to only have the relevant contour lines visible. As an example, keeping
structural contours (measured in negative thousands of feet) and net sand contours
(measured in tens of positive feet) both active at the same time during gridding will
result in bizarre maps as Petra will try to honor both sets of values.
Include Control Points – Control points are data points not tied to a particular well.
Control can come from a wide variety of sources including seismic data, topographic
surveys, or from legacy computer-generated grids.Control points can either be
loaded into Petra’s internal memory (under the Contours>Control Pts>Load File... in
the Map Module) or simply displayed from an external control point file (under the
Contours>Control Pts>Display External Control Point Files... in the Map Module).
Control points can also be created from scratch inside Petra (under the
Contours>Control Pts>Add... in the Map Module).
Include Faults – This option uses ALL VISIBLE overlay fault lines on the map module
to influence the gridding. Fault lines break the normal process of interpolation
between different data points. When drawing a fault in the Map Module, setting a
drawn overlay line’s Line Class to “Fault Trace” reveals the Fault Tab. The Fault Tab
sets the fault line’s value strength (determining the amount of fault drag), and the
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display of any fault symbols.

Since Petra will use all visible faults during gridding, it’s a good idea to keep different
sets of faults separated into different overlay layers. When using faults during
gridding, make sure to only have the relevant fault traces for that particular surface
visible.
Apply SS(TVD) to Zone Items – This option grids SS (for vertical wells) or SSTVD
(for deviated wells with loaded and enabled survey data) formation tops instead of
MD formation tops. In areas with any surface topography, this option is essential to
generate accurate subsurface structure maps
Calc XY For Dev Wells At Top – This option forces the data point to be contoured at
the map position of a specific formation top. By default, Petra plots and calculates
grids based on the location of the well symbol. On deviated or horizontal wells,
however, this can mean that the data value can be gridded thousands of feet away
from where the value was actually measured. This can significantly change an
interpretation – especially if the lateral part of the well is long or if there is faulting
involved. Select the appropriate top from the drop down menu, Petra will calculate
the map location of that fm top from survey data, and use that specific point instead
of the well symbol location for gridding.

5.14.1.2 Create Contour Grid - Method Tab

Click Here for a "How-To" guide on creating Contour Grids
The Method Tab controls the grid size and surface style of the gridding. The grid
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size of a grid largely controls how many points are in a calculated grid, which has a
direct bearing on contour line smoothness and how well the computer-generated
contour lines “honor the data.” The grid method, on the other hand controls how
Petra interpolates the grid from one data point to another.

The Create Contour Grid Method Tab

Grid Size
On a rectangular grid, the grid size determines the spacing between horizontal and
vertical interpolated grid node values, as shown in the example below where the blue
grid nodes are evenly spaced between a set of wells. A grid spacing of 900’
translates to grid nodes 900’ apart both north-south and east-west. Small spacing
leads to more grid nodes, which generally “honor the data” better but require much
more computer time. Large spacing, on the other hand, tends to generate smoother
contours with less computer time but at the cost of a less rigorous tie to data points.
The grid size section offers several methods for setting the grid size.
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Use Grid Size of (XY units) – This option sets grid spacing to a user-input X and X
grid size in map units (feet or meters). A good rule of thumb here is to use ½ the
average well spacing.
To calculate average well spacing, select the “Well Dist…” button on the Data Tab
(highlighted below on the left). The Well Dist… button on the gridding screen (on the
right) gives statistical information on distances between wells, including average
distances. This tool will calculate distance statistics between all wells displayed on a
map without discerning if they have data or not. In other words, if you have a large
number of closely spaced wells but only a few of those wells have data, this well
distribution box will give you an average distance that is too small.

Compute Optimum Size From Z Data - During gridding, Petra will compute a grid
size based on the well data distribution.
Set Rows and Columns Slider Bar – Instead of setting a specific grid size, this option
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instead sets the total number of horizontal and vertical rows for the grid. Sliding the
“Coarse to Fine” slider bar changes the number of rows and columns used in the
grid. Notice that as these are changed, the x and y grid spacing sizes change
accordingly.
Match Grid Size of Grid – This option sets the grid size of the new grid to exactly
match the grid size of an old grid. Select this option, and use the drop down menu to
select the grid file to be matched. Note that the X and Y sizes are updated to show
the grid sized used.
Mathematical calculations between two or more different grids require the size and
spacing of each grid to match exactly. As an example, creating a hydrocarbon pore
volume grid (where HPV = thickness * porosity * hydrocarbon saturation) would
require the isopach, porosity, and water saturation maps to all have the same grid
spacing. Using this option to match the porosity and hydrocarbon saturation grid size
to the initial isopach grid will save considerable time later.

Surface Style
This option determines the shape and characteristics of the gridded surface by
applying different mathematical functions to the original data. Surface styles
interpolate the data between data points on both rectangular and triangular grids.
Highly Connected Features - This is Petra’s default gridding style. It uses a least
squares gridding algorithm that tends to preserve trends in the data and works well
for most data, particularly structure maps and gently changing petrophysical data.
The Highly Connected Features surface style works well with faulted reservoirs.
This surface style tends to not do well with rapidly changing or large contrasts
between data points such as production in a closely-drilled field.
This method tends to avoid geologically unrealistic contours (or “artifacts”) on the
edges of the grid, though contours can to be somewhat jagged and uneven with
small grid sizes. The application of surface flexing (“Smooth Contours Using Grid
Flexing” immediately below the Surface Style drop down menu) works well with this
surface style, as it tends to smooth and even out the spacing between contour lines.
Disconnected Features – This surface style uses a linear projection algorithm that
tends to produce closed-off features. This surface style can useful for mapping
patch reefs or isolated channels. The Disconnected Features surface style can be
used with faults. Contours generated from this surface style can be uneven and
jagged, but this is easily remedied by adding surface flexing (“Smooth Contours
Using Grid Flexing” immediately below the Surface Style drop down menu).
Since this method calculates grid values from a projected linear slope between one
data point to the next, the Disconnected Features surface style is susceptible to a
couple of different types of gridding artifacts. At the edge of a map this surface
style extends the nearest linear projection when calculating Z values, making it
particularly prone to “runaway grid values” on the edge of the map. The
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disconnected nature of the surface style also tends to make “bumpy” maps where
two adjacent wells form an adjacent dome and a bowl instead of a more generalized
trend.
Simple Weighting With Slopes – This surface style calculates a grid using three
steps. Petra first calculates a slope for each data point based on surrounding data
points. These slopes are then used to project the data points’ Z values out to each
individual grid node. Finally, this surface style takes the weighted average of the
projected Z values.
he Distance Weighting Damping Factor on the Advanced Tab can greatly affect this
surface style. This option uses any value from 1 to 8, with a recommended default
setting of 2. With a small factor, more distant data points have more influence on an
individual data point which tends to average the grid node; this usually results in a
smoother grid. With a larger factor, close data points influence the individual grid
much more than more distant data points. The recommended value for this factor is
2. For more information, see the help file on the Advanced Tab.
Simple Weighting Without Slopes – This surface style applies a weighted average to
the data points around each grid node. In contrast to the Simple Weighting With
Slopes surface style, no slope information is used. This option is useful for very
dense control such as 3D seismic bin locations.
The Distance Weighting Damping Factor on the Advanced Tab can greatly affect this
surface style. This option uses any value from 1 to 8, with a recommended default
setting of 2. With a small factor, more distant data points have more influence on an
individual data point which tends to average the grid node; this usually results in a
smoother grid. With a larger factor, close data points influence the individual grid
much more than more distant data points. The recommended value for this factor is
2. For more information, see the help file on the Advanced Tab.
Distance Grid - This surface style calculates the distance to the nearest data point
for every grid point. Put another way, the grid right next to a data point will have a
low Z value, while a grid a great distance from any data point will have a high Z
value. Contouring this distance grid can be a useful way of visualizing drainage and
bypassed parts of the reservoir. Parts of the grid with a high distance to the nearest
well are less likely to be drained than parts of the grid with a low distance.
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Again, this method only calculates distance to the nearest selected data point, which
can include contour lines and control points in addition to wells. If “Use Overlay
Contour Lines” is selected on the Data Tab, the surface style will calculate the
distance from the nearest well or the nearest contour line. This renders any
visualization of drainage useless, so be sure to only select “Zone Data” for this
surface style.
Closest Point - This option simply sets each grid node to the value of the closest
data point. It doesn’t interpolate between data points, and is really more useful for
resampling existing grids. It is best used with very dense data such as 3D seismic
coverage or with legacy XYZ grids.
Minimum Curvature (no faults) - This surface style attempts to create a very smooth,
gradual surface. Contour lines with this method are smooth and evenly spaced,
which makes this style a good choice for gently changing petrophysical properties
and simple structural settings.
This method cannot be used with faults. Since the minimum curvature algorithm is
also available under the “Smooth Contours Using Grid Flexing” option (immediately
below the Surface Style drop down menu), so you can use the Highly Connected
surface style (which works well with faults) along with the grid flexing option. Since
this method strives to have as simple a surface as possible (one with a “minimum
curvature”), this surface style tends to smooth over some of the variation in data
points. In short, this method has the potential to “not honor the data” as well as
other methods. Edge effects with “runaway Z values” are also common with this
method.
The Min Curvature Tension setting on the Advanced Tab can greatly affect this
surface style. Practically, high tension grids – particularly above 5 - have smoother
and more even contours but may not honor the original data as well as lower tension
grids.
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Adjust Zero Contour for Isopach Surface – This option helps to make more
geologically reasonable isopach maps where there are zero-valued data points.
When creating a grid, Petra attempts to connect data points. As an example, the
grid will attempt to connect a 15’ data point with another 15’ data point, resulting in a
15’ contour line connecting the two points.
Zero-valued data points are a little different. Since Petra attempts to connect all
zero points, the grid can unrealistically oscillate around zero. The “Adjust Zero
Contour for Isopach Surface” option instead forces Petra to assume that the actual
zero isopach line for the grid is midway between a zero value and a non-zero value.
Effectively, this creates a more realistic isopach map.

The "Adjust Zero Contour for Isopach Surface" puts the actual 0' contour halfway between zero and non-zero data
points

Smooth Contours Using Grid Flexing – This option adds an additional step after
gridding to generate smoother, more even contour lines. When this option is
selected, Petra first uses the selected surface style to interpolate between the data
points to create grid nodes. Next, Petra applies the minimum curvature surface style
to both the original data points and to a decimated sample of the newly-interpolated
grid values.
The relative strength of the grid flexing option is set by the “Flex Grid Factor” on the
Advanced Tab. This option can be set anywhere between 0 and 12. Setting a low
grid factor will keep a relatively strong primary surface style, while a high grid factor
will increase the relative strength of the minimum curvature surface style.
Grid flexing is also influenced by the “Min Curvature Tension” option on the Advanced
Tab. Practically, high tension grids – particularly above 5 - have smoother and more
even contours but may not honor the original data as well as lower tension grids.
5.14.1.3 Create Contour Grid - Trend/Bias Tab

Click Here for a "How-To" guide on creating Contour Grids
The Trend/Bias Tab allows for the calculation of Trend and Residual grids to highlight
hidden anomalies and to introduce a directional bias (i.e. North to South features are
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connected) to grids.

The Create Contour Grid Trend/Bias Tab

Trend Residual Surface
Surfaces with a strong trend can often obscure smaller regional anomalies. As an
example, a strong regional dip can easily hide subtle bumps that make great traps.
Trend-Residual mapping is a way to subtract the effect of the generalized “Trend”
from the original surface to reveal the “Residual.” This Residual map shows
anomalies that are above and below the trend.
The Trend surface is a simplified version of the original surface. In essence, Petra
fits a polynomial function to the data. The "Order of Fit" option determines the order
of this function. As an example, a 1st order fit is a plane, a 2nd order polynomial shows
some curvature, and a 3rd order polynomial is a saddle. Generally, higher order
trend surfaces fit the original surface better, which tends to minimize the residual
surface. To model a monoclinal dip, select a 1st order of fit.
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No Trend Residual - This is the default option, and is used for normal gridding. It
produces a normal grid of the original data instead of a trend or residual derived
from the original data.
Create Trend Surface - Select this option to create only a trend surface to the data.
As mentioned earlier, the "Order of Fit" option determines the function fit to the data.
While it’s a good idea to create a trend surface for quality control, it’s not necessary
to create a separate trend surface in order to see a residual.
Create Trend Residual Surface – Select this option to calculate a residual from a
trend. This option automatically creates a trend surface, subtracts the trend surface
from the original grid, and displays the residual without this step.

Directional Bias
It’s sometimes useful to add a directional bias on computer-created grids. With this
option selected, Petra will attempt to connect data points along this direction. This
can aid in modeling sand distribution in specific depositional environments like
channels or barrier islands, for example.
Active – This option turns on the directional bias.
Direction – This sets the bias’ direction.
Strength – This option sets the strength of the bias. A stronger bias will attempt to
connect more distant data points together.

5.14.1.4 Create Contour Grid - Limits Tab

Click Here for a "How-To" guide on creating Contour Grids
The Limits Tab sets the extents and edges of a calculated grid.
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The Create Contour Grid Limits Tab

Grid Extrapolation
By default, the gridded surface extends only over the area of the map containing
wells. Alternatively, you may have the grid values computed over the entire range of
the grid limits. Extrapolating beyond the data control points can sometimes result in
unreliable or runaway grid values. Also, see "Extrapolation Distance" in the Advanced
section to control the amount of extrapolation produced.
Do not Grid beyond Data – This option limits gridding only to the data points in the
Map Module.
Extrapolate values to Edge of Grid – This option extrapolates the slope of the grid
beyond the selected data points.

Grid Limits
The grid limits govern the extents of a grid. For aesthetics or to save gridding time,
it’s often useful to limit gridding to only the relevant area.
Use Grid Limits of Well Data – This option extends gridding out to all selected wells
in the Map Module with data.
Use Grid Limits Specified Below- This option limits data to the X and Y limits defined
in the “User Defined Grid Limits” box below.
User Defined Grid Limits – This field has 4 boxes outlining the maximum and
minimum X (East-West) and Y (North-South) values. You can enter your own grid
area XY limits. Selecting the “Screen Limits” button automatically populates these
boxes with the current view on the map, while the “Well Limits” button populates
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these boxes with the extents of all selected wells.

Blanking Method
The blanking method determines how Petra handles the edges of rectangular grids
when the “Do Not Grid Beyond Data” option is selected on the Limits Tab. Since
triangular grids only interpolate directly between data points, blanking methods have
no effect on these types of grids.
Neighbor Search – This method draws color fills and contours out to the edges of the
grid, which most often will be the extrapolation distance. This can result in a jagged
grid edge around corner wells on rectangular grids.
Convex Hull - This method trims grids beyond a polygon defined by the outer-most
data points. This results in smoother edges.

5.14.1.5 Create Contour Grid - Advanced Tab

Click Here for a "How-To" guide on creating Contour Grids
The Advanced Tab changes settings on how Petra creates grids. While a couple of
these settings actually modify how Petra uses missing or poor quality data
(Substitute Zero for Missing SS Datums, and Skip Well if Quality Code Includes),
most of the settings govern the specific settings of the gridding algorithms.
It’s generally quicker to focus time and effort on drawing a few contour lines
to add interpretation rather than using these settings. Remember, it’s not
necessary to draw a complete set of contour lines in order to greatly enhance the
gridding process. Even just a few key contour lines can have an enormous (and
quick) effect on the computer-generated grid.
The “Defaults” button on the lower right corner of this tab reverts all settings back to
the default settings. The default settings are a good all-around choice for most
gridding.
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The Create Contour Grid Advanced Tab

Misc Options
"Substitute Zero For Missing SS Datums" – Plotting maps in subsea (or “SS”)
attempts to eliminate the effect of surface topography on subsurface structures.
Instead of plotting subsurface features according to their measured depth (MD), SS
depths are referenced to sea level at 0’ elevation; depths below sea level are in
negative numbers and depths above sea level are positive. The equation to calculate
a fm top’s SS is straightforward: Elevation – MD = SS. Elevation is usually provided
as ground level (GR), kelly bushing (KB), or derrick floor (DF).
In the example below, the reservoir in the subsurface is perfectly flat. There’s a
significant change in elevation across the area (blue arrows), however, which has a
large effect on the overall measured depth (black arrows) to the reservoir. The best
way to illustrate the true nature of the reservoir’s structure is with SS depths (red
arrows), which are exactly the same for all wells. The third well, however, is missing
an elevation datum, so accurately calculating its SS depth is impossible. Normally,
when the reference datum is missing, Petra simply leaves the SS depth null. These
null values have no effect on gridding SS surfaces.
Selecting the “Substitute Zero For Missing SS Datums” option, however, will
substitute in a zero for the missing elevation. For areas of uniformly low elevation
this is a reasonable assumption. For areas with changing elevation, however, this
can grossly distort the map. In the example below on the right, a zero elevation
substitution ignores the effect of elevation, which causes a large (and entirely fake)
syncline underneath the well missing a elevation datum.
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Use Simplified Fault Traces – This option simplifies the number of points on drawn
fault lines in order to accelerate gridding. Fault lines on the overlay – particularly
those drawn using the “stream” mode - can contain a large number of redundant
points. Since faulted grids require triangulation of each fault line node, simplifying the
fault can greatly accelerate gridding time and reduce overall grid file size. This
option does not change the fault line as drawn on the overlay.
Optimize Data Search For Speed – This option presorts data points by location in
order to accelerate gridding. This clustered data, however, tends to generate radial
grid artifacts. Most modern computers are fast enough to not need this option.
Enable Grid Substitution - Use this option to use values from another grid file to fill in
sparse control point areas. This unlocks the Grid Subst Tab. Here, select an
existing grid in the default grid directory. Petra will substitute values from this grid
wherever there are missing values on the new grid.

The Create Contour Grid Grid Substitution Tab

Do Not Resample Contour Lines – In order to use a drawn contour line, Petra needs
to resample the line into a set of discrete points. By default, Petra calculates an
optimum sample based on the specific grid’s spacing. This option instead forces
Petra to use all available data points from the contour line, which can greatly
oversample the data and generate erroneous ties to the contour line.
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Skip Well if Quality Code Contains – This option skips data points from wells that
have specified quality codes. Here, enter one or more values separated by a
semicolon to indicate wells that are NOT to be used for gridding.
Disconnected Features Weight Option – The Disconnected Features surface style
depends on “weighted averages”, in which nearby data points contribute more to an
individual grid point’s average than distant data points. This option changes how the
Disconnected Features surface style averages different data points.
The weighting of different data points is determined by a ratio between the distance
of a data point to the grid node and a “total distance.” This option simply sets how
Petra defines this “total distance.” Distance to Farthest Neighbor uses the distance
to the furthest well used in the octant search, while the Search Radius option instead
uses the entire search radius (which by default is half the diagonal of the gridded
area). Effectively, the nearest neighbor distance creates a localized weighting
relationship for every grid node, while the search radius setting uses the same
weighting relationship for every grid node.
Apply Log10 Transform – Highly variable data such as production information can
generate anomalously broad contours during normal gridding. This option applies a
transform to the data to “tighten” contour lines around highly variable data. The
output grid will have the original Z value units.
Mathematically, the Log10 transform has three steps. First, the filter applies a
Log10 transform to all data points. In the example below, the six wells with values of
10 surround one well with a value of 1000 shown on figure A. Taking the LOG10 of
these data points changes them to six wells with a value of 1 surrounding a single
well with a value of 3 (Log10(10) = 1, Log10(100) = 3). Gridding these transformed
values generates a simple grid with values between 1 and 3 as shown on figure B.
Finally, Petra converts the data points and the new grid back to their original data
points with the inverse of Log10, 10^X. Effectively, this changes the original linear
slope between the central, large data point and the outlying smaller data points from
a linear relationship to a power relationship.
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Practically, the transformed grid reduces the regional effect of the large value in the
center. Generally, adding the LOG10 transformation will generate a more
conservative grid with highly variable data than a simple linear surface style alone.

Fault Gap XY Tolerance – Faulted grids sometimes have small white triangles on
color-filled grids near fault node points. Changing this option changes how Petra
constructs a faulted grid, which can eliminate these artifacts. The default value is 1.0
XY unit, and should be kept between 0.5 and 3.0. A value that is too large may
cause other unwanted white space between grid cells
On rectangular grids, Petra handles faults by creating a triangular grid inside the
regular rectangular network of grid nodes. Where the overlay fault crosses a set of
four grid nodes (as in the example below), Petra adds more data points a small
distance away from the drawn overlay fault line on the normal rectangular grid
spacing. Petra then constructs a triangular grid using these new points to break the
grid across the fault. This “Fault Spacing” option sets the maximum distance
between the drawn fault and the newly created points.
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Fault Gap Tolerance

Max Pts Per Octant – Petra interpolates the value of each grid node from
surrounding data points. This option sets the maximum number of data points in
each octant used for each grid node, and can be anywhere from 1 to 8. For
example, with a value of 2 the gridding process will use a maximum of 16 data points
(2 for each octant) distributed around the grid node.
When determining which data points will be used for each grid node, Petra first
divides the area around the grid node into eight wedges, or “octants.” Petra then
uses the closest data points (up to the maximum set by this option) in each octant for
calculating an individual grid node’s value. Dividing the surrounding data into octants
helps avoid grid nodes that are too heavily biased by data points in one direction.

Max points per octant set to 1 (left) and 2 (right)

Flex Grid Factor – This option changes the relative strength of the “Smooth Contours
using Grid Flexing” option. Low Grid Flex Factor create final grids that look like the
original surface style, while higher Grid Flex Factors will create a grid that looks
more like a Minimum Curvature grid.
When the “Smooth Contours using Grid Flexing” option is selected (on the Method
Tab), Petra first interpolates the data points with the selected surface style, then
adds an additional step to interpolate both the original data points and the newly
created grid values with the minimum curvature gridding algorithm.
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Mathematically, this option controls the decimation of the initial grid, and can be set
from 2 to 12. When this option is set to 2, every other original grid point will be used
in the Minimum Curvature step. In this case, a large number of initial grid points
remain which constrains much further interpolation from the second minimum
curvature interpolation. When this option is set to 12, only every 12th original grid
point will remain. The relative low number of initial grid points allows for more
interpolation from the Minimum Curvature step. In short, the lower the Grid Flex
Factor, the more the final grid will look like the original surface style. Higher Grid
Flex Factors will create a grid that looks more like a Minimum Curvature grid.
Min Curvature Tension – This option sets the flexibility, or “tension”, of the Minimum
Curvature surface style and the Grid Flexing option available on the Method Tab.
This value can be set between 0 and 9. A grid with a low tension setting easily folds
and bends to accommodate changes in the data, while grids with a higher tension
folds less easily. Practically, high tension grids – particularly above 5 - have
smoother and more even contours but may not honor the original data as well as
lower tension grids.

Specific Surface Style Options
Distance Weighting Damping Factor – Both the Sample Weighing With Slopes and
Sample Weighing Without Slopes surface styles depend on “weighted averages”, in
which nearby data points contribute more to an individual grid point’s average than
distant data points. This parameter determines the relative contribution of close data
points versus more distant data points to the final data grid value. Petra can use any
value from 1 to 8, with a recommended default setting of 2. With a small factor,
more distant data points have more influence on an individual data point which tends
to average the grid node; this usually results in a smoother grid. With a larger factor,
close data points influence the individual grid much more than more distant data
points. The recommended value for this factor is 2.
Mathematically, when either of the sample weighing surface styles calculates an
individual grid node, Petra uses the adjacent data points and multiplies them by an
inverse of the distance to the grid node (1/Dn). Multiplying by the inverse of the
distance minimizes the contribution of more distant datapoints (with a larger D)
relative to more proximal ones (with a smaller D). The Distance Weighing Damping
Factor, n, is the power of the distance in the inverse, which magnifies or minimizes
the inverse’s effect on distant data points.
The example below walks through a single grid node (the + in the center) calculated
from three surrounding points. The map view on the left shows that two data points
have values of 15 and are 10 units away from the grid node, while one data point has
a value of 10 and is 3 units away from the grid node. The formula for the calculating
the grid node is below the map view. Filling in the values on the left side of the
figure, it is a little easier to see how the Distance Weighting Damping Factor, n,
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affects the formula. Larger values of n decrease the relative contribution of the more
distant wells with a value of 15, which drops the averaged grid node value.

Using a damping factor to prioritize close data points at the expense of more distant data points

Search Radius – To calculate a single grid node, Petra interpolates values from
surrounding data points. Most rectangular gridding uses an “octant” search, where
Petra uses only the nearest data points (set by the “Max Pts Per Octant” setting)
from each of the eight pie-shaped wedges, or “octants.” This option sets the radius
of this search in XY units. The default, set with a zero value, is a fairly large search
radius of half the diagonal of the gridded area.

A small search radius only uses close data points (left) while a larger search radius can use use more points (right)

Dividing the surrounding data into octants helps avoid grid nodes that are too heavily
biased by data points in one direction. If the specified search limit is too small, the
grid may contain null values in areas of sparse data control.
Extrapolation Distance - This option sets the distance (in XY units) to extrapolate the
grid beyond the data points. The default value of 0.0 extrapolates the grid two grid
cells beyond the actual data points or up to the data limits set by the "Grid
Extrapolation" option selected in the Limits section.
The extrapolation distance will only extend the grid in multiples of the grid spacing.
The “convex hull” blanking method (on the Limits Tab) also automatically nulls any
grids beyond a polygon defined by the outer-most data points, which can negate any
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changes made to the extrapolation distance.
Skip Data Pts Closer than (XY Map Units) – Close data points can cause unwanted
gridding artifacts. When Petra finds two data points that are within this setting’s
value of XY units together, it only uses the first one it finds. As an example, setting
this value to 100 will skip any other data points within 100 XY map units. For well
data, Petra will use the well with the lower WSN.
Use Natural Neighbors – This option causes most surface styles to use a “natural
neighbors” triangulation search instead of the normal octant search when selecting
data points to interpolate for each grid node. This tends to provide a more localized
interpolation, which can benefit grids with dense data point coverage. Since this
adds an additional pre-gridding triangulation stop, this option can increase gridding
time.
When deciding which data points to use for each grid node, most rectangular grids
styles (Highly Connected Features, Disconnected features, Simple Weighting With/
Without Slopes) use an octant search where the area around a grid node is divided
into eight wedges, or “octants.” This octant search ensures that data points used for
the grid point interpolation are evenly geographically distributed. A natural neighbors
search, in contrast, selects surrounding data points that can be connected by a
triangular network. This option just changes how Petra selects the data points for
interpolation, so the output will be a normal rectangular grid.

Octant search selects data points in 8 wedges around the node, while a natural neighbors search uses a triangular
grid

Equal Distance Alg. - This option adds additional triangulated data points in between
widely spaced data points before normal gridding. This helps to fill in areas of
sparse data coverage to better preserve regional trends on the grid.
Mathematically, this step performs a simple triangulation between distant data points
and adds them to the grid before performing the normal gridding with the selected
surface style. These triangulated data points can have a refinement of 1, 2, or 3, as
set by the adjacent drop down menu (for more information on refinement, see the
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“Triangle Refinement” in the Triangulation Help document). These additional data
points are used along with the original data points during the normal gridding. It’s
worth noting that with a normal rectangular surface style the final output grid will be
rectangular – the triangulated data points created by the Equal Distance Algorithm
are not saved in the final output grid.
Practically, this option is useful for keeping a small grid size when the grid has areas
of sparse data coverage and areas of tight data coverage. This option works best
with the "Highly Connected Features" gridding surface style method.
5.14.1.6 Create Contour Grid - Triangulation Tab

Click Here for a "How-To" guide on creating Contour Grids
The Triangulation Tab sets changes the gridding from rectangular to triangular
gridding. Triangular grids always “honor the data” at the cost of sometimes
unrealistic changes in slope or dip. Refinement adds more interpolation inside these
triangles, which smoothes these grids. Interior angle clipping reduces grid artifacts
caused by widely separated wells on the edge of the map.

Instead of interpolating values for nodes at regularly spaced X and Y intervals,
triangulation instead constructs a network of nearest neighbors using the data points.
Essentially, Petra calculates node values along lines (shown with lines) between
data points. These nodes form triangles known as “Delaunay triangles.” Notice also
that there is a node value directly on top of each well. The resulting contours “honor
the data” better because they are drawn using the actual values as opposed to
interpolated data in rectangular gridding. Triangular grids are better suited to closely
spaced, or highly-variable data rather than widely separated data.
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Check the Triangulate box to perform triangulation instead of rectangular gridding.

Triangle Refinement – In a simple triangular grid, each Delaunay triangle is
independent from every other triangle so calculated gradients on one triangle can
differ significantly from an adjacent triangle. This can lead to rapidly changing,
geologically unrealistic dips and angular contour lines. Contours from these simple
triangular grids can look strange and can even cross.
Petra smoothes these triangular contours with a process called “triangle refinement.”
Refinement adds more points inside a Delaunay triangle to smooth the grid’s surface
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and contour lines. These points inside the triangle are interpolated using Petra’s
surface style (such as “Highly Connected Features”). selected on the Method Tab
and surrounding data points. The refinement value selected here determines the
number of additional points, which in turn governs the smoothness of the contours. A
refinement of 1 simply uses the existing data points with no interpolation, while a
refinement of 16 adds a great deal of interpolated points inside each triangle.
Practically, a highly refined grid will have smoother contour lines than a grid with
lower or no refinement.

Interior Angle – Triangular grids attempt to connect all data points together
regardless of how far apart they are. The part of the grid based on an interpolation
between distant data points often shows geologically unrealistic contours –
especially on the edge of the map. On the right side of the example below, two
highlighted triangles have high interior angles of 172 and 160 degrees. The area of
the grid represented by these two triangles probably interpolates the data too far
and should be removed.
The triangular grid between these distant wells has one corner with a large angle.
Filtering out triangles with this high interior angle helps to trim out overly-interpolated
or geologically unrealistic parts of the grid on the edge of the map. Setting the value
here to 150, as in the example below, will eliminate all triangles with an internal angle
above 150 degrees. The smaller the angle, more edge triangles are removed.
Suggested values are 120 to 160 degrees.
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Fast Local Slope Interpolation Method –Normal refinement uses the selected surface
style to interpolate data points inside each Delaunay triangle based on the
surrounding “neighborhood” of data points. The “Fast Local Slope” method instead
uses partial derivatives to interpolate inside each triangle. In other words, while the
normal refinement method attempts to make a more coherent regional picture based
on outside data, this method simply uses only the data points in the Delaunay
triangle. Consequently, this method is quick, but is prone to geologically
unreasonable dip changes and other artifacts.

5.14.1.7 Create Contour Grid - Misc Tab

Click Here for a "How-To" guide on creating Contour Grids
The Misc Tab controls a few miscellaneous gridding options including the userspecific grid file directory, seismic shot point decimation, the preview window, grid
scaling and grid templates.
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Default Grid File Directory
By default, Petra stores all grids into a single GRIDS folder inside the project’s
directory. Particularly in large projects with multiple interpreters, it’s sometimes
useful to designate multiple grid folders. Changing this setting just affects the
individual user, and not the default grid file of the project as a whole.

Seismic SP Decimation
A single seismic survey can contain far too many points to usefully grid. It’s often
useful to thin seismic data coverage down to accelerate gridding. This option only
disregards data during gridding, and does not erase any seismic data.
Use every Nth Pt – This option decimates data points just by occurrence, where
Petra will use every Nth point and disregard the rest. Setting the N value to 5 will
start with the first available SP point, such as SP 7, 12, 17, 22, etc.
Use SP Multiples of N – This option decimates data points with a little more control
over which specific SP points are selected. Setting the N value to 5 ensures that
Petra will use SP 0, 5, 10, 15, etc.

Show Preview Window While Gridding
This option simply adds a preview window to the normal gridding screen. During
gridding, this preview shows a small thumbnail of the grid as its created. This is
particularly useful for early QC of large, time-consuming gridding processes.
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Scale Output Grid By
This option provides a way to quickly rescale grids. This is particularly useful for
rescaling grids based in feet to meters and vice versa. In a project where depths
are stored as feet, selecting the “Convert Feet To Meters” option before gridding will
multiply all values in the grid by 0.3048, for example.

Gridding Templates
A template saves all the settings associated with creating a grid file in a *.gt file.
Loading this template restores these settings. This can be particularly useful in a an
iterative environment where several grids are being updated and modified
continuously.

5.14.1.8 Create Contour Grid - Tops Tab

Click Here for a "How-To" guide on creating Contour Grids
Horizontal wells commonly pop in and out of a specific interval of stratigraphy. Each
occurrence of this bed boundary is a potentially useful data point. One of the best
ways to capture this information is with multiple, related formation tops.
In the example below, the wellbore enters the target rock once at point A, exits the
interval at point B, and enters again at point C. Every time the wellbore crosses this
boundary, it creates a potentially useful data point with a latitude, longitude, and a
TVD value.
Petra can only store one named top for each well, so it’s necessary to create a set
of tops. It’s usually best to keep this simple by simply naming the tops successively.
In the example below, points A, B, and C are named “Sycamore1”, “Sycamore2”,
and “Sycamore3”. All three tops reflect the same stratigraphic surface, but at three
different points on the same wellbore.
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This tab aliases multiple formation tops on horizontal wells to a single formation top
during gridding. In the example below, gridding the “SCMR” top will also use the
“SYCAMORE1”, “SYCAMORE2”, and “SYCAMORE3” tops as additional data
points.

It’s worth noting that TVD values of these tops from horizontal wells commonly don’t
line up with existing subsea maps – and is usually wrong in multiples of 30’. Pipe
tally errors can easily add or subtract footage from MD. A single wrong MD leads to
incorrect calculations of TVD for every successive survey point.

5.14.1.9 Create Contour Grid - Interval Data Tab

Deviated and horizontal wells can generate data spread along the wellbore’s path.
Interval data is a good way of displaying and incorporating multiple data points along
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a wellpath into a grid. Petra can grid any numerical interval field designated as a “real
value.” Date and text interval fields can’t be used in gridding.
In the Map Module select Contours>Create Grid… from the menu bar at the top of
the screen. Here, select the relevant data, grid size, and surface style; Petra can
integrate interval data into a grid using zone data, tops, overlay contour lines, or other
XYZ data. On the Interval Data Tab, select the “Active” option to use the selected
interval table and numerical interval field in gridding.
Note that there are a couple of ways to modify which intervals are used in gridding:
intervals can be pared down by quality codes, zones, or interval filters. The “Skip
Well if Quality Code Contains” option allows the user to skip wells that have specified
quality codes. Here, enter one or more values separated by a semicolon to indicate
intervals that are NOT to be used for gridding.
This “Intervals must Fall within Depths of Zone” option limits which intervals are used
in gridding to only the intervals inside the specified zone definitions. The “WELL” zone
covers all depths, and consequently all intervals. Be careful when using zones and
horizontal wells. Note that this zone criteria works uses the zone interval definitions,
which are often defined by tops. Horizontal wells that stay entirely within a zone and
never reach the base will not have a base top picked, and will consequently be
excluded from gridding.
The “Apply Interval data Filters” option provides more direct control over which over
which intervals are used in gridding. Intervals that do not meet the filter criteria are
not gridded. To create or modify a set of filters, select the “Set Filters…” button on
the Filters tab.. For more information on filters see the “Using Filters” section of this
document.
The “Use Interval Top/Middle/Base Depth” is option sets where numerical “real value”
interval fields are contoured. Especially with longer intervals in horizontal wells, this
difference can significantly change where a data point is plotted. Note that this option
is grayed out when gridding interval tops and bases.
In the example below, a single interval in the wellbore is outlined in with a box on the
cross section on the left. While the top and base of the interval have a specific XY
location on the map, other data (such as an average porosity value) can grid that
value at the XY position at top of the interval, at the middle of the interval, and at the
base of the interval.
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By default, Petra uses the survey’s TVD when contouring the top and base of
intervals. The Apply Subsea TVD Correction to Interval Field Value option instead
corrects to SSTVD by subtracting the KB elevation. This option is essential when
incorporating interval data into SS structure maps.
The “Export XYZ File Containing Int Data Used in Gridding” option creates a text file
containing the X and Y coordinates (using the project’s map projection) along with the
interval value used in gridding. Specifically, Petra creates a *.XYZ file in the project’s
GRIDS folder. This file will be named after output grid file name with a “_INTDATA.
XYZ” suffix.

5.14.2 Contour a Grid
For a more general guide, see "How to Make a Contour Map."
A computer-generated grid by itself is just a set of numbers that reflect a X
coordinate, a Y coordinate, and a Z value. A big part of interpretation is representing
this data clearly and concisely with contour lines and color.
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Setting a Grid File, Conour Range, and Colorbar

Grid Tab
Options Tab
Style Tab
Advanced Tab
File Tab
5.14.2.1 Contour a Grid - Grid Tab

The Grid Tab establishes the specific grid file to contour and display on the map, as
well as the colorbar.
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The Contour a Grid window's Grid Tab

Grid File
This section defines the grid file that will produce the contours.
Grid Directory - This window displays the currently selected grid directory. By
default, Petra will look in the project's GRIDS folder. To change this folder, select the
"..." button to the right. This grid directory affects the grids displayed on the following
dropdown menu; if a grid isn't showing up, make sure to check that the folder
containing the desired grid is selected.
Grid Dropdown - This dropdown lists all the available grids in the selected grid
directory; if a grid isn't showing up, make sure to check that the folder containing the
desired grid is selected. These grids can be arranged by creation date, or by file
name in alphabetical order. Note that the selected grid's title shows in the "Title"
window at the bottom of the Grid File Section.
Delete - This option deletes the currently selected grid.
Rename - This option renames the currently selected grid
Default Range - This option attempts to automatically set the contour range based on
the minimum and maximum values in the grid.
Stats - This option displays a histogram and other statistical data about the z values in
the grid.
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A Data Stats Histogram of the Grid Values

Grid Info - This option displays information about the grid file, including creation date,
grid size and location in XY units, and map projection details.

A Grid Information Window

Contour Range
Min - This option sets the minimum contour value.
Max - This option sets the maximum contour value
Interval - This option sets the interval between different contours and colorfils. Plain
lines can handle an unlimited number of contour intervals. For color filled contours, a
"Normal" colorbar can use a maximum of 46 contour intervals and an "Enhanced"
colorbars can use a maximum of 512 contour intervals.
Units - This option displays the units of the contour lines.

Colors
This button changes the colorbar for the grid contours. Petra has two ways of
displaying color on computer-created grids: normal and enhanced.
Normal colorbars have greater flexibility in changing colors and irregularly spaced
intervals, but tends to be a little more work to set up and has a more limited total
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number of intervals.
Enhanced colorbars are generally simpler than the normal method and allows a
greater number of color intervals (512), but can only handle regularly spaced intervals
and is less flexible in interpolating between colors.

The two types of colorbars: normal (Left) and enhanced (Right)

Show Thumbnail - This option displays a small picture of the grid. This can be useful
for checking the contour interval and colorbar settings.
5.14.2.1.1 Color Interval Definition (Normal)

The normal colorbar is Petra’s default way of selecting the colors for a grid. This
system gives greater flexibility in changing colors and irregularly spaced intervals, but
tends to be a little more work to set up and has a more limited total number of
intervals.

The Color Interval Definition Window
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Edit Value
Each selection of the interval list box displays the interval "z" value in the Edit Value
entry field. Use the Apply button to modify the z value. Intervals need not be a
constant increment, however, z values must increase from top to bottom.

Set Interval
Min - This option sets the maximum contour. Grid values below this minimum won't
appear on the contours.
Max - This option sets the maximum contour. Grid values above this maximum won't
appear on the contours.
Interval - This option sets the desired contour interval.
Apply - This button creates intervals from the minimum to maximum.

Number of Intervals
This option displays and modifies the total number of intervals on the interval list. The
normal colorbar can handle a total of 46 different intervals, starting with the minimum
and counting up towards the maximum. Decreasing intervals will drop the highest
intervals first. Similarly, adding additional intervals will add add intervals above the
maximum.

Color Scheme
Load... - This button loads a previously saved set of intervals and colors.
Save... - This button saves the current set of intervals and colorbar to a *.ZPL file.
Default Colors - This button resets the color palette and intervals to the grid defaults.

Palette
Changing An Interval Color - To change the color for a particular interval, select
the interval by clicking the left mouse button on the list box in the center of the screen.
The interval color will be highlighted in the color palette. Click the left mouse button on
any color palette color cell to change the interval's color.
Set Colors... - This button changes the the selected palette's color. Alternatively,
doubleclick the palette color
The system color selection dialog is activated for changing the cell's color. The
system color dialog can also be used to define several additional customized colors.
Use
Interp - This button will interpolate the entire palette starting with the upper left corner
and ending with the lower right corner. If you want to interpolate between two specific
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cells, click the starting cell then hold down the CONTROL KEY and click the ending
cell. All intermediate cells will be interpolated.
Load... - This button loads a previously saved customized color palette.
Save... - This button saves the current color palette to a *.ZPL file.
- The "Fill with Pallete" button fills the color scheme with the current palette from
top to bottom starting with the upper left corner palette cell. If the number of color
intervals is less than the number of palette colors, then only the beginning palette
colors will be used. See the "Stretch Fill" option to fill the color scheme with all palette
colors.
- The "Flip Colors" button inverts the colors in the internal list box from top to
bottom.
- The "Stretch Fill With Palette" button will fill the color scheme starting with the
upper left-most palette color. The entire palette will be "stretched" over the color
interval range.
Default - This option selects one of Petra "default" colorbars. By default, these ZPL
files are stored in C:\geoplus1\Parms.

Selecting a "Default" colorbar

Auto Incr - This option advances the interval list box item following color selection for a
particular interval. Use this feature to quickly set the colors for all items in the interval
list box. Simply select the first numeric interval and begin selecting colors from the
palette. Each click of the palette sets the color for the current interval and advances
to the next interval. Continue until all interval colors are selected.

Changing Colors on a Normal Colorbar Walkthrough
Changing the palette on the right side of the screen directly changes the colors used
on the colorbar. To change a color on the palette, double click inside any color box to
bring up a color tool. This screen has a set of basic colors, though you can use any
color by selecting the color box on the right, or enter values using Hue/Saturation/
Lightness or Red/Blue/Green.
© 2014

Map Module

937

Changing a palette color (Left), selecting red on the color screen (Right)

The palette color changed to red

Filling an entire palette by selecting individual colors is slow and creates blocky color
transitions. Interpolating between colors in different palette cells is easier and leads to
smoother transitions. Interpolation proceeds from upper left to lower right. To
interpolate between two specific cells, click the starting cell then hold down the CTRL
key and click the ending cell. All intermediate cells will be interpolated. In the example
below, the interpolation is from the white cell in the upper left corner to the red cell
created in the example above. Repeat the process with different cells to create a
smooth transition between several different colors.

Interpolating between colors with the CTRL key. Before (Left) and after (Right)

For a single color colorbar, set the upper left and lower right colors to the starting and
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ending colors. Next, select the “Interp..”. button to interpolate the entire palette
starting with the upper left corner and ending with the lower right corner. In the
example below, the upper left color is white, and the lower right color is pink. Using
the “Interp…” button interpolates between white and pink, as shown in the example
below.

Using the "Interp..." button. Before (Left) and after (Right)

5.14.2.1.2 Color Interval Definition (Enhanced)

The enhanced colorbar is a slightly different way of selecting the colors for a grid.
This system is generally simpler than the normal method and allows a greater number
of color intervals (512), but can only handle regularly spaced intervals and is less
flexible in interpolating between colors.
After opening the enhanced Color Scale window, the first thing to do is set the interval
with the minimum Z value, maximum Z value, and the interval. Select “Apply Z” to set
the scale.
To change the colors on the enhanced colorbar, select a color from the palette and
then select a specific interval. This “paints” the interval in the selected color.
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The Enhanced Colors colorbar

Z-Min - This option sets the minimum value for the colorbar.
Z-Max - This option sets the minimum value for the colorbar.
Z-Int - This option sets the colorbar interval value for the colorbar.
Apply Z - This option applies any changes made to the Z-Min, Z-Max, or Z-Int entries
to the colorbar.
Z Stats - This option opens an additional "Data Statistics" window that displays a
histogram of the selected grid's values, along with the min, max, mean, standard
deviation, mode, and sum of all grid values. Note that the histogram can either be a
normal "bin" histogram, or a cumulative histogram.
This tool can also be used to automatically calculate the minimum and maximum for
the colorbar.

A Data Statistics window with a normal (Left) and cumulative (Right) histogram

Custom - This option changes the currently selected color interval. Selecting this
option opens the Color window. Here, select a new color for the desired interval.
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The Color window changes the selected color interval to a custom color.

Clear All - This option sets the entire color bar to black.
Interpolate - This option interpolates color between the first and last color on the
colorbar

The colorbar before (Left) and after (right) interpolation

Reverse - This option reverses the colors on the colorbar.
Shift Left - This option shifts the colors on the colorbar towards the color on the far
left interval. As an example, shifting towards a red color will every interval on the
colorbar redder.
Shift Right - This option shifts the colors on the colorbar towards the color on the far
right interval. As an example, shifting towards a red color will every interval on the
colorbar redder.
Rotate Left - This option scrolls the colors on the colorbar by one interval to the left.
The far left color will wrap around to the far right.
Rotate Right - This option scrolls the colors on the color bar by one interval to the
right. The far right color will wrap around to the far left.
Original - This option resets the colorbar.
Undo Last - This option undoes the last change made to the colorbar.
Save - This option saves the enhanced colorbar to an external *.COL file.
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Load - This option loads an enhanced colorbar from an external *.COL file.
Apply Preset - This option uses one of several preset enhanced colorbars.
- These buttons lighten and daken the entire colorbar.
5.14.2.2 Contour a Grid - Options Tab

The Options Tab sets how Petra displays grid contour lines and color fills.

The Contour a Grid window's Grid Tab

Color Filled Contours - This option uses the colorbar set on the Grid Tab color-fill the
gridded surface.
Draw Color Scale Bar - This option draws a small color scale showing the color
associated with each contour interval. The adjacent dropdown selects the location of
the scale bar, which can be either on the upper left or upper right side of the map
Draw Contour Lines - This option draws contour lines on the grid. These lines will
start at the "Min" contour range on the Grid Tab and proceed up to the "Max" contour
range using the contour "Interval" value.
Label Contours - This option control whether any contours are labeled. Refer to the
style tab for labeling options.
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Draw Lines In Default Color - By default, Petra draws contours using the colors from
the colorbar. This option instead draws all contour lines using the default color (which
is usually black). To change the default color, select Display>Colors on the menu bar
at the top of the Map Module.
Smooth Contour Lines - This option smooths contour lines. For jagged or triangular
grids, this may force grids to not "honor the data."
Draw Lines Using Color Intervals - Normally, contour lines are drawn at regular
intervals, using the minimum, maximum and interval. Contour interval is independent of
the color range and intervals specified. This option draws contour lines only at the
intervals specified by the color range option. This option can be used to draw contour
lines at irregular contour intervals. When checked, the normal contour min, max, and
interval are ignored and the color bar intervals are used instead.
Use Transparent Background Color Fill - This option suppresses area filling of
contours which match the map's background color, which is normally white. Use this
option in conjunction with the overlay Draw Filled Items First option to plot color filled
contours on top of filled lease outlines but not cover up the leases when the grid color
is the same as the background (white).
For Isopachs, Use WHITE For Values Less Than Zero - This option automatically
changes the color for values less than zero to be white so that isopachs are not colorcontoured below zero.
Automatically Save/Load Contouring Template With Grid - This option automatically
saves and restores the contouring parameters with the grid file. Whenever the OK
button is clicked, a file is saved to the grids folder using the grid file name and an
extension of .GDT. Whenever a grid is selected from the grid file list, the template is
loaded to restore the settings last used to contour the grid.
5.14.2.3 Contour a Grid - Style Tab

The Style Tab changes how Petra draws and labels grid contour lines.
Petra can draw lines either as a "normal" or "bold." Bold lines can be useful for
decreasing visual clutter or for showing a larger interval - bolding every 4th line on 25'
contour interval quickly shows a gradation of 100', for example.
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The Contour a Grid window's Style Tab

Normal Line Width - This option sets the line width for drawing normal contour lines.
Normal Line Style - This option sets the style for drawing normal contour lines.
Number of Decimals in Label - This option changes the number of decimals displayed
on the label.
Bold Line Width - This option sets the line width for drawing bold contour lines.
Bold Line Style - This option sets the style for drawing bold contour lines.
Bold Every Nth Contour Where N= - This sets the interval for drawing bold contour
lines.
Label Every Nth Contour Where N= - This sets the interval for labeling contour lines.
Label Size (XY Map Units) - This option sets the height of the contour labels in XY
map units, i.e., feet or meters on the earth's surface. Set the size to zero for the
default of 0.1 inches.
Label Distance (XY Map Units) - This option sets the distance between contour
labels in map XY units, i.e., feet or meters. Set the distance to zero for default value.
5.14.2.4 Contour a Grid - Advanced Tab

This screen offers options for more advanced contouring. These options are
important if you need to edit contours and regrid using the map overlay contours.

© 2014

944

PETRA Help

The Contour a Grid window's Advanced Tab

Capture Contour For Import to Map Overlay
This option provides a mechanism to save the contour lines as they are drawn. Once
these are in the the overlay, the contours can be modified and used as input to create
another grid file.
Do Not Capture Contours - This option draws contour lines and colorfills normally,
and does not save anything to the overlay file. This option is on by default.
Capture Contours Directly Into Layer - This option saves the gridded contour lines to
the overlay layer selected in the "Layer to Capture Into" dropdown box. Captured
lines will be saved as a "Contour Line" line class, which preserves the contour line's
value.
Capture Contour Fill to Overlay Layer - This option saves a set of closed polygons
with the appropriate color fill to the overlay layer selected in the "Layer to Capture
Into" dropdown box.
Capture Contours Into Overlay *.SEG File - This option saves the contours to the
selected *SEG file. Use the "Browse" button to select the desired file.

Grid Gradient Arrows
This section plots arrows at grid nodes indicating the direction and magnitude of the
slope.
Draw Gradient Arrows - This option draws arrows at grid nodes.
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Draw Every Nth Grid Cell - This option sets whether and how Petra skips grid nodes
for arrows. As an example, N = 1 plots arrows at every grid cell, while N=3 plots
arrows at every third node.
Grid Arrow Scale Factor - This option sets the length of the gradient arrows. A scale
factor" less than 1.0 shortens arrows, while a scale factor greater than 1.0 lengthens
arrows.
Reverse Dip Direction - This option draws the arrows to point updip rather than
downdip.

Grid Node Values
Post Grid Nodes - This section causes the grid node values to be posted at each grid
node location. Set the "Label Size" to the appropriate xy map units or leave the default
of 0.0 for labels of 0.1 inch. When you label grid nodes, you can edit them by doubleclicking on a node value while holding down the CTRL and ALT keys. Changes here
are made directly to the grid file and there is no undo or backup.

Miscellaneous
Quick Grid Cell Fill - This option will color fill each grid cell with a single color. Color
contour bands are not drawn.
Draw Grid Cell Outlines - This option causes grid lines to be drawn along each grid
row and column. This can be useful for demonstrating the resolution of the grid
relative to the actual data points.

5.14.2.5 Contour a Grid - File Tab

The File Tab saves grid contour templates.
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The Contour a Grid window's File Tab

Load Template... - This button loads a previously saved customized color palette.
Save Template... - This button saves the current color palette to a *.ZPL file.
Grid File Directory - By default, Petra looks for grids in the project GRIDS folder.
This dialog sets an individual user's grid file directory.
5.14.3 Adding Interpretation to Grids

A great way to have both the benefits of a human interpretation with the speed and
flexibility of using a computer is to adopt a hybrid approach of shaping computer
grids with interpreter-drawn contour lines and points.
There are several ways to modify and alter a computer-generated grid into a more
geologically-sound interpretation: hand drawn overlay lines, adding control points,
and individually tweaking grid points. Overlay lines come in several different “classes”
– normal, contour, unconformity, and fault. While normal lines are just for displaying
visual information (like section outlines or roads), contour, unconformity, and fault
lines can also be used to influence the gridding process.Contour lines can be edited
via the map overlay feature. Contour lines can be "captured" into one of the overlay
layers and manipulated as any other overlay line.
Related Topics
Adding Hand Drawn Overlay Lines and Faults
Capturing Contour Lines to the Overlay
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5.14.3.1 Adding Overlay Contour Lines

Use Overlay Contour Lines and Include Faults options on the Create Contour Grid
tool's Data Tab.

Contour Lines
Hand-drawn contour lines are a great way to add geologic interpretation to a
computer-generated grid. Since each line is assigned a value, Petra’s gridding tries to
honor those values when creating a grid. Since Petra uses all the displayed contours
when it grids, it’s a good idea to store each related set of contours in its own overlay
layer.

Zero Contour Lines
Though the “Adjust Zero Contour for Isopach Surface” option helps to reduce grid
artifacts around the zero line, hand drawn contours are probably the best way to
create a smooth, realistic surface. To continue to use the computer generated zero
contour line, it’s also possible to use a very small contour value (around 0.1).
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Hand drawn control lines on an isopach (Left), the same isopach with a zero contour line (Right)

Faults
In the Map Module, faults are treated as a special class of overlay line. Just like any
other overlay line, faults lines have width, color, and an assigned layer. Unlike other
overlay lines, however, faults have a special tab labeled “Faults.” This tab controls
how fault symbols are drawn, as well as how Petra handles the fault during the
creating a computer-generated grid. Since faults are irregular surfaces, Petra uses
triangulation when creating a faulted grid.

Setting an overlay line as a fault (Left), setting the fault strength and fault symbol (Right)

High-angle, near-vertical faults are drawn as a line, while low-angle faults with aerially
missing section can be drawn as two separate faults that form a polygon. Since
computer-gridding can create contours inside these fault polygons (where the surface
should be missing), it’s a good idea to blank these polygons out with an opaque
polygon.

Fault Strength
On a hand-drawn contour map, a fault breaks contour lines. Put another way, a fault
breaks a map into two different parts. Data on one side of the fault is only relevant to
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that fault block, and has less (if any) relevance to the map on the other side of the
fault.
Similarly, a drawn fault tells Petra to interpolate the gridded data up to the fault and
ignore data across the fault. The “opacity” of the fault determines the strength of this
break. A low opacity fault will still be largely connected, while a completely opaque
fault will ignore data across the fault entirely. Practically, this means that the opacity
of the fault influences both the fault’s throw and the amount of fault drag. High opacity
faults have greater throw and more independent fault blocks, while transparent faults
have lower throw and greater amount of fault drag. Completely opaque faults cause
grid nodes to be nulled along the fault, which can create a saw-tooth effect of colorfilled grid along the fault.

Fault strength's effect on throw and fault drag

5.14.3.2 Capturing contour lines to the overlay

This method captures contour lines from a grid to an overlay layer. Once these lines
are overlay contour lines, they are editable just like any other line. This technique can
be useful for letting Petra build a quick first pass at contour lines, and then using an
interpreter’s skill to modify them into a more reasonable geological interpretation.
Depending on the complexity of your contours, this can be very labor- and
time-intensive. For most contour maps, it’s almost certainly faster and better
to hand-draw overlay contour lines from scratch.
Under the Advanced Tab, select “Capture Contours Directly Into Layer”, and then
select the Overlay layer you want to contain these contours. The “R” button allows
you to rename the layer. In the example below, the overlay layer has been renamed
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to “GRID CAPTURE.”

Capturing contours to the overlay
Use the "Contours>Display Contours" menu and go to the "Advanced" tab. Choose the
option to capture the contours directly into an overlay layer and select the appropriate
layer. As the contours are drawn they will be stored into the overlay. Next, turn off the
contours from the Contours menu. You should see the contours that are in the
overlay. These contours can be edited as any other overlay item.

Selecting the contour to be edited
Select the contour line to be edited using the ARROW icon located at the top of the
overlay tool bar. The overlay tool bar is located along the right side of the mapping
module window. It is displayed using the "Overlay>Show Tool Bar" map menu. After
clicking the ARROW icon, click the left mouse button once on a contour. Selection is
indicated by small squares drawn at each "control point". Double clicking the contour
line will show the attribute screen as will clicking the overlay " attributes" icon
containing a small letter "i".

Changing the contour line attributes
After selecting a contour line, double click any point on the line or click the "attributes"
icon located in the upper right corner of the overlay tool bar.

Adjusting individual contour line control points
The location of each contour line control point can be repositioned by clicking and
dragging the control point using the left mouse button. Position any of the control
points, then click the right mouse button to redraw the screen show the modified
contour line.

Adjusting sections of a contour line
Entire sections of a selected contour line can be adjusted, stretched or skewed using
a rubber band splining technique in combination with the CTRL KEY. The process
involves holding down the CTRL KEY and picking two anchor points with the left
mouse button. The anchor points are identified by small Xs and define the section to
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be adjusted. The points between the two anchors can be dragged into position using
the left mouse while holding down the CTRL KEY. Releasing the CTRL KEY can still
move individual points. The section adjustment is maximum at the point be dragged
and minimum at the two anchor points. New anchor points can be selected for the
currently selected line by holding down the ALT KEY and clicking with the left button.
Again, hold down the CTRL KEY to modify or drag the section between the anchor
points. When done, either select another contour line or click the right mouse button to
redraw the screen.

Linking short segments of contours together
Occasionally, contour lines are generated that are short in length and do not connect
with other contours. A selected contour line can be connected to another contour of
the same Z value if one of its end control points is close enough to another line. You
can force two contour segments to be close by dragging one of the end points very
near the end of the other line. With one segment selected, click the "connect" icon
located on the overlay tool bar which looks like a black line with a red section in the
middle. After joining, the control points of both segments will be highlighted.

Breaking a contour into two separate segments
A single contour line can be broken into two separate segments. When selecting the
line, click on the exact spot at which the line should be broken. Then click the "break
line" icon on the overlay tool bar. One of the segments will remain highlighted and the
other will be off.

Deleting a contour line
Select a contour line and click the "delete" icon (trash can) located on the overlay tool
bar.
5.14.4 Grid Operations
In addition to simple display, grids are also useful in a variety of calculations.
Isopach and TST
Grid to Grid
Grid Equation Transform
Grid Calc Transform
Curvature Grid Calculations
Compute Statistics Around Wells
Sample Grid to Wells
Sample Grid to Seismic
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Sample Grid to Control Points
Resample Grids to Match
Shaded Relief Grid
Convert Triangular to Rectangular Grid
5.14.4.1 Isopach and TST Calculations

The Wells drilled through steeply dipping beds can generate anomalously thick results.
This tool attempts to calculate the true stratigraphic thickness of a lithologic package
bounded by two calculated grids.
To open the Isopach from Grids tool, select Contours>Grids>Isopach and TST from
the menu bar at the top of the Map Module.

Data Tab

The Isopach From Grids' Data Tab

Upper Surface Grid - This dropdown sets the upper surface grid. Generally, this will
be a grid of the top of the formation.
Lower Surface Grid - This dropdown sets the upper surface grid. Generally, this will
be a grid of the top of the formation.
Output Isopach Grid - This entry sets the name of the newly calculated isopach grid.
Either enter a new name, or select an existing grid to overwrite.
Isopach Grid Title - This option sets the title of the computed isopach grid.
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TST Tab

The Isopach From Grids' Data Tab

Apply TST Correction - This option applies the true stratigraphic thickness correction
TST = TVD (cos θ), where θ is the true formation dip.
Grids are Seismic Times - By default, Petra assumes that the upper and lower grids
are formation tops in TVD. This option adds an additional step to multipy the values in
the grid by a specified velocity.
Calculated Dip From - This dropdown sets how the TST calculation finds formation
dip. Formation dip can be calculated from the top grid, the bottom grid, or an average
of the two.

Dir Tab
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The Isopach From Grids' Dir Tab

5.14.4.2 Grid To Grid Calculations

The Grid-To-Grid Operations tool is a powerful general purpose tool to quickly
perform over 30 different grid calculations. This tool is useful for simple mathematical
operations, merging two different grids into a single grid, clipping specific grid values,
or a variety of other calculations. The Grid-To-Grid tool also contains many of the
equations used elsewhere, including trend-residual analysis and curvature analysis.
Note: All grids used in this process must have the same number of rows and
columns, grid dimensions and extents.
To open the Grid-To-Grid Operations tool, select Contours>Grids>Grid-to-Grid
Operations… from the menu bar at the top of the Map Module.
Note that the Grid Equation Transform is a slightly simpler tool that can be used for
more basic single-grid operations.

Data Tab
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The Grid-To-Grid Calculation Data Tab

Grid Folder
Output Grid File - This entry sets the name of the newly calculated isopach grid.
Either enter a new name, or select an existing grid to overwrite.
Grid Title -This option sets the title of the output grid file.
Grid Operation - This dropdown selects the desired grid operations. Note that "A"
and "B" refer to input grids. "C" refers to the output grid.

Basic Mathematical Operations
C=
C=
C=
C=
C=
C=

A+B
A–B
A*B
A/B
A + Constant
A * Constant

Merging Two Grids
C = Minimum of A or B
C = Maximum of A or B
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C=
C=
C=
C=

Substitute B for A when A is NULL
Merge Deepest of A and B
Merge Shallowest of A and B
Union of A and B

Clipping Specific Grid Values
C=
C=
C=
C=
C=
C=

Maximum of A or Constant (clip above constant)
Minimum of A or Constant (clip above constant)
NULL if A is less than Constant
NULL if A is equal to Constant
NULL if A is greater than Constant
Constant if A is NULL

Extended Mathematical Operations
C=
C=
C=
C=
C=

SQRT(A)
Log10(A)
NaturalLog(A)
AntiLog10(A)
AntiNaturalLog(A)

Curvature Analysis
C=
C=
C=
C=

Dip Azimuth of A in degrees
Dip Magnitude of A in degrees times Constant
Slope In X direction times Constant
Slope in Y direction times Constant

Smoothing
C = Smooth (A) Grid (Constant = number of filter points)

Time-Depth Conversion
Time-Depth conversion operations use an additional time-depth file, selected on the
"Auxiliary File" entry on the bottom of the Data Tab. This file can be either columnar
or comma-delimited. The Grid-To-Grid operations tab also adds a "Time-Depth Tab
to handle further formatting of the time-depth pairs.
C = Convert Time Grid (A) to Depth (Uses Auxiliary File)
C = Convert Depth Grid (A) to Time (Uses Auxiliary File)

Isopachs
C = Truncated Isopach using Top (A), Base (B) and Fluid Contact (Constant)
C = Truncated Isopach using Top (A), Isopach (B) and Fluid Contact (Constant)
C = Sum of Isopach Grids A and B
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Trend-Residual Analysis
C = Trend Surface of A (Constant = Trend Order)
C = Trend Residual Surface of A (Constant = Trend Order)
C = Truncated Isopach using Top (A), Base (B), and 2 Fluid Contacts (Constant 1
and 2)
C = Truncated Isopach using Top (A), Isopach (B), and 2 Fluid Contacts (Constant 1
and 2)

Input Grids - Assign the grid files to the "A" and "B" variables in the grid operation.
Use the "Grid Info" buttons to view grid details.
Constant - If the operation calls for a constant value, enter the value here.
List Grids By - This option changes how grids are sorted on the inport and export
dropdown menus.
Compare AB - This option displays a comparison of grid information between the A
and B grids.
Auxiliary File - This entry establishes a ASCII or CSV file used for time-depth
conversions.

Time-Depth Tab
The Time-Depth Tab only appears when a Time-Depth Conversion operation is
selected on the Data Tab
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The Grid-To-Grid Calculation Time-Depth Tab

Auxiliary File Contains - This option sets the general type of time-depth pairs. Select
whether the pairs are "Depth, Time" or "Time, Depth"

Seismic Times Are
Grid File - This option sets whether the grid uses 1-way or 2-way travel time.
Aux File -This option sets whether the auxiliary file uses 1-way or 2-way travel time.

Seismic Time Units Are
Grid File - This option sets whether the grid uses seconds or milliseconds.
Aux File -This option sets whether the auxiliary file uses uses seconds or
milliseconds.

Misc Tab
The Misc Tab contains one option for setting the zero azimuth. This option is only
used for some curvature analysis calculations, and references all calculated azimuths
to the selected direction.
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The Grid-To-Grid Calculation Time-Depth Tab

5.14.4.3 Grid Equation Transform

While the Grid-To-Grid Operations tool can handle most simple equations, the Grid
Data Equation Transform is built to handle larger custom equations.
To open this tool, select Contours>Grids>Grid Equation Transform.

Equation Tab
The Equation Tab sets the actual equation using variables and mathematical
operators
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The Grid Data Equation Transform Equation Tab

The variable on the left side of the equal sign is the result grid, while variables to the
right are the input grids and constants. Variables can either be very specific (such as
“AVG_POROSITY” or “ISOPACH”) or general (such as “A” or “B”).
Equations entered here obey standard order of operations: Parenthesis, Exponents/
Roots, Multiplication, Division, Addition, and Subtraction.

Basic Mathematical Operators:
+
*
/
**

Addition
Subtraction
Multiplication
Division
Exponent

Mathematical and Trigonometric Functions:
ABS(x)
ACOS(x)
ASIN(x)
ATAN(x)
COS(x)
COSH(x)
EXP(x)
INT(x)
LOG(x),LN(x)
LOG10(x)
MAX(x,y)
MIN(x,y)
ROUND(x)
SIN(x)
SQRT(x)
SQR(x)
SINH(x)

Absolute value of x
Arccosine of x (in radians)
Arcsine of x (in radians)
Arctangent of x ( in radians)
Cosine of x in radians
Hyperbolic cosine of x (radians)
e to power of x
Truncated value of x
Natural Log of x
Log based 10 of x
Maximum of x and y
Minimum of x and y
Rounded value of x
Sine of x in radians
Square root of x
x squared
Hyperbolic sine of x (radians)
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Tangent of x in radians
Hyperbolic tangent of x (radians)

Options Tab
The Options Tab has a couple of options that mostly pertain to calculations involving
isopachs.

The Grid Data Equation Transform Options Tab

Substitute Zero For Nulls - This option causes null-valued grid values to be set to zero
prior to executing the equation. A null value anywhere inside the equation generates a
null result, which can create holes in a summed isopach.
Set Negatives to Zero - This option causes negative grid values to be set to zero prior
to executing the equation. Summing negative values actually reduces the total
footage, so it may be useful to substitute zero values for negative numbers.

Assign Z Data Equation Variables
After setting the variables, the next step is to assign grids and constants to the
variables.
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Setting variables to grids and constant. Before (Left) and after (Right)

Output Grid
Grid - This entry sets the name of the newly calculated isopach grid. By default,
Petra will create a grid using the variable name outlined in the equation, but users can
enter a new name or select an existing grid to overwrite.
Title - This option sets the title of the new grid.

Equation Variable Assignments
This section sets which variables in the equation are which grids and constants. Select
the equation variable on the Equation Variable Assignments list and select the correct
grid or constant. Select the "Assign" button to finalize each variable.
5.14.4.4 Grid Calc Transform

The Grid Calc Transform function applies user-defined programs to perform grid-togrid operations. The grid calc models are text files that contain the programming
logic to perform complicated, multi-line equation and conditional operations on grids.
The model is executed one time through for each grid node. One or more grids can
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be produced as output from a grid calc model. The model list is pre loaded with all
model files found in the GRIDS sub directory under the project directory. All models
must end with a .TXT extension. Select a model file from the drop-down model list
then click the "Compile Model" button.
To open the Grid Calc Transform tool, select Contours>Grids>Grid Calc Transform
from the menu bar at the top of the Map Module.

Compiling The Model
Grid calc models are stored in text form and must be "compiled" into an executable
form prior to execution. Compiling the model loads the the input and output variables
into the assignment list boxes.

Assigning Model Variables
MAXIMUM VARIABLE NAME LENGTH IS 40 CHARACTERS

Input Variables
Input variables may be grids, constant values, or NULL values. Each input variable
should be assigned to the appropriate identifier.
To assign a model variable, click once on the variable name listed in the "Input
Variable Assignments" list. Then choose a "Grid File", "Constant" value, or ""Null"
item. After making the choice, click on the Apply button to set the assignment. The
new assignment will appear in the input variable list.
Note: All input grids must have matching data limits, rows and columns, and grid
sizes.

Output Grids
The result of the model is one or more grid files. These grids can be selectively
assigned to one of the existing grid files or can be assigned a new grid name.
Output variables are assigned using the same technique described in the input
variable section. Output grids should have a title specified.
Temporary output grids computed in the model but not stored back to the disk can
be specified as "UNASSIGNED".
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Model Execution
Once the model is compiled and all input and output variables are assigned, press
the "Execute Model" button to start the user model transformation process.

Grid Calc Model Programming Syntax
Grid calc models are text files that contain the programming logic to perform
complicated, multi-line equation and conditional operations on grids. The model is
executed one time through for each grid node value including Null nodes.
Users should be familiar with programming languages such as FORTRAN before
attempting to create or modify a user model file.

Statements
Each statement in the model consists of variables, operators, and key words. Each
statement in the model is terminated with a semicolon (;). Statements may be
continued over more then one line. An operator or delimiter, such as, a space or
parenthesis separates constants, variables, and numbers. Statements which control
the flow of the program logic contain key words "GOTO", "IF...THEN...ELSE", or
"BEGIN...END". Branching is done using statement LABELS placed on a line prior to
the point of continued processing. Each label consists of a character string
terminated by a colon (:). Examples of labels are LABEL1:, L999: and DONE:.

Model Comments
An exclamation mark (!) defines the beginning of a comment. Entire lines may be
commented by placing an ! in column one. In-line comments may be placed on
executable statements by placing the ! and comment following the semicolon (;) line
terminator. Blank lines in the model are ignored.
Comment examples:
!

this is a commented line.

A= B + C;

!

this is an in-line comment.

Symbols and Keywords
(;)

End of statement terminator

(!)

Comment indicator (start comment)
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Label terminator

space

Delimiter

IF
THEN
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Test control word
statement

Continuation of test

THEN BEGIN

Starts "TRUE" condition of test

ELSE BEGIN

Starts "FALSE" condition of test

GOTO
CONSTANT
GRID
IN
OUT
DO
END
ENDDO
ENDMOD

Branch to a label
Declare constant
Declare grid variable
Declare GRID as input variable
Declare GRID as output variable
Do loop
End THEN BEGIN or ELSE BEGIN section
End Do Loop
Terminates the model

Functions
Function

Keyword

------------

-------------

add

+

A+B

subtract

-

A-B

multiply

*

A*B

divide

/

A/B

exponential
assign
compare equal
(A.EQ.B) THEN...
logical AND
(C=D))...
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**

A**2 (A squared)
=

A = 1.0

= or .EQ.
.AND.

IF(A=B) THEN...

or

IF

IF((A=B).AND.
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logical OR
(C=D))...

.OR.

IF((A=B).OR.

greater than

> or .GT.

less than

< or .LT.

IF(A<B)...

>= or .GE.

IF(A.GE.B)...

greater or equal
less or equal
E to power of X
log (natural)
log (base 10)
absolute value

<= or .LE.

LN(x)
LOG10(x)
ABS(x)
SQRT(x)

negative (-x)

NEG(x)
TRUNC(x)

sign of number times 1

SIGN(x)

round to 2 dec places

ROUND(x)

maximum of x and y
minimum of x and y
remainder of x / y

IF(A.LE.B)...

EXP(x)

square root

truncate to integer

IF(A.GT.B)...

IF(SIGN(x)=-1)...

MAX(x,y)
MIN(x,y)
MOD(x,y)

Parenthesis
Binary operators are defined as an expression enclosed within parentheses, such as,
(x+y) or (x*y). Statements require parentheses only when more than one binary
operation is used or when one wishes to force the evaluation precedence. The
normal operator precedence from lowest to highest is:

+ and * and /
**
unary - (minus sign)

The expression,
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(A+((B*(C**D))/E))-F

and would be evaluated in the following steps. Intermediate expressions are shown
in braces.
K = C**D

[A+B*K/E-F]

L = B*K

[A+L/E-F]

M = L/E

[A+M-F]

N = A+M

[N-F]

O = N-F
Parenthesis force the sub-expression enclosed to be evaluated first, as illustrated
below.
(A+B)*C**D/(E-F)
K = A+B

[K*C**D/(E-F)]

L = C**D

[K*L/(E-F)]

M = K*L

[M/(E-F)]

N = E-F

[M/N]

O = M/N

Declaration Section
The declaration section is the first part of a model program in which the input and
output logs and constants are defined. Each declare statement consists of a "type"
keyword, a variable name, and a "use" keyword. It is not necessary to declare
temporary variables, Temporary variables are defined for the first time as the result
of an assignment statement.
Examples:
GRID

UPPER

GRID

LOWER

IN;

GRID

ISOPACH

OUT;

CONSTANT
CONSTANT NULL;
NULL grid
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IN;

2.5;

! value is optional
! assumed to represent
value
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Executable Statement
An executable statement is any statement in which an equation type calculation is
performed or an assignment is made. The general form is:
ASSIGNMENT_VARIABLE = executable_statement;

Examples

x = a * b;
x = (a*(b+c))/(x-y);

Note that each line is terminated with a semi-colon (;) and the equal sign (=) is
required. Variables appearing on the right side of the equation must either be
declared as constants or grids or be temporary variables defined as the result of an
earlier assignment statement.

GOTO and LABEL Statement
The "GOTO" keyword and following label is use to branch to another part of the
program.
Example
IF ( x > 0.0 ) THEN GOTO DIVIDE;
y = 0.0;
GOTO MORE;
DIVIDE:
y = y / x;
MORE:
statement;
statement;
etc.

IF-THEN STATEMENT
The IF-THEN statement conditionally executes a single assignment statement,
GOTO, or BEGIN-END group based on the results of a logical comparison.
Example
IF( SW > 0.75 ) THEN

BEGIN;
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SW3 = (1-SW)**3;
SW = 1-(16/3)*SW3*(5-128*SW3);
END;

IF-THEN-ELSE STATEMENT
The IF-THEN-ELSE compound statement provides conditional processing in a clear
and efficient manner without the use of a GOTO.

Examples:
IF ( logical expression ) THEN BEGIN;
statement;
statement;
etc.
END;
ELSE BEGIN;
statement;
statement;
etc.
END;

DO-LOOP STATEMENT
The DO loop statement is used to repeat a section of the model a set number of
times.
The general format of the DO loop is:
DO counter = first TO last;
statement;
statement;
etc.
ENDDO;

The following example sums values from 1 to 10. "A" is summed when K is
even and "B" is summed when K is odd.
SUM = 0.0;
N = 10;
DO K = 1 TO N;
IF( MOD(K,2)=0) THEN BEGIN;
SUM = SUM + A;
END;
ELSE BEGIN;
SUM = SUM + B;
END;
ENDDO;

EXAMPLE GRID CALC MODEL
! ISOPACH.TXT - GRID CALC MODEL TRANSFORM
!
! COMPUTES ISOPACH BETWEEN TWO STRUCTURE GRIDS
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!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! INPUT GRIDS USED IN THE MODEL
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
GRID
UPPER
IN;
! UPPER STRUCTURE GRID
GRID
LOWER
IN;
! LOWER STRUCTURE GRID
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! OUTPUT GRIDS USED IN THE MODEL
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
GRID
ISO
OUT;
! OUTPUT ISOPACH GRID
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! CONSTANTS USED IN THE MODEL
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
CONST
NULL;
! USED TO TEST FOR NULL GRID VALUES
CONST
ISOMIN
0.0;
! USED TO CLIP ISOPACH TO ZERO THICKNESS
IF ( (UPPER .NE. NULL) .AND. (LOWER .NE. NULL) ) THEN BEGIN;
ISO = UPPER - LOWER;
ISO = MAX(ISO,ISOMIN);
! CLIP AT ZERO THICKNESS
END;
ELSE BEGIN;
ISO = NULL;
END;

DONE:
ENDMOD;

5.14.4.5 Curvature Grid Calculations

Petra can perform a wide variety of curvature analysis techniques on existing
rectangular grids. Curvature analysis can be useful for spotting faults, regional jointing
and lineaments, as well as highlighting differential compaction.
Importantly, the accuracy of curvature analysis depends on the accuracy of its input
map. In other words, the veracity of curvature analysis relies on good grids with tight
control. The “Minimum Curvature” surface style will tend to minimize curvature, while
the “Disconnected Features” surface style will tend to amplify curvature. Grids in
areas of sparse well data will be smooth and will have low curvature as a result. Data
busts and bulls eyes caused by a bad datum or missing survey data, on the other
hand, will create anomalously high curvature.
To open the Compute Grid Curvature tool, select the Contours>Grids>Curvature Grid
Calculations from the menu bar in the Map Module.

Grids Tab
The Grids Tab sets the input grid used in the calculation and the name of the output
curvature grid.
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The Compute Grid Curvature Grids Tab

Input Grid - This dropdown selects the grid used in the curvature calculation. To
change the directory, select the Grid Folder at the bottom of the tab.
Output Grid - This entry sets the name of the output grid that will store the calculated
curvature grid. Select an existing grid, or enter a new name.

Curvature Tab
The Curvature Tab selects curvature calculation to perform.

© 2014

972

PETRA Help

The Compute Grid Curvature Grids Tab

Mean Curvature - This operation calculates the average curvature for all azimuth
directions. It’s used mostly for deriving other curvature attributes, and isn’t particularly
useful for geological interpretation
Gaussian Curvature - This operation calculates the product of the minimum and
maximum curvatures. Though it’s been suggested that this method is useful for faults
(Lisle, 1994; Wen & Townsend, 1997), Roberts (2001) states that the Gaussian
curvature switches between positive and negative values too often to be useful.
Though this sign-switching problem could be mitigated by using the absolute values,
Gaussian curvature is mostly used for deriving other curvature attributes.
Maximum Curvature - This operation calculates the highest curvature for every point
regardless of azimuth or sign. Points with large positive values here have convex
curvature, while the negative values reflect concave curvature at some azimuth.
Roberts (2001) suggests that maximum curvature is useful for outlining faults and fault
geometries.
Without any faults drawn in the overlay, Petra’s gridding algorithms attempt to create
a continuous surface between the data points. As such, gridding will inherently smooth
over faulting, which creates regions of higher curvature. Upthrown sides of faults
exhibit a positive curvature while downthrown sides have negative curvature. In theory,
the zero crossing between the positive and negative curvature is the center of the
fault.
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Faulting calculated from grid curvature. Modified from Roberts (2001)

Minimum Curvature - This operation calculates the smallest, flattest curvature for
every point regardless of azimuth or sign. Points that still have fairly large minimum
curvature values can indicate possible fractures and faults.
Most Positive Curvature - This operation calculates the highest positive (convex)
curvature regardless of azimuth. As mentioned earlier, convex structures can be tied
to the upthrown sides of faults.
Most Negative Curvature - This operation calculates the highest negative (concave)
curvature regardless of azimuth. As mentioned earlier, convex structures can be tied
to the downthrown sides of faults.
Dip Curvature - This operation plots curvature in the direction of maximum dip.
Effectively, this curvature is a measure of the rate of change of dip in the maximum
dip direction. This tends to exaggerate local relief on the structure, which can enhance
differential compaction on channel sands and debris flows (Roberts, 2001)
Strike Curvature - This operation plots curvature in the direction of strike. In other
words, this measurement highlights ridges and valleys along strike, where positive
numbers reflect a ridge and negative numbers reflect a valley. Typically, this operation
is used in topographic terrain analysis to help analyze gravity-driven processes like
soil-erosion and drainage. More specifically, this method better illustrates where
valleys will aid drainage and where ridges will block it. In an oil & gas industry setting,
strike curvature can be turned upside-down to help illustrate how the top surface of a
reservoir will aid or block the migration of hydrocarbons (Roberts, 2001). In other
words, a ridge of positive curvature at the top of a reservoir will act as a conduit for
migration, while a valley digging into the top of a reservoir will block migration.
Curvedness - This operation plots the magnitude of curvature independent of shape.
This gives a general measurement of the total curvature present within the surface.
Dip Angle (Slope) - This operation calculates the angle of dip for each point.
Dip Azimuth (Direction) - This operation plots the azimuth of dip. Rapid changes in this
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may indicate faulting or lineaments.
Shape Index - This operation calculates the Sharpe Index (Si), which is a numerical
measurement of shape. The Sharpe Index ranges from -1 to +1, where -1 indicates a
point that is shaped like a bowl, 0 is perfectly flat, and +1 is dome shaped. Values
between -1 and 0 are valleys, while values between 0 and +1 are ridges.
Geologically, this index can be used to emphasize subtle faults or lineaments.

The Sharpe Index. Modified from Roberts (2001)

Output Grid Title - This entry sets the title of the created grid.

Options Tab
The Options Tab sets a few additional options for the curvature calculation

The Compute Grid Curvature Grids Tab

Smoothing
Apply Smoothing Filter Using - This option applies a rolling average to the calculation.
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The entry specifies the total number of points to include in the rolling average.

Resolution of Analysis
Number of Rows (Cols) Btwn Samples - This option decimates the data to only
analyze every N’th sample. Setting this value to 2, for instance, would only calculate
the curvature on every other grid node. Setting this value to 5 would only load every
5th sample. By default, this option is set at 1 to analyze every grid node on the
selected grid.

Normalization
Normalize Output Grid From - This option converts the values calculated by the
curvature calculation to instead use a user-specified minimum and maximum. This can
be useful for better illustrating some grids that normally would have a gradient too
small to usefully display on a grid.
Convert Negative Surface to Positive Values - This option simply applies the absolute
value of all surface calculations. With this option, Petra will substitute a positive value
for negative values.
Output Azimuth as... - This option changes how Petra exports azimuth values. This
can be useful for exporting grids to other software packages that handle azimuth a
little differently.

Reference Tab
The Reference Tab simply provides the reference for the curvature calculations.
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The Compute Grid Curvature Grids Tab

5.14.4.6 Compute Statistics Around Wells

This function uses a contour grid file to compute values within an area around each
well on the map. You can compute either volumetrics within a circle or statistics
within an elliptical area around each well.

DATA TAB

Value to Compute at Each Well on Map

Grid Volume At the Well - This option computes values equal to the volume within a
specified radius around each well. (see Volumes Tab)
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Grid Statistics (Average, Min, Max, etc) - This option computes statistical values
within an oriented ellipse around each well. (see Statistics Tab)

Grid File To Compute Values From

Select the grid file used for calculations.

Zone Item To Store Computed Value For Each Well

Select the zone and zone item for storing the computed results for each well. You
may select an existing zone item of type in a name to create a new item in the
selected zone.

VOLUME TAB

This section describes options available when the volume option is chosen on the
data tab.

Area Specified As

Radius In XY Units - The area parameter (see below) is specified as a radius of a
circle in xy map units (feet or meters).

Acres - The area parameter (see below) is specified as the number of acres in a
circle around each well.

Area Around Each Well Is

This option allows the area value to be set as a constant value for all wells or it can
vary from well to well by using a zone item for the area. In either case, the value
must be in the units specified by the 'Area Specified As' parameter.
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Volumetrics Lower Data Limit

This option allows you to set a lower limit for volume calculations. For example, if a
grid contained values from 0 to 100, a lower limit of 50 would restrict the volumes to
be computed for 50 to 100 only.

Scale Resulting Volumes By

Enter any multiplication factor you wish to be applied to the computed volumes. Note
that when the 'Area Specified As' parameter is acres, then the volume will
automatically be scaled to acre/ft as well.

STATISTICS TAB

This section describes options available when the statistics option is chosen on the
data tab. Results are determine using all grid node values and grid cell center points
falling inside a specified elliptical area around each well.

Statistical Value To Be Computed

Select the type of value to be computed around each well. Options are:
Average Value
Minimum Value
Maximum Value
Sum

Compute Values Within an Oriented Ellipse with the Following Dimensions

Define the dimensions and orientation of an ellipse by specifying the length (semimajor axis), width (semi-minor axis) and azimuth relative to a compass heading.
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You can also use the "Compute Dimensions From Acres" button to set the length and
width values by entering the area of the ellipse in acres and the ratio of length to
width.

Output Ellipses To \GRIDS\ELLIPS.TXT

Check this option to export a file called "ellips.txt" to the project's "grids" folder
containing polygons suitable for importing into the map overlay. Each polygon is an
ellipse centered at a well. The file contains x, y, and segid and can be imported as
polygons using the "Overlay>>Load>>Generic ASCII File"

5.14.4.7 Sample Grid to Wells

This operation calculates the grid value at a well’s location and store it to the well's
data item.
To sample a grid to a set of wells, select Contours>Grids>Sample Grid to Wells.

Data Tab
The Data Tab sets the grid to sample and the data item that stores the grid value.
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Grid File To Sample
This dropdown selects the grid to sample to the wells. This list of wells can be
reordered by creation date or by name.

Well Z Data To Sample To
Zone - This dropdown selects the zone containing the desired data item.
Item - This dropdown selects the data item containing the sampled grid value.
Set Zs not sampled from Grid to a NULL value - This option will overwrite the data
item with a null wherever there is no grid value.
Sample to NULL Values Only - This option will only sample data values to empty data
items. In other words, this option will prevent the grid from overwriting preexisting
values.
Apply Datum Elevation (SS Structure Grids Only) - This option will use each well's
datum elevation to create a pseudo-MD data value.
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Sample Increment for Directional Wells (in Depth Units) - This option sets the sample
increment
Assign Quality Code to Sampled Wells - This option assigns a quality code to all
sampled data items.

Limits Tab
The Limits Tab restricts how Petra handles wells that do not penetrate the grid.

Sampling a grid to individual wells

5.14.4.8 Sample Grid To Seismic

The sample grid to seismic option can back interpolate z values from a contour grid
onto seismic shot point locations.

Grid File To Sample
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This section contains a list of the current grid files in the project. Choose the grid to
sample onto the seismic locations. Use the "Grid Info" button to view the grid details
or to check grid statistics.

Sample To Seismic Z Variable

This section defines the seismic Z data item which will receive the interpolated values
from the grid. Select one of the defined seismic Z data items or type in a new Z
name. If you enter a new name, you will be prompted for the Z data description,
units, and remarks.

The "Sample to Active lines only" option can be used to restrict the grid sampling to
only the seismic lines which are currently in the active state. Turn this option off if you
want to sample the grid to all seismic lines and shot points.

Turn on the "Only Sample to Null Z Values" option if you do not want to overwrite
valid values with the interpolated grid values. Only seismic Z values containing a Null
value will be replaced.
5.14.4.9 Sample Grid to Control Points

Enter topic text here.
5.14.4.10 Resample Grids to Match

The Resample Grids function can be used to resample one or more grid files to
match a specific source grid or to a new grid size. Resampling may be necessary if
grid-to-grid operations are to be performed.

Two methods are available for resampling grids:
(1) Grid To Match All Resampled Grids (Source) The grid node locations of this grid will become the nodes of the resampled grids. All
resampled grids will match the number of rows and columns and grid dimensions of
this grid. Use the "Grid Info..." button to display grid header information of the
source grid.
(2) New X and Y Grid Size The number of rows and columns of the resampled grids will be computed from the
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X and Y grid sizes. The new grid limits will not change.

Grids To Resample Choose one or more grids which will be resampled to match the source grid. Do not
include the source grid in the selection list. Change the "Sort Grids By" option to
resort the grid list by date or name.

Method Neighbor Search - This method averages several grid node values around the xy
point to be sampled. This is usually the most accurate method.
Direct Interpolation - The method averages the 4 grid nodes of the grid cell
containing the xy point.
Direct Interpolation (faster) - Similar the previous method.

Note: resampled grids are modified in place. If you wish to retain a copy or the
original grid, make a backup copy using Windows Explorer. The grids are stored in
the "GRIDS" directory under the project primary directory.

Click the OK button to begin the resampling process.

5.14.4.11 Shaded Relief Grid

Enter topic text here.
5.14.4.12 Convert Triangular to Rectangular Grid

Enter topic text here.
5.14.5 Export Grid File - Map

Petra grid files can be exported in various commercial and ASCII formats.

Files Tab
Output File - Enter or use the "Browse" button to select the file name to receive the
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output grid file.
Grid File To Export - Select the Petra grid file you wish to export. Use the "Info"
button view a grid file's header or see the grid histogram stats.

Format Tab
Output Grid Format - Select the format of the exported grid file.
"Zycor Grid Format" - Choose this format to export a grid as an ASCII file with the
appropriate header information to be loaded in to Zycor Zmap software.
"ASCII Tabular File" - Choose this format to output the grid as a simple tabular or
columnar file. The following options are provided to further specify this format.
"Max Values Per Record" - Set the number of grid values written to each output
record. If each output record contains a grid row, the number of values written to
the record will not exceed the number of columns.
"Data Value Column Width" - Set the number of characters for each data value.
"Grid Origin" - Select the order in which the grid rows and columns are written to
the file. Each record may represent a row or a column and the first value written
may be the upper left corner or the lower left corner of the grid.
"Null Value Indicator" - This is the value written when the grid node contains a null
value. Be sure the column width is large enough to include this value. The null
indicator is written as a string value and need not be numeric.
5.14.6 Export Grid As XYZ - Map

Petra grid files can be exported as an ASCII file in which each record contains the X,
Y, and Z values for each grid node. These XYZ grids can be used in other software
packages, or for other kinds of modeling.
To export a Petra grid as an XYZ file, select Grids>Export>Grid as XYZ Points.. on
the menu bar at the top of the Map Module.

Files Tab
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XYZ Output File - Enter or use the "Browse" button to select the file name to receive
the output xyz file.
Grid File To Export - Select the Petra grid file you wish to export. Use the "Info"
button to view a grid file's header or see the grid histogram stats.
Include Active Control Points in the Output File - By default, Petra only exports the
points from the interpolated grid. This option also includes the control points loaded
into Petra's active memory.

Format Tab

Columns
Fixed Columns - Choose this option for fixed column output and set the "Column
Width" to the appropriate value.
Separate Values With - Choose this option for delimited value output and select the
desired value delimiter. Data may be separated by a comma, a space, or a semicolon.

Coordinates
X-Y-Z - Choose this option to export X,Y coordinates.
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LON-LAT-Z - Choose this option to export Latitude, Longitude coordinates.

5.14.7 Grid Volumetrics

The Map Module’s “Compute Volume from a Grid” tool calculates volumetrics from a
single grid. With a good quality isopach, pore volume, or hydrocarbon pore volume
grid, this method can generate accurate estimations of the area occupied by
hydrocarbons, and can divide these volumetrics into different lease polygons.
Once the overlay volumetric polygons are set-up, select
Contours>Volumetrics>Compute Volume From a Grid… on the menu bar at the top
of the Map Module to open the volumetrics tool.

Data Tab

Grid File Used For Volumes
Here, select the grid and grid type to be used in the calculation from the dropdown
labeled “Grid File Used For Volumes.” In the example below the “HPV” grid is
selected. To change the grid directory, select a different file path on the Dir Tab.
Note that grids on this dropdown menu can be sorted alphabetically by selecting the
button. The
button selects the most recently created grid in the directory.
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Grid Units
When calculating volumetrics, it’s important to make sure the units are correct. Petra
stores the default XY and depth units of measurement (feet or meters) in the Map
Projections Settings. When Petra calculates a grid, it uses these XY coordinate
units. The units used to create the selected grid are shown under Grid XY Units.
By default, Petra assumes that the Z units for the grid are the “Default Depths Units”
selected on the Map Projection Settings. Make sure the units selected here reflect
the units of the grid.

Grid Type - “Iso”
The “Grid Type” dropdown tells Petra what the numerical values in the grid actually
mean. A grid used in volumetrics can be one of three types: “Iso” type data with
values from zero to positive numbers, structure data with structural highs as larger
numbers, or structural data with structural highs as smaller numbers. In the example
below, the SCMR ISOPACH grid is selected as an isopach.
With “Iso” grids (including isopach grids, pore volume grids, and hydrocarbon pore
volume grids), Petra uses the thickness to calculate the volume underneath the grid
nodes. This is the most common and easiest way to calculate volumetrics with a
grid. Note that Petra will ignore the effect of negative numbers in “Iso” type grids.

Grid Type - Structure
Though Petra can use a structure grid in a volumetric calculation, it is almost always
better to use an isopach grid. In practice, using a structure grid really only works
with small, simple structures with a thick, homogenous reservoir and a discrete water
contact.
The numerical representation of a structural high or low is dependent on the
reference datum (Measured Depth/MD or SubSea/SS). SS grids store structural
highs as larger numbers (e.g. +2,000 SS is higher than +1,000 SS and -1,000’ SS is
higher than -2,000’ SS). MD grids store structural highs as smaller numbers (e.g.
1,000’ MD is higher than 2,000’ MD). Practically, grids referenced to SS use the
“Structural Highs as Larger Numbers” option, while grids referenced to MD use
“Structural Highs as Smaller Numbers" option.
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A single structure map only represents the elevations of a surface and doesn’t
inherently have any measurement of thickness. When using a structure map, Petra
calculates thickness by using the volume of the grid between the minimum and
maximum Z values set on the Data Tab. In the example below, Petra will calculate a
thickness between -1200’ SS and -2200’ SS. It’s important to note that setting a
limit below the bottom of the grid will add a large extra bulk to the volumetric
calculation. The example below will have an additional 200’ of section added to the
volumetric calculation.

Calculating volumetrics with a structure map can also lead to problems if the
thickness of the reservoir rock is thinner than the difference between the grid and the
bounding lower z value. With a sufficiently thick reservoir, the bounds are completely
covered by reservoir rock. With thinner reservoirs, the volumetric calculation can
include a volume that doesn’t actually include reservoir rock, thus overestimating the
volume.
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Compute Volume for Following Area(s)
This section tells Petra whether the volume underneath a grid will be broken out by
different volumetric polygons. The “Generate Volumes for Each Visible Overlay
Volumetric Polygon” option will calculate the volume of the grid covered by every
visible overlay polygon. Recall that a line defining these polygons need to be closed
on the line’s General Tab and named on the line’s Volm Tab. If these polygons
overlap, Petra will count the volume of the shared area twice. Setting this option to
“Generate Volume For Entire Grid Only” will instead ignore visible polygons and
calculate the volume over the entire grid.

Compute Volumes Between
The Minimum and Maximum Z values set limits on the overall volumetric calculation.
Though these settings are critical when using a structure grid, the limits can also be
useful when calculating volumetrics on thickness or “iso” maps. In particular, setting
the limits can help to reduce the effect of a large, thin uneconomic area on the
calculation.

Horizontal Slice Volumes
It’s also possible to calculate volumetrics for horizontal slices from the minimum z
value to the maximum z value through the reservoir. In the example below, horizontal
slices will be calculated for 0-10’ of thickness, 10-20’, 20-30’, and so on through the
entire section. With large grids and small increments, this additional step can be
fairly time-consuming.

Options Tab
The Options tab provides a few more options for the volumetrics calculation.
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Ignore Volume if Thickness is Less Than - This option sets the minimum thickness
necessary for Petra to consider in the volumetric calculation; anything below this
thickness isn’t included. By default, this thickness cutoff is set at zero, which means
that all the entire positive volume of the grid is used. Setting this thickness higher can
help to reduce the influence of a large thin or uneconomic area. Note that the cutoff
thickness is relative to the selected grid units – a 10’ cutoff applied to an isopach grid
is very different than a 10’ cutoff applied to a HPV grid.
Grid Refinement - The Grid Refinement option breaks larger grid cells into smaller
triangular areas. This slightly increases the accuracy of the volumetrics calculation at
the cost of more computing time.
Also Output Volumes to CSV File - The ”Also Output Volumes to CSV File” option
writes a CSV file containing the name, area (both a total area of the polygon and the
total area of the grid underneath the polygon), relevant calculated volume, an
average grid thickness (if selected), the working interest, and the WSN of the
polygon’s “designated well.” Petra creates a CSV file using the volumetric grid
name in the project’s GRIDS directory. Using the example above, Petra creates a
file named HPV.CSV. Leaving this CSV file open while trying to calculate a new
volume (and thus export data to the same CSV file) can create an IO error.

Print Average Value for each Polygon in Report - This option simply calculates the
average grid thickness for each visible named polygon. What this thickness actually
represents depends on the type of the grid used. The average Z value for a
structure grid will be an average elevation rather than an average thickness.
Apply Working Interests Associated with Overlay Polygons - This option scales each
volume inside a volumetrics polygon by the working interest.
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Write Volumes to SHAPE FILE - This option saves currently visible volumetric
polygons and data to a shape file. Select the option and navigate to the desired
shape file. This copies all currently visible volumetric polygons to a single shape
file.

Reserves Tab
The Reserves Tab selects the type of reserves calculation and specifies the type of
input grid. The reserves types include basic volumes, recoverable oil in place,
recoverable gas in place, coal bed methane, and coal tonnage. The map type tells
Petra whether the input grid is an isopach, a pore volume map, or a hydrocarbon
pore volume map. The Map Type only affects oil and gas reserve calculations. The
options on the Reserves tab changes depending on the selected reservoir and map
type. Similarly, the area and volume dropdowns at the bottom of the window show
the relevant units for the specific reserves calculation.

Basic Volumes (No Scaling)
The simplest form of a volumetric calculation is the first option, “Basic Volumes (No
Scaling).” This option simply calculates the volume occupied by the grid without any
additional reservoir calculations. Note that the “Map Type” option has no effect on
this calculation.
The “Basic Volume” calculation can display results in a variety of areas and formats.
For area, the available units include raw units (as defined on the Units Tab), square
feet, square meters, and acreage. For volume, the available units include raw units
(as defined on the Units Tab), cubic feet, acre-feet, acre-meters, MBO, MMCF, and
cubic meters.
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Oil in Place with Recovery
Petra’s oil reserves calculations multiplies the total area of pore space occupied by
hydrocarbons by a recovery factor. This volume is then divided by Bo to correct for
differences in volume between hydrocarbons in the reservoir and the same
hydrocarbon at surface conditions.
Recoverable Oil In Place: ROIP = Volume*Por*(1-Sw)*Rf / Bo
The three options for “Map Type” (isopach, pore volume, and hydrocarbon pore
volume) simply tell Petra what the selected grid represents. Practically, the map type
grays out irrelevant options.
An isopach grid just contains thickness and will need an average water saturation
and porosity. A pore volume grid already contains the thickness and porosity
information and just needs average water saturation. A hydrocarbon pore volume
grids already contains all this information, and therefore needs no averaged porosity
and saturation information.
The “Oil In Place with Recovery” calculation can display results in a variety of areas
and formats. For area, the available units include raw units (as defined on the Units
Tab), square feet, square meters, and acreage. For volume, the available units
include raw units (as defined on the Units Tab), cubic feet, acre-feet, acre-meters, or
MBO.

Gas in Place with Recovery
Petra’s oil reserves calculations multiplies the total area of pore space occupied by
hydrocarbons by a recovery factor. This volume is then divided by Bg to correct for
differences in volume between hydrocarbons in the reservoir and the same
hydrocarbon at surface conditions.
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Gas In Place: GIP = Volume*Por*(1-Sw)*Rf / Bg
Where Bg = Patm/P*(460+T/460+60)*Z; Patm = 1
The three options here for “Map Type” (isopach, pore volume, and hydrocarbon pore
volume) simply tell Petra what the selected grid represents. Practically, the map type
grays irrelevant options out.
An isopach grid just contains thickness and will need an average water saturation
and porosity. A pore volume grid already contains the thickness and porosity
information and just needs average water saturation. A hydrocarbon pore volume
grids already contains all this information, and therefore needs no averaged porosity
and saturation information.
The recoverable gas in place calculation also requires a compressibility factor,
reservoir pressure, and reservoir temperature. The calculation only uses the
numbers on the imperial units side; SI units must be converted to imperial
units. Using imperial units is fairly simple – simply enter the reservoir pressure and
temperature in PSI and °F into the boxes on the left (highlighted in yellow) To use SI
units, enter in the pressure and temperature in kPAA and °C into the boxes on the
for bth pressure and
right (not highlighted) and select the arrow buttons
temperature to convert to imperial units. After the SI pressure and temperature are
converted, then compute the volumetrics normally.
The “Gas In Place with Recovery” calculation can display results in a variety of areas
and formats. For area, the available units include raw units (as defined on the Units
Tab), square feet, square meters, and acreage. For volume, the calculation is limited
to MMCF.

Coal Bed Methane (CBM) in Place with Recovery
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The “CBM Gas in Place with Recovery” option calculates reserves for a coal bed
methane field. Note that the “Map Type” option has no effect on these calculations,
and the grid is always assumed to be an isopach grid.
CBM Gas In Place: CBMGIP = Volume*Cf*Gc*Sg*Rf
where Cf converts bulk density in g/cc to tons/acre-ft
The “Coal Gas In Place with Recovery” calculation displays results in a variety of
areas and formats. For area, the available units include raw units (as defined on the
Units Tab), square feet, square meters, and acreage. For volume, the calculation is
limited to MMCF.

Coal Tonnage
Coal tonnage simply calculates the volumetrics of an isopach grid and multiplies this
value by an average coal density.
Coal (Tons) = Volume*CoalDensity*62.42796061/2000 when density is in gm/cc
Coal (Tons) = Volume*CoalDensity/1000 when density is in kg/m3
The “Coal Tonnage” calculation displays results in a variety of areas and formats.
For area, the available units include raw units (as defined on the Units Tab), square
feet, square meters, and acreage. For volume, the calculation is limited to Tons
(2,000 lbs).
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Wells Tab
Petra can copy the volumetric data for each named polygon to a specific well’s
designated zone and data item. Recall that each polygon’s designated well is
established by double-clicking the polygon in the map module to open its Overlay
Line Attributes screen (see Initial Polygon Setup above). The “Store Polygon
Volume in Each Polygon’s Designated Well” option stores the calculated volume to
the designated well.

The “Zone To Store Polygon Volume” dropdown simply sets the zone where the
relevant volumetric data will be stored. By default, volumetric data is saved in the
WELL zone. In the example below, data will be stored in the “VOLUMETRICS”
zone.

© 2014

996

PETRA Help

The “Item to Store Polygon Volume” selects the specific data item where the
relevant volume is stored. In the example below, data will be stored in the “GIP”
zone
The “Item to Store AVG Z” selects the specific pre-existing data item where the
average grid thickness for each visible named polygon is stored. What this thickness
actually represents depends on the type of the grid used Note that the “Print
Average Value for each Polygon in Report” option on the Options Tab needs to be
selected for this option to work. In the example below, data will be stored in the
“GIP” data item in the VOLUMETRICS zone.

Dir Tab
This tab simply sets the directory of available grids. By default, this option is set to
the project’s GRIDS folder.
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Attribute Maps
Attribute maps show which wells meet some data criteria. Attribute maps can be set
to show well header information, zone data items, digital and raster logs, or monthly
production data. Attribute map criteria includes whether data are present or absent,
whether the data fits within a numerical range, or by a specific text or value search.
To add an attribute map, select the
button on the toolbar at the top of the Map
Module, or select Options>Attribute Map from the menu bar at the top of the screen.
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Available Data Items
The Available Data Items list shows the possible items for the attribute map. This
includes: well header information, zone data items, log curves, monthly production
data, or interval data. To add an item to the attribute map, select the relevent item
and click the associated

button to add the item to the Selected Attributes list.

Selected Attributes
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The Selected Attributes list sets the order of the attribute wedges, as well as
controls the individual settings. After adding the attribute from the available data
items, use the "Settings" and "Colors" tabs to define the display parameters for the
attribute. Use the

button to remove an attribute from the list or the

button to

clear the list. use the
and
buttons to reposition the attributes in list and the
relative position in the attribute symbol

General Tab
The General Tab controls a few settings that apply to the entire attribute map.

General
Suppress Legend - This option disables the screen legend showing the color and
attribute description.
Drop Missing Segments - Check this option to drop segments when data does not
meet the attribute "Show When" criteria on the Settings Tab.
Suppress Outline - This option removes the outline of the attribute map circle. This
can reduce visual clutter, but also reduces the individual impact of a single attribute
bubble.

Style
This option sets the overall style of the attribute map. Options include a doughnut
that leaves a hole for the sell symbol, or a pie that does not.
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Circle Size (Diameter) and Units
Enter the diameter of the attribute symbol in either inches or map units. When the
inches option is selected, the attribute symbols will always plot at the specified
diameter regardless of zoom. When map units are selected, the attribute diameter
when vary in size based on the map scale.

Settings
Save - This button saves the current attribute settings to an external *.ATT file.
Load - This button loads attribute settings from an external *.ATT file. Note that this
will replace all the current settings.
System Defaults - This button restores the system defaults and removes all
attributes.

Settings Tab

Data Is Present - This option shows the attribute when the well header data is nonblank, zone data is not null, or when a log exists for the well.
Data Is Missing - This option shows the attribute when the well header data is blank,
zone data is null, or when a log does not exist for the well.
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Active Vel Func - This option restricts the "Any Velocity Function" search (on the Well
Header Items dropdown) to only include wells with an active velocity function.
Uncalibrated Rasters - This option restricts a raster log attribute map (either "Any
Raster Log" or a specific raster log) to only rasters without depth calibration points.
This option will not affect non-raster log searches.
If Top Use SS Value - For a "Numeric Values" search on formation tops, this option
uses the SS value rather than the MD value. This option will not affect non-formation
top searches.

Numeric Values
Data Is In Range - This option shows the attribute when a zone data falls within the
specified range. Enter the range as a minimum and maximum value.

Text Header or Zone Values
Data Contains Value - This option shows the attribute when a well header text item
contains the specified text value. This option is not case sensitive.
Data Does Not Contain Value - This option shows the attribute when a well header
text item does not contain the specified text value. This option is not case sensitive.
Data Exactly Matches Value - This option shows the attribute when a well header
text item exactly matches the specified text value. This option is not case sensitive.
Show Unique Values - When a data item is selected on the Selected Attributes List,
this button displays a list of the unique values in that data item.

WSN List
This option limits the attribute map for the selected data item to only those wells on a
wsn list. This allows for attribute maps based on more complex, layered criteria. As
an example, a WSN list can show wells that have a TD greater than 10,000’, have
raster logs, and were drilled in 1973. To do this, use the Select Wells By Data
Criteria `
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Use Aliases - This option uses the relevant alias for the highlighted option on the
Selected Attributes List. This will use log and zone alias lists.
Disabled - This option disables the highlighted attribute on the Selected Attributes
list. Disabled attributes will have a sign next to them.

Colors Tab
The Colors Tab sets the color for the selected attribute on the Selected Attributes
list.

Color - This dropdown sets the color the selected attribute from the color drop down
list. To change another attribute's color, select the relevant attribute on the Selected
Attributes List on the lower left corner of the screen.
Randomize - This button randomizes the colors for each attribute.

Color Palette
This tool changes the colors in the "Color" dropdown above.
Save - This button saves the current palette to an external *.ZPL file
Load - This button replaces the current palette with a palette from an external *.ZPL
file.
Edit Palette - This button opens the Windows Color dialog box for modifying
individual colors in the color dropdown list.
Default Palette - This button restores the color palette to the Petra default.
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Legend Tab
This tab controls a little about the attribute legend that normally appears in the
bottom left corner of the Map Module.

Use Default Title In Legend - This option just uses the default title for the legend.
This will just report a brief summary of the color and data criteria.
Override Title Using the Following Title - This option replaces the attributes legend
with custom text specified in the entry box below.
Make Screen Legend Opaque Background - This option puts an opaque white box
behind the attribute legend.
Include Well Counts for Each Item - This option adds a total count of the wells
satisfied by the criteria.

Wells Tab
The Wells Tab adds an additional criteria to limit the attribute map to only wells on a
WSN list.
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All Wells On Map - This option does not restrict the attribute to a well list, and will
draw attributes on any well on the map that meets the data criteria. This is on by
default.
Only Wells Listed in WSN List File Below - This option restricts the attribute symbols
to only wells in the WSN list in the entry box. Wells that meet the data criteria but
are not on the WSN list will not have attribute bubbles.
Auto Retain Well List of Posted Wells - This option keeps the well list in memory.
Without having to read the WSN list off the network or hard drive, Petra can redraw
attribute maps slightly faster.
Save WSN File of Wells with Attributes - This option creates a new WSN containing
the wells that meet the selected attribute. It will save a new file ATTRMAP$$.WSN
in the same location as the WSN file selected above. Note that this will use the
attribute selected on the "Selected Attributes" list on the lower left corner of the
screen.

5.16

Bubble Maps
Bubble maps display data items as color-filled circles or circle segments at each
well. The bubble can change color or size with the data's value. Multi-bubble
segments can be equal or proportional to the percentage of the total similar to a pie
chart. Bubble maps are ideal for illustrating highly variable data sets such as
cumulative production.
To add a bubble map, select the

button on the Map Module toolbar, or select
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Options>Bubble Map from the menu bar at the top of the screen.

Title - This title appears in the legend for the bubble map

Bubble Mode
Normal Bubble Mode - Normal bubble mode produces a single or multi-segmented
bubbles of equal proportions. The radius can be fixed or vary with the z value
magnitude.
Pie Bubble Mode - This option produces a "pie chart" for multiple z values where
each segment size is proportional to the percentage of the total. The radius can be
fixed or vary with the magnitude of the sum of all z values.
Discrete Bubble Mode - This option can specify up to 8 discrete ranges so that all
values with a given range will have the same bubble size.
Data Items for Bubbles (max 32)
The list box on the left of the screen shows each z data item selected for bubble
map display. Z data items are chosen from the ZDATA TAB and added to the list
box using the

button. List box Items can be replaced using the

dropped using the

button or

button.

Z Data Tab
This section displays two drop down lists. The upper list contains all data groups and
user-defined zones. Selecting an item from this list causes the lower list to display
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all z-data items associated with the zone. Selecting a z-data item causes the "Value
Range" to display a suggested data range based on the z-data statistics.

Select Z Data Used For Bubbles
Stats... - This button displays a histogram of the selected z-data item.
View Z Data - This button opens a zone data item viewer. Here, use the "+" button
to the left of the desired zone to expand the tree, and then select the desired data
item. Note that entries here can be edited as well.
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The View/Edit Zone Data tool with no data item selected (left) and with a data item selected (right)

Use Aliases - This option enables zone aliases.
Disabled - This option disables the data item on the Data Items For Bubbles list.
This is functionally the same as double clicking the item on the Data Items For
Bubbles list. Disabled items will have a
next to it.

Value Range
Default Value Range - This tool computes the range for the selected data item.
Specifically, this tool sets the range +/- 2 standard deviations around the mean.
Colors - This tool opens the Color Interval Definition tool to set the color and interval
boundaries over the selected z-data value range.

Radius Tab (Normal Bubble Mode)
Selecting the "Normal Bubble Mode" will enable the Radius Tab. The Radius Tab
sets how the size of the bubbles.
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Constant Radius - This option draws all bubbles at the same size, regardless of the
value of the data item. The entry box and dropdown sets the desired units - note
that the size of the bubble can be set in map inches, XY map units, and acres.
Vary Radius as Units/Inch - This option draws bubbles that vary with the values of
the data item; wells with large values will have large bubbles. This entry varies the
radius as units/inch.
Scale Maximum Z Value to XY Map Units - This option sets the maximum radius of
all bubbles to a specified distance in XY map units (feet or meters). Since these
options are in XY units, all bubbles remain at a relative size independent to the map
scale. Bubbles will be limited in size to the maximum radius size in inches. No bubble
will exceed the maximum radius size.
Scale _____ to XY Map Units - This entry sets the radius in XY units, divided by a
scale factor. For example, a value of 200 and a scale entry of 2 will draw a bubble
with a 100 XY unit radius.
Values are XY Units (Apply Map Scale) - This option sets the size of the bubble as
directly proportional to the XY map units. For example, a value of 200 will draw a
bubble witha 200 XY unit radius.
Limit Radius to - This entry sets the maximum radius of the bubble selected on the
"Data Items For Bubbles" list. Note that this can be set in inches or XY units.

Pie Tab (Pie Bubble Mode)
The Pie Tab sets z value scaling information and sets the radius style for all pie
bubbles. Each z value can be scaled using a multiplication factor. This allows z
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values or differing units to be combined without one overwhelming the others.

Multiply Data item By - This option multiplies the data item by a constant. This can
be useful for increasing the size of one data item in the pie relative to other data
items.

Pie Scaling
Constant Radius in Inches - This option draws all pie bubbles with the same radius.
Only the proportion of the pie slices will change. This entry sets the radius in inches.
Vary Radius as Units/Inch - This entry sets the radius in inches, divided by a scale
factor. For example, a value of 200 and an entry of 200 will draw a bubble with a 1
inch radius.
Scale Max Z To - This entry sets the radius in XY units, divided by a scale factor.
For example, a value of 2000 and an entry of 20 will draw a bubble with a 100 XY
unit radius.
Limit Radius To - This option sets the maximum size of the pie. Pie bubbles will not
be larger than this setting, regardless of the value. Note that this option is set in
either inches or XY units immediately to the right.
Min Radius - This option sets the minimum size of the pie. Pie bubbles will not be
smaller than this setting. Note that this option is set in either inches or XY units
immediately to the right.

Pie Normalization
This option determines how the size of each pie bubble is computed.
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Normalize to the SUM of all Items - This option sets the relative size of each slice in
a proportion to the sum of all the data items displayed on the bubble map. This
option is useful for displaying multiple equal variables, such as the relative proportion
of production out of two or more intervals.
Normalize to the First Item Listed - This option sets the relative size of each slice in
proportion to the value of the first data item displayed on the bubble map. This
option is userful for displaying data relative to a single variable. As an example, this
can be useful for plotting RR vs EUR production values, where the "EUR" would be
the first item on the "Data Items For Bubbles" list.

Discrete Tab (Discrete Bubble Mode)
This screen allows you to set the low bound, high bound, radius and color for up to 8
discrete bubble sizes. When a bound cell is left blank, the associated range value is
set to 1E30. If the radius is blank, the line is ignored during display.

Options Tab
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Color Filled Circles - This option fills the bubble maps with the colors specified on the
Z Data Tab. Deselecting this option will only draw outlines of the bubbles.
Black Outlines - This option draws a black outline around the bubbles. Disabling this
option will draw open colored circles. Check the Black Outlines to have the color
filled circles outlined using a black pen.
Show Color Scale On Screen - This option displays a color bar scale in the upper left
corner of the map.
Display Color Scale on Printed Map - This option adds a color bar on the printed
map, rather than the map on the computer screen.
Draw Multi-Bubbles as Full Circles - This option will draw bubbles as variable radius
concentric circles instead of wedges.
Transparent Color Mode - By default, Petra draws bubble maps with an opaque
color, and the bubble can cover other elements. This option instead draws the line
or polygon with a transparent color. With a transparent drawing mode, other
elements will be visible through the line or polygon.
Plot After Wells - By default, Petra draws well symbols after and on top of bubbles.
This option instead draws the bubbles after the well symbols, so that the bubbles are
on top.
Show Discrete Bubble Legend in Corner - This option adds a legend for the discrete
radii and bounds set on the Discrete Tab in the upper left corner of the Map Module.
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The Discrete Bubble Legend

Well Sort Order
The Data Sort Order section includes options for sorting the bubbles by Z value.
Sorting in "Ascending" order results in smaller bubbles plotting on top or larger
bubbles. Sorting in "Descending" order puts larger bubbles on top of smaller bubbles.
The "Do Not Sort" option results in bubbles plotting in well sequence order.

Sample Tab
This tab shows a sample of the bubble map circle. When multiple z data items are
displayed, the currently selected list box item is identified in the multi-segmented
bubble as a highlighted color.

File Tab
The File Tab saves and loads bubble map settings to an external file. This can be
useful for rapidly switching between several bubble map settings.
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Load Settings - This option replaces the current bubble map settings with those from
an external file.
Save Settings - This button saves the current bubble map settings to an external *.
BUB file.

Well Tab
The Well Tab can limit the bubbles displayed on the Map Module to only the wells
listed on a WSN list.
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All Wells On Map - This option does not limit the bubbles, and displays bubbles for
every well on the Map Module.
Wells From WSN List File Below - This option limits the bubbles to only the wells
listed on the WSN list selected below.
WSN List File - This entry sets the location of the WSN file.
Synchronize All Items To Use This Setting - This option sets all data items on the
"Data Items For Bubbles" list to use the WSN list settings.

5.17

Symbol Highlights
This function highlights wells with special well symbols, marker symbols, or picture
files. This tool can be used in addition to the Attribute Map.
Optionally, each group of wells can have data items posted around the well location.
Each group of selected wells is identified using a Well Sequence Number (WSN) list
file. A maximum of 25 separate groups can be defined with different properties, such
as, symbol type, symbol style, description and data posting.
To add symbol highlights, select Options>Highlight Symbols... from the menu bar at
the top of the Map Module

Defining Well Groups
Begin with the Wells tab and proceed through each of the other tabs. Then click the "
Add" button to add the group to the list. Each defined group is listed by symbol and
description. A generic 'GAS' symbol is used for groups which use the current well
symbol. Click the "Replace" button after making a change to a previously defined
group. Drop a single group using the "Drop" button or remove all groups using the
"Clear All" button.
Set the "Active" check box to the off state to disable previously defined highlight
symbols but retain the template for later activation.

Wells Tab
The Wells Tab just selects the WSN list for each symbol highlight.
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Hightlight Selected Wells Defined by WSN File - Use the browse button ('...') to find
and select the WSN file which identifies the wells to be highlighted.
Build WSN List File... - This button opens the Select Wells By Data Criteria tool.
Here, select wells with the desired criteria, and save a new WSN list file. It's
probably best to save the WSN list to a safe, regularly-backed-up location.

Symbol Tab
This tab selects the actual symbols around the wells on the Map Module.

Symbol Type
Click on one of the symbol type options listed below.
Selected Marker Symbol - Use this option when you wish to have a large circle,
triangle, square, etc. plotted on top of the normal well symbol. The marker symbol is
chosen from the "Markers" list box.
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Current Well Symbol - Use this option when you want color-coded well symbols.
Each well is plotted using the current well symbol. The color and size of the well
symbol will be set by the symbol size and style attributes.
Windows Meta File - This option will plot a picture file in the Windows Meta File
format, (emf or wmf), at each well location of the group. It will be sized using the
symbol size attribute. Meta files are created external to Petra.

Get Symbol Color & Size
The symbol size mode attribute determines whether to use a user-defined size or
the size of the current well symbol.
From "Style Tab" - Means to use the symbol size defined on the "Style Tab". Sizes
are given in XY map units, i.e., feet or meters. Use this option when placing larger
marker symbols over the well symbol.
From Current Well Descr. - Means to make the highlight symbol the same size as the
current well symbol. Use this option along with the "Current Well Symbol" option to
show color-coded well symbols.

Markers
This list sets the actual marker plotted around the selected WSN list.
Include a Slash over Marker - This option puts a slash over the selected marker.
This can be useful for marking wells that fail some sort of criteria, such as wells that
are too shallow or that failed to produce out of an interval.

Style Tab
This tab sets additional symbol properties, including a description and color.
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Description - Enter a short text string that describes the group of highlighted wells.
This text will appear in the legend.
Color - This option sets the color of the highlight symbol. Click the small browse
button ("...") to choose a color.
Use Color From Current Symbol - This option just uses the color of the well symbol.
Pen Width - This option determines the line thickness of the highlight symbols.
Choose from narrow to extra wide.
Symbol Size (Map Units) - Specify the height of the highlight symbol in XY map units
(feet or meters).
Connect Highlighted Wells With A Line - This option draws a line between highlighted
wells. This can be used as an alternative to the Display Selected Cross-Section
Lines tool.

Meta File Tab
This tab appears whenever the symbol type is set to windows meta file. The meta
file picture will be plotted at each well location defined by the groups WSN list.

Windows Meta File Used for Symbol - Click the small browse button ("...") to find
and select the wmf or emf Windows Meta File.

Data Posting Tab
This feature allows data items to be posted for those wells in the group. Posting
information is defined using a data posting template. The template must be created
and saved under the data posting options located under the mapping Options>Data
Posting menu.
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Post Data By Wells Using Template File - Click the small browse button ("...") to
locate and select the data posting template file (.dbw). LEAVE BLANK to indicate
you do not wish to post data for the group.

General Tab
This tab defines properties relating to all groups.

Title Block Caption - This text string will appear as the title for the highlight symbols
legend. It can be left blank if not title is needed.
Show Legend in Upper Corner of Map - Check this option on to have a legend
displayed in the upper left corner of the map. This legend is not shown in zoom
mode. There is also a highlight symbols legend available on the map title block.
Legend Symbol Size Factor - Enter a multiplier scale factor greater than zero to
adjust the size of the legend symbol and text. For example, a size factor of 0.5 will
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make the legend data 1/2 scale. A size factor of 2.0 will make the legend data twice
as large.
Plot Wells on Top of Highlight Symbols - This option causes the highlight symbols to
be plotted prior to plotting the well symbols so that the well symbols will not be
covered up by the highlight symbols.
Save Template - You can save the highlight symbol settings for later retrieval.
Load Template - You can load previously saved highlight symbol settings.

5.18

Drainage Ellipses
The Map Module can draw elliptical drainage ellipses around well symbols on the Map
Module. These can help illustrate already drained areas and aid plans for future
development.
To add drainage ellipses, select Options>Drainage Radius from the menu bar at the
top of the Map Module.

Drainage Area Tab
The Drainage Area Tab defines the size of the drainage ellipse for each well.

Zone/Item - To add a drainage ellipse, select the zone and item that contains the
overall area drained by the specific well. Unlike the ratio and orientation for the
ellipse, the size requires a data item value for every well; wells with a null value for the
drainage area will not have a drainage ellipse.
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Area Units - This drop down selects the units for the zone data item. This includes
acres, square feet and meters, and hectares.
Display As - This drop down selects the type of area units displayed on the map.
Minimum/Maximum - These options set the minimum and maximum areas for the
drainage radii. Wells with areas outside these limits either will not display on the map
(when the "Ignore Data Outside Range" limit is selected), or just won't be any larger
than the maximum or smaller than the minimum.
Ignore Data Outside Range - This option disables any drainage radii that are outside
the minimum and maximum set on the option immediately above.
Colors - This tool can draw drainage radii in different colors based on their size. This
button opens the Normal Color Interval Definition tool to set the desired color scheme.

A/B Ratio Tab
The A/B Ration Tab sets the ratio of the ellipses' semi-major axis (A) to the semiminor axis (B). The higher the ratio, the skinnier and longer the drainage ellipse.

Zone Item - Using a zone item allows the drainage ellipse to vary from well to well.
Select the relevant zone and data item containing the ratio.
Constant - This entry sets a constant ratio across all wells with an ellipse.

Orientation Tab
The Orientation Tab sets the compass direction of the drainage ellipse. Petra reads
azimuth as increasing clockwise from north at 0: N = 0, E = 90, S = 180, and W =
270.
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Zone Item - Using a zone item allows the direction of the ellipse to vary from well to
well. Select the relevant zone and data item containing the azimuth of the drainage
ellipse.
Constant - This entry sets a constant ratio across all wells with an ellipse.

Options Tab
The Options Tab controls a couple of additional option on how Petra draws and labels
drainage ellipses.

Color Filled Drainage - This option fills the drainage ellipse with the color (or colors)
specified on the Drainage Area tab. By default, this color fill is opaque and will
obscure elements below. To change this option to a transparent color fill, select "Plot
as Transparent" on the Options Tab.
Draw Color Scale Bar - When Petra uses multiple colors for the drainage ellipse, this
option draws a scale bar on the map.
Outline Drainage Area in Black - This option adds a black outline to the drainage area.
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This is a good option to select when the "Color Filled Drainage" option is deselected.
Multiply Each Z Value By Center Ellipse At Alternate Location of Fm Top - By default, Petra centers drainage
ellipses on the well symbol. This option instead moves the drainage ellipse to the
location of the formation top specified in the dropdown below. This can be useful for
more accurately representing the location of drainage in deviated or directional wells.

Wells Tab

All Wells On Map - This option plots drainage ellipses on every well on the map. This
option can create misleading maps, since it will include all wells on the map regardless
of whether the produced out of the relevant formation or not.
Wells From WSN List - This option limits drainage ellipses to only wells listed on a
WSN list. This option is good for limiting drainage ellipses to only wells producing out
of the relevant horizon, but will need to be updated as new wells are drilled.

General Tab
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Plot as Transparent - Petra normally plots drainage ellipses with an opaque color fill
(when the "Color FIlled Drainage" option is selected on the Options Tab). This option
plots color filled drainage ellipses with a transparent color fill. This can be useful
when the drainage ellipses cover other map elements.
Plot Rectangle Instead of Ellipses - This option posts a rectangle rather than an
ellipse.

Load Settings - This button saves the drainage ellipse settings to an external *.DAM
file.
Save Settings - This button replaces the current drainage ellipse settings with those
from an external *.DAM file.

Overlay Tab

Capture Ellipses to Map Overlay Layer - This option captures the drainage ellipses to
the overlay selected on the dropdown below.
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R - This button renames the overlay layer selected on the dropdown menu. This can
be useful for renaming a default layer name to something more descriptive.
Clear - This option completely removes all lines, text, and images from the overlay
layer selected on the dropdown menu.
Include Polygon Labels - This option adds a volumetric polygon name (available on
the Overlay Line Atribute's Volm Tab) based on the well's WSN.
Label Prefix - This option adds a prefix to the volumetric polygon name created by the
"Include Polygon Labels" option.

5.19

Log Curve Display
The Plot Log Curves Beneath Wells tool controls how Petra displays log curves
underneath well symbols on the Map Module.
To open the Plot Log Curves Beneath Wells Tool, select the
button on the
toolbar at the top of the Map Module, or select Options>Log Curve Map from the
menu bar at the top of the Map Module.
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The Plot Log Curves Beneath Wells tool (left) and log curves on the Map Module (right)

Available Logs
This dropdown displays all the logs available in the project. Selecting the Digital or
Raster button selects the general type of log.
To add a log to the Selected Logs list, select the desired log on the Available Logs
list and left click the
button.

Selected Logs
The Selected Logs determines which logs are displayed on the Map Module.
To drop a log from the Selected Logs list, select the desired log on the Selected
Logs list and left click the "<" button. To drop all logs from the Selected Logs list,
left click the "<<" button.
To change the log plot order, select the
or
button. Logs at the top of the list
are plotted first (and below) logs at the bottom of the list.

Scale Tab (Digital)
The Scale Tab changes the display settings for the selected log curve on the
Selected Logs list. Note that the Scale Tab changes appearance based on whether
a digital or raster log is highlighted on the Selected Logs list.

The Plot Log Curves Beneath Wells Scale Tab (Digital Log Selected)

Track - This entry sets the log's track, or relative position against the well symbol. In
the screenshot above, the GR curve is set to track 1, which is immediately to the left
of the well symbol.
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Track positions relative to the well symbol (above the "DEPTH" track)

Log Scale
Compute Optimum Scale - This option dynamically computes the scale range at each
well so that the log fills the track regardless of the data range. This option normalizes
the scale so that all wells have the same appearance. Since this option changes the
scale for every well, it can be misleading for quantitative analysis of well data.
Set Scale Range - This option sets a fixed left and right scale for the log curve. The
"Defaults" button calculates a scale range that is 2 standard deviations around the
mean using the first 20 wells with data.
Log 10 Scale - This option plots the curve on a logarithmic plot. Log scale values
must be greater than zero and are normally entered as powers of 10.

Shading
This section sets how Petra draws the log curve.
Do Not Shade - This option just plots the plain curve without any shading or fills.
Shade Less Than Cutoff - This option fills the log curve when the log curve values are
below the specified "Cutoff Value." Note that this option uses the "Color Below
Cutoff" dropdown menu.
Shade Greater Than Cutoff - This option fills the log curve when the log curve values
are above the specified "Cutoff Value." Note that this option uses the "Color Above
Cutoff" dropdown menu.
GeoColumn Shading - This option enables the geocolumn shading, which fills the
space under the log curve based on a log curve's values. Selecting this option
enables the GeoCol Tab on the far right side of the Plot Log Curves Beneath Wells
Tool. The GeoCol Tab controls the specifics of how Petra uses geocolumn shading.

Use Aliases - This option uses log curve aliases when the the selected curve is
absent. Disabling this option will force petra to only use the exact curve name.
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Use Transparent Color Fill - By default, Petra uses an opaque color fill that can
obscure other items on the map. This option instead uses a transparent color fill that
can still display items below the log curve display.
Put Raster Pay on Images - This option plots the raster pay intervals on the log.
Clip at Track Bounds - This option clips log data beyond th

Scale Tab (Raster)
The Scale Tab changes the display settings for the selected raster log on the
Selected Logs list. Note that the Scale Tab changes appearance based on whether
a digital or raster log is highlighted on the Selected Logs list.

The Plot Log Curves Beneath Wells Scale Tab (Raster Log Selected)

Track - This entry sets the log's track, or relative position against the well symbol. In
the screenshot above, the resistivity raster log is set to track 2, which is immediately
to the right of the well symbol. Particularly for raster logs, it's often useful to put
different group names in different tracks to prevent overprinting.

Track positions relative to the well symbol (above the "DEPTH" track)

Use Aliases - This option allows Petra to use raster group name aliases. Raster
aliasing forms a list of "equivalent" raster group names - when the primary group
name is missing, Petra attempts to substitute another group name instead.
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Transparent Color Fill - By default, Petra uses an opaque color fill that can obscure
other items on the map. This option instead uses a transparent color fill that can still
display items below the log curve display.
Plot Raster Pay on Images - This option displays all raster pay intervals on the log.
Clip at Track Bounds - This option trims the raster group on the edge of the track.
Since Petra automatically scales the raster image to the desired height and width,
this option is really only useful for digital logs.

Tracks Tab
The Tracks section applies to all logs plotted and contains options for setting the
track width, height, and scale. The track dimensions define a rectangle in which
each log is plotted.

The Plot Log Curves Beneath Wells Tracks Tab

Select or enter a "Track Width" value in units equivalent to the XY units or the map, i.
e, feet or meters. The track width will be scale independent and will shrink or
expand as the map scale changes.

Track Height
This option sets the height of an individual log curve.
Map Units - This option sets the height of the curve in the XY units on the Map
Module. Since the height is in map units, the size of the curve will change
proportionally by zooming in and out.
Depth Scale - This option sets the height of the curve in a set scale. For example, if
the depth scale is 100 feet/inch, then 100 feet of log would occupy a space of 1 inch
below the well spot. The size of the track does not change with the scale of the
map; practically, this can lead to messy maps when fully zoomed out.
Depth Scale Units - This dropdown sets the scale units of the track.
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Track Gap - This option adds additional space between the well symbol and the top
of each track.

Draw Track Outlines option draws a rectangle at the track boundaries.
Opaque Background - This option draws an opaque background for all tracks. This
makes the log curves easier to see, but can obscure other features on the map.

Depths Tab
The Depths section shows the depth range over which the log curves will be
displayed.

The Plot Log Curves Beneath Wells Depths Tab

Sample Decimation - This option decimates the data to only export every N’th
sample. Setting this value to 2, for instance, would only export every other data
point. Setting this value to 5 would only export every 5th sample. By default, this
option is set at 1 to export every datapoint in the curves.

Set Depth Range - In the Set Depth Range box, select the relevant top, MD, or TVD
button. For MD and TVD, select the relevant button and enter the adjacent depth in
the entry field. For tops, select the desired top from the “Fm Top Name” dropdown
box. Notice that an offset can also be added or subtracted to the fm top; this offset
will include data points above or below the actual fm top depth.
To set depths by a zone’s interval definitions, select the desired zone on the “Set
Upper and Lower Depths From Zone” dropdown menu. Note that the WELL zone by
default covers -1M MD to +1M MD, so it should cover the entire footage of all wells.
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Tops Tab
The Tops Tab superimposes log curves on top of the displayed log curves.

The Plot Log Curves Beneath Wells Tops Tab

Draw Fm Tops - This option enables or disables the formation tops on the log curve
plot. Disabling this option turns the tops off, but retains the settings.
Use Top Aliases - This option uses top aliases for the export. In practice, this option
will attempt to replace the missing top with one of the other "equivalent" tops on the
alias list.
Supress Source Code from Label - By default, Petra adds every formation top's
source code. This option removes the source code, and only plots the name of the
top on the label.

File Tab
The File Tab saves the current settings to an external file or restores settings from
an external file.
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The Plot Log Curves Beneath Wells File Tab

Save - This button saves the current settings to an external file.
Load - This button replaces the current log curve settings with the settings from an
external file.

Options Tab
The Options Tab changes how Petra handles shifted logs.

The Plot Log Curves Beneath Wells Options Tab

Clear DB Shifted Logs - This option resets the curve shifting stored in the database.
This will remove all log curve shifting for all wells in the database, which will affect all
users.

Repositioned Logs
This section controls how Petra handles repositioned log curves.
Disable Shifted Logs - This option temporarily disables any log curve shifting. The
project retains the settings.
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Use Offsets From DB - This option uses the curve shifting normally saved in the
database.
Use Offsets From File - This option uses log curve shifting stored to an external file.
For more information on external offset files, see Data Offsets File Manager.

Wells Tab
The Wells Tab can limit the wells displaying logs to only those wells on a WSN list.
Wells not on the list will not display log cuves.

The Plot Log Curves Beneath Wells Wells Tab

All Wells - This option allows log curves for all wells displayed on the Map Module.
Wells From the WSN List Below - This option only displays log curves for the wells
on the user-selected WSN list selected below. Wells not on the WSN list will not
display any curves.

GeoCol Tab
The GeoColumn tab provides options for displaying a curve using "geocolumn"
shading. The GeoColumn feature shades a curve with multiple colors based on curve
values.
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The Plot Log Curves Beneath Wells GeoCol Tab

Shading Direction - This option sets the direction of the shading. The sading can be
to the left or right of the log curve.
Log Used For Shading - The values from the curve selected here are used to define
the color "cutoff" ranges. This curve can be the same curve as being shaded or can
be any other curve.
GeoColumn Base Line Value - Shading occurs from the curve traces back to either
the track edge or a specified curve value.

5.20

Map Measure Tool
The Map Measure tool displays the distance and other information between two
points on a user drawn line.
button on the toolbar at the
To use the Measure Tool, select Tool>Measure or the
top of the Map Module. First, left click anywhere on the map to set the start point.
This draws a line between the start point and the cursor. Petra will display the
distance, endpoint LatLon (or XY), the dx and dy in map units, and angle between the
start and end points in the lower left module of the Map Module.
To display the endpoint's XY location instead of LatLon points, select the "Measure
Tool Shows XY instead of LatLon" option on the Map Margin and Preferences tool.
To display distances in miles/kilometers rather than feet/meters, select the "Measure
Tool Shows MILES or KM" option on the Map Margin and Preferences tool.
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Map Monthly Production Chart
The monthly production chart displays up to 3 monthly production variables as a small
graph next to the selected wells.
To set up monthly production charts select the
button ton the Map Module
Toolbar, or select Options>Production Charts... from the menu bar at the top of the
Map Module.

The Map Module with Monthly Production Charts

Prod 1/2 Tab
Years Tab
Options Tab
File Tab
Wells Tab
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5.21.1 Map Monthly Production Chart Prod1/2 Tab

The Prod 1 and Prod 2 Tabs set the production data shown on the production chart.

Production Stream - This dropdown selects the individual production stream. By
default, the OIL, GAS, and WATER and water streams are set in green, red, and
blue. Select "None" to disable the graph.
Cumulative Values - This option displays cumulative values for the selected stream at
the bottom of the plot.
Auto Scale - This option automatically scales the selected production stream to use
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the desired logarithmic decades set on the Options Tab.
Linear - By default, Petra plots production values on a logarithmic scale. This option
forces Petra to instead use a linear scale.
Manual Y-Max - This entry specifies a maximum for the selected production stream.
Values above this plot will be off the top of the chart. Note that the minimum will be
determined by the number of log cycles.
Color Box - This bar sets the color of the stream on the plot. To change the color,
select the color box, and select a new color on the

Changing the production stream color

Suppress Y Axis - This option suppresses the labels on the Y axis.
5.21.2 Map Monthly Production Chart Years Tab

The Years Tab sets the extents of the X axis

Years
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Automatic - This option sets automatic scaling for the X axis of the production chart to
the first and last month of production.
From & Through - These entries set limits on the duration of production data. By
default, Petra displays data from 1900 through 2100, which will be much too big a
range for most applications.
Include Historical Production in Manual Mode - Some states record historical
production in a single historical year labeled "0." This option includes this historical
year 0 in when years are set manually.
5.21.3 Map Monthly Production Chart Options Tab

The Options Tab sets some of the details and scaling for the monthly production charts.

Use Common Scale On All Graphs - This option forces all 3 graphs to use the
maximum computed scale.
Number of Log Cycles on the Y-Axis - This entry sets the number of logarithmic
decades.
Position Relative to Well Symbol - This option sets the location of the monthly
production plot around the well symbol.
Text Scale Factor - This option resizes text. For example, setting this value to 1.5
changes the text to 150% of the default size.
Year Label Decimation - This option decimates the year labels by the specified
number. As an example, setting this option to "5" will only display every 5th year
label.
Plot Minor Y Grid Lines - This option draws the minor lines on the production axis.
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With this option deselected, only the logarithmic decade markers will appear on the
plots.
Plot As Opaque - This option plots the monthly production plots as opaque.
Depending on draw order, this option may cover up other items on the map.
Draw Through Null Values - This option will draw a line to connect all values. By
default, months with no production have gaps in the graph line.
Use Aliases - This option uses monthly production name aliases.
Suppress Labels - This option removes labels on the Y axis.
Color-Fill Charts - This option fills the area on the plots below the production curve.
This can obscure other production data.
Suppress Cums - This option prevents cumulative production values from appearing
on the bottom of the production charts.
Suppress Connecting Line - This option prevents a connecting line between the
production plot and the well symbol.

Chart Size
Chart sizes are in - This dropdown sets the size of the production plot in inches or XY
map units.
Chart Width - This entry sets the width of the production chart.
Chart Height - This entry sets the height of the production chart.
Gap Btwn Well Symbol - This option sets the space between the production chart and
the well symbol.

Enlarge With Zoom - This option increases the size of the production plots when
zoomed in on a smaller part of the map.
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5.21.4 Map Monthly Production Chart File Tab

The File Tab saves and restores Monthly Production settings and globally changes the positioning if production charts

Load Settings - This button loads previously saved production plot settings from a
*PMO file.
Save Settings - This button saves the production plot settings to a *PMO file.
Clear Shifted Charts - This option resets all shifted charts back to the default position.

Moved Charts
Do Not Move Charts - This option overrides any manually shifted charts, and draws
them back at the default position. Note that the positions are still saved in the DB and
can be restored by selecting a different option.
Use Offsets from DB - This option uses the manually selected positions of the
production charts.
Use Offsets from File - This option uses the currently selected file in the Data Offsets
File Manager.
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5.21.5 Map Monthly Production Chart Wells Tab

The Wells Tab selects a smaller subset of wells to display a production chart.

The wells tab section provides options for posting production plots only on a subset of
the wells on the Map Module.
All Wells On Map - This option plots production plots on all wells on the Map Module.
Wells From the WSN List below - This option uses a well list to select the wells with
production charts. Only wells on the WSN list will display production plots.

5.22

Seismic Line Mapping
The seismic mapping options provide settings for posting seismic shot point data.
Seismic Z values can be posted and color coded for a quick line miss tie check.
Enable or disable seismic data posting by setting the "Seismic Active" check box at
the bottom of the screen.

Posting Options Tab
Plot Line Names - This option causes each seismic line to be labeled at its starting
and ending shot point.
Plot SP Symbols - This option plots a winged circle at the shot point location. The
size and decimation interval can be set (see below).
Plot SP Numbers - This option labels shot points with the shot point number. The size
and decimation interval can be set (see below).
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Connect SPs with a Line - This option draws a straight line from shot point to shot
point. This option helps delineate lines when decimating shot points.
Color Coded Lines - When checked, line names and the connecting line between
shotpoints will be drawn using the color assigned to each line. Otherwise, the color
assigned in the "Display>Colors" option will be used.
Plot Line End Pts Only - Activating this option results in only the starting and ending
shot points being plotted. This option works best in conjunction with the line
connection option and can provide a quick display when seismic details are not
required.
Use Default Line Color Only - This option overrides the color that has been set for
each seismic line. The default color can be changed using the Display>Colors option.
Show Active Lines Only - When this option is selected, only those seismic lines which
have been designated as active in the seismic module will appear on the map.
Include Seismic In Auto Limits Mode - The auto map limits mode computes the map
limits from the well locations. Set this option to have the seismic data included in this
calculation.
Sizes - Select the symbol and text sizes for the shot point symbols, shot point
number labels, and line end point labels. The Text Gap size controls the white space
between the shot point symbol and the posted number or Z value. Select the "
Enlarge With Zoom" option if you want the symbol and text sizes to increase
whenever you zoom in.
Decimation Intervals - This section controls the intervals for posting shot point
symbols and labeling shot point numbers. When the "Multiples Only" option is active,
only those shot point numbers which are evenly divisible by the selected interval will
be plotted. If not selected, then every Nth shot point (N=interval) will be plotted.
SP Number Position - The shot point number can be plotted to the left or right of the
symbol.

Z Data Tab
The Z Data tab controls posting and color coding Z values.
Z Value - Choose the seismic Z value to be plotted.
Z Value Posting - To post a Z value by a shot point location, set the "Post Z Value"
check box and select the appropriate decimation "Interval", text "Size", and number
of "Decimals" to the right of the decimal point when formatting the posted value.
Color Coded Z Values - This section defines the attributes for color coding the Z
value. Activate this option by setting the "Color Coded Z Value" check box. The "Z
Color Range" button invokes the Z color palette for defining the range and interval of
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the color scale. Use the "Compute Z Range" button to search the seismic Z values
for an appropriate default color range. Set the "Cell Size (inches)" value to the
preferred size of the color square plotted at each shot point symbol. Color-coding
uses the "Interval" from the "Z Value Posting" section.

5.23

Dip Symbols
The Dip-Azimuth Indicators tool adds dip and strike indicators to the Map Module.
Petra can either use dip and strike from zone data, or from an external data file. Note
that dip symbols from zone data are limited to well locations, while external data files
can display anywhere on the map.
To add dip highlights, select Options>Dip Symbols from the menu bar at the top of the
Map Module

General Tab
The General Tab sets the data type for the dip and azimuth data. Petra can either
use dip and azimuth data from a data item in the database or from an external file.
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Dip & Azimuth Data Stored in Zone Database - This option sets the dip and azimuth
for each well from two zone items. This plots dip and azimuth at well locations, and
will create the Zone Tab.
Dip-Azm Data Loaded From an External File - This option loads dip and azimuth from
an external text file. This option isn't limited to posting dip and azimuth at well
locations, and can actually plot the symbols anywhere on the map. This option
requires access to the external file - moving or changing the file name will remove the
dip symbols. This will create the "External File Tab.

Zone Data/External File Tab
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Dip Data
These two dropdowns set the location of the dip data item. The upper dropdown sets
the zone, and the lower dropdown sets the specific data item.

Azimuth Data
These two dropdowns set the location of the azimuth data item. The upper dropdown
sets the zone, and the lower dropdown sets the specific data item.

Options Tab

Dip Symbol Size - This entry sets the size of the dip symbols in map units. Since
these symbols are in map units, they will enlarge and shrink with zoom.
Symbol Position Around Location - This dropdown sets the position of the dip symbol
around the well symbol. Dip symbols can be above, below, left, right, and centered
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right on top of the well symbol.
Gap Between Well and Dip Symbol (XY Units) - This entry sets the spacing between
the well and dip symbol in map units. By default, this is set to 100 units. Since this
distance is in map units, it will enlarge and shrink with zoom.

Azimuth Representation
There are a few different conventions for strike compass directions. This section tells
what the azimuth numbers actually represent.
Angles Measured in Direction of Dip/Strike - This dropdown specifies whether the
azimuth value represents the compass direction of the dip or the strike.
Angles Measured in Clockwise from North - This option sets the azimuth as measured
clockwise from north. North is 0, East is 90, South is 180, and West is 270.
Angles Measured in Counter-clockwise from East - This option sets the azimuth as
measured counterclockwise from East. East is 0, North is 90, West is 180, and South
is 270.

Plot Dip Labels - This option adds labels for the dip. Deselecting this option will just
add the dip symbols.
Dip Label Size - This option sets the size of the dip label. Since this distance is in
map units, it will enlarge and shrink with zoom.
Include Azimuth with Dip Label - When the "Dip Label Size" option is selected, this
option appends the azimuth data to the end of the dip label.
Ignore Shifted Symbols - This option posts the dip symbol at the original well location
when well symbols have been shifted.

5.24

Lat-Lon and X-Y Ticks - Map
Maps can have latitude-longitude and/or x-y ticks labeled around the map edges.
To add ticks, select Options>Ticks on the menu bar at the top of the Map Module.

Lat-Lon Tab
This section controls the display of LatLong ticks and labels. The "Show Lat-Lon
Ticks" option enables LatLon ticks.
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Compute Optimum Tick Interval From Map Scale - This option automatically
calculates and posts LatLon ticks on the map.
Use The Following Tick Interval - This option specifies a particular lat-lon tick-labeling
interval in degrees, minutes, and seconds. As an example, 0-30-0 would draw and
label ticks at 30-minute intervals.

Label Direction
Internal Inward - This option draws the labels facing outward from the map.
Internal Outward - This option draws the labels outwards from the map.
Label Map Border - This option draws labels horizontally around the edges of the
map.
In Gutter - This option draws ticks in the gutter. Note that the gutter is set with the
Map Margins and Preferences tool.

"Internal Inward" labels (left), "Internal Outward" labels (left center), "Label Map Border" (right center), "In
Gutter" (right center)

Visibility
Show Lat-Lon Ticks - This option enables LatLon ticks on the Map Module.
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Hide Lat-Lon Ticks - This option disables LatLon ticks on the Map Module.
No Internal Ticks - This option displays only the ticks inside the data limits.
Draw Lines - This option adds lines across the the LatLon Ticks.

X-Y Tab
This section controls the display of XY ticks and labels.

Compute Optimum Tick Interval From Map Scale - This option automatically
calculates and posts XY ticks on the map.
Use The Following Tick Interval - This option specifies a particular XY tick-labeling
interval in degrees, minutes, and seconds. As an example, 0-30-0 would draw and
label ticks at 30-minute intervals.

Plot Outer Ticks Only - This option suppress all XY ticks except the outer edge of
the map.
Fill Border Corresponding to XY Values - This option adds adds a filled region
between xy points. This option makes it a little easier to see the distances between
XY ticks.
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The "Fill Border Corresponding to XY Values" option disabled (left) and enabled (right)

Draw Lines Instead of Ticks - This option adds lines across the the LatLon Ticks.

Text Angle
Normal - This option draws the labels along the outer border of the map. These
labels will be horizontal along the top and bottom of the map, and vertical on the left
and right edges.
Rotated - This option draws the labels at right angles on the outer border of the
map. These labels will be vertical along the top and bottom of the map, and
horizontal on the left and right edges.

Visibility
Show XY Ticks - This option enables XY ticks on the Map Module.
Hide XY Ticks - This option disables XY ticks on the Map Module.

Sizes Tab
This section controls the sizes of the tick labels and other attributes.

© 2014

Map Module

1049

Lat-Lon Ticks - This option sets the size and style of the LatLon labels. Note that
LatLons can be displayed in Degrees Minutes Seconds, Degrees Minutes, or in
decimal degrees.
X-Y Ticks - This option sets the size and style of the XY labels. The "Label Every
Nth" option decimates the XY ticks labels to only every Nth tick.

5.25

Post IP/Formation Tests
Petra can easily post IP and formation test information on the Map Module. Note that
these IP and formation tests are in separate tools, but the two tools are very similar
and work in almost the same way.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.

IP Tests on the Map Module
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The IP and Formation Tests Items Tab

Items Tab
Fm Name Tab
Test Type Tab
Dates Tab
Style Tab
Options Tab
File Tab
5.25.1 IP/FM Test Items Tab
The Items Tab sets the specific entries on the Map Module.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.
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To add a specific test item, select the desired test item on the "Available Test Items
To Post" list, and select the ">" button.
To add all test items, select the desired test item on the "Available Test Items To
Post" list, and select the ">>" button.
To remove a specific test item, select the desired test item on the "Selected Test
Items to Post" list, and select the "<" button.
To remove all test items, select "<<" button.
5.25.2 IP/FM Test Fm Name Tab
The Fm Name Tab limits the IP or DSTs on the Map Module to specific formation
names. Tests not matching the names on this screen won't plot on the map.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.
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Use Fm Names - This option enables or disables the formation name filtering.
Search DB For Fm Names - This option adds a list of the DST or IP formation names
in the project. Selecting a name from this list will add it to the search criteria.

The "Search DB For Fm Names" option

5.25.3 IP/FM Test Type Tab
This tab limits the posted tests only specific kinds of tests.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.
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Preferred Test Only - This option only posts the tests with the "Preferred Test" flag
set on Production Test Details window available on the IP Tests Tab or the FM Test
Tab.
IP Tests Only (Post IP Tests Tool) - This option restricts the tests to only IP tests.
Any Test Type - This option does not limit the tests by type,and will plot anything.
This option is on by default.
Selected Types - This option restricts the tests on the Main Module to only the tests
with test types that match the user-entered text. Note that multiple types can be
entered.
5.25.4 IP/FM Test Dates Tab
The Items Tab sets the specific entries on the Map Module.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.
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Limit Tests to Those Within The Following Date Range - This option enables a date
restriction for the tests plotted on the Map Module. Tests not inside this range will not
plot on the Map Module.
From/To Date - These two entry boxes set the start and end dates in MM/DD/YYYY.
Limit Wells to Those Within the Following Depths (DST Only) - This option enables a
depth restriction to the DSTs plotted. Only DSTS within a specified depth range will
plot on the Map Module.
Set Depths (DST Only) - This opens the Set Depth Range tool that limits the tests to
those within a depth range set by formation tops, a constant depth range (in MD,
TVD), or a zone's interval definition.

5.25.5 IP/FM Test Style Tab
The Items Tab sets the specific entries on the Map Module.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.
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Text Position - This option sets the location of the text relative to the well symbol.
Text Size - This option sets the text size. The Post IP tool can post data in either XY
units or inches, while the Post Formation Tests Tool can only post in XY units.
Text Color - This option sets the text color. Select the box or the "..." button to open
the color dialog.

Text Justification - This option sets the location of the text relative to its position. Text
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can be to the left, right, or centered.
Font - This dropdown sets the font used for the IP of DST posting. By default, this is
set to Arial.
Gap Between Well and Posted Text - This entry sets the gap between the well and
the posted text. The Post IP tool can set this gap in either XY units or inches, while
the Post Formation Tests Tool can only set this gap in XY units.
Text Size Methods (Post IP Tests Only) - This option changes who Petra sets text
size and gaps. The Inches option will set distances and text sizes in inches, which
stay the same size regardless of zoom. The XY option, on the other hand, will keep
text and gaps at a set XY units on the map, which will scale with zoom.
5.25.6 IP/FM Test Options Tab
The Items Tab sets the specific entries on the Map Module.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.

Display Oil as MBO - This option divides the oil result by 1000 to display oil in the
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thousands of barrels.
Display as MMCF - This option divides the gas result by 1000 to display gas in the
million cubic feet.
Suppress Units - This option prevents units from displaying on the Map Module.
Suppress Name - This option prevents units from displaying on the Map Module.
Opaque Text - This option adds an opaque box immediately behind the text. This can
make the text significantly easier to read, but may obscure other map features.
Post Zero Values - By default, these tools assume that tests with zero values are
bad, so they aren't posted on the Map Module. This option forces all tests to post on
the map.
Post All Tests Matching Criteria - By default, these tools only post the first test
matching the criteria. This option forces the Map Module to post all tests.
Do Not Draw Connecting Line on Shifted Text - By default, Petra draws a dotted line
between the well symbol and shifted IP/DST text boxes. This option disables the line
between the two. This can declutter the map, but might make it difficult to connect a
test to a specific well - particularly with wells with large offsets.

Manually Shifted Text Options
Petra's default data posting can sometimes create overlapping or illegible text blocks.
This section controls how Petra handles manually shifted text sometimes plot (above,
below, left, and right) can be moved or repositioned relative to the well spot using the
mouse. To manually move data posting, select the well and click the
toolbar to reposition the data posting box.

button on the

Use Offsets From DB - This option uses the data shifting saved in the project
database.
Use Offsets File - This option uses the data offsets from the Data Offsets File
Manager.
Do Not Apply Offsets - This option disables all manual data shifting, but retains the
settings in the database. Petra will draw the data posting text boxes in the default
locations.

Automatic Overpost Resolution Mode
This tool automatically shifts data post boxes to resolve over posting conflicts.
None - This option turns off the automatic resolution, but retains the settings in the
database. Petra will return the data post boxes to their original locations.
Resolve All Overposting Automatically - This option changes all overposted data post
boxes.
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Resolve Overposting for Items Not manually Shifted - This option moves only the text
that hasn't been moved manually. This can be useful for moving the some of the text
yourself, and have Petra move the rest.

5.25.7 IP/FM Test File Tab
The File Tab restricts the tests posted on the Map Module to only those wells listed in
a WSN file, and saves the tool settings to an external file.
To open the IP Tests tool, select Options>Post IP Tests.
To open the Post Formation Tests tool, select Options>Post DSTs.

Use WSN List File - This option enables or disables the WSN file restriction.
WSN List File Name - This entry sets the location of the WSN file.

Load Template - This replaces the current settings on the Post IP Tests or Post
Formation Tests tool with the settings from an external *.IPP (for IP tests) or *.DSP
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(for DS tests) files.
Save Template -This saves the current settings on the Post IP Tests or Post
Formation Tests tool to an external file. This can be useful for switching between
several different posting settings.This s

5.26

Directional Wells - Map
Directional wells present unique challenges for mapping. Unlike vertical wells that
have a single XY location for their surface location, tops, and TD, deviated and
directional wells occupy space along a wellbore that can extend thousands of feet
away from the original surface location. Accurately spotting data on a map often
means posting data well away from the surface or bottomhole location.

Enabling Directional Wells
By default, Petra's Map Module will only display a well's surface location and bottom
hole location - both of which are connected by a straight line.
To enable directional well "work paths" which project the well's active directional
survey onto the map surface, select Wells>Directional Survey>Enabled on the menu
bar at the top of the Map Module.

Getting Started
Setting the directional well's symbol location
Displaying interval data on deviated well paths
Formation tops on deviated well paths
Adding dip-azimuth arrows on deviated well paths
5.26.1 Directional Well Symbol Location - Map

This option determines the computed location of the well symbol relative to the well's
surface location.
To set the location of the directional well symbols, select Wells Directional
Survey>Set Location Depth.

Data Tab
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Well Location Method
Maximum Survey Depth - Well symbols are spotted at the position of the deepest
survey depth.
Formation Top Depth - Wells are located at a depth defined by a formation top.
Measured Depth - Wells are located at a specified measured depth value.
True Vertical Depth - Wells are located at a specified TVD value.

Depth Parameters
This section is used to specify the location depth selected in the Well Location
Method.

Misc
The surface location can be connected to the bottom-hole location by either a
straight line of by drawing the actual survey "worm" track.
When the worm track is drawn, it can extend all the way to the maximum depth
location or stop at the well symbol.
When the Formation Top Depth Well Location Method is used, you may select to
spot the well symbol associated with the formation top instead of the normal well
symbol.

Options Tab
Do Not Drop Survey Worms For Regional Scaled Maps 5.26.2 Plotting Interval Data in the Map Module
The Map Module can show and grid interval data on deviated and horizontal wells.
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Petra can show a rectangular area with the interval’s pattern and color along the
wellbore, each interval’s marker symbol, or both. Intervals are a good way of
showing the encountered lithology, or for quickly showing the wellbore’s footage spent
in, above, or below a target stratigraphic unit.

Plotting Interval Colors
Interval colors are plotted in a filled rectangle along the wellpath. This is useful for
aerially representing continuous information in a wellbore, such as changes in
lithology, biostratigraphic assemblages, or even gas shows.
In the Map Module, select Options>Interval Data on Well Path… Select the
appropriate interval table to display from the dropdown, and select the “Plot Filled
Rectangle” option under the Interval Indicator dropdown. With this option, Petra fills
the rectangle with each interval’s color.
Filters provide more control over which intervals are displayed on the Map Module.
Intervals that do not meet the filter criteria are not displayed. To create or modify a
set of filters, select the “Set Filters…” button on the Filters tab.. For more information
on filters see the “Using Filters” section of this document.

Plotting Interval Data Markers
Interval markers are along the wellpath at the top, middle, or base of the interval.
Unlike the filled rectangle, interval markers can be plotted at a user-defined
orientation. Interval markers are useful for representing discrete markers, such as
fractures or MWD tool changes.
In the Map Module, select Options>Interval Data on Well Path… Select the
appropriate interval table to display from the dropdown, and select the “Plot Marker
Symbol” option under the Interval Indicator dropdown. Next, select the position of
each interval’s marker relative to the wellbore (middle, left, or right of the wellbore)
and the position of the marker along the interval (top, base, midpoint). Note that filters
can also be applied to the interval data; only intervals meeting the filter criteria are
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shown. In the example below, the “Fractures” interval table stores a horizontal line
marker for every interval.

To set the direction of each marker, select the Orientation Tab. Markers can be
perpendicular to the borehole, parallel to the borehole, or have a user-defined
orientation, or azimuth. This user-defined azimuth can either be a constant azimuth
for all interval markers in all wells, set for all intervals markers for each well by a zone
data item, or for each individual interval in each well by an interval data field. When
storing individual fractures in a wellbore, storing azimuth data in each interval captures
the most information and allows for each marker to have its own orientation. In the
example below, the AZI data field gives the compass azimuth for each fracture.

To set the size of each marker, select the Size Tab. The size of each marker can
either be a constant for all interval markers in all wells, set for each well by a zone, or
for each individual interval in each well by an interval data field. Note that the marker
size can either be set to use map XY units, feet, or meters. Selecting a constant size
of 0 sets a default marker size, as shown in the example below. The Marker Scale
Factor can scale the size of a zone- or interval field-defined marker by anything
between 0 and 100.
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5.26.3 Formation Tops Along Deviated Well Path - Map

Formation tops and markers can be spotted along the directional survey "worm"
path.
This option can be found under the map Wells>Directional Survey>FmTops On Well
Path menu option.
Tops are identified by an associated well symbol plotted on the survey path. The
top's position along the borehole is defined by the measured depth or subsea TVD
value of the formation top. Options are available to assign a single symbol to a top
for all wells or display the well symbol that is stored in the database with the top
value.
Formation plotting along the well path is both enabled and disabled by clicking the "
Active" check box at the bottom of the entry form.

Tops Tab
The tops tab section defines which formation tops are plotted on the deviated well
track. The "Available Tops" section contains a drop down list showing all tops
defined in the project.
Tops which are plotted must first be selected from the "Available Tops" section and
added to the "Selected Tops" list.
To select a top for display, select the top name in the drop down list, set the
appropriate symbol and color options, and click the
button to add the top the
"Selected Tops" list.
You may change the symbol or colors for a selected top. First, click the top in the
"Selected Tops" list. Then change the options in the "Available Tops" section, and
click the
button to update the top with the new values.
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Remove individual items from the "Selected Tops" list by clicking the
Clear all tops from the list by clicking the
button.

button.

Use Symbol From Data - Choose this option if you have assigned a numeric well
symbol code to the individual top values for each well.
Use This Symbol - Choose this option to plot the symbol selected from the drop
down symbol list.
Screen Symbol Color - Choose the color for the symbol drawn on the screen.
Plotter Symbol Color - Select the color for drawing the symbol on printed maps.

Options Tab
This section contains the labeling and size options. The deviated borehole path can
be labeled with the measured depth or TV subsea depth for each posted top. In
addition, the borehole path can show ticks with depth labels at a specified depth
increment.
Text Size (in) - Select or enter the height in inches for the depth labels.
Label Tops - Check this option if you want the depth for each plotted top to be
labeled.
Symbol Size (in) - Select or enter the height in inches for all well symbols marking the
position of a top.
Depth Tick Labels
"Do Not Label Depths"- No ticks and labels will be drawn along the well path except
for those labels for each top (see Label Tops option).
"Label Measured Depth Values" - The well path is labeled at specified intervals
showing measured depths down the well borehole.
"Label Subsea TVD Values" - The well path is labeled at specified intervals showing
subsea true vertical depths down the well borehole.
Depth Ticks Every - Select or enter the interval at which measured or subsea TVD
values are to be labeled along the well path. The units for the directional survey data
determine the units of this value.
Starting Depth For Ticks - Enter the minimum measured depth to limit drawing ticks
and labels along the well path. This option can be minimized over posting near well
surface locations.
Enlarge Sizes With Zoom - Select this option to have the label and symbol sizes
increased whenever you zoom in on an area.
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5.26.4 Dip-Azimuth Arrows on Deviation Path

Arrows indicating direction and magnitude of dip can be plotted along the directional
survey "worm" path.
To open this tool, select Options>Dip/Azm Arrows On Survey Path menu option.
This feature requires two digital log curves defining the dip magnitude (dip curve) and
direction (azimuth curve). Curve values must be in degrees. Arrows are drawn at
specified intervals along the survey path oriented in the direction defined by the
azimuth curve. The length of the arrows are either all the same length or proportional
to the dip curve values.
Curves - Choose the dip and azimuth curves. Set the "Use Log Curve Aliases" if the
dip or azimuth curves have been aliased.
Arrows - Options are available to set the arrow line length and arrow head size.
These sizes are specified in map xy coordinates, i.e., feet or meters. When the "
Proportional" option is checked, the arrow line length represents the maximum arrow
length, i.e., 90 degree dip. Values with dips less than 90 degrees will have arrows
proportionally shorter than the maximum. For example, a dip of 30 degrees will have
an arrow that is 1/3 as long as the specified length.
Dip Labels - Optionally, you can post the dip magnitude. The dip is posted at the end
of the arrow head at a height specified in map xy units.
Depth Increment - Arrows are placed along the survey path at a specified interval.
This interval is given in curve depth units. For example, an increment of 100 would
place arrows at 100ft (mtr) measured depth intervals along the survey path.
No. of Samples to Average - This feature allows the arrows and dip labels to
represent averages of several values. For example, given a depth increment of 100
and an average value of 100, then the arrows plotted at 100ft increments would be
the average of 50 samples above and 50 samples below the depth being posted.
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Popup Menu Data Selection
The Map Module can add user-selected well header or zone data item to a "User
Favorites" pop-up menu on the right mouse button.
To change the User Favorites, right-click on a well symbol on the Map Module, and
select User Favorites>Select.
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A User Favorites display with two formation tops (left), and the Well Data Selection Tool (right)

Selected Data Items
This list box displays all data items currently selected for popup menu display. To
add an item to the Selected Data Items list, select the desired well header data or
zone data item and select the "Add" button. To replace an item on the Selected
Data Items list, highlight both the item on the Selected Data Items list and desired
header or zone data item, and then select the "Replace" button. To remove a single
item from the Selected Data Items list, select the item then click the ">" button. To
remove all items, select the ">>" button.
The items on the User Favorites dropdown are listed in top to bottom display order.
The order of an item can be changed by selecting the item then clicking the up
down

or

arrow to move the item relative to the other items.

Well Header Data - Items are added to the popup menu by selecting the data from
one of the two groups from the "Select Data Items" and clicking the Add button.
Well Header Data - This dropdown contains well header information such as UWI,
well name, operator, locations, etc.
Zone Data Item - This dropdown contains zone data in the project. This also
includes formation tops under the "FMTOPS" zone.
TVD Subsea Top - By default, the dropdown displays measure depth values for
tops. This option instead displays TVD subsea values on the dropdown. Tops can
be displayed as either measured or subsea depth.
Load/Save - Frequently used lists of data items can be saved to disk for future use.
Click the Save button and specify the file name to save the list into. Use the Load
button to reload the saved list.
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Boundary Polygons - Creating A 9-Section Plat
The following illustrates the procedure to select an area containing only 9 sections
and limiting data to only plot inside the 9-section plat.
1) Original map area limits showing 9-section plat area (in red).

2) Overlay menu showing option to select a "boundary polygon"
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3) Select "9 section" area using a rectangle. You must include ALL points of the
sections to be included.
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After selecting the rectangle, the 9-section polygon area is outlined in red and you
are given the option to keep it or not. If you keep the polygon, you are prompted to
save the polygon to a "boundary polygon (.PLG) file and the map in #4 below is
redraw.
4) Resultant "clipped" 9-section map area.

5) Since the 9-section polygon is saved in a "boundary polygon" (.PLG) file, you may
reload the boundary polygon at any time using the "Display>Set Limits Using
Boundary Polygon..." option
6) The outline of the boundary polygon is drawn using the color settings under
"Display>Colors" and item
called "Map Boundary Polygon"
ALTERNATE METHOD: Drawing a polygon and using it as a "boundary polygon"
1) Original map showing drawn polygon area (red dashed line)
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2) Select the polygon and use the Overlay menu to save the polygon to a boundary
polygon file.
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3) Load the boundary polygon file using the "Display>Set Limits Using Boundary
Polygon..." option
Note - you'll want to turn off the original polygon so it is not partially clipped by the
boundary polygon.

5.29

Production Patterns - Map
Petra can automatically draw Production Patterns around groups of wells defining
injector-producer patterns. Each pattern consists of a central "node" well and one of
more surrounding wells. Each well in a pattern contains the percentage of
production allocated to the pattern. Wells that belong to more than one pattern will
have less than 100 percent allocated to each pattern. An "auto allocation" function
can be used to compute the allocations based on sharing between patterns or angles
around wells.
Probably the easiest way to use production patterns is to use the toolbar. To open
the toolbar, select Tools>Production Patterns>Pattern Tool Bar on the top of the
Map Module. Alternatively, select Tools>Production Patterns> to select individual
tools.
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or Add Pattern - This option starts the process of defining a new pattern of wells
to the production pattern list. After choosing "add pattern", first click the left mouse
button on the central NODE well. Then, left-click each well that is part of the pattern.
Finally, click the right mouse button to end. A pattern definition screen will be
displayed so you may set the percent allocations (100% by default).
or Select Pattern - Use this option to select a pattern by clicking the left mouse
button on the NODE well. After selection, the pattern will be highlighted in green.
Once highlighted, the pattern can be modified (with the pattern properties option) or
deleted (with the trash can button).
or Deselect Pattern - This option deselects a highlighted pattern.
or Pattern Properties - This option opens the Prod Pattern Definition tool (see
below), which can view or modify the pattern's well list and production allocation.
or Delete Pattern - This option removes the selected pattern. Note that Petra
will ask for a verification will be prompted to verify that you want to delete the
selected pattern.
or Clear All Patterns - All patterns will be removed from memory. Be sure to
save a pattern file if you wish to retain the patterns.
or Load Pattern File - Use this option to reload a saves production pattern file (*.
PAT).
or Save Pattern File - This option will save the production patterns to a file for
later retrieval (*.PAT).
or Create Pattern Polygons - This function uses the wells in the patterns to
construct and store closed polygons in the map overlay facility. These polygons can
then be used for volumetrics.
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Compute Pattern Volumes - This function computes a monthly production stream that
is the summation of all wells in a pattern, multiplied by the appropriate allocation
percentage. The resulting "allocated" production stream is stored in the NODE well.
Pattern Tool Bar - This function enables a small floating tool bar containing quick
buttons for adding, selecting, deleting, etc. production patterns.

Prod Pattern Definition Tool
The Prod Pattern Definition tool sets the well's pattern name, wells, and allocations.

Pattern Name - Each pattern has its own name. By default, Petra sequentially
names patterns as P1, P2, P3, and on.
Pattern Wells - This list displays the wells in the pattern. Note that the pattern's
node well has a "<<<NODE" annotation.
This Is the Node Well - This entry sets the node well in the pattern.
Allocation - This entry changes the allocation for the well selected on the Pattern
Wells List. Select the well, set the allocation percentage, and select the "Apply"
button.
Drop Well - This button removes the well selected on the Pattern Wells List
Add Well - This option adds a well by the well's UWI/API number.
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Allocating Production
Auto Allocate Production - This tool computes the allocation percentage for wells in
multiple patterns. This tool will compute the percentages between all patterns in the
project.

Method 1
Petra sets the percentages for each well by the number of shared patterns. If a well
is common to two patterns, the well's allocation percentage is 50% for each of the
two patterns.

Method 2
This tool computes the angles formed by a well and its nearest neighbors in the
pattern. The allocation percentage is the angle divided by 360.
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Displaying Cross-Sections - Map
The Map Module can display cross-section lines.

Show Current Section on Map
This option displays the current cross section in the Cross Section Module. As the
cross section changes, so will the outline on the map. To enable or disable this
display, select CrosSection>Display Current Section on Map on the menu bar at the
top of the Map Module.

Show Selected Sections
This option displays the outlines of multiple saved cross sections. In contrast to the
"Show Current Section on Map" tool, this only displays the outlines of *.CSP files,
though it has more options.
To enable or disable this display, select CrosSection>Display Selected Cross-Section
on Map on the menu bar at the top of the Map Module.
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Available Cross Section List
This list displays the available saved cross-section line files (*.CSP). By default, this
tool will look in the user's Parms directory. To change the directory, select the
"Browse" button and navigate to the location of other cross section files.
Add - This button adds the currently selected cross section file or files to the
"Selected Cross-Section Lines" list. Only files on the "Selected Cross-Section Lines"
list will be displayed.
Drop - This button drops the currently selected cross section file or files from the
"Selected cross-Section Lines" list.
Clear - This button drops all cross section files from the "Selected Cross-Section
Lines" list.

Selected Cross-Section Lines
The Selected Cross-Section Lines list displays the cross section that will be displayed
on the map module. Selecting a cross section here also allows the specific properties
below to be changed.

Properties
Start Label - This entry sets a label at the start of the cross section selected on the
Selected Cross-Section Lines list. This can be useful for A to A' type labels.
End Label - This entry seta the label at the end of the cross section.
Color - This option changes the color of the cross section line displayed on the map.
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Label Size - This option changes the size of the start and end labels at the edges of
the cross section line. Note that this is in XY units, and will change with zoom.
Label Gap - This option changes the size of the gap between the label and the edges
of the cross section line. Note that this is in XY units, and will change with zoom.
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Cross-Section Module
The Cross-Section Module displays a profile view of a selected set of wells,
generally with some combination of wireline log data, formation tops, and completion
data. These cross sections demonstrate structural or stratigraphic relationships, and
illustrate reservoir attributes.
To open the Cross-Section Module,select the
button on the Main Module toolbar,
or select Tools>Cross-Section on the menu bar at the top of the Main Module. This
tool is also commonly opened directly from the Map Module whenever wells are
selected for a cross-section.
For pure top picking, the Log Correlation Tool provides a streamlined interface with
fewer plotting and display options. As another alternative, the Slip Log Module
displays and pick tops on up to four horizontal raster logs.

Getting Started
Basics
Selecting Wells for the Cross Section
Changing the Spacing Between Wells
Setting a Depth Range

Logs and Tops
Displaying Digital Logs
Displaying Raster Logs
Displaying Formation Tops
Correlating Formation Tops
Adding a Correlation Slip Box

Annotations and Data Posting
Posting Well Data around the Well Symbols
Adding Annotations, Images, and Faults with the Overlay
Plotting Perfs, Tests, Cores, and Shows
Plotting Interval Data

Basic Shortcuts and Key Definitions
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Highlighting a well - single click on the well's depth track with the left mouse button
Displaying information about the well in the map module - single click on the well's
depth track with the right mouse button.
Show the data for a selected well in the main module - double-click on the well's
depth track with the left mouse button
While correlating tops, set a well's top value to a null value - Delete
Terminating interactive process such as screen drawing or zooming - hit ESC
During screen drawing, skip to next graphic element - Space Bar
Drop the last point picked while drawing an overlay line - Delete
Drop the last well picked while picking wells for a cross-section - Delete
Delete a selected overlay item - Use the trash can icon on the toolbar.
Scroll map during zoom mode - Shift + Arrow Keys.

Advanced Tools
Using Unassigned Tops
Adding a Color Fill between Digital Logs
Adding a Grid Profile

6.1

Selecting Cross-Section Wells
The cross Section Module can select wells in two ways: from a list, or from the Map
Module

Select Wells From List
The Cross-Section Module can only use a list to select wells. To open this tool,
select Wells>Select Wells>From a List... from the menu bar at the top of the CrossSection Module.
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Selecting wells from a list

The “Available Wells” list on the left shows the currently selected wells in the module,
which can be sorted by WSN, UWI/API, well name and number, or label. The “Wells
Selected for Cross Section” list on the right shows wells currently displayed on the
Cross Section Module. To add a well to the cross section, highlight a well from the
“Available Wells” list and select the “>” button to move the well to the “Wells Selected
For Cross Section” list. The well at the top of this list is plotted on the far left side fo
the cross section, while successive wells plot to the right. Removing a well from a
cross section is similar – select the well on the “Wells Selected For Cross Section” list
on the right and select the “<” button to drop the well from the list. Selecting the “<<”
button drops all wells from the Cross Section Module.
Since wells are arranged by header information instead of by geography, this can be
a fairly tedious way of creating a cross section of geographically proximal wells. The
real advantage of using the list selection method is that it’s a fairly straightforward
way to add or subtract wells, or to move the order of wells around in an existing cross
section. Selecting the
and
buttons change the position of a selected well on
the “Wells Selected for Cross Section” list. Again, wells at the top of the list plot on
the left side of a cross section, while those on the bottom plot to the right side.

From the Map Module
The Map Module is usually a great way of selecting the wells for a cross section.
This option graphically picks the wells for the cross section in a couple of different
ways.
From inside the Cross-Section module, select Wells>Select>Switch to Mapping Tool
from the menu bar at the top of the Cross-Section Module. This will switch to the
Map Module.
From inside the Map Module, select, CrossSection> and the relevent method from the
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menu bar at the top of the screen.

Selecting the wells for a cross section with the Map Module

Well-to-Well
The well-to-well option is probably the most common way to generate a cross
section. To select a well-to-well cross section select the
icon on the tool bar at
the top of the screen. Alternatively, select CrossSection>Well-To-Well… from the
menu bar at the top of the screen. Selecting this option changes the mouse pointer to
a crosshair. Next, simply left-click on the first wellspot on the map to add it to the
cross section. Left-click on more wells to add them to the cross section. After
selecting all the desired wells, right-click to finish and jump to the Cross-Section
module.

Single Well Display
The single well display works very similarly to the well-to-well option. Select
CrossSection>Single Well Display from the menu bar at the top of the screen. Simply
left-click on the well, and the Cross-Section Module will show that single well. This
option is also available from the Main Module at Logs>Single Well Cross Section… In
the main module, the cross section will show the currently selected well.
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Selecting a single well cross section from the Main Module

Line and Corridor
A well-to-well cross section zig-zags from well to well, so the cross section is never
actually straight. The Line & Corridor selection option allows the user to define the
“line” of the cross section as well as a “corridor.” All visible wells in the Map Module
falling inside this corridor will be projected onto the line at a right angle.
To create a Line and Corridor cross section, first draw a line by left-clicking at the
start and end of the cross section. Next, click at some distance perpendicular to the
line to define a corridor. In the example below, the corridor extends above and below
the cross section line by about 1000’. To finish the cross section, right click the
mouse. All visible wells within the corridor will be projected onto the cross section. It’s
worth remembering that all visible wells within the corridor will be projected onto the
cross section, including wells without tops or logs. In projects where recompletions
are stored as a separate well (usually with an API ending with 0001), these
recompletion wells will be projected into the cross section as well.
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Drawing a line for the cross section (Left). Setting the upper boundary of the corridor (Right)
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Setting the lower boundary of the corridor (Left). The completed Line and Corridor cross section (Right)

By default, the Line and Corridor method projects wells into the cross section at right
angles. Notice that each projection line has a small rectangle, or “node” where it
touches the cross section line. Moving this node changes where a well is projected
into the cross section. Select CrossSection > Move Line Node Projections or Ctrl N,
and then select the desired line node. Dragging this line node to a new position can
change the position or even order of the well on the cross section.

Moving the projection nodes (Left). The cross section with moved nodes (Right).
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Width and Margins
The Cross Section Size Options tool sets the cross section width, margins, and well
spacing.
To open the Cross Section Size Options window, select Scales>Width and Margins
from the menu bar at the top of the Cross Section Module, or select the
on the toolbar.

button

Width Tab
The Width Tab sets how spaces wells on the cross section. The primary difference
is whether wells are regularly spaced, or spaced relative to their actual distance on a
map.

The Cross Section Size Options Width Tab

Set Width - This option sets the total width of the cross section from the left well
symbol to the right well symbol. This option is only available for the "Relative to Well
XY Locations (between Well Symbols)", "Relative to Well XY Locations (Between
Tracks)", and "Constant Distance Between Well Smbols (in Inches)" spacing options.
Deviated wells may be wider than the specified length if any bore hole deviates
beyond the left or rightmost well.
Set Distance Btwn Wells - This option sets the distance between well symbols or
track edges. This option is only available when the "constant distance" spacing
modes are selected.
Auto size single well cross section - This option displays single well cross section in
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the center of the cross section. In more detail, this option automatically sets the
cross section length to 1.0 inches when there is only 1 well selected.

Well Spacing Mode
This determines how wells are positioned along the cross section.
Relative to Well XY Location (Between Well Symbols) - This option spaces out the
wells on the cross section proportional to their distances between one another. With
this option, Petra plots this data relative to the well symbol, so closely spaced wells
on the cross section can overplot.
Relative to Well XY Location (Between Tracks) - This option spaces out the wells on
the cross section proportional to their distances between one another. With this
option, Petra plots this data relative to the edges of the well tracks, so closely
spaced wells will not overplot.
Constant Distance Between Well Symbols (in Inches) - This option sets a constant
distance between different well symbols. With multiple log tracks, well data can
overprint.
Constant Distance Between Well Track Edges (In Inches) - This option sets a
constant distance between well track edges. This prevents well data from
overposting, but can make it more difficult to visualize structural changes between
wells.

Margins Tab
The Margins leave blank space around the cross section. Margins are measured in
inches.
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The Cross Section Size Options Margins Tab

Show Margins on Screen - This option draws a dashed box on the screen to show
the extents of the margins. Overlay items not inside this box will not plot.

Misc Tab
The Misc Tab controls a few additional option on how Petra draws and rescales the
cross section.

The Cross Section Size Options Misc Tab

Screen Scroll Percentage - This option controls how the the screen shifts when the
scroll arrows are selected. The range is the percentage of the screen that remains the default value of .75 scrolls 75% of the screen so that only 25% of the original
screen remains.
Horiz Scale Text Size - This option sets the size of the horizontal scale text.
Overpost Resolution - This option sets the upper limits for Petra overpost resolution
function.
Section End Labels - label the left and right side of the cross-section with
annotations, such as, A and A'.
Do Not Plot Border - This option prevents Petra from drawing the border around the
cross section.
Do Not Plot Heading Title - This option prevents Petra from drawing the heading title
on the top of the cross-section.
Angle for Deviated Borehole Projection of Single Well Display - the angle (in
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degrees) of a plane-of-projection for "single well" cross-sections. It controls the
direction the deviated borehole deflects away from the well location.

6.3

Posted Data - Cross Section
The Cross-Section Module can post well header or other zone data items around the
well symbols at the top of the cross section.
To add data posting around the well symbols, select Options>Data Posting... on the
menu bar at the top of the Cross-Section Module.
Note that an abbreviated, simpler version of this tool is available in the Well Symbol
Style menu.

Data Tab
The Data Tab sets the items to display, as well as the details on the size, font, and
color of each item.

Available/Selected Data Items
Posted data items are chosen from either the "Well Header Items" or "Zone Data
Items" lists. Click the appropriate

button beside the item list to add the item to

the "Selected Data Items" list. Remove individual selected items by clicking the
button or remove all selected items using the
button. Reposition selected items
using the up

button or the down

bottom.

Data Item Properties
Each posted data item contains posting attributes including the position relative to the
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well symbol, text color and size, number of numeric decimal places and how the
value is labeled. Additional attributes can be set for formation tops including whether
to use alias names and whether to post subsea values. All Z values can have the
"quality" code posted following the value.
Position - Text items can be posted in four positions around the well spot. Select the
position to place the text item Above, Below, Left or Right of the well symbol on the
cross section.
Label Style - Several labeling styles are provided and control whether variable
names are posted along with the value.
Font - Each line item can have a font specified from the font list.
Text Size - This section sets the text height for the selected data item in inches. Text
will enlarge slightly when you zoom in if the "Enlarge With Zoom" option is selected.
Click the ALL button to set all text to the same height.
Decimals - Set the number of decimal places to the right of the decimal point for
numeric values. Whole numbers will still post as integer numbers. Only values with
fractional parts will show the number of specified decimals.
Text Color - Each text line item can be plotted in a different color. Choose from the
palette provided by clicking on the color cell. Click the ALL button to set all text to the
same color.

Post Subsea Top - Use the option when posting formation tops and you want to see
subsea values. Subsea values are computed as: SS=Datum-Top.
Use Top Aliases - If you have defined formation top aliases, use this option to have
the aliases searched for when posting a value.
Post Quality Code - Check this option to have the quality code posted following a
zone data or top item. Null values will show only the quality code.
Post Units - This option causes the units value to be posted following the zone or top
value.
Truncate to 1st Word - This option truncates the data to only the first word.
No Commas - This option removes commas from the line.

Active - When the "Active" option is checked, data will be posted by each well.
Uncheck the option to disable data posting.
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Options Tab
The Options Tab controls a few additional options for data posting.

Enlarge With Zoom - By default, the Cross-Section module keeps text the same size
regardless of zoom. This option proportionally enlarges text when you zoom in.
Drop Missing Data Lines - This option suppresses blank data lines due to missing
data. Blank lines added as data lines are not suppressed.
Opaque Text - Check this option for posting text with an opaque background.
Opaque text is useful when posting over color-filled contours.
Drop Source Code From Labels - This option suppresses the display of the source
portion of the item name when the Label Style includes the name.
Always Show SSTVD as SS - This option forces Petra to always display SSTVD
values as SS values.

Gap Btwn Well And Data - Enter the number of inches to leave as a gap between
the well symbol and the posted data items.
Line Spacing (inch) - Enter the number of inches to separate each posted text line.
Global Scale Factor - Enter a multiplying scale factor greater than 1.0 to enlarge all
text or less than 1.0 but greater than 0.0 to reduce the text.
Display Dates As - This dropdown changes how the data posting displays dates.

Load/Save Settings - These buttons save and load the settings on the Posting Data
tool to an external *.DBW file.
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Sample Tab
The Sample Tab displays a sample wellspot with the data fields selected on the
Data Tab. This can be useful for quickly determining how Petra will actually print the
data posting onto a plotter.

6.3.1

Post Data At Depth

Well data can be posted at specific depths next to the log tracks on a cross-section.
This option is located under the "Wells>Post Data at Depth..." menu.
This feature allows you to post any data stored in the tops or zone tables at a depth
defined by either a top, a zone or constant depth. Figure 1, below, shows an
example of two text boxes posted with different data for each box. The yellow box
contains a title and 3 data items while the pink box contains one data item and no
title. The yellow box has been depth referenced to the DSAND zone while the pink
box references formation top 602DKOTJ.
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Portion of cross-section showing data posted at depth

Figure 2a and 2b, below, show the dialog screen settings for the yellow box in the
cross-section displayed above.

Figure 2a - Data at Depth Dialog Screen Showing Box Properties

© 2014

Cross-Section Module

1095

Figure 2b - Data at Depth Dialog Screen Showing Data Item Properties

How To Create and Define a Data Box
1) Add New Box
Create a new data box by clicking the small "+" icon located at the top of the "text
boxes" list.

2) Set Depth Reference
Set the Depth Reference section to define at what depth you want the text plotted.
This can be either a formation top, a zone definition, or a constant measured depth.
When a zone is used as a reference, an additional parameter is provided to specify
whether the box is placed at the top, mid-point or base of the zone interval. This
example uses the mid-point of the DSAND zone. Please note that a box will not be
plotted if either the reference top is missing or a referenced zone's top or base is
missing. It should also be noted that only zones which are defined based on
formation tops should be used as a reference. For example, you should not use a
zone similar to the "well" zone as a reference.
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3) Set Box Properties
Set the box Title, Style and WSN List properties.
Title - This is optional

Style - Choose the box type, colors, and placement. The box vertical placement
defines how the box will be connected to the reference depth. The box can be
positioned to the left or right of the log tracks.

WSN List - This option allows you to restrict which wells have this box posted. You
must provide a "wsn list" file containing a list of wells. If the cross-section well is in
this list, then, and only then, will the data be posted.
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4) Choose Text Items
Begin by selecting a data item from the Zone and Zone Item lists. Then click the "+"
icon to add the item to the "Data Items in Box" list.

Next, set the data item Options and Style
Options - Miscellaneous posting options for a specific data item.

Style - How the text appears cosmetically.
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Limits -

Maximum Number of Boxes is 64
Maximum Data Items per Box is 32
Maximum Title Length is 40 Characters

6.4

Depth Scale - Cross Section
The Cross-Section Depths window controls how Petra displays well depths. This
includes setting cross sections as structural or stratigraphic, setting the vertical depth
scale and interval range.
To open the Cross-Section Depths window, select Depths-Depth Scale... from the
menu at the top of the Cross-Section Module, or the

button on the toolbar.

General Tab
The General Tab sets most of the basics of the Cross-Section's depths.
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The Cross-Section Depths General Tab

Cross-Section Type
The cross-section type can be either "Structure" or "Stratigraphic". A structural
cross-section has a depth interval defined by upper and lower measured or subdatum depths. A stratigraphic section has depths defined using formation tops. The
upper top is treated as the relative datum and appears as a "flattened" surface.

Depth Axis Options
Show Depth Track - This option plots depths and depth ticks inside the depth track.
Label Deviated Borehole - This option labels deviated wellbores.
Depth Track on Deviated Boreholes - This option adds a MD depth track for deviated
wellbores.
Round Depth Labels to Whole Nbrs - This option rounds depth labels to the nearest
whole number rather than leaving a decimal.
Show Depths on Section Ends - This option displays depth ticks at the left and right
edges of the cross section. For structural cross sections, these values will be in the
depth range selected on the "Structure Depths" tab. For stratigraphic cross
sections, these values will reflect the distance in feet or meters away from the top
defining the upper depth limit.
Limit Depths By T.D. - This option prevents well tracks and data from plotting below
the well's TD specified on the Main Module's Wells Tab. This can be useful for more
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accurately visualizing the depths penetrated by each well.
Limi Depths By Datum Elev. - This option prevents well tracks and data from plotting
above the well's datum elevation specified on the Main Module's Wells Tab. This can
be useful for more accurately visualizing the surface elevation for each well.
No Depth Label Ticks - This option prevents depth label ticks inside the depth track.

Single/Dual Label(s) in Depth Track - The "Single Label" option displays only the
label specified in the "Depth Grid Lines Multiples of" option in the depth track (MD or
SSTVD). The "Dual Labels" option displays both MD and SSTVD labels.
Track Width (inches) - This option sets the width of the depth track.
Track Text Size - This option sets the size of the depth track labels.
Section End Label Size - This option sets the size of the depth labels on the left and
right edges of the cross section.
Vertical/Horizontal Text - This option specifies whether the depth labels inside the
depth track are vertical or horizontal. Most users will find horizontal text too
cluttered.
Label Format - This dropdown specifies how Petra plots depth labels. Options
include simple numbers, a comma delimiting units of 1,000, and the addition of a " ' "
for feet or "m" for meters.
# of Decimals - This dropdown selects the number of decimals in the depth labels.

Log Curve Sample Decimation
This option decimates log curves. A value of 1 plots all log samples in the depth
interval, while a "2" plots every other sample and "3" plots every third sample. This
can be useful for reducing the jittery character of greatly compressed log curves.

Depth Grid Lines Multiples of
This option changes how Petra displays depth grid lines. With the MD option
selected, the "Single Label in Depth Track" will display only MD. With the SSTVD
option selected, the "Single Label in Depth Track" will display only SSTVD.

Depth Scale Tab
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The Cross-Section Depths Depth Scale Tab

Depth Scale - This option sets the vertical exaggeration of the cross section. Note
that the scale can be set in either imperial or metric units.

Depth Axis Tick & Grid Interval
These options set how Petra draws major and minor grid lines on the track grid or
ticks on the depth track.
Compute Optimum Using Depth Scale Above - This option attempts to automatically
calculate reasonable major and minor grid lines. This is a good default option for
most users.
Use These Settings - This option instead draws major and minor lines based on user
settings.

Structure Depths Tab
This tab sets the depth interval when the "Structure" depth type is selected on the
General Tab.
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The Cross-Section Depths Structure Depths Tab

Upper Depth - This option sets the upper depth for the cross section. These values
can be in MD, TVD, or SS.
Lower Depth - This option sets the lower depth for the cross section. These values
can be in MD, TVD, or SS.
Depth Type - This option sets the type of the depths in the Upper and Lower Depth
fields. MD and TVD will increase from the datum, while SS will be relative to sea
level.
Use These Depths to Position Deviated Wells along the Cross-Section - This option
adjusts the position of directional and deviated wells to produce a more accurate
portrayal of the wellbore.
Compute Using Tops - This option selects a depth range that will display all the the
currently displayed formation tops.
Compute Using Logs - This option selects a depth range that will display all the the
currently displayed digital logs.

Stratigraphic Depths Tab
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This tab sets the depth interval when the "Stratigraphic" depth type is selected on the
General Tab.

The Cross-Section Depths Stratigraphic Depths Tab

This tab sets the depth interval when the "Stratigraphic" option is selected on the the
General Tab. Select the formation tops which define the upper and lower depth.
Note that an offset entered in depth units extend the cross section above, or trim the
cross section below the selected top. In the example above, the cross section will
extend 50' above the A formation, and 250 below the B formation.
Use These Depths to Position Deviated Wells along the Cross-Section - This option
adjusts the position of directional and deviated wells to produce a more accurate
portrayal of the wellbore.
Correct Section for Fault Cut Gaps - This option will use the fault cuts in the
database to attempt to correct for missing section on the stratigraphic cross section.

Grid Lines Tab
The Grid Lines Tab adds vertical lines and horizontal lines across the cross section.
These lines can make it easier to visualize depths and the distance between wells.
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The Cross-Section Depths Grid Lines Tab

Depth Grid - This option draws horizontal lines across the cross section using the
"Major" settings set on the Depth Scale Tab.
Include Minor Depth Grid Lines - This option draws horizontal lines across the cross
section using the "Minor" settings set on the Depth Scale Tab.

Horizontal Grid
This option draws vertical lines between the wells to signify distances between
wellbores in XY units. Note that these lines will only make sense with a well spacing
that's relative to XY Location.
No Grid - This option does not draw any vertical lines.
Grid Ticks Only - This option draws only ticks along the bottom of the cross section.
Grid Lines - This option draws full vertical lines extending from the bottom of the
cross section to the top.
Grid Interval - This option sets the interval of the horizontal grid lines. Setting this
entry to 1000 will draw vertical lines every 1000 XY map units (feet or meters)
Select Well Userd as Origin of Grid - This dropdown selects the origin, or 0, of the
vertical lines. By default, Petra selects well on the far left as the origin.

© 2014

Cross-Section Module

1105

Auto Flatten Tab
The Auto Flatten Tab controls how Petra creates stratigraphic cross sections from
the "Flatten on..." command when right clicking on a top.

The Cross-Section Depths Auto Flatten Tab

Adjust Depths to Show All Displayed Tops - This option automatically creates a
depth range that displays all selected tops.
Adjust Depths Using Offsets From Flattened Top - This option uses the selected
offsets above and below the top.

6.5

Digital Log Display Options
The Logs Display Options window controls how log curves are displayed on the
cross-section. Options are provided for defining the log scales, color and line style
and shading criteria.
For a detailed walkthrough on using these options on a variety of log curve types, see
"How To Display Digital Log Curves."
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To open the Log Display Options window, select Logs>Display Options from the
menubar at the top of the Cross Section Module. Alternatively , select the
on the toolbar at the top of the screen.

button

Scale Tab
Style Tab
Cutoff Tab
GeoColumn Tab
Tracks Tab
Misc Tab
Cross Over Tab
Lith Sum Tab

The Scale Tab with logs added to the "Selected Logs" list

Available Logs List
The available logs list shows the digital log curves in the project.
All Wells - This option lists all curves for all wells in the project.
Selected Wells Only - This option lists only the curves for the wells currently selected
on the cross section.
Show Aliased Curves Only - This option only shows curves that have been aliased.
Using log aliases can greatly simplify the process of making a good template that will
work for many wells.

Selected Logs List
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The Cross Section Module only displays the logs on the Selected Logs list.
To add a log to the Selected Logs list, select the desired log on the Available Logs list
and left click the ">" button.
To drop a log from the Selected Logs list, select the desired log on the Selected Logs
list and left click the "<" button. To drop all logs from the Selected Logs list, left click
the "<<" button.

Color and Shading Indicators
Plain Line Color - Curves with no shading have a plain rectangle with the curve's color.
As an example,
indicates that the SP curve is a plain red line.
Cutoff Shading - Curves with cutoff shading have a split rectangle. The left half of the
rectangle indicates the color of the line, while the right half indicates the color of the
cutoff fill. As an example,
indicates that the ILD curve has a black line with
blue cutoff fill.
GeoColumn Shading - Curves with GeoColumn shading have an empty white
rectangle. As an example,
indicates that the GR curve has a GeoColumn
Shading pattern.
In the example below, the SP and %_Shale curves are plain lines - the SP curve is
red, while the %_Shale is black.The GR curve's plain box indicates a GeoColumn
shading. The ILD and %_Sand's boxes indicate cutoff shading - the ILD curve has a
black line with a blue cutoff fill, and the %_Sand curve has a black line with a yellow
cutoff fill.

The Left Rectangle indicates the color and shading of the log curve.

Track Indicators
The rectangle to the right of the curve name indicates the curve's track, or position
relative to the well symbol. In the example below, the GR and SP curves are in track
1, the ILD curve is in track 2, the NPHI and DPHI curves are in track 3, and the %
_Sand and %_Shale curves are in track 4.
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Every track has a given color (left). The right rectangle on the Selected Logs List indicates the curve's track (right)

6.5.1

Log Display Scale Tab
The scale tab is primarily used to add logs to to the cross section, and to set the logs'
scales and position around the wellbore. Note that changing the settings only applies
to the highlighted log on the Selected Logs list.

The Scale Tab with logs added to the "Selected Logs" list

Track - This entry specifies the position of the log relative to the depth axis. Refer to
the "Tracks" tab to track details.
Label - This entry sets the header for the log curve. By default, Petra will use the
curve name.
Left Scale - This option sets the log value for the left side of the log scale.
Right Scale - This option sets the log value for the right side of the log scale.
Logarithmic Scale - This option plots the selected log with using a logarithmic scale.
The left and right scales should be entered as powers of 10 when using this option.
Note that anything with a "0" scale will disable the logarithmic option.
Disabled - This option temporarily hides the log trace from the display. Disabling a
curve retains the settings.
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Use Alias Logs - This option uses log curve aliases when the the selected curve is
absent. Disabling this option will force petra to only use the exact curve name.
Suppress Track Header - This option hides the log curve headers at the top of each
track.

Default Log Scale - This option will set the left and right scales to the curve's default
log scale. Note that this is set on the Log Maintenance Tool or with the Save Default
Scale button below.
Save Default Scale - This option sets the log curve's default scale to the current
settings on the Left and Right scale entries.
Statistical Default Scale - This option automatically fills in the left and right scale
values using the statistical average from the logs of the current cross-section wells.
Values are computed as 2 standard deviations from the mean. The logarithmic option
is set if the minimum value is positive and the different of the maximum and minimum
exceeds 500.
6.5.2

Log Display Style Tab

Style Tab
The color and style tab defines the appearance of the log trace highlighted on the
"Selected Lots" list. This tab will change slightly with different shading methods.
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The Style Tab with No Shading selected (Left) and with Cutoff Shading (Right)

Shading Method
This section sets how Petra draws log curves.
No Shading - This option just draws a plain line using the Line Color selected on the
lower right corner of the Style Tab..
Shade Using Cutoff - This option fills in the log curve whenever it is above or below a
user-specified cutoff value. Selecting this option displays the Cutoff Tab, which sets
the cutoff value and color scheme.
Geocolumn Shading - This option fills the curve using a colorbar from a log curve.
Note that geocolumn shading can color the the selected log trace using values from
another log curve. This option can be used to plot a litho-column type display.
Proceed to the "GeoColumn Tab" to set the geocolumn shading options.

Misc Plotting Style
Clip Log At Track Edges - This option truncates the log outside the track boundaries
when the log is outside the range defined by the left and right scale.
Center Log Trace In Track - This option removes the mean value of the displayed log
trace resulting in the log plotting in the center of the log track.
Discrete Points - This option displays the log as a series of small x's instead of a
continuous line. This is useful for displaying non-wireline data, such as sidewall core
porosity values.
Pay Flag Curve - This option displays the log curve as a "step" function, which can be
very useful when plotting pay flag curves.
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A 0-1 "Flag" Curve with the default plotting (Left) and with the "Pay Flag Curve" option selected (Right)

Labeled Spikes - This option displays the log curve as a series of horizontal lines with
optional value labels at the end of the spikes. Spikes begin at the minimum valued side
of the track and extend toward the maximum valued side. The label size can be set on
the "Misc" tab screen. A size of zero suppresses the labels.

Line Style - This dropdown sets the the log curve's pattern. This can include solid
lines, and various combinations of dashes and dots.
Line Width - This dropdown sets the line width for the log trace. Note that the widths
of the user-set lines (User 1, User 2, etc) are set on the Petra Program Options' Font/
Graphics Tab
Line Color - This box sets the color of the selected curve. Note that this box is
avalable only when the "No Shading" shading method is selected.
6.5.3

Log Display Cutoff Tab
The Cutoff Tab controls how a log is shaded relative to a cutoff value. This tab sets
the color for the log trace as well as the cutoff shading underneath the log trace.
This tab is enabled when the highlighted log on the Selected Logs list is using the
"Shade Using Cutoff" option.
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The Cutoff Tab

Shade
The shade section sets how the cutoff shading works relative to the cutoff value.
Less Than Cutoff - This option shades the area of the curve wherever the log values
are below the cutoff value.
Greater Than Cutoff - This option shades the curve wherever the log values are above
the cutoff value.

"Less than Cutoff" (Left) and "Greater than Cutoff" (Right) shading options, with a 200 constant cutoff

Cutoff
The cutoff section sets the specific cutoff for the selected log curve.
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Constant Cutoff - This option sets a specific, constant cutoff value.
Statistical Cutoff - This option sets a option provides a variable cutoff based on the
mean log value and standard deviation. The cutoff value is entered as the number of
standard deviations above the mean. The equation used is:
CUTOFF = MEAN + (SD x USERVALUE)

Curve Line Color
Choose the color to use when the log trace is less than the cutoff value. Check the
associated color palette to change the color box.

Shading Color
Choose the color to use when the log trace is greater than the cutoff value. Check the
associated color palette to change the color box.

Pattern
Petra can draw patterns inside cutoff shading. The left up/down button sets the
pattern, while the right up/down button sets the density of the pattern.

Suppress Curve Outline - This option hides the outline of the curve. In practice, this
option will leave a curve that only shows the fill and pattern.
6.5.4

Log Display Tracks Tab
Every digital log curve has a "track" that determines the position of the log curve
relative to the wellbore. Each log trace is plotted in one of the 11 predefined track
positions relative to the well symbol by assigning a track number to each log. As
shown in the illustration below, tracks 1 through 7 are single width tracks while tracks
0, 8, 9 and 10 are double width tracks. Tracks are displayed as a series of depth grid
lines and one or more vertical subdivisions. Setting the width, number of grid divisions
and logarithmic scale option can customize tracks. Each track grid can be visible or
hidden from view.

© 2014

1114

PETRA Help

The Tracks Tab

A well with Track 1 (Left), Track 2 (Center), and Track 3 (Right)

Track Definitions
The track definition section contains a list showing each of the 11 tracks.
Select the desired track to modify it. Note that the selected track is indicated by a
"<==" symbol to the right of the name.

Show - This option toggle the track between hidden and shown. Hidden tracks are
indicated by the symbol in the track list. Note that log curves can still display in
hidden tracks. Alternatively, double-click a track to toggle its status.
Width - This option sets the width of the selected track in inches.
Divisions - This entry sets the number of vertical scale lines for the track. When the
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Log10 option is selected, this entry sets the number of decades.
Bold Every - This option sets the interval for plotting bold division lines. As an
example, setting this value to 2 will plot every other vertical division line as bold. Set
this value to zero if no bold division lines are to be plotted.
Log10 - This option plots logarithmic decades on the track, and should be used for
logarithmic log curves are plotted in the track. Each track division display an
additional 9 intervals.
Reverse - Check this option to plot Logarithmic grid lines in reverse order, i.e., 0.9,
0.8, 0.7,...,0.1. Use this option to make the log10 grid lines match a log10 curve
plotted with the maximum value on the left and the minimum value on the right.
Log10 Offset - This entry sets the starting point for the logarithmic track grid.
Normally, logarithmic tracks start at offset 1 representing log scales such as,
0.1,1.0,10.0,100.0,etc. However, increasing the log10 offset to 2 will draw the grid to
represent scales such as, 0.2,2.0,20.0,etc. Use an offset of 3 for 0.3,3.0,30.0,etc.
Suppress Trk Grid - This option prevents the selected track from displaying horizontal
or vertical lines.
Suppress Outline - This option prevents the selected track from displaying the outer
border of the track and any header labels.

Append Tracks 8, 9, 10 - By default, Petra displays tracks 8,9, and 10 as a double
track over tracks 2 & 3, 4 & 5, and 6 & 7 respectively. This option instead appends
tracks 8, 9, and 10 onto the far right of the normal tracks.
Default Log Widths - This option sets all track widths to 1.0 and 2.0 inches.
Sync - This option sets the digital log track widths to be equal to the raster log track
widths. This can be useful when working with mixed digital and raster logs.
Paper Log Widths - This option sets all track widths to match standard paper logs of
2.5 and 5.0 inches.

Track Label Height (inches) - This option sets the text size for the log curve labels at
the top of each track grid.
Depth Track Pos - This option changes the location of the depth track. By default, the
depth track is set to the left of track 2.
6.5.5

Log Display Misc Tab
The Log Display Misc Tab sets some additional options on how Petra draws digital
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logs on the Cross Section Module.

.
The Misc Tab

Suppress Log Curve Scale Headers on Tracks - This option prevents log curve labels
from appearing above the log tracks
Include Curve Headers On Disabled Tracks - This option draws the log curve labels
on top of tracks even when the tracks are disabled.
Plot Track Grids After Log Curves - This option draws track grids on top of the log
curves. This can be useful for more easily reading log values.
Suppress Track Grids If No Curves are Plotted - This option prevents tracks from
being drawn when the well contains no log curves.
Use Curves From Other Well Completions - This option uses log curves from the
well's completions.
Plot Shading Btwn Logs After Other Shading - This option draws the shading between
logs last, to ensure that it is on top of other shading.
Suppress Track Grids on Deviated Wells - This option prevents track grids on
deviated wells. This can be useful for a cleaner, simpler appearance.
Show Tracks in Zoom Mode Only (Screen) - This option prevents track grids from
appearing on the full cross-section. The vertical and horizontal scale lines only appear
when the user is zoomed in on a portion of the cross-section.
Display Curve Units In Header - By default, Petra only displays the curve name and
left and right values. This option also displays the log curve's units. Note that these
units can be changed in the Log Maintenance window available from the Main
Module's Logs Tab.
Show Aliased Curve Name in Track Header Label - By default, Petra will display the
curve name substituted in for an aliased log. This option instead forces Petra to
display the aliased log even if another curve name is used. The Legend Label Method
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sets how this label is displayed.
Spike Curve Labels Size - This option sets the size of the labeled curve spikes. Note
that the "Labeled Spikes" option on the Style Tab ust be checked.
Reset All Curve Labels - This option resets all curve labels to the default options.

6.5.6

Log Display Discrim Tab
The Log Display Discrim Tab sets a discriminator curve that suppresses geocolumn
shading for the selected log curve on the Selected Logs list.
This tab is enabled when the "Use Discriminator" option is selected on the GeoColumn
Tab.

The Discrim Tab

Discriminator Curve - This dropdown sets the discriminator curve for the highlighted
curve on the Selected Logs List. When the discriminator curve is 0 or NULL, Petra
will not display any geocolumn shading. This can be useful for de-emphasizing
anomalous values in the curve.
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A gamma curve with geocolumn shading and a discriminator curve. Note that when the discriminator curve is set to 0,
the gamma curve has no geocolumn shading.

6.5.7

Log Display Cross Over Tab

The Log Display Cross Over Tab sets some additional options on how Petra draws
digital logs on the Cross Section Module.

The Log Display Options Cross Over Tab

Set Color Shading Btwn Curves... - This button opens the Shade Between Logs tool.

Shade Between Logs Tool
This cross section option allows you to color and pattern fill between two adjacent
log traces or a log trace and the track edge.
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Only those logs which have been selected for plotting on the "Log Scales" screen will
be available for shading between logs.

The Shade Between Logs

Shaded Curve Pairs List
This list box shows which logs pairs have been selected for shading.

Select Log Pairs To Shade Between
This section is used to select the log pairs and shading options. Choose two logs,
one from the Log 1 list and the other from the Log 2 list. Set the When option to
indicate the relationship of Log 1 to Log 2 when shading should be done. Choose
the Color or Pattern to fill with.

Click the Add button to add a new log pair to the selected list.
The Replace button is used to change the options of an existing log pair. First click
the item in the Shaded Log Pairs list box. Change the options then click the replace
button.
Use the Drop button to remove a log pair from the selection list.
For example, you might shade between neutron porosity (NPHI) and density porosity
(DPHI) to indicate the presence of hydrocarbon. To do this, first select NPHI as Log1
and DPHI as Log2 then choose the option that says "Log 1 LEFT of Log 2". Shading
takes place whenever the NPHI log plots to the left of the DPHI log
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Active - This option check box keeps the shading active. Deselecting this option
disables log shading, but retains the settings.
6.5.8

Log Display GeoColumn Tab
The GeoColumn tab provides options for displaying a curve using "geocolumn"
shading. The GeoColumn feature shades a curve with multiple colors based on curve
values. It's like cutoff shading but using many cutoffs.

Shading Direction - This option sets the direction of the shading. The sading can be
to the left or right of the log curve.
Log Used For Shading - The values from the curve selected here are used to define
the color "cutoff" ranges. This curve can be the same curve as being shaded or can
be any other curve.
GeoColumn Base Line Value - Shading occurs from the curve traces back to either
the track edge or a specified curve value.
Use Discriminator - A discriminator curve is a "flag" curve containing 1's and 0's. When
a discriminator curve is used, the GeoColumn shading will occur only where the
discriminator curve is equal to 1.
Use Discriminator - This option enables the Discrim Tab, which establishes a
discriminator curve. A discriminator curve suppresses geocolumn shading at depths
where the curve has a has a value of 0 or NULL.
Suppress Curve Outline - The curve trace is not drawn. Only the shading will be
drawn.
Transparent When Background Color - When the shading color matches the screen
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background color, shading will not occur.
6.5.9

Log Display Lith Sum Tab
The Lith Sum tab sums multiple curves together. This is most commonly used for
adding multiple lithologic percentages that normally would plot on top of each other.

Track - This option selects the track that contains the logs to sum together.
Disable This Track - This option disables the log summation for the currently selected
track. With this option selected, logs will plot as usual, but the settings on the Lith
Sum tab are retained.
Disable for All Tracks - This option disables the log summation for all tracks. With this
option selected, logs will plot as usual, but the settings on the Lith Sum tab are
retained.

Available Curves In this Track
This list displays all curves for the currently selected track.

Sum Curves in Track in the Following Order
While in the Lith Sum Tab, select the logs from the “Available Curves in this Track”
window, and click the “>” to add them to the “Sum Curves in Track in the Following
Order” window. In this example, the sand and shale percentages are moved over into
the “Sum Curves…” window
Next, use the up and down arrows to set the curves in the order they should be
summed. The order should be the same as the order the curves appear on the scale
from low to high. In this example, “%_Sand” is on the low end of the scale from 0© 2014
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100, so it should go first. This will sum the two logs together to reflect a cumulative
value.
When combined with the "shade between log" function, you can get the following
display where curves AHNY, SAND, LIME, DOLO and SHLE were used:

Sand and shale percentages with Lith Sum enabled (Left) and disabled (Right)

6.6

Raster Log Display Options
The cross-section displays log raster images for a given well by referencing group
names. For example, you might display images from the "GR" group in track 1 and
images from the "Default" group in track 2.
Petra predefines one group called the "Default" group. You can create as many
groups as you have different images for a well. Groups names should normally have
something to do with either the log curves they contain or the sample rate of the log, i.
e., "5-inch logs".
Each well can have only one image in a group. However, there is no limit on the
number of different groups you can define. Therefore, if you have 5 different log
images for a well, you must have 5 different image groups defined. The well will have
1 image in each of the 5 groups.

Available Image Groups
This section contains a list of all defined image group names in the project. To
dislpay an image group, select the desired log on the Available Image Groups list and
left click the ">" button to the right of the Available Image Groups list. To add all logs
to the Image Groups To Display list, left click the ">>" button to the right of the
Available Image Groups list.
Show Groups For This Cross Section Only - This filters the "Available Image Groups"
list to only the groups in the currently selected wells. Thais can be a very useful way
of quickly filtering out irrelevant group names.
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Image Groups To Display
This section contains a list of all image groups that will be displayed on the cross
section. To drop an image group from the Image Groups To Display list, select the
desired log and left click the ">>" button to the right of the Image Groups To Display
list. To add all logs to the Image Groups To Display list, left click the ">>" button to
the right of the Image Groups To Display list.

Track Tab
Each selected image group has "Group Details" associated with it. Click to highlight
one of the groups listed in the "Image Groups To Display" section. Then, set the
appropriate detail options.

Log Track # - This defines the image's plotting position relative to the well symbol and
digital log depth track. The track positions are illustrated for convenience.
Track Width - The track width is entered in inches and determines the width of the log
raster image. Typically, the track width should be set to the actual width of the paper
log from which the image was scanned. NOTE - Log images use the same tracks as
the digital log curves. Therefore, changing the width will also effect any digital curves
displayed in the same track.

Group Options Tab
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Show Extra Depths Above/Below Calibrations
Do Not Display Extra Depths - This option limits the raster to only the depth calibration
points
Display Extra Depths Defined in LIC File - This option
Display Extra Depths Using Values Below - This option adds extra footage above and
below the top and/or bottom calibration points. Petra simply extrapolates the distance
between depth calibration points, so the extra distance can be erroneous or include
other information on the scanned image.

Aliases
Plot Only First Aliased Group Found - This option only plots the first aliased image.
Plot All Aliased Groups - This option plots all aliased images for a group. When
multiple runs covering different depths are aliased together, this is a great way of
displaying a more complete picture of the wellbore data. On the other hand, multiple
aliased logs can be a real overposting mess.

Pay Tab
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Show Pay Intervals - With this option checked, any pay intervals that have been
defined during the calibration process will be drawn on the cross section.

General Tab
This section applies to all image groups and contains various plotting options and
conditions.

Enable Separate Templates Per Well - This option enables different sets of raster log
image settings for different wells. With the huge variety of raster names, depths, and
quality, individual raster settings can be a great way of creating ideal settings for each
well.
Plot Headers at Image Top - This option displays the section of the image defined as
the header at the top of the image.
Plot Scale Header at Image Top - This option displays the section of the image
defined as the log scale header at the top of the image.
Plot Headers at Image Bottom - This option displays the section of the image defined
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as the header at the bottom of the image. It may be necessary to increase the size
of the bottom margin it the bottom header becomes clipped.
Scale Header Height (inches) - The amount of space to reserve for plotting the header
section, both above and below the curve section. The header section will be
"stretched" the fit this height.
Scale Footer Height (inches) - The amount of space to reserve for plotting the header
section, both above and below the curve section. The header section will be
"stretched" the fit this height.
Float Top Header - Normally, the top header section will appear just below the well
symbol at the upper depth of the cross section. This option will cause the top header
to float with the top of the image curve section even if the image starts deeper than
the upper depth of the cross section.
Draw Calibration Lines - This option will draw lines across the image at the calibration
depths. Use this option to compare the image calibration depths with the digital depth
track.
Hide Track Grids Containing Images - This option causes digital track grids to be
hidden if the track contains a log image to be displayed.
Suppress Depth Track If Image in Track 0 - Petra draws the depth track directly
underneath the well symbol in track 0. This option prevents the depth track when
there is a raster in track 0.
Show Fill Image Path Name in Status Bar - When you bring the mouse over the raster
image, Petra displays the raster's group name and image file name. This option
instead displays the full image pathway. This option can be useful for troubleshooting.
Plot Images From Other Completions - By default, Petra will only display raster
images from the exact well, and not from other completions. This option enables
raster images from other completions.
Use Screen Plot Technique For Printer - This option changes how Petra draws raster
logs. Select this option when the Cross-Section Module plots incorrectly.
Display Image Gaps Label Image Groups -

Memory Tab
The memory tab changes how Petra works with image files. This can affect Petra's
redraw speed and system resources.
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Reload Images From Disk – With this option, Petra refreshes raster image files from
the network or local disk every time the cross section's appearance changes. With a
large Layer File and a slow network, this can translate to poor performance.
Keep Images in Memory – This option tells Petra to load the raster image files once
and keep them in local memory rather than continually refreshing from the network or
local drive. By eliminating waiting on the network, this option accelerates redrawing at
the expense of using more RAM.

File Tab

Load Template - This button loads an external Log Image Temlpate (*.LIT) template
file. Loading an external file will overwrite the current raster settings.
Save Template - This button saves the current raster log settings to an external Log
Image Temlpate (*.LIT) template file.

Misc Tab
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Pay Label Text Height - This option sets the text height in inches of the raster log pay
labels (set on the Pay Tab).
Opaque Text - This option causes open wells symbols, such as a gas or dry hole
symbols, to be plotted using the background color (normally white) to fill the interior of
the symbol. Use this option when you wish the well symbols to stand out against a
colored background.
Pay Label Position - This option sets the location of the pay label. 1 is outside the
pay interval on the left, 2 is left-justified, 3 is centered, 4 is right-justified, and 5 is
outside the pay interval on the right
Use Pay From Calibration Files. Do Not Use DB Pay - Calibration files can store pay
intervals. This option forces Petra to use the pay intervals from the calibration file,
rather than the project database. This can be useful for temporarily reviewing old pay
intervals.

6.7

Displaying Formation Tops
The Formation Tops For Cross-Section Tool defines how the Cross Section Module
displays formation tops.
The Select Tab sets the tops to display on the cross section. The General Tab sets
options that apply to all displayed tops while the Color Tab and Style Tab customize
individual tops.

Select Tab
The Select Tab adds and removes tops from the Cross Section Module's display.
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The Formation Tops for Cross Section Select Tab

Available Tops List
The available logs list shows the formation tops in the project.
Restrict By Source - This option restricts the tops on the Available Tops list by the
selected source code. Only the tops with the selected source code will appear on the
Available Tops List. The "<All Sources>" option displays all tops from all sources
(unless restricted by the Reorder Tool on the Main Module's FmTops Tab).

Displayed Tops List
The Cross Section Module only displays the tops on the Selected Logs list.
To add a log to the Selected Logs list, select the desired log on the Available Logs list
and left click the ">" button.
To drop a log from the Selected Logs list, select the desired log on the Selected Logs
list and left click the "<" button. To drop all logs from the Selected Logs list, left click
the "<<" button.

General Tab
The general tab options apply to all selected tops.
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The Formation Tops for Cross Section General Tab

Tops Connection Method
Do Not Connect Tops - This option draws small ticks at each well.
Connect Tops To Track Boundaries - This option draws the tops straight across the
log tracks and connects the tops from well to well.
Connect Tops to Borehole With Straight Line - This option draws straight lines
between wells.
Connect Tops to Borehole With Curved Line - This option draws tops using a spline
function fit to the tops, which results in a more realistic structural picture.

Label Method
Although individual tops may be labeled or not labeled, this option disables all top
labels at once.
Label Tops - For each top, this option uses the label settings set on the Style Tab.
Essentially this option allows top labelling.
Do Not Label Tops - This option disables all formation top labels on the Cross Section
Module.
Opaque Label Box - This option uses opaque label boxes around the formation top
label. This can be useful for displaying labels over log shading.
Label Position - This option sets
Label with Actual Name of Alias -This option continues to use formation top aliasing,
but will plot the actual name of the formation top rather than the aliased name.
© 2014

Cross-Section Module

1131

Repeat Tops
Ignore Repeat Tops - This option does not plot repeat tops. Only the first top listed
will appear on the cross-section
Indicate Top with Markers - This option draws a small triangle (matching the color of
the top) at each top location in the cross-section. This makes it easier to recognize
repeat tops along a wellbore. These markers also indicate which tops are repeats by
not filling in the triangle for any repeat value.

Settings
Use the "Load" and "Save" options to save the selected tops along with their display
options to a disk file for later use.

Color Tab
The color tab sets color and shading options for the selected top on the Displayed
Tops List.

The Formation Tops for Cross Section Color Tab

Line Color - This dropdown selects the top's color. The Palette button selects an
alternative color that will replace the selected color on the dropdown menu.
Fill Color - This option sets the color of the fill between wells or inside well tracks.
The Palette button selects an alternative color that will replace the selected color on
the dropdown menu. More detailed options for how Petra draws the color fill below
the formation top are on the Fill Options Tab
Pattern Fill - This window sets a lithologic pattern for the color fill. The scroll bar to
the right sets the density of the pattern.
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Fill Between Tops - This option turns on the color fill in between formation tops. Note
that there are more options on the Fill Options Tab.
Apply Colors To All Tops - This option sets all selected tops to use the currently
displayed line and fill color options.
Default Palettes - This option resets the color palettes for the Line and Fill Color
dropdown menus.
Save Color Palettes - This option saves the current color palettes for the Line and Fill
Color dropdown menus to external files.
Load Color Palettes - This option loads a color palettes for the Line and Fill Color
dropdown menus from external files

Style Tab
The style tab contains options for setting the line style and labeling options for
individual tops. For each top, first select the top from the "Tops To Display" by clicking
on the top names.

The Formation Tops for Cross Section Style Tab

Label
Label Between Wells - This option plots the top name between the two wells with the
widest spacing.
Label At Wells - This option plots the top name next to the borehole of each well.
Do Not Label This Top - This option suppresses the label for an individual top.
Label Height - This entry sets the size for the individual labels in in inches.
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Draw As Unconformity - This option draws the top using a wiggly line to indicate an
unconformity surface.
Allow Top Aliases - This option uses formation top aliases.
Do Not Connect Top - This option will draw the selected tops as a series of tick
marks at the depth track but will not connect wells with a line.
Disable Top - This option temporarily disables a top. All the line and fill options are
stored.
Treat Top as a Contact - This option draws the selected top after all others. This can
be useful for demonstrating fluid contacts that cross formation boundaries and
interfere with formation shading.
Line Width - This dropdown sets the line width for the top. Note that the userselected line widths are set on the Petra Program Options' Font/Graphics Tab.
Line Type - Select the line type used to draw the line for the top.
Apply Style To All Tops - Press this button to set all tops displayed using the current
style settings.

Misc Tab

The Formation Tops for Cross Section Misc Tab

Sorting
The sorting section controls whether tops are pre-sorted before plotting, which
controls how Petra draws fills between tops.
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Sort Tops - This option attempts to automatically sort formation tops in increasing
depth order before drawing any fills, ensuring that the shading between tops is
correct.
Do Not Sort Tops - This option disables automatic sorting. This option is best used
where the automatic option incorrectly shades tops because of pinch-outs and missing
values. Note that the tops on the Displayed Tops List must be manually sorted from
top to bottom.

Fill Options Tab
The Fill Options Tab changes how Petra draws fill between formation tops.

The Formation Tops for Cross Section Fill Options Tab

Do Not Fill Between Wells - This option turns off the fill between wells.

"Do Not Fill Between Wells" selected (left) and deselected (right)
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Track Fill
Do Not Fill Tracks - This option does not display any formation top fill in the depth
tracks.
Fill All Tracks - This option fills all displayed depth tracks.
Fill Depth Track Only - This option fills only the depth track immediately underneath
the well symbol.
Fill Track 1 - This option fills only the selected depth track.

The "Fill All Tracks" (left), "Fill Depth Track Only" (center) , and "Fill Track 1" (right) Options

Advanced Fill Options
Only fill between tops that occur in all wells - This option will only fill between tops that
occur in all wells. Tops that have a null value for any well on the cross section will not
have any fill.
Fill between tops that occur in adjacent wells - This option will fill any top that occurs
in two adjacent wells. This option is more tolerant of missing tops.

6.7.1

Repeat Tops
Repeat Top Pick Mode
To pick repeat tops, a new picking mode has been added to the cross-section. This
mode is available through the Correlation Tool Bar only. To enter this mode select a
top from the drop down and click the ‘Repeat Top Mode’ button (clicking the arrow to
the right gives you an option to enter auto store mode which is similar to Smart Pick
mode). Upon entering this mode a dialog will appear explaining how this mode works.
Picking repeat tops is different than other picking methods in the cross-section. This
mode is specially designed for handling horizontal wells in complex cross-sections.
Here are the keys needed to successfully begin picking repeat tops.
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1) CTRL+Click to Select a Well. In order to pick a top along a deviated well path,
Petra must know what well you want to pick on. To select a well, simply
CTRL+Click anywhere along the desired well path. This will outline the entire
bore-path with a lime-green color (can change color through the Display->Colors
dialog).
2) *NOTE* Tops indicated by markers. Once a well is selected, if the currently
selected top has any picked values on that well they will be marked with an ‘x’ or
‘+’. This shows you what tops are currently on that well and also which tops can
be moved or deleted.
3) Click to Pick a New Value. Simply clicking at the desired location will add a top
value for the current top on the selected well.
4) SHIFT+CLICK to Pick a Value in Space. If the well is deviated Petra now allows
the user to pick tops that are offset vertically from the well path. To add a top in
space (must be vertically directly above or below the bore-path) hold down the
SHIFT key while you click. A ‘+’ will indicate the new top value.
5) Drag Tops. Simply clicking directly on one of the ‘x’ or ‘+’ markers and dragging
(while continuing to hold down the mouse button) lets the user move tops
around.
6) ALT+Click to Delete a Pick. To delete a repeat top value, simply hold down ALT
while you click on its marker. *NOTE* You cannot delete the original top value
with this method, use the ‘Set Null’ option when out of the repeat top picking
mode.
7) Right Click to Re-Draw. Right clicking anywhere will re-draw the screen with any
changes you've made to the top. This does not end picking! If not in ‘Auto Store’
mode then you will be prompted to save changes to the DB.
8) End Picking. When done picking, just press ESC or click on the Repeat Top
Mode button again to exit the picking mode. If not in ‘Auto Store’ mode then you
will be prompted to save changes to the DB.

Below is a screenshot of the new picking mode in cross-section. Note the far left well
is highlighted showing we have selected that well to pick on. Also we are picking the
354BRNT Top. The red triangles are the top markers showing all points that the top
has values picked at. The filled-in triangles are the original tops while the empty ones
are the repeats. The red ‘x’ and ‘+’ markers show you where the 354BRNT top has
values along the selected well. The ‘x’ markers are points that the top actually crosses
the well path, while the ‘+’ marker is the top picked ‘in space’ below the well path.
Also note how the status bar shows you the actual MD along the well path (at the
closest point to the cursor).
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Correlating Formation Tops

There are few different ways to pick tops in the CrossSection Module.
As an alternative, however, the Log Correlation Tool provides a simpler interface for
pure formation top picking with fewer plotting and display options. This tool can be
particularly handy when working in projects with a large number of unique raster log
group names.

Right Click Menu
First, select a well by left clicking on either we well symbol or the depth track directly
beneath the well symbol. Note that Petra will draw a pink box around the well symbol.
Next, hover the cursor directly over the top to correlate and right click the mouse.
Here, select the "Correlate Top: " option. Note that the bottom of the Cross Section
module turns yellow to signify that there's a top being actively picked. Click the left
mouse button on the desired location of the top for multiple wells, and select the right
mouse button when finished.
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This method is quick, but can only propagate tops already picked in at least one of the
wells in the cross section. To pick a top not on any of the wells, you'll need to use
either the correlation toolbar or the menu bar.

Correlation Toolbar
The Cross Section Module has a special Correlation Toolbar that picks a single
formation top selected from a dropdown, as well as a "Smart Pick" mode that quickly
modifies any top displayed on the cross section.

Tops>Start Correlate
First, select Tops>Start Correlate.. from the menu bar at the top of the CrossSection
Module. Next, select the desired top to correlate, or select the +New To " button to
add a new formation top to the project. Click the left mouse button on the desired
location of the top for multiple wells, and select the right mouse button when finished.
Alternatively, select Tops>End Correlate..

6.8.1

Fm Top Correlation Toolbar
To enable or disable the Top Correlation Toolbar, seelct Tops>Show Correlation
Toolbar from the menu bar at the top of the CrossSection Module.

Smart Pick
This tool is a "drag and drop" method of changing tops. When in Smart Pick mode,
you can CTRL+ left click any top and drag it to a new position. Importantly, this
method makes immediate changes to the database without any additional
dialog boxes. Select the green button to start Smart Pick mode, and the red button
to end Smart Pick mode.

Top Dropdown - This dropdown selects the top used by the "Start" and "Stop"
buttons.
© 2014

Cross-Section Module

1139

Start - This option starts picking the top selected on the Top Dropdown immediately
to the left. Click the left mouse button to pick the tops's depth for multiple wells. To
stop picking tops, select the right mouse button or select the "Stop" button to the
right.
Stop - This button stops picking tops, and provides an opportunity to save the top
changes to the project database. Selecting "Yes" will apply the changes to the
database, while "No" will ignore any changes made to the tops.

Refresh - This option refreshes the image on the screen with the latest tops from the
database. This can be useful when multiple users are working the same tops
simultaneously in the project.
New - This option creates a new formation top in the project with the Add New
Formation Top Marker tool.
Set Null - This option erases the depths for the top on the top selected on the Top
Dropdown. Click the left mouse button to null the tops's depth for multiple wells. To
stop erasing tops, select the right mouse button or select the "Stop" button to the
right.
Type Log - When a From-To pair is set, and a type log selected (Logs>Select Log
Curve) this button will create a Type Log Correlation Window.
From-To - This establishes a From-To pair used in many different Cross Section
Module functions.

6.9

Pay Data Toolbar
The Pay Data toolbar is primarily used for picking new pay intervals and editing
existing pay intervals.

Pay Intervals - This dropdown selects the a pay name for adding new pay intervals.
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- This button sets the pay name set on the Pay Intervals dropdown with a mouse.
Source Restriction - This dropdown limits the pay names displayed on the Pay
Intervals dropdown to only those with the selected source code. This can be useful
for filtering out irrelevant pay names.
- This button creates a new Pay name
- This button opens the Pay Data Display Options tool.
- This button adds new pay intervals for the selected pay name. Position the
mouse over a well near the depth track vertically beneath the well symbol. Make note
of the WSN of the well you are near. Pick the top of the pay interval using the left
mouse button; click the left mouse button again to set the base of the pay interval.
Note that you can continue picking more pay intervals on the same well or any other
well. You may zoom or scroll the screen while in picking mode.
To stop picking pay intervals, select the right mouse button. You will be prompted to
save the pay intervals to the database.
- This button moves existing pay interval boundaries. Position the cursor over a
well near the depth track. Click and hold down the left mouse button near the top or
base of the pay interval being modified and adjust it up or down in depth. Release the
left mouse button positioned at the new depth. You will be prompted to keep the
change. Click the Right Mouse button to signal you are done modifying pay intervals.
- This button deletes pay intervals. Position the cursor over a well near the depth
track. Click the left mouse button anywhere between the top and base of the pay
interval. An X will be drawn where you clicked and you will be prompted to delete the
selected pay interval. Click the Right Mouse button to signal you are done deleting
pay intervals.
- This button sums the pay intervals from a select pay name to a zone item. The
selected pay from all wells in the current cross-section will be summed.
- This button hides the Pay Data Toolbar.
6.9.1

Pay Data Display Options
The Pay Display Options tool controls how Petra displays pay intervals on the cross
section. Some of the basics of the pay names, including name, color, and display
patterns, are set on the Pay Interval Data tool on the Main Module's Raster Tab.
To open the Pay Data Display Options tool, select the
button on the cross
section module's Pay Data Toolbar. Alternatively, select Pay>Pay Data Display
Options on the menu bar at the top of the Cross Section Module.
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Data Tab

Available Pay List
The available logs list shows the pay names in the project.
For All Wells - This option lists all pay names for all wells in the project.
Selected Wells Only - This option lists only the pay names for the wells currently
selected on the cross section.

Selected Pay List
The Cross Section Module only displays the pay names on the Selected Pay list.
To add a log to the Selected Pay list, select the desired pay name on the Available
Pay list and left click the ">" button.
To drop a log from the Selected Pay list, select the desired pay name on the Selected
Pay list and left click the "<" button. To drop all pay names from the Selected Pay
list, left click the "<<" button.
Label Pay - This option adds a label to the side of the pay intervals. The specifics of
this pay label are set on the Options Tab.

Options Tab
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Pay Label Size - This entry specifies the height of the pay label size in inches.
Label Vertical Position - This dropdown sets the vertical position of the label relative
to the top and base of the pay interval. The label can be upper, center, or bottomjustified.
Label Horizontal Position - This dropdown set the horizontal position of the label
relative to the pay interval.
Label Style - This dropdown sets the exact text on the label. This can be a
combination of pay name, thickness, and top/base.
Include Source - This option adds the pay name source to each label.
Do Not Play Pay Intervals Unless Well Contains a Raster Log - This option only allows
pay intervals for logs displaying a raster log.
Do Not Drop Pay Labels When They Are Too Small - By default, Petra will not display
labels for very thin pay intervals. This option forces labels for all pay intervals.
Plot Pay in DEPTH TRACK Only - By default, Petra draws pay intervals across the all
tracks on the cross section. This option forces Petra to only display the pay intervals
in the depth track.
Plot Pay PATTERN Symbols - Though a pay name can have both a pattern and color
(both are set on the Pay Interval Data tool), Petra only displays pay interval color by
default. This option adds the pay name's pattern to the cross section. This can
obscure some of the details on logs.

Defaults - This button restores the defaults for the Pay Data Display Options tool.
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Well Symbol Style - Cross Section
The well location style screen provides options for setting the well symbol size and
well labeling style. The well label is a single line of text and can be used as an
alternative to using the Posted Data option.
To open the Well Symbol Style tool, select Wells>Symbol Location and Style on the
menu bar at the top of the Cross Section Module.

Symbol Tab

The Well Labeling Style's Symbol Tab

Symbol Size - Select the one of the default symbol sizes, small, medium or large or
select the Custom button and enter the symbol size in inches.
Opaque Symbols - Check this option to have the well symbol filled with the
background color.
Symbol Location - This option sets the location of the location of the
Symbol Color - Choose to draw the well symbol using the default color defined in
the system colors or using the well symbol definitions defined in the Well Symbol
Descriptions section

Annotation Tab
The Annotation Tab provides a simple alternative to the Data Posted By Well Spot
tool. The Annotation Tab becomes available when the "Allow Simple Well Labeling"
option on the Options Tab is selected.
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The Well Labeling Style's Annotation Tab

Well Label - This dropdown sets the label around the well symbol. Options include:
-No Label (Suppress the well label)
-Unique Well Id (UWI or Api Number)
-Api Series No. (5-digit series number or the UWI)
-Well Short Name
-Well Label
-Well Seq No. (WSN)
Position - This option sets the label position above, below, left or right of the well
symbol.
Label Size - - Select the one of the default symbol sizes, small, medium or large or
select the Custom button and enter the symbol size in inches.

Options Tab
The Options Tab sets a few additional options for well labeling.
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The Well Labeling Style's Options Tab

Label Distance Between Wells - This option posts the distance between each well
symbol at the top of the cross section. The entry to the right sets the height of the
text. The "Label Distances As" dropdown sets the label in feet or meters.
Place Well Symbol at Bottom of Deviated Wells - This option posts the well symbol
at the bottom of deviated wells instead of at the top of the cross section.
Allow Simple Well Labeling - This option creates the Annotation Tab.

6.11

Cross-Section Overlay
Note: All of the following instructions are based on the use of the Overlay Tool Bar.
If your overlay tool bar becomes hidden, click on "Overlay>Show Tool Bar".

Creating Lines
To create lines in Petra, simply click on the pencil icon on the toolbox. Then click
where you want the beginning of the line to start. Clicking the left mouse button again
will add control points, while clicking the right button will end the line. After you finish
adding control points on the line, the Overlay Line Attributes dialogue box will pop up.

Editing Lines
To select and edit pre existing lines, click on the red arrow on the toolbar which brings
up a crosshair for your mouse on the map module and then select the line you wish to
edit with one click of the left mouse button. This changes the color of your line to blue
and shows all the control point points in the line. Occasionally after making many
changes to lines, it is necessary to redraw the screen to see the changes or to
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continue editing.
Moving individual control points - change the location of any blue boxed "control point"
by clicking and dragging it to a new position.
Moving whole lines - To move a whole line unchanged, press ALT and click on the line
with the right mouse button.
Copying a line - click on the copy button that looks like
on the

. To paste the line, click

button and place the text.

Creating Text
To set text, click on the "abc" icon on the toolbar. Petra first asks you to establish a
baseline that shows where you want the text and then builds a rectangle to establish
the height of the text.
Editing Text
To edit pre existing text, first click on the red arrow on the toolbar, which brings up a
crosshair for your mouse on the map module. Select the text you wish to edit with
one click of the left mouse button; this brings up a blue box around your text and
allows you to edit the text. Sometimes after manipulating a piece of text multiple
times, it may become necessary to refresh the screen to see the blue box that
highlights text.
Editing features like the content of the text displayed, the height of the text in map
units, angle in degrees, overlay layer, text color and font, and text justification - double
click anywhere inside the blue box. This brings up the Overlay Text Attributes
dialogue box that allows you precise control over features, including degree of angle
and text height.
Changing the location of the text - press ALT and right click somewhere inside the box
and drag it to the new location.
Changing the angle of the text manually - press ALT and right click on one of the
control points that establish the baseline on the bottom of the blue box.
Copying a text box - click on the copy button. To paste the text, click on the button
and place the text.
Importing an Image File
To add an image file, simply click on the "Add Image File" button on the toolbar that
looks like
. After clicking this, Petra will ask you to establish a rectangle on the
map screen where the image file will be placed. Then, Petra will ask you for the
location of the file and the layer you want it to go into. Various scaling options are
available under the "Options" tab.
Adding a Fault Line
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To add an fault line, simply click on the fault line icon on the mapping toolbox that
looks like . This will change your mouse to a crosshair. To add the fault, first click
on position for the beginning of the fault and then click again to place more nodes on
the fault. The right mouse button ends the process of adding nodes to the fault. After
this, click to the left and the right of the fault to define throw.
Note: Fault lines can be moved and edited just like a line. Select it with the red
arrow selecting tool Right clicking it will move the entire fault, while left clicking
a single node will stretch the line.
Note: Be careful to place the fault lines away from the well lines. Crossing a well
with a fault line will generate an erroneous image.
6.11.1 Overlay Tool Bar - Cross Section

The overlay tool bar contains icons to manipulate overlay lines and text.
Select overlay line or text item.
Show attributes of the selected item.
Add a line, polygon, contour, or fault to the map.
Add text to the map. Click 3 points. First point is the start of text baseline,
second point is the end of text baseline, third point indicates text size.
Add an Image reference to plot a Windows metafile or bitmap file. Click and
drag to draw a rectangle to define the position and size of the image.
Add a fault line to the cross section.
Add a box or rectangle to the map.
Delete the selected item.
Copy the selected item into the overlay clipboard function.
Paste the item from the overlay clipboard onto the screen.
Display Layer & Preferences screen which provides global editing options.
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6.11.2 Overlay Line Attributes - Cross Section

Every overlay line has a series of attributes that define the type of line and its
appearance.
To edit a line's attributes, select the red arrow button, and double-click a node on the
desired line.

General Tab
The General Tab sets the basics of the line, including its layer and class.

The Overlay Line Attributes General Tab

Layer - This dropdown sets the layer that will contain the line. Since the
CrossSection Module can selectively display or hide entire layers, related lines
should generally be in the same layer.

Line Class
While normal lines are just for displaying visual information (like section outlines or
roads), contour, unconformity, and fault lines can also be used to influence the
gridding process.
Normal Line - Normal lines have no specific attributes beyond a color and fill. Normal
lines are useful for display purposes, including lease lines and arrows.
Unconformity Line - Unconformity lines illustrate an unconformable surface contact
with a squiggly line on the map.

Line Width - This dropdown sets the line widths for drawing the line. Line widths
range from narrow to extra-wide. This dropdown also can select the 4 custom
"User-1" through "User 4" line widths. These line widths can be modified on the
Petra Program Options' Font/Graphics Tab in the Main Module.
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Line Style - This dropdown sets the line to use one of the predefined drawing styles
to draw a solid or dashed line.

Smooth Line Points - By default, Petra draws a straight line between the node points
that make up a line. This option instead draws a smoothed line through the line's nod
points.
Closed Polygon - This option forces the starting and ending points to match when
drawing polygons. This switch should be specified when using area fill options.
Polygon Name - This entry sets the name of the polygon.
Label Polygon - This option plots the volumetric name in the center of the polygon.

Colors Tab

The Overlay Line Attributes General Tab

Do Not Fill - This option disables color fill for lines that are not polygons. This can
also be used to draw a polygon without any color fill.
Fill Interior - This option fills the polygon with the color set on the "fill color"
dropdown.
Line Color - This dropdown sets the color of the line. For closed polygons, this will
set the shape's outline. To change the available colors on this dropdown, select the
"Palette..." button. To restore the default colors, select the "Default" button.
Fill Color - This dropdown sets the color of the fill inside a polygon. To change the
available colors on this dropdown, select the "Palette..." button. To restore the
default colors, select the "Default" button.

Drawing Mode
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Normal - This option draws the line or polygon element with an opaque color. Lines
or polygons with a normal drawing mode will cover elements that are below them.
Transparent - This option draws the line or polygon with a transparent color. With a
transparent drawing mode, other elements will be visible through the line or polygon.
Combine Colors - This option will display overlapping lines and polygons with a
different color. In practice, this option is a great way to demonstrate regions of
overlap on the overlay.

The blue circle on top with Normal (Left), Transparent (Center) and Combine Colors (Right) drawing modes

Patterns
Petra can draw patterns inside polygons. The left up/down button sets the pattern,
while the right up/down button sets the density of the pattern.

Pattern Color - This dropdown sets the color of the pattern inside a polygon when
the "Use Pattern Color" option is selected.

Pattern Line Mode
Use Thin Black - This option draws the selected pattern using thin black lines. This
option will override the "Pattern Color" dropdown.
Use Line Color & Width - This option draws the selected pattern using the line color
(selected on the Colors Tab) and thickness (selected on the General Tab). This
option will override the "Pattern Color" dropdown.
Use Pattern Color - This option uses the color set by the Pattern Color dropdown
immediately to the left.
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Pattern Filled polygons with "Use Thin Black" (Left), "Use Line Color & Width" (Center), and "Use Pattern
Color" (Right)

Contours Tab
This section sets individual contour line values and settings. This section is only
available when the "Contour Line" class is selected on the General Tab.

The Overlay Line Attributes Contours Tab

Contour Value - This entry sets the value for the contour line.
Label Contour Line - This option enables or disables contour line labeling.
Label Height - This option sets the height of the contour label in inches.
Hachures - This option adds hachures to inside or outside of a contour line. The
"None" option disables hatchures for the selected line.

Arrow Tab
This section allows arrow heads to be added to the line end points. Note that Petra
can only draw arrows on lines with a "Normal Line" line class selected on the
General Tab.
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The Overlay Line Attributes Faults Tab

Arrow Type - This dropdown sets the appearance of the arrow. Note that the
arrows are directional. An arrow pointing to the right will put the arrowhead at the
end of the line, while an arrow pointing to the left will put the arrowhead at the
beginning of the line.
Size - This option sets the size of the arrow in inches.

6.11.3 Overlay Layers & Preferences - Cross Section

Layer Name List
Visible for both Properties and Preview Tabs, the list box shows all layer names in
the open Overlay file.
This list selects the currently active layer - as an example, to change the state outline
color to red, you'd need to select the "State" overlay layer here first.
The Layer Name List displays the current status of all the layers in the overlay file.
Layers which are not currently visible are indicated by a small symbol. The layer's
default color, which is the color assigned to newly added items, is shown on the right
edge of the list.
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Interpreting a layer name on the Layer Name List

The Layers Tab has two tabs: Properties and Preview. The Properties Tab
changes layer visibility, layer names, and update status. The Preview Tab displays a
quick preview of the data inside the specified layer. These two tabs are on the
upper right corner of the Overlay Layers tool.

Layers Tab
The Layers Tab sets a few of the basics for the layers in the overlay file. This
includes changing layer names, visibility, and update status.

The Overlay Layers' Layers Tab (Properties Tab)

Layer Properties
Layer Name - To change the name of a layer, first select the layer in the Layers lists.
Type a new layer name and click the "Apply" button.
Layer Default Color - To change the default color of a layer, first select the layer in
the Layers list. Select a new color from the drop down color list and click the "Apply"
button.
Layer Visibility - Use this section to "Show" or "Hide" individual layers. Double clicking
the layers list will toggle a layer's visible state.
Plot This This Layer After other Graphics - This option changes how Petra handles
overlaps between overlay objects and other elements on the Cross Section Module.
When this option is selected, Petra will draw the selected layer last, on top of other
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objects.

- This option can be used to delete all data associated with the
selected layer. You will be prompted to verify the clearing process. Data is only
removed from memory. It does not effect any saved overlay files unless you
overwrite them with the modified overlay.

Update Layer Data

Line Color - This dropdown sets the color of the line. For closed polygons, this will
set the shape's outline. To change the available colors on this dropdown, select the
"Palette..." button. To restore the default colors, select the "Default" button.
Fill Color - This dropdown sets the color of the fill inside a polygon.
Text Color - This dropdown sets the color of the text. To change the available colors
on this dropdown, select the "Palette..." button. To restore the default colors, select
the "Default" button.
Text Size - This entry sets the height of the text in depth units, or inches. With
"relative" inches, the text will enlarge as you zoom in and out of the map.

Make All Layer Items Use Layer Default Color - This option changes all layer items
to use the default layer color set on the Layers Tab
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Layer Order
This section allows layers to be specified in a plotting preference order. All layer
names are shown in the list box in the current plotting order. Layers at the top of the
list are plotted before layers coming later in the list. Thus, a layer at the top of the
list may be covered up by subsequent layers.

Select a layer from the list and click the small
layer's plotting order.

and

arrows to change the

General Tab
The General Tab has a couple of miscellaneous options for scaling and image path
reports.
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Use Old Method for Scaling on Line-and-Wells Mode Create Image Path Report... -

6.11.4 Overlay Text Attributes - Cross Section

The Overlay Text Attributes tool sets the details for text displayed on the Cross
Section Module. This tool will appear immediately after creating a text box.
To reopen this box and change text settings, select the red arrow button (
) on the
Overlay Tool Bar on the right side of the CrossSection Module and select the text to
change.
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Text - This entry sets the actual text on the cross section. This can contain text from
1 to 255 characters.
Layer - This dropdown sets the overlay layer that will contain the text. To rename
the selected layer, select the "R" button.

Text Height
Size in Depth Units - This option scales text hight to the Cross Section Module's
default depth units (set on the Map Projection Settings Units Tab). With this option,
text hight will increase and decrease with zoom.
Size in Inches (Absolute) - This option scales text height in inches. This option sets
text height at a single size - it will stay the same size regardless of zoom. Be careful
with this option when sending large cross sections to a plotter - an absolute text size
that looks good on a computer screen may be too small for a large plot.
Size in Inches (Scaled To Section) - This option scales text height in inches relative
to the actual size of the cross section (set by the vertical depth scale and the
horizontal Cross Section Size Options). Put another way, this draws text at the
actual scale that will be sent to the plotter.

Text Angle - This setting sets the text's rotation in degrees. 0 is horizontal, positive
degrees rotate the text counter clockwise, and negative degrees rotate the text
clockwise.
Justification - This option sets the text justification within the textbox. This can be set
to left, right, or centered.
Color - This option sets the text's color.
Font - This option sets the text's font.
Use Opaque Background - Set this option to draw the text using the cross section
background color as the background of the text. Opaque text will cover up underlying
data.

6.12

Plot Interval Data
The Cross Section Module can display any combination of interval data colors,
patterns, markers and text.
To display interval data for a well in the Cross Section Module, select Wells>Plot
Interval Data. This box shows a list of the interval data tables on the left along with a
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series of tabs on the right that control how interval data (Style, Text, Filters) are
shown.

Intervals displayed in the Cross Section Module

First, select the interval data table or tables to display. Petra can show multiple
intervals at the same time, though it’s generally better to keep different interval
tables in different tracks. In the example below, only the LITH table is selected.

Style Tab
The Style Tab governs how the interval data is displayed on the Cross Section.
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The Interval Data Fill's Style Tab

Use Interval Fill Color – This option tells Petra to fill the interval with the interval’s
color.
Use Interval Fill Pattern - This option tells Petra to fill the interval with the interval’s
pattern.
Use Interval Marker Symbols - This option tells Petra to fill the interval with the
interval’s marker symbols. The Marker Scale factor below changes the size of these
symbols. The individual interval’s marker fill can also be overridden with the Marker
Fill Mode below.
Text Positioning – Text can be positioned at the top, middle, or bottom of an interval.
Select the dropdown by default labeled “Text At Top of Depth Interval” to change
where text is plotted.
Combining Text Horizontally or Vertically – This changes how multiple text fields are
displayed. “Combine Text Horizontally” lists additional text fields to the right of the
first text box. “Combine Text Vertically” stacks additional text fields on the bottom of
the first text field.
Separate Text with Space – This option changes how different fields are separated
when plotted horizontally. Horizontally combined text boxes can either be separated
with a space, slash, a dash, or a comma.
Text Label Size – This option sets the size of text (in inches). Keeping this option at
0 is a good default. Remember that an absolute text size probably won’t be
appropriate for both computer screens and large paper plots; 1 inch letters will look
huge on a computer screen, but will be normally sized on a large wall plot.
Marker Scale Factor – This option sets the scale of the interval markers. Setting the
scale factor to 0.5, for example, plots all markers at ½ their original size.
Marker Fill Mode – Though every interval stores information on how to display
markers, this option overrides the fill mode for all displayed markers on the cross
section. Note that this does not change the settings stored in the interval.
Pattern Scale Factor – This option sets the pattern scale, or density, of the lithologic
pattern fill. Higher numbers here generate higher pattern density.

Text Tab
The Text Tab sets the specific data fields to be displayed as text.
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The Interval Data Fill's Text Tab

To add text, select the appropriate Table on the Interval Data to Plot dropdown
menu and a data field from the “Data Fields to be Posted By Intervals dropdown
menu on the right. Select the
button to adds the field to the list. Items at the top
of the list will be at the top (for vertically combined text) or on the left (for horizontally
combined text). Seecting the “Include Text Labels” option adds the field name as a
prefix before each data field. Particularly elaborate displays can also be saved as a
template in a *.IDF file with the Save/Load Template buttons.

The Filters Tab
Filters provide more control over which intervals are displayed on the Cross Section
Module. Intervals that do not meet the filter criteria are not displayed. To create or
modify a set of filters, select the “Set Filters…” button on the Filters tab. For more
information on filters see Using Interval Filters.

The Interval Data Fill's Filters Tab

© 2014

Cross-Section Module

6.13

1161

Interpretive Color Fill
The Interpretive Log Color-Fill feature interpolates the values from a single log curve
in between the wells. This can be useful for visualizing stratigraphic change across a
field. This tool uses selected formation tops to help guide and constrain the
interpolation between one well and the next.

Log Data
The Log Data tab sets the log curve to be interpolated between wells.

The Log Data Tab

Select Log Curve To Interpolate From Well to Well - This dropdown selects which
log curve will be interpolated from well to well.
Use Log Aliases for Missing Logs - This option allows the interpretive log fill to use
log aliases. Without this option, only the wells with the exact curve name will have a
log fill.
User Curves from Other Well Completions - This option allows the interpretive log fill
to use log curves from other completions.

Tops Tab
Petra uses FmTops between wells to better constrain the interpolation. This tab
sets the boundaries for the interpretive log fill.
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The Tops Tab

Fill Between the Selected Tops
This list displays the tops currently displayed on the Cross Section Module.
You can choose the tops used in the interpolation. Color-fill will be generated
between each pair of tops chosen. For example, if you have tops A, B, C and D and
do not choose C, then you will have color-fill from A down to D. The grid will follow
the A-B interval and the B-D interval. Top C will have no influence on the grid. If you
chose only A and B then the color-fill when only be generated between tops A and B.

Resolution Tab
The Resolution Tab controls the resolution of the interpretive color fill grid.
Generally, smaller grids look better but require more time to generate.

The Resolution Tab

Grid Cell Width
This option sets the width of each grid cell, and can be set to small, medium, large,
or to a specified XY map unit width. In general, the default width is sufficient for
most cross sections.
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Grid Cell Height
The vertical resolution sets the height of each grid cell, and can be set to small,
medium, large, or to a specified depth unit.
This usually should be set to the resolution of the curve data on the cross section, as
coarse grid heights can obscure thinner beds.. As an example, curve data with a
half foot resolution should have a grid cell height of 0.5.

Color Range Tab
This tab sets the colorbar for the interpretive log fill.

The Color Range Tab

Minimum - This entry sets the lower value for the color bar.
Maximum - This entry sets the upper value for the color bar.
Interval - This entry sets the interpolation interval for the color bar. Note that the
colorbar can have a maximum of 46 intervals, starting with the minimum and counting
up towards the maximum.
Set Colors... - This option opens the Color Interval Definition, which can more directly
change the intervals and specific colors on the interpretive log fill.

Miscellaneous Tab
This Miscellaneous Tab sets an additional option for optimizing the interpretive log fill.
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The Miscellaneous Tab

Faster Display - Larger Plot Files - This option stores the interpretive color fill grid in
RAM, which can accelerate cross section plotting at the expense of using system
resources.
Slower Display - Smaller Plot Files - This option does not store the interpretive color
fill grid in RAM. This decreases the consumption of system resources, but can result
in slower plot times and poorer graphics.

Interpretive Color Fill and the Top Connection Method
The Interpretive Color Fill's appearance is controlled by the Top Connection Method
Dropdown Method on the Formation Tops' General Tab.
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The "Connect Tops to Borehole" (Left) and Connect Tops to Track Boundaries (Right)

6.14

From-To Pairs
"From-To" pairs establish pairs of depths on a well. These points are useful in a
variety of functions, including shifting log curves, pay intervals, and fault gaps.
To create From-To pairs, select the "From-To" button on the Fm Top Correlation
Toolbar. Alternatively, select Logs>Start Picking From-To Pairs on the menu bar at
the top of the CrossSection Module. Left click once at the top of the interval and
again at the base of the interval. Repeat to add more from-to pairs. Right click to
stop picking, or select Logs>End From-To Picking.
The From-To pair tools are available from Logs>... menu at the top of the Cross
Section Module.

For Digital Logs (uses the log curve indicated under the Logs
menu)
Depth Shift Log Curves
Amplitude Shift Log Curves
Set Data Values To NULL
Interpolate Data Values

For Fault Gaps
Create Fault Gaps - This option adds new fault cuts based on the extents of the
from-to pairs.
Shift Existing Fault Gaps - The "from" depth is used to identify an existing fault
marker and the depth of that fault is set to the "to" depth.
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For Pay Data
Pay Intervals (create) - This entry stores the From-To thickness to a selected zone
data itme.ew pay data entries are added to the database for each interval.

For Perfs
Create Perfs - New perf entries are added to the database for each interval.

6.14.1 Depth Shift Log Curves - Cross Section

One or more log curves can be interactively depth shifted. This process involves
picking pairs of adjustment points on a selected log curve displayed on the cross
section. Each adjustment pair represents the depth to shift "from" and the depth to
shift "to". This process allows log curves to be shifted up or down and curve
sections to be compressed or expanded.
Once the "from-to" pairs are picked from the displayed log curve, the "Depth Shift"
log menu invokes the shifting option. You are prompted with the well and log curve
information to verify that you want to apply the shift. You are also given an option to
apply the same depth shift to other log curves in the database.

Depth Shifting Other Log Curves
An option is available to apply the depth shift to not only the selected log curve but to
any other log curves in the database. A list box displays all available log curve names
with the currently selected curve pre-highlighted in the selection list. Click the list box
to highlight all log curves for which you want to apply the depth shift. Note: you are
not required to apply the shift to the originally selected log curve.
6.14.2 Amplitude Shift Log Curves - Cross Section

Corrections can be made interactively to the log curve values or amplitude. This
process involves picking pairs of adjustment points on a selected log curve displayed
on the cross section. Each adjustment pair represents the anchor points at which the
shift will start ("from") and end ("to"). For example, if two pairs of anchor points are
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selected, the log curve values will be shifted using the difference in the "from" and
"to" values are the depths represented for each pair. The log curve values between
the to pairs will use linear interpolation to determine the amount of shift.
Once the "from-to" pairs are picked from the displayed log curve, the "Amplitude
Shift" log menu invokes the shifting option. You are prompted with the well and log
curve information to verify that you want to apply the shift.
6.14.3 From-To Set Data Values To NULL
Enter topic text here.
6.14.4 From-To Interpolate Data Values
The log values within each interval are interpolated using the two values at the "from"
depth and "to" depth.
6.14.5 Cross-Section "Pay" Intervals
This tool stores a picked From-To pair to a zone data item or to a digital log curve.

Pay Zone Tab
This tool stores the thickness of the From-To pair to a zone data item. Note that
Petra can either add the thickness to a preexisting entry, or completely replace the
entry with the From-To thickness.

Store Pay Thickness in Zone Table - This option enables the pay thickness to be
stored to a zone data item.
Zone Item Update Mode - This option changes how Petra stores the thickness when
there is already an entry in the well's zone data item. "Replace Current Value"
completely overwrites any preexisting entry, while "Add to Current Value" simply adds
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the thickness to the pre-existing value.

Pay Curve Tab
This option stores a new curve to the database based on the From-To Pairs.

Store "Pay" Intervals as Pay Flag Curve - This option enables the pay curve to be
stored to the database.
Store Pay Flag Curve As - This dropdown sets the name of the pay flag curve. Either
select an existing curve name on the dropdown menu, or enter a brand new name.
Current Value in "Pay" Intervals - This option sets the value for the interval between
the From-To pairs. By default, this is set to 1
Curve Value in "Non-Pay" Intervals - This option sets the value for the interval outside
the From-To pairs. Note that the "Use NULL value" will set the curve value to nulls
outside the From-To pairs. By default this entry is set to 0.
Curve Update Mode - This option controls how the tool handles overwriting a preexisting pay curve. "Add or Replace Existing Curve" will completely overwrite a
preexisting curve with the same name, while the "Add or Merge Into Existing Curve"
will simply merge the new from-to interval's pay into the preexisting curve.

6.15

Grid Profile Option
The Cross-Section grid profile option projects grids created in the Map Module as a
profile across structural cross sections. Grid profiles are not plotted on
stratigraphic cross sections.
To project a grid onto a Cross Section, select Tops>Contour Grid Profiles on the
menu bar at the top of the Map Module.
A maximum of 25 surfaces can be selected and displayed. Note that grids are
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identified as subsea structure, measured depth, or datum. Datum grids are not
plotted, but are used to convert other grids to match the cross section depth axis
scale. If your grids are not showing up on the cross section, check that you have the
appropriate grid types set and are including a datum grid.

Grids Tab
The Grids Tab adds grids to the Cross Section Module, and controls their general
appearance.

Select Grids For Cross-Section Profiles
This section contains a list of available grid files located in the project's GRIDS
directory.
Choose a grid then click the "Add To List" button to select it for plotting. The grid
name will appear Selected Grids List.

Selected Grids
This section displays those grids which have been selected to plot on the cross
section. Single clicking a grid name in this list will show the current attribute settings in
the Grid Attribute section. Double clicking a grid name will show the grid's statistics.
You may remove a single grid from the selection list by using the small '>' button
located below the list box. To clear the selection list to start over, click the '>>' button.

Grid Attributes
Set each of the grid attributes for a selected grid. First, highlight the grid name in the "
Selected Grids" list by clicking on the grid name. Set the attributes (see below) and
click the "Apply" button. (Note: the Apply button is optional).
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Grid Type - The grid type determines how the grid depth values are interpreted. A
grid must be identified as either "Subsea (Structure)", "Measured Depth", or "Datum".
Including a datum grid, such as a contour map of the KB, will insure that the other
grids are correctly drawn when switching between log depths and tvdss depths.
Color - Choose the line color for drawing the grid profile.
Line Style - Choose from one of the standard line pattern styles.
Line Width - Choose from one of the standard line thickness.
Label - Enter the descriptive title for the grid. The default comes from the grid file
header.

Options Tab
The option tab controls some of the details of drawing grid profiles.

Sample Rate
The sample rate determines how many samples are interpolated from the surface grid
along the length of the cross section. The default value is 100.

Averaging
The averaging factor (N = 1..10) determines the distance around each profile data
point in Method 1. Larger values result in smoother profiles. All grid node values within
a distance of N times the grid spacing will be averaged using an inverse distance
weighting function. A value of 1 will sample only the grid nodes within a single grid cell
distance. A value of 10 allows all grid nodes that are closer than 10 times the grid size
to be included in the average. For Method 2, the averaging factor determines the
amount of smoothing applied by a triangular filter function.
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Method
Choose one of the two grid sampling methods. Method 1 samples the grid using an
inverse distance weighting and results in a smoothed profile. Method 2 interpolates
each profile point from the grid cell it is contained in.

6.16

Uassigned Tops Overview
The Cross Section Module and Log Correlation Tool both create and store
“unassigned tops.” Unassigned tops are useful for correlating things outside the
traditional definition of a formation top. This can include possible faults or other
marker "picks" that are considered by the interpreter to be unknown, uncorrelated or
otherwise "unassigned". For convenience, picks are grouped by name, color, and
interpreter. A single well can store any number of unassigned tops with the same
name. Unassigned tops are stored to Petra’s database, and are shared among
different modules and different users.
Unassigned tops can be easily correlated and converted into formal formation tops.
Once the interpreter determines that a set of picks correlates, a "correlation" line can
be created to connect the picks on the cross-section. Once you are satisfied that a
correlation is valid, it can be converted to a formation top.
To display the CrossSection Module Unassigned Tops Toolbar, select
Tops>Unassigned Tops>Toolbar.

(1) List of Pick names
(2) List of Correlation names
(3) Buttons to add and modify pick names and set pick display options
(4) Buttons to add, modify or delete picks
(5) Buttons to add and modify correlation names and set correlation display options
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(6) Buttons to connect picks as a correlation and convert a correlation to a top
(7) Eye dropper function lets you click on a pick or correlation and set the item
names in
(1) and (2)
(8) Maintenance functions for creating, modifying, and deleting picks and correlations
(9) Interpreter list to restrict (1) and (2)

UAT Workflow
The typical work flow for UAT is as follows: (#) indicates toolbar functions used
A. Create one or more pick names (1, 3 & 9)
B. Make picks on one or more cross-sections (4)
C. Create a correlation name (2 & 5)
D. Define a correlation of picks (6)
E. Convert correlation to a Top (6)

Therefore the progression from pick to top is as follows:
PICK ==> CORRELATION ==> FMTOP

UAT Picks
All picks are associated with a pick name and interpreter source. Each pick name
has its own color, line thickness and line style. Each user sharing a Petra project
should create their own pick group so their picks won't be confused with other users'
picks. Picks are drawn on the cross-section as individual and unconnected depth
markers.

UAT Correlation
A correlation is a user-defined name for a series of correlated picks. Each
correlation name has its own color, line thickness and line style. Eventually, a
correlation can be converted to a formation top. Correlations are drawn on the
cross-section as connected "picks".

6.17

Cross Section Slip Box
The slip box takes a screenshot of a part of the cross-section and places it into a
separate window inside the cross-section. This section of the log can be a great help
to correlation between one log and another. The slip box window can be moved
around the screen, as well as stretched and squeezed. The slider box on the top of
the window changes the box's opacity to make it easier to overlay on top of other
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logs.

6.18

Type Log Curve Tool - Cross Section
The Type Log Curve Tool provides a floating, re-sizable window containing a single
digital log curve. The tool can be useful for correlating logs.
While this tool is very similar to the Slip Box, there are a few differences. The Type
Log Curve Tool can only display a single digital log curve, while the Slip Box can
display an image of any combination of digital and raster logs. The Type Log Curve
has a few additional display options relative to the Slip Log, including completely
flipping the depth and log scales.

Creating a Type Log Curve Window
First, select Logs>Select Log Curve menu to choose the actual log curve for the type
log curve window. There are a couple of limitations on the specific curve selected:
the tool can only use log curves actively displayed on the cross section (set on the
Log Display Options). Additionally, this tool can only use unaliased log curves - a
good workaround is to simply disable the "Use Alias Logs" option on the Log Display
Option's Scale Tab, create the window, and then re-enable the log aliases.
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Next, select Logs>Start Picking From-To Pairs to define the depth range. Left click
once at the top of the interval and again at the base of the interval. Right click to stop
picking. If you pick multiple from-to pairs, Petra will only use the last pair to
establish the depths on the Type Log Curve Window..
Finally, select Logs>Type Log Curve Tool>Set Type Curve menu. The type curve
will appear in a floating window.
The Type Log Curve Tool window can be dragged across the screen, as well as
resized by clicking and dragging any of the edges of the window.

Type Log Curve Tool Options
There are a few additional options for the Type Log Curve Tool available by right
clicking the window.
Match Depth Scale - This option sets the height of the tool window so the log curve
matches the current depth scale.
Match Curve Scale - This option resets the width of the tool window so the log curve
scale matches the current track width.
Match Depths and Curve Scale - This option resets the vertical depth scale and
horizontal log scale to match the current cross section depth scale and log curve
scale.
Flip Scale - This option reverses the amplitude scales. For example if the curve is
plotted from 0 to 100, flipping the scale plots the curve from 100 to 0.
Flip Depths - This option vertically flips the depths on the type log, so that the base
of the from-to pair is at the top of the window. This can be useful for working with
structurally complex, overturned section.
Reload Curve - This option reloads the curve from the database. This can be useful
for updating curves that have been normalized, merged, or otherwise changed.
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Label Tops - This option toggles labels on the flip box.
No Frame - This option removes the frame around the Type Log Curve Tool.
Minimize - This option minimizes the tool window.
Help - This option displays this help screen.
Close - Closes the type log curve tool window.

Function Key Usage
Arrow Keys (unshifted) - Tool window is moved up, down, left and right.
Shift+Up Arrow - Tool window height decreased.
Shift+Down Arrow - Tool window height increased.
Shift+Left Arrow - Tool window width decreased.
Shift+Right Arrow - Tool window width increased.

6.19

Pseudo Wells
Pseudo Wells are wells added to the project inside the Cross-Section Module that
act as additional control points for drawing tops. Pseudo wells have a wells with a
special database flag set to indicate they are not real wells. Pseudo wells can be
hidden or shown on both the Cross-Section and Map Module. In the Cross-Section
module, pseudo wells sill affect the positioning of formation tops, even when the
pseudo wells are hidden. This can be useful for adding additional points to control
how tops display on the cross section.
Pseudo wells can only be added to a well-to-well cross-section with at least two
wells. Pseudo wells also require the "relative spacing" mode active on the Width and
Margins tool.
To add pseudo wells, select Wells>Add Pseudo Well on the menu bar at the top of
the Cross-Section Module.
To hide the pseudo wells, select Wells>Add Pseudo Well on the menu bar at the top
of the Cross-Section Module.
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Adding Vertical Pseudo Wells
Vertical wells are added by clicking once on the position of the well relative to the
other wells on the section.

Adding Deviated Pseudo Wells
Deviated wells are added by drawing the path of the borehole, from top to bottom,
as it should appear on the section.
When a pseudo wells is added to the cross-section, it will have a datum (KB) value
interpolated from it's two neighboring wells. The symbol code for the well is set to
"PSEUDO" and can be used to as data criteria to "find pseudo wells" using the well
selection function.
The right-click pop up well menu contains three related menus:
1) "Convert Pseudo Well to Real Well"
2) "Convert Real Well To Pseudo Well"
3) "Redraw Pseudo Well Deviated Track".
Item 3 can be used to redraw the deviated borehole for a previously drawn deviated
pseudo well.

Map Module
To hide pseudo wells on the Map Module, select the "Exclude Pseudo Wells When
Loading Wells" on the Well Symbol Style's Options Tab.
Note that the inclusion or exclusion of pseudo wells takes place when the wells are
"loaded". This means if you add pseudo wells to a cross-section they well not show
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on the map until you re-select the wells. A simple "refresh data" will not do it.
However, if you are showing pseudo wells on you map and you wish to exclude
them, simply set the "exclude" option and "refresh data".

6.20

Displaying Test Indicators
The Select Test Indicators to Plot window adds perfs, tests, shows, and other
information along the wellpaths in the Cross-Section Module.
To open this tool, select the
button on the Cross-Section Module's toolbar, or
select Wells>Post Test Indicators on the menu bar at the top of the screen.

Tests Tab
Options Tab
Remarks Tab
Dates Tab
Text Tab
IP Tests Tab
DSTs Tab
Cores Tab
PdCum Tab
Perfs Tab
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FootNotes Tab

6.20.1 Test Ind. Tests Tab

To add a test indicator, select the check box next to the desired test indicator. Next,
select the track number and position.

Track No
Each trace trace is plotted in one of the 11 predefined track positions relative to the
well symbol. As shown in the illustration below, tracks 1 through 7 are single width
tracks while tracks 0, 8, 9 and 10 are double width tracks.

Relative Position
A trace's relative position sets the position inside the track. Relative position goes
from 1 to 5, with 1 at the far left, 3 at the center, and 5 at the far right.

Depth Track Symbols
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The depth track symbols sets the a few additional indicators inside the depth track.
Options include casing, liners, prod symbols, and cement.
6.20.2 Test Ind. Options Tab

Plot Bridge Plug Symbol At Depth Track - By default, Petra plots bridge plugs in the
same track and relative position as perfs. This option overrides the position of the
perfs and instead plots bridge plug symbols at the depth track.
Taper DST Symbols - By default, Petra draws DST symbols as rectangles, This
option instead tapers the DST symbols.
Show tests from re-completions which match 10-digit API# - Generally, Petra treats
recompletions as separate wells. Accordingly ,Petra only draws the tests from the
single well displayed on the cross-section and does not include recompletions. This
option instead forces Petra to display tests from all recompletions.
Do Not Plot values When Equal to 0.0 - This option suppresses plotting values equal
to zero. This can be useful for simplifying plots.
Test Symbol Width Scaling Factor - This option scales the width of all test symbols,
where 1 is the default. Setting this value to 0.5 will
Prod Symbol Size - This option sets the size of the production symbols in inches. The
default setting is 0.2 inches.
6.20.3 Test Ind. Remarks Tab
The Remarks Tab adds remarks for the selected tests. Note the options for tests not
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selected on the Tests Tab will be grayed out.

6.20.4 Test Ind. Dates Tab
The Dates Tab restricts the tests displayed on the cross section to only those falling
within a date window.

6.20.5 Test Ind. Text Tab
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Text Options
Word Wrap Width - This option sets the number of characters for a single line of a
test remarks field. Petra will wrap the text beyond this number of characters. For
closely-spaced wells, it might be useful to decrease this enry.
Text Height - This option sets the height of test text.
Opaque Text - This option makes the text and the surrounding text boxes opaque.
This can be useful for making text more visible, but can obscure other features on the
cross section.

Remarks Position
This option sets the location of the remark text. Text can either start at the top of the
test, or centered within the top and base of the test.
6.20.6 Test Ind. IP Tests Tab
The IP Tests Tab controls how IP tests are displayed on the cross section. This tab
is only available when the IP Tests option is selected on the Tests Tab.

Plot All Production Tests - This option does not restrict the tests, and will display all of
them on the cross section.
Plot IP Tests Only - This option restricts the tests on the cross section to only IP tests
Plot Non-IP Tests Only - This option restricts the tests on the cross section to only
non-IP tests.
Preferred Tests - This option restricts the tests on on the cross section to only
"preferred tests" established on the Production Tests Detail Window available on the
IP Tests Tab.
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6.20.7 Test Ind. DSTs Tab
The IP Tests Tab controls how DSTs are displayed on the cross section. This tab is
only available when the DSTs option is selected on the Tests Tab.

6.20.8 Test Ind. Cores Tab
The Cores Tab controls how cores are displayed on the cross section. This tab is
only available when the Cored Intervals option is selected on the Tests Tab.

Cross Types To Plot - This entry restricts the cores plotted on the cross section to
only those with the "core type" specified on the Main Module's Cores Tab. To plot all
core types, leave this entry blank.
Hide Core Symbol - This option hides the core symbol. This can be useful for
reducing the visual clutter by only displaying the core remarks.
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6.20.9 Test Ind. PdCum Tab
The PdCum Tab controls how production cums are displayed on the cross section.
This tab is only available when the PD Cum option is selected on the Tests Tab.

Enter Fm Names to Restrict PdCum Data or Blank for All - This option restricts the pd
cums on the cross section to only those with one of the specified "Fm Names" set on
the Main Modules's Prod Cums Tab.

Post the Following Items
This section sets what will plot along with the production cum symbol. This can
include the formation name, dates, oil/gas/water cumvs and more. The entry box to
the right plots additional fields loaded by the user.

6.20.10 Test Ind. Perfs Tab
The Perfs Tab controls how perfs are displayed on the cross section. This tab is only
available when the Perfs option is selected on the Tests Tab.
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Restrict Perfs to Sources - This option restricts the perfs on the cross section to only
those with one of the specified source set on the Main Modules's Perfs Tab.
Plot Other Sources is Above Source Not Present - When the selected perf source
specified on the "Restrict Perfs to Sources" isn't available, this option allows Petra to
plot other perf sources. This effectively just makes the entered sources a priority
rather than a strict requirement.

Problem Perfs
"Problem" perfs are duplicate or overlapping perf intervals in the database. The Perfs
Tab can filter these perfs out without actually deleting them from the database.
Skip "Problem" RED Perfs - This option prevents large overlapping gross interval
perfs from appearing on the cross section.
Skip "Problem" BLUE Perfs - This option prevents duplicate perfs from appearing on
the cross section.

Include or Exclude Perfs by Type
By default, Petra plots all perf types. This tool selectively displays different perf types
on the cross section.
Do Not Restrict Perfs By Type - This option just plots all perf types.
Include the Selected Perf Type - This option will include only the perfs selected on the
Perf Type List below. Only the checked perf types will plot.
Exclude the Selected Perf Type - This option will exclude the perfs selected on the
Perf Type List below. Perf types checked will not plot.
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6.20.11 Test Ind. FootNotes Tab

By default, Petra displays text about test indicators along side the test symbol on the
wellbore. This option instead plots the test text as a footnote at the bottom of the
wellbore.
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SpreadSheet Module
The spreadsheet tool allows you to edit data from the database in spreadsheet
format. Spreadsheet columns are made up of selected Well Header or Zone data
values. Options include copying, sorting, computing statistics, find/replace, among
others.
IMPORTANT: Petra does not automatically save changes made in the
Spreadsheet Module to the project database unless instructed. The values
displayed on the Spreadsheet Module are the values at the time the spread sheet
was created. Any changes made in the Spreadsheet module must be save to the
project. Users must Save the changes to the project by selecting File>Save on
the menu bar at the top of the screen or by selecting the "Yes" option when
requested to Save.
To open the Spreadsheet Module:
Select Tools>Spreadsheet on the Main Modules menu bar
Click the

button on the Main Module Toolbar

Important: The first time that the the Spreadsheet Module is opened the
Spreadsheet Options dialog will open so that the default columns can be selected.
Thereafter, the spreadsheet will open populated with the selected well values.

Read Only - This check box disables the Spreadsheet Module from writing back to
the project database. This is intended as a safeguard to prevent data from
accidentally being modified.
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- Opens the Spreadsheet Options Tool.
- Manually refreshes the displayed data. Alternatively, select Columns>Reload
from the menu bar at the top of the screen
- Changes back to the project database. Alternatively, select File>Save on the
menu bar at the top of the screen.
- Opens the Replace tool that performs a find/replace on the currently selected
column.
- Sorts the spreadsheet by the currently selected column in ascending
alphabetical order.
- Sorts the spreadsheet by the currently selected column in descending
alphabetical order.
- Opens a Data Statistics window. This window will have a list for well header
info, and a histogram for numerical data items.
Related Topics
Selecting columns
Working With Columns

7.1

Spreadsheet Options
The Spreadsheet Options dialog box allows you to:
Select the well header and Z data items which make up the columns of the spread
sheet.
Select and sort any subset of wells in the Spreadsheet
Select Spreadsheet Module start up options
To select or change Spreadsheet Options:
Click the

button on the top of the Spreadsheet Module or,

Select Columns>Select... on the Spreadsheet Module menu bar
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Related Items:
Spreadsheet Columns Tab
Spreadsheet Wells Tab
Spreadsheet Options Tab
7.1.1

Spreadsheet Options Columns Tab
The Spreadsheet module can display well header information (like API, well number,
elevation datum, etc) and zone data items. Note that formation tops are in the
"FMTOPS" zone, and can either be expressed as MD, SSTVD, or TVD tops.
Spreadsheet columns are made up of selected Well Header or Zone data values. To
select,add,or replace the columns included in the spreadsheet:
Click the
Tab

button on the top of the Spreadsheet Module and then the Columns

Select Columns>Select on the Spreadsheet Module menu bar
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Column is Quality Code Field - Selecting this option sets the desired column to use the
data item's quality code field rather than the actual value.
Column is Remark Field - Selecting this option sets the desired column to use the data
item's remark field rather than the actual value.
Use Aliases - This option uses zone data item aliases to display "equivalent" data
items when the selected zone data item is unavailable. Note that Petra can only read
aliased data items, and will not overwrite any values.
To add a column:
1. Select the desired header information or zone/data item.
2. Select the "+ Add" button.
To replace a column:
1. Select the item in the Spreadsheet Data Columns list.
2. Select the replacement data item from the Select Data Column Item section.
3. Select the "Replace" button.
To remove a column(s):
1. Select the desired column(s) from the Select Data Column Items list.
2. Click the "<" button.
3. To drop all logs from the Selected Logs list, left click the "<<" button.

Saving Column Lists
Frequently used lists of data items can be saved to disk for future use. The "Save"
and "Load" buttons save column settings to an external spreadsheet columns (*.SSC)
file.
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Spreadsheet Options - Wells Tab
The Spread Sheet Module can display any subset of wells in the project. To select or
change the wells shown:
Click the
or,

button on the top of the Spreadsheet Module and then the Wells Tab

Select Wells>... on the Spreadsheet Module menu bar

All Wells - This option selects all wells in the project.
Wells By Data Criteria - This option opens the Wells By Data Criteria tool that selects
wells by specific data criteria.
Map Selected Wells - This option selects the wells currently selected in the Map
Module.
Main Selected Wells - This option selects the wells currently selected in the Main
Module.
Cross-Section Wells - This option selects the wells currently selected in the CrossSection Module.

Sorting Wells
The Spreadsheet Module can sort wells by the data in a selected column in
Ascending, Descending, Original or Multi Column order. To sort the wells, select any
data cell in the desired column for the sort and then select the sort method from the
Spreadsheet Module menu bar Wells>Sort... or the right-click pop up menu.
When wells are sorted, wells containing a null value in the sort column are positioned
to be bottom of the list.
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Sort Original Order - resorts the wells by WSN, or Well Serial Number. A well's
WSN is just the order it was loaded into the project
Multi Column Sort sorts wells by multiple columns. When Multiple Column Sort is
selected the following dialog is displayed to select the relevant columns for sorting in
priority from top to bottom.

7.1.3

Spreadsheet Options - Options Tab

Use BH Location Data - This option uses bottom hole locations rather than the default
surface locations.
Startup Options - Checking opens Spreadsheet Options dialog box by default rather
than the Spreadsheet populated with current column values.
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Working with Columns

Column Statistics
A statistical histogram can be displayed for numeric data columns. Click any data cell
of the desired column and choose the "Show Stats" menu of either the "Columns"
menu or the pop up menu invoked with the right mouse button.

Find and Replace
The find option can search the current column for a specified value. Values in the
current column may be replaced using the same option. Set the current column by
clicking any data cell of the desired column. The find and replace functions search
downward from the current data cell.
To apply a Find and Replace, select the
button on the toolbar or select
Search>Find and Replace on the menu bar at the top of the Spreadsheet Module.

Upper Case Option
Columns>Set Column Data To Upper Case - This option converts all lower case
characters in the current column to upper case.

Export>Comma Delimited File
This option copies the currently selected data out to a comma delimited file.
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Include Column Headings - This option includes column headings at the top of the CSV
file. Deselecting this option removes headings, which can make importing the data
easier for some software packages.
Include WSN Column - By default, Petra includes the well's Well Series Number in the
export. Since this number just reflects the order the well was imported into the
project and serves as an internal record keeping for Petra, it may not be useful in all
applications.
Put Double-Quotes Around Data - This option adds double quotes around data. This
can make imports easier for some software packages.
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Log Cross Plot Module
The Log Crossplot Module graphically compares two different log curves on an X-Y
scatter plot to help identify the log response to lithology. Color-coding the data points
can show an additional third variable on the scatter plot.
To open the Log Cross Plot Module, select Tools>Log Data Cross Plot from the menu
bar at the top of the Main Module.
This brings up the “Data Definition” screen superimposed over the main Crossplot
Module, both of which are blank by default.

The Data Definition window (left) and a blank Z Cross Plot Module

Getting Started
Selecting wells
Setting the depth range
Setting the X and Y Axes
Setting Z-Axis color coding

Advanced Tools
Regression Lines
Drawing Polygons
Pickett Plots
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Log Crossplot Selecting Wells

Selecting Wells
The Log Crossplot Module can display any subset of wells in the project. To change
the wells shown, select Wells> from the menu bar at the top of the Log Crossplot
Module
All Wells - This option selects all wells in the project.
Wells By Data Criteria - This option opens the Wells By Data Criteria tool that selects
wells by specific data criteria.
Map Selected Wells - This option selects the wells currently selected in the Map
Module.
Main Selected Wells - This option selects the wells currently selected in the Main
Module.
Cross-Section Wells - This option selects the wells currently selected in the CrossSection Module.

To switch between wells, select either the desired well on the dropdown at the top of
the Log Crossplot Module or use the left and right arrows to scroll through the
selected wells.

Plot Single/Combine All Wells
Petra can either plot the log crossplot data points from a single well or from multiple
wells in aggregate. To switch between these two modes, select Wells>Plot Single
Well and Wells>Combine All Wells. Note that showing multiple wells will remove the
curves displayed on the right side of the screen – after all, with data points from
multiple wells, which curves would you show?
By default, data points from all wells are shown the same color. To color code
different wells by different colors, select the “Use Different Symbol Color When
Combining Wells” on the General Tab of the Log Cross Plot Data Definition screen
available from Logs>Axes and Scales on the menu bar at the top of the screen. Note
that this color coding only uses ten distinct colors; plotting more than ten wells will
recycle colors.

8.2

Log Crossplot Set Depths
It’s often useful to limit the crossplot’s data points to a specific interval of interest.
Data points can be constrained by zone definition, tops, or by a specified depth (MD
or TVD).
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On the menu bar at the top of the screen, select Depths>Set Depths… from the menu
bar at the top of the screen. Alternatively, select the
button on the toolbar at the
top of the Crossplot Module. This opens the Depths Tab on the Log Cross Plot Data
Definition screen.

Zones
To set depths by a zone’s interval definitions, select the “Set Depths From Zones”
button. Next, select the desired zone. Note that the WELL zone by default covers 1M MD to +1M MD, so it should cover the entire footage of all wells. If the tops used
in the zone interval definition are missing for a well, Petra will not display the log plot.

Set Depth From Range
To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TV Depth button. For MD and TVD, select the
relevant button and enter the adjacent depth in the entry field.

Tops
For tops, select the desired top from the “Fm Top Name” dropdown box. Notice that
an offset can also be added or subtracted to the fm top; this offset will include data
points above or below the actual fm top depth.

8.3

Log Cross Plot Data Definition
The Log Data Cross Plot Data Definition tool sets the X and Y axes, establishes Z
color shading, saves templates, and sets titles and labeling.
To open the Z Data Cross Plot Data Definition tool, select the

button option on
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the menu bar at the top of the Log Crossplot module, or select Logs>.Axes & Scales.

General Tab
X - Y Axes Tab
Z - Axis
Discriminators Tab
Depths Tab
Z Capture Tab
Options Tab
Tops Tab
8.3.1

Log Crossplot Data General Tab
The General Tab controls the presentation of the cross plot, including the title, the
cross plot type, and labels. The General Tab also governs the symbol style for
individual data points.
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Title
This box sets the title for the plot. This title will appear at the top of each cross plot
display.

Cross Plot Type
X-Y and X-Y-Z Plot– This option creates a scatter plot with two logs forming the
vertical and horizontal axes. Note that this option creates the X – Y Axes Tab next to
the General Tab. A third variable (Z) can be shown by color coding the individual data
points.
Ternary Diagram - This option displays three log values on an equilateral triangle.
Ternary diagrams are most commonly used to display ratios between three variables
that add up to a constant, such as the relative percentages of shale, sandstone, and
limestone that add up to 100%. In Petra, however, the three scales on the diagram
are independent, so they don’t necessarily need to add up to a constant. Note that
this option creates the Ternary Tab next to the General Tab. A fourth variable (Z) can
be shown by color coding the individual data points.

Label Well Using
This dropdown sets how wells are labeled at the top of the plot. Wells can be labeled
by UWI, name, number, well label, UWI and name, or well name and number.

Symbol
These dropdowns set the shape and size of the data points on the plot. By default,
data points are red but can be color-coded to reflect an additional curve on the Z Axis
Tab.

Show Curves For
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This option simply filters the available curves on the Ternary and X – Y Tabs.
Selecting “All Wells” shows curves for all wells in the project, while “Selected Wells
Only” limits the curve selection only to curves available to the currently selected wells.
It’s generally simpler and faster to keep this setting to “Selected Wells Only.”
Use Different Symbol Color When Combining Wells - Petra can show log data points
for a single well, or for multiple wells. This option color codes different wells by
different colors. Note that this color coding only uses ten distinct colors; plotting more
than ten wells will recycle colors. Deselecting this option will plot all log data points a
default red.
The examples below show a combination of four wells. The plot on the left shows
every data point from every well as red. The plot on the right, however, breaks out
the data points from each well in a different color (blue, pink, green, and red).
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Log Crossplot Data X-Y Axes Tab
The X-Y Tab is only available when “X-Y and X-Y-Z Plot” is selected on the General
Tab. This tab sets the curves and scales for the scatter cross plot. Note that if any
of the curves are unavailable, Petra cannot plot the diagram. If using log aliasing,
make sure to select “Use Log Aliases” on the bottom part of the tab.

X-Axis and Y-Axis
This section sets the curve and scale for the horizontal X axis and the vertical Y axis.
Select the desired curve on the dropdown, and set the scale using the Minimum and
Maximum. In the example below, the X axis is a gamma ray log, and the Y axis is a
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deep resistivity log. Note that both curves can also be displayed in a logarithmic
scale; just be sure to select a minimum above zero. The “Use Depths of Above Curve
for X/Y Axis” will instead plot the other axis curve relative to depth.
The example below shows an X – Y log cross plot where gamma ray is on the
horizontal X axis and deep resistivity is on the vertical Y axis. Note that the resistivity
log is on a log10 scale. The logs for the relevant curves are plotted to the right of the
screen since this plot only shows the log cross plot for a single well.

Swap X & Y - This button simply swaps the selected curves, scales, and settings for
the X and Y sections.
Connect Points - This option draws a connecting line between data points down MD
on the curve. This connecting line is a little smaller than the data points, and is red by
default.
The example below shows the cross plot with connected points. Especially with less
log footage (and fewer data points), this plot illustrates how the curve cross plot
relationship changes with depth.
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Plot Histograms - This option adds a histogram along both axes showing the
distribution of each curve’s data points. The example below shows histograms
arranged for both the horizontal and vertical axes.

8.3.3

Log Crosspllot Data Ternary Tab
The Ternary Tab is only available when “Ternary Diagram” is selected on the General
Tab. This tab sets the curves and scales for the three logs on the plot. Note that if
any of the curves are unavailable, Petra cannot plot the diagram. If using log aliasing,
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make sure to select “Use Log Aliases” on the bottom part of the tab.

Axis 1, 2, and 3
These sections set the curve and scale for the three axes on the triangle. Select the
desired curve on the dropdown, and set the scale using the Minimum and Maximum.
Note that curves can also be displayed in a logarithmic scale; just be sure to select a
minimum above zero.
The example below shows a ternary diagram between gamma, neutron porosity, and
deep resistivity. The three curves used in the diagram are shown on the right side of
the screen. Unlike a traditional phase diagram or lithologic percentage plot, the data
points do not add up to a constant value. Instead, this plot represents how the
petrologic data clusters together in different facies.
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Log Crossplot Data Z Axis Tab
The Z-Axis tab color codes data points by an additional third log curve, giving a third Z
dimension to the scatter or ternary diagram.

Use Z Axis log
This option simply toggles the selected Z-axis coloring. When toggled on, data points
will use the Z-axis colors. When toggled off, Petra just uses the default color for data
points, but retains all the color and curve settings for the Z axis.
Use Z-Axis Colors When Combining Wells
This option overrides the “Use different symbol color when combining wells” option on
the General Tab.

Z – Axis
This section sets the curve and colorbar for the data points. Select the desired curve
on the dropdown, and set the scale using the Color Range button.
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Here, set the minimum and maximum values for the contours in the “MIN” and “MAX”
boxes. The “Interval” sets the contour interval between colors. There can be up to 47
different intervals. Petra comes with several other color schemes available through
the “Default” button on the right side of the screen. The example above uses
“rainbow.zpl.” To create a new color scheme, select an individual interval and select a
color from the palette for that interval.
The two examples below demonstrate how Z data can add an additional dimension to
log cross plots. The first example colors a gamma and deep resistivity cross plot by
density porosity values. Cool sandy data points tend to correlate with higher porosity,
with the notable exception of an island of high resistivity tight streak in the upper left
corner of the plot.
The second example shows a gamma ray, resistivity, and neutron porosity ternary
cross plot with data points colored by density porosity. This plot reaches similar
conclusions as the first, with the added conclusion that neutron porosity and density
porosity are closely related.
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Log Crossplot Data Discriminators Tab
The discriminator curve filters data points by log criteria. Select one or more curves
on the dropdowns, and set the scale using the Minimum and Maximum. Data points
that fall outside of this data criteria are not included on the cross plot. In the example
below, only data points where density porosity is between 10% and 30% will be
included on the plot.

Include Discriminator Logs When Plotting Curves
This option simply plots the discriminator curve along the other curves on the right side
of the screen and at the scale specified by the minimum and maximum cutoff values.
In the example below, low density porosity values are filtered out, simplifying the plot.
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Notice that the density porosity curve (DPHI) is used twice – as a “Z Axis” color scale,
and also as a discriminator curve.

8.3.6

Log Crossplot Data Depths Tab
The Depths Tab sets the depths of the data points for the cross plot. This is most
useful for limiting the cross plot to a specific interval of interest. Data points can be
constrained by zone definition, tops, or by a specified depth (MD or TVD).

Zones
To set depths by zone, select the “Set Depths From Zones” button. Next, select the
desired zone. Petra will use the zone interval definitions established in the Main
Module. Note that the WELL zone by default covers -1M MD to +1M MD, so it should
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cover the entire footage of all wells. If the tops used in the zone interval definition are
missing for a well, Petra will not display the log plot.

Set Depth From Range
To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TV Depth button. For MD and TVD, select the
relevant button and enter the adjacent depth in the entry field.
For tops, select the desired top from the “Fm Top Name” dropdown box. Notice that
an offset can also be added or subtracted to the fm top; this offset will include data
points above or below the actual fm top depth. In the example below, data points up
to 100 feet above the “2ND_WALL_CREEK” top and 50 feet below the
“2ND_WALL_CREEK_BASE” top will be included in the cross plot. Note that the “Set
Upper and Lower Depths From Zone” will populate the depths fields on this screen
with the selected zone’s interval definitions. This makes it easier to select an existing
zone’s definitions and modify them.

Sample Decimation
This option decreases the total number of data points in the cross plot by only
including every Nth valid data point. This can be useful when working with large
intervals, or with finely sampled curves. As an example, setting N = 3 means that
Petra will only include every third data point. To plot every available data point, select
N = 1.
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Log Crossplot Data Capture Tab
The Log Cross Plot Module can also calculate and capture Kendall’s Tau to a specific
data item for each well selected. Kendall’s Tau is a measurement of the association
between two measured quantities.

8.3.8

Log Crossplot Data Options Tab
The Options Tabs sets a couple of additional options for the Cross Plot Module.

How to Determine Default Scale Ranges
This option simply governs how Petra populates the scale ranges on the X-Y Axes
Tab and Ternary Tab when a curve is added for the first time. By default, Petra uses
the user-set default ranges established in the Main Module’s Logs Tab. Alternatively,
Petra can conduct a statistical measurement of the curves.

Create Regression Report
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This option creates a regression report called “xplot_regression.txt” in the project’s
PARMS directory. This report contains statistical measurements of the relationship
between the X and Y axes, as well as a regression linear equation. While inside the
Log Crossplot Module, select CTRL + R to quickly open this report.
REGRESSION REPORT
Jul 1, 2010 10:10 AM
X = GR
Y = ILD
LINEAR REGRESSION
N = 266
SUM X = 27227.29900
SUM Y = 27227.29900
SUM X^2 = 3078851.23372
SUM Y^2 = 171.41121
ssx = 291912.09524
ssy = 20.44893
r1 = -2082.67644
r2 = 5969289.15957
Corr Coef = -0.85243
Slope = -0.00837
Y-Int = 1.61005
Std Error = 0.15120
Equation: LOG(ILD) = (-0.00836969)*GR + 1.6101

8.3.9

Log Crossplot Data Tops Tab
The Tops Tab sets the display of tops against the curves displayed on the right side
of the screen.

Display Tops on Logs - This option simply toggles the selected tops. When toggled
on, the curve vs depth plot on the right will display the selected tops. When toggled
off, Petra leaves off the tops, but retains all the tops and color settings.
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Available and Selected Tops
To add a top highlight the desired top name in the "Available Tops" list and click the
add button (">"). This moves the log over to the “Selected Tops” list. To remove a
top, highlight the top name in the “Selected Tops” list and click the remove button
("<"). The “>>” and ”<<” buttons add all tops and remove all tops, respectively.

Style
To change the color of a top, select the top on the “Selected Tops” list and select the
desired color using the color box on the right. The “All” button applies the selected
color to all tops on the “Selected Tops” list. In the example below, the
2ND_WALL_CREEK” top and the “2ND_WALL_CREEK_BASE” tops are both
displayed in red.

8.4

Log Cross Plot - Pickett Plot Overlay
A Pickett Plot is a double logarithmic plot of resistivity versus porosity.
To add a Pickett Plot, select Options>Pickett Plot. Here, add the cementation,
saturation, tortuosity, and water resistivity coefficients at formation temperature.
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The Pickett Plot Overlay displays up to 3 water saturation lines based on the Archie
water saturation equation:
Log(RT) = -M*Log(PHI) + Log(A*Rw) - N*Log(Sw)
Constants are supplied for M, N, A, and Rw. Up to 3 Sw values can be specified.
Each Sw value produces a separate line on the cross plot.
The cross plot must have a Resistivity curve as the X axis and a Porosity curve as
the Y axis. Both axes must be log 10 scale. Typically the Porosity is scaled from
0.01 to 1.0 and Resistivity is scaled from 0.1 to 1000.
The Pickett Plot can have up to three water lines. By default, the 100% water
saturation line is added. To change these water saturation lines, enter in the desired
percentage (in decimal values from 0 to 1) and toggle the relevant line’s button to the
left.

8.5

Log_Crossplot Polygons
Facies polygons outline different areas of the crossplot. Each polygon in the
Crossplot Module can have its own name, color, and “facies value.” A facies value is
a way of coding a log crossplot polygon into a facies curve.
When creating a facies curve, Petra compares the footage of the relevant curves to
the log crossplot polygons. The MD of data points falling inside a polygon’s boundary
are given that polygon’s facies value. As such, facies polygons allow for a more
nuanced cutoff criteria, since polygons vary the cutoff based on the relationship
between logs. Additionally, multiple polygons means that a facies log can code for
multiple facies at the same time.
The example below shows a Gamma/Resistivity crossplot with a single “pay” polygon.
This polygon covers the data points where gamma is lower than about 90 API units
and resistivity is above 10 ohmm – in short, it’s the potentially productive sand. Its
facies value is 1. On the curves to the right, the data points inside this polygon are
highlighted in red. Footage-wise, it’s from about 2905 to 2940’ MD.
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Carrying on the example, the polygon is converted to a facies log. All the data points
inside the polygon are coded with the facies polygon’s value of 1. The example below
shows how a facies curve actually looks in the Main Module; the depths where the
gamma and deep resistivity curve values fall inside the polygon are coded with a
facies value of 1. Thought this example only shows one well, a single facies polygon
file can be applied to any number of wells, making it a powerful way of interpreting
crossplots over an entire project.

Making a Facies Polygon
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To establish a facies polygon, right click anywhere on the log plot and select “Add
Polygon.” Alternatively, select Polygons>Add from the menu bar at the top of the
screen. Drawing a polygon works exactly the same as drawing lines elsewhere in
Petra. Pick polygon node points with the left mouse button and select the right mouse
button to stop picking points. Petra will automatically close open polygons.
During picking, press ESC picking to cancel the current polygon or DELETE to drop
the last picked point. Selecting F1 while picking will snap the cursor to the nearest
node point on another polygon, which can be useful for generating polygons with no
empty space between them and no overlap.
Once the polygon is picked, Petra brings up the “Polygon Definition” box. Here,
simply enter the name of the polygon or facies, pick a color, and add a polygon facies
value. The facies name is be the only way of distinguishing the polygons apart when
calculating a facies curve, so spending time on descriptive names is a good idea. This
facies value is the numerical code used when making facies curves, so make sure
every facies has a unique value.

Modifying and Deleting a Facies Polygon
To change the area of a facies polygon, right click anywhere on the log plot, select
“Select Polygon”, and then left click on the desired polygon. Make sure to click right
on the line. Alternatively, select Polygons>Select from the menu bar at the top of the
screen, and then left click on the desired polygon. This highlights the polygon and
shows its node points; select a node point and drag it to the desired position to
change the outline of the polygon. When finished, right click and select “Redraw” to
refresh the screen and show the changes.
Changing a polygon’s name, color, and facies value is similar. Select the polygon with
the mouse, as outlined above. Once the polygon is highlighted, right click and select
“Modify Polygon.” Alternatively, select Polygons>Modify from the menu bar at the top
of the screen with the polygon is highlighted. This opens the Polygon Definition box,
which sets name, facies value, and color for the polygon.
To delete a drawn polygon, select the polygon with the mouse as outlined above.
Once the polygon is highlighted, right click and select “Modify Polygon.” Alternatively,
select Polygons>Modify from the menu bar at the top of the screen with the polygon
is highlighted. This opens the Polygon Definition box. Select the “Delete Polygon”
button on the bottom of the box.

Loading and Saving Facies Polygons
Closing the Log Crossplot Module erases the polygons from Petra’s memory, so
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make sure to save the polygons to a file. Additionally, this file will be used later to
create facies curves. Select Polygons>Save from the menu bar at the top of the
screen. Create a name and select the save button.
On the Save Polygons to Disk box, the area outside the polygons name and value can
be modified. By default this area is named “DEFAULT” and its value is zero. This
screen also allows for a comment to better describe the polygons.

Creating Facies Curves from Facies Polygons
To compute a facies curve, select Compute>From Logs>Advanced Transforms from
the menu bar at the top of the screen in the Main Module. This opens the “Log
Transformations” module.

Setting the Wells and Depths in the Log Transformations Box
First, select the desired wells and depths in the Log Transformations Module with
Wells>Select. “Current Well From Main” selects the single well currently selected in
the Main Module. “All Wells” selects all wells available in the project. “By Data
Criteria” selects wells based on a set of nested criteria including well headers, logs,
or zone data. “Wells From Main” selects all wells currently selected in the Main
Module.

© 2014

1218

PETRA Help

Next, limit the calculation by depth ranges in the Log Transformations Module by
selecting Depths>Depth Range on the menu bar at the top of the screen. The
interval calculated can be constrained by zone definition, tops, or by a specified depth
(MD or TVD)

Using the Crossplot Facies Model to Calculate a Facies
Curve
Next, select the “Facies Log” button,
, or select Transform>X-Plot Facies Model
from the menu bar at the top of the Log Transformations Module. Petra will then ask
for the location of the saved facies polygon file (*.XPP). Select the desired polygon
file. Petra then opens the Facies Log from Cross Plot Polygons tool. This tool is
divided into several different tabs.
On the File Tab, the “Facies Polygon File” entry box should be populated with the
selected facies polygon file. The File Comments entered when saving will be shown
below. To select a different facies polygon, select the “Browse” button.

The Logs tab sets the logs used in the facies curve calculation. To change the logs
used in the crossplot calculation, select the desired curves on the X-Axis and Y-Axis
dropdown boxes. Note that changing the logs will keep the polygon cutoff values the
same. If using log aliases in the project, make sure to select the “Use Log Aliases”
checkbox. This window also changes the name of the output facies curve; by default
this is set to “FACIES” as in the example below. To change the name, just enter in a
new curve name.
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The Facies Tab sets the actual values used in the facies curve. The “Default Facies
Value” entry box sets the value of any foot where the curve data doesn’t fall inside any
of the polygons. In the example below, it’s set to 0.
The “Log Values For Each Facies Polygon” window lists each of the polygon names
along with their respective facies values. The values shown are initially populated by
each polygon’s “facies value” created in the Log Crossplot Module. To change a
polygon, select the polygon name on the list, and change the value on the “Edit Value”
box. Select the “Change Value” button to accept the changes. In the example below,
depths where the gamma ray and deep resistivity fall into the “PAY” polygon will be
coded as 1 on the facies curve, while all other depths will be set to zero.

The Discriminators tab filters data points by log criteria. To set a discriminator curve,
select up to 5 curves and set the scale using the minimum and maximum entry boxes.
Data points that fall outside of these data criteria are not included in the facies curve
and will be given the default facies value entered on the Facies tab.
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Z Cross Plot Module
The Z Crossplot Module graphically compares different Zone Data Items on an X-Y
scatter plot to help identify the relationship between multiple variables. Color-coding
the data points can show an additional third variable on the scatter plot. This module
can be used to display petrophysical relationships, production information (when
stored in a data item), or any other parameter stored in a zone.
To open the Z Cross Plot Module, select Tools>Z Data Cross Plot from the menu bar
at the top of the Main Module.
This brings up the “Data Definition” screen superimposed over the main Crossplot
Module, both of which are blank by default.

The Data Definition window (left) and a blank Z Cross Plot Module

Getting Started
Selecting Wells
Setting the XY Scales
Setting Z-Axis color coding
Additional Options
Loading and saving Data Definitions

Advanced Tools
Regression Lines
Drawing Polygons

9.1

Z Cross Plot Selecting Wells
By default, The Z Crossplot Module simply uses the wells selected in the Main
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Module. All data points for all these wells show up on the scatter plot.
To change the wells selected on the Z Cross-plot, select theWells> option on the
menu bar at the top of the screen.
All Wells - This option selects all wells in the project.
Select by Data - This option opens the “Select Wells By Data” option. This tool can
refine the wells used in the cross plot based on several different criteria. Additionally,
multiple nested searches can combine to make for more precise well lists.
Wells from Main/Map/Cross-Section - These options select the wells currently active
in the relevant module. As an example, selecting “Wells from Map” selects only the
wells currently selected in the Map Module.
Highlight from Polygon - This option changes the color of the data points inside a given
polygon to use the same color as the polygon.

9.2

Z Data Cross Plot Data Definition
The Z Data Cross Plot Data Definition tool sets the X and Y axes, establishes Z color
shading, saves templates, and sets titles and labeling.
To open the Z Data Cross Plot Data Definition tool, select the Data option on the
menu bar at the top of the Z Crossplot module.

The Z Data Cross Plot Data Definition X-Y Axis Tab

X-Y Axis Tab
Z Axis Tab
Options Tab
File Tab
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Z Cross Plot Data Definition X-Y Axis
The X-Y tab ontrols the basic settings for the plot, like the plot title and axes.

The Z Data Cross Plot Data Definition X-Y Axis Tab

Title - This entry sets the title of the plot.

X Axis Data
This section sets the specific zone and data item, for the X axis of the plot. The upper
dropdown select the zone, and the lower dropdown selects the data item.
Minimum (left) - This entry sets the minimum value for the cross plot.
Maximum (right) - This entry sets the maximum value for the cross plot.
Log Scale - This button sets the selected axis to a logarithmic scale.
Stats - This button displays a histogram of the z data for the selected wells, which can
aid in setting a reasonable minimum and maximum scale for the plot.
Defaults - This option sets the minimum and maximum scale based on the minimum
and maximum data value in the data. If the minimum and maximum values are more
than 500 apart (and is not a top or contains negative numbers), Petra will
automatically scale the axis to a logarithmic scale. Note that dates can also be used
in these fields in the format MM/DD/YY, like 01/01/1910.

Y Axis Data
This section sets the specific zone and data item, for the Y axis of the plot. The
upper dropdown select the zone, and the lower dropdown selects the data item.
Minimum (lower) - This entry sets the minimum value for the cross plot.
Maximum (upper) - This entry sets the maximum value for the cross plot.
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Log Scale - This button sets the selected axis to a logarithmic scale.
Stats - This button displays a histogram of the z data for the selected wells, which can
aid in setting a reasonable minimum and maximum scale for the plot.
Defaults - This option sets the minimum and maximum scale based on the minimum
and maximum data value in the data. If the minimum and maximum values are more
than 500 apart (and is not a top or contains negative numbers), Petra will
automatically scale the axis to a logarithmic scale. Note that dates can also be used
in these fields in the format MM/DD/YY, like 01/01/1910.

Misc
View Z Data - This button opens a zone data item viewer. Here, use the "+" button to
the left of the desired zone to expand the tree, and then select the desired data item.
Note that entries here can be edited as well.

The View/Edit Zone Data tool with no data item selected (left) and with a data item selected (right)

Flip X Y - This option flips the X and Y axis.
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Z Cross Plot Data Definition Z-Axis
The Z-Axis tab color codes data points by an additional Z data value, giving an
additional dimension to the XY scatter plot.
Data points that do not have a Z value will not be plotted.

The Z Data Cross Plot Data Definition Z-Axis Tab (left) and a color-coded cross plot (left)

Use Z-Axis - This option enables Z-Axis color coding.

Z Axis Data
This section sets the specific zone and data item, for the Z axis color coding. The
upper dropdown select the zone, and the lower dropdown selects the data item.
Minimum (left) - This entry sets the minimum value for the cross plot.
Maximum (right) - This entry sets the maximum value for the cross plot.
The normal colorbar is Petra’s default way of selecting the colors for a grid. This
system gives greater flexibility in changing colors and irregularly spaced intervals, but
tends to be a little more work to set up and has a more limited total number of
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intervals.

The Color Interval Definition Window

Edit Value
Each selection of the interval list box displays the interval "z" value in the Edit Value
entry field. Use the Apply button to modify the z value. Intervals need not be a
constant increment, however, z values must increase from top to bottom.

Set Interval
Min - This option sets the maximum contour. Grid values below this minimum won't
appear on the contours.
Max - This option sets the maximum contour. Grid values above this maximum won't
appear on the contours.
Interval - This option sets the desired contour interval.
Apply - This button creates intervals from the minimum to maximum.

Number of Intervals
This option displays and modifies the total number of intervals on the interval list. The
normal colorbar can handle a total of 46 different intervals, starting with the minimum
and counting up towards the maximum. Decreasing intervals will drop the highest
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intervals first. Similarly, adding additional intervals will add add intervals above the
maximum.

Color Scheme
Load... - This button loads a previously saved set of intervals and colors.
Save... - This button saves the current set of intervals and colorbar to a *.ZPL file.
Default Colors - This button resets the color palette and intervals to the grid defaults.

Palette
Changing An Interval Color - To change the color for a particular interval, select
the interval by clicking the left mouse button on the list box in the center of the screen.
The interval color will be highlighted in the color palette. Click the left mouse button on
any color palette color cell to change the interval's color.
Set Colors... - This button changes the the selected palette's color. Alternatively,
doubleclick the palette color
The system color selection dialog is activated for changing the cell's color. The
system color dialog can also be used to define several additional customized colors.
Use
Interp - This button will interpolate the entire palette starting with the upper left corner
and ending with the lower right corner. If you want to interpolate between two specific
cells, click the starting cell then hold down the CONTROL KEY and click the ending
cell. All intermediate cells will be interpolated.
Load... - This button loads a previously saved customized color palette.
Save... - This button saves the current color palette to a *.ZPL file.

- The "Fill with Pallete" button fills the color scheme with the current palette from
top to bottom starting with the upper left corner palette cell. If the number of color
intervals is less than the number of palette colors, then only the beginning palette
colors will be used. See the "Stretch Fill" option to fill the color scheme with all palette
colors.
- The "Flip Colors" button inverts the colors in the internal list box from top to
bottom.
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- The "Stretch Fill With Palette" button will fill the color scheme starting with the
upper left-most palette color. The entire palette will be "stretched" over the color
interval range.
Default - This option selects one of Petra "default" colorbars. By default, these ZPL
files are stored in C:\geoplus1\Parms.

Selecting a "Default" colorbar

Auto Incr - This option advances the interval list box item following color selection for a
particular interval. Use this feature to quickly set the colors for all items in the interval
list box. Simply select the first numeric interval and begin selecting colors from the
palette. Each click of the palette sets the color for the current interval and advances
to the next interval. Continue until all interval colors are selected.

Changing Colors on a Normal Colorbar Walkthrough
Changing the palette on the right side of the screen directly changes the colors used
on the colorbar. To change a color on the palette, double click inside any color box to
bring up a color tool. This screen has a set of basic colors, though you can use any
color by selecting the color box on the right, or enter values using Hue/Saturation/
Lightness or Red/Blue/Green.
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Changing a palette color (Left), selecting red on the color screen (Right)

The palette color changed to red

Filling an entire palette by selecting individual colors is slow and creates blocky color
transitions. Interpolating between colors in different palette cells is easier and leads to
smoother transitions. Interpolation proceeds from upper left to lower right. To
interpolate between two specific cells, click the starting cell then hold down the CTRL
key and click the ending cell. All intermediate cells will be interpolated. In the example
below, the interpolation is from the white cell in the upper left corner to the red cell
created in the example above. Repeat the process with different cells to create a
smooth transition between several different colors.

Interpolating between colors with the CTRL key. Before (Left) and after (Right)
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For a single color colorbar, set the upper left and lower right colors to the starting and
ending colors. Next, select the “Interp..”. button to interpolate the entire palette
starting with the upper left corner and ending with the lower right corner. In the
example below, the upper left color is white, and the lower right color is pink. Using
the “Interp…” button interpolates between white and pink, as shown in the example
below.

Using the "Interp..." button. Before (Left) and after (Right)

9.2.3

Z Cross Plot Data Definition Options
This option governs a couple of additional settings for the plot, including setting the
labels for the axes and the symbol size.

The Z Data Cross Plot Data Definition X-Y Axis Tab
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Axis Labeling Mode
This dropdown determines how Petra labels the X and Y axes. The options include:
Zone Name - Data Item - Item Description
Zone Name - Data Item
Zone Name - Item Description
Item Name - Item Description
Item Name
Item Description

Symbol Size (Inches) - This option sets the size of the individual data points on the
cross plot.
Do Not Use LOG Scale to Compute Defaults - This option forces Petra to always use
linear scales when setting defaults on the X-Y Axis Tab and the Z-Axis Tab.
9.2.4

Z Cross Plot Data Definition File
The file tab saves and loads settings for the “Data Definition” window as a *.ZXS file
in the project’s PARMS directory. This only saves the settings for the axes, title, and
labeling; it does not save polygons.

9.3

Z Cross Plot Regression
Petra can also perform variety of regression operations on the cross plot data. To
add regression lines to the plot, select Options>Regression from the menu bar at the
top of the screen.
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The Cross Plot Module with a regression line

Auto Fit Line - This option adds a linear regression line to the log crossplot. The
equation for the line, correlation, and standard deviation are all shown at the bottom of
the screen.
Auto Fit Quadratic - This option adds a quadratic curve to the log crossplot. Like the
linear regression, the equation for the line, correlation, and standard deviation are all
shown at the bottom of the screen.
User Fit Line - The User Fit line creates a linear user-drawn line across the log
crossplot. Simply draw the line across the data. The equation for the line,
correlation, and standard deviation are all shown at the bottom of the screen.
Show Standard Error Bars - This option adds error bars at one standard deviation.
The better the line fits the data, the smaller these bars will be. As a reminder, these
bars will include about 68% of the data points assuming a normal distribution.

9.4

Z Cross Plot Polygons
Z Crossplot polygons outline different areas of the graph, separating wells that have
specific z data relationships. Each polygon in the Z Crossplot Module can have its
own name, color, and value. Note that polygon values don’t have any effect in the Z
Crossplot Module, but exist so that polygons can be shared with the Log Crossplot
Module. Polygons allow the user to select wells based a more nuanced criteria rather
than by simple data searches, since polygons can vary the cutoff based on the
relationship between zone data.
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The example below shows the Net to Gross crossplot with a single “OUTLIER”
polygon. This polygon covers the data points the net to gross ratio is outside a single
standard deviation. Put another way, the amount of net sand in these wells is
significantly lower than what the rest of the data would suggest. This could be due to
gamma normalization problems or petrophysical effects.

Making a Polygon
To establish a polygon, right click anywhere on the log plot and select “Add Polygon.”
Alternatively, select Polygons>Add from the menu bar at the top of the screen.
Drawing a polygon works exactly the same as drawing lines elsewhere in Petra. Pick
polygon node points with the left mouse button and select the right mouse button to
stop picking points. Petra will automatically close open polygons.
During picking, press ESC picking to cancel the current polygon or DELETE to drop
the last picked point. Selecting F1 while picking will snap the cursor to the nearest
node point on another polygon, which can be useful for generating polygons with no
empty space between them and no overlap.
Once the polygon is picked, Petra brings up the “Polygon Definition” box. Here,
simply enter the name of the polygon, pick a color, and add a polygon value. The
polygon name is a good way of distinguishing the polygons apart when exporting
wells, so spending time on descriptive names is a good idea.

Creating a new polygon
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The Cross Plot Module with a polygon

Modifying and Deleting a Polygon
To change the area of a facies polygon, right click anywhere on the log plot, select
“Select Polygon”, and then left click on the desired polygon. Make sure to click right
on the line. Alternatively, select Polygons>Select from the menu bar at the top of the
screen, and then left click on the desired polygon. This highlights the polygon and
shows its node points; select a node point and drag it to the desired position to
change the outline of the polygon. When finished, right click and select “Redraw” to
refresh the screen and show the changes.
Changing a polygon’s name, color, and value is similar. Select the polygon with the
mouse, as outlined above. Once the polygon is highlighted, right click and select
“Modify Polygon.” Alternatively, select Polygons>Modify from the menu bar at the top
of the screen with the polygon is highlighted. This opens the Polygon Definition box,
which sets name, value, and color for the polygon.
To delete a drawn polygon, select the polygon with the mouse as outlined above.
Once the polygon is highlighted, right click and select “Modify Polygon.” Alternatively,
select Polygons>Modify from the menu bar at the top of the screen with the polygon
is highlighted. This opens the Polygon Definition box. Select the “Delete Polygon”
button on the bottom of the box.
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Loading and Saving Polygons
Closing the Log Crossplot Module erases the polygons from Petra’s memory, so
make sure to save the polygons to a file if you want to use them later. Select
Polygons>Save from the menu bar at the top of the screen. Create a name and
select the save button.
On the Save Polygons to Disk box, the area outside the polygons name and value can
be modified. By default this area is named “DEFAULT” and its value is zero. This
screen also allows for a comment to better describe the polygons.

Creating a new polygon file (left) and setting the value for data not inside the polygons

On the Save Polygons to Disk box, the area outside the polygons name and value can
be modified. By default this area is named “DEFAULT” and its value is zero. This
screen also allows for a comment to better describe the polygons.

Exporting Wells inside a Polygon
To save a well list select Polygon>Export wells. Here, select the “Browse” button to
navigate to a location on the network and name a WSN list. Next, add a comment for
the WSN list if desired. Finally, select the polygon containing the wells to be included
in the WSN list. Note that the “Output Wells Outside All Polygons” only selects the
wells not inside any polygon. The example below shows how the wells inside the
“OUTLIER” polygon will be written to a WSN list called “outlier.wsn.”
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Histogram Module
The Petra histogram module displays histograms for selected log curves. "Picks" can
be digitized from the display and stored in the Zone database. Histogram picks are
typically used for log normalization.
To open the Histogram Module, select Tools>Log Histogram from the menu bar at
the top of the Main Module.
For a detailed walkthrough of the Histogram Module, see “How to Use the Histogram
Module.”

Getting Started
Selecting Wells
Selecting a Log Curve

Basic Shortcuts and Key definitions
PageUp - Display previous well
PageDn - Display next well
CrossHair Cursor
Select the "Display>CrossHair Cursor" menu to toggle the large histogram cross
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hair. The histogram crosshair follows the mouse cursor inside the histogram chart.
The cross hair value is echoed in the log curve box.

Advanced Tools
Creating "Picks"

10.1

Histogram Selecting Wells

Selecting Wells
The Histogram Module can display any subset of wells in the project. To change the
wells shown, select Wells> from the menu bar at the top of the Histogram Module
All Wells - This option selects all wells in the project.
Wells By Data Criteria - This option opens the Wells By Data Criteria tool that selects
wells by specific data criteria.
With Selected Curve - This option selects only the wells with the currently selected
curve in the Data Definition tool's Log Curve Tab.
Map Selected Wells - This option selects the wells currently selected in the Map
Module.
Main Selected Wells - This option selects the wells currently selected in the Main
Module.
Cross-Section Wells - This option selects the wells currently selected in the CrossSection Module.
To switch between wells, select either the desired well on the dropdown at the top of
the Log Crossplot Module or use the left and right arrows to scroll through the
selected wells.

Plot Single/Combine All Wells
Petra can either plot the log data points from a single well or from multiple wells in
aggregate. To switch between these two modes, select Wells>Plot Single Well and
Wells>Combine All Wells. Note that showing multiple wells will remove the curves
displayed on the right side of the screen – after all, with data points from multiple
wells, which curves would you show?
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Histogram Data Definition
The Histogram Data Definition tool sets the basics of the log histogram, including the
log curve used, the limits and shape of the histogram, and the depth interval.

Log Curve Tab
The Log Curve Tab sets the histogram title, curve, and axis.

Title - This entry sets the histogram title. This title will appear with the currently
selected well information immediately above the histogram.
Log Curve - This log dropdown sets the curve used in the histogram, as well as the
upper and lower bounds.
Log10 Scale - This option draws the histogram in a logarithmic scale instead of a
linear scale. This can be useful for representing curves with a very large variation,
such as resistivity curves.
Use Log Alises - This option uses log curve aliasing to replace missing log curves with
an equivalent log curve.
Default Scale Range - This option sets the minimum and maximum log curve scales
with the defaults set on the Main Module's Log Maintenance Tool.
Statistical Scale Range - This option attempts to read the log curve values and set an
appropriate scale.
Reverse Curve Display - By default, Petra scales logs the log curve display from the
minimum at the left to the maximum at the right. This option flips the log scaling such
that the minimum is on the right, and the maximum on the left.

Histogram Tab
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Number of Histogram Cells - This entry sets the total number of bins or "cells" used in
the histogram. The best number of bins will vary from application to application.
Maximum Samples Per Cell - This entry sets the maximum height of any one bin. The
default is 100
Compute Maximum Samples From Data - This option instructs Petra to calculate and
scale the vertical axis to the maximum number of samples in any one bin. When this
option is deselected, Petra will scale the vertical axis to the "maximum samples per
cell."
Show Mean and Std Dev on Histogram - This option calculates and displays the mean
and standard deviation for the histogram. The mean will appear as a long-dashed
vertical line on the histogram, while the standard deviation will be two short dashed
vertical lines.
Color Fill Histogram Cells - This option fills the histogram bins. Deselecting this option
will leave empty rectangles for the bins.

Histogram Type
Standard - Standard plots divide the samples into different bins that each represent a
discrete interval of values. The height of the rectangle represents the "frequency" or
count of samples inside the bin.
Cumulative - This type of plot divides the count for each bin by the total number of
samples to create a percentage. Each bin then shows the sum of the previous bins
up to 100%.
"Greater Than" Freq Plot - This type of plot divides the count for each bin by the total
number of samples to create a percentage. Each bin then shows the sum of the
previous bins subtracted from 100%.
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Standard (Left), Cumulative (Center), and "Greater Than" Freq Plot (Right)
Histograms

Discriminators Tab
This tab establishes a discriminator curve to filter the sampled log curve. At depths
where the discriminator curves are outside the minimum and maximum values, the
corresponding depth will be left out of the histogram. If this box is checked and the
log is absent, the statistics will not be calculated.

Depths Tab
By default, Petra tries to display data over the entire log curve. Especially for log
normalization, it's much better to keep the curve histogram limited only to the most
relevent section.
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Set Depths From Zones - This button sets the interval based on zone interval
definitions. Select the desired zone from the "Select Zones(s)" list below. Note that
the WELL zone by default covers -1M MD to +1M MD, so it should cover the entire
footage of all wells.
Set Depths From Range - This option sets the depth range from any two formation
tops, measured depths, or true vertical depths. This button opens the “Set Depth
Range” dialog.

To set depths by tops or by a specific depth range, select the button. Next, select
the “Set Range” button. In the Set Depth Range box, select the relevant top, MD, or
TVD button. For MD and TVD, select the relevant button and enter the adjacent
depth in the entry field. For tops, select the desired top from the “Fm Top Name”
dropdown box. Notice that an offset can also be added or subtracted to the fm top;
this offset will include data points above or below the actual fm top depth.
To set depths by a zone’s interval definition, select the desired zone on the “Set Upper
and Lower Depths From Zone” dropdown menu.

Sample Decimation - This option decimates the data to only keep every N’th sample in
the histogram. Setting this value to 2, for instance, would only display every other
sample. Setting this value to 5 would only load every 5th sample. By default, this
option is set at 1 to include every sample in the histogram.
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Tops Tab
The Tops Tab draws formation tops on the log curve on the right part of the
Histogram Module. Tops can be particularly useful for orienting yourself to the log
curve.

Display Tops on Logs - This option enables and disables formation tops on the log
curve. Deselecting this option will keep the selected formation tops.
To select the tops that appear on the log curve, add tops to the "Selected Zone
Items" list by selecting th e">" button to add a selected top, or the ">>" button to add
all tops. To drop a top from the "Selected Zone Items" list, select the desired top and
select the "<" button. To drop all tops from the "Selected Zone Items" list, select the
"<<" button.

10.3

Histogram - Select Picks
“Picks“ are database-stored curve values. Picks are most commonly used for log
curve normalization, such as scaling all gamma ray values in a project to set “sand”
and “shale” values. Commonly, picks are first created for the entire project from
statistical measurements, and the histogram module is used to visually inspect and
QC the pick relative to the actual curve.
When working with picks, it’s usually a good idea make sure the “CrossHair Cursor”
option is on. When this option is selected, (Display>CrossHair Cursor on the menu
bar at the top of the screen), Petra draws a vertical line on the correlation log that
corresponds to the cursor’s location on the histogram. This can make it significantly
easier to see the relationship between the histogram value and the log.
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Displaying Existing Picks
On the menu bar at the top of the screen, select Picks>Define Picks from the menu
bar at the top of the screen. Alternatively, select the
button from the Picks
toolbar at the top of the screen. This opens the Define Histogram Picks window.
Here, select an existing zone data item with the zone (top) and data item (bottom) in
the “Available Zone Items” box.
The example below shows two picks: “PC10GR” and “PC90GR.” Both of these
picks these are log statistics created in the Main Module (Compute> From
Logs>Statistics…), where “PC10GR” is the curve’s 10th percentile, and “PC90GR”
is the curve’s 90th percentile.

The picks for each well will then be displayed on the histogram. The examples
below show two different wells. Since wells are logged with different tools at
different times, the picks are slightly different. The well on the left has a smaller
difference between the 10th percentile sand and the 90th percentile shales than the
well on the left.

Creating New Picks
To create a new data item in the selected zone, select the

button in the
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“Define Histogram Picks” window. Select the
button to add the data item to the
“Selected Picks” list in the lower left corner of the window. Note that new zone data
items won’t have any data, so no picks will immediately appear.

Modifying Picks
To modify a displayed pick, in the main Histogram Module window select the desired
pick from the dropdown on the Picks toolbar, and select the “Start” button.

Select the new location of the pick on the histogram. As mentioned above, the
“CrossHair Cursor” draws a vertical line on the log to show the histogram’s value
relative to the curve. Left click to set the selected pick. Next, right click to open a
set of options. These options include: Next Well, Prev Well, Redraw, End Picking,
Delete Picking. Selecting “Next Well” and “Prev Well” saves the pick change and
scrolls through the wells selected in the Histogram module. “Redraw” saves the
pick change, refreshes the screen to reflect the changes, and leaves the pick tool
active. “End Picking” saves the pick change and deactivates the picking tool, but
does not refresh the screen. “Delete Pick” erases the pick value entirely, leaving a
null value in the database for that well.
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Log Correlation Module
The Log Correlation Tool is a straightforward tool for correlating formation tops,
unassigned tops/faults, and pay intervals. This tool can display both raster and digital
logs.
To open the Log Correlation Tool, select Tools>Log Correlation on the menu bar at
the top of the Main Module, or select the
button on the Main Module toolbar.
For a more comprehensive set of options, the Cross Section Module provides more
advanced options beyond top picking. As another alternative, the Slip Log Module
displays and pick tops on up to four horizontal raster logs.
For a detailed walkthrough of the Histogram Module, see “How to Use the Histogram
Module.”

The Log Correlation Module

Getting Started
Using the Guide
The guide at the top of the screen shows the suggested workflow for using the Log
Correlation Tool. You'll want to select a few wells, set the Log Types for each track,
put raster logs inside those Log Types, set the depths, and finally select and pick tops
and pay intervals. The Quick Guide on the top of the screen has a set of buttons that
link directly to these different tasks in this order.

Step 1 - Select Wells
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Step 2 - Set Tracks
Step 3 - Set Left/Center/Right Track
Step 4 - Depths
Step 5 & 6 - Picking Type: Formation Tops, Unassigned Tops, Pay
Step 7 (Formation Tops Only) - Set Pay Style
Step 8 (Formation Tops Only) Pick Tops & Step 7 (Unassigned Tops, or Pay)

Correlation Tools
Adding a Correlation Slip Box
Panning & Zooming with the Quick List MiniMap

Annotations and Data Posting
Well Symbols and Log Headers
Posting Well Data around the Well Symbols
Plotting Perfs

Basic Shortcuts and Key Definitions
Highlighting a well - single click on the well's depth track with the left mouse button
Show the data for a selected well in the main module - double-click on the well's depth
track with the left mouse button
Terminating interactive process such as screen drawing or zooming - hit ESC
During screen drawing, skip to next graphic element - Space Bar
Drop the last point picked while drawing an overlay line - Delete
Drop the last well picked while picking wells for a cross-section - Delete

11.1

Step 1 - Select Wells
There are two ways to select wells for the Log Correlation Module: with the Map
Module or directly from the Cross Section Module.

With the Map Module
The "Select Wells" button on the guide takes you directly to the Map Module.
Alternatively, click the map icon at the top of the screen: . Once in the Map
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Module, select Tools>Pick "Log Correlate" Wells… Select individual wells with the
left mouse button to add wells to the Log Correlation Tool. Right click to stop and
switch back to the Log Correlation Tool.

With the Cross Section
Select Wells>Use Cross Section Wells. This option will plot the wells currently used
in the Cross Section Module.

11.2

Step 2 - Set Tracks
The next step is to set tracks with either the "Set Tracks" button on the guide, or the
set tracks button on the toolbar:
. Tracks simply define where raster logs and the
depth track will be drawn in relation to the well symbol and data posting.

Defining the Log Type
To define a track, click the drop down box directly under "Log Type" for each
column. Under this drop down menu, notice that Petra initially creates a few default
Log Types including Density, Gamma Ray, Induction, Neutron, Resistivity, and Sonic.
In this example, the Resistivity Log Type will be drawn in the center column, and the
Density Log Type will be drawn in the right column. You can also select the "New
Log Type" button on the lower right corner of this screen to create a new Log Type.
Notice the text underneath each of the columns (highlighted in red below) initially
reads "3 wells have no logs defined." Initially, none of the Log Types have any logs
names assigned to them. In other words, Petra doesn't know what raster log names
(also known as "group names") should be drawn in either the "Resistivity" or
"Density" tracks. The next step is to assign log names to each of these Log Types.
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Changing the Depth Track Location
You can also modify the location of the depth track. The depth track plots MD or
TVD depths next to the raster logs. This option simply moves the location of the
depth track relative to the other tracks and the well symbol. In the example below,
notice that the depth track is set to "Right Center" between the center and Right
column.
Click OK to go to the Log Correlation Tool main screen. Alternatively, click the
"Change Logs" button under one of the Log Types to take you directly to the next
step at the Assign Log Type screen.

11.3

Step 3 - Logs In Tracks

Introduction to Log Names and "Log Types"
The fundamental problem with log data is the proliferation of log names created by
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different commercial data vendors and individual users. The same general type of
curve can have hundreds, if not thousands, of different names in a single project.
The Log Correlation Tool gets around this problem by using "Log Types." A Log
Type is just an alias list of equivalent logs. In the example below, the "Resistivity"
Log Type we build will contain a list of the resistivity raster logs in a project. To
display a resistivity curve on a cross-section, we simply tell Petra to draw the
"Resistivity" Log Type. Petra then goes down this list of raster logs for each well on
the cross-section and draws the first one it finds. For the interpreter, this means that
time invested in setting up Log Types will pay off with quicker, easier cross-sections
later.

Assign Log Type Window
The next step is to put raster logs inside the newly defined tracks. Practically, this
means that we need to assign raster group names to the Log Types. In the main
screen, select one of the defined tracks under Step 3. In this example, the center
track with the Resistivity Log Type is selected.
This brings up the Assign Log Type screen. This screen shows the available raster
logs and their start and stop depths for each well in the Log Correlation Tool.
Shading separates different wells. You can sort by ascending or descending order
for each column.
This screen also features a search box at the top of the screen that filters data by
WSN, UWI, well name, well label, log name, or start and stop depths. Select "Filter"
to return the data meeting the criteria. This filter can also be made sensitive to
capitalization by selecting the "Case Sensitive Filter" box. After narrowing your logs
and wells by applying one filter, you can select different criteria and select "Filter"
again to further limit the results. "Clear Filter" removes all filtering and returns all the
available raster logs for all selected wells.
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You can select raster logs for the wells either by aliasing default raster groups to a
Log Type or by individually assigning raster logs for each well. Using both
approaches together will give the best combination of speed and customization. A
good Log Type default list is a useful way of making a quick first pass at the proper
raster log for each well, while assigning individual logs can ensure that you are
displaying the best possible log.
"Default" Log Type Rasters – This method aliases different raster groups to one
Log Type. Petra then assigns a "default" raster log to the well based on this list. In
this example, different resistivity raster images will be aliased to a single default
"Resistivity" Log Type. The first step to setting up a Log Type is to select the
Default Maintenance button on the lower left side of the screen (highlighted in red).
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This brings up the Add/Edit Log Type Defaults screen. Here you can add, delete, or
modify the existing Log Types. In this example, the Resistivity type is selected in the
"Defined Log Types" box in the upper left corner. Next, select the raster names to
add to the Log Type. To add or remove raster names to the Log Type, select the
"<" or ">" buttons (highlighted in red). In the example below, the Resistivity Log
Type will bring up the log, Res, and Res1 raster logs as a default. In essence, Petra
will try to draw the first available raster log on this list for the Resistivity Log Type in
the center track. Click Save Changes and Close to exit.
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Back at the Assign Log Type screen, notice that the raster logs selected on the
default Log Type list now show checks in the boxes underneath the "Default" column.
In addition to showing which logs are selected, these check boxes can also be used
to quickly add and drop logs from the selected Log Type. For example, clicking the
"Default" check box next to the "ELOG" raster log will drop it off the "Resistivity" Log
Type for all wells. Clicking the same "Default" check box again restores it to the list.
The Log Type Defaults list (highlighted in red below) shows the order of the default
logs for the selected wells. Again, log names higher on the list will be drawn before
log names lower on the list. To change the priority of the alias list, select a log name
and use the
and
buttons.

© 2014

Log Correlation Module

1257

"Assigned" Individual Raster Logs - The other way of selecting raster log names to
display is to individually assign raster logs for each well. Though this process takes
more time, assigning individual logs allows you to select the best raster log for each
well. Petra stores this information for the next time you bring the well into the Log
Correlation tool.
The easiest way to assign a specific raster log to a well is to use the Assign Log
Type screen. To select a specific raster log, select that raster log's check box in the
"Assigned" column.
Additionally, you can also open the well-specific "Log Type Assignments" box by
double-clicking an individual well. To assign a raster log to the selected well, select
the specific raster log from the "Available Raster Logs" list on the right side of the
screen and click the "<" button. In the example below, the "ELOG" raster has been
assigned to the selected well. Select OK to save the changes and return to the main
"Assign Log Type" screen.
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In the example below, notice that the two different wells have "assigned" logs. In
one case (highlighted in blue), the log RES_TYPE will be plotted instead of the two
default logs, RES and ELOG. In the other case (highlighted in red), ELOG is both a
default log and an assigned log. This just means that it will be displayed regardless
of its order in the default Type Log list.
The Assigned logs box (highlighted in green below) shows the assigned logs for the
selected well. If a well has multiple assigned logs, you can prioritize them with the
and
buttons. Log names at the top of the assigned logs list will be shown
before log names at the bottom of the list.
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After setting up one Log Type, this is a good place to go back and repeat the same
Step 3 in order to fill the log types established for the columns in step 2. Carrying on
with the example, the screenshot shows the results of setting up log types for
resistivity and density logs. Notice that the far left well does not have a log. This is
because the depth scale is still from 1000-2000' MD, which is above the start of that
well's raster logs. After setting up log types, the next step is to move our focus
down to the interval of interest, the 2nd Wall Creek formation.
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Step 4 - Depths
The next step is to set the depths for the correlation tool. In the main screen, click
the "Depths" button on the guide, or click the depths button on the top toolbar: .

General Tab
The General Tab sets the type of cross section, as well as the specifics of the depth
track.
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Depth Type
The depth type can be either "Structure" or "Stratigraphic". A structural cross-section
has a depth interval defined by measured or SubSea depths. A stratigraphic section
instead has depths defined with formation tops, where the raster logs are hung on
the upper fm top. Stratigraphic cross-sections are useful for showing variation in
stratigraphy independent of structural change.

Depth Axis Options
Show Depth Track – This option toggles the display of the small track that shows
MD, TVD, or SS depths. To hide it, deselect the "Show Depth Track" option. Hiding
the depth track will also hide any perf and test information.
Limit Depths By TD – This option limits the drawn raster logs and the depth track
down to a well's TD (as stored in Petra's database) rather than to full extents of the
bottom set with the Structure or Stratigraphic Depths Tabs.
Track Width - This governs the width of the depth track. Text inside the depth track
is automatically scaled. Expanding the track width of the Depth Track can make the
measured depth numbers easier to read.

Structure Depths
This tab to sets depths for structural plots.
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Upper Depth/Lower Depth - These entry boxes set the boundaries for the cross
section. Depth values can be entered as either measured or subsea depths.
Remember that subsea values below sea level (like those on wells drilled on the Gulf
Coast) are are negative from 0.
Compute Using Tops – Petra can automatically compute a valid structure depth
range from the tops selected for the cross-section. If no tops are picked for the
selected wells, Petra won't be able to calculate a depth range.
Compute Using Logs - Petra can automatically compute a valid structure depth range
from the logs selected for display. Here, Petra will calculate depths that will cover
the top of the shallowest and bottom of the deepest logs.

Stratigraphic Depths
This tab sets the depths for stratigraphic plots.
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Upper/Lower Depth Limit Defined by (DATUM) - These dropdowns select the
formation tops that define the upper and lower boundaries of the stratigraphic plot.
Note that Petra will flatten the wells along the upper formation. You can also add an
"offset" number, which allow stratigraphic depths to include data a set number of feet
or meters above and below the selected tops. It's also acceptable to use the same
formation top for both the upper and lower depth limits with a sufficient offset above
and below, as in the example below. Notice that the upper and lower depth limits
are set by the same top with offsets 50' above and 200' below.
It's worth noting that if either of these formation tops are null for a well, Petra doesn't
have anything to flatten on and the well will be blank. For initial correlation work, it is
generally best to pick a consistent, widely correlated top to flatten on.

11.5

Step 5 & 6 - Select Type and Display
The next step is to select the pick type. These three buttons on the quick list are an
easy way to switch between picking tops, unassigned tops ("U/A Tops"), or pay
intervals. Each button under Step 5 changes Steps 6 and 7 to reflect the particular
pick type. In all cases step 6 links to that pick type's display options:
Formation Tops
Unassigned Tops
Pay
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11.5.1 Formation Tops

To switch to picking fm tops, first select the "Tops" option on the Picking Type box
on the Guide at the top of the screen.

This changes the Quick List to Pick Tops mode.

To start picking tops, first select the desired fm top on either the Displayed Tops list
at the top or the Pick Tops list at the bottom. Next, select the "Pick Tops" button on
the guide:

or the green button on the Pick Tops Quick List:

.

Remember that the two pick modes work differently. "Pick Across" creates a single
top across all wells, while "Pick Down" cycles through the Pick Tops list. To create
fm tops, just click the depths on the raster logs where your tops are located. To
stop picking, right click the mouse or click the stop button on the Pick Tops Quick
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List: . The example below shows formation tops for the top and base of the 2nd
Wall Creek in red. Notice that the currently active fm top, 2nd Wall Creek, is shaded
to black.

If working on fm tops, the next step is to select the tops you want to display and
pick. First, select the "Tops" option under the Step 5, and then click the "Select
Tops" button under Step 6 on the guide (highlighted in red).

This brings up the Formation Tops Display Options window. To display a formation
top in the Log Correlation Tool, first select it on the "Available Tops" list and click the
"<" button to bring it over into the "Displayed Tops" list. The tops listed in the
Available Tops list can be filtered to show only the tops with values for the wells in
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the Log Correlation tool or by source.

Once on the Displayed Tops list, you can change the color of the top as it shows up
on the plot. The small check box next to the name on the Displayed Tops list toggles
whether the picks are for display only or can be modified. Tops with a green check
can be picked and shown up on the Pick Tops list, while those without a green check
are display only.

After the tops are selected, the next step is to pick the style of the displayed tops.
Under the Style Tab, you can change how the line between tops is drawn. Line
width makes the lines between tops thicker and thinner, while the line type
determines whether the line is dashed or solid. The "Apply Line Width and Line
Type" button will change the width and type for every other displayed top, but will
retain each line's color. In the example below, the "2nd Wall Creek" top is selected.
The style tab shows that this top is red, solid, and of normal width.
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If your project has Top Aliases set up in the Main Module, click the "Allow Top
Aliases" to use them.

"Disable Top" temporarily hides the specific formation top on the cross-section while
retaining its display settings. Disabled tops will have a symbol next to their name.

11.5.2 Unassigned Tops

The Log Correlation Tool also allows you to create and store "unassigned tops."
Unassigned tops are useful for correlating things outside the traditional definition of a
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formation top – i.e. distinct, mapable lithostratigraphic units. This can include faults
or other marker "picks" that are considered by the interpreter to be unknown,
uncorrelated or otherwise "unassigned". Unassigned tops can be easily correlated
and converted into formal formation tops.
Just like regular formation tops, you also need to turn on the display of unassigned
tops. First, select the "U/A Tops" option under the Step 5, and then click the "Select
Tops" button on the guide (highlighted in red).

This brings up the Unassigned Tops Display Options Screen. This screen shows all
the pre-existing unassigned top names in the project. In the example below, there is
only the "default" unassigned tops name. Since this will be shared throughout the
whole project, it's a good idea to make a new, named set of unassigned tops. To
create a new set of unassigned tops, select the

button.

On the Unassigned Tops "Pick" Properties box, enter a name under "Pick Name" that
reflects the purpose of your unassigned tops. This can be as generic or as specific
as you like. In the example below, the picks are all going to be on 2nd Wall Creek
resistivity features, so the pick name is "2nd Wl Crk Res." Next, select or enter an
interpreter name. It's a good idea for every interpreter to have their own in order to
prevent one user from overwriting another user's work. In the example below, the
source name is "CTM." Next, select the line style, width and color for the
unassigned tops. Select OK to create the correlation and return to the display
options screen.
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Notice that the unassigned tops name now appears in the Available Unassigned
Tops list on the right of the screen. To display a formation top in the Log Correlation
Tool, first select it on the Available Tops list and select the "<" button to bring it over
into the "Unassigned Tops To Display" list.
Once on this list, you can still change the color of the unassigned tops. Selecting the
small check box next to the name on the Unassigned Tops To Display list toggles
whether the picks are display only or can be modified. Tops with a green check can
be picked and modified in the correlation tool, while those without a green check are
display only.

Unassigned Top Correlations Display Options
Unassigned tops by themselves have no relationship to each other. Correlating
unassigned tops links them together into a single named unit. These correlations can
be flattened to show stratigraphic variation or converted into regular formation tops.
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One of the best uses for correlation is to flatten the cross section on localized
distinctive log features with no formal name.
Just like regular formation tops an unassigned tops, you also need to turn on the
display of unassigned top correlations. First, select the "U/A Tops" option under the
Step 5, and then click the "Select Tops" button on the guide (highlighted in red).

This brings up the Unassigned Tops Display Options Screen. To look at
correlations, click on the "Unassigned Top Correlations" Tab on the top of the
screen. This screen shows all the pre-existing unassigned top and unassigned top
correlations in the project. In the example below, there are no available correlations.
To create a new set of unassigned tops, select the

button.

On the Unassigned Tops "Correlations" Properties box, enter a name under
"Correlation Name" that reflects the purpose of your unassigned picks. This can be
generic or specific as you like – in the example below, the correlation is on a single
resistivity bump above the 2nd Wall Creek, so the correlation's name is "Resistivity
Bump." Next, select or enter an interpreter name. It's a good idea for every
interpreter to have their own to prevent one user from overwriting another user's
correlations. In the example below, the source name is "CTM." Next, select the
line style, width and color for the unassigned top correlation. Select OK to create
the correlation and return to the display options screen.
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Notice that the correlation now appears in the Available Correlations list on the right
side of the screen. To display a correlation in the Log Correlation Tool, first select it
on the Available Tops list and click the "<" button to bring it over into the "Unassigned
Tops To Display" list.
Clicking the small check box next to the name on the Correlations To Display list
toggles whether the correlations are display only or can be modified. Tops with a
green check can be picked and modified in the correlation tool, while those without a
green check are display only.

Picking Unassigned Picks
To switch to picking unassigned tops, first select the "U/A Tops" option on the
Picking type box on the Guide.
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This changes the Quick List to show the Unassigned Picks toolbar.

Unassigned Picks

Making Unassigned Tops:
This creates new unassigned tops under the picks
name shown in the dropdown menu. Different pick names can be used to keeps
groups of unassigned picks separate by both purpose and interpreter. In the
example above, new unassigned tops will be part of the "2nd WL CRK RES" name
created earlier. To pick tops, click on the logs on the main screen. Multiple
unassigned tops with the same picks name can be added to the same wellbore.
Right click to finish picking tops.

This brings up the option of saving the new pay intervals to Petra's database.
Selecting "No" will erase all new, unsaved unassigned picks. In the example below,
notice the red lines signifying the resistivity anomaly picked as a unassigned top.
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Moving Unassigned Tops:
To move unassigned tops, select this button. Left
click the unassigned top to move and drag it to the new location. When finished,
right click the mouse button. This brings up the option of saving the new pay
intervals to Petra's database. Selecting "No" will leave all unsaved pay picks
unchanged.
To delete unassigned tops, select this button. Left click
Delete Selected Tops:
the unassigned top to delete it. The unassigned top interval will be hatched with red
to show that the changes haven't been saved to the database. When finished, right
click the mouse button. This brings up the option of deleting the unassigned top from
Petra's database. Selecting "No" will leave all unsaved pay picks unchanged.
Delete Tops by Name:
This button deletes all the unassigned tops with the
currently selected unassigned tops name. In this example, the "2nd Wl Crk Res"
unassigned tops group is selected, so selecting this option will delete all the "2nd Wl
Crk Res" unassigned tops on the currently selected wells.
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Create New Unassigned Tops Name:
This button provides another quick way to
create new unassigned group names. This brings up the New Pay Interval Definition
screen. Enter the name, source, description, and color of your pay zone.
Unassigned top names created here will automatically show up in the Unassigned
Picks dropdown menu on the Quick List.

Unassigned Correlations

Connect Unassigned Tops:
This button designates selected unassigned tops to a
specific correlation. First, select the correct correlation name on the lower
dropdown menu (in the example above, the correlation is called "Resistivity Bump").
Next, select the "Connect Unassigned Tops" button and click on unassigned tops on
the wells to add them to the correlation. Right click when done. The unassigned
tops will now be connected by a line to signify that they are part of a correlation. In
the example below, the blue correlation line connects the unassigned tops.
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Convert Correlation to Fm Top:
This button converts a correlation into a fm top.
As a formal fm top, the surface can be gridded or used in calculations. First select
the appropriate correlation from the correlation dropdown menu. Next, select the
"Convert correlation to Fm Top" button to bring up the "Convert Correlation To Top"
window.

This brings up the Convert Correlation To Top window. Here, select an existing fm
top or create a new top for the correlation. In this example, the "Resistivity Bump"
correlation will be converted to the "Resistivity Bump Top" Fm top. This newly
created fm top will be stored into Petra's database.

This screen also gives you the option to convert the correlation for all wells in the
database, only the currently selected wells in the Log Correlation Tool, or only the
wells selected in the Main Module.
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Flatten on Correlation:
This option flattens all wells onto the correlation selected
on the correlations dropdown menu. This is useful for quickly seeing changes in
stratigraphy or for testing correlations without the formality of a true fm top.

Delete Correlation:
dropdown menu.

This option deletes the correlation selected in the correlation

Create new unassigned top name:
This option is another way to quickly create a
new correlation. Select this button, and enter the name, interpreter, color, and line
width and style of the correlation line. Correlations created here will automatically be
displayed.

Making another Cross-Section.
After you pick your first set of tops and pay, it's not necessary to go through the
entire process again for a new cross-section. Petra saves track settings, default
logs, depths, and top information to apply to your next set of wells. To make a new
cross section, all you'll have to do is select the new set of wells (Step 1) and make
adjustments in the default and/or assigned raster logs (Step 3). Continually making
small improvements to your default Log Type list as you make new cross sections is
a good use of your time – the better and more comprehensive your default Log Type
list, the less time you have to spend individually assigning raster logs to wells.
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Other Display Options
Plotting Well Data around Well Symbol – To plot well data around the well symbol
at the top of the screen, select Wells>Plot Data around Well Symbol. This brings up
the Post Data By Well Symbol screen. Here you can select which well identification
data will be plotted around the well symbol. In the example below, the wells' label is
plotted above the well symbol.

Well Symbols - While in the Correlation Tool's main screen, dragging the lower line
of the frame containing the well symbols increases and decreases this space. The
and
buttons on the toolbar at the top of the screen toggle the well symbol and
well data on and off, respectively.

The example below shows well labels displayed over each well symbol.
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Plotting Log Scale Information – The tops of raster images usually have scale
information for each track. If this scale information is calibrated, it can be shown on
the Log Correlation Tool's main screen. To show and hide this raster scale
information, click the
and
buttons on the toolbar at the top of the screen. The
next step is to tell Petra how the scale information is stored in the raster calibration.
Under Logs/Images>Log Header Display on the menu bar at the top of the screen,
select "Header", "Lower Scale", or "Upper Scale." Many older Petra projects store
scale information as the "header." Once this data is displayed, dragging the lower
line of the frame containing the scales stretches and squeezes the image scales for
readability.

Test Indicators - Select Wells>Plot Test Indicators to bring up the Test Indicators
screen. Select the display color for perfs, and click "Enable Perfs Display." The Log
Correlation Tool will display perfs as a colored box on the depth track. The example
below shows perf indicators as a red rectangle on the depth track (highlighted in
green).
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Zoom and Scroll
For detail work, it's probably advantageous to zoom and scroll on the cross section.
There are two ways to zoom in and out on the Log Correlation cross section.

Toolbar Zoom – The toolbar has a set of zooming tools:
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"+" and "-" zoom in and out by 1/2 onto the center of the screen. The
button
allows you draw an area to zoom. The
button returns to the last zoom setting,
magnifying glass removes all zoom to return you to the default scaling.
while the

The Pan and Scroll Window - This window on the Quick List log correlation window
pans and scrolls around a zoomed cross-section. The "enlarge button" creates an
additional window, which is useful for double monitor setups.

Like the toolbar zoom, the "+" and "-" zoom in and out of the center of the screen,
while the "X" removes all zoom. The extents of the log correlation main window are
shown in red on this window. Dragging this red outline scrolls the extents of the main
correlation window at the current zoom level.

Scrolling with the Arrow Keys Window – When zoomed in on a section, you can also
quickly pan across the section using the arrow keys. By default, the screen will pan
by 50% with every key press. To change this number, go to Display>Arrow Keys.

The Right Mouse Button
Many common commands and some context-specific commands are available by
clicking the right mouse button on the cross section. A familiarity with these
commands can ultimately add up to huge savings in time and effort.

The right mouse button accesses several common commands related to tops. Place
your mouse over the top right click the mouse flatten on, hide, or null the closest
picked fm top. To start picking the selected top under the Pick Tops Quick List, right
click and select "Start Picking Top(s)."
.
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Slip Box
The slip box takes a screenshot of a part of the cross-section and places it into a
separate window inside the cross-section. This section of the log can be a great
help to correlation between one log and another. The slip box window can be moved
around the screen, as well as stretched and squeezed. The slider box on the top of
the window changes the box's opacity to make it easier to overlay on top of other
logs.
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11.5.3 Pay Picking and Display Options

The Log Correlation Tool can show one or more color-filled intervals representing
"pay" zones. Though most often used for illustrating zones of productive reservoir,
you can use pay zones to show anything that has a top and base. Pay zone intervals
and thicknesses can also be stored to a data item in the Zone database. Once
stored as a data item, these thicknesses are available for posting or contouring.
To display pay intervals, select the "Pay" option under the Picking Type Option then
click the "Select Pay" button on the guide (highlighted in red). This opens the Pay
Data Display Options screen.

This screen shows pay zones already in the project, and can be filtered to show
either pay intervals for the selected wells in the Log correlation Tool or to show the
pay intervals for all wells in the project. These pay intervals can also be filtered by
the source.
In the example below, notice that the option for showing pay "For Selected Wells
Only" (highlighted in red) is turned on. Since none of the selected wells have any pay
selected, nothing appears in the "Available Pay" window.

In this example, a 2nd Wall Creek pay interval already exists in the database.
Changing "For Selected Wells Only" to "For All Wells" displays all the pay zones in
the project. Notice in the example below that there are pay intervals both for
lithology ("LS" and "Sand") as well as for actual reservoir pay ("2WC"). To display a
pay interval, select it on the Available Pay list and click the "<" button to bring it over
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to the Selected Pay list on the right. To enable editing on the pay zone, make sure to
select the small checkbox to the left of the pay zone's name. A green check, like
that shown in the example below, signifies that the pay interval can be edited.

To create a new pay interval, select the
button on the Pay Data Display Options
window. This brings up the New Pay Interval Definition box. Enter the name,
source, description, and color of your pay zone. Select "Add" to add the pay interval
to Petra's database.

Pay Picking Mode
To switch to picking pay intervals, select the "Pay" option under Step 5 on the Guide.
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This changes the Quick List to show the Pay Intervals toolbar.

Begin Picking:
After selecting the appropriate pay interval, left click once in the
appropriate location on the wellbore to create the top of the pay interval, and again
to create the bottom. To continue picking wells across your cross-section, simply
click on the appropriate depth on other wells. Petra will draw a hatched box
covering the interval, as shown in the example below. This hatching indicates that
the pay intervals are not saved to the database. When finished, right click the
mouse button.

This brings up the option of saving the new pay intervals to Petra's database.
Selecting "No" will erase all unsaved pay picks. In other words, if you make 25
correct pay picks in a row followed by a single bad one, make sure to select "Yes"
and go back to fix the bad pick. Selecting "No" will erase all the unsaved good picks
as well as the single unsaved bad one.
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Once saved, the hatched lines on the pay intervals disappear to signify that the pay
intervals are stored to Petra's database, as shown in the example below.

Move Picks:
To move pay picks, select this button. Left click the top or bottom of
a pay interval and drag it to the new location. The pay interval will be hatched to
show that the changes haven't been saved to the database. When finished, right
click the mouse button. This brings up the option of saving the new pay intervals to
Petra's database. Selecting "No" will leave all unsaved pay picks unchanged.
Delete Picks:
To delete picks, select this button and left click inside the pay
interval. When finished, right click the mouse button. This brings up the option of
saving the new pay intervals to Petra's database. Selecting "No" will cancel all
unsaved pay deletions, leaving the pay picks unchanged.
Create New Interval Name:
This brings up the New Pay Interval Definition
screen. Enter the name, source, description, and color of your pay zone.
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Step 7 (Fm Tops Pick Style)
When the "Tops" picking type is selected, Step 7 shows the two options for picking
formation tops: across and down. You can change the pick style with the buttons on
the Guide, or by using the
and
buttons on the Pick Tops part of the Quick List.
Pick Across – This is the standard pick mode in the Cross Section module. In this
mode, a single formation top is picked across all wells shown.
Pick Down - In this mode, tops are picked in the order they're shown on the Pick
Tops list. Practically, this means that tops can be picked successively down the
same wellbore before moving to the next wellbore. It helps to have the tops in a
stratigraphically successive order going down the wellbore. Use the
buttons to
move a selected top up or down in the Pick Tops list.

11.7

Step 8-(Pick Tops) & Step 7(U/A Tops or Pay)
The last step is to actually pick your fm tops, unassigned tops, and pay intervals.
The most convenient way to pick all three is to use the Quick List on the right of the
button in the upper left
screen. To toggle the Quick List on and off, click the
corner of the screen, or select View>Quick List on the menu bar at the top of the
screen.
The quick list has three settings: Pick Tops, Unassigned Tops, and Pay Intervals.
The easiest way to select between the three modes is to use the "Picking Type" box
on the Guide.

11.8

Well Symbols and Log Header
While in the Correlation Tool's main screen, dragging the lower line of the frame
containing the well symbols increases and decreases this space. The
and
buttons on the toolbar at the top of the screen toggle the well symbol and well data
on and off, respectively.
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Plotting Log Scale Information
The tops of raster images usually have scale information for each track. If this scale
information is calibrated, it can be shown on the Log Correlation Tool's main screen.
To show and hide this raster scale information, click the
and
buttons on the
toolbar at the top of the screen. The next step is to tell Petra how the scale
information is stored in the raster calibration. Under Logs/Images>Log Header
Display on the menu bar at the top of the screen, select “Header”, “Lower Scale”, or
“Upper Scale.” Many older Petra projects store scale information as the “header.”
Once this data is displayed, dragging the lower line of the frame containing the
scales stretches and squeezes the image scales for readability.

11.9

Pan and Zoom
Zoom and Scroll
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For detail work, it's probably advantageous to zoom and scroll on the cross section.
There are two ways to zoom in and out on the Log Correlation cross section.
Toolbar Zoom – The toolbar has a set of zooming tools:

.

“+” and “-“ zoom in and out by 1/2 onto the center of the screen. The
button
allows you draw an area to zoom. The
button returns to the last zoom setting,
magnifying glass removes all zoom to return you to the default scaling.
while the
The Pan and Scroll Window - This window on the Quick List log correlation window
pans and scrolls around a zoomed cross-section. The “enlarge button” creates an
additional window, which is useful for double monitor setups.

Like the toolbar zoom, the “+” and “-“ zoom in and out of the center of the screen,
while the “X” removes all zoom. The extents of the log correlation main window are
shown in red on this window. Dragging this red outline scrolls the extents of the main
correlation window at the current zoom level.
Scrolling with the Arrow Keys Window – When zoomed in on a section, you can also
quickly pan across the section using the arrow keys. By default, the screen will pan
by 50% with every key press. To change this number, go to Display>Arrow Keys.

11.10 Slip Box
The slip box takes a screenshot of a part of the cross-section and places it into a
separate window inside the cross-section. This section of the log can be a great
help to correlation between one log and another. The slip box window can be moved
around the screen, as well as stretched and squeezed. The slider box on the top of
the window changes the box's opacity to make it easier to overlay on top of other
logs.
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11.11 Post Data By Well Symbol
The Log Correlation Module can display header information around each well symbol.
To plot well data around the well symbol at the top of the screen, select Wells>Plot
Data around Well Symbol.

Top/Bottom/Left/Right - These dropdowns select the desired header information that
will be displayed around the well symbol. The "Top" dropdown, for example, sets the
information that will be displayed above the well symbol.
Font - This entry displays the font used for the header information. To select a
different font, select "Change Font."
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Size - This option sets the text size.
Color - This sets the color of the text.

11.12 Plot Test Indicators
The Log Correlation module can perfed intervals along the wellbore.
To add perfs, select Wells>Plot Test Indicators

Perfs Tab
Perf Display Color - This option sets the color for perfs on the Log Correlation
Module.
Enable Perfs Display - This option enables perfs on the log correlation module.
Deselecting this option will remove perfs from the display.

Options Tab
Show tests from recompletions which match 10 digit API - By default, Petra treats
recompletions as separate wells. This option forces the Log Correlation Module to
use all perfs from all recommpletions that match the first 10 digits of the API number.
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Production Analysis Module
The Decline Curve Analysis Module displays a well's production data and applies
decline curves to forecast a well’s ultimate production. This tool can display the
entire production history for a well or display individual production streams that
represent sequential or commingled production.
To open the Decline Curve Analysis Module, select Tools>Decline Curve Analysis
from the menu bar at the top of the Map Module.

Sequential and Comingled Production
"Sequential" production refers to wells perforated in the lowest productive reservoir
and then produced to depletion and plugged. The next deepest reservoir was
perforated and so forth. Each reservoir is sequentially produced until all reservoirs
are depleted. "Comingled" production refers to wells with simultaneous production
from multiple reservoirs, all produced to depletion. This method makes it difficult to
calculate the individual contribution of oil, gas, water and/or condensate from any
individual reservoir unless production logging methods are used.

Getting Started
Selecting Wells
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Setting the Current and Available Production Streams
Changing the X & Y Axes
Fitting a Curve
Decline Curve Forecasting

Production Analysis Toolbar

- This button prints a hard copy.
- This button zooms in on the plot. Simply draw a rectangle around the desired
region on the plot.
- This button restores the plot to the default X and Y axis.
- This button fits the available production to the screen.
- These buttons set the decline curve forecast.
- This option adds a plot of the perfs along the horizontal axis. This can be useful
for analyzing the effect of perfs on production.

12.1

Selecting Decline Curve Wells
By default, The Decline Curve Analysis Module simply uses the wells selected in the
Main Module.
To change the wells selected on the Decline Curve Analysis Module, select the Wells>
option on the menu bar at the top of the screen.
Select All Wells - This option selects all wells in the project.
Select Wells by Data - This option opens the “Select Wells By Data” option. This tool
can refine the wells used in the cross plot based on several different criteria.
Additionally, multiple nested searches can combine to make for more precise well
lists.
Wells from Main - These options select the wells currently active in the Main Module.
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List of WSN, UWI and Well Labels
WSN, UWI and user-created Well Labels can be sorted in Ascending or Descending
order using the left mouse button (LMB) and clicking the column title box. Using the
LMB, you can select the well of interest by clicking on the particular row.

12.2

Current and Additional Production Streams
The C
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Current Production Stream
This dropdown sets the stream that will be forecasted using the forecasting methods.
Individual stream forecasting requires the user to select the stream here.

Display Additional Streams
The Additional Streams list represents all production streams in the Petra Project
database. Not all streams will be available for all wells. Note that the the color boxes
to the right of each each stream may be changed.
Multiple streams in the DCA module are displayed by clicking the streams you want
displayed under Additional Streams.

12.3

X & Y Axis
The Y (Production Rate) and X (Time in Years) axes can be adjusted graphically by
holding down the LMB and “dragging” in the clear area next to the axis of interest.
Note the dotted lines which denote the axis halfway marks on each axis. Holding
down the LMB and dragging in the appropriate area will modify either the minimum or
maximum value.
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Fit Chart to Data Extents
The Fit Chart to Data Extents expands the production history to full graph extents.

12.4

Fitting a Decline Curve
The DCA module provides the user with a set of graphical tools to fit an exponential or
hyperbolic curve to the production data. Manual and automatic curve fits are provided
via the buttons below.

Manual Exponential method
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For a Manual Exponential Method, click the LMB on the location of the initial decline
(Qi) and terminal decline points (Qt). The exponential line is fit and model decline
parameters as well as TA, REM and EUR are calculated and displayed on the graph
and in the forecast box.

Manual Hyperbolic method
After clicking the LMB on the location of the initial decline (Qi) and terminal decline
points (Qt), the mouse will be centered on the line at which point you can “bend” the
line to match the production decline curve. Once you have a match, click the LMB one
more time and the hyperbolic line is displayed with model decline parameters as well
as TA, REM and EUR calculated and displayed on the graph and in the forecast box.

Autofit Exponential and Hyperbolic methods
After clicking the selection box, move the mouse to the graph and draw a box around
the area of the decline curve you want to curve fit. Click the LMB again and the
exponential or hyperbolic line is fit and model decline parameters as well as TA, REM
and EUR are calculated and displayed on the graph and in the forecast box.

12.5

Decline Curve Forecasting
The Forecast Parameters and Results box provides model parameters and forecast
results. The Up and Down arrows on the right of each entry modify the input
parameters by an incremental amount. Note that the plot is updated in real-time.
Clicking LMB on the Up arrow increases the value and clicking the Down arrow
decreases the value.
Values can be entered by holding the LMB down and highlighting“swiping” the field. A
new value can be entered and the forecast model adjusted accordingly.
The Forecast Parameters and Results box may be moved to the graph area by going
to the top of the box. Hold down the LMB when the crosshairs are displayed and
drag to the graph area.
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Qi

Initial Production Rate

(graphically positioned or entered value in
Petra database)

Qt

Production rate at Time t

(graphically positioned or entered value in
Petra database)

Qf

Economic Limit Rate

(user entered specified)

Di

Initial Decline rate, %/yr

(calculated after Manual or AutoFit)

b

Hyperbolic exponent

(calculated after Manual or AutoFit)

TA

Time to Abandonment, yrs.

(calculated after Manual or AutoFit)

CUM Cumulative Production

(value in Petra database)

REM Recoverable Reserves

(calculated after Manual or AutoFit)

EUR Estimated Ultimate Recovery

(calculated after Manual or AutoFit)

Model parameters
Qi, Qt, Qf, Di and b may be modified by either entering values or incrementally
changed by clicking the Up / Down arrows in each field.

Rotation about Qt
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Rotation of the exponential fit can be accomplished by holding the LMB down on the
box representing Qi and rotating the line. Values in the forecast box will change
accordingly.

“Parallel” move of forecast line
A “parallel” move of the forecast line (Di constant) is accomplished by holding the
LMB down on the box on the center of the forecast line. Values in the forecast box
will change accordingly.
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Saving/Loading Forecasts
Load Forecasts From Parms
Save Forecasts To Parms

12.7

(loads model parameters from PARMSDB)
(saves model parameters to PARMSDB)

Plot Options
The Plot Options tool sets a few additional options for the Production Analysis module
.
To open the Plot Options tool, select "Plot Options" at the top of the Decline Curve
Analysis menu bar.

General Tab

Plot Text Color - This option sets the text color on the Decline Curve Analysis Module.
Plot Border Color & Thickness - The left button sets the border color around the plot,
while the right button sets the line thickness
Minor Gridline Color & Thickness - The left button sets the minor gridline's color on the
plot, while the right button sets the line thickness
Major Gridline Color & Thickness - The left button sets the major gridline's color on
the plot, while the right button sets the line thickness

Rate vs Time Tab
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Plot Perfs - This option plots perfs along the bottom horizontal axis of the plot. Note
that this option is also available on the toolbar at the top of the Decline Curve Analysis
Tool.

p/z Tab

p/z Data Stream - This dropdown selects the data stream containing the p/z stream.
p/Z Economic Limit - This option sets the economic limit in psi.
Projection Line Color - This limit sets the projection line's color.

Forecast Tab

© 2014

1302

PETRA Help

Minimum Eff. Decline Rate Where Hyperbolic Goes Exponential - Over the course of a
well's life, production can switch from hyperbolic production to exponential. This option
sets the minimum effective decline rate where this production switches over.
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Production Group Normalization Module
The Production Group Normalization Tool displays and analyzes monthly production
data for a set of wells. With this tool, production data can be easily summed
together, averaged, or time-normalized back to a single starting date. This is useful
for comparing historical and average production between different populations of
wells. For example, this tool can be used to compare production differences based
on completion techniques, reservoir properties, or structural setting.
It's important to remember that this tool only works with wells that have monthly
production data. Wells missing monthly production data will not contribute to
cumulative or average plots. Production streams where each well in a lease contains
a fractional percentage of the total lease production can also generate spurious
results.
To open the Production Group Normalization Tool, select Tools>Production Group
Plot on the Main Module's menu bar. (Note - the first time it opens, you will see
defaults of oil, gas and wtr for the first 100 wells from your main well list).
To load or save an existing Production Group Plot, select File>Load… or
File>Save…. on the menu bar at the top of the screen. This “PGP” file stores the list
of wells and all display settings. Remember that the Production Group Normalization
Tool still reads and recalculates from Petra's database, so the data shown on the
screen after loading a plot will reflect the most current production stream information
in the database.

Getting Started
Selecting Wells

Options Tab
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The Options Tab establishes which averaging and time-normalization, if any, will be
applied to the data.

Well Grouping Method
Group Plot (Sum Wells) – This sums the selected wells' production streams
together. This data can either be shown as a cumulative or an average plot.
Individual Well Plot – This plots the individual production streams for each selected
well.

Time Normalization Method
Production streams record production for a well each calendar month. Timenormalizing this data adjusts all the production streams back to a single starting
point. When production is time-normalized and averaged, the plot illustrates
“average well” or “type curve” production for the selected wells.
Raw Data – This option shows the production data through time without adjusting to
a single starting time. Production is plotted on the Y axis against calendar year
along the X axis. Raw data plotted against cumulative values shows historical
production for the selected wells.
Normalized to Start Time – This option adjusts each well's production to a single
starting point a set number of months and years after the beginning of production.
This helps to eliminate partial month production or spurious data at the beginning of a
well's production stream. For example, setting this option to 2 months will set the
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start time for every well (0 on the X axis) after the first two months of production. A
time-normalized plot shows production on the Y axis against the elapsed time along
the X axis. Average production plotted against elapsed time after a single starting
point gives an “average well” or “type curve” production. The cumulative values on
the bottom of the production plot do not include the data truncated by time
normalization, and reflect only the sum of the data after the normalized start time.
Normalize to Max Data Value Within 1st – This option adjusts all production to a
starting time at the maximum value of a selected production stream within a time
frame. This is useful to time-normalize wells that take a variable amount of time to
reach full production. As an example, if this option is selected with maximum OIL
production in one year, Petra will find the month with maximum oil production within
the first year and set that as the start time (0 on the X axis). Average production
plotted against elapsed time after a single starting point gives an “average well” or
“type curve” production. The cumulative production values at the bottom of the
screen do not include the data truncated by the normalization, and reflect only the
data after the maximum value.
Auto Redraw – This option automatically redraws the plot whenever any change is
made. If this option is deselected, the manual redraw button is located on the upper
right side of the screen.

Other Plotting Options
Chart Axis Cycles – This sets the number of logarithmic orders of magnitude shown
on the plot. The default is 3.
Show Well Counts – This enables well count graphs to be plotted at the top of the
screen. This graph shows the number of wells with production data for each month.
Each production stream has its own well count, which is turned on under the “Plot
Well Counts” check box under each production stream tab. When looking at
averaged data, this plot helps to show how many wells are being used to calculate
average production at any given month. Non-producing wells (those with null values)
are not factored into averages. Well counts can also be useful to show the number
of producing wells in a field when looking at historical cumulative data.
In the example below, notice that the well count graph is on top of the regular timenormalized average production graph.
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Show Daily Rates – This converts monthly production rates into an average daily
production rate.
Show Avg Prod/Well – This option divides cumulative production based on the
number of producing (non-null) wells. In other words, if a well has a null for a month,
it is not used in calculating an average production for that month.
Draw Through Null Values – This option draws a straight line between null production
values.
Suppress Yearly Cums in Report – When creating a text file as a data report under
the REPORT TAB, Petra normally also includes cumulative values for the end of
each year. When this box is checked, the cumulative values are left off the report in
order to ease the production data's import into other applications. For more
information, see REPORT TAB.
AutoScale All – Selecting this option sets all Production to AutoScale. Using this
option retains any user-set YMax settings for each tab (see below).
BkGnd, Labels, Grid – These options set the colors for the background, X axis
labels, and logarithmic grids. By default these are white, black, and grey.

OIL, GAS, WTR, and OTHER(1-5) Tabs
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Petra can store multiple production streams for an individual well. Typically these
production streams include oil, gas, and water values along with a few reservoirspecific streams. The Production Group Normalization Tool has 8 tabs named Oil,
Gas, Wtr, and Other 1-5 for displaying separate production streams on the same
plot. Each tab sets the display options for one production stream. Despite the
naming convention, you can select any production stream and any color for each tab.
To toggle the display of these different streams on the plot, use the first 8 buttons
on the toggle bar at the top of the screen:
.
Display… - This check box toggles the display of the currently selected production
stream on and off.
The color box immediately to the left allows you to change the color of the production
plot on the screen.
Plot Well Counts – When “Show Well Counts” is enabled on the OPTIONS TAB, this
displays a graph of the well count graph for the production stream as shown in the
example. This well count graph shows the total number of wells with production
values for each month.
Hide Y Axis Labels – By default, every stream shown on the plot has its own
production scale added to the Y axis. This option hides the selected production
stream's axis labels. When multiple production streams are shown at the same
scale, it's sometimes helpful to only show one set of values.
Scale Range – By default, Petra default automatically sets the Y axis scale for
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production, shown by “Auto Scale to Data.” Selecting “Use YMax Below” allows you
to select a specific maximum value for the Y axis.

Wells Tab

The Wells Tab shows a list of the wells selected in the Group Production Plot tool.
The checked box to the left of each well signifies that the well is used in cumulative
or average data shown on the main plot. Unchecking the box temporarily removes
the well from both plots and calculations. The “Check All” and “None” buttons
respectively select and deselect all wells in the Production Group Normalization Tool.
Well Hilite Active –This shows an individual well's production stream relative to the
aggregate data. Clicking on a well name causes the individual well's production to
be shown on the main plot. The drop down menu selects the individual production
stream to display, while the color box selects the display color. In the example
above, the plot is showing the individual well's oil production stream in pink relative to
the time normalized average oil production for the field. Highlighting a well also
shows its WSN, UWI, and well Label on the top of the plot in the selected color.

Ratios Tab
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The Ratios Tab contains a series of ratios that are be automatically calculated and
plotted on the graph in addition to the production stream data. To toggle the display
of the selected ratios on the plot, use the “X/Y” button on the far right of the
buttons at the top of the screen. Available ratios include:
Wtr/Oil
Gas/Oil
Oil/Gas
Gas/(Oil + Wtr)
Wtr/(Wtr+Oil)
Oil(Wtr+Oil)
Oil/Othr4
(Oil+Wth)/Othr4
Othr5/Othr4
(Othr4 + Othr5)/Othr4
Other4/(Other 4+Othr5)

To change the color of the ratio as plotted on the chart, click the color box
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immediately to the right of the ratio's description.
Select None – This button deselects all ratios so that they are no longer plotted.
Show Names – This option replaces the Othr4 and Othr5 listed in the ratio listing with
Other4&5's selected production streams. This makes selecting the proper ration
easier.

Comment Tab

This adds annotation to the bottom left side of the plot (highlighted in red in the
example).The “Plot Comments” button toggles these annotations on and off.

Report Tab
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The Report Tab shows and exports detailed information about the monthly
production data.
The text on the tab gives a brief report for the production streams for each well.
This report gives the name of the production stream, the wsn, and years of first and
last production.

Data Report – This button generates a text file containing the data displayed on the
screen. In other words, the text file contains the same normalized and averaged
data as on the screen, as well as any calculated ratios. Normally, this report also
includes cumulative values for the end of each year. To suppress these cumulative
values, check the “Suppress Yearly Cums” box on the Options Tab (see above).
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With Yearly Cums (Left) and with Yearly Cums Suppressed (Right)

Capture Production to a Well… - This stores the displayed production and ratio data
to a well. Most often this data should be stored to a fake or “placeholder” well.
Once stored to a well, you can use the production analysis tool to fit a decline curve
or calculate the average date when an economic limit is reached. These placeholder
wells containing aggregate production data can also be re-selected inside the Group
Production tool, allowing you to compare different populations of wells to each other.

13.1

Selecting Wells
There are three ways to select wells: with an existing WSN list, by data criteria, or
with the map module.

With an existing WSN List
Select Wells>Load WSN File… on the menu bar at the top of the Production Group
Normalization screen. Navigate to and select the WSN list, and click the Open button.

By Data Criteria
Select Wells>Select Wells… on the menu bar at the top of the screen. This opens
the “Select Wells By Data” box common to other Petra Modules. For more
information on selecting wells based on data,

With the Map Module
In the Map Module, select Wells>Select Wells on the menu bar at the top of the
screen. You can select a set of geographically contiguous wells with “Inside
Rectangle”, “Inside Polygon”, or “Outside Polygon.” You can also select wells
individually with the “With Mouse” command. Click to select individual wells with the
left mouse button, and right click to stop.
After displaying the number of wells selected from the Map Module, Petra displays
the “Selected Wells Options.” Select “Use Wells In Prod Group Plot
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Module” (highlighted in red below). Click OK to select the wells and open the Group
Production Tool.

Once these wells are selected in the group production tool, it's also possible to
individually turn wells on and off by clicking on each well's check box under the
WELLS TAB. Turning a well off removes its contribution to the aggregate cumulative
or average production. For more information, see the WELLS TAB below.
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Thematic Mapping Module
The Thematic Mapping Module imports, displays, queries, and colors ESRI Shape
Files based on attribute data. This tool can send the results to a Map Module's
overlay.
To open the Thematic Mapping Module, select the
button on the toolbar at the
top of the Main Module. Alternatively, select Tools>Thematic Mapper from the menu
bar at the top of the screen.

Getting Started
Creating a Well Theme from Petra Project Data
Adding a New Theme from a Shape File
Copying Themes
Removing a Theme
Changing Theme Order
Working with Multiple Themes
Using Queries to Create Themes
Coloring Theme Properties
Clipping a Theme's Extents
Sending a theme to a Map Module Overlay Layer
Create and export a "WSN" list file from a well theme

14.1

Create Well Theme
A "well theme" is a shape file that is created and populated with well data from the
Petra project database. Like any other shape file, you can run queries on a well
themes attributes - a well theme will contain well data pulled from the Petra project.
By default, the shape file for well themes are written to the Petra project's Overlay
folder.
To add a new well theme, select Theme>Create Well Theme... from the menu bar at
the top of the Thematic Mapping Module.

Wells Tab
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Well List
The well list determines which wells are pulled from the Petra database into the well
theme
All Wells - This option pulls all wells in the project. While in prospect mode, this
option will only pull the wells from the currently selected prospect.
Wells In Main - This option pulls the currently selected wells on the Main Module.
WSN List - This option pulls the wells from a user-selected WSN list. Select the
"Browse" button to navigate to and select the pre-existing WSN list.

Well Locations
This option determines which well locations are used to display the wells on the map.
Surface Location - This option plots the well theme symbols at each well's surface
location.
Bottom Hole Location - This option plots the well theme symbols at each well's
bottomhole location.
Map Location - This option plots the well theme symbols at the location specified by
the directional survey location tool.

Columns Tab
The Columns Tab sets the specific types of data included in the well theme.
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Add - This button adds the selected well header or zone data item to the "Well
Shape File Data Columns" list. Data on this list will be included in the well shape file.
Replace - This button will replace the selected item on the "Well Shape File Data
Columns" list with the well header or zone item data. Data on this list will be included
in the well shape file.
Well Header Data - This dropdown selects the specific header info for the well
theme.
Zone Data Item - These dropdowns select zone data items for the well theme. The
upper dropdown selects the specific zone, and the middle dropdown selects the
item. When the zone data item is a formation top, bottom dropdown sets the
specific type of top - MD, SSTVD, or TVD.
Column is Quality Code Field - This option sets the selected column as a quality
code field, rather than the actual item.
Column is Remark Field - This option sets the column as a remark, rather than the
actual item.

File Tab
The "File" tab sets the output filename and reference datum of the created shape
file.
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Petra well shape filename and folder - By default, this tool creates the well shape file
in the the Petra project Overlay folder.
What Geographic Coordinate System Best Represents the Lat/Lon Coords In The
Petra Project? - This dropdown sets the reference datum of the the Petra well
locations.

Aux Files
By default, the Create Well Theme tool creates well themes for all wells. This tab
creates additional well themes based on specific well types, including straight wells,
surface locations, bottom locations, or the wellpaths of deviated wells.

Straight holes only - This tool adds an additional well theme containing only straight
holes.
Surface location only - This tool adds an additional well theme containing only the
surface locations of wells with different surface and bottom hole locations.
Bottom location only - This tool adds an additional well theme containing only the
bottom hole locations of wells with different surface and bottom hole locations.
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Deviated well path - This tool draws the well paths for wells with directional surveys.

Misc Tab

Use Aliases For Tops and Zone Items - By default, Petra will only use the actual top
and zone items set on the Columns Tab. This entry enables formation top aliases
and zone item aliases.

14.2

Adding a New Theme
This tool adds new themes from external ESRI shape files (*.SHP). The new theme
will be added to the theme list and will have the same name as the shape filename.
Select the menu option "Theme>Add Theme..."
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In the "Select ESRI Shape File" open dialog, browse to find the shape file you wish
to open and click the "Open" button.

If the shape file does not have an associated ".prj" file to define the shape file's
coordinate system, then you will be prompted to specify the appropriate lat-lon or xy
coordinate system. The default for lat-lon data is NAD 1927.
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The shape file name is added to the theme list on the left side of the screen and the
data is displayed in the map window of the Thematic Mapper. The newly added
theme becomes the "current" theme.

© 2014

Thematic Mapping Module

14.3

1323

Export WSN Well List
Any theme that contains Petra well data can be exported to a "wsn list" file, thus
allowing query results to be used in Petra functions that use wsn lists.
To export a well theme simply right click on the well theme and select the "Export
Petra WSN List..." menu as shown below:
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You can also save WSN lists from the expression, spatial and distance query
screens. This allows a query to be performed, highlight the results, save a WSN list
and cancel without actually saving a new theme.

14.4

Copying a Theme
The Copy Theme function allows the "current theme" to be copied to a new shape
file. Options are available to copy the entire theme's data or to copy just the
elements in the current zoom window. In addition, you can change the coordinate
system of the output theme to a different coordinate system from the original theme.
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The following screen shows the options to copy "oilpipe" to a new theme called
'oilpipe_1".
CLIPPING
In this example the entire theme will be copied. You can also zoom prior to copying,
and then copy only the visible (zoomed) area to the new theme.
DATUM SHIFTING
Also shown in this example is the ability to change the coordinates, in this case latlon coordinates from one datum to another. When the option is checked, there are
two additional options provided. The "Predefined Conversions" allow NAD27 and
NAD83 transforms in North America. The "Advanced" option is provided for all other
datum shifts.
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With the "Advanced" option checked, a new tab is displayed.
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The "New Coordinate System" tab provides two options. First, you specify the output
coordinate system for your new theme. Secondly, it provides the datum shift
parameters for converting from one lat-lon coordinate system to another. In this case
for datum shifting the lat-lon values of the theme from NAD27 to NAD83.
Datum shifting can be done in one or two steps, depending on the data source and
destination. If the combination of old and new datum is listed in the "First
Transformation" list, then a "Single Transformation" can be used. If not, then the old
coordinate system must be shifted using a "Double Transformation" in which the old
coordinates are shifted to an intermediate coordinate system with the "First
Transform" and then transformed to the final coordinate system with the "Second
Transform". This example illustrates a datum shift from NAD27 to NAD83 using a
double transform.
Note - Some transforms require the use of external files. For example, NADCON and
HARN transforms require additional files which Petra does not deploy. If you have
ArcView installed, you may already have the required files. Contact Petra technical
support if you require these files and do not have ArcView installed.
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Theme Selection and Activation
Current Theme Selection
The "current" theme is identified by a slightly raised outline in the theme list. The
current theme is also identified at the bottom left corner of the screen. The current
theme is the theme which is used when "theme properties" is selected.
Theme Activation
A theme is displayed or hidden depending on the "check box" next to the theme
name in the theme list.

14.6

Theme Display Order
Themes are displayed in the reverse order they are listed in the Theme List so that the first
theme listed (top of list) is plotted last, or "on top of" all other themes.

14.7

Clipping a Theme's Extents
The "Copy Theme" function can clip the output theme to contain only those elements
appearing in the current zoom window.

1. Zoom the window to the appropriate areal extent for clipping.
2. Select the "current" theme.
3. Right-click on the theme name to display the popup menu and select "copy theme"
4. Select the "Current Zoom" option under "Theme Items To Copy"

14.8

Thematic Mapping Map Projections
The Thematic Mapping Module can handle multiple shape files with different map
projections. Some shape files have a *.PRJ file that contain the shape file's map
projection information. For shape files without the PRJ file, however, you'll need to
set the file's map projection manually.
When there are two or more themes with different projections, you'll need to pick
one. PetIn addition to setting the coordinate system for each shape file or theme, it
will be necessary to set the "display coordinate system" if you have different
coordinate systems for two or more themes . You will be prompted automatically
© 2014

Thematic Mapping Module

1329

when adding a theme that differs from previously loaded themes.

Theme Coordinate System
Shape files will be in one of two ESRI coordinate systems:
"Geographical Coordinate System" - The shape file contains latitude-longitude
coordinates. Typically, we have either NAD27 or NAD83 lat-lon coordinates.
"Projected Coordinate System" - The shape file contains xy coordinates based on a
specific map projection, such as, UTM or State Plane.

Display Coordinate System
The Display Coordinate System is the lat-lon "unprojected" or xy projected
coordinate system of the displayed map. That is, you may display the map as either
unprojected latitude-longitude or as projected xy coordinates using a given map
projection. Unprojected lat-lon displays may not look correct due to lat-lon lines being
drawn as straight lines. Distance queries require a projected display for accuracy.
The Display Coordinate System can be changed anytime using the "options" menu.

14.8.1 Change A Theme's Map Projection
The "Copy Theme" function allows you to change the coordinate system of the copied theme.
For example, you might have a shape file in NAD 83 that you want to be NAD 27. The copy
function will allow you to set the coordinate system of the output theme (shape file) to be NAD
27.

14.8.2 DatumTransform Constants
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Accra_To_WGS1984

Ghana

Adindan_To_WGS1984_1

Mean for Ethiopia and Sudan

Adindan_To_WGS1984_2

Burkina Faso

Adindan_To_WGS1984_3

Cameroon

Adindan_To_WGS1984_4

Ethiopia

Adindan_To_WGS1984_5

Mali

Adindan_To_WGS1984_6

Senegal

Adindan_To_WGS1984_7

Sudan

Afgooye_To_WGS1984

Somalia

AGD1966_To_GDA1994

Australia

AGD1966_To_GDA1994_2

Australia - ACT

AGD1966_To_GDA1994_3

Australia - Tasmania

AGD1966_To_GDA1994_4

Australia - New South Wales & Victoria

AGD1966_To_GDA1994_8

Australia - Tasmania

AGD1966_To_GDA1994_9

Australia - Northern Terr

AGD1966_To_GDA1994NTv2New New South Wales & Victoria
SouthWalesAndVictoria
AGD1966_To_GDA1994NTv2Nort Northern Territory
hernTerritory
AGD1966_To_GDA1994NTv2Tas Tasmania
mania
AGD1966_To_GDA1994NTv2Victo Victoria
ria
AGD1966_To_WGS1984

Australia

AGD1984_To_GDA1994

Australia

AGD1984_To_GDA1994_2

Australia

AGD1984_To_GDA1994_3

Western Australia

AGD1984_To_GDA1994NTv2Que Queensland
ensland
AGD1984_To_GDA1994NTv2Wes Western Aus
ternAustralia
AGD1984_To_WGS1984_1

Australia
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AmericanSamoa1962_To_HARNA American Samoa 1962 to NAD 1983 HARN
mericanSamoaEast
American Samoa st
AmericanSamoa1962_To_HARNA American Samoa 1962 to NAD 1983 HARN
mericanSamoaWest
American Samoa st
AmericanSamoa1962_To_WGS19 American Samoa
84
Amersfoort_To_ETRF1989

Netherlands

Amersfoort_To_WGS1984

Netherlands

Antigua1943_To_WGS1984

Antigua

Aratu_To_WGS1984_1

Brazil - Campos

Aratu_To_WGS1984_2

Brazil - Tucano basin north

Aratu_To_WGS1984_3

Brazil - Tucano basin central

Aratu_To_WGS1984_4

Brazil - Tucano basin south

Arc1950_To_WGS1984_1

Mean for Botswana, Malawi, Swaziland, Zaire,
Zambia, and Zimbabwe

Arc1950_To_WGS1984_2

Botswana

Arc1950_To_WGS1984_3

Burundi

Arc1950_To_WGS1984_4

Lesotho

Arc1950_To_WGS1984_5

Malawi

Arc1950_To_WGS1984_6

Swaziland

Arc1950_To_WGS1984_7

Zaire

Arc1950_To_WGS1984_8

Zambia

Arc1950_To_WGS1984_9

Zimbabwe

Arc1960_To_WGS1984

Mean for Kenya and Tanzania

Arc1960_To_WGS1984_2

Kenya

Arc1960_To_WGS1984_3

Tanzania

ATS1977_To_NAD1983CSRS982 Canada - PEI
NTv2PrinceEdwardIs
ATS1977_To_NAD1983CSRS98N Maritimes
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Tv2Maritimes
ATS1977_To_NAD1983CSRS98N New Brunswick
Tv2NewBrunswick
ATS1977_To_NAD1983CSRS98N Nova Scotia
Tv2NovaScotia
BabSouth_To_NAD1983

Bablethuap Island - Republic of Palau

Batavia_To_WGS1984

Indonesia (Sumatra)

BataviaJakarta_To_Batavia

Batavia (Jakarta) to Batavia

BataviaJakarta_To_WGS1984

Batavia(Jakarta) to WGS84

Belge1950Brussels_To_Belge1950Belge 1950(Brussels) to tBelge 1950
Belge1972_To_WGS1984_1

Belgium

Belge1972_To_WGS1984_2

Belgium

Bermuda1957_To_WGS1984

Bermuda

Bern1898Bern_To_Bern1898

Bern 1898 (Bern) to Bern 1898

Bern1898Bern_To_CH1903

Bern 1898 (Bern) to CH1903 (Greenwich)

Bissau_To_WGS1984

Guinea-Bissau

Bogota_to_WGS1984

Columbia

Bogota_To_WGS1984_2

Colombia Casanare, BP Cusiana/Cupiagua field
areas

BogotaBogota_To_Bogota

Bogota (Bogota) to Bogota

BogotaBogota_To_WGS1984

Bogota(Bogota) to WGS84

BukitRimpah_To_WGS1984

Indonesia (Bangka and Belitung Islands)

Camacupa_To_WGS1972BE_1

Angola - offshore

Camacupa_To_WGS1984_1

Angola - offshore block 5

Camacupa_To_WGS1984_10

Angola - offshore block 2, 3, & 17

Camacupa_To_WGS1984_2

Angola - offshore block 2

Camacupa_To_WGS1984_3

Angola - offshore block 1 & 16

Camacupa_To_WGS1984_4

Angola - offshore block 7 & 8

Camacupa_To_WGS1984_5

Angola - offshore block 3

Camacupa_To_WGS1984_6

Angola - offshore block 7

Camacupa_To_WGS1984_7

Angola - offshore block 3, 7, 15, & 17
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Angola - offshore block 1 & 16
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CampoInchauspe_To_WGS1984 Argentina
CampoInchauspe_To_WGS1984_ Argentina - Neuquen province, Chos Malal area
2
Cape_To_Hartebeesthoek94

South Africa

Cape_To_WGS1984_1

South Africa

Cape_To_WGS1984_2

South Africa

Carthage_To_WGS1984

Tunisia

Carthage_To_WGS1984_2

Tunisia - offshore

CH1903_To_WGS1984_1

Liechtenstein, Switzerland

CH1903_To_WGS1984_2

Liechtenstein, Switzerland

CH1903Plus_To_CHTRF1995

Liechtenstein, Switzerland

ChosMalal1914_To_CampoInchau Argentina - Neuquen province, Chos Malal area
spe
ChosMalal1914_To_WGS1984

Argentina - Neuquen province, Chos Malal area

CHTRF1995_To_WGS1984

Liechtenstein, Switzerland

Chua_To_WGS1984

Paraguay

Conakry1905_To_WGS1984

Guinea

CorregoAlegre_To_WGS1984

Brazil

Dabola_To_WGS1984

Guinea

Datum73_To_WGS1984_1

Portugal

Datum73_To_WGS1984_2

Portugal

DatumLisboaBessel_To_WGS198 Portugal
4_1
DatumLisboaBessel_To_WGS198 Portugal
4_2
DatumLisboaHayford_To_WGS19 Portugal
84_1
DatumLisboaHayford_To_WGS19 Portugal
84_2
DeirezZor_To_WGS1972BE
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DeirezZor_To_WGS1984_2

Syrian Arab Republic

DeirezZor_To_WGS1984_3

Syrian Arab Republic - Al Whaleed area

DeirezZor_To_WGS1984_4

Syrian Arab Republic - Shaddadeh area (36 N, 41
E)

DHDN_To_ETRF1989

Germany - former W Germany

Dominica1945_To_WGS1984

Dominica

ED1950_To_ED1987_2

Norway (offshore north of 65 deg N)

ED1950_To_ETRF1989_1

Norway -offshore N of 65N Svalbard and Jan
Mayen Islands

ED1950_To_WGS1984_1

Mean for Austria, Belgium, Denmark, Finland,
France, Germany (West), Gibraltar, Greece, Italy,
Luxembourg, Netherlands, Norway, Spain,
Sweden, Switzerland, and Portugal

ED1950_To_WGS1984_10

Italy (Sardinia)

ED1950_To_WGS1984_11

Italy (Sicily)

ED1950_To_WGS1984_12

Malta

ED1950_To_WGS1984_13

Portugal, Spain

ED1950_To_WGS1984_14

Tunisia

ED1950_To_WGS1984_17

France

ED1950_To_WGS1984_18

UK - offshore E of 6W

ED1950_To_WGS1984_19

Greece

ED1950_To_WGS1984_2

Mean for Austria, Denmark, France, Germany
(West), Netherlands, and Switzerland

ED1950_To_WGS1984_23

Norway -offshore N of 62N Svalbard and Jan
Mayen Islands

ED1950_To_WGS1984_24

Norway -offshore S of 62N

ED1950_To_WGS1984_3

Mean for Iraq, Israel, Jordan, Kuwait, Lebanon,
Saudi Arabia, and Syria

ED1950_To_WGS1984_4

Cyprus

ED1950_To_WGS1984_5

Egypt

ED1950_To_WGS1984_6

Ireland, United Kingdom

ED1950_To_WGS1984_7

Finland, Norway

ED1950_To_WGS1984_8

Greece
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ED1950_To_WGS1984_9

Iran

ED1950_To_WGS1984PT3

Portugal

ED1950_To_WGS1984PT7

Portugal

ED1950ED77_To_WGS1984

Iran

ED1987_To_WGS1984_1

North Sea south of 62 deg N (UK, Denmark,
Germany, Norway) and Netherlands (offshore)

Egypt1907_To_WGS1972

Egypt

Egypt1907_To_WGS1984

Egypt

Egypt1907_To_WGS1984_3

Egypt - Gulf of Suez

Estonia1992_To_ETRF1989

Estonia

Estonia1992_To_WGS1984

Estonia

ETRS1989_To_WGS1984

Europe

Fahud_To_WGS1984

Oman

Fahud_To_WGS1984_2

Oman

FD1958_To_WGS1984

Iran - Kangan District

Ferro_To_MGI

MGI (Ferro) to MGI

GDA1994_To_WGS1984

Australia

GGRS1987_To_WGS1984

Greek GRS

GraciosaBaseSW1948_To_WGS1 Faial, Graciosa, Pico, Sao Jorge, & Terceira
984_1
Islands (Azores)
GraciosaBaseSW1948_To_WGS1 Faial, Graciosa, Pico, Sao Jorge, & Terceira
984_2
Islands (Azores)
GreekAthens_To_Greek

Greek(Athens) to Greek

Grenada1953_To_WGS1984

Grenada

Guam1963_To_HARNGuam

Guam 1963 to NAD 1983 HARN Guam

Guam1963_To_HARNMarianasRot Rota Island - Northern Mariana Islands
a
Guam1963_To_HARNMarianasSai Saipan Island - Northern Mariana Islands
pan
Guam1963_To_HARNMarianasTini Tinian and Aguijan Island Northern Mariana Islands
anAguijan
Hanoi1972_To_WGS1984
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Hartebeesthoek94_To_WGS1984 South Africa
HeratNorth_To_WGS1984

Afghanistan

HitoXVIII1963_To_WGS1984

Argentina - Tierra del Fuego

Hjorsey1955_To_WGS1984

Iceland

Hungarian1972_To_ETRS1989_1 Hungarian to ETRF 1989
HuTzuShan_To_WGS1984

Taiwan

Indian1954_To_WGS1984

Thailand, Vietnam

Indian1960_To_WGS1972BE

Vietnam - offshore

Indian1960_To_WGS1984_1

Vietnam - offshore

Indian1960_To_WGS1984_2

Vietnam near 16N

Indian1960_To_WGS1984_3

Vietnam - Con Son island

Indian1975_To_WGS1984

Thailand

Indian1975_To_WGS1984_2

Thailand

Indian1975_To_WGS1984_3

Thailand - Bongkot field

Indonesian1974_To_WGS1984

Indonesia

IRENET95_To_ETRF1989

Northern Ireland

Jamaica1969_To_WGS1984_1

Jamaica 1969 to WGS 1984_1

Kalianpur_To_WGS1984_1

Bangladesh

Kalianpur_To_WGS1984_2

India, Nepal

Kalianpur_To_WGS1984_3

Pakistan

Kalianpur1937_To_WGS1984_2

Myanmar - Moattama area

Kandawala_To_WGS1984

Sri Lanka

Kertau_To_WGS1984

West Malaysia, Singapore

Korean1995_To_WGS1984_1

Republic of Korea

LaCanoa_To_WGS1984

Venezuela - Delta Amacuro, Anzoategui, Bolivar,
Monagas, Sucre States

Leigon_To_WGS1984

Ghana

Liberia1964_To_WGS1984

Liberia

LisbonLisbon_To_Lisbon

Lisbon (Lisbon) to Lisbon

LKS1994_To_WGS1984

Lithuania

Locodjo1965_To_WGS1984

Cote d'Ivoire
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Luzon1911_To_WGS1984_1

Philippines (excluding Mindanao)

Luzon1911_To_WGS1984_2

Philippines (Mindanao)

Mahe1971_To_WGS1984

Mahe Island

Majuro_To_NAD1983

Majuro - Republic of Marshall Islands

MakassarJakarta_To_Makassar

Makassar (Jakarta) to Makassar

Malongo_To_Mhast_1

Angola - Cabinda offshore

Malongo1987_To_WGS1984_1

Angola - Cabinda offshore

Malongo1987_To_WGS1984_2

Angola - Cabinda offshore

Manoca_To_WGS1984_1

Cameroon

Massawa_To_WGS1984

Ethiopia (Eritrea)

Merchich_To_WGS1984

Morocco

MGI_To_WGS1984

Boznia and Herzegovina, Croatia, Serbia, Slovenia

MGI_To_WGS1984_2

Austria

MGI_To_WGS1984_3

Austria

MGIFerro_To_WGS1984

Mean for Croatia, Slovenia, Bosnia and
Herzegovina, & Serbia

Mhast_To_WGS1984_1

Angola - Cabinda offshore

Minna_To_WGS1984_1

Cameroon

Minna_To_WGS1984_2

Nigeria

Minna_To_WGS1984_3

Nigeria - south

MonteMario_To_WGS1984

Italy (Sardinia)

MonteMarioRome_To_MonteMarioMonte Mario (Rome) to Monte Mario
MonteMarioRome_To_WGS1984 Monte Mario(Rome) to WGS84
Montserrat1958_To_WGS1984

Montserrat

Moznet_To_WGS1984

Mozambique

MPoraloko_To_WGS1984

Gabon

Mporaloko_To_WGS1984_2

Gabon

NAD1927_To_NAD1983_6

Canada - Quebec

NAD1927_To_NAD1983CSRS98_ Canada - Quebec
1
NAD1927_To_NAD1983CSRS98_ Canada - Saskatchewan
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2
NAD1927_To_NAD1983NTv2Cana NAD27 to NAD83 Canada
da
NAD1927_To_WGS1984_1

Mean for Antigua, Barbados Barbuda, Caicos
Islands, Cuba, Dominican Republic, Grand
Cayman, Jamaica, and Turks Islands

NAD1927_To_WGS1984_10

Canada (Alberta, British Columbia)

NAD1927_To_WGS1984_11

Canada (Manitoba, Ontario)

NAD1927_To_WGS1984_12

Canada (New Brunswick, Newfoundland, Nova
Scotia, and Quebec)

NAD1927_To_WGS1984_13

Canada (Northwest Territories, Saskatchewan)

NAD1927_To_WGS1984_14

Canada (Yukon)

NAD1927_To_WGS1984_15

Panama (Canal Zone)

NAD1927_To_WGS1984_16

Cuba

NAD1927_To_WGS1984_17

Greenland (Hayes Peninsula)

NAD1927_To_WGS1984_18

Mexico

NAD1927_To_WGS1984_2

Mean for Belize, Costa Rica, El Salvador,
Guatemala, Honduras, and Nicaragua

NAD1927_To_WGS1984_21

United States (Alaska - Aleutians East of 180E)

NAD1927_To_WGS1984_22

United States (Alaska - Aleutians West of 180E)

NAD1927_To_WGS1984_3

Mean for Canada

NAD1927_To_WGS1984_30

Cuba

NAD1927_To_WGS1984_4

Mean for United States (CONUS)

NAD1927_To_WGS1984_5

Mean for United States (CONUS East of
Mississippi River including MN, MO, and LA)

NAD1927_To_WGS1984_6

Mean for United States (CONUS West of
Mississippi River)

NAD1927_To_WGS1984_7

United States (Alaska)

NAD1927_To_WGS1984_8

Bahamas (except San Salvador Island)

NAD1927_To_WGS1984_9

Bahamas (San Salvador Island)

NAD1927CGQ77_To_NAD1983_2 Canada - Quebec
NAD1927CGQ77_To_NAD1983CS Canada - Quebec
RS98
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NAD1927DEF1976_To_NAD1983NNAD27 Def76 to NAD83 Ontario
Tv2Ontario
NAD1983_To_HARNArkansas

Arkansas HARN

NAD1983_To_HARNHawaii

Hawaii HARN

NAD1983_To_HARNIllinois

Illinois HARN

NAD1983_To_HARNIndiana

Indiana HARN

NAD1983_To_HARNIowa

Iowa HARN

NAD1983_To_HARNMinnesota

Minnesota HARN

NAD1983_To_HARNMissouri

Missouri HARN

NAD1983_To_HARNNewJersey

New Jersey HARN

NAD1983_To_HARNNewYork

New York HARN

NAD1983_To_HARNNorthDakota North Dakota HARN
NAD1983_To_HARNSouthDakota South Dakota HARN
NAD1983_To_NAD1983CSRS98_ Canada - Quebec
1
NAD1983_To_NAD1983CSRS98_ Canada - Saskatchewan
2
NAD1983_To_NAD1983CSRS98_ Canada - Alberta
3
NAD1983_To_WGS1984_1

Canada, Central America, Mexico, and United
States (Alaska, CONUS)

NAD1983_To_WGS1984_2

United States (Alaska - Aleutians)

NAD1983_To_WGS1984_3

United States (Hawaii)

NAD1983_To_WGS1984_4

United States- CORS ITRF96

NAD1983_To_WGS1984_5

United States

NAD1983CSRS98_To_WGS1984 Canada - New Brunswick
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NAD1983HARN_To_WGS1984

United States

NAD27_To_NAD83_AK

NAD27 to NAD83 - Alaska

NAD27_To_NAD83_CONUS

NAD27 to NAD83 - CONUS

NAD27_To_NAD83_PRVI

NAD27 to NAD83 - Puerto Rico-Virgin I. Old nonNAD27 - NAD83 grid-based transformations

NAD83_To_HARN_AL

Alabama HARN
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NAD83_To_HARN_AZ

Arizona HARN

NAD83_To_HARN_CN

California North HARN -above 36N

NAD83_To_HARN_CO

Colorado HARN

NAD83_To_HARN_CS

California South HARN -below 37N

NAD83_To_HARN_EM

Montana & Idaho HARN - E of 13W

NAD83_To_HARN_ET

Texas HARN - E of 100W

NAD83_To_HARN_FL

Florida HARN

NAD83_To_HARN_GA

Georgia HARN

NAD83_To_HARN_KS

Kansas HARN

NAD83_To_HARN_KY

Kentucky HARN

NAD83_To_HARN_LA

Louisiana HARN

NAD83_To_HARN_MD

Maryland & Delaware HARN

NAD83_To_HARN_ME

Maine HARN

NAD83_To_HARN_MI

Michigan HARN

NAD83_To_HARN_MS

Mississippi HARN

NAD83_To_HARN_NB

Nebraska HARN

NAD83_To_HARN_NE

New England -CT,MA,NH,RI,VT HARN

NAD83_To_HARN_NM

New Mexico HARN

NAD83_To_HARN_NV

Nevada HARN

NAD83_To_HARN_OH

Ohio HARN

NAD83_To_HARN_OK

Oklahoma HARN

NAD83_To_HARN_PR

Puerto Rico & Virgin Islnds HARN

NAD83_To_HARN_TN

Tennessee HARN

NAD83_To_HARN_UT

Utah HARN

NAD83_To_HARN_VA

Virginia HARN

NAD83_To_HARN_WI

Wisconsin HARN

NAD83_To_HARN_WM

Montana & Idaho HARN - W of 113W

NAD83_To_HARN_WO

Washington & Oregon HARN

NAD83_To_HARN_WT

Texas HARN - W of 100W

NAD83_To_HARN_WV

West Virginia HARN
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NAD83_To_HARN_WY

Wyoming HARN

Nahrwan1967_To_WGS1984_1

Oman (Nasirah Island)

Nahrwan1967_To_WGS1984_2

Saudi Arabia

Nahrwan1967_To_WGS1984_3

United Arab Emirates

Nahrwan1967_To_WGS1984_4

UAE - Abu al Bu Koosh

Nahrwan1967_To_WGS1984_5

Qatar

Naparima1955_To_WGS1984_2

Trinidad

Naparima1955_To_WGS1984_3

Trinidad

Naparima1972_To_WGS1984

Trinidad & Tobago

Naparima1972_To_WGS1984_2

Trinidad and Tobago

Naparima1972_To_WGS1984_3

rinidad and Tobago

NewZealand1949_To_NZGD2000_ New Zealand
3PAR
NewZealand1949_To_NZGD2000_ New Zealand
7PAR
NewZealand1949_To_NZGD2000 New Zealand
NTv2
NGO1948_To_WGS1984

Norway

NGO1948Oslo_To_NGO1948

NGO 1948 (Oslo) to NGO 1948

NordSahara1959_To_WGS1972B Algeria - Hassi Messaoud area
E
NordSahara1959_To_WGS1984

Algeria

NordSahara1959_To_WGS1984_3Algeria - Hassi Messaoud
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NTF_To_ED1950

France

NTF_To_RGF1993_1

France

NTF_To_WGS1972

France

NTF_To_WGS1984

France

NTFParis_To_ED1950

NTF(Paris) to ED 1950

NTFParis_To_NTF

NTF (Paris) to NTF

NTFParis_To_RGF1993_1

France

NTFParis_To_WGS1972

NTF(Paris) to WGS 1972

NTFParis_To_WGS1984

NTF(Paris) to WGS 1984
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NZGD1949_To_WGS1984

New Zealand

NZGD1949_To_WGS1984_2

New Zealand

NZGD2000_To_WGS1984_1

New Zealand

ObservMeteorologico1939_To_W Corvo & Flores Islands (Azores)
GS1984_1
OldHawaiian_To_NAD83

Old Hawaiian to NAD83

OldHawaiian_To_WGS1984_1

Old Hawaiian to WGS 1984 (1 - OHA_M)

OldHawaiian_To_WGS1984_2

Old Hawaiian to WGS 1984 (2 - OHA_A)

OldHawaiian_To_WGS1984_3

Old Hawaiian to WGS 1984 (3 - OHA_B)

OldHawaiian_To_WGS1984_4

Old Hawaiian to WGS 1984 (4 - OHA_C)

OldHawaiian_To_WGS1984_5

Old Hawaiian to WGS 1984 (5 - OHA_D)

OSGB1936_To_ED1950UKOOA UK - England, Scotland, Wales, N Sea
OSGB1936_To_WGS1984_1

Mean for UK (England, Scotland, Wales, and Isle
of Man)

OSGB1936_To_WGS1984_2

UK (England)

OSGB1936_To_WGS1984_3

UK (England, Wales, and Isle of Man)

OSGB1936_To_WGS1984_4

UK (Scotland, including Shetland Islands)

OSGB1936_To_WGS1984_5

UK (Wales)

OSGB1936_To_WGS1984Petrole UK - England, Scotland, Wales, N Sea
um
Padang1884Jakarta_To_Padang1 Padang 1884(Jakarta) to to Padang 1884
884
PDO1993_To_WGS1972

Oman

PDO1993_To_WGS1984

Oman

PDO1993_To_WGS1984_3

Oman - Block 4

Pohnpei_To_NAD1983

Pohnpei - Fed. States of Micronesia

PointeNoire_To_WGS1984

Congo

PortoSanto1936_To_WGS1984_1 Porto Santo & Madeira Islands
PortoSanto1936_To_WGS1984_2 Porto Santo & Madeira Islands
POSGAR_To_WGS1984_1

South America

PSAD1956_To_WGS1984_1

Mean for Bolivia, Chile, Colombia, Ecuador,
Guyana, Peru, and Venezuela
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PSAD1956_To_WGS1984_10

Bolivia - Madidi

PSAD1956_To_WGS1984_11

Bolivia - Block 20

PSAD1956_To_WGS1984_2

Bolivia

PSAD1956_To_WGS1984_3

Chile (Northern, near 19 deg S

PSAD1956_To_WGS1984_4

Chile (Southern, near 43 deg S

PSAD1956_To_WGS1984_5

Colombia

PSAD1956_To_WGS1984_6

Ecuador

PSAD1956_To_WGS1984_7

Guyana

PSAD1956_To_WGS1984_8

Peru

PSAD1956_To_WGS1984_9

Venezuela

Pulkovo1942_To_Estonia1992

Estonia

Pulkovo1942_To_ETRF1989

Germany - former E Germany

Pulkovo1942_To_LKS1994

Lithuania

Pulkovo1942_To_WGS1984

Russia

Pulkovo1942_To_WGS1984_10

Kazakhstan - Caspian

Pulkovo1942_To_WGS1984_12

Estonia

Pulkovo1942_To_WGS1984_3

Hungary

Pulkovo1942_To_WGS1984_4

Poland

Pulkovo1942_To_WGS1984_5

Czech Republic

Pulkovo1942_To_WGS1984_6

Latvia

Pulkovo1942_To_WGS1984_7

Kazakhstan

Pulkovo1942_To_WGS1984_8

Albania

Pulkovo1942_To_WGS1984_9

Romania

Qatar_To_WGS1984

Qatar

Qatar1974_To_WGS1984_2

Qatar - offshore

Qatar1974_To_WGS1984_3

Qatar - onshore

QORNOQ_To_WGS1984

Greenland (South)

Rassadiran_To_WGS1984

Iran - Tehari Refinery

REGVEN_To_SIRGAS_1

Venezuela

RGF1993_To_ETRF1989_1

France
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RT38Stockholm_To_RT38

RT38 (Stockholm) to RT38

RT90_To_WGS1984

Sweden

SAD1969_To_WGS1984_1

Mean for Argentina, Bolivia, Brazil, Chile,
Colombia, Ecuador, Guyana, Paraguay, Peru,
Trinidad & Tobago, and Venezuela

SAD1969_To_WGS1984_10

Paraguay

SAD1969_To_WGS1984_11

Peru

SAD1969_To_WGS1984_12

Trinidad & Tobago

SAD1969_To_WGS1984_13

Venezuela

SAD1969_To_WGS1984_14

Brazil

SAD1969_To_WGS1984_2

Argentina

SAD1969_To_WGS1984_3

Bolivia

SAD1969_To_WGS1984_4

Brazil

SAD1969_To_WGS1984_5

Chile

SAD1969_To_WGS1984_6

Colombia

SAD1969_To_WGS1984_7

Ecuador

SAD1969_To_WGS1984_8

Ecuador (Baltra, Galapagos)

SAD1969_To_WGS1984_9

Guyana

Samboja_To_WGS1984

Indonesia - E Kalimantan Mahakam delta area

SaoBraz_To_WGS1984_1

Sao Miguel and Santa Maria Islands (Azores)

SaoBraz_To_WGS1984_2

Sao Miguel and Santa Maria Islands (Azores)

SapperHill1943_To_WGS1984

Falkland Islands (East Falkland Island)

Schwarzeck_To_WGS1984

Namibia

Schwarzeck_To_WGS1984_2

Namibia

Segora_To_WGS1984

Indonesia - Kalimantan

SierraLeone1968_To_WGS1984

Sierra Leone

SIRGAS_To_WGS1984_1

South America

SouthYemen_To_YemenNGN1996 South Yemen
StGeorge_To_NAD83

St. George I. to NAD83

StKitts1955_To_WGS1984

St. Kitts and Nevis

StLawrence_To_NAD83

St. Lawrence I. to NAD83
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StLucia1955_To_WGS1984

St. Lucia

StPaul_To_NAD83

St. Paul I. to NAD83

Tananarive1925_To_WGS1984

Madagascar
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Tananarive1925Paris_To_Tananari Tananarive 1925 (Paris) to Tananarive 1925
ve1925
Tananarive1925Paris_To_WGS19 Tananarive (Paris) to WGS84
84
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Tete_To_Moznet_1

Mozambique

Tete_To_Moznet_2

Mozambique - Maputo & S Gaza province, S of
approx. 24S

Tete_To_Moznet_3

Mozambique - Gaza, Inhambane, S Sofala and S
Manhica, betwn 20S-24S

Tete_To_Moznet_4

Mozambique - Sofala N of Beira corridor, Manhica,
Tete & Zambezia, 16S

Tete_To_Moznet_5

Mozambique - Nampula, Niassa and Cabo
Delgado, N of 16S

Timbalai1948_To_WGS1984

Brunei, Malaysia (Sabah, Sarawak)

Timbalai1948_To_WGS1984_2

Brunei Darussalam offshore

Timbalai1948_To_WGS1984_3

Brunei Darussalam onshore

TM65_To_WGS1984

Ireland

Tokyo_To_JGD2000_1

Japan

Tokyo_To_WGS1984_1

Mean for Japan, Korea, and Okinawa

Tokyo_To_WGS1984_2

Japan

Tokyo_To_WGS1984_3

Korea

Tokyo_To_WGS1984_4

Okinawa

Tokyo_To_WGS1984_5

South Korea

Tokyo_To_WGS19842001

Japan

Trinidad1903_To_WGS1984

Trinidad and Tobago

Voirol1875_To_WGS1984

Algeria - N of 35g (31 30') N

Voirol1875Paris_To_WGS1984

Voirol 1875 (Paris) to WGS84

Voirol1975Paris_To_Voirol1875

Voirol 1875 (Paris) to Voirol 1875

VoirolUnifie1960_To_WGS1984

Algeria

1346

PETRA Help

VoirolUnifie1960Paris_To_VoirolUniVoirol Unifie 1960 (Paris) to Voirol Unifie 1960
fie1960
VoirolUnifie1960Paris_To_WGS19 Voirol Unifie (Paris) to WGS84
84

14.9

WGS1972_To_WGS1984_1

World

WGS1972_To_WGS1984_2

World

Yacare_To_WGS1984

Uruguay

YemenNGN1996_To_WGS1984

Yemen

Zanderij_To_WGS1984

Suriname

Project Files
The current state of the Thematic Mapping Module can be saved as a "project file". A project
file contains a list of the selected shape files along with all information to redisplay the themes
in the current status. Project files can be saved anywhere on your system, however, the
default is to save them under the Petra project's public "parms" folder.

14.10 Changing the Theme Order
You can change the display order for themes by dragging and dropping items within the
Theme List. Use the left mouse button to drag a theme to a new position in the list.

14.11 Theme Properties
Every theme has a set of properties, most of which govern how the theme is
displayed.
To view a theme's properties, first select it as the "current" theme. Then select the
button on the toolbar, or Theme>Theme Properties... on the menu bar at the top
of the screen.

© 2014

Thematic Mapping Module

1347

14.11.1 Single Symbol

The Single Symbol method applies the same color, line style, marker symbol and fill
color to all records in the theme (shape file).
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14.11.2 Unique Values

The Unique Values method applies different colors based on values. The example
below shows selecting the "operator" field and assigning a different color to each
operator name.
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Results in the following map display
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You may change the color for each unique value entry by "double-clicking" the item
under the themes list.
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14.11.3 Class Breaks

The Class Breaks method applies a different color to shape file records based on a
range of numeric values in a selected data field. The example below shows selecting
the "TD" field and assigning a color range to its values.
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The Color button can be used to assign a different color scheme.
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The resulting map is displayed.
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14.12 Queries
Queries can be performed using the attribute data associated with a shape file
theme. Queries result in a new shape file (theme) being created with a subset of the
records from the original theme. The following queries are available:
Expression Query - These are queries based on SQL statements, such as,
TD>10000 or OWNER="Smith"
Spatial Query - These queries perform queries using the "shape" data for two
themes, a "source" and "selection" theme. These queries are good for finding wells
falling inside leases or pipelines crossing leases.
Distance Query - Distance queries use a "source" and "selection" theme to find all
of the "source" records within a distance to the "selection" theme records. This query
can be used to find wells within a given distance to a pipeline theme.
14.12.1 Expression Query

Use an expression query
to find a subset of records within the current theme that
meet certain selection criteria. The query uses standard SQL language for defining
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the query.

Following example shows finding the subset of wells that have a cumoil value greater
than 1000000 and a datum value that is not NULL. The screen displays the Query
Results and we clicked the "Highlight Results" button to see the wells meeting our
criteria. We then clicked the "Save As Theme" button and saved the results to a new
theme called "MyWells".
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"LIKE" Operator

Use the LIKE operator (instead of the = operator) with wildcards to build a partial
string search.
For example, the following query would select Mississippi and Missouri among the
USA state names:

[STATE_NAME] LIKE 'Miss*'
where * represents any group of characters.

The following query would find Catherine Smith and Katherine Smith:
[OWNER_NAME] LIKE '?atherine smith'
? represents any single character.
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WILDCARDS

Wildcards are used with the LIKE operator to build a partial string search.
The following wildcards are available with Shapefiles:

_ indicates one character.
% indicates any number of characters.
If you are querying personal geodatabase data:
? indicates one character.
* indicates any number of characters.

If you use a wildcard character in a string with the = operator, the character is
treated as part of the string, not as a wildcard.

The # is also used as a wildcard to match a single digit (numeric value) with the LIKE
operator when querying a shapefile.

For example, this query would return parcel numbers A1, A2, etc.:
[PARCEL_NUMBER] LIKE 'A#'

14.12.2 Spatial Query

Spatial queries
use the "shape" data from two themes to find records in the
"source" theme that meet conditions from a "selection" theme. For example, spatial
queries can be used to find "points" (or wells) contained in leases, two lease files
that overlap, and a variety of other conditions based on the interaction of the
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geometry of the "shapes".

The following example finds all wells in the "Shape_Leases" theme.

The selected wells were then saved as the "WellsInLeases" theme.

© 2014

Thematic Mapping Module

1359

14.12.3 Distance Query

A Distance query
uses the "shape" data from two themes to find records in the
"source" theme that are within a given distance from the "selection" theme. For
example , you might want to find all wells that are within 1000 feet of a pipeline
theme.

The following example shows finding all wells within 700 feet of a section line. The
original "PetraWells" theme was selected as the "current" theme, thus becoming the
"source" theme. The "SECTIONS" theme was used as the "selection" theme.
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When you perform a distance query using a dataset (shape file) containing latitudelongitude data, you will receive the following warning that the distance query is only
an approximation due to the variation in the number of feet (or meters) per degree at
different locations on the earth.

The selected wells were then saved as the "Edge Wells 1" theme (shown in yellow).
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14.12.4 Spatial Query Methods

moAreaIntersect - If the search feature is a polygon feature, returns features that
are wholly or partially contained within it, but not adjacent to it. Otherwise, the
features themselves must be polygon features, and the method returns features
that wholly or partially contain the search feature. This method is similar to the
moContainedBy search method, with the difference that the feature may contain
the shape, OR the shape contain the feature.
moAreaIntersect NoEdgeTouch - Same as moAreaIntersect, but the boundaries
of the search feature and the feature may not intersect or touch.
moCentroidInPolygon - Returns polygon features whose centroids are contained
by the shape
moCommonLine - Returned features must share at least one identical common
line segment with the search feature.
moCommonPoint - Returns features that share at least one identical common
point with the search feature.
moCommonPointOrLineCross -Returns features that share a common point with
the search feature or intersect it.
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moContainedBy - Returns features that wholly contain the search feature. If the
feature is a polygon feature, the search feature must be wholly inside it, inclusive
of the feature's boundary. If the feature is a line feature, the search feature must
lie along the feature's path. If the feature is a point feature, the search feature
must be on one of its vertexes.
moContainedByNoEdgeTouch - Returns features that wholly contain the search
feature, not inclusive of the search feature's boundary. The feature must be a
polygon feature, the search feature must be wholly inside it, and their boundaries
may not intersect or touch.
moContaining - Returns features that are wholly contained within the search
feature.
moContainingNoEdgeTouch - Returns features that are wholly within the search
feature, not inclusive of the search feature's boundary. The search feature must be
a polygon feature, the feature must be wholly inside it, and their boundaries may
not intersect or touch.
moEdgeTouchOrAreaIntersect - Returns features that touch the search feature,
are wholly or partially within the search feature, or wholly or partially contain the
search feature(s).
moExtentOverlap - Returns features whose extents overlap the extent of the
search feature. (Can be used with a 3D Rectangle for searching on 3D features).
moIdentical - Returns features that are identical to the search feature. Considers
feature type and coordinate description. Typically used to find duplicate data.
moLineCross - Returns features that intersect the search feature.
moPointInPolygon - Returns polygon features that contain the first coordinate of
the search feature.

14.13 Send Theme To PETRA Overlay
The Send To Petra function sends the current theme to an overlay layer in the Map
Module. After making the appropriate theme the "current" theme, click on the small
icon. The map module will be notified and respond with a window for you to
specify the layer in which to load the thematic data.
The following example sends the "Shape_Leases" to overlay layer "Leases"
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3D Visualization Module
The 3D Visualization Module (or "3DViz") displays many kinds of project data in a
project as three dimensional objects in a cube (map X, map Y, and subsea depth).
Note: 3DViz can only display sub sea depth data. 3DViz requires no special computer
hardware and should run on most PC's.
To start 3DViz, select the
icon on the main Petra toolbar. Alternatively, select
Tools>3D Visualization on the menu bar at the top of the Main Module.

Getting Started
Changing the View with the Mouse
Rotate and move scene - Left Click and Drag
Zoom In - Right Click and Drag Up
Zoom Out - Right Click and Drag Dn
Rotate Scene - Ctrl + Left Click and Drag
Pan Scene - Shift + Left Click and Drag, or Middle Click and Drag
Adding New Data
Set Vertical Exaggeration
Setting Default Well KB and TVD Values
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Setting the Data Extent
Setting a Frame
Axes Options

Keyboard Shortcuts
F2 Seismic Editing Mode
F5 Refresh Data From Tables
F6 Restore Default View
Ctrl + X Axis Options
Ctrl + E Extent Options
Ctrl + F Frame Options
Ctrl + O Display Options
Ctrl + C Clear All
Ctrl + Alt + C Clear Screen
Ctrl + D Display All
Ctrl + L Set Light Position
Ctrl + W Set Data Limits to Full Extent
+ Zoom In
- Zoom Out
Z Zoom Off
W - Show as wireframe
S - Show as solid

Load Default overlay - Generate and plot a overlay containing well symbols.

15.1

Main Menu

File
Import Custom Bitmap - This option draws an image bitmap in the 3DViz frame. by
mapping its corners to the world coordinates.
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Print To Bitmap - Generates a bitmap from the window image.
Print... - Print the 3DViz image to a printer
Load Settings - Load 3DViz settings.
Save Settings - Save 3DViz Settings.
Reset Parameters - Reset all 3DViz parameters and settings to default value and
closes the program.
Exit - Close the 3DViz program

Wells
Select Wells - Select wells to use in the 3DViz module. Well lists may come from
various sources or be generated by sorting.
Select Well by WSN - Hilight a particular well based upon WSN.

Display
Refresh Data - Reloads all data from disk and replots all layers.
Set Extent - Extent Dialog to set the X/Y and Z extents of the visualizer.
Set Data Limits to Full Extent - Sets the extents to the min-max of the layers.
Set Vertical Exaggeration - Vertical Exaggeration dialog.
Set Light - Makes globe appear on display allowing the positioning of the light source.
This is used in conjunction with the Display Options Light parameter.
Frame - Frame options dialog, allowing the placement of a 3D frame or cube at XYZ
extents.
Axes - Axes dialog options to label the X, Y, and Z axis.
Restore Default View - Sets the 3DViz view to the default zoom and rotation.
Save Current View - Save the current view (zoom and position)
Restore Saved View - Restore the saved view (zoom and position)
Default Settings - Resets all custom settings to their default state.
Options - Display Options dialog.

View
Map View
Front View
Zoom In
© 2014

3D Visualization Module

1369

Zoom Out
Zoom Off

15.2

Selecting Wells
To change the wells selected on the Decline Curve Analysis Module, select the
Wells>Select Wells option on the menu bar at the top of the screen.
All Wells - This option selects all wells in the project.
By Data Criteria - This option opens the “Select Wells By Data” option. This tool can
refine the wells used in the cross plot based on several different criteria. Additionally,
multiple nested searches can combine to make for more precise well lists.
Main Selected Wells - This option selects the wells currently active in the Main
Module.
Map Selected Wells - This option selects the wells currently active in the Map Module.
Petra Current XSect Wells - This option selects the wells currently active in the Cross
Section Module.
Selected Cross Section Image Wells - This option selects the wells currently active in
the Cross Section Module.
PetraSeis Selected Wells - This option selects the wells currently active in the
PetraSeis Module.
No Wells - This option selects the wells currently active in the Main Module.

15.3

Toolbars
The 3DViz's main toolbar across the top of the screen controls zoom, rotation, saving
and loading views, data and other display options.

Zoom and Rotate
The buttons zoom in on the data displayed on the 3DViz module, and rotate the box.

Working with Views
- This button saves the current "view" or angle of the 3DViz module. This will keep
only the rotation of the frame, and not any of the layer elements.
- This button restores the saved view to the 3DViz module. This will rotate the
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frame back to the saved angle.
- This button restores the angle to the default module.
- This option clears the screen.

- This tool refreshes the data displayed on the module from the project database.
This is useful for reflecting changes made to the database in other modules, such as
updated tops.
- This button opens the "Search Well By WSN" tool. This tool finds a well by its
well sequence number.

- This button changes the data extents. Wells and grids outside the data extents
will not plot on the 3DViz Module.
- This button changes the vertical exaggeration.
- This button opens the Map View tool that graphically resets the 3DViz aerial
extents.
- This button opens the Front View tool that graphically resets the 3DViz depth
extents.

15.4

Front View
The Front View window displays a cross section through the the frame of the project
to show wellbores and tops. The tool projects from south to north, so the left side of
the Front View tool is west, and the right side is east.
The primary use of this tool is to set the depth boundaries of the 3DViz extents by
dragging the red lines to the desired depths. This tool can also change the eastern
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and western boundaries of the 3DViz extents.
To open the Front View select the
button on the menu bar at the top of the
screen. Alternatively, select View>Front View from the menu bar at the top of the
3DViz Module.

- This option refreshes the Map Module to reflect the most current data in the
project.
- This option enables or disables wellbores on the Map View Table.
- This option applies the new extents set on the Front View to the 3DViz Module.

15.5

Map View
The Map View displays an aerial view of the area selected in the 3DViz Module. This
tool can select wells and highlight wells, and change the limits on the 3DVIz Module.
To open the Map View select the
button on the menu bar at the top of the screen.
Alternatively, select View>Map View from the menu bar at the top of the 3DViz
Module.
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- This option resets the limits on the Map View to the current limits selected on the
3DViz Module.
- This option refreshes the Map Module to reflect the most current data in the
project.
- This option enables or disables wellbores on the Map View Table.
- These buttons zoom in and out of the Map View. Note that this also resets
the red lines on the Map View.

Selecting and Highlighting Wells
To select a well, simply click it on its location in the Map View. Doubleclicking a single
well will take you directly to it in the Main Module. To select multiple wells, hold down
the CTRL key and select multiple wells.
- This tool highlights selected wells on the 3DViz Module. This effectively dims all
other wells displayed in the project. To disable highlighting, simply doubleclick
anywhere inside the frame.
- This option limits the 3dViz Module to only the wells selected on the Map View
Tool.
- This tool limits the 3DViz Module to the extents defined by the red rectangle.

Changing the Area
The Map View tool can change the extents on the 3DVIz Module. The red lines on the
edges of the map display the 3DViz Module's current extents. Selecting and dragging
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the lines to the desired location changes the limits on the module.

15.6

Place a Custom Bitmap
This tool places a bitmap image file (*.BMP) in the 3DViz frame. To add a picture file,
select File>Import Custom Bitmap from the menu bar at the top of the 3DViz Module.

Bitmap - This entry sets the specific name and location of the bitmap file. Selecting
the "Browse" button opens the Windows Explorer. Note that the 3DViz module will
only keep a link to the image, rather than importing into the project. As such, the
image file needs to remain accessible.
Opacity - This option sets the opacity/transparency of the image file. Setting this
entry to 1 will make the image completely opaque, or to 0.1 will make the image
mostly transparent.

Bitmap Placement Options
Bitmap Place At - This dropdown sets the location of the image file. This includes the
front plane (south), back plane (north), right plane (east), left plane (west), top plane,
or bottom plane. Note that changing this dropdown will change the entries on the
Extent Section.

Extent
This sets the specific extents of the image file. Note that the 3DViz module will plot
the lower left hand corner of the image file in the "Origin", the left extent in the X1,Y1,
Z1 position, and the upper extent in the X2,Y2, Z2 position.
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Printing
To print out a hard copy, select File>Print... from the menu bar at the top of the 3DViz
Module.

Print Options
The Print Options tool sets the options for the hard copy, including the orientation, title
block, and resolution.

Orientation
Portrait/Landscape - This option sets the orientation of the hard copy.

Options
Include Title Block - This option adds a title block to the plot. Selecting this option
opens the Title Block Print Options below.
Print Preview - This option creates a preview of the plot.

Resolution
This option sets the resolution of the plot. Lower resolution plots are quicker, but of
lower quality.

Title Block Print Options
The title block dialog allows loading of saved title blocks and saving of modified title
block.
Set and select the desired parameters while viewing a representation of the finished
title block on the left. The title block is positioned in the upper left corner of the
printed page.
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Print Logo
This option adds a logo to the title block. To add a logo, select the "..." button and
navigate to the desired image file containing the image of the logo. The small
checkbox to the left switches the image on or off.
Logo Width - This option sets the width of the logo in inches.
Logo Height - This option sets the height of the logo in inches.

Title
Company - This option adds the company name at the top of the title block.
Project - This option adds the project name. By default, Petra adds the project name
to this entry.
Title1/2/3 - These options adds text lines to the title block.
Mapped By - This option adds a "mapped by" option to the title block. This can be
useful to identify the creator.
Descriptions - This option adds a description field to the title block. By default, Petra
adds the project description set on the Main Module Project Tab.

Legends
Tops - When tops are displayed on the 3DViz Module, this option adds a legend for
the plot.
Logs - When logs are displayed on the 3DViz Module, this option adds a legend for
the plot.
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Others - This option adds legends for other layers on the 3DViz Module.

15.8

3DViz Layers
The Layers List on the left side of the screen shows the elements that have been
added to 3dViz Module. This tool is a quick way to hide, modify, remove, and sort
different data types.
This tool also has a special list for Tops, Logs, and Seismic data.
The first three toolbar buttons control sorting of the layers. The next buttons remove
or change the property of the selected layer. The last portion of the property button
shows the Layer popup menu shown below. The property of an entry can also be
shown by double clicking on the layer.

Quicklist

- These sort the current layers on the 3DViz module by alphabetical order.
- This opens the 3DViz Sort Layers tool.
- This tool remove selected layer, and will clear all the layer settings..
- This tool opens the options on the currently selected layer. As an example,
selecting this tool with the "Tops" entry highlighted will open the Tops tool.

Properties
Zoom to Selected Layer - Zooms the image to center the data from the selected
layer.
Clear and Clear All - Hides the specified Layers.
Display and Display All - Shows the specified Layers
Remove Selected - Removes the selected layer from the Layers list.
Remove and Remove All Layers - Remove the specified layers from the layer list.
Properties - Display the selected layer property dialog.
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- Boreholes
- Tops
- Shows
- Perfs
- Log Curves
- Dipmeter
- Grids
- Petra Overlay (*.OVL)
- Petra Map Images (*.GEO)
- Cross Section File (*.X3D)
- Depth Plane
15.8.1 3DViz Boreholes
The 3D Viz Module can display boreholes as tubes with a specified diameter and
color. Note that deviated wells are drawn using the directional survey data loaded on
the Main Module's Location Tab.
button on the on the Layer
To modify how boreholes are displayed, select the
Toolbar. Alternatively, select Wells>Bore Holes on the menu bar at the top of the
3dViz Module.
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Set Color and Size
Size - This option sets the wellbore diameter in map units. As an example, setting this
option to "50" will create wellbores with a diameter of 50 meters or feet. This is
useful for illustrating borehole location (displaying them at actual diameter would
make them very difficult to see), but can be misleading about the proximity of very
closely spaced wells (like sidetracks).
Color - This option sets the color for the boreholes on the 3DViz module. Select the
rectangle to set a different color.
Opacity - This option sets the opacity of all wellbores on a scale from 0 (transparent)
to 1 (completely opaque).
Dim Opacity - This tool dims all wells except the selected well. Dimmed wells can
have an opacity anywhere from 0 (transparent) to 1 (completely opaque).
Select Wells to Hilight - This option uses a Select Wells By Data Criteria to highlight
selected wells with a different wellbore color.
Hilight Color - This option sets the color for the optional highlight.
Show Secondary Surveys - Petra can store "Primary" and "Secondary" directional
surveys, but the 3DViz module only displays the "Primary" survey by default. This
option enables both the primary and secondary surveys for all directional wells.

Additional Color Options for Directional Wells
This section controls how the 3DViz module displays directional wells with survey
data.
Plot directional wells using color(s) selected above - This option plots directional wells
using the color specified on the "Color" box in the "Set Color and Size" section above.
Plot Directional Wells using Survey Definition color - This option instead plots
directional wells using the "default color" specified on the Survey Def Maintenance
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tool.
15.8.2 3DViz Tops
The 3DViz Module displays tops as a thin disk or cylinder on boreholes.
To modify how Tops are displayed, select the
button on the on the Layer Toolbar
. Alternatively, select Wells>Tops on the menu bar at the top of the 3dViz Module.

Select Tab
The Select Tab adds and removes formation tops to the 3DViz Module.

Select Source
This section displays the FmTop sources for the project. The Available Tops list will
only display tops for checked sources. This can be useful for filtering out only the
relevant tops from a large, multi-user project.

Available Tops
This list displays the FmTops in the project with the selected source(s). To add a
single top, select it on the Available Tops list, and select the ">" button. To add all the
tops on the Available Tops list and select the ">>" button

Selected Tops
This list displays the tops added from the Available Tops list. To drop a top, select
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the desired top from the Selected Tops list and select the "<" button. To drop all tops
from the 3DViz Module, select the "<<" button.

Edit
This section changes the size and color of the selected top on the Selected Tops List.

Options Tab
The Options Tab sets the fm top display style, and adds a filter to exclude fm tops
with a specified quality code.

Style - This dropdown selects how formation tops display on the 3DViz Module.
Options include cylinders, discs, and ticks.

3D Viz formation tops as cylinders (left), discs (center), and ticks (right)
Skip Well if Quality Code contains - This option excludes formation tops with specified
quality codes. This can be useful for excluding questionable, extrapolated, or
otherwise lower-quality tops. To use multiple codes, seperate different codes with a
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a semi-colon
15.8.3 3DViz Shows
Petra displays shows as a cylinder around the wellbore. Petra can either shade all
shows in the database the same color, or with individual colors and diameters.
To modify how shows are displayed, select the
button on the on the Layer
Toolbar. Alternatively, select Wells>Shows on the menu bar at the top of the 3dViz
Module.

All Shows with Same Color and Size
This option plots all shows at the same color and size.
Size Factor - This entry sets the size of the show cylinder relative to the borehole. A
size factor of "3" will plot shows as three times larger than the borehole.
Color - This entry sets the color of all shows.

Color and Size based on show Types
Size Factor - This entry sets the size of the show cylinder relative to the borehole. A
size factor of "3" will plot shows as three times larger than the borehole.
Color - This entry sets the color for the relevant show type.
Opacity - This option sets the opacity of the show cylinders on a scale from 0
(transparent) to 1 (completely opaque).
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15.8.4 3DViz Perfs
Petra displays perfs as a cylinder around the wellbore. Petra displays all perfs the
same color.
To modify how shows are displayed, select the
button on the on the Layer
Toolbar. Alternatively, select Wells>Shows on the menu bar at the top of the 3dViz
Module.

Color - This entry sets the color for the relevant show type.
Size Factor - This entry sets the size of the perf cylinder relative to the borehole. A
size factor of "3" will plot shows as three times larger than the borehole.
Opacity - This option sets the opacity of the perf cylinders on a scale from 0
(transparent) to 1 (completely opaque).
15.8.5 3DViz Logs
Petra displays logs with "geocolumn" shading, as multi-colored cylinders around the
wellbore. The 3DViz Module varies the cylinders size and color based on log values.
To modify how digital logs are displayed, select the
button on the on the Layer
Toolbar. Alternatively, select Wells>Curves... on the menu bar at the top of the 3dViz
Module.
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GeoColumn Tab
The 3DViz module can draw digital logs in two different ways - by varying the
diameter of the cylinder and the color. These two are independent and can color the
selected log trace using values from another log curve. This option can be useful for
plotting a litho-column type display.

Select Log
This dropdown selects the digital log to display around the wellbores. This curve will
be used to set the diameter of the log curve cylinders.

Size Scale
Min Scale -This option sets the minimum boundary for the digital logs.
Max Scale - This option sets the maximum boundary for the digital logs.
Size Factor - The size factor sets the scaling for the digital log cylinders. Setting this
value to 4 will draw digital log curves at 4 times the wellbore diameter.
Logarithmic Scale - This option displays the selected digital log on a logarithmic scale.
Clip/Shift Logs to Fit Range - This option controls how logs plot when they are outside
the minimum and maximum scale. The "Clip Logs at Range" will simply clip the logs
beyond the range, while the "Shift Logs to fit Range" option instead scales the logs to
fit the range.
Normalize Logs to fit Range Def - This option populates the min and max scale by the default log scale set on the
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Main Module's Log Tab's "Scale" button.
Stat - This option populates the min and max scale using a
Data - This option populates the min and max scale using a statistical measurement of
the log values.

Direction
This section sets how logs plot diameters on the wellbores.

Largest value corresponds to Largest diameter - This option draws logs as a variable
cylinder. Larger log values are fatter than low log values.
Largest value corresponds to Smallest diameter - This option draws logs as a variable
cylinder. Larger log values are thinner than low log values.
Fixed diameter - This option draws logs as a fixed cylinder.

Select Log for Shading
The Shading log sets the colors of the log curve cylinder. By default Petra uses same
log as used for the diameter scaling, but can use any digital log.
Select Log for Shading - This sets the log for the color shading.
Min Scale - This option sets the lower boundary of the color bar.
Max Scale - This option sets the upper boundary of the color bar.
Sample Rate - This option sets the sample rate for the color scale

Depths Tab
The Depths Tab sets the depths of the logs displayed on the 3DViz log. Selecting the
"Set Depths..." option opens the Set Depth Range tool.
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15.8.6 3DViz Dipmeter
This tool displays dipmeter data on the 3D Module. This tool displays dip and azimuth
as tilted disks along the wellbore.
To display dipmeter data, select the
button on the on the Layer Toolbar.
Alternatively, select Wells>Dipmeter on the menu bar at the top of the 3DViz Module.
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Select Logs
Dip Log - This dropdown selects the dip log in the project. Petra reads 0 as flat, and
90 as vertical.
Azimuth Log - This dropdown selects the azimuth log in the project.
Use Aliases - This option enables log aliases for the dip and azimuth log.

Sample Rate
Display Depths that are Multiple of - This option restricts the discs to only a set depth
interval. Setting this interval to to 50, for example, will only display dipmeter discs
every 50'.
No. Of Dip/Azm Samples to Average - This option calculates and displays an average
of both dip and azimuth around every displayed disc. This can be useful for displaying
data that represents a larger chunk of lithology. As an example, setting this entry to
10 will average 5 data points on either side of the displayed disc. This setting will
generally depend on the data sample rate and the desired smoothing.

Size and Color
Size Factor - This entry sets the size of the dipmeter discs. The diameter is a multiple
of the wellbore diameter. Setting this entry to 4, for example, will draw dipmeter
discs that are 4 times bigger than the wellbores.

Coloring
The 3DViz Module can display dipmeter discs with either a single set color or with a
colorbar set by another digital log.
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Single Color - This option displays dipmeter discs with a single set color. To change
the color, select the

button.

Use Color Curve - This option colors dipmeter discs based on another digital log curve
value. Select the desired log curve from the dropdown - note that it can be any digital
log curve, not just a dipmeter curve. To set a colorbar, select the
that this tool can use either the Normal Colors or Enhanced Colors.

button. Note

15.8.7 3DViz Grids
Petra displays grids as a surface in the 3DViz Module.
To modify how shows are displayed, select the
button on the on the Layer
Toolbar. Alternatively, select Surfaces>Grids on the menu bar at the top of the 3dViz
Module.

Grid Tab
The Grids dialog allows the selection of a Petra structure grid (depth) and an attribute
grid (color). The attribute grid defaults to the structure grid, although a different
attribute grid may be selected. The attribute grid must have identical grid
characteristics as the structure (same size and bins).
The colors for the attribute grid may be changed and the opacity may be adjusted.
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Grid File
The 3DViz module can display grids both as a surface and as a color. The "Structure"
grid sets the grid, while the "Attribute" grid sets the coloring used. This can be useful
for displaying both structural and reservoir information, such as a structure and
isopach map together on the same.
Structure - This entry sets the structural grid. The 3DViz Module will display the
values in the grid relative to the zmin and zmax set on the frame.
Attribute - This entry sets the attribute grid that colors the structure grid using the
colorbar set in the Color Range Section below.

Color Range
Min - This sets the lower range for the colorbar.
Max - This sets the upper range for the colorbar
Interval - This sets the color interval for the colorbar
Units - This sets the units for the grid file.

Opacity/Decimation
Opacity - This option sets the opacity for the grid file plotted on the 3DViz Module,
ranging from 0 (transparent) to 1 (opaque).
Decimation - This option decimates out the number of grid points plotted on the 3DViz
Module. This reduces the amount of memory and increases drawing speed for large
grids.

IsoPach Tab
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Upper Grid File - This dropdown sets the upper boundary for the isopach. In general,
this will be an upper boundary of a grid file.
Lower Grid File - This dropdown selects the lower boundary for the isopach. This can
either be a structure grid on the base of the isopach or a grid representing isopach
thickness.
Color - This option sets the color of the isopach mass.
Opacity - This option sets the transparency or opacity of the isopach.

15.8.8 3DViz Overlay
This tool adds a Petra Overlay File (*.OVL) at a flat depth inside the 3DViz Module's
cube. As an overlay file, various overlay layers can be turned and off inside the 3dViz
module. This tool can be a little more flexible than the Map Images tool, but can't
display map data outside of an overlay file (such as attribute maps or data posting).
To modify how an overlay file is displayed, select the
button on the on the Layer
Toolbar. Alternatively, select Maps>Load Overlay File on the menu bar at the top of
the 3dViz Module.
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Overlay - This dropdown selects the overlay to display on the 3DViz module. By
default, this tool looks in the project's Parms directory. To change the directory,
select the Browse button and navigate to the desired location.
- This button opens the Overlay Layers and Preferences tool. Here, you can
enable and disable different overlay layers. Note that the overlay file here is read only
- though you can clear layers and change plotting order, these changes will not be
saved back to the overlay file.
Opacity - This option sets the opacity of the overlay file between 0 (transparent) and
1 (opaque).

Place Overlay At
Fixed Elevation - This option sets the depth (in SSTVD) to draw the overlay file. The
"Top" button sets this depth to the highest datum in the project, while the "Bottom"
button sets this depth to the lowest TD in the project)

Well Symbol
Well Symbol - This option adds well symbols to the overlay file.
Browse - This option sets an additional filter for t
Symbol Size Factor - This entry sets the size of the symbols on the overlay.
15.8.9 3DViz Map Images
Map images generated by the Petra map module may be displayed at a specified
elevation on the 3D display.

Creating a *.GEO File
The first step is to displaying a map on the 3DViz module is to create a *.JPG and &*.
GEO file. The JPG is a simple image file, while the *.GEO file sets the specific
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location of the image on the 3DViz Module.
In the Map Module, select File>Print To...>3dViz Image from the menu bar at the top
of the screen.

The map images contain a well list which may be used with the image by checking the
Load Wells from Image check box. Here, select File>Export 3DViz Image and save
the file to the desired location. Note that Petra will create 2 files, a *.JPG and a *.
GEO file.

Adding the Map Image
To add the image file, select the
button on the Layer Toolbar. Alternatively,
select Maps>Load Petra Map on the menu bar at the top of the 3DViz Module.
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Map - This dropdown selects the *.GEO file created in the Map Module. Select the
"Browse" button to navigate to the file.
Opacity - This option sets the opacity of the Map Image. Opacity can be set
anywhere from transparent (0) to opaque (1).
Place Map At - This option sets the elevation of the image. The "Top" button sets the
entry equal to the very top of the frame, while the "Bottom" entry sets the map to the
base of the frame.
15.8.10 3DViz Cross Sections
Petra displays cross sections as a fence diagram inside the 3DViz module. The
3DViz module uses a special *.X3D file to position a cross-section image file inside
the 3D volume.
Multiple cross section images may be shown, generating a fence diagram. Multiple
cross sections, particularly at high resolution, will require more memory and will
render more slowly.

Creating a X3D File
The first step to displaying a cross section on the 3DViz module is to create a X3D
file. This process creates both the cross section image and the X3D file, which
correctly positions the cross section image file inside the 3DViz volume. In the Cross
Section Module, select Print To>3DViz from the menu bar at the top of the screen.
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On the Print Preview Tool, select File>Export 3DViz File or File>Export 3DViz File
(Clipped) on the menu bar at the top of the screen.

Adding a Cross Section
Petra displays cross sections as a fence diagram inside the 3DViz module.
To modify how shows are displayed, select the
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Toolbar. Alternatively, select Surfaces>Grids on the menu bar at the top of the 3dViz
Module.

Cross Section - This dropdown selects the cross section to display on the 3DViz
Module. Note that Petra will look for *.X3D files created by the Print Preview tool. By
default, this tool will look in the project directory.
Color - This option sets the background color of the cross section. By default, this is
white.
Opacity - This option sets the opacity of the cross-section in the 3DViz Module.
Rendering Resolution - This slider bar sets the resolution of the cross section on the
3D module.
15.8.11 3DViz Depth Plane
Petra displays a single plane as a surface inside the 3DViz Module.
To add a plane, select the
button on the on the Layer Toolbar. Alternatively,
select Surfaces>Depth Plane... on the menu bar at the top of the 3DViz Module.
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Well Options (Default KB & TD)
The 3DViz module uses a KB (or other well datum) and TD (Total Depth) to position
wells inside the module. The 3DViz module cannot plot wells that do not have these
values.
This tool assigns a default KB and TD for wells missing these values. A Deviated well
will use the deviation survey to calculate a TD.
Select Wells>Set KB and TD from the menu bar at the top of the 3DViz module.

Set KB and TD for Missing Records - This entry enables the default KB and TD for
wells that are missing them.
KB - This entry sets the default KB for the wells missing an active datum. By default,
this is set to 0.
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TD - This sets the default TD for the wells missing an active TD. By default, this is
set to 10000.
Calculate Means and TD - This button calculates the average values for KB and TD
for the wells currently loaded in the project.

15.10 Vertical Exaggeration
Set the vertical (depth) exaggeration for the viewer by entering the desired value in
the edit box.
To change the vertical exaggeration, select Display>Set Vertical Exaggeration on the
menu bar at the top of the screen.
There is also an entry for Vertical Exaggeration in the Set Extents dialog.

15.11 Frame Options
Frame Options are used to draw lines at the corners of the cube bound by the
extents. It can also be used to position semi transparent planes on the sides of the
cube.
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Frame Color - This option sets the color for the frame.
Draw Planes - This option toggles the frame around the data on the 3DViz Module.
Opacity - This option sets the opacity of the frame.
North - This option sets the northern color and opacity of the frame's surface. By
default, the northern frame is yellow to distinguish it from other frames.
South - This option sets the southern color and opacity of the frame's surface.
East - This option sets the eastern color and opacity of the frame's surface.
West - This option sets the western color and opacity of the frame's surface.
Top - This option sets the color and opacity of the bottom of the frame's surface.
Bottom - This option sets the color and opacity of the bottom of the frame's surface.

Frame Extents
The frame extents set the boundaries of the frame.
Set Extent From - This dropdown sets the extents of the frame from either the
currently selected well limits, or by the limits of the data currently displayed.
xmin - This entry sets the east boundary of the frame.
xmax - This entry sets the west boundary of the frame.
ymin - This entry sets the north boundary of the frame.
ymax - This entry sets the south boundary of the frame.
zmin - This entry sets the upper boundary of the frame.
zmax - This entry sets the lower boundary of the frame.

15.12 Extents
The Set Extent dialog sets the X, Y, and Z extents of the module. The 3DViz module
will not plot project data, like wellbores or grids outside the extents.
To change the extents of the display, select the
button on the toolbar.
Alternatively, select Display>Set Extent on the menu bar on the top of the 3DViz
Module.
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XY Extent
This section sets the aerial or map extent of the 3DViz module.
Set XY Extent By - Selecting this dropdown populates the X and Y min and max
extents.

Z Extent
The Z Extent sets the upper and lower boundaries of the 3DModule.
Set Z Extent By - Selecting this dropdown populates the "Upper Depth" and "Lower
Depth" entries below.
Set VE - This entry sets the vertical exaggeration for the module.

Edit
X Min - This entry sets the east boundary of the 3DViz Module.
X Max - This entry sets the west boundary of the 3DViz Module.
Y Min - This entry sets the north boundary of the 3DViz Module.
Y Max - This entry sets the south boundary of the 3DViz Module.
Upper Depth - This entry sets the upper boundary of the module in SSTVD.
Lower Depth - This entry sets the lower boundary of the module in SSTVD.
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15.13 Display Options
The Display Options tool sets some of the general display options for the 3DViz tool.
To open the display options tab, select Display>Options on the menu bar at the top of
the module.

General
Display Warnings - This tool displays warnings and errors encountered while plotting
the display. This can include bad data like missing well information, such as missing
location, TD, or reference datum data.
Display Light Option when Setting Light - This option turns on the Switch for displaying
Light Option Dialog when setting Light.
Display Help At Start - This tool adds Switch for making the Layer side panel hide or
show.

Background
Background Color - Change to modify the background color of the visualizer.

Light
Fixed Light Source - This option fixes the light in space, or relative to the user.
Rotating data in the 3DViz Module will not affect the light source.
Light Move with Object - This option fixes the light relative to the data displayed in the
3DViz Module. Rotating the data around will also rotate the light.

Transformation
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Rotation Angle - This option sets the number of degrees the image rotates with each
button or key press.
Zoom Factor - This option controls the multiplier for the zoom button on the toolbar.

15.14 Axes Options
The Axes Property tool adds labels to the X, Y, and Z axis.
To open the Axes Property tool, select Axes>Display on the menu bar at the top of
the 3DViz Module.

X/Y/Z Axis Visible - These checkboxes control which of axes labels appear on the
module. Deselected axes do not display.
Color - This option sets the colors of the axes labels.
Corner Offset - This entry determines the distance the axis line is from the cube
corner. Zero is on the corner.
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Size Factor - This option sets the size factor of the axes labels. 1 is the default text
size, while 2 will double the text size.

Title
X/Y/Z Axis Title - These entries set the the text plotted along the relevant axis.

Ticks and Labels
Number of Intervals - This entry sets the number of labeled points along each axis.
The lowest number, 2, labels only the furthest extents of the axis and the center.
Increasing this number adds more labels along the axis.

© 2014

Chapter

16

Slip Log Module

16

1403

Slip Log Module
The Slip Log Module displays up to four (4) raster log images horizontally across the
screen - similar to laying out logs along your desk. Each raster logs can scroll
independently, or multiple logs can lock and scroll together. This tool is mostly used
for picking formation tops.
The Slip Log Module can only display raster logs, while the Cross Section Module
and Log Correlation Tool can handle both digital and raster logs. The Cross Section
Module provides more advanced options, while the Log Correlation Tool provides a
streamlined interface with fewer plotting and display options. Both tools display logs
vertically in a cross-section.
To open the Slip Log Module, select the

button on the Main Module toolbar.

Getting Started
Basics
Selecting Wells
Setting a Depth Scale
Displaying Raster Logs
Aligning Raster Logs

Logs and Tops
Displaying and Correlating Formation Tops
Applying Fault Gaps to Raster Logs

16.1

Selecting Slip Log Wells
The Slip Log Module uses the Map Module to select wells.
From inside the Cross-Section module, select Wells>Select From Map from the menu
bar at the top of the Cross-Section Module. This will switch to the Map Module.
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From inside the Map Module, select Tools>Pick Slip Log Wells from the menu bar at
the top of the screen. Next, left click on 2 to 4 wells on the map to select them for the
Slip Log Module. Right click to stop picking wells.
Next, simply left-click on the first wellspot on the map to add it to the Slip Log Module.
Left-click on one to three more wells to add them to the Slip Log Display. After
selecting the desired wells, right-click to finish and jump back to the Slip Log Module.

16.2

Slip Log Depth Scale
Raster logs are displayed using a specified depth scale in units/inch.
To change the depth scale on the on the Slip Logs Module, select
on the toolbar
or select Depths>Depth Scale on the menu bar on the top of the Slip Log Module.

16.3

Select Slip Log Raster Images
Each well in the display has associated with it one raster log group. The first time a
well is chosen for display, you will be prompted to select the log from a list of
available logs for that well. The selected log reference is retained and used whenever
the well is chosen for display. You can change the log reference for a given well at
any time.

Setting an initial Slip Log Image
The Slip Log Tool will select images sequentially for the wells selected. This log
reference will be retained and used whenever the well is displayed, but can be
changed at any time.
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Changing a Slip Log Image
To change a well's slip log image, select the
button above and select Select
Different Image for This well. This reopens the "Select Raster Image" tool.

16.4

Aliging Slip Logs Raster Images
Aligned raster logs move together to aid in raster or fault correlation. The Slip Log
Module can align two or more raster logs with a couple of different methods.

Line Up at Depth
The Line Up at Depth tool aligns raster logs at a single depth.
To use this tool, select Depths>Line Up on the menu bar at the top of the Slip Log
Module, or select the
icon on the toolbar.

Here, enter the start depth for the logs. This will align all raster logs at a common
depth, and automaticay lock the scrolling so that the logs will scroll up and down
together.
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Alignment Cursor
The Alignment Cursor lines up raster logs based on depths picked by the user. These
depths are picked graphically and can reflect any feature seen on the log, including
tops, flooding surfaces, or unconformities.
To use this tool, select View>Alignment Cursor, o select the
toolbar.

button on the

This tool activates a horizontal red cursor drawn on each image that can visually
inspect features on the different images. To align images to a similar feature, first left
click on each image to lock the alignment cursor for that image. Repeat left clicking to
lock the cursor for the remaining images. Finally, right mouse click to align the images
to the common feature.

Align By Fm Tops.
This tool aligns images to a selected formation top.
To use this tool, open the Edit Fm Tops tool by selecting Tops>Show Edit Tool or by
selecting the

button on the toolbar.

Highlight the desired top, and select the

16.5

button to hang all raster logs on the top.

Displaying and Picking Slip Log FmTops
The first step to working with tops in the Slip Logs Module is to select the tops to
display. A project can contain hundreds of tops, so this tool can be useful for filtering
the list down to only the most relevant formation tops.
To select the tops to display on the Slip Log Module, select Tops>Select Tops to
open the Select Zone Item List tool.
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Select the desired tops on the by selecting formation top names from the "Available
Items" list and adding them to the rightmost "Selected Items" list. To add one or more
selected item names, highlight the names and click the ">" button. You may add all
items from the "available" list by clicking the ">>" button. Items may also be added by
double clicking the name in "available" list.
To remove a top from the the "selected" list, highlight the desired top and select the
"<" button. To clear all tops from the list, select the "<<" button.

Editing Tops
Once tops are displayed on the Slip Log Module, select Tops>Show Tops on the
menu bar at the top of the screen or select the
button on the toolbar to edit tops.

/
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While in edit mode, you can use the left mouse button to drag or move existing tops
and click to pick new top values.
- This button changes the color of the selected top.
- This option manually sets the MD of the selected top.
- This option aligns the logs on the selected top. This can be useful for quickly
picking tops relative to a common, easily correlated top across a field.

16.5.1 Repeat Tops
Repeat Tops occur when the same lithologic interval is encountered multiple times in
the same wellbore. This is most common in directional wells, though is also possible
with structurally complex areas with overturned beds and folds.
To add repeat tops in the Raster Image Calibration tool, select Tops>Show Repeat
Tops.
When editing formation tops, you can now pick, move, or delete repeat values as well.
First ensure that under the Tops menu, ‘Show Repeat Tops’ is checked. This should
display any tops along with their repeat values if any exist in the visible range. When in
editing mode, there is a new check box and button on the Edit Fm Tops dialog. If the
‘Pick Repeat Tops’ dialog is checked then holding down the CTRL key while clicking
adds a repeat of the selected top at that depth. ALT clicking deletes a repeat top.
You can also click and drag any top to adjust its position. The ‘Set Repeats’ button
opens a grid showing you the value of all repeats for the given top. From here you can
edit, add, or delete values.

16.6

Applying Faults to Slip Log Images
The Slip Logs Module can add fault gaps in the project database to the raster logs.
The Slip Log tool will add a blank space for the gap and shift the image down in
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depth.

To add fault gaps, select Depths>Apply Fault Gaps on the menu bar at the top of the
Slip Log Module.
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Directional Well Module
The Directional Well Module displays and interprets horizontal and directional wells,
and is a great way of visualizing digital logs, tops, events, and surfaces along well
paths for analysis and interpretation. This tool is also a great compliment to the 3D
Visualization tool to view directional wells in more detail.
To open the Directional Well Module, select Tools>Directional Well on the menu bar
at the top of the Main Module. Alternatively, select the
the top of the Main Module.

button on the toolbar at

Getting Started
Using the Map Window
Using the Profile View
Using the Spreadsheet
Quick Reference Guide (PDF Version)
Planning a Well
Instructional Videos

17.1

Map View
The Directional Well Module's Map View works a lot like a simplified version of the Map
Module. It displays wells and well paths, overlay data, and grids. Note that the Directional
Well Module opens the Map View window automatically. The Map View window cannot
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close, and can only be minimized.
To reopen this window select the
Module.

button on the toolbar at the top of the Directional Well

Map View Toolbar
- These buttons zoom in, zoom out, and zoom to full extents

- This button redraws the Map View using the data loaded in memory.
- This button refreshes the Map View with the latest data in the project. This
can be useful for updating the map view to reflect changes made by other users or in
another module.
- This button opens the "Line and Wells" tool that selects wells for the Profile
View tool.
- This button opens the "Vertical Section" tool that displays a single well down
it's vertical section plane.
- This button opens the directional well planning tool

© 2014

Directional Well Module

1413

- These buttons create grids, display contours, hide contours, or
regrids the last set of countours.

Overlay
To load an overlay file, choose the menu option Overlay>Open. You can then select any
overlay that you have previously created in the Map Module. Note that overlay files in the
Map View tool are read-only, and cannot change here. To make edits to your overlays, use
the overlay editing and management functionality in the Map Module.

Display Options
The Display Options changes a few additional settings on the Map View. To open
the display options tool, select Display>Display Options on the menu bar at the top
of the Map View window.

Show Current Profile - This option enables or disables the Profile View outline on the
Map View.
Show Secondary Surveys - Petra can store multiple directional surveys in the project
database. This is commonly used for proposed well plans and actual directional
surveys. When this option is enabled, both primary and secondary directional
surveys are displayed on the map. When this option is disabled, the Map View will
only show "active" surveys.

Data Border Gap
The Data Border Gap establishes a blank space around the outline of the wells
selected. To open the data border gap options, select Display>Data Border Gap on
the menu bar at the top of the Map View window.
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A 80% border gap (left) and a 0% border gap (right)

17.1.1 Contour Grids

The Grid Contouring options in the Directional Well Module are a subset of the
options available in Petra’s Map Module. All grid files (.GRD) created in the
Directional Well Module are stored in the same grid folder in your Petra directory as
the Map Module, and grid files can be opened in either module.
Before you can make a contour map you must first direct Petra to construct a
gridded surface from formation tops or zone data. A grid contains regularly spaced
values which have been interpolated from the original data by locally fitting various
mathematical functions to the data.

Getting Started
Creating Contour Grids
Displaying Contour Grids
17.1.1.1 Create Contour Grids (Directional Well Module)

To create a contour grid, open the Contours>Create Contour Grid menu item or click
on the Create Contour Grid button on the icon bar.

Data Tab
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Grid Folder - This box shows the currently selected grid folder, where any created
grids will be stored. Selecting the “…” button on the right of this box changes the grid
folder’s path. By default, Petra looks in the active project’s GRIDS directory.
Grid Title - This option sets the title for the grid. This title will be placed in the grid file
header and displayed as the map title whenever a contour map is generated from the
grid. A default title is created whenever well data items or seismic z values is
selected.
Output Grid File Name - This is the external file name for the computed grid file.
Petra creates a default file name when well data items or seismic z values are
selected. The file extension for grid files is .GRD.

Zone Data To Grid
Zone Data – This option selects well data visible from the Zones Tab on the Main
Module. Simply select the zone and the appropriate zone data item. The “FMTOPS”
zone includes all created fm top data. The adjacent drop down selects whether the
fm top will be gridded as a MD, SS, SSTVD (if directional surveys are loaded and
enabled), or Seis Time (if velocity functions are loaded). A grid using this data will
use well data from for every selected well on the Map Module. Wells that have been
dropped from the map will not be used in the grid.
Disabled wells, on the other hand are still honored when gridding, even though they
don’t appear on the map. To disable a well, first select the well in the Map Module
with the left mouse button. Then, right click and select “Disable (Do Not Plot”). If
disabled wells contain bad data points, Petra will still try to grid using that data, which
may result in bulls eyes or other anomalies.
View Data - This option opens the View/Edit Zone Data tool.
Well Dist – This option calculates some basic statistics about well spacing, which can
be particularly useful when establishing grid spacing. This tool will calculate distance
statistics between all wells displayed on a map without discerning if they have data or
not. In other words, if you have a large number of closely spaced wells but only a few
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of those wells have data, this well distribution box will give you an average distance
that is too small.

Method Tab
The Method Tab controls the grid size and surface style of the gridding. The grid size
of a grid largely controls how many points are in a calculated grid, which has a direct
bearing on contour line smoothness and how well the computer-generated contour
lines “honor the data.” The grid method, on the other hand controls how Petra
interpolates the grid from one data point to another.

Grid Size
On a rectangular grid, the grid size determines the spacing between horizontal and
vertical interpolated grid node values, as shown in the example below where the blue
grid nodes are evenly spaced between a set of wells. A grid spacing of 900’
translates to grid nodes 900’ apart both north-south and east-west. Small spacing
leads to more grid nodes, which generally “honor the data” better but require much
more computer time. Large spacing, on the other hand, tends to generate smoother
contours with less computer time but at the cost of a less rigorous tie to data points.
The grid size section offers several methods for setting the grid size.
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Use Grid Size of (XY units) – This option sets grid spacing to a user-input X and X
grid size in map units (feet or meters). A good rule of thumb here is to use ½ the
average well spacing.
To calculate average well spacing, select the “Well Dist…” button on the Data Tab
(highlighted below on the left). The Well Dist… button on the gridding screen (on the
right) gives statistical information on distances between wells, including average
distances. This tool will calculate distance statistics between all wells displayed on a
map without discerning if they have data or not. In other words, if you have a large
number of closely spaced wells but only a few of those wells have data, this well
distribution box will give you an average distance that is too small.

Compute Optimum Size From Z Data - During gridding, Petra will compute a grid size
based on the well data distribution.
Set Rows and Columns Slider Bar – Instead of setting a specific grid size, this option
instead sets the total number of horizontal and vertical rows for the grid. Sliding the
“Coarse to Fine” slider bar changes the number of rows and columns used in the grid.
Notice that as these are changed, the x and y grid spacing sizes change accordingly.
Match Grid Size of Grid – This option sets the grid size of the new grid to exactly
match the grid size of an old grid. Select this option, and use the drop down menu to
select the grid file to be matched. Note that the X and Y sizes are updated to show
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the grid sized used.
Mathematical calculations between two or more different grids require the size and
spacing of each grid to match exactly. As an example, creating a hydrocarbon pore
volume grid (where HPV = thickness * porosity * hydrocarbon saturation) would
require the isopach, porosity, and water saturation maps to all have the same grid
spacing. Using this option to match the porosity and hydrocarbon saturation grid size
to the initial isopach grid will save considerable time later.

Surface Style
This option determines the shape and characteristics of the gridded surface by
applying different mathematical functions to the original data. Surface styles
interpolate the data between data points on both rectangular and triangular grids.
Highly Connected Features - This is Petra’s default gridding style. It uses a least
squares gridding algorithm that tends to preserve trends in the data and works well
for most data, particularly structure maps and gently changing petrophysical data. The
Highly Connected Features surface style works well with faulted reservoirs. This
surface style tends to not do well with rapidly changing or large contrasts between
data points such as production in a closely-drilled field.
This method tends to avoid geologically unrealistic contours (or “artifacts”) on the
edges of the grid, though contours can to be somewhat jagged and uneven with small
grid sizes. The application of surface flexing (“Smooth Contours Using Grid Flexing”
immediately below the Surface Style drop down menu) works well with this surface
style, as it tends to smooth and even out the spacing between contour lines.
Disconnected Features – This surface style uses a linear projection algorithm that
tends to produce closed-off features. This surface style can useful for mapping patch
reefs or isolated channels. The Disconnected Features surface style can be used
with faults. Contours generated from this surface style can be uneven and jagged, but
this is easily remedied by adding surface flexing (“Smooth Contours Using Grid
Flexing” immediately below the Surface Style drop down menu).
Since this method calculates grid values from a projected linear slope between one
data point to the next, the Disconnected Features surface style is susceptible to a
couple of different types of gridding artifacts. At the edge of a map this surface style
extends the nearest linear projection when calculating Z values, making it particularly
prone to “runaway grid values” on the edge of the map. The disconnected nature of
the surface style also tends to make “bumpy” maps where two adjacent wells form an
adjacent dome and a bowl instead of a more generalized trend.
Simple Weighting With Slopes – This surface style calculates a grid using three steps.
Petra first calculates a slope for each data point based on surrounding data points.
These slopes are then used to project the data points’ Z values out to each individual
grid node. Finally, this surface style takes the weighted average of the projected Z
values.
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The Distance Weighting Damping Factor on the Advanced Tab can greatly affect this
surface style. This option uses any value from 1 to 8, with a recommended default
setting of 2. With a small factor, more distant data points have more influence on an
individual data point which tends to average the grid node; this usually results in a
smoother grid. With a larger factor, close data points influence the individual grid
much more than more distant data points. The recommended value for this factor is
2. For more information, see the help file on the Advanced Tab.
Simple Weighting Without Slopes – This surface style applies a weighted average to
the data points around each grid node. In contrast to the Simple Weighting With
Slopes surface style, no slope information is used. This option is useful for very dense
control such as 3D seismic bin locations.
The Distance Weighting Damping Factor on the Advanced Tab can greatly affect this
surface style. This option uses any value from 1 to 8, with a recommended default
setting of 2. With a small factor, more distant data points have more influence on an
individual data point which tends to average the grid node; this usually results in a
smoother grid. With a larger factor, close data points influence the individual grid
much more than more distant data points. The recommended value for this factor is
2. For more information, see the help file on the Advanced Tab.
Distance Grid - This surface style calculates the distance to the nearest data point for
every grid point. Put another way, the grid right next to a data point will have a low Z
value, while a grid a great distance from any data point will have a high Z value.
Contouring this distance grid can be a useful way of visualizing drainage and
bypassed parts of the reservoir. Parts of the grid with a high distance to the nearest
well are less likely to be drained than parts of the grid with a low distance.

Again, this method only calculates distance to the nearest selected data point, which
can include contour lines and control points in addition to wells. If “Use Overlay
Contour Lines” is selected on the Data Tab, the surface style will calculate the
distance from the nearest well or the nearest contour line. This renders any
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visualization of drainage useless, so be sure to only select “Zone Data” for this
surface style.
Closest Point - This option simply sets each grid node to the value of the closest data
point. It doesn’t interpolate between data points, and is really more useful for
resampling existing grids. It is best used with very dense data such as 3D seismic
coverage or with legacy XYZ grids.
Minimum Curvature Tension - This surface style attempts to create a very smooth,
gradual surface. Contour lines with this method are smooth and evenly spaced, which
makes this style a good choice for gently changing petrophysical properties and
simple structural settings.
This method cannot be used with faults. Since the minimum curvature algorithm is
also available under the “Smooth Contours Using Grid Flexing” option (immediately
below the Surface Style drop down menu), so you can use the Highly Connected
surface style (which works well with faults) along with the grid flexing option. Since
this method strives to have as simple a surface as possible (one with a “minimum
curvature”), this surface style tends to smooth over some of the variation in data
points. In short, this method has the potential to “not honor the data” as well as other
methods. Edge effects with “runaway Z values” are also common with this method.
The "Min Curvature Tension" setting below can greatly affect this surface style.
Practically, high tension grids – particularly above 5 - have smoother and more even
contours but may not honor the original data as well as lower tension grids.

Flex Grid Factor – Flex Grid Factor adds an additional step after gridding to generate
smoother, more even contour lines. When this option is selected, Petra first uses the
selected surface style to interpolate between the data points to create grid nodes.
Next, Petra applies the minimum curvature surface style to both the original data
points and to a decimated sample of the newly-interpolated grid values. This option
can be set anywhere between 0 and 12. Setting a low grid factor will keep a
relatively strong primary surface style, while a high grid factor will increase the relative
strength of the minimum curvature surface style.
Grid flexing is also influenced by the “Min Curvature Tension” option on the Advanced
Tab. Practically, high tension grids – particularly above 5 - have smoother and more
even contours but may not honor the original data as well as lower tension grids.This
option changes the relative strength of the “Smooth Contours using Grid Flexing”
option. Low Grid Flex Factor create final grids that look like the original surface
style, while higher Grid Flex Factors will create a grid that looks more like a Minimum
Curvature grid.
Min Curvature Tension - Setting this option Petra first interpolates the data points with
the selected surface style, then adds an additional step to interpolate both the original
data points and the newly created grid values with the minimum curvature gridding
algorithm.
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Mathematically, this option controls the decimation of the initial grid, and can be set
from 2 to 12. When this option is set to 2, every other original grid point will be used
in the Minimum Curvature step. In this case, a large number of initial grid points
remain which constrains much further interpolation from the second minimum curvature
interpolation. When this option is set to 12, only every 12th original grid point will
remain. The relative low number of initial grid points allows for more interpolation
from the Minimum Curvature step. In short, the lower the Grid Flex Factor, the more
the final grid will look like the original surface style. Higher Grid Flex Factors will
create a grid that looks more like a Minimum Curvature grid.

Advanced Tab

Max Pts Per Octant – Petra interpolates the value of each grid node from surrounding
data points. This option sets the maximum number of data points in each octant used
for each grid node, and can be anywhere from 1 to 8. For example, with a value of 2
the gridding process will use a maximum of 16 data points (2 for each octant)
distributed around the grid node.
When determining which data points will be used for each grid node, Petra first
divides the area around the grid node into eight wedges, or “octants.” Petra then
uses the closest data points (up to the maximum set by this option) in each octant for
calculating an individual grid node’s value. Dividing the surrounding data into octants
helps avoid grid nodes that are too heavily biased by data points in one direction.
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Max points per octant set to 1 (left) and 2 (right)

Use Natural Neighbors – This option causes most surface styles to use a “natural
neighbors” triangulation search instead of the normal octant search when selecting
data points to interpolate for each grid node. This tends to provide a more localized
interpolation, which can benefit grids with dense data point coverage. Since this adds
an additional pre-gridding triangulation stop, this option can increase gridding time.
When deciding which data points to use for each grid node, most rectangular grids
styles (Highly Connected Features, Disconnected features, Simple Weighting With/
Without Slopes) use an octant search where the area around a grid node is divided
into eight wedges, or “octants.” This octant search ensures that data points used for
the grid point interpolation are evenly geographically distributed. A natural neighbors
search, in contrast, selects surrounding data points that can be connected by a
triangular network. This option just changes how Petra selects the data points for
interpolation, so the output will be a normal rectangular grid.

Octant search selects data points in 8 wedges around the node, while a natural neighbors search uses a triangular grid

Skip Well if Quality Code Contains – This option skips data points from wells that have
specified quality codes. Here, enter one or more values separated by a semicolon to
indicate wells that are NOT to be used for gridding.
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Tops Tab

Skip Well if Quality Code Contains – This option skips repeat formation tops from
wells that have specified quality codes. Here, enter one or more values separated by
a semicolon to indicate repeat tops that are NOT to be used for gridding.

Triangulation Tab
The Triangulation Tab sets changes the gridding from rectangular to triangular
gridding. Triangular grids always “honor the data” at the cost of sometimes unrealistic
changes in slope or dip. Refinement adds more interpolation inside these triangles,
which smoothes these grids. Interior angle clipping reduces grid artifacts caused by
widely separated wells on the edge of the map.

Instead of interpolating values for nodes at regularly spaced X and Y intervals,
triangulation instead constructs a network of nearest neighbors using the data points.
Essentially, Petra calculates node values along lines (shown with lines) between data
points. These nodes form triangles known as “Delaunay triangles.” Notice also that
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there is a node value directly on top of each well. The resulting contours “honor the
data” better because they are drawn using the actual values as opposed to
interpolated data in rectangular gridding. Triangular grids are better suited to closely
spaced, or highly-variable data rather than widely separated data.

Check the Triangulate box to perform triangulation instead of rectangular gridding.
Triangle Refinement – In a simple triangular grid, each Delaunay triangle is
independent from every other triangle so calculated gradients on one triangle can
differ significantly from an adjacent triangle. This can lead to rapidly changing,
geologically unrealistic dips and angular contour lines. Contours from these simple
triangular grids can look strange and can even cross.
Petra smoothes these triangular contours with a process called “triangle refinement.”
Refinement adds more points inside a Delaunay triangle to smooth the grid’s surface
and contour lines. These points inside the triangle are interpolated using Petra’s
surface style (such as “Highly Connected Features”). selected on the Method Tab and
surrounding data points. The refinement value selected here determines the number
of additional points, which in turn governs the smoothness of the contours. A
refinement of 1 simply uses the existing data points with no interpolation, while a
refinement of 16 adds a great deal of interpolated points inside each triangle.
Practically, a highly refined grid will have smoother contour lines than a grid with lower
or no refinement.
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Interior Angle – Triangular grids attempt to connect all data points together regardless
of how far apart they are. The part of the grid based on an interpolation between
distant data points often shows geologically unrealistic contours – especially on the
edge of the map. On the right side of the example below, two highlighted triangles
have high interior angles of 172 and 160 degrees. The area of the grid represented
by these two triangles probably interpolates the data too far and should be removed.
The triangular grid between these distant wells has one corner with a large angle.
Filtering out triangles with this high interior angle helps to trim out overly-interpolated
or geologically unrealistic parts of the grid on the edge of the map. Setting the value
here to 150, as in the example below, will eliminate all triangles with an internal angle
above 150 degrees. The smaller the angle, more edge triangles are removed.
Suggested values are 120 to 160 degrees.

Fast Local Slope Interpolation Method –Normal refinement uses the selected surface
style to interpolate data points inside each Delaunay triangle based on the surrounding
“neighborhood” of data points. The “Fast Local Slope” method instead uses partial
derivatives to interpolate inside each triangle. In other words, while the normal
refinement method attempts to make a more coherent regional picture based on
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outside data, this method simply uses only the data points in the Delaunay triangle.
Consequently, this method is quick, but is prone to geologically unreasonable dip
changes and other artifacts.
17.1.1.2 Display Contour Grids

Contour maps can be generated from grid files produced by the "Create Grid"
function. Both contour lines and color-filled contours can be produced.
To create a contour grid, open the Contours>Display Contour Grid menu item or click
on the Display Contour Grid button on the icon bar.

Grid Tab
The Grid Tab sets the specific grid displayed on the Directional Well Module's Map
View.

Grid File
This section sets the specific grid file for the contours on the Map View.
Grid File Directory - This entry sets the location of the available grid files (*.GRD). By
default, this tool will look in the project's GRIDS directory.
Grid Dropdown - This drop down sets the grid file that will produce the contours.
Note that this list contains only the grid files stored inside the Grid File Directory
selected above. The files are listed from newest to oldest date created.
Grid Info - This button shows information about the selected grid file. This includes
the title, dimensions, and grid spacing. For a histogram and more detailed statistics
on the grid's Z values, select the "Stats" button.
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Contour Range
This section sets the minimum, maximum, and contour interval for the contours. This
tool will automatically calculate default values, and will apply a rainbow colorbar.
Colors - This button opens the Enhanced Color Interval Definition tool, which allows
for much greater control over the contour colorbar. This tool can apply a preset color
bar, or set individual colors for each interval.

Options Tab

Color Filled Contours - This option uses the colorbar set on the Grid Tab color-fill the
gridded surface. Deselecting this option will turn off the color fill.
Draw Color Scale Bar - This option draws a small color scale showing the color
associated with each contour interval. The adjacent dropdown selects the location of
the scale bar, which can be either on the upper left or upper right side of the map
Draw Contour Lines - This option draws contour lines on the grid. These lines will
start at the "Min" contour range on the Grid Tab and proceed up to the "Max" contour
range using the contour "Interval" value.
Label Contours - This option control whether any contours are labeled. Refer to the
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style tab for labeling options.
Draw Lines In Default Color - By default, Petra draws contours using the colors from
the colorbar. This option instead draws all contour lines using the default color (which
is usually black). To change the default color, select Display>Colors on the menu bar
at the top of the Map Module.
Smooth Contour Lines - This option smooths contour lines. For jagged or triangular
grids, this may force grids to not "honor the data."
Quick Grid Cell Fill - This option will color fill each grid cell with a single color. Color
contour bands are not drawn.
Draw Grid Cell Outlines - This option causes grid lines to be drawn along each grid
row and column. This can be useful for demonstrating the resolution of the grid
relative to the actual data points.

Style Tab
This section provides control over line thickness, line style, and labeling interval.
Contour lines are drawn as either "normal" or "both" state.

Normal Line Width - Select the line width for drawing contour lines in the normal
state.
Normal Line Style - Select the line style for drawing contour lines in the normal state.
Bold Line Width - Select the line width for drawing contour lines in the bold state.
Bold Line Style - Select the line style for drawing contour lines in the bold state.
Bold Every Nth Contour Where N= - Set the interval at which bold contours are drawn.
Label Every Nth Contour Where N= - Set the interval at which contour lines are
labeled.
Label Size (XY Map Units) - The height of the contour labels in XY map units. Set the
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size to zero for the default of 0.1 inches.
Label Distance (XY Map Units) - The distance between contour labels in map XY
units. Set the distance to zero for default value.
17.1.2 Selecting Wells

The Directional Well Module includes two methods for selecting wells for the Profile
View: Line and Wells, and Vertical Section Plane.

Line And Wells
The Directional Well Module’s Line And Wells tool works identically to the Line and
Wells Cross-Section in the Map Module.
1. Zoom in to the wells you are interested in on the Map

2. Click the “Line and Wells” button on the menu bar
3. Click twice on the map to draw the line of projection

4. Click to select the desired wells. The first well you click will be your “Active” well.
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5. Right-click to end and open the Profile View

Vertical Section Plane View
The Directional Well Module’s Vertical Section Plane View tool simplifies setting up a
Profile View with horizontal wells.
1. Zoom in to the wells you are interested in on the Map

2. Click the “Vertical Section Plane View” button on the menu bar
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3. Click on the well you would like to display in the Profile View

4. Petra automatically draws the Profile View parallel to the wellbore and projects the
well you have chosen onto the plane.

Adding Additional Wells to the Profile View
Once the Profile View has been created, you may wish to add or drop wells from it.
In the Map Window, simply right-click on a well:
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In the Profile View, right-click on a well symbol to drop the well:

17.2

Profile View
The Profile View displays a cross section through the area selected on the
Directional Well Module's Map View.
To open the Profile View, use the "Line and Wells" or "Vertical Section" tool on the
Map View or select the

button on the Directional Well Module's toolbar.

Getting Started
Posting Digital Logs
Posting and Picking Formation Tops
Creating and posting Events
Correlation Window
Post gridded surfaces
Jump quickly to 3D Visualization to view directional wells in 3D
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On the top menu bar, the following functions are available:

1. Zoom in / out / off

2. Redraw / Refresh Data
3. Depth Scale Dialog
4. Digital Logs and Tracks Dialog
5. Formation Tops Display Options
6. Draw Order
7. Measure Tool (for measuring apparent dip and distance between two points)
8. 3D Visualization
9. Enable/Disable Offset vs. TVD Mode

Log Values at Cursor
The Directional Well Module has the ability to display the actual value of a specified Digital
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Log at the cursors location on the fly. Before using this feature, there has to be a Digital Log
displayed in either the Side or Bottom tracks. If a Digital Log is available in one of these
tracks, this is activated by simply clicking on a single Log header in any of the tracks.

Measure Tool
The measure tool is used for measuring apparent dip and distance between two points along
the profile plane. After selecting the measure tool you can now click any two points along the
profile view and see the apparent dip and distance between those points automatically
calculate.
*NOTE* Please be aware that these are two points along the plane that has been selected
for projecting the profile into. To get a better sense of what two points in space are being
used for this calculation, watch the cursor on the Map View as you select your points on the
Profile View.
Using the Apparent Dip Line
Under the Tops menu there is an option to either "Place" or "Edit" an Apparent Dip Line. This
is simply an reference line that can be placed along the Profile View at a given Apparent Dip
Angle. This is calculated along the plane like the Measure Tool (see above). The end points
of this line can be "dragged" up and down by Left Clicking and dragging with the mouse. Also
the depth of the line can be adjusted by Shift + Left Click and dragging with the mouse.
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Double clicking one of the end points opens the Edit dialog (also accessible through Tops
menu) which allows you to manually set an angle, depth, and label/line attributes.

(Apparent Dip Line is in Blue)

17.2.1 Depth Scale
The Profile View Depth Scale tool changes both the vertical and horizontal scale on
the Directional Well Module's Profile View. This tool also changes the upper and
lower depth range and adds depth ticks to the active well.
This tool is a more precise alternative to the "Fit Depths To Screen" tool (F4) and the
Auto-Set Depths tool (F5). Both of these tools are available under the Depths menu
on the menu bar at the top of the Profile View window.
To open the Depth Scale tool, select the
button on the toolbar at the top of of the
Profile View window, or select Depths>Depth Scale on the menu bar at the top of the
Profile View Window.

Depth Scale Tab
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Horizontal Scale/Width/Vertical Exaggeration - This dropdown controls how Petra
draws the horizontal axis on the Profile View. Petra can draw the profile in a set
horizontal scale, width, or vertical exaggeration.
Depth Scale/Horizontal Scale/Width/Height - This dropdown controls how Petra draws
the vertical axis on the Profile View. Petra can set this to a depth scale, a set height,
or vertical exaggeration.
Depth Scale Measured In: - This dropdown sets the depth scale on the profile view.
Depths can either be in feet or meters.
Horizontal Scale Measured In: - This entry displays the horizontal scale for the Profile
View.
Width and Height Measured In: - This dropdown sets the units of measurement used
for the Profile View.

Depths Tab
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Upper Depth - This entry sets the upper boundary of the Profile view. These numbers
can reflect TVD or SubSea depths.
Lower Depth - This entry sets the lower boundary of the Profile view. These numbers
can reflect TVD or SubSea depths.

Depth Type
Depths Entered as TVD Depths - This option sets the upper and lower depths of the
profile view as true vertical depths. This will work for relatively flat areas, but will
misrepresent the depths and tops of areas with any topography.
Depths Entered as SubSea Depth (True Structure Section) - This option sets the
upper and lower depths of the profile view as subsea depths. This sets the logs and
tops relative to the reference datum, which more accurately reflects the true position
in depth.

Depth Scale
The Depth Ticks tab displays depth ticks at points along the Active well's wellpath.
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Show Depth Ticks - This option enables or disables the depth ticks on the profile view.
Tick Width (Inches) - This entry sets the width of the depth ticks in inches.
Tick Label Size (Inches) - This entry sets the size of the depth track in inches.

Depth Tick Intervals
Compute Optimum Using Depth Scale - This option attempt to automatically calculate
a reasonable depth tick schedule over the Profile View window.
Use These Settings - This option manually sets the depth ticks and labels for the
profile view.

Depth Scale Drag Handles
The left side of the Profile View has two small drag handles that adjust the depths
visible in the window. Simply click, drag, and release to change the depths. After
changing the depths using the drag handles, press F4 to redraw the window with the
new depth interval.
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17.2.2 Formation Tops
The Tops Display Options Tool controls how the Profile View displays formation tops.

Select Tab
The Select Tab adds and removes tops from the Cross Section Module's display.
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Available Tops List
The available logs list shows the formation tops in the project.
Restrict By Source - This option restricts the tops on the Available Tops list by the
selected source code. Only the tops with the selected source code will appear on the
Available Tops List. The "<All Sources>" option displays all tops from all sources
(unless restricted by the Reorder Tool on the Main Module's FmTops Tab).

Displayed Tops List
The Cross Section Module only displays the tops on the Selected Logs list.
To add a log to the Selected Logs list, select the desired log on the Available Logs list
and left click the ">" button.
To drop a log from the Selected Logs list, select the desired log on the Selected Logs
list and left click the "<" button. To drop all logs from the Selected Logs list, left click
the "<<" button.

Style Tab
The style tab contains options for setting the line style and labeling options for
individual tops. For each top, first highlight the top from the "Display Tops" list.
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Line Color - This dropdown selects the top's color.
Line Width - This dropdown sets the line width for the top. Note that the userselected line widths are set on the Petra Program Options' Font/Graphics Tab.

Misc Tab

Label Tops - For each top, this option uses the label settings set on the Style Tab.
Essentially this option allows top labelling.
Opaque Label Box - This option uses opaque label boxes around the formation top
label. This can be useful for displaying labels over log shading.
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Label Text Size - This entry sets the size of the text in inches.
Label Relation - This entry sets the formation tops label's location. This can either be
located above or below the line.
Apply to All - Press this button to set all tops displayed using the current style
settings.

Markers Tab

Indicate Top With Marker - This option controls how the top displays on the Profile
View. Deselecting this option will remove the top.
Marker Size - This dropdown sets the size of the marker on the formation top.
Top Marker - This dropdown sets the specific shape of the top marker.
Apply to All - This option sets the marker size and shape to all formation tops on the
Displayed Tops list.
17.2.3 Events

"Events" store depth-related information and annotations about directional wells.
This can include casing information, gas kicks or fluid losses, drilling or rig events,
lithological data from cuttings, or sidetrack annotation.
Events are stored in Petra’s Main Module in the Interval Tab in the DirWellEvents
Table. Here, the well events can be edited or deleted.
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There are three different kinds of events: Text boxes, point events, and range
events. Text boxes just contain an entry for text. Point events save information
about a single depth on a directional well. Range events save data about a part of
the directional well between a top and base.

Event Toolbar
The easiest way to create or modify To enable or disable the Event Toolbar, select
Toolbars>Events from the menu bar at the top of the

- This button adds a new Text Box.
- This button opens a Point Event.
- This button adds a Range Event
- This button edits an existing event.
Directional Survey Drop down – Events can be stored against any of the well’s
directional surveys. To view the events for a different survey, select it from the drop
down box.
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Editing Events
To move the location of the text box for an event, shift-click on the box and drag it to
the new location.
To edit the settings for an event, shift-double-click on the box.
To change the depths of a point or range event, turn on the editing mode (Event
Editing Mode button on the icon bar).
Click and drag the depth marker to change the depth of an event.
Alt-click to delete an event.
Click and drag on the text box to move.
17.2.3.1 Text Box Events

Text boxes are the only event type that are not associated with a depth along the
well.
To create a text box event, select the
button on the events toolbar. Next, select
the desired location on the Profile View. After setting the location, the Edit Event tool
will open:

Data Tab

Text Box - This box sets the text that will be displayed in the event.
Date and Time - These two entries set the date and time of the event. By default, this
is set to the time the event is created. It's probably a good idea to change these to
reflect the date and time of the drilling event.
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Display Options Tab

Show Date - This option displays the date (set on the Data Tab) on the text box.
Show Time - This option displays the time (set on the Data Tab) on the text box.
Text Size - This option sets the size of the text on the text box in inches.
17.2.3.2 Point Events

Point events are a special kind of event that reflect a point or depth along the well.
To create a point event, select the
button on the events toolbar. Next, click on the
well at the depth where you would like to place your event. After setting the location,
the Edit Event tool will open:

Data Tab
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Select Survey Definition - Petra can handle multiple sets of directional surveys. This
dropdown sets which set of surveys the point event will be associated with.
Top - This entry sets the depth of the point event.
Text Box - This box sets the text that will be displayed in the event.
Date and Time - These two entries set the date and time of the event. By default, this
is set to the time the event is created. It's probably a good idea to change these to
reflect the date and time of the drilling event.

Display Options Tab
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Show Text Box - This entry enables or disables the point event's text box.
Show Date - This option displays the date (set on the Data Tab) on the point event.
Show Time - This option displays the time (set on the Data Tab) on the point event.
Show MD - This option displays the MD (set on the "Top" entry on the Data Tab) of
the point event.
Text Size - This option sets the size of the text on the point event label in inches.

Line Color - This entry sets the line color of the border around the point event text
box.
Line Width - This entry sets the line color of the border around the point event text
box.
Reset Text Box Location - If the text box is not visible at your current zoom level, click
this button to reset its location.
17.2.3.3 Range Events

Range events are tied to two depths along the well. Range events are tied to two
depths along the well. To create a range event, simply click the icon on the Events
toolbar and click on the well at the depths over which you would like to place your
event. The Edit Event dialog will open:

Data Tab

Select Survey Definition - Petra can handle multiple sets of directional surveys. This
dropdown sets which set of surveys the point event will be associated with.
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Top - This entry sets the upper depth of the range event.
Base - This entry sets the lower depth of the range event.
Text Box - This box sets the text that will be displayed in the event.
View Range Event As - This entry sets the graphical style for the range event.
Markers Only - This option displays only the start and end depth markers for the
range.
Borehole - This option highlights the borehole of the well in the line color selected on
Display Options Tab.
Cylinder - This option draws a cylinder around the borehole with the selected color
and width.
Date and Time - These two entries set the date and time of the event. By default, this
is set to the time the event is created. It's probably a good idea to change these to
reflect the date and time of the drilling event.

Display Options Tab

Show Text Box - This entry enables or disables the text box.
Show Date - This option displays the date (set on the Data Tab) on the text box.
Show Time - This option displays the time (set on the Data Tab) on the text box.
Show MD - This option displays the MD (set on the "Top" entry on the Data Tab) of
the point event.
Text Size - This option sets the size of the text on the text box in inches.
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Line Color - This entry sets the line color of the border around the point event text
box.
Line Width - This entry sets the line color of the border around the point event text
box.
Reset Text Box Location - If the text box is not visible at your current zoom level, click
this button to reset its location.
17.2.4 Correlation Window

The Profile View's Correlate tool correlates specific markers and formation tops
between horizontal and vertical wells. Note that this tool only works on digital logs raster logs will need to be digitized.
To open the correlation window, select Logs>Correlate on the menu bar at the top
of the Profile View, or select F2.

Getting Ready
Some things must be setup in the Profile View before using this tool. :
1) Add two or more wells to the profile view
2) Select an 'Active' Well (by right clicking on well symbol). This is normally your
horizontal well.
3) Select an 'Offset' Well (by right clicking on well symbol). This may be a pilot hole
or any other well in the region.
4) Setup the Digital Logs for these wells through the "Logs and Tracks" Dialog. (This
is somewhat optional as these can be changed within the correlation tool, but it is
easier if it matches what is in the profile view)

Correlation Tool
Here is an example of the Correlate Windows with Gamma Ray curves of both a
vertical and horizontal Well when first opened. You will notice that the track on the
left is for the 'Offset' Well and the right track contains the 'Active' Well. Before
launching I had setup the GR curves with geocolumn shading for these two wells and
all of those attributes were pulled into this window. You can also click on the Logs
to add, remove, and modify attributes of the displayed Logs. At the
tool button
bottom of each track there is a depth indicator. This shows you the MD your cursor
is within each track/log. Also, there are two tabs on the right side, Tops and Logs.
The options in these are similar to similar options in other parts of Petra. The
different parts of this window are explained in detail below.
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Manipulating the Logs
Zooming
You can "zoom" in on certain depths within a well by clicking the Zoom button and
then left click a depth (on either well), and while holding the mouse button down,
drag to another depth and release. If you want to see the entire log(s), click the
Zoom Off button and then single click the desired well.

To invert a well, simply click the Invert button on that well.
Stretch/Squeeze
In order to correlate a horizontal well to a vertical, there is the need to manipulate
the log by stretching and squeezing it. This is easily done in this window. When you
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first enter this dialog, there will be two green dashed lines (top and bottom) of each
well. We will call these scaling points. You can simply left click and drag any of these
around and watch the log react. To add additional points, just double click at the
desired location. Here are some shortcut keys to help with this process along with a
screen shot demonstrating this functionality.
Scale Section of Log (stretch/
squeeze)

Ctrl + Left Click + Drag Up/Down

Slide Log Up/Down

Shift + Left Click + Drag Up/Down

'Slip' Log Within Region

Middle Click + Drag Up/Down

Add Scaling Point to Log

Double Left Click

Delete Scaling Point

Alt + Left Click

Formation Tops
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To display/hide certain tops, just check/uncheck it in the Tops tab. The Line Style/
Width and Color options apply to whatever top you have selected (if it is checked).
Picking Tops

To enter Top Picking Mode, simply select a displayed top from the drop down (shown above)
and hit the green button. You can now left click on either well to add a top pick at that depth
pick or alt + left click an existing pick to remove one. When done picking, simply hit the red
button (next to green button).

*NOTE* Top picks done in the Correlate Window are always MD/TVD Linked Tops. Also, you
can still access all functionality within the profile view while the Correlate Window is open. If
you choose to still pick tops in the profile view you can do so and use the Correlate Window
to help as a reference.
Calculate Apparent Dip
Clicking this button enables a mode where one can calculate the apparent dip between any
points on the two wells. Once in this mode, simply click (or click and drag) a point on each
well; and the apparent dip will be calculated and displayed below the tracks. This calculation
uses the well locations, datums, and the directional survey data (if available) and finds the
XYZ location in 3d space between the two points. Then the apparent dip is calculated from
horizontal.

*NOTE* This Apparent Dip is always shown as positive.
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Reset to Default
Clicking this button defaults all Top and Log settings to match what is being displayed in the
Profile View.

17.2.5 Gridded Surfaces

Petra can draw one or more gridded surfaces on the Directional Well Module's
Profile View. You can create grids in the Map Module or with a simplified tool inside
the Directional Well Module's Map View. The Gridded Surfaces
To post a gridded surface, select Tops>Contour Grid Profiles on the menu bar at the
top of the Profile View.
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Grids Tab

Select Grids For Cross-Section Profiles
This section contains a list of available grid files located in the project's GRIDS
directory.
Choose a grid then click the "Add To List" button to select it for plotting. The grid
name will appear Selected Grids List.Selected Grids
This section displays those grids which have been selected to plot on the cross
section. Single clicking a grid name in this list will show the current attribute settings
in the Grid Attribute section. Double clicking a grid name will show the grid's
statistics. You may remove a single grid from the selection list by using the small '>'
button located below the list box. To clear the selection list to start over, click the
'>>' button.

Grid Attributes
Set each of the grid attributes for a selected grid. First, highlight the grid name in the
"Selected Grids" list by clicking on the grid name. Set the attributes (see below) and
click the "Apply" button. (Note: the Apply button is optional).
Grid Type - The grid type determines how Petra interprets the grid's Z values. A
grid must be identified as either "Subsea (Structure)", "Measured Depth", or
"Datum". Including a datum grid, such as a contour map of the KB, will insure that the
other grids are correctly drawn when switching between log depths and tvdss
depths.
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Color - Choose the line color for drawing the grid profile.
Line Style - Choose from one of the standard line pattern styles.
Line Width - Choose from one of the standard line thickness.
Label - Enter the descriptive title for the grid. The default comes from the grid file
header.

Options Tab

Sample Rate
The sample rate determines how many samples are interpolated from the surface
grid along the length of the cross section. The default value is 100.

Averaging
The averaging factor (N = 1..10) determines the distance around each profile data
point in Method 1. Larger values result in smoother profiles. All grid node values
within a distance of N times the grid spacing will be averaged using an inverse
distance weighting function. A value of 1 will sample only the grid nodes within a
single grid cell distance. A value of 10 allows all grid nodes that are closer than 10
times the grid size to be included in the average. For Method 2, the averaging factor
determines the amount of smoothing applied by a triangular filter function.

Method
Choose one of the two grid sampling methods. Method 1 samples the grid using an
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inverse distance weighting and results in a smoothed profile. Method 2 interpolates
each profile point from the grid cell it is contained in.

Label Text Size
This option sets the size of the labels displayed on the Profile View.

Color Fill Between Grids
This tab adds a color fill between two grids displayed on the Profile View.

To add a color fill, select the "+" button to add a new line. In the left column under
"Grid 1" select the upper grid from the dropdown. In the right column, under "Grid 2"
select the lower grid from the dropdown. Finally, select the desired color from the
third column.

17.2.6 3D Visualization

The Profile View can send the current view to the 3D Visualization Module. The 3D
Visualization Module is automatically adjusted to the same depth ranges and scales
as your Profile View, and any gridded surfaces and tops posted in the Profile View
will also be displayed in the 3D Visualization Module.
To change the 3dViz Module to use the extents and grids on the Profile View, select
the
button on the toolbar at the top of the Profile View.
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To reset the 3dViz Module to use the original extents and grids, select the
on the toolbar at the top of the Profile View.
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button

The Active well in the Profile View will be highlighted and the other displayed wells
will be semi-transparent.
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17.2.7 Displaying Digital Logs Workflow
In the Profile View, there are a number of tracks in which digital logs can be
displayed:

Side Track (on the left side of the window) – 5 sub-tracks for digital log data
Bottom Track – 5 sub-tracks for digital log data
Along wellbores (either vertical or horizontal) – 1 track on each side of each wellbore

To open the Log Display Options Dialog, from the Profile View, click the Digital Logs
and Tracks Dialog button on the icon bar, or in the menu bar, choose Logs > Select
Logs and Tracks:

Log Display Options Dialog
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1 Side Track Preview
2 Grouping, Filtering, and Well Name Display options
3 Wells and Logs
4 Selected Log Statistics
5 Bottom Track Preview
6 Settings for selected digital log
7 Side and Bottom Track Settings
When the Log Display Options dialog opens, it will automatically display all wells
selected in the Profile view and the digital logs loaded into the Petra database for
those wells.
In the top bar (#2 in the image above), you can select various grouping and filtering
options to quickly locate the wells and logs of interest to you:
Group by Well:
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Group by Log:

Apply Filter:
Apply Filter opens the filtering dialog. In this dialog you can create filters to only show
the logs of interest:
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To create a filter:

1. At the bottom of the dialog, enter the condition you would like to filter on, for
example “Log Contains GR”, and press the “Add” button.

2. Multiple conditions can be added, and filtering can be performed on Depths and
Well Names in addition to Log names. Multiple conditions are applied using the
“and” operator.
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3. To view the filtered logs in the main dialog, press “Ok”:

4. To remove the filter, simply uncheck the “Apply Filter” checkbox.
Track Settings
To change the widths of the tracks, use the lower right portion of the dialog. There
are 5 tracks available in the side track and bottom track.
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To activate a track, click its “Active” checkbox. You can also adjust the width (in
inches).
Changes to the number and widths of tracks activated will be shown in the track
previews:

Changing Digital Log Settings
To activate a digital log, click the checkbox next to its row in the table.
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The blue highlight on the row selected indicates that you are working with that log
curve in the settings panel on the right. To change the style and track settings of a
different curve, simply click on its row to move the blue highlight color.
To change the style and track settings of multiple curves at the same time, simply
control-click or shift-click on multiple rows. Settings will apply to all selected wells
when you press “Apply”.

To uncheck all digital logs that have been enabled, press the Clear All button.

Log Curve Settings

In the settings panel on the top right, the following tabs are available. Again, these
settings all apply only to the well or wells highlighted in blue in the well and curve list.

The Scale Tab is primarily used to select the log track and log scale limits. Scaling
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options apply to the highlighted log name in the wells and logs portion of the dialog
(blue highlight).

- Active checkbox: Activates/deactivates the selected log. This has the same
functionality as the checkbox discussed above.
- Label: Change the log’s label.
- Disabled: Check this option to temporarily hide a log trace from the display but
retain its settings.
- Draw Along the Borepath: Draws the log along the borepath of the well.
o Draw on Side of Borepath: Specify which side of the borepath the log should be
drawn upon.
o Borepath Track Width: Set the width, in inches, of the track along the borepath.
- Use Alias Logs: Check this option if you want aliased curves to be plotted
whenever the selected curve is absent.
- Logarithmic Scale: Check this option to plot a log using log 10 value. The left and
right scales should be entered as powers of 10 when using this option and the
scale min/max must be >0.
- Scale: Left/Right scale for selected log curve.
- Side Track / Bot Track drop down: Select whether you would like this curve to
appear in the Side Track or Bottom Track, and if so, in which sub-track.
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The Style Tab defines the appearance of each log trace. Color, line width, line style
and shading options are provided. Color and style options apply to the highlighted log
name in the wells and logs portion of the dialog (blue highlight).

- Shading Method: The display style for a log is controlled by the selected shading
method.
o No Shading: Displays a log using a single color selected from the "Line Color"
palette provided.
o Shade Using Cutoff: Displays the log in 2 colors and allows the log trace to be
shaded based on a user-defined cutoff value. Proceed to the "Cutoff Tab" to set
the cutoff shading options.
o GeoColumn Shading: Shades the selected log trace using values from another log
curve. This option can be used to plot a litho-column type display. Proceed to the
"GeoColumn Tab" to set the GeoColumn shading options.
- Line Style: Choose the line pattern for drawing the log trace.
- Line Width: Choose the line width for drawing the log trace.

The Cutoff Tab provides options relating to how a log is shaded based on a userdefined cutoff value. Two colors are used to plot the log trace - one for values below
the cutoff and another for values above the cutoff. Shading can occur below or above
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the cutoff value.

- Shade:
o Less than Cutoff: Draws the log curve using the two color scheme according to the
cutoff value and shades values less than (below) the cutoff.
o Greater Than Cutoff: Draws the log curve using the two color scheme according to
the cutoff value and shades values greater than (above) the cutoff.
- Cutoff:
o Constant Cutoff: Enter the log value which defines the boundary at which color
change and shading is to occur.
o Statistical Cutoff: Provides a variable cutoff based on the average or mean log
value and standard deviation. The cutoff value is entered as the number of standard
deviations above the mean. The equation used is:
CUTOFF = MEAN + (SD x USERVALUE)

- Shading Color: Choose the color to use when the log trace is less than the cutoff
value. Check the associated color palette to change the color box.
- Curve Line Color: Choose the color to use for the curve line.
- Suppress Curve Outline: Suppresses the curve line
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- Use Discriminator: A discriminator curve is a "flag" curve containing 1's and 0's.
When a discriminator curve is used, the GeoColumn shading will occur only where
the discriminator curve is equal to 1. When this option is selected, the Discrim tab
will appear where the discriminator curve can be selected:

The GeoColumn tab provides options for displaying a curve using "GeoColumn"
shading. The GeoColumn feature shades a curve with multiple colors based on curve
values.

- Shading Direction: Specify which side of the curve should be shaded.
- Log Used for Shading: The values from the curve selected here are used to define
the color "cutoff" ranges. This curve can be the same curve as being shaded or can
be any other curve.
- GeoColumn Base Line Value: Shading occurs from the curve traces back to either
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the track edge or a specified curve value.
- Use Discriminator: A discriminator curve is a "flag" curve containing 1's and 0's.
When a discriminator curve is used, the GeoColumn shading will occur only where
the discriminator curve is equal to 1. When this option is selected, the Discrim tab
will appear where the discriminator curve can be selected:

- Suppress Curve Outline: The curve trace is not drawn. Only the shading will be
drawn.
- Transparent When Background Color: When the shading color matches the screen
background color, shading will not occur.

The Misc tab provides options for configuring the header for each curve in the track.
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Pressing the Apply button will update the “Profile View” with all of the changes you
have made. You may need to move the dialog to the side to see the Profile View. The
changes are not permanent until the OK button is pressed, which closes the dialog.

Advanced Options for Digital Log Curves
Traditionally, when drawing digital logs along a horizontal borepath, the logs may
“loop” back onto themselves when the borepath has a high degree of curvature:

Petra uses advanced functionality to ensure the digital log curve maintains a useful
appearance by drawing a tangent line along the borepath and using that line as the
track edge for the log curve:
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The settings for this advanced functionality can be found in the Track settings
“Advanced” tab.

17.3

Spreadsheet View
The Directional Well Module can view and modify directional survey data. This tool
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can be used to compare multiple directional surveys in a single well, which are
commonly Actual and Proposed directional surveys.
To open the Spreadsheet tool, select the
Well Module.

button on the top of the Directional
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The Directional Module's spreadsheet tool with a single survey (left) and with two surveys (right)

View Survey - This dropdown selects between multiple directional surveys. This
dropdown selects the left set of surveys, and is set to "Actual" by default.
View Survey Right - This dropdown selects the directional survey set to display on
the right.
Show XY's/Show Lat Lon's - These two options enable the XY and LatLon surface
location of each survey point.
Show Vertical Section - This option enables the vertical section column, which is a
horizontal measurement away from the surface location calculated along a compass
azimuth.
Allow Editing of XY Offsets - This option allows the XY offsets in the project to
change.
Dir. Survey - This button opens the directional survey data tool.

17.4

Hot Keys
Download a PDF Version of this Guide
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General
Panning while zoomed

Hold down the Middle Mouse Button
while dragging the mouse

Re-Draw Screen

F5

Refresh Data

Shift + F5

Select All Wells

Ctrl+A

Select Wells by Data Criteria

Ctrl+S

Open Help

F1

Profile View
General
Print

Ctrl+P

Auto-Set Depths to Fit Well

F3

Fit Depths to Screen

F4

Top Picking (once in Picking mode)
Pick FM Top on the well-bore

Left Click on the Well-Bore at desired
MD depth

Pick FM Top above/below the
well-bore

Shift + Left Click at the desired
location

Move FM Top Pick

Left Click and drag to new location

Delete FM Top Pick

Alt + Left Click on the pick to delete

Events (while NOT in edit mode)
Move Event Text Box

Shift + Left Click and Drag
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Shift + Double Left Click on the event

Events (while in edit mode)
Move Event Text Box

Left Click and Drag

Open Event Edit Dialog

Double Left Click on the event

Move Event Depth

Left Click and Drag one of the event
markers

Correlate Window

17.5

Scale Section of Log (stretch/
squeeze)

Ctrl + Left Click + Drag Up/Down

Slide Log Up/Down

Shift + Left Click + Drag Up/Down

'Slip' Log Within Region

Middle Click + Drag Up/Down

Add Scaling Point to Log

Double Left Click

Delete Scaling Point

Alt + Left Click

Planning A Well
Before you plan a well, it is recommended that you load an overlay into the Directional
Well Module’s Map window. From the menu, choose Overlay > Open and select an
overlay that you have saved in your Map module. This will let you easily quality check
the coordinates that you will be entering for surface, landing, and bottom hole
locations.

Using the Zoom functionality, zoom in to the area in which you would like to plan a
well:
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In the Map menu bar, select Plan > Plan A Well

An option dialog box will pop up with the following options:

- Create New Well – adds a new well to the Petra database with a proposed survey.
- Add Borepath to Existing Well – Allows you to add a new directional survey to an
existing well in the Petra database.

© 2014

Directional Well Module

1477

To plan a new well in your database, select Create A New Well and press “Continue”.
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Enter in:

- UWI/API: This can either be UWI/API you will use for licensing the well or any
name for the well
- Symbol: For use on the map display
- Select Survey Definition For Survey: We recommend that you put the proposed
survey into the proposed survey category for clarity. This enables you to add the
actual as-drilled survey into the actual category later on.
- Well Name: Optional
- Well Label: Optional
Press “Continue”.
Plan Locations and Path:
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1. Datum: Enter your datum, typically a GL (Ground Level) or KB (Kelly Bushing).
a. Auto Calc Datum: After you have picked a surface location, Petra can automatically
calculate the datum based on the datum of the closest well.
2. Depth Options: Set the dialog to use either Sub-Sea TVD (elevation) or TVD (depth
from datum).
3. Surface, Landing, and Bottom Hole locations
a. These three groups down the left side of the dialog let you set the location and
depth of each of the three points of the planned well. The radio buttons along the
side (indicated with arrows on the dialog) are used to select which point you are
currently working with.
b. You can also simply type in a value in either XY or Lat Long for these three points,
if you have them on a survey plan.
4. Set Location of Selected
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a. This box is used to set the location of whichever of the three planning points (#3 on
the dialog) you have selected.
i. From Map – Allows you to set the location by clicking on the map
ii. From Well – Allows you to set the location based on another well on your map
iii. Surface – Sets the location to be the same as the Surface location
iv. Landing – Sets the location to be the same as the Landing location
v. Bottom – Sets the Location to be the same as the Bottom location
b. Apply Offset – In addition to being able to set the location based on any of the
above 5 options, you can also apply an offset (for example if you knew you wanted
the surface location of your new well to be a certain distance away from surface
location of a previous well). Please note that all offsets are applied in Grid North,
not True North.
5. Set Depth of Selected
a. Used to set the depth of whichever of the three planning points (#3 on the dialog)
you have selected.
i. Offset from a Single Grid – Allows you to set the depth based on a gridded
surface. Select the surface from the drop-down list below. You can also enter a
depth offset (positive for shallower, and negative for deeper) to set the point above
or below a target.
ii. Between Two Grids – Allows you to set the depth based on two grids. Petra will
place the point halfway between the two gridded surfaces in depth.
b. Press the “Apply” button to apply the changes to your selected planning point.
Press Apply to see your changes in a profile view.
A more detailed workflow sequence example is:
Pick a Surface Location from a map:

1. Make sure the radio button next to “Surface Location” is checked, and click the
“From Map” button:
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2. Petra will show you the map. Click on the surface location for your well. Petra will
automatically place a well symbol at the surface location and populate the dialog
box with the XY or Lat Long of the location.

a. If you would like to apply an offset or a Kick Off Depth, you can make those
changes now in the dialog.
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Create a Landing Location from offsets:

1. Check the “Active” checkbox under Landing Location, make sure the radio button
next to “Landing Location” is checked, and click the “Surface” button to set the
Landing Location from the Surface location of the well:

2. Now apply an offset to that Landing Location of X=0m and Y=400m (0ft and 1200ft
respectively). The map will change to reflect your new landing location directly
north of your surface location.
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3. Apply a depth for your Landing Location by either entering a depth in the “Depth”
box, or by setting an offset to a grid.

Pick a Bottom Location from the map.

1. Make sure the radio button next to “Bottom Location” is checked, and click the
“From Map” button.
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2. Petra will show you the map. Click on the bottom location for your well. Petra will
automatically place a well symbol at the bottom location and populate the dialog
box with the XY or Lat Long of the location.

3. Apply a depth for your Bottom Location by either entering a depth in the “Depth”
box, or by setting an offset to a grid.
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If you simply add a depth point for the Landing Location and another depth point for
the Bottom Location, Petra will plan the well in a straight line between those two
points. If you have significant topographical changes along the well path, you may
wish to sample the well to a surface (or between two surfaces) along the wellbore.
To do this, check the “Use Settings Above To Determine Survey from Landing to
Bottom Hole” checkbox, ensure your settings are correct (sampling to one or two
grids, offset) and press “Apply”.

The difference is shown below.
With two points along the wellbore (Landing Location and Bottom Location):
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Sampling to the Top of Coal Seam surface:

Press “Apply” to add your newly planned well to the Petra database. To make
changes to your well, simply change the desired values in the dialog and press Apply.
When you are satisfied with your planned well, you can press Done to exit the
planning screen.

© 2014

Directional Well Module

1487

Note About Projected View:
When working with a horizontal well with an offset (or offplane) landing location and a
lateral bend, Petra projects the well path onto a straight line drawn between the
surface and bottom hole locations. The difference in the projection of grids and
borehole path may cause an apparent depth issue in the projected view with respect
to the landing location:
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To resolve this apparent discrepancy, you can view your profile “un-projected”, or
along the actual well path. To toggle this setting, press the “Enable/Disable TVD vs
Offset Mode” button on the menu bar:

The un-projected view will show the actual landing location in relation to the surface in
question:
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18

"How To" Workflows

18.1

How to make a contour map
Contour maps represent a three dimensional structure where X, Y, and Z displays
how a quality like depth, isopach thickness, or porosity varies by location.
There are a few different methods for creating a contour map in Petra. Contour maps
can be drawn by hand, by having the computer calculate and contour grids, or by a
combination of hand contours and computer grids. Both methods have their strengths
and weaknesses. Directly drawing contour lines allows more control over the map,
while creating computer-calculated grids is fast and flexible. Using both hand contours
and computer-calculated grids is a good way to harness the strengths of both
methods.

Hand-drawn Contour Lines
Hand-drawn maps are best. An interpreter making a contour map knows the geology
of an area and is able to incorporate this interpretation in a contour map, while a
computer cannot. This method can be time consuming, however, especially with large
data sets.
To create a contour line, first click on the pencil icon on the toolbox on the right side
The mouse cursor will turn to a crosshair. Click the left
of the map module:
mouse button where you want the beginning of the line to start, and continue clicking
the left mouse button for more control points on the line. Clicking the right mouse
button will end the line and bring up the Overlay Line Attributes dialogue box.
The “Line Stream” method can be significantly faster than creating each line node
individually. To enable Line Streaming, select Overlay>Line Stream Mode Active or
select SHIFT + CTRL + S on your keyboard. The normal pencil icon on the toolbar
changes to
. After selecting this button, mouse cursor turns to a crosshair. Click
the left mouse button where you want the beginning of the line to start, and drag the
mouse to draw the line. Note that Petra places line nodes automatically. The line
stream method creates a large number of nodes, which may be time-consuming to
move individually. To end the line, click the right mouse button. Clicking the right
mouse button will end the line and bring up the Overlay Line Attributes dialogue box.
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In addition to selecting line color and width, you can establish a line as a contour line.
Contour lines draw like normal lines, but store and display a contour value. To
designate a line as a contour line, click the “Line Class” dropdown box and select
contour line. Designating a line as a contour line creates the “Contours” tab.

The Contours Tab gives further control over the contour line.
Contour Value – This is where you establish the individual line’s value. In the example
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above, the value of the line is 80.
Label Contour Line – Checking this box will tell Petra to label the contour line. Text
size is chosen immediately below.
Hatchures – This tells Petra to draw hachures on contour lines. Draw contour lines
clockwise for IN and OUT to respectively be inside and outside a closed polygon.
From a line’s start to finish, Petra will draw an IN hachure on the right and an OUT
hachure on the left.

Gridding
In creating a computer-drawn contour map, Petra first extrapolates data between
data points into a grid. Petra then draws a set of contour lines from this grid. The
process of creating computer-drawn contour lines is generally faster than drawing
contours by hand. Computer-created grids can also be used for more advanced
calculations, such as volumetric and isopach summations. However, purely computercreated grids do not incorporate any form of geological experience or interpretation.

Creating a grid
The first step of creating a set of computer-drawn contour lines is to create a grid. A
grid contains the mathematical extrapolation of your data points over an area. Grids
can be calculated on any combination of the following data types:
zone data items (such as fm tops and reservoir data)
repeat tops from horizontal and deviated wells
contour lines and faults displayed on the map module
control points loaded into Petra’s memory or from an external file
interval data
To create a grid, in the map module either go to Contours>Create Grid, or click on
. This brings up the create Contour Grid box.
the “Create a Grid” icon:

Selecting Data
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First, select the type(s) of data you want to grid under the “Zone Data To Grid.”
Zone Data - Most grids will be on zone data from each well, such as reservoir
thickness or formation tops. In the example above, the net pay thickness for the 2nd
Wall Creek reservoir is being gridded. This value is stored under the “2WALLCREEK”
zone under the “NET” data item. Petra automatically creates both a grid title and grid
file name based on this zone data, though these names can be changed.
In deviated and horizontal wells, a data point (such as a formation top) can be at a
distance away from the surface location. Selecting the “Calc XY for Dev Wells At
Top:” button will calculate the correct XY location along the wellbore for the data point
at the selected formation top. This feature needs survey data to be loaded into
deviated wells.
Repeat Tops – Petra can store repeated tops from horizontal and deviated wells in a
special format available on the Repeats Tab on the Main Module. To use repeat tops
while gridding, select the Tops Tab on the Create Contour Grid dialogue box.
Contour lines – Contour lines are one of the most powerful ways to directly modify a
grid. This option tells Petra to use all displayed contour lines as additional data points
in the gridding process. Hand drawing a contour line can be useful for making a more
realistic grid. Petra will use all contour lines from all displayed layers, so be sure to
turn off the display of irrelevant contour lines. For a more detailed discussion of
contour lines, see “Hybrid Method” below.
Fault Polygons – This tells Petra to use lines and polygons designated as faults in the
gridding process. Petra will use all faults from all displayed layers, so be sure to turn
off layers containing irrelevant faults.
Control Points – Control points are XYZ data that are not tied to wellbores. This is
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often seismic data.
Interval Data – Interval data can be particularly useful for storing data outside of
Petra’s normal zone/data item database – particularly for gridding petrophysical data
along deviated and horizontal wells. To grid with interval data, select the Interval Tab
on the Create Contour Grid dialogue box.

After you’ve selected the data type, click on the “Well Dist…” button. This tells you
statistical information on distances between wells. This information on well spacing is
useful in determining the grid size.

Generally, it’s best to make your grid size ½ the average distance between nearest
neighbors. It’s worth noting that this tool will calculate distance statistics between all
wells displayed on a map without discerning if they have data or not. In other words,
if you have a large number of closely spaced wells but only a few of those wells have
data, this well distribution box will give you an average distance that is too small.
When making a grid, it is generally best to select only the wells that have the right
data and exclude wells with null values. In the example above, average distance is
806, so a grid size of 400 xy units is appropriate.

Selecting a Grid Size and Surface Style
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The next step is to select grid size and surface style in the Method Tab. Grid size
simply governs the spacing of grid points, which can influence the “smoothness” of a
grid. Small grid spacing generally better honor data points but are prone to
“bullseyes.” Large spaced grids with fewer points are smoother but usually don’t
honor the data as well.
Though there are 4 ways to select a grid size, the best way for a new grid is to use ½
the average well spacing (see above). In the above example, average well spacing is
860’, so grid size is 400’ by 400’.
Next, select a Surface Style. The surface style determines how Petra interpolates the
data to create a “surface” for contouring. For most data, “Highly Connected
Features” works best and handles faults well. For isopach maps, select “Adjust Zero
Contour for Isopach Surface.” This option moves the zero line midway between a
zero point and the closest non-zero data points. In effect, this option creates a grid
with the more reasonable assumption that the interval pinches out before the wellbore
penetration.

Other Advanced Features
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One of the best options is “Adjust Grid To Better Fit Control Points”, which adds an
additional processing step to force rectangular grids to “honor the data” better. It’s
worth noting that this feature still depends on a reasonable grid size. More
specifically, a large grid size will break this feature.

There are many more options for manipulating the grid file available on the other tabs,
but ultimately the best way to do that is to use contour lines. See “Hybrid Method”
below.

Contouring a Grid
Now that the data has been extrapolated into a grid, Petra can draw a set of contours
on that grid surface.
To contour a grid, in the map module either go to Contours>Display Contours, or
click on the “Contour a Grid” icon:

. This brings up the create Contour Grid box.
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First, select the grid you wish to display. The grid’s title and a color range will be
selected automatically. At the bottom of the Contour Range section, you have the
option of selecting “Normal colors” and “Enhanced Colors.” Both of these options
select colors for display, but Normal Colors is a little simpler for new users. Select
“Normal Colors”, and select the “Colors” button.

Here, set the minimum and maximum values for the contours in the “MIN” and “MAX”
boxes. The “Interval” sets the contour interval between colors. Note that normal
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colors can have up to 47 different intervals, while “Enhanced” colors can have many
more intervals. The default color scheme is a rainbow from purple to red, but Petra
comes with several other color schemes available through the “Default” button on the
right side of the screen. You can also set your own color scheme by clicking on each
individual interval and then clicking on a color from the palette for that interval. Click
OK when the color bar is set, and OK again to contour the grid. The contour map
should now show up on your map.

Hybrid Method
A hybrid method of contouring takes advantage of a computer’s speed and a human
interpreter’s knowledge. It is fairly easy to modify a computer-calculated grid with
overlay contour lines, as well as convert a grid’s contours to overlay contour lines.
This allows for iterative improvement of a contour map.
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Modifying a Grid with Contour Lines
Using hand-drawn overlay contour lines to modify a computer-calculated grid is a
great way to add a more geologic interpretation to a contour map.
In the map below, a net pay map is discontinuous at the thickest part of the reservoir,
and is only limited to the area immediately around the wells. A better interpretation of
this data would smooth the contours and extend the northwest-southeast trend of the
map.

The first step is to draw contour lines, as discussed above. Petra will incorporate
these lines during regridding, and will modify the grid to fit them. This set of contour
lines can be comprehensive (as shown below) or can be only a couple of short lines
over a problem area. Make sure that these lines are designated as contour lines and
have the correct contour value.
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Once the contour lines are drawn, the next step is to recreate the grid using the
contour lines. In the map module either go to Contours>Create Grid, or click on the
“Create a Grid” icon:
. This brings up the create Contour Grid box. Just like
calculating a regular grid, put in the zone data to be contoured. This time, also add
“Use Overlay Contour Lines.” Petra will use these drawn overlay contour lines.
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The newly contoured grid now reflects the drawn contour lines to have a more realistic
geological interpretation, as shown below. Hand-drawn overlay contour lines are easy
to change, so this grid can be iteratively modified to create better and better maps.
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Creating Contour Lines from a Grid
You can capture gridded contours to contour lines in an overlay layer. Once these
lines are overlay contour lines, you can edit them just like any other line. This can be
useful for letting Petra build a quick first pass at contour lines, and then using your
skills as an interpreter to modify them into a more reasonable geological
interpretation. Depending on the complexity of your contours, this can be very labor
and time-intensive. For most contour maps, it’s probably faster and better to handdraw overlay contour lines from scratch and use them to modify your grid as
discussed above.
After creating a grid file, open the “Contour a Grid” dialogue box. Go to the Options
Tab, and turn on “Draw Contour Lines” and “Draw Lines in Default Color Only.” This
will tell Petra to draw black contour lines.
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Next, go to the Advanced Tab. Select “Capture Contours Directly Into Layer”, and
then select the Overlay layer you want to contain these contours. The “R” button
allows you to rename the layer. In this example, the overlay layer has been renamed
to “CONTOURS.”

This draws the gridded contours (in colors) and stores the computer-generated
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contour lines as overlay contour lines in the designated layer.

Turn off the grid, by either going to Contours>Hide Contours, or by clicking on the
“Hide a Grid” icon:
.
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The grid is off, and now you are left with a set of fully editable contour lines stored in
the designated layer. In the example above, one contour line has been selected and
all the line points are highlighted in blue.

Notice that the computer-generated contour lines have a lot of points, and editing
them one-by-one will take a long time. It’s generally easier to reduce the number of
points on the line by using the “Simplify” tool on the tool box. It’s icon looks like this:
. When you’ve completed modifying these contour lines, you can use them again in
recalculating your grid (see “Modifying a Grid with Contour Lines” above).

18.2

How to Display Digital Logs

Introduction
Digital logs record wellbore information as it changes with depth. Unlike paper logs,
however, digital logs store the actual log values in a form that is directly readable by a
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computer. Though digital logs typically consist of wireline information, they can also
include core data, petrophysical model outputs, or anything that has a numerical value
associated with a depth. Digital logs are easily stored in Petra’s database, can be
calibrated and used in calculations, and look great in a cross section.
This guide uses a standard set of logs to illustrate a wide variety of Petra’s display
styles and features in the cross section module. This guide covers:
SP – Centering & simple colored lines
Resistivity – Logarithmic scaling & cutoff shading
Neutron and Density Porosity – crossover shading
Gamma Ray – GeoColumn shading
Mudlog – Lith summation

Adding a New Digital Curve to a Cross Section
All digital log curves are added and modified in the Log Display Options window. To
open this window, in the cross-section module click the Log Display Options button:
, or go to Logs>Scales and Display Options… on the menu bar.

A blank Log Display Options window

The “Available Logs” list on the left side of the screen gives a list of all digital logs that
can be added to a cross section. This list can be filtered to include the digital logs
from all wells in the project, or just the wells currently selected in the Cross Section
Module. To add a log, highlight the name in the "Available Logs" list and click the add
button (">"). This moves the log over to the “Selected Logs” list. To remove a log,
highlight the log name in the “Selected Logs” list and click the remove button ("<").
Once a log is added to the “Selected Logs” list and is highlighted, the track and
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display options for that log can be set on the various tab screens.

SP – Simple Line and Color
On the Scale Tab of the Log Display Options window, highlight the SP curve on the
"Available Logs" list and click the add button (">"). Once the log name is on the
“Selected Logs” list, click the curve to highlight it. In this example, the SP curve has
been added to “Selected Logs” list.
The next step is to select a depth track, which sets the position of the curve relative to
the depth track. Select the depth track for each log by clicking the track up and down
arrows (highlighted in red). SP curves usually go to the left of the depth track, so in
this example the SP curve goes into Track 1. Next, set the left and right scale
(outlined in blue). In this example, the left side of the track will be -40 and the right is
-10.
Click “Use Alias Logs” if your project has digital log aliasing.

Setting the track (Red) and scales (Blue) for a new SP Curve

Go to the Style Tag. SP curves show relative deflection, so select “Center in
Track” (highlighted in red). This puts the curve in the center of the track using the
scaling set by the left and right scale. In this example, the left and right scale are
50Mv apart, so the SP curve will be centered with 25 mV on either side. This is great
for SP curves, but will cause other logs to plot incorrectly.
Here, you can also select color, style, and thickness of the curve’s line. To set line
color, click the “Line Color” box and select a color. To change line style (dashed or
solid) or the width, click the appropriate dropdown box. In this example, the SP curve
is red with a “wide” line width.
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The "Center Log In Track" option only uses the log scales to set the relative amplitude of the curve. This can be useful
for SP curves, but is misleading for almost everything else.

Finally, set up the log track under the Tracks Tab. Hidden tracks don’t show a
horizontal or vertical grid and are denoted by the symbol to the left. Double clicking
each track name under the Track Definitions box toggles the depth track on and off.
Click inside the “Width” box to set each track’s width. In this example, the track is 2
inches wide.
Next, set the number of vertical divisions for the track as well as how often these lines
will be bold. The track has 10 divisions, and every 5th line will be bold. In other
words, the track has 10 vertical scale lines with a bold one in the middle. Since the
SP scale is set to represent 50 mV, each vertical line represents 5 mV of SP
deflection. After everything is set, click OK at the bottom of the screen to save the
settings and display the cross section.

Setting the vertical scale lines for the first track

Notice that the log curve header for the SP curve reads “SP(CTR).” This signifies
that the SP curve is centered inside the track. The CTR suffix reminds the reader that
the scales only show relative, rather than absolute, changes. Consequently, the curve
scales on the header only show the relative scale of deflection.
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The completed SP curve in the first track

Resistivity Curve - Cutoff-based Filling & Log 10 Scales
Filling in a log based on a cutoff criteria is useful for showing when a curve passes a
critical threshold. Since resistivity below a certain threshold indicates a wet reservoir,
it’s useful to highlight the curve when it’s above a certain cutoff line. In this example,
resistivity will be highlighted above 10 ohmm.
When curves have a large range of values, linear scales tend to show the changes at
one magnitude at the expense of displaying changes at another magnitude. Since
resistivity curves can cover two or three orders of magnitude, this example will also
show how to display these large ranges on a logarithmic scale.
First, add the resistivity curve to the “Selected Logs” list. In this example, it’s named
“ILD.” Once it’s on the list, click the curve in the “Selected Logs” list to highlight it and
select the track number. Resistivity curves are usually to the immediate right of the
depth track, so set the track to 2. Since these values can vary so greatly, it’s useful
to show resistivity curves on a logarithmic scale. Set the left and right scales and
check the “Logarithmic Scale” box (highlighted in red) below the scale settings. In this
example, the scales are set from 0.2 to 200, Click “Use Alias Logs” if your project
uses digital log aliasing.
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Adding the deep resistivity curve, and setting it to use logarithmic scaling

Go to the Style Tab. You can set the line style and width here, but for this example
the resistivity curve is left as a solid line with normal width. Click on “Shade Using
Cutoff” under the Shading Method box. This creates and immediately opens the
Cutoff Tab.

Adding a cutoff-based shading

Under the Cutoff Tab, you can set the specific parameters of how the curve will be
shaded. In this example, the resistivity curve will be shaded whenever resistivity is
above 10 ohmm. This helps to quickly distinguish productive intervals from wet
intervals. Click on “Greater Than Cutoff” and set the cutoff value, which in this
example is 10.
The curve line and curve shading colors are independent and are set by clicking in
each color box. In this example, the curve line is black, and the shading underneath
that curve will be blue.
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Setting the cutoff, line color, and shading. Where the ILD curve is above 10, it will have blue shading.

Go to the Tracks Tab. Turn on and set up the track by double clicking the symbol
next to Track 2 under Track Definitions. Also establish the width of the track. In the
example below, the width is 2 inches.
Normally the number of divisions sets the number of vertical scale lines in the track.
When drawing a logarithmic log, however, the number of divisions needs to be the
same as the number of orders of magnitude. In this example, the plot needs to
contain 3 divisions ( 2, 20, 200). To draw the logarithmic scale between the divisions,
click the “Log10” button (highlighted in red). Finally, set the Log 10 Offset (highlighted
in blue). The Log 10 Offset scales the logs correctly inside the track. Logarithmic
scales from 0.1 to 100 use a Log10 Offset of 1, and scales from 0.2 to 200 use an
offset of 2. After everything is set, hit OK at the bottom of the screen to draw the
cross section.

Turning on track 2. Since the resistivity curve uses logarithmic scales, the "Log10" option is on. Since the scale is
from 0.2 to 200, the "Log10 Offset" option is set to 2

Logarithmic scales require the left and right track scales, the divisions, and the Log10
offset to all agree. With the number of settings, these scales can be tricky and it is
not immediately obvious when something is wrong. Even if you don’t plan on using
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cutoff shading for interpretation or presentations, it’s usually a good idea to use it in
the beginning as an easy way to check the scaling and display of logarithmic logs. If
the cutoff shading starts at the correct division on the plot, everything is set up
properly. If not, then the divisions, scaling, or Log10 offset need to be adjusted. In
the example below, the shading starts at 10 ohmm, so the settings are correct.

The completed ILD curve in the second track

Neutron and Density Curves - Crossover Shading
Crossover shading is useful for coloring the space between two log curves. In some
reservoirs, the “gas effect” on porosity logs causes neutron porosity to read too tight
and density porosity to calculate too porous. Shading the area between the two
porosity logs is useful for discerning the total footage of crossover, as well as the
relative magnitude.
In this example, the neutron porosity and density porosity are named NPHI and DPHI,
respectively. Add the two curves to the “Selected Logs” list and put them into Track 3
to the right of the resistivity curve. Remember that Petra handles each log
independently, so you’ll have to set the track for each well. Set each log’s scale, as
well. In this example, both the left and right track edges are set to 0.3 and 0 to cover
30% to 0% porosity.
Percentages can be stored as both 0-100 and 0-1. Be sure to set the scales here
according to your log’s scaling convention.
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Click “Use Alias Logs” if your project has digital log aliasing.

Adding the NPHI and DPHI curves

Next, go to the Style Tab. Since Petra handles each curve individually, we’ll look at
the Style tab for the neutron and density porosity logs one at a time. First, click the
neutron porosity log in the Selected Logs window. In this example, the neutron
porosity log’s line color is set to red in order to distinguish it from the density porosity.

Setting the NPHI curve to use a red line color

Next, click on the density porosity log on the Selected Logs window. Hole washouts
cause the density tool to read anomalously low density, which results in high
calculated porosity values reading well above 30%. To clip these bad values, under
the “Misc Plotting Style” box, select “Clip at Track Edges” (highlighted in red).
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Trimming bad density porosity values with the "Clip At Track Edges" option

Next, go to the Tracks Tab. Turn on Track 3 by double clicking the symbol under
Track Definitions and set the width. In this example, the width is 2 inches.
Set the
divisions to show a useful number of vertical scale lines. In this example, there are 30
divisions with 3 bold lines.
Track settings are independent of logs. Since both the neutron and density logs are in
the same track, these changes just need to be made once.

Setting the divisions for the NPHI and DPHI log track

To set up crossover shading between the neutron and density porosity curves, go to
the Cross Over Tab. Click the button reading “Set Color Shading Btwn Curves…”
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Setting up Color Shading

This brings up the “Shade Between Logs” window. You can also get to this window
anytime through Logs>Shade Crossover (Btwn Log Curves)… on the menu bar at the
top of the Cross Section Module.
To fill in the space between two logs, first select the two curves for crossover shading
in the Curve 1 and Curve 2 dropdown boxes. In this example, Curve 1 and 2 are NPHI
and DPHI, respectively. Next, select the proper shading method. In this case, the
area where neutron porosity reads to the RIGHT of density porosity should be
shaded. Click “+Add” to bring the curves to the “Shaded Curve Pairs” list on the far
left side of the screen and hit the OK button on the bottom of the screen. If you make
changes be sure to click “Replace” to update a specific log pair.
Crossover shading does not require the two curves to be at the same scale.
Crossover shading simply fills in the area between the two curves as drawn on the
track.

Setting the crossover shading
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The two porosity curves should now appear on the cross section. The area between
the two porosity curves is shaded red. Notice that the washouts on the density curve
are clipped at the edge of the track.

The DPHI and NPHI curves now have shading to illustrate the gas crossover effect

Gamma Ray - GeoColumn Shading
GeoColumn shading colors the area between a curve and the track edge with variable
color based on log curve values. The color shading under the curve can either be
from the same curve or from an entirely different log. Shading a gamma ray log with
the same gamma ray values better displays the finer variations between sandy and
shaly sections.
First, add the curve to the selected logs list, put it in the appropriate track, and set the
scales. In this example, the GR curve will go in track 1 with the scales set from 0 to
200.
GeoColumn shading can cover up a fair amount of the track, so it’s a good idea to use
the “Up” arrow (highlighted in red) to move the GeoColumn curve to the top of the list.
When Petra draws multiple things in the same space, items at the top of the list are
drawn first - and consequently underneath – the rest of the items on the list. In this
case, the SP curve and the GeoColumn shaded GR curve will be in the same track.
Plotting GR first will prevent the SP curve from being covered up. Click “Use Alias
Logs” if your project has digital log aliasing.
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Adding the GR curve, and moving it to the top of the Selected Logs List (Red)

Next, go to the Style Tab. Under the Shading Method box, select “GeoGolumn
Shading” (highlighted in red). This creates a new tab for GeoColumn shading
(highlighted in blue).

Turning on GeoColumn shading for the GR curve

Go to the GeoColumn tab. First, select the log used for shading from the dropdown
menu (highlighted in red). This is the curve that determines the color fill underneath
the GR log. In this example, the gamma ray curve will have shading that reflects the
same gamma ray values. Varying the color underneath the GR curve will better show
small variations in sand and shale content. As mentioned above, it’s also possible to
shade a curve using a different log – for instance, it might be useful to shade the GR
curve with PE values to show differences in lithology.
The next step is to set the color scheme for the shading underneath the curve. Petra
has a default rainbow color scheme, but a different color scheme will represent the
data better. Click the Colors button (highlighted in blue).
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The geocolumn shading will use the GR curve for the coloring underneath the curve

Set the minimum and maximum values for the colorbar in the “MIN” and “MAX” boxes,
with the interval between the bars set at “INTERVAL.” Press the “Apply” button to
make the changes to the definition. In this example, the colorbar scale is set to a MIN
of 0 and MAX of 200, with an interval of 10.
Next, set the color scale. In this example, the difference between high and low
gamma reflects sand content. It’s useful to represent this variation with a color bar
showing sand as yellow and shale as black. To set the color bar with a yellow to
black scale, in the color palette double click on the upper-left color box (highlighted in
red) and set the color to yellow. Double click the lower right color box (highlighted in
red) and set the color to black. These two boxes set the colors for the upper and
lower values of the colorbar. Next, click “Interp…” (highlighted in blue) to interpolate
between these two colors and fill the colorbar.

The Interp button (blue) interpolates colors between the upper left and lower right corners (Red) of the color palette

© 2014

"How To" Workflows

1519

The colorbar now scales from 0 as a pale yellow to 200 as black, which approximates
the difference between a low gamma ray count for a sand and a high count for a hot
shale. Click OK to accept the colorbar settings.

A good color scheme for highlighting sand-shale differences in a gamma ray curve

Once the colorbar is set, the GeoColumn Tab should reflect the changes. There is no
need to change any settings under the Tracks Tab since the settings will be the same
as those established with the SP curve. Click OK to finish and draw the log.

A completed GeoColumn Tab

The GeoColumn shading now shows subtle variations in gamma ray character. Notice
how it is plotted below the SP curve.
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The GR curve with GeoColumn shading that varies based on the value of the GR curve

Mudlogs - Lith Summation
Lith summaries are useful for displaying cumulative data. Most often, this is lithology
percentages measured from mudlog samples. If a sample has 70% shale and 30%
sandstone, it’s generally more useful to represent these two numbers as a cumulative
plot adding up to 100 instead of two separate curves at 30 and 70.
This same technique can be used to represent any combined values that represent a
percentage of a whole. This includes flow data from production logs, mineralogical
breakdowns from spectral gamma ray logs, or fluid-filled porosities from MRI logs.
In this example, mudlog sand and shale percentages are recorded as “%_Shale” and
“%_Sand” logs. To create a LithSum, place the logs into a track and set the scale. In
this example, the sand and shale percentages are set to track 4, which is to the right
of the porosity logs. Additionally, the left and right scales of are set to 100 and 0%.
Click “Use Alias Logs” if your project has digital log aliasing.
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Adding sand and shale percentage curves. Note that both are in the 4th track.

In this example, the sand percentage will be on the far right. It’s easiest to fill the first
curve in with cutoff shading. In this example, the first curve on the right is the “%
_Sand” curve. Click on the curve to highlight it, and select the “Shade Using Cutoff”
option. This creates and brings up the Cutoff Tab.

Turning on Cutoff shading for the %_Sand curve

Shading the first curve of a LithSum set is very similar to setting the shading on the
resistivity curve discussed above. In this example, the shading is set to yellow
whenever the curve is greater than 0. This will fill in all the area covered by the
sandstone percentage. It’s also possible to add a sandstone pattern to the fill by
using the scroll windows next to the pattern box (highlighted in red). The left set of up
and down arrows changes the pattern, while the right set of arrows changes the
scaling or “density” of the pattern.
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Adding a sandy color and pattern for the %_Sand curve

Next, set up and turn on the track by double-clicking the symbol to the left of the
name in the “Track Definitions” box. The mudlog in the example is set to track 4, and
is 2 inches wide.

Turning on the 4th track, and setting the divisions to reflect 10% increments

If we click “OK” and plot now, the sand percentage is filled in but the shale
percentage is displayed as a regular log. In other words, 70% shale content is
displayed as 70 on the scale bar (highlighted in red in the example below). This is
misleading since it suggests 30% sand and 40% shale instead of the two parts adding
up to 100%. The shale fraction and the sand fraction need to be summed in order to
accurately reflect the data.
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Displaying the %_Sand and %_Shale curves as regular curves without LithSum.

To set up Lith Sum, go back to the Log Display Options screen. Select one of the
curves to be added together in a track and go to the Lith Sum tab.
While in the Lith Sum Tab, select the logs from the “Available Curves in this Track”
window, and click the “>” to add them to the “Sum Curves in Track in the Following
Order” window. In this example, the sand and shale percentages are moved over into
the “Sum Curves…” window
Next, use the up and down arrows to set the curves in the order they should be
summed. The order should be the same as the order the curves appear on the scale
from low to high. In this example, “%_Sand” is on the low end of the scale from 0100, so it should go first. This will sum the two logs together to reflect a cumulative
value.
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Setting up the LithSum in the 4th track.

The last step is to shade between the shale and sand lines. Go to the Cross Over
Tab and select “Set Color Shading Btwn Curves…”

Setting up shading between the %_Sand and %_Shale curves

Select the two curves for crossover shading in the dropdown boxes for Curve 1 and
Curve 2. In this example “%_Sand” is curve 1, and “%_Shale” is curve 2.
Next, select the proper shading method. In this case, the area where “Sand_%”
reads to the RIGHT (below) of “Shale_%” should be selected.
Finally, select a color and a pattern. In this example the area between the sand and
shale percentages should reflect shale, so grey with a standard shale pattern is
selected. Click “+Add” to bring the curves to the “Shaded Curve Pairs” list on the far
left side of the screen and hit the OK button on the bottom of the screen. Click OK
again on the Log Display Options window to keep your changes and draw the cross
section.
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Setting the crossover shading

Mudlog data is now displayed on the cross-section in a meaningful way. At a glance,
it’s easy to determine the relative percentages of shale and sand relative to the
openhole logs.

The completed Lith Sum shading for the sand and shale percentage curves

18.3

How to Alias Digital Logs
Different naming conventions between wireline companies and tools mean that one
type of digital log curve can have a variety of different names. As an example, within
the same project a gamma ray curve can be named GR, GRD, GRN, GRR, GRS,
GAMMA, and so on.

Generally, we want Petra to treat all these curves as the same. Rearranging a
dozen log curve names for display on a cross section can be tedious, and performing
a calculation with multiple logs with different names can be almost impossible.
Digital log aliasing is a great way to get around these naming problems by
establishing a list of curve names that are equivalent. In other words, if the curve
name isn't present, Petra will look down the list to find another curve name as a
substitute.
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To establish digital log aliasing, in the main module under the Logs Tab, click the
“Aliases…” button (highlighted in red in the example below). Alternatively, in the main
module drop-down menu, go to Logs>Define Aliases…

This brings up the Define Log Curve Aliases box. First, click the drop down box next
to “Chose Log to be Aliased” and select the digital log curve name that will store the
aliasing. In the example below, the GR log will store the alias list for all gamma ray
curves. Since Petra will always start at this curve name, the selected name should
be your top choice for the curve in question.

Next, select other curves to add to the list, and hit the “>” arrow to bring them over.
You can reorder the list by using the up and down arrow keys. Since Petra goes
down this list from top to bottom, the order here should reflect the relative priority or
quality of the logs with the best logs at the top.

When you've completed the aliasing, click the “Store Aliases” button to save the
changes to the database. Click “Done” to leave the aliasing screen and return to the
Main Module. If you click “Done” before storing the aliases, Petra will not save your
alias list.
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As a final note, the Society of Petrophysicists and Well Log Analysts has an excellent
searchable curve name dictionary. This can be very useful in deciphering unknown
digital log and curve names:
http://www.spwla.org/cgi-bin/mnemonics_data_search.cgi

18.4

How to use Raster Logs
Introduction

Raster logs are scanned copies of paper logs saved as image files. In order to plot
the correct part of the picture at the right depth on a cross section, Petra requires
computer-recognizable depths to be assigned to depths printed on the original log.
This process is called depth calibration. In the example below, a scanned resistivity
log is depth calibrated (shown in red lines) at 2000' and 3000' MD.
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For details on calibrating a raster log, see Raster Image Calibration

This guide assumes you're starting with a set of raster logs already scanned and
depth registered, which is typical of commercial data vendors. For more information
on calibrating your own logs from scanned images, see here.

Group Names

Raster images are assigned "group names", which typically are used to describe and
group one type of log curve. In the example below, the "Resistivity" group
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(highlighted in red) contains resistivity curves and a correlation gamma ray curve.

Double-clicking on the raster group name brings up the actual image. In the
example, double-clicking the "Resistivity" group name brings up the resistivity log
assigned to that group. Notice the red depth calibration line starting at 5400' MD.
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Displaying Raster Logs on a Cross-Section

To display a set of raster logs, in the cross section module first go to
RasterLogs>Log Images Display Options.
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This brings up the "Select Log Images to Display" box. To display a raster image on
the cross section, you need to select the groups for display and then place them
inside tracks.
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To select a group for display, first select the raster group and click the ">" button
(highlighted in red in the example above). This brings the group name into the
"Image Groups to Display" window on the bottom of the screen.

In general, it's best to display your highest resolution raster logs when you have a
choice. When placed on cross section, Petra scales all logs to same size.
Squeezing a 5" raster log to fit a 1" space retains much more detail than stretching a
1" log to fit a 5" space.

Next, click on the group name in the "Image Groups to Display" box, and select a
track with the "Log Track #" box (highlighted in blue in the example above). This
track number sets the raster log's position relative to each well's depth track. For
reference, track locations are given on the far right side of the box. Track 1 is
immediately to the left of the depth track, while track 2 is to the right of the depth
track. The widths of these tracks can be modified by clicking on the width and typing
the desired number. In the example above, the "Resistivity" group is in track 1, and
the Density/Neutron group is in track 2. These tracks have been modified to be 3
inches wide.

While still in the "Select Log Images to Display" box, click on the General Tab.
There are a few options that can tweak the appearance of your cross section.
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In this case, we can elect to plot the scale header at the top of the raster log. Scale
headers are set during depth registration. Commercial vendors rarely set up a
Petra-recognizable scale header, so you'll likely have to establish this yourself – for
more information on this and other depth calibration, see here.

Additionally, track grids are useful for showing digital data, but get in the way of
raster data. Click "hide track grids that contain raster images." Click OK.

Following the example, the resistivity log is plotted to the left of the depth track, and
the porosity logs are plotted to the right.
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Dealing with Runaway Raster Group Names

In a simple case with only a few consistently-named raster groups, placing rasters
inside a cross section is fairly straightforward. In larger projects, however, there are
some significant practical hurdles to using raster logs.

One of the biggest challenges to working with raster images is the inconsistency of
group names assigned by commercial sources. This inconsistency means that even
a relatively small Petra project can contain hundreds of raster group names. For
instance, "Comp Resistivity Neutron Density 2.5IN" and "Comp Neutron Density CAL
2.5" are almost certainly the same type of log, but they have two different group
names. Additionally, multiple logging runs for the same well can put different depth
intervals in different group names. The quality of the scanned images can vary as
well, where the same group name in different wells can be of very different quality.
With hundreds of names, multiple runs, and wildly differing quality of scans, selecting
a standard set of raster logs suitable for all cross sections in a project can be very
difficult.
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Petra has two major ways of dealing with this problem: aliasing and individual raster
templates.

Aliasing
Much like aliasing of digital logs or tops, aliasing of raster groups establishes a list of
raster group names that are equivalent. In the event that the selected raster group
is not found, Petra moves down a list of other raster groups.

Aliasing is fairly quick and easy, but a single master alias list might not provide the
best results for every well for the reasons outlined above. For example, in one well
group A is the highest quality log. In another well, log group B is the highest quality
log. A single aliasing list won't be able to make this distinction between the two
wells, and will simply plot the first log on the aliasing list regardless of quality.

To set up an aliasing list, in the Rasters Tab in the Main Module, click on "Group
Maintenance" on the bottom of the screen (highlighted in red).

This brings up the Log Image Group Maintenance box. Go to the Aliases Tab.
Select the raster group you want to alias. This should be your best single log group
or a group with a large number of images. Next, click the checkbox for "Edit Aliases
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For This Group." This enables you to click on and add other groups to this alias list.
It's possible to rearrange groups inside this list using the blue up and down arrows
on the right side of the screen. Once completed, click "Save." In the example
below, the "Resistivity" group is aliased with "Resistivity_2in" and "Resistivity_1." In
other words, when the "Resistivity" group isn't present, Petra will attempt to draw the
other two raster logs instead.

To turn on aliasing in the cross section module, go to RasterLogs>Log Images
Display. After a group is selected, click on the "Use Aliases" box (outlined in red).
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Individual Raster Templates
In addition to setting raster logs for an entire cross section, it is also possible to set
raster logs for an individual well in a cross section. Using an individual well template
allows you to select the best logs for each well irrespective of the global raster
settings. This is a great solution, but it requires individual attention for each well
modified. Generally, a good approach with individual templates is to establish a
decent aliasing scheme, and then create individual templates for wells that do not fit
the aliasing suitably.

To change an individual well's raster template, first select the well by left clicking on
the well symbol or the depth track. Notice how the well symbol is highlighted with a
pink box when selected. Next, right click to bring up the menu. Select "Set Raster
Template for This Well Only…"
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This brings up the "Select Log Images to Display" box. It is exactly the same as the
"Select Log Images to Display" for the entire cross section, but only pertains to one
well. Here, you can add or change the settings of the raster groups for the selected
well. Following the example, we've added the "Computed" curve, a computercalculated effective porosity and water saturation log for the middle well. This raster
group will go in track 3 on the far right.
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Turning off individual well templates is just as easy. Just select the well by left
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clicking on the well symbol or the depth track as before. Next, right click to bring up
the menu and select "Disable Raster Template for This Well…" This turns off the
individual template and defaults to the regular cross section raster log template.
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How to fix "Problem Perfs"
Petra projects often contain duplicate or redundant perf intervals. These “problem”
perfs can be divided into two major sets: gross interval perfs, or duplicate perfs.
Petra automatically recognizes these perf intervals and color-codes them. Gross
interval perfs are coded as red, while duplicate perfs are classified as blue.

Gross Interval Perfs (RED)
Commercial data vendors originally copied perf information from reported IP tests.
Additionally, Petra also has an option to import IP tests as gross perfs. When one
IP test covers multiple perfs, this method records one large “perf” that covers the
entire gross interval. These gross intervals obscure the actual perfs in a well and
invalidate most perf footage calculations.

Duplicate Perfs (BLUE)
Duplicate perfs occur when the same perf interval is repeated in the database. Just
like gross intervals, this can come from commercial data sources, or from
reimporting data into a Petra project.
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In the example below, you can see that there are only four actual perfed intervals:
1150-1158, 1164-1169, 1229-1236, and 1240-1245. The remaining perfs are either
gross intervals or duplicates. Notice that Petra color codes these intervals both on
the list and the graphical diagram of the perfs.
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You can deal with “problem” perfs in two ways – permanently deleting them, or by
keeping them in the database and filtering them out of displays and calculations.
Permanently Deleting Problem Perfs
Deleting “problem” perfs permanently changes the database. Be sure to have a
backup and to check the perfs that will be deleted. Petra stores information like
start and end date for each perf, so make sure this data is captured in the remaining
perfs.
First, select all wells containing problem perfs in the Main Module. Next, go to
Compute> From Tests>Remove “Problem” Perfs on the menu bar in the Main
Module. This brings up the Delete “Problem” Perfs dialogue box. You have the
option of deleting gross interval (RED) and/or duplicate (BLUE) perfs. A report
option is also available on this screen.
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Filtering Problem Perfs
If you choose not to erase these perfs from the database, it is very easy to simply
filter them out.
Cross Sections
In the cross section module, redundant and duplicate perfs can obscure the details of
what intervals are actually perfed. As you can see in the example below, the
redundant 95' gross interval perf completely covers the 4 intervals actually perfed.

To filter out these redundant perf intervals, first click on the Test Indicators button:
at the top of the screen. Alternatively, go to Wells>Plot Test Indicators… This
brings up the “Select Test Indicators to Plot” box.
Next, under the Perfs Tab click the check boxes to “Skip 'Problem' Red Perfs” and
“Skip 'Problem' Blue Perfs” as highlighted in the red box below.
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On future cross sections, Petra will automatically filter out these redundant perfs. In
the example below, the large gross perf intervals are gone and only the actual perf
intervals are left.
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Perf Flagging
Bad perf intervals can also cause problems when performing the perf-based
calculations available at Compute>From Tests>Flag Wells With Tests… in the Main
Module. Invalid perfs will cause false positive “perf in zone” flags and wrong total
perf footages. Selecting “Skip 'Problem' Red Perfs” and “Skip 'Problem' Blue Perfs”
ensures that Petra only counts true, non-redundant perf intervals.
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How to use Log Correlation Module
The Log Correlation Tool is an easy way to correlate formation and unassigned tops
as well as faults and pick pay intervals. To open the Log Correlation Tool, click the
Log Correlation icon on the toolbar in the Main Module:

Introduction to Log Names and “Log Types”
The fundamental problem with log data is the proliferation of log names created by
different commercial data vendors and individual users. The same general type of
curve (such as a gamma ray curve) can have hundreds, if not thousands, of different
names in a single project.
The Log Correlation Tool gets around this problem by using “Log Types.” A Log
Type is just an alias list of equivalent logs. In the example below, the “Resistivity”
Log Type we build will contain a list of the resistivity raster logs in a project. To
display a resistivity curve on a cross-section, we simply tell Petra to draw the
“Resistivity” Log Type. Petra then goes down this list of raster logs for each well on
the cross-section and draws the first one it finds. For the interpreter, this means that
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time invested in setting up Log Types will pay off with quicker, easier cross-sections
later.

Guide
The guide at the top of the screen shows the suggested workflow for using the Log
Correlation Tool. You’ll want to select a few wells, set the Log Types for each
column, put raster and digital logs inside those Log Types, set the depths, and finally
select and pick tops and pay intervals. The Quick Guide on the top of the screen
has a set of buttons that link directly to these different tasks in this order.

Step 1 - Select Wells
There are two ways to select wells: with the Map Module or directly from the Cross
Section Module
With the Map Module - The “Select Wells” button on the guide takes you directly to
the Map Module. Alternatively, click the map icon at the top of the screen:
.
Once in the Map Module, select individual wells with the left mouse button to add
wells to the Log Correlation Tool. Right click to stop and switch back to the Log
Correlation Tool.
With the Cross Section - Select Wells>Use Cross Section Wells. This option selects
the wells used in the Cross Section Module.
In the example below, there are three wells with no log types selected. The default
depths for the module are from 1,000’ to 2,000’ MD.
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Step 2 – Set Columns
The next step is to set the columns with either the “Set Columns” button on the guide,
or the “Set Columns” button on the toolbar: . Columns simply define where raster
and digital logs will be drawn in relation to the well symbol and data posting.
To define a column, first define whether the column will contain digital or raster log
data. Next, click the drop down box directly under “Log Type” for each column.
Under this drop down menu, notice that Petra initially creates a few default Log
Types including Density, Gamma Ray, Induction, Neutron, Resistivity, and Sonic. In
this example, the Resistivity Log Type will be drawn in the center column, and the
Density Log Type will be drawn in the right column. You can also select the “New
Log Type” button on the lower right corner of this screen to create a new Log Type.
You can also modify the location of the depth track. The depth track plots MD or
TVD depths next to the raster logs. This option simply moves the location of the
depth track relative to the other columns and the well symbol. In the example below,
notice that the depth track is set to “Left Center” between the center and left column.
Notice the text underneath each of the raster columns initially reads “3 wells have no
logs defined.” Initially, none of the Log Types have any logs names assigned to
them. In other words, Petra doesn’t know what raster log names (also known as
“group names”) should be drawn in either the “Resistivity” or “Density” columns. The
next step is to assign specific logs to the Log Types.
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Click OK to go to the Log Correlation Tool main screen. Alternatively, click the
“Change Logs” button under one of the Log Types to take you directly to the next
step at the Assign Log Type screen.

Step 3 - Putting Logs Inside Columns
The Log Correlation Tool can display both digital and raster logs.

Raster Logs
The next step is to put raster logs inside the newly defined columns. Practically, this
means that we need to assign raster group names to the Log Types. In the main
screen, select one of the defined columns under Step 3. In this example, the center
column with the Resistivity Log Type is selected.
This brings up the Assign Log Type screen. This screen shows the available raster
logs and their start and stop depths for each selected well, with shading separating
different wells. You can sort by ascending or descending order for each column.
This screen also features a search box at the top of the screen that filters data by
WSN, UWI, well name, well label, log name, or start and stop depths. Select “Filter”
to return the data meeting the criteria. This filter can also be made sensitive to
capitalization by selecting the “Case Sensitive Filter” box. After narrowing your logs
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and wells by applying one filter, you can select different criteria and select “Filter”
again to further limit the results. “Clear Filter” removes all filtering and returns all the
available raster logs for all selected wells.

You can select raster logs for the wells either by aliasing default raster groups to a
Log Type or by individually assigning raster logs for each well. Using both
approaches together will give the best combination of speed and customization. A
good Log Type “default” list is a useful “top-down” way of making a quick first pass
at the proper raster log for each well, while assigning individual logs ensures (in a
“bottom-up” way) that you are displaying the best possible log.
“Default” Log Type Rasters – This method aliases different raster groups to one
Log Type. Petra then assigns a “default” raster log to the well based on this list. In
this example, different resistivity raster images will be aliased to a single default
“Resistivity” Log Type. The first step to setting up a Log Type is to select the
Default Maintenance button on the lower left side of the screen (highlighted in red).
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This brings up the Add/Edit Log Type Defaults screen. Here you can add, delete, or
modify the existing Log Types. In this example, the Resistivity type is selected in the
“Defined Log Types” box in the upper left corner. Next, select the raster names to
add to the Log Type. To add or remove raster names to the Log Type, select the
“<” or “>” buttons (highlighted in red). In the example below, the Resistivity Log
Type will bring up the Elog, Res, and Res1 raster logs as a default. In essence,
Petra will try to draw the first available raster log on this list for the Resistivity Log
Type in the center column. Click Save Changes and Close to exit.
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Back at the Assign Log Type screen, notice that the raster logs selected on the
default Log Type list now show checks in the boxes underneath the “Default” column.
In addition to showing which logs are selected, these check boxes can also be used
to quickly add and drop logs from the selected Log Type. For example, clicking the
“Default” check box next to the “ELOG” raster log will drop it off the “Resistivity” Log
Type for all wells. Clicking the same “Default” check box again restores it to the list.
The Log Type Defaults list (highlighted in red below) shows the order of the default
logs for the selected wells. Again, log names higher on the list will be drawn before
log names lower on the list. To change the priority of the alias list, select a log name
and
buttons.
and use the

© 2014

1554

PETRA Help

“Assigned” Individual Raster Logs - The other way of selecting raster log names to
display is to individually assign raster logs for each well. Though this process takes
more time, assigning individual logs allows you to select the best raster log for each
well. Petra stores this information for the next time you bring the well into the Log
Correlation tool.
The easiest way to assign a specific raster log to a well is to use the Assign Log
Type screen. To select a specific raster log, select that raster log’s check box in the
“Assigned” column.
Additionally, you can also open the well-specific “Log Type Assignments” box by
double-clicking an individual well. To assign a raster log to the selected well, select
the specific raster log from the “Available Raster Logs” list on the right side of the
screen and click the “<” button. In the example below, the “ELOG” raster has been
assigned to the selected well. Select OK to save the changes and return to the main
“Assign Log Type” screen.
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In the example below, notice that the two different wells have “assigned” logs. In
one case (highlighted in blue), the log RES_TYPE will be plotted instead of the two
default logs, RES and ELOG. In the other case (highlighted in red), ELOG is both a
default log and an assigned log. This just means that it will be displayed regardless
of its order in the default Type Log list.
The Assigned logs box (highlighted in green below) shows the assigned logs for the
selected well. If a well has multiple assigned logs, you can prioritize them with the
and
buttons. Log names at the top of the assigned logs list will be shown
before log names at the bottom of the list.
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After setting up one Log Type, this is a good place to go back and repeat the same
Step 3 in order to fill the log types established for the columns in step 2. Carrying on
with the example, the screenshot shows the results of setting up log types for
resistivity and density logs. Notice that the far left well does not have a log. This is
because the depth scale is still from 1000-2000’ MD, which is above the start of that
well’s raster logs.
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Digital Logs
In addition to raster logs, Petra can display digital logs inside the Log Correlation
Module. While raster logs are simply images with fixed scales and curves, digital
logs actually contain the actual numerical values recorded by the tool in the wellbore.
Digital logs are much more flexible and can be displayed at any curve scale and in
any combination.
To change the display of digital logs, select one of the digitally-defined columns on
the guide under Step 3. In this example, the left column with the “Digital Logs” log
type is selected. This brings up the LAS to Raster screen.
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Petra uses a digital log “template” containing scales, colors, and position information
to draw the digital log curves on the main Log Correlation Tool window. A template
is established for each Log Type. In this example, the “Digital Logs” Log Type is
selected, and is shown on the digital Log Template dropdown menu (highlighted in
red).
You can select digital logs for the wells either by creating a default template for a
Log Type or by individually assigning log templates for each well with the “Well”
dropdown menu (highlighted in blue), which switches between the Default digital log
template and the templates for the wells selected in the Log Correlation tool. This
works similarly to the “Default” and “Assigned” raster logs discussed earlier. Though
you can create digital log templates for each well, it’s probably much faster to use a
single default log template with aliased digital logs.
“Default” Digital Log Template – This method uses a single template of digital logs
and display options for all wells. This method works particularly well with digital log
aliasing, which establishes a list of curve names that are equivalent. In the example
project, gamma ray curves are stored as GR, GRN, GRR, and GRS. Once those
curve names are aliased to the single curve name “GR”, the digital log template
treats them all as equivalent. For most projects, there’s no need to use individually
assigned digital log templates to deal with different curve naming conventions. Once
the curves and display options are set, make sure the “Default” option is selected on
the Well dropdown menu (highlighted in blue) and select “Save Log Template.
“Assigned” Individual Templates – With a robust digital log aliasing scheme, the only
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real reason to use individual digital log templates is to use different scales or other
display features (such as color or shading) for different wells. Once the curves and
display options are set for the individual well, make sure the well’s API/UWI is
selected on the Well dropdown menu (highlighted in blue) and select “Save Log
Template.”

The “Available Logs” list on the left side of the screen gives a list of all digital logs
that can be added to a well. Note that aliased curves are annotated with an *. This
list can be filtered to include the digital logs from all wells in the project, or just the
wells currently selected in the Log Correlation Module. To add a log, highlight the
name in the "Available Logs" list and click the add button (">"). This moves the log
over to the “Selected Logs” list. To remove a log, highlight the log name in the
“Selected Logs” list and click the remove button ("<").
Once a log is added to the “Selected Logs” list and is highlighted, the track and
display options for that log can be set on the various tab screens. Each displayed log
has its own scale and color settings established by the Scale through Raster/
Calibration tabs on the bottom of the Las to Raster Image box. For a more detailed
walkthrough of displaying digital logs, see “How to Display Digital Log Data.”

Scale Tab - The Scale Tab governs a few basic settings for each log. The Scale
Tab also sets the left and right scale for the selected log, as well as if the log will
use the alias list.
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Style Tab – The Style Tab changes how the selected log is displayed. This tab sets
the color and thickness of the curve, as well as any shading. Shading can highlight
log values above or below a cutoff value, or change color as a function of another log
(GeoColumn shading).

GeoColumn Shading – When the GeoColumn option is set on the Style Tab, the
GeoColumn Tab appears. GeoColumn shading colors the area between a curve and
the track edge with variable color based on log curve values. The color shading
under the curve can either based on same curve or from an entirely different curve.
This shading can either fill to the left or right edge of the track.

Tracks Tab – The Tracks Tab controls how the background grids are drawn for the
digital logs. This tab sets the width of the tracks and configuration of vertical scale
lines. Double clicking each track name under the Track Definitions box toggles the
depth track on and off. Hidden tracks (denoted by the symbol) don’t show grids or
any curves.

Misc Tab – The Misc Tab sets a few additional options regarding digital log display.
Plotting track grids after log curves layers the track grids over the log curves for
additional visibility. Using curves from other well completions will use curves from
wells with a similar API/UWI number (ending in 00001, 00002, etc). Plotting the
shading between logs after other shading will plot this shading on top of any other
curves for visibility. Display Curve units in header will show the curve units stored in
Petra’s database (on the Logs Tab in the Main Module) on the curve header. Show
aliased curve name in track header label will show the curve’s actual name instead of
the aliased name.

Crossover – The Crossover Tab shades the space between two log curves or
between a curve and a track edge. Crossover shading is commonly used for
illustrating the “gas effect” on porosity logs. Simply select curve 1 and 2, and whn
the shading should appear. It’s worth noting that cossover shading simply fills in the
area between the two curves as drawn on the track, and does not require the two
curves to be at the same scale.

LithSum – Lith summaries are useful for displaying cumulative data. As an example,
if a sample has 70% shale and 30% sandstone, it’s generally more useful to
represent these two numbers as a cumulative plot adding up to 100 instead of two
separate curves at 30 and 70.
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Raster/Calibration – The Log Correlation Module actually creates a temporary raster
image of the digital log for display. This tab governs how this temporary file is
created. The Raster Image section sets the overall resolution of these raster
images. If images are blurry, try adjusting the log scale to be more in line with the
scale on the mail Log Correlation Module. Adjusting the DPI can also sharpen the
image, but at the cost of slower drawing.

Normally, the Log Correlation module draws logs with a linear scale between the top
and bottom of the digital data. Deviated logs, however, don’t have a perfectly linear
relationship between MD and TVD. Adding additional calibration points helps to
stretch and squeeze the temporary raster image to better represent a TVD log.
Note that adding additional calibration points requires more drawing time.

Step 4 - Depths
The next step is to set the depths for the correlation tool. In the main screen, click
the “Depths” button on the guide, or click the depths button on the top toolbar:
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Depth Type
The depth type can be either "Structure" or "Stratigraphic". A structural cross-section
has a depth interval defined by measured or SubSea depths. A stratigraphic section
instead has depths defined with formation tops, where the raster logs are hung on
the upper fm top. Stratigraphic cross-sections are useful for showing variation in
stratigraphy independent of structural change.

Depth Axis Options
Show Depth Track – This option toggles the display of the small track that shows
MD, TVD, or SS depths. To hide it, deselect the “Show Depth Track” option. Hiding
the depth track will also hide any perf and test information.

Limit Depths By TD – This option limits the drawn raster logs and the depth track
down to a well’s TD (as stored in Petra’s database) rather than to full extents of the
bottom set with the Structure or Stratigraphic Depths Tabs.

Track Width - This governs the width of the depth track. Text inside the depth track
is automatically scaled. Expanding the width of the Depth Track can make the
measured depth numbers easier to read.

Structure Depths
If the plot is structural, use this tab to set the depths. Enter the "Upper Depth" and
"Lower Depth" values to define the desired section to display. Depth values can be
entered as either measured or SubSea depths. Remember that SubSea values
below sea level (like those on wells drilled on the Gulf Coast) are negative numbers.
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Compute Using Tops – Petra can automatically compute a valid structure depth
range from the tops selected for the cross-section. If no tops are picked for the
selected wells, Petra won’t be able to calculate a depth range.

Compute Using Logs - Petra can automatically compute a valid structure depth
range from the logs selected for display. Here, PERA will calculate depths that will
cover the top of the shallowest and bottom of the deepest logs.

Stratigraphic Depths
If you’ve selected stratigraphic depths, use this tab to set the scaling. Select the
formation tops which define the upper and lower depth. Petra will flatten the wells
along the upper formation. You can also add an "offset" number, which allow
stratigraphic depths to include data a set number of feet or meters above and below
the selected tops. It’s also acceptable to use the same formation top for both the
upper and lower depth limits with a sufficient offset above and below, as in the
example below. Notice that the upper and lower depth limits are set by the same
top with offsets 50’ above and 200’ below.

It’s worth noting that if either of these formation tops are null for a well, Petra doesn’t
have anything to flatten on and the well will be blank. For initial correlation work, it is
generally best to pick a consistent, widely correlated top to flatten on.
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At this point, the cross section shows the raster logs at the specified depths. In the
example shown below, the cross-section shows the resistivity logs in the first column
and density logs in the second column. The depth scale is from 2500’ MD to 3500’
MD.

Step 5 – Select Picking Type
The previous steps simply create a cross-section to interpret. The next step is to
select the pick type. These three buttons on the quick list are an easy way to switch
between picking tops, unassigned tops (“U/A Tops”), pay intervals, or faults. Each
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“picking type” button under Step 5 changes Steps 6, 7, and 8 to reflect the particular
pick type.

Each pick type changes the Quick List on the right of the screen, as well. The Quick
List is the most convenient way to pick tops, pay, and faults. To toggle the Quick
List on and off, click the
button in the upper left corner of the screen, or select
View>Quick List on the menu bar at the top of the screen.
Picking Fm Tops
The Log Correlation Tool allows you to create and store formation tops. Formation
tops reflect distinct, mapable lithostratigraphic units that are equivalent from well to
well. Formation tops are stored to Petra’s database, and are shared among
different modules and different users.

Step 6 - Formation Tops Display Options
The next step is to select the tops you want to display and pick. First, select the
“Tops” option under the Step 5, and then click the “Select Tops” button under Step 6
on the guide (highlighted in red).
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This brings up the Formation Tops Display Options window. To display a formation
top in the Log Correlation Tool, first select it on the “Available Tops” list and click the
“<” button to bring it over into the “Displayed Tops” list. The tops listed in the
Available Tops list can be filtered to show only the tops with values for the wells in
the Log Correlation tool or by source.

Once on the Displayed Tops list, you can change the color of the top as it shows up
on the plot. The small check box next to the name on the Displayed Tops list toggles
whether the picks are for display only or can be modified. Tops with a green check
can be picked and shown up on the Pick Tops list, while those without a green check
are display only.

After the tops are selected, the next step is to pick the style of the displayed tops.
Under the Style Tab, you can change how the line between tops is drawn. Line
width makes the lines between tops thicker and thinner, while the line type
determines whether the line is dashed or solid. The “Apply Line Width and Line
Type” button will change the width and type for every other displayed top, but will
retain each line’s color. In the example below, the “2nd Wall Creek” top is selected.
The style tab shows that this top is red, solid, and of normal width.
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If your project has Top Aliases set up in the Main Module, click the “Allow Top
Aliases” to use them.

“Disable Top” temporarily hides the specific formation top on the cross-section while
retaining its display settings. Disabled tops will have a
symbol next to their name.

Step 7 – Pick Fm Top Style
When the “Tops” picking type is selected, Step 7 shows the two options for picking
formation tops: across and down. You can change the pick style with the buttons on
the Guide, or by using the
and
buttons on the Pick Tops part of the Quick List.

Pick Across – This is the standard pick mode in the Cross Section module. In this
mode, a single formation top is picked across all wells shown.

Pick Down - In this mode, tops are picked in the order they’re shown on the Pick
Tops list. Practically, this means that tops can be picked successively down the
same wellbore before moving to the next wellbore. It helps to have the tops in a
stratigraphically successive order going down the wellbore on the Pick Tops list.
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Use the

buttons to move a selected top up or down in the Pick Tops list.

Step 8 - Picking Fm Tops
Selecting “Tops” on step 5 changes the Quick List to Pick Tops mode.

To start picking tops, first select the desired fm top on either the Displayed Tops list
at the top or the Pick Tops list at the bottom. Next, select the “Pick Tops” button on
the guide or the green button on the Pick Tops Quick List: .

Remember that the two pick modes work differently. “Pick Across” creates a single
top across all wells, while “Pick Down” cycles through the Pick Tops list. To create
fm tops, just click the depths on the raster logs where your tops are located. To
stop picking, right click the mouse or click the stop button on the Pick Tops Quick
List:
. The example below shows formation tops for the top and base of the 2nd
Wall Creek in red. Notice that the currently active fm top, 2nd Wall Creek, is shaded
to black.
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You can also create “Auto-named” fm tops using the Create New Fm Top button:
on the Quick List. Just like regular tops, auto-named tops correlate across logs and
can be used in cross-sections and the map module. The only real difference is that
the normal fm top setup is bypassed, so auto-named tops are named on the current
date and time - DDMMYYYYHHMMSS. In the example below, the auto-named top
“10082008143211” just means it was created 8 October, 2008, at 14:32:11
(2:32:11PM). Auto-named tops are great for quickly correlating an unknown
surface, and setting the name and source later. Additionally, auto-named tops can
easily be merged into existing fm tops.

Renaming and Merging Tops
Merging tops takes essentially takes the values of one named set of tops and moves
them to another named set. Instead of dealing with two tops representing the same
surface, it’s more convenient to merge them into one. To merge the two together,
first select the top to merge into another and select the “Rename/Merge Selected
Top.” In the example below, the “10082008143211” auto-named top is selected.
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This brings up the Rename/Merge Top screen. Notice that the Source Top is listed
at the top of the screen. This is the top that will be renamed or merged into the top
selected on the list at the right of the screen. In this example, the
“10082008143211” auto-named top will be merged with the 2nd Wall Creek.

The Data Merge Rules settings at the bottom of the window set how the two tops
will be merged together

Update Values – In wells where both tops exist, the source top (in the example
below, 10082008143211) will remain and the selected top (2nd Wall Creek) will be
erased.

Add New Values Only – In wells where both tops exist, the selected top (in the
example below, 2nd Wall Creek) will remain and the source top (10082008143211)
will be erased.
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Picking Unassigned Tops
The Log Correlation Tool also allows you to create and store “unassigned tops.”
There can be multiple unassigned tops with the same name on the same well.
Because of this, unassigned tops are useful for correlating things outside the
traditional definition of a formation top. This can include possible faults or other
marker "picks" that are considered by the interpreter to be unknown, uncorrelated or
otherwise "unassigned". Unassigned tops can be easily correlated and converted
into formal formation tops. Unassigned tops are stored to Petra’s database, and are
shared among different modules and different users.

Step 6 - Formation Tops Display Options
Just like regular formation tops, you also need to turn on the display of unassigned
tops. First, select the “U/A Tops” option under the Step 5, and then click the “Select
Tops” button on the guide (highlighted in red).

This brings up the Unassigned Tops Display Options Screen. This screen shows all
the pre-existing unassigned top names in the project. In the example below, there is
only the “default” unassigned tops name.
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Since this will be shared throughout the whole project, it’s a good idea to make a
new, named set of unassigned tops. To create a new set of unassigned tops, select
the
button. On the Unassigned Tops “Pick” Properties box, enter a name under
“Pick Name” that reflects the purpose of your unassigned tops. This can be as
generic or as specific as you like. In the example below, the picks are all going to be
on 2nd Wall Creek resistivity features, so the pick name is “2nd Wl Crk Res.” Next,
select or enter an interpreter name. It’s a good idea for every interpreter to have
their own in order to prevent one user from overwriting another user’s work. In the
example below, the source name is “CTM.” Next, select the line style, width and
color for the unassigned tops. Select OK to create the correlation and return to the
display options screen.

Notice that the unassigned tops name now appears in the Available Unassigned Tops
list on the right of the screen. To display a formation top in the Log Correlation Tool,
first select it on the Available Tops list and select the “<” button to bring it over into
the “Unassigned Tops To Display” list.
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Once on this list, you can still change the color of the unassigned tops. Selecting the
small check box next to the name on the Unassigned Tops To Display list toggles
whether the picks are display only or can be modified. Tops with a green check can
be picked and modified in the correlation tool, while those without a green check are
display only.

Step 6 Cont. - Unassigned Top Correlations Display Options
Unassigned tops by themselves have no relationship to each other. Correlating
unassigned tops links them together across wells into a single named unit. These
correlations can be flattened to show stratigraphic variation or converted into regular
formation tops. One of the best uses for correlation is to flatten the cross section on
localized distinctive log features with no formal name.

Just like regular formation tops and unassigned tops, you also need to turn on the
display of unassigned top correlations. First, select the “U/A Tops” option under the
Step 5, and then click the “Select Tops” button on the guide (highlighted in red).

This brings up the Unassigned Tops Display Options Screen. To look at correlations,
click on the “Unassigned Top Correlations” Tab on the top of the screen. This
screen shows all the pre-existing unassigned top and unassigned top correlations in
the project. In the example below, there are no available correlations. To create a
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new set of unassigned tops, select the

button.

On the Unassigned Tops “Correlations” Properties box, enter a name under
“Correlation Name” that reflects the purpose of your unassigned picks. This can be
generic or specific as you like – in the example below, the correlation is on a single
resistivity bump above the 2nd Wall Creek, so the correlation’s name is “Resistivity
Bump.” Next, select or enter an interpreter name. It’s a good idea for every
interpreter to have their own to prevent one user from overwriting another user’s
correlations. In the example below, the source name is “CTM.” Next, select the
line style, width and color for the unassigned top correlation. Select OK to create
the correlation and return to the display options screen.

Notice that the correlation now appears in the Available Correlations list on the right
side of the screen. To display a correlation in the Log Correlation Tool, first select it
on the Available Tops list and click the “<” button to bring it over into the “Unassigned
Tops To Display” list.
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Clicking the small check box next to the name on the Correlations To Display list
toggles whether the correlations are display only or can be modified. Tops with a
green check can be picked and modified in the correlation tool, while those without a
green check are display only.

Step 7 - Picking Unassigned Tops and Correlations
Selecting U/A tops on step 5 changes the Quick List to show the Unassigned Picks
toolbar.

Unassigned Picks

Making Unassigned Tops:
This creates new unassigned tops under the picks
name shown in the dropdown menu. Different pick names can be used to keeps
groups of unassigned picks separate by both purpose and interpreter. In the
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example above, new unassigned tops will be part of the “2nd WL CRK RES” name
created earlier. To pick tops, click on the logs on the main screen. Multiple
unassigned tops with the same picks name can be added to the same wellbore.
Right click to finish picking tops.

This brings up the option of saving the new pay intervals to Petra’s database.
Selecting “No” will erase all new, unsaved unassigned picks. In the example below,
notice the red lines signifying the resistivity anomaly picked as a unassigned top.

Moving Unassigned Tops:
To move unassigned tops, select this button. Left
click the unassigned top to move and drag it to the new location. When finished,
right click the mouse button. This brings up the option of saving the new unassigned
tops to Petra’s database. Selecting “No” will leave all unassigned tops unchanged.
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Delete Selected Tops:
To delete unassigned tops, select this button. Left click
the unassigned top to delete it. The unassigned top interval will be hatched with red
to show that the changes haven’t been saved to the database. When finished, right
click the mouse button. This brings up the option of deleting the unassigned top from
Petra’s database. Selecting “No” will leave all unassigned top picks unchanged.

Delete Tops by Name:
This button deletes all the unassigned tops with the
currently selected unassigned tops name. In this example, the “2nd Wl Crk Res”
unassigned tops group is selected, so selecting this option will delete all the “2nd Wl
Crk Res” unassigned tops on the currently selected wells.

Create New Unassigned Tops Name: This button provides another quick way to
create new unassigned group names. This brings up the New Pay Interval Definition
screen. Enter the name, source, description, and color of your pay zone.
Unassigned top names created here will automatically show up in the Unassigned
Picks dropdown menu on the Quick List.

Unassigned Correlations

Connect Unassigned Tops:
This button designates selected unassigned tops to
a specific correlation. First, select the correct correlation name on the lower
dropdown menu (in the example above, the correlation is called “Resistivity Bump”).
Next, select the “Connect Unassigned Tops” button and click on unassigned tops on
the wells to add them to the correlation. Right click when done. The unassigned
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tops will now be connected by a line to signify that they are part of a correlation. In
the example below, the blue correlation line connects the unassigned tops.

Convert Correlation to Fm Top:
This button converts a correlation into a fm top.
As a formal fm top, the surface can be gridded or used in calculations. First select
the appropriate correlation from the correlation dropdown menu. Next, select the
“Convert correlation to Fm Top” button to bring up the “Convert Correlation To Top”
window.

This brings up the Convert Correlation To Top window. Here, select an existing fm
top or create a new top for the correlation. In this example, the “Resistivity Bump”
correlation will be converted to the “Resistivity Bump Top” Fm top. This newly
created fm top will be stored into Petra’s database.

This screen also gives you the option to convert the correlation for all wells in the
database, only the currently selected wells in the Log Correlation Tool, or only the
wells selected in the Main Module.
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Flatten on Correlation:
This option flattens all wells onto the correlation selected
on the correlations dropdown menu. This is useful for quickly seeing changes in
stratigraphy or for testing correlations without the formality of a true fm top.

Delete Correlation:
dropdown menu.

This option deletes the correlation selected in the correlation

Create new unassigned top name:
This option is another way to quickly create a
new correlation. Select this button, and enter the name, interpreter, color, and line
width and style of the correlation line. Correlations created here will automatically be
displayed.

Picking Pay Intervals
The Log Correlation Tool can show one or more color-filled intervals representing
“pay” zones. Though most often used for illustrating zones of productive reservoir,
you can use pay zones to show anything that has a top and base. Pay zone intervals
and thicknesses can also be stored to a data item in the Zone database. Once
stored as a data item, these thicknesses are available for posting or contouring.
Pay intervals are stored to Petra’s database, and are shared among different
modules and different users.

Step 6 – Pay Interval Display Options
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To display pay intervals, select the “Pay” option under the Picking Type Option then
click the “Select Pay” button on the guide (highlighted in red). This opens the Pay
Data Display Options screen.

This screen shows pay zones already in the project, and can be filtered to show
either pay intervals for the selected wells in the Log correlation Tool or to show the
pay intervals for all wells in the project. These pay intervals can also be filtered by
the source.

In the example below, notice that the option for showing pay “For Selected Wells
Only” (highlighted in red) is turned on. Since none of the selected wells have any pay
selected, nothing appears in the “Available Pay” window.

In this example, a 2nd Wall Creek pay interval already exists in the database.
Changing “For Selected Wells Only” to “For All Wells” displays all the pay zones in
the project. Notice in the example below that there are pay intervals both for
lithology (“LS” and “Sand”) as well as for actual reservoir pay (“2WC”). To display a
pay interval, select it on the Available Pay list and click the “<” button to bring it over
to the Selected Pay list on the right. To enable editing on the pay zone, make sure to
select the small checkbox to the left of the pay zone’s name. A green check, like
that shown in the example below, signifies that the pay interval can be edited.
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button on the Pay Data Display Options
To create a new pay interval, select the
window. This brings up the New Pay Interval Definition box. Enter the name,
source, description, and color of your pay zone. Select “Add” to add the pay interval
to Petra’s database.

Step 7 – Picking Pay Intervals
Selecting “Pay” on step 5 changes the Quick List to show the Pay Intervals toolbar.
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Begin Picking:
After selecting the appropriate pay interval, left click once in the
appropriate location on the wellbore to create the top of the pay interval, and again
to create the bottom. To continue picking wells across your cross-section, simply
click on the appropriate depth on other wells. Petra will draw a hatched box
covering the interval, as shown in the example below. This hatching indicates that
the pay intervals are not saved to the database. When finished, right click the mouse
button.

This brings up the option of saving the new pay intervals to Petra’s database.
Selecting “No” will erase all unsaved pay picks. In other words, if you make 25
correct pay picks in a row followed by a single bad one, make sure to select “Yes”
and go back to fix the bad pick. Selecting “No” will erase all the unsaved good picks
as well as the single unsaved bad one.

Once saved, the hatched lines on the pay intervals disappear to signify that the pay
intervals are stored to Petra’s database, as shown in the example below.
© 2014

"How To" Workflows

1583

Move Picks:
To move pay picks, select this button. Left click the top or bottom
of a pay interval and drag it to the new location. The pay interval will be hatched to
show that the changes haven’t been saved to the database. When finished, right
click the mouse button. This brings up the option of saving the new pay intervals to
Petra’s database. Selecting “No” will leave all unsaved pay picks unchanged.

Delete Picks:
To delete picks, select this button and left click inside the pay
interval. When finished, right click the mouse button. This brings up the option of
saving the new pay intervals to Petra’s database. Selecting “No” will cancel all
unsaved pay deletions, leaving the pay picks unchanged.

Create New Interval Name:
This brings up the New Pay Interval Definition
screen. Enter the name, source, description, and color of your pay zone.

Picking Faults
The Log Correlation Tool can show faults and fault gaps that represent missing
section. Fault intervals are stored to Petra’s database, and are shared among
different modules and different users.
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Step 6 – Picking Faults
To display pay intervals, select the “Fault” option under the Picking Type Option then
click the “Pick Fault” button on the guide (highlighted in red).

This changes the cursor to a crosshair. To create a new fault, click on the
intersection of the fault with the depth track. A single click brings up the “Add Fault
Gap” screen. Note that clicking and dragging the cursor up and down will calculate
and automatically calculate the missing section for the fault. It’s not necessary to fill
in a name, source, or comment for every fault, but doing so can help distinguish
between different interpreters’ work.

Fault gaps can be shown in a stratigraphic cross section and help to account for
missing section. To add fault gaps, select Faults>Display Options and select “Fill
Fault Intervals.” Note that you can limit faults by a source name, which can be
useful in large multi-user projects.
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To delete a fault, select the “Delete Fault” button and select the fault to delete. This
will delete the fault throughout the entire project, so be careful not to erase another
interpreter’s work. On a stratigraphic cross-section with fault gaps, make sure to
click on the top of a fault gap to delete it.
Making another Cross-Section.
After you pick your first set of tops and pay, it’s not necessary to go through the
entire process again for a new cross-section. Petra saves column settings, default
logs, depths, and top information to apply to your next set of wells. To make a new
cross section, all you’ll have to do is select the new set of wells (Step 1) and make
adjustments in the default and/or assigned raster logs (Step 3). Continually making
small improvements to your default Log Type list as you make new cross sections is
a good use of your time – the better and more comprehensive your default Log Type
list, the less time you have to spend individually assigning raster logs to wells.
Other Display Options
Plotting Well Data around Well Symbol – To plot well data around the well symbol at
the top of the screen, select Wells>Plot Data around Well Symbol. This brings up
the Post Data By Well Symbol screen. Here you can select which well identification
data will be plotted around the well symbol. In the example below, the wells’ label is
plotted above the well symbol.
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Well Symbols - While in the Correlation Tool’s main screen, dragging the lower line
of the frame containing the well symbols increases and decreases this space. The
and
buttons on the toolbar at the top of the screen toggle the well symbol
and well data on and off, respectively.

The example below shows well labels displayed over each well symbol.

Plotting Log Scale Information – The tops of raster images usually have scale
information for each column. If this scale information is calibrated, it can be shown
on the Log Correlation Tool’s main screen. To show and hide this raster scale
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information, click the
and
buttons on the toolbar at the top of the screen.
The next step is to tell Petra how the scale information is stored in the raster
calibration. Under Logs/Images>Log Header Display on the menu bar at the top of
the screen, select “Header”, “Lower Scale”, or “Upper Scale.” Many older Petra
projects store scale information as the “header.” Once this data is displayed,
dragging the lower line of the frame containing the scales stretches and squeezes
the image scales for readability.

Test Indicators - Select Wells>Plot Test Indicators to bring up the Test Indicators
screen. Select the display color for perfs, and click “Enable Perfs Display.” The Log
Correlation Tool will display perfs as a colored box on the depth track. The example
below shows perf indicators as a red rectangle on the depth track (highlighted in
green).
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Zoom and Scroll
For detail work, it’s probably advantageous to zoom and scroll on the cross section.
There are two ways to zoom in and out on the Log Correlation cross section.
Toolbar Zoom – The toolbar has a set of zooming tools:

“+” and “-“ zoom in and out by 1/2 onto the center of the screen. The
allows you draw an area to zoom. The
while the

.

button

button returns to the last zoom setting,

magnifying glass removes all zoom to return you to the default scaling.

The Pan and Scroll Window - This window on the Quick List log correlation window
pans and scrolls around a zoomed cross-section. The “enlarge button” creates an
additional window, which is useful for double monitor setups.

Like the toolbar zoom, the “+” and “-“ zoom in and out of the center of the screen,
while the “X” removes all zoom. The extents of the log correlation main window are
shown in red on this window. Dragging this red outline scrolls the extents of the main
correlation window at the current zoom level.

Scrolling with the Arrow Keys Window – When zoomed in on a section, you can also
quickly pan across the section using the arrow keys. By default, the screen will pan
by 50% of the currently displayed screen with every key press. To change this
scrolling percentage, go to Display>Arrow Keys.

Smooth Scrolling with the Alt Key – When zoomed in on a section, you can smoothly
move the section by pressing and holding the Alt key. Clicking and dragging any
point on the zoomed in screen will then move the shown part of the cross-section.
The Right Mouse Button
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Many common commands and some context-specific commands are available by
clicking the right mouse button on the cross section. A familiarity with these
commands can ultimately add up to huge savings in time and effort.

The right mouse button accesses several common commands related to tops. Place
your mouse over the top right click the mouse flatten on, hide, or null the closest
picked fm top. To start picking the selected top under the Pick Tops Quick List, right
click and select “Start Picking Top(s).”

Slip Box
The slip box takes a screenshot of a part of the cross-section and places it into a
separate window inside the cross-section. This section of the log can be a great
help to correlation between one log and another. The slip box window can be moved
around the screen, as well as stretched and squeezed. The slider box on the top of
the window changes the box’s opacity to make it easier to overlay on top of other
logs.
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Shifting Wells Up and Down
Logs can be shifted up and down to facilitate correlation. Press Shift and click the
well to move the entire log up and down relative to the other logs. To undo any
shifting, select the “Refresh Data” button on the toolbar at the top of the screen.

18.7

How to use Interval Data
Interval data stores data to a specific depth interval that doesn’t fit well with the
traditional zone concept, such as data that is too fine (such as core descriptions) or
too coarse (such as mud weights or biostratigraphic information) to fit inside two
formation tops.

The difference between Zones and Intervals
Petra defines a “Zone” as a specific interval defined by a discrete top and a base.
Usually a zone’s top and base are defined by specific formation tops so that the zone
covers a consistent lithostratigraphic unit. Inside each zone, Petra stores a “Data
Item” such as isopach, net pays, or log measurements that relate to that zone. Since
zones and their data items are shared across all wells in a project, this method of
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organizing data makes storing and mapping single-value data for a specific formation
much easier. As an example, mapping all the isopach values for a specific formation
is much easier when the values are all stored in one common zone data item for each
well.
Zones are limited, however. Cuttings or core data may actually subdivide a specific
zone into several different units based on lithology, color, porosity, or other
petrophysical characteristics. Similarly, data such as a mudweight or a
biostratigraphic presence can be larger than a single zone’s definition. Capturing all
this information with the traditional zone model is cumbersome as it leads to a
proliferation of new, well-specific zones.
Intervals, on the other hand, are designed to store information about the wellbore
without using zones. The interval concept stores data too fine for the zone concept
(such as core and lithologic descriptions) as well as data that exists completely
outside the normal stacked strata concept (such as logging runs or mud weights).
Interval data also handles data overlapping different formations, such as
paleostratigraphic data.

Interval Data Basics
Petra stores interval data in tables and fields similar to a spreadsheet. The “table”
stores related interval data in a spreadsheet, where each interval is stored as a
separated row. In the example below, the project has the default tables LITH, CORE,
and PALEO.
Inside the table, each interval is stored as its own row, and information about that
interval is stored in “fields”, or columns in that row. All tables come with a few fields,
TOP, BASE, DATE1, DATE2, QUALITY, and FMNAME, but you can add user-defined
fields containing numbers, dates, or text. In addition to the standard fields, the LITH
table in the example below contains the field “Desc” which stores lithologic
descriptions.
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Creating, Modifying, and Deleting Tables
An interval data “table” stores interval data in a spreadsheet, where each interval is
stored as a separated row. Since every interval row in the table shares the same
fields (as columns), it’s a good idea to keep different types of data in different tables.
To create, modify, or delete tables in a Petra project, select the “Maintenance” button
on the bottom of the Interval Tab on the Main Module.

- This option adds a new interval data table. Selecting this option brings up a
dialogue box to add the new table’s name and description. A newly created table
contains no new fields.
- This option edits just the name and description of an existing interval data table.
To edit the fields inside the interval, select the “Data Fields” option on the
Maintenance screen.
- This option deletes the entire interval data table, along with all the fields and
data contained within the table.

Creating, Modifying, and Deleting New Fields
In an interval table, each interval is stored as its own row, and information about that
interval is stored in “fields”, or columns, in that row. To create, modify, or delete
fields in a Petra project, select the “Maintenance” button on the bottom of the Interval
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Tab on the Main Module.

- This option adds a new interval field to the selected interval data table.
Selecting this option brings up a dialogue box to add the new field’s name, description,
and attributes. The Kind dropdown box sets the kind of data the interval field stores:
a Real Field, Date Field, or String Field. Real Fields simply store numbers, such as
porosity or permeability. Dates store calendar days as MM/DD/YYYY. String values
store text like core descriptions. For Real fields, the Units box sets the displayed
units of measurement, while the Decimal Places for Display option sets the displayed
trailing decimals.

- This option modifies the name, description and attributes of the selected field.
- This option deletes the selected field.

Reordering Tables
By default, interval tables show up in the order they’re created. Especially in large
multi-discipline, multi-user projects with many different kinds of data, it’s often useful
for a user to reorder and filter the interval tables to only show relevant data. To
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reorder the Interval tables, select the “Order...” button on the Interval Tab on the Main
Module. This brings up the “Filter Interval Data Table Names” box. Here, use the “>”
button to bring a single selected table from the Available Internal Table List on the left
to the Filtered Interval Table List on the right. The “>>” button brings over all available
tables. Once on the Filtered Interval Table List, use the up and down arrows to
change the order of the shown tables. Tables at the top of the list will be shown
before tables on the bottom of the list. To drop a selected table from the Filtered list,
select the “<” button, and to drop all tables from the filtered list, select the “<<”
button. If there are any tables on the Filtered Interval Table List, only those tables will
be shown.

Reordering and Hiding Fields
By default, interval fields show up in the order they are created. To reorder the
Interval fields, select the desired table and select the “Columns...” button on the
Interval Tab on the Main Module (highlighted on the left figure below). This brings up
the “Interval Data Column Display Properties” window. This screen shows the list of
the table’s available fields on the left, the displayed fields on the upper right, and the
selected field’s properties are shown in the lower right. This window changes the
order of the displayed fields, hide and show specific fields, and changes field
properties.
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Reorder the specific fields
To reorder a field, select the column at the top of the screen and drag it to the
desired position. In the example below, the “TOP” column has been dragged to be
before the “QUALITY” column.

Hide and show specific fields
To drop a specific field, select the column at the top of the screen and select the “-“
button. To add a specific field, select the field name from the list on the left side of
the window and select the “+” button.

Change the field properties
The “Column Properties” on the lower right shows name, justification, shown decimals,
the label style (Name or Name and Units), and the data property (Value or Quality).
Changing these settings changes how the selected field will be shown.
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Adding Interval Data
New interval data can be brought into Petra either manually or by a tabular data
import.

Adding New Data Manually
To add new intervals manually, first select the correct well in the Main Module. On
the Interval Tab, select the right interval table. In the example below, the “LITH” table
is selected. Finally, select the “Edit details” button in the upper right on the Interval
Tab. This brings up the Edit Interval Data window for the selected interval table.
Continuing with the example, the Edit Interval Data window below shows the fields for
only the LITH table.

To add a new interval, enter in the Top and Base. Next, select the button to add the
interval.

With the interval now added, enter in the remaining interval details and select button
to save the changes to the interval. In the example below, the Quality, Formation, and
LITH Table specific fields are filled in.
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To save the changes to the database, select OK. Here, Petra gives the option to
save or discard ALL changes made to the selected well’s interval table. All the edits
to all intervals will be ignored if you select CANCEL.

Importing Tabular Interval Data
Digital data where each row contains information about a discrete interval can be
easily imported into Petra. Before attempting to import interval data, check to see if
the data has a column dedicated to the UWI/API. Since Petra assigns interval data to
specific wells by comparing UW/API numbers, interval data without an identifying API/
UWI column can’t be imported. The easiest way to remedy this is to simply open the
interval data in a spreadsheet program, and add a new column for well UWI/API.

To import new digital interval data, select Project>Import>Import Tabular Interval
Data… on the menu bar at the top of the Main Module. This opens the “Import
Interval Data from Tabular File Format” box. Here, select the “Open File” button and
navigate to the interval data’s location.

Once the file containing the interval data is opened, Petra switches to the Data
Format Tab. This tab essentially links the entries in the file to specific kinds of data.
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The first step is to select the interval data file’s formatting under File Format. Files
can be imported into Petra in one of three formats: “Columnar”, “Comma Delimited”,
or “~ Delimited.” Columnar data organizes data into fixed columns, where Petra
imports data based purely on the number of characters from the left. The left
screenshot, on the other hand, shows the API number as defined by columns 1
through 14.
Comma and ~ delimited data, on the other hand have no fixed column size and are
instead separated by a comma or a tilde. With delimited data, Petra imports data
based on the “Field” defined by the delimiter. The example below shows the same
UWI/API field defined in two different ways. The right screenshot shows the API
number defined as “Field (1)”, i.e. it is separated by the first comma.

Be careful when importing text as a comma delimited file. If the text has a comma in
it, Petra will read that as the end of the field. The interval data stored as UWI, Top,
Base, Description such as:

05123187700000, 6295, 6998, Calcareous, micaceous, clay-rich siltstone

Would only be imported as:
API: 05123187700000
Top: 6295
Base: 6998
Description: Calcareous

In other words, all the description past the first comma is cut off. This can also cause
bad imports when data is beyond the comma-filled text.
The next step is to establish field definitions. Essentially this step defines which part
of the file is which kind of interval data. The easiest way is to select and highlight the
specific data field in the “Data Record” part of the screen, then select the type of
interval data on the left. Petra can import fields for any interval table. In order to put
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interval data with the correct well, the UWI or API # field must be defined.
When loading the TOP and BASE of the interval, Petra assumes that the depths are in
MD. To import other depths, such as SS or TVD, select the appropriate depth on the
“Field is not a Depth or is MD” dropdown when establishing a field definition.
For user-defined fields (Not the TOP, BASE, DATE1, DATE2, QUALITY, FM NAME,
UNITS fields), Petra can store a quality code. To import the quality code, select the
“Store Field Value” dropdown menu and set it to “Store Field Quality Code.”
To add the field definition, select the “+” button. The “-“ button drops the selected
field definition. To modify an existing field, make the appropriate changes and select
the

button.

The example below shows field definitions for the data file, which include the well API,
interval top, interval base, formation name, and description.

To save the field definitions and options, select the “Save” button. This option saves a
*.FMI file. Selecting the "Load" button restores all the saved settings.
Most data files have some header or comments at the top. The “Records to Skip
Before 1st Well” option tells Petra to skip a set number of lines before importing any
well data. Click the "Set Skip" button to set the number of skipped records based on
the record currently in the data record window,

Changing Interval Attributes, Markers, and Patterns
Every interval stores a set of colors, markers, and patterns that can be displayed on
the cross-section module. It’s possible to change these settings for every interval
individually, or with multiple intervals at a time.
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Setting a Single Interval’s Attributes, Markers, and Patterns
First, select the desired interval by clicking on the graphical representation of the
interval on the right side of the screen. The selected interval will be marked with a
black triangle on the right side of the interval (highlighted in the example below). Next,
select the Attributes Tab. Here, select the interval’s line and fill color. In the example
below, the first interval (a calcareous siltstone interbedded with sandstone) will be
drawn with a light blue fill. Notice that the selected color appears on the list of
intervals on the far left as well as on the graphical representation of the intervals on
the far right.

Next, select the Markers Tab. Select the marker from the list of available markers,
set the style and color, and select the button to post the marker symbol. In the
example below, the “X” signifies a lack of porosity from the core description.
Single - A single symbol is plotted
Tiled - Multiple symbols are plotted like wallpaper.
Column - Multiple symbols are stacked vertically in a column
Row - Multiple symbols are aligned horizontally in a row
Stretch X - A single symbol is plotted with its width stretched to fit the interval width
Stretch Y - A single symbol is plotted with its height stretched to fit the interval height
Stretch XY - A single symbol is plotted with its width and height stretched to fit the
interval rectangle
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Finally, select the Patterns Tab. This sets a wide variety of lithologic patterns.
Select one of the available patterns and a size from the list and select the button.
Note that the “size” of the pattern governs the density of the pattern’s display. The
example below shows the interbedded sands and shales from the core description.

Setting Multiple Intervals’ Attributes, Markers, and Patterns in
a Single Well
First set a single interval to the desired attributes, markers, and patterns. Next,
select the
button on the “Defaults” section on the Attributes Tab (highlighted
below). This stores the current scheme of colors and patterns as a “default” attribute
so it can be used later on different intervals.
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The next step is to select the multiple intervals that will have this default attribute
scheme. To select multiple intervals, select the “Set Tabs” button:
or hold down
the CTRL key. Next, select the desired intervals on the graphical representation of
the intervals on the right side of the screen. Note that the selected or “tagged”
intervals have a small black triangle on the far right (highlighted in the example below).
In the example below, all the very fine grained sandstones have been tagged.

To tag all intervals in the well, select the
button.

button. To drop all tags, select the

Finally, select the
button on the Defaults section of the Attribute Tab. This
applies the current “Default” scheme of colors, markers, and patterns to all tagged
intervals.
The
while the

button only applies the default scheme to the currently selected interval,
button applies the default scheme to all intervals in the well.
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To add another “default” scheme, simply set a single interval to the desired colors,
markers, and patterns and select the the
button on the “Defaults” section on the
Attributes Tab. In the example below, there are three default schemes based on
lithology: the blue interbedded siltstone/sandstone, the pale yellow very fine grained
sandstone, and the bright yellow fine grained sandstone.

Even after adding default schemes, it’s easy to go back and modify individual
intervals to display different information. In the previous example, three different
default schemes reflected lithology and grainsize from core descriptions. To carry this
example one step further, markers can also be added to signify porosity. Recall that
for the sandstone/siltstone, an X marked low porosity. To add markers for an
individual interval, select the interval and go to the Markers Tab. Select the marker
and the marker’s color, and select the
button. In the example below, red
stars have been added for all intervals with porosity above 10%, and a black X for all
intervals with porosity below 10%.
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To save the changes to the database, select OK. Here, Petra gives the option to
save or discard ALL changes made to the selected well’s interval table. All the edits
to all intervals will be ignored if you select CANCEL.

Setting Multiple Intervals’ Attributes, Markers, and Patterns in
Multiple Wells
The previous methods change the display of intervals for one well at a time. This can
work well for a small number of intervals in a few wells. Even a modest Petra project
can contain a large amount of intervals spread out over many wells; changing intervals
one well at a time would be very tedious and time-consuming.
Petra’s Find and Replace Interval Data can apply one of the “Default” attribute color
and pattern schemes to all intervals in the selected wells that meet a set of search
criteria. For more information see the Find/Change Data section.

Find/Change Data…
The Find and Change Data function searches intervals by data criteria and either
changes the intervals’ color and pattern fills, or changes field data entries.
To perform a search on interval data, select the “Maintenance” button on the bottom
of the Interval Tab on the Main Module. Next, under the Data tab (highlighted in blue)
select the “Find/Change Data…”
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Setting Basic Interval Search Criteria
Select the interval data table to search under the TABLE dropdown. Next, select the
interval field that will be searched under the FIND DATA IN dropdown menu. On the
WHERE dropdown, select the style of the search. Petra can search inside data fields
in a few different ways; select the condition (such as Data is Equal to value) and the
appropriate value, range, or text string to find. The example below shows a search
for intervals containing the phrase “very fine grain.”

Limiting the Interval Search to a Zone
This search can be further limited by zones on the Options Tab. Since a zone can be
defined by a set of formation tops or depths, this can be a powerful way of limiting the
search to intervals that have footage inside a specific stratigraphic interval. In the
example below, only intervals intersecting the DSAND zone will be used.
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Using a Filter in the Interval Search
With a Find and Replace operation, filters provide a finer control over which intervals
are changed. Intervals that do not meet the filter criteria are not changed. To create
or modify a set of filters, select the “Set Filters…” button on the Options tab.
Filter criteria are shared between different functions, making it easier to use the
same subset of interval data for different applications. Deselecting this box in any
part of Petra does not erase the filter criteria; it simply inactivates the filters. For
more information on filters see the “Using Filters” section of this document.

Setting the Color and Patterns for the Interval Search
Using the Find and Replace Data method to change color and patterns applies a
“default” attribute scheme to intervals meeting search criteria. This method’s key
advantage is that it can be applied to multiple wells in a project. As a reminder, a
“default” attribute is created in the Edit Interval Data window. For more information
on creating a default attribute scheme, see the above section on “Setting Multiple
Intervals’ Attributes, Markers, and Patterns in a Single Well.”
Once the search criteria are set, select “Set Interval Attributes.” This tells Petra to
change the color and pattern attributes of the intervals that meet the search. On the
CHANGE INTERVAL ATTRIBUTES TO dropdown menu, select the appropriate
default attribute scheme. The example below shows that the lithologic description
field “Desc” in the LITH table will be searched. Recall that in earlier examples, very
fine grained sandstones were given a pale yellow color fill with a sandstone lithologic
pattern. In the search shown below, intervals containing the phrase “very fine grain” in
© 2014

"How To" Workflows

1607

the lithologic description will be given this same color and fill pattern.

Setting the Data Change for the Interval Search
Using the Find and Change Data function changes field data entries in intervals
meeting search criteria. This method changes a selected field value for every interval
meeting search criteria. This method’s key advantage is that it can be applied to
multiple wells a project.
Once the search criteria is set, select “Change Data Values.” This tells Petra to
change a specific field on the intervals that meet the search. On the CHANGE DATA
IN dropdown menu, select the appropriate field and data value. The example below
shows that the lithologic description field “Desc” in the LITH table will be searched. In
the search shown below, intervals containing the phrase “very fine grain” will have
their Qual field changed to “B.”
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Using Filters
Filters limit the intervals used in a particular process. Filters give more control over
which intervals are displayed on map and cross sections, which intervals are used in
calculations to create zone and log curves, and which intervals are used in Find/
Replace operations.
In all these cases, filters add an additional set of search criteria. Intervals that do not
meet the filter criteria are not used for that particular task. For example, intervals that
don’t pass the filter criteria in the Map Module are not plotted on the map. Filter
criteria are shared between different functions, making it easier to use the same
subset of interval data for different applications. Unchecking this box in any part of
Petra does not erase the filter criteria; it simply inactivates the filters. To create a
new set of filters, select the “Set Filters…” button. The examples below show the
“Set Filters…” for displaying intervals in the Map Module and for calculations in the
Main Module.
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The Interval Data Selection filters can be divided into two parts. The upper half of the
screen builds and modifies filters, while the lower half shows the active filters and the
“pass” relationship between different filters.
To create a new filter, select the table and field for the filter from appropriate
dropdown menus. The example below filters intervals in the LITH table by data in the
DESC data field.
Next, select the filter’s “Search Type.” With one exception (“Interval Thickness In
Range”) the search type tells Petra what the filter should look for inside a field:

Not Equal to Value
Equal to NULL
Not Equal to NULL
Value in Range
Field Contains String

“Interval Thickness in Range” eliminates intervals that are thicker or thinner than a
given range. Finally, select the “Add” button to add the filter to the “Current Filters”
list at the bottom of the box. In the example below, the filter is set to include only
intervals that contain the words, “very fine grain”
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Up to 10 filters can be active at once. There are two options for how to combine
multiple filters: “Pass Filter when ANY conditions are met” and “Pass Filter when ALL
conditions are met.” The choice of these two options can have a significant influence
on which intervals are plotted on the cross-section. For more on combining multiple
filters, see Appendix 2.
Pass Filter when ANY conditions are met – this will pass any interval where at least
one of the conditions is met. This is the more permissive option, since only one of the
filter criteria needs to be met to pass.
Pass Filter when ALL conditions are met – this will pass any interval only when all
conditions are met. This is the more restrictive option, since all filter criteria need to
be met to pass.

Plotting Interval Data in the Cross Section Module
The Cross Section Module can display any combination of interval data colors,
patterns, markers and text. To display interval data for a well in the Cross Section
Module, select Wells>Plot Interval Data. This box shows a list of the interval data
tables on the left along with a series of tabs on the right that control how interval data
(Style, Text, Filters) are shown.
First, select the interval data table or tables to display. Petra can show multiple
intervals at the same time, though it’s generally better to keep different interval tables
in different tracks. In the example below, only the LITH table is selected.

The Style Tab
The Style Tab governs how the interval data is displayed on the Cross Section.
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Use Interval Fill Color – This option tells Petra to fill the interval with the interval’s
color.
Use Interval Fill Pattern - This option tells Petra to fill the interval with the interval’s
pattern.
Use Interval Marker Symbols - This option tells Petra to fill the interval with the
interval’s marker symbols. The Marker Scale factor below changes the size of these
symbols. The individual interval’s marker fill can also be overridden with the Marker
Fill Mode below.
Text Positioning – Text can be positioned at the top, middle, or bottom of an interval.
Select the dropdown by default labeled “Text At Top of Depth Interval” to change
where text is plotted.
Combining Text Horizontally or Vertically – This changes how multiple text fields are
displayed. “Combine Text Horizontally” lists additional text fields to the right of the
first text box. “Combine Text Vertically” stacks additional text fields on the bottom of
the first text field.
Separate Text with Space – This option changes how different fields are separated
when plotted horizontally. Horizontally combined text boxes can either be separated
with a space, slash, a dash, or a comma.
Text Label Size – This option sets the size of text (in inches). Keeping this option at 0
is a good default. Remember that an absolute text size probably won’t be appropriate
for both computer screens and large paper plots; 1 inch letters will look huge on a
computer screen, but will be normally sized on a large wall plot.
Marker Scale Factor – This option sets the scale of the interval markers. Setting the
scale factor to 0.5, for example, plots all markers at ½ their original size.
Marker Fill Mode – Though every interval stores information on how to display
markers, this option overrides the fill mode for all displayed markers on the cross
section. Note that this does not change the settings stored in the interval.
Pattern Scale Factor – This option sets the pattern scale, or density, of the lithologic
© 2014

1612

PETRA Help

pattern fill. Higher numbers here generate higher pattern density.

The Text Tab
The Text Tab sets the specific data fields to be displayed as text.

To add text, select the appropriate Table on the Interval Data to Plot dropdown menu
and a data field from the “Data Fields to be Posted By Intervals dropdown menu on
button to adds the field to the list. Items at the top of the list
the right. Select the
will be at the top (for vertically combined text) or on the left (for horizontally combined
text). Selecting the “Include Text Labels” option adds the field name as a prefix
before each data field. Particularly elaborate displays can also be saved as a
template in a *.IDF file with the Save/Load Template buttons.
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The Filters Tab
Filters provide more control over which intervals are displayed on the Cross Section
Module. Intervals that do not meet the filter criteria are not displayed. To create or
modify a set of filters, select the “Set Filters…” button on the Filters tab. For more
information on filters see the “Using Filters” section of this document.

Interval Data in the Map Module
The Map Module can show and grid interval data on deviated and horizontal wells.
Petra can show a rectangular area with the interval’s pattern and color along the
wellbore, each interval’s marker symbol, or both. Intervals are a good way of
showing the encountered lithology, or for quickly showing the wellbore’s footage spent
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in, above, or below a target stratigraphic unit.

Gridding with Interval data
Deviated and horizontal wells can generate data spread along the wellbore’s path.
Interval data is a good way of displaying and incorporating multiple data points along
a wellpath into a grid. Petra can grid any numerical interval field designated as a “real
value.” Date and text interval fields can’t be used in gridding.
In the Map Module select Contours>Create Grid… from the menu bar at the top of
the screen. Here, select the relevant data, grid size, and surface style; Petra can
integrate interval data into a grid using zone data, tops, overlay contour lines, or other
XYZ data. On the Interval Data Tab, select the “Active” option to use the selected
interval table and numerical interval field in gridding.

Note that there are a couple of ways to modify which intervals are used in gridding:
intervals can be pared down by quality codes, zones, or interval filters. The “Skip
Well if Quality Code Contains” option allows the user to skip wells that have specified
quality codes. Here, enter one or more values separated by a semicolon to indicate
intervals that are NOT to be used for gridding.
Intervals must Fall within Depths of Zone - This option limits which intervals are used
in gridding to only the intervals inside the specified zone definitions. The “WELL” zone
covers all depths, and consequently all intervals. Be careful when using zones and
horizontal wells. Note that this zone criteria works uses the zone interval definitions,
which are often defined by tops. Horizontal wells that stay entirely within a zone and
never reach the base will not have a base top picked, and will consequently be
excluded from gridding.
Apply Interval data Filters - This option provides more direct control over which over
which intervals are used in gridding. Intervals that do not meet the filter criteria are
not gridded. To create or modify a set of filters, select the “Set Filters…” button on
the Filters tab.. For more information on filters see the “Using Filters” section of this
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document.
Use Interval Top/Middle/Base Depth - This option sets where numerical “real value”
interval fields are contoured. Especially with longer intervals in horizontal wells, this
difference can significantly change where a data point is plotted. Note that this option
is grayed out when gridding interval tops and bases.
In the example below, a single interval in the wellbore is outlined in with a box on the
cross section on the left. While the top and base of the interval have a specific XY
location on the map, other data (such as an average porosity value) can grid that
value at the XY position at top of the interval, at the middle of the interval, and at the
base of the interval.

Apply Subsea TVD Correction to Interval Field Value - This option instead corrects to
SSTVD by subtracting the KB elevation. By default, Petra uses the survey’s TVD
when contouring the top and base of intervals. This option is essential when
incorporating interval data into SS structure maps.
XYZ File Containing Int Data Used in Gridding - This option creates a text file
containing the X and Y coordinates (using the project’s map projection) along with the
interval value used in gridding. Specifically, Petra creates a *.XYZ file in the project’s
GRIDS folder. This file will be named after output grid file name with a “_INTDATA.
XYZ” suffix.

Plotting Interval Colors
Interval colors are plotted in a filled rectangle along the wellpath. This is useful for
aerially representing continuous information in a wellbore, such as changes in
lithology, biostratigraphic assemblages, or even gas shows.
In the Map Module, select Options>Interval Data on Well Path… Select the
appropriate interval table to display from the dropdown, and select the “Plot Filled
Rectangle” option under the Interval Indicator dropdown. With this option, Petra fills
the rectangle with each interval’s color.
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Filters provide more control over which intervals are displayed on the Map Module.
Intervals that do not meet the filter criteria are not displayed. To create or modify a
set of filters, select the “Set Filters…” button on the Filters tab.. For more information
on filters see the “Using Filters” section of this document.

Plotting Interval Data Markers
Interval markers are along the wellpath at the top, middle, or base of the interval.
Unlike the filled rectangle, interval markers can be plotted at a user-defined
orientation. Interval markers are useful for representing discrete markers, such as
fractures or MWD tool changes.

In the Map Module, select Options>Interval Data on Well Path… Select the
appropriate interval table to display from the dropdown, and select the “Plot Marker
Symbol” option under the Interval Indicator dropdown. Next, select the position of
each interval’s marker relative to the wellbore (middle, left, or right of the wellbore)
and the position of the marker along the interval (top, base, midpoint). Note that filters
can also be applied to the interval data; only intervals meeting the filter criteria are
shown. In the example below, the “Fractures” interval table stores a horizontal line
marker for every interval.
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To set the direction of each marker, select the Orientation Tab. Markers can be
perpendicular to the borehole, parallel to the borehole, or have a user-defined
orientation, or azimuth. This user-defined azimuth can either be a constant azimuth
for all interval markers in all wells, set for all intervals markers for each well by a zone
data item, or for each individual interval in each well by an interval data field. When
storing individual fractures in a wellbore, storing azimuth data in each interval captures
the most information and allows for each marker to have its own orientation. In the
example below, the AZI data field gives the compass azimuth for each fracture.

To set the size of each marker, select the Size Tab. The size of each marker can
either be a constant for all interval markers in all wells, set for each well by a zone, or
for each individual interval in each well by an interval data field. Note that the marker
size can either be set to use map XY units, feet, or meters. Selecting a constant size
of 0 sets a default marker size, as shown in the example below. The Marker Scale
Factor can scale the size of a zone- or interval field-defined marker by anything
between 0 and 100.
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Storing Interval Data to a Zone
It’s sometimes useful to extract data from intervals to a zone. Zones are easily used
in calculations and mapping. In the Main Module, select Compute>From Interval
Data>Extract Interval Data To Zone
Under the Extract Interval Data from dropdown menus, select the appropriate interval
table and field. In the example below, the “RW from SP” interval data is selected
from the “Petrophysics” table.
Petra can either extract the interval field data or the interval thicknesses. In the
example below Petra will calculate an average of the “RW from SP” interval data.
Since a single zone can contain multiple or overlapping intervals, there are a few
different ways to extract this field or interval thickness data:

First/Last value
Min/Max of values
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Average of values (weighted or unweighted by thickness on the Options Tab)
Sum of values
Count of values
Sum of interval thicknesses
Average of Thicknesses
Count of intervals

Next, select the zone and data item where the interval data will be stored. Note that
this tool uses the selected zone’s definitions (where fm tops or depths define the top
and base of the zone) to limit the extraction only to intervals intersecting the zone. A
default zone definition of -99999’ to 99999’ will include every interval in the wellbore.
Next, select when the field value should be stored to the zone data item. Petra can
store the interval data meets the following criteria:
When the item is present – This option stores the interval field value to the zone data
item when the interval data contains a value. This is useful for most applications, such
as storing a petrophysical value to a zone.
Item is absent – This option stores the value when the interval data field is null.
Practically, this option is only useful when extracting the sum/average of interval
thicknesses or interval counts. As an example, extracting a count of intervals when
the porosity interval data is absent generates a well-by-well count of intervals missing
porosity values.
Range – This option stores the interval field value when the field value falls between a
minimum and maximum value.
Contains text – This option stores the interval field data when the interval field contains
specified text.
Matches text - This option stores the interval field data when the interval field exactly
matches the specified text.

The Options Tab contains further options for limiting the intervals used in the
extraction.
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Restrict Intervals By Selected Zone - By default, Petra only uses intervals that
intersect the selected zone’s definitions (where fm tops or depths define the top and
base of the zone). Note that undefined zones extend from -99999’ to 99999’ MD,
which includes every interval in the wellbore. Deselecting this option will not limit
intervals by zone definitions. Alternatively, intervals can also be limited by interval
quality codes or FmName fields.
Method To Compute Average Values - When computing an average value for the
interval, Petra normally uses weighted averages, where thicker intervals contribute
more to the average than thin intervals. Selecting “Compute UnWeighted Average”
gives equal weight to all values regardless of interval thickness.
Set Computed values of zero to null - Remember that a null is not equal to zero.
Mistaking the two can generate spurious maps and calculations. The option sets
extracted values of zero to a null value.
Use Filters To Restrict Intervals - Filters provide more control over which intervals are
used in the zone extraction. Intervals that do not meet the filter criteria do not
contribute to a zone data item. To create or modify a set of filters, select the “Set
Filters…” button on the Filters tab. For more information on filters see the “Using
Filters” section of this document.

Storing Interval Data to a Log Curve
It’s sometimes useful to extract numerical data from intervals to a log curve. Logs
curves are easily displayed on cross sections and can be used in petrophysical
calculations to create new composite curves. In the Main Module, select
Compute>From Interval Data>Extract Interval Data To Curve
Under the Extract Interval Data from dropdown menus, select the appropriate interval
table and field. In the example below, the “RW from SP” interval data is selected
from the “Petrophysics” table.
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Petra extracts an interval field data value and applies it to that interval’s
corresponding footage on a log curve. As an example, an interval from 1500 to 2000’
with a RW of 0.06 will translate into a log curve with a repeating RW of 0.06 from
1500 to 2000’, as shown in the example below.

Intervals often have gaps and overlaps between intervals. Gaps between intervals
are simply stored as null values on the curve. Where log intervals overlap, the bottom
interval overprints the upper interval. To resolve these gaps and overlaps in the data,
see Resolving Gaps and Overlaps in this document.

Under the Extract Interval Data from dropdown menus, select the appropriate interval
table and field. Next, select the name of the log curve. In the example below, the
“RW from SP” from the “Petrophysics” table will be stored as a new “RW” curve.
These curves can be stored at any sample rate, though 1 foot- and ½ foot-spacing
are the most common.
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The Options Tab contains further options for limiting the intervals used in the
extraction. Filters provide more control over which intervals are used in the zone
extraction. Intervals that do not meet the filter criteria do not contribute to the log
curve. To create or modify a set of filters, select the “Set Filters…” button on the
Options Tab. For more information on filters see the “Using Filters” section of this
document.

Storing Log Curve Statistics to an Interval
It’s sometimes useful to extract numerical data from log curves to an interval. More
specifically, this tool calculates statistics over a selected log curve between the top
and base of each interval and stores the result as a interval data field. This statistical
measurement is stored to a data field in a selected interval table. When stored as
interval data, log curve statistics can be easily used in petrophysical calculations or
compared with other interval data fields. In the Main Module, select Compute>From
Logs>Extract Log Stats to Int Data…
First, select the desired log curve from the dropdown menu at the top of the screen.
In the example below, the GR curve is selected. Note that this tool will calculate log
statistics on aliased curves, as well.
Next, select the desired interval table from the “Interval Data Table” on the lower left
side of the screen. In the example below, the LITH” table is selected, so the statistics
measured will be stored in interval data fields in the LITH table
Finally, select the desired statistics and the desired location. In the example below, a
mean (or average) will be calculated for the GR log. The calculated average will be
stored in a interval data field called “GammaStat.” Petra stores statistics out to 7
decimal places, even though the interval data field may only show fewer trailing
decimals.
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Storing Interval Thickness to an Interval Field
This operation stores each interval’s thickness to a specified field in that interval.
Select the “Maintenance” button on the bottom of the Interval Tab on the Main
Module. On the Table tab, select the interval field that will store the interval thickness.
In the example below on the left, the “Recov” field on the CORE table is selected.
Next, under the Data tab (highlighted in blue on the example to the right) select “Store
Interval Thickness” (highlighted in red).

The example below shows that the sidewall core thicknesses (in this case given a
thicker interval) all store thicknesses of 2 feet in the “Recov” field.
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Gaps, Overlapping Interval Data, and Bulk Shifts
Interval data is often at the wrong depths, or contains overlapping intervals or gaps.
Though interval data is designed precisely to handle this incomplete and contradictory
data, it’s often useful to convert interval data into one continuous chain for display or
calculations. Interval data can also become out of sync with other well data; moving
interval data up or down with a bulk shift easily remedies the discrepancy.
To perform these operations on a single well, select the “Edit Details” button on the
upper right corner of the Interval Tab on the Main Module. Next, Edit dropdown on
the menu bar at the top of the window, select “Make Intervals Continuous” button or
“Resolve Internal Overlaps”, or “Bulk Shift.”

Make Intervals Continuous
This option eliminates overlaps where two different intervals cover the same footage.
With this option, Petra moves the base of the upper interval to match the top of the
lower interval, as shown in the example below.
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Resolve Internal Overlaps
This option eliminates gaps between intervals. With this option, Petra moves the base
of the upper interval to match the top of the lower interval to cover the gap, as shown
in the example below.

Bulk Shift
This option adds or subtracts a specific number to all interval depths. A negative
number moves all intervals up, while a positive number moves all intervals down.
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Calculations with Interval Data
Petra can perform basic calculations on interval data columns, zone data items, or
constants. This operation is performed on all intervals in selected interval table in
either the current well or for all wells selected in the Main Module. To calculate a new
interval data column from another, select the appropriate interval table on the
appropriate well, then select the “Calculate Column…” on the Interval Tab
First, establish where the output will be stored. Petra can store data to a new or
preexisting column in the selected data table. To store data to a new column, select
“Create New Column” and enter in the new column’s name. To use a column that’s
already in the data table, select “Use Existing Column”, and select the column from
the underlying dropdown menu. Be careful when using an existing column, as this
operation can overwrite any data already entered.
Next, enter an equation using variables and mathematical operators. For a list of
available operators and sample equations, see appendix 3. The variable on the left
side of the equal sign is the result variable. Note that the variables here are just text
and will be assigned later, so they can be either specific (“porosity”) or general (“A”).
Note that equations can be saved and loaded again at a later date with the “Save”
and “Load” buttons on the right side of the screen. In the example below, porosity
data is being used to calculate a permeability value.
Now that the equation is entered, select “Assign Vars.” This populates the Variable
List in the bottom left corner of the window with the variables written in the equation.
Select a variable from the Variable List, and select a column, zone data item, or
constant from the relevant dropdown menus on the right. Select the “Assign” button.
This will change the entry in the Variable List box to reflect the correct variable.
The Options Tab has a few more controls over the calculation. The calculation can
be performed on only the currently selected well in the Main Module, or on all wells
selected in the main module. Petra stores a null value whenever there’s a missing
variable in the calculation, but the “Save ZERO value to Database” can overwrite this
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null value with a zero. By default, Petra overwrites all interval data fields during the
calculation. Deselecting the “Overwrite Existing Database Values with Calculation
Result” forces Petra to leave existing database numbers alone, limiting the calculation
to only filling in null values. To perform the calculation, select the OK button.

Graphing Interval Data
Petra can plot any numerical interval “real value” versus depth or another real value.
This can be particularly useful for quickly seeing how a quantity such as mud weight
changes with depth, or understanding the relationship between two different kinds of
data like porosity and permeability.
To view an interval graph, first select the correct well in the Main Module. On the
Interval Tab, select the right interval table. In the example below, the “CORE” table is
selected. Finally, select the “Edit details” button in the upper right on the Interval Tab.
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On the Graph Tab, select “Depth vs Z” or “X vs Z” on the first dropdown menu.
“Depth vs Z” shows the selected values for the interval fields selected on the Z1, Z2,
and Z3 dropdown menus on the vertical axis relative to depth on the horizontal axis.
The example below shows how porosity varies with depth.

“X vs Y” shows a scatter plot for the two interval fields selected on the X and Y
dropdown menus. The X value is plotted on the horizontal axis, and the Y value is
plotted on the vertical axis. The example below shows how permeability varies with
porosity

APPENDIX 1: Setting Default Tables and Fields
Changing these default interval tables can be useful from an administrative
perspective. Changing these tables ensures that all new projects will be created with
the same interval tables and fields, though these can always be changed inside Petra.
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When creating a new project, Petra looks at a file called INTDATA.DEF located in the
program’s Parms directory. On most standalone installations, this will be located in C:
\geoplus1\Parms. This file contains the default tables and fields that will be created in
a new project.
It’s important to not edit the default interval table file (INTDATA.DEF). Instead, copy
the INTDATA.DEF file to a new file called INTDATA.USR. Make all new changes to
the new file called INTDATA.USR. Petra first looks for INTDATA.USR before it looks
for INTDATA.DEF.
The default version of this file contains three tables: LITH, CORE, and PALEO.

Table: LITH - Lithology
Field: Desc - Description

Table: CORE - Core Interval Data
Field: Poros - Core Porosity
Field: Perm - Core Permeability
Field: Recov - Amt of Core Recovered

Table: PALEO - Paleo Data
Field: FmName - Formation Name
Field: Bug - Fossil Name
Field: Age - Age of Zone
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Petra reads the INTDATA file and builds interval data based on comma-delimitated
values.

TABLE, TABLE NAME, “Table Description”
FIELD, KIND, NAME, SRC, “Field Description”, UNITS, DECIMALS

TABLE – This signifies that the entry is for a new table.
Table Name – This is the name of the table. It’s a good idea to separate tables
based on genetically related data, such as mudlogs, core descriptions. Remember
that tables, unlike zones, are completely independent of stratigraphy, so it is probably
easier to lump all related data together rather than break out intervals based on
specific formations.
“Table Description” - This sets a brief description of the Table. In the example, the
“LITH” field’s description is “Lithology Data.” Remember to put quotation marks
around the description.
FIELD – This just signifies that the entry is for a new field. Make sure all new field
entries are prefaced by “FIELD.”
Kind – Fields can store three kinds of data: Real Values, Date Values, or String
Values. The letter here tells Petra what kind of data this field will store – “R” for Real
values, “D” for Date values, and “S” for String values. Real values simply store
numbers, such as porosity or permeability. Dates store calendar days as MM/DD/
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YYYY. String values store text, like core descriptions.
Name – This is the name of the field.
SRC – This sets the user source for the specific field. User sources are useful for
distinguishing between different user’s interval data in a multiuser environment.
“Field Description” – This sets a brief description of the field. In the example, the
“Recov” field’s description is “amt of core recovered.” Remember to put quotation
marks around the description.
UNITS – This sets the units of the field.
DECIMALS – This sets the number of decimals shown for real value (numerical) data.
Though it’s a good idea to set this value to 0 for string and date fields, it’s not
necessary

APPENDIX 2: ANY and ALL with multiple Interval Data
Filters
There are two options when combining multiple filter combinations. Data can either
pass ALL conditions, or ANY of the conditions. The difference between the two is
significant, and is best illustrated by an example with two data filters:

“Object is yellow”
“Object is smaller than a breadbox”

We’ll apply those filters to three objects: a Banana, an Apple, and a Schoolbus.
When ALL conditions need to be met, only the banana passes the filter because it is
both yellow and smaller than a breadbox.
When the filter just requires ANY condition to be met, each object only needs to pass
one of the filters. In this example, all three objects pass the filter. The apple is
smaller than a breadbox, the schoolbus is yellow, and the banana is both smaller than
a breadbox and yellow.

APPENDIX 3: Equations and Mathematical Operators
Petra recognizes a wide variety of mathematical operators:
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+ Addition
- Subtraction
* Multiplication
/ Division
** Exponent
ABS(x)

- Absolute value of x

ACOS(x)

- Arccosine of x (in radians)

ASIN(x)

- Arcsine of x (in radians)

ATAN(x)

- Arctangent of x ( in radians)

COS(x)

- Cosine of x in radians

COSH(x)

- Hyperbolic cosine of x (radians)

EXP(x)

- e to power of x

INT(x)

- Truncated value of x

LOG(x),LN(x)

- Natural Log of x

LOG10(x)

- Log based 10 of x

MAX(x,y)

- Maximum of x and y

MIN(x,y)

- Minimum of x and y

ROUND(x)

- Rounded value of x

SIN(x)

- Sine of x in radians

SQRT(x)

- Square root of x

SQR(x)

- x squared

SINH(x)

- Hyperbolic sine of x (radians)

TAN(x)

- Tangent of x in radians

TANH(x)

- Hyperbolic tangent of x (radians)

Operators are performed in the following precedence:
1 Exponent
2 Multiplication and division
3 Addition and subtraction
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Use of parentheses can change the order of precedence.

Example Equations:
GRN=GR - MEAN_GR + MEAN
LOGNRM = LONORM+(LOG-PICKLO)*(HINORM-LONORM)/(PICKHI-PICKLO)
LOGNRM = LOG+ LOGPICK - GOODPICK
SW = ( RW/(RT * (PHI**M)))**(1/N)
R = ((A+B*(C-1.0))/100
R = X*SIN(A)+Y*COS(B)
R = LOG10(X)
R = X*X or R = SQR(X)
R = X**Y (x raised to the y power)

18.8

How to use Petra Standard 2014 Repair Tools
Petra Standard 2014 has split the PetraDBIRepair tool from one application into two
seperate applications:
DBIRepair - a command line application used to verify, repair, reindex or optimize a
single table in a Petra project.
PetraRepair - PetraRepair.exe allows you to select multiple tables in a project to
run DBIRepair on simultaneously.
PetraPack -

18.8.1 DBIRepair
DBIRepair.exe is a command-line tool for scripting Petra database verification, repair,
reindexing, and optimization.
DBIRepair.exe is able to accept a full path filename to a single Petra table (with
automatic VERIFY and REPAIR, if necessary) with parameter switches for
FORCEREPAIR, REINDEX and/or OPTIMIZE (for scripting). DBIRepair.exe requires
exclusive access to the table (all users must be out of the project). There is a
separate report .txt file created with the same name as the table in the same folder
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as the table for each table processed containing any exceptions during the process.
The format for the command line is:
DBIRepair.exe fully_qualified_path_and_table_file_name \FORCEREPAIR\REINDEX \OPTIMIZE
Fully_qualified_path_and_table_file_ name
Specifies the full path to the Petra
database table (see note 1)
\FORCEREPAIR
Forces a full repair of the table
(optional, see note 2)
\REINDEX
Reindexes the table
(optional – see note 3)
\OPTIMIZE
Optimizes the table
(optional – see note 4)

Notes:

1. DBIRepair.exe with just the fully qualified path and table file name on the
command line will automatically perform a Verify. It will automatically perform a
Repair, if it is found necessary by the Verify. This is the safest and fastest
option, since a Verify only reads the data and doesn’t have to write any data to
a new table.
2. \FORCEREPAIR is optional and will bypass the Verify and force a Repair even if
it is not necessary. This is a longer process as it has to create a new table to
write the data into.
3. \REINDEX is optional and will delete the existing index(es) on a table and create
them again from scratch.
4. \OPTIMIZE is optional. It will create a new table and write the existing data in
the order of the primary key index, effectively shrinking the file size by eliminating
any deleted data. It will speed up data access somewhat as the data will now
be stored on disk in the actual index order.
5. All users must be out of the project before any repair processes are started.
6. Backup (copy and zip) your Petra project folder before any repairs are
undertaken.

© 2014

"How To" Workflows

1635

18.8.2 PetraRepair
PetraRepair is a graphical interface for the DBIRepair command-line application. that
makes it easy to verify, reindex, repair, and optimize an entire Petra project.
Note:Do not be alarmed by the number of individual DBIRepair.exe screens that pop
up on the monitor and then one by one disappear! PetraRepair launches separate
DBIRepair processes to work in parallel on each table in the Petra project.
Notes:

1. All users must be out of the project before any repair processes are started.
2. Backup (copy and zip) your Petra project folder before any repairs are
undertaken.
To start PetraRepair, simply double-click on the file (PetraRepair.exe) in your Petra
installation directory:
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Click the “Open” button to choose the .ini file for the project you would like to repair (in
the PARMS folder):

By default all the tables are checked. If you would like to only repair some of the
tables, select them now:
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The default for PetraRepair (no check boxes selected at the bottom) is to verify the
tables and “automatically” repair only tables with a problem.
Click “Start” to launch DBI Repair for each table with the appropriate switches:
Do not be alarmed by the number of individual DBIRepair.exe screens that pop
up on the monitor and then one by one disappear!
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18.8.3 PetraPack
PetraPack.exe can be run at any time without having to kick anyone out of the project.
It will accept a command line full path to a Petra project .ini file (for scripting) or an
open dialog will appear for .ini selection, if the command line is left blank.
PetraPack can be launched once for different Petra projects and the operating system
will assign each process to separate cores and memory space. This allows packing
of more than one Petra project at a time, making use of the available cores and
memory. A report .txt file with the same name as the .ini file will be created in the
folder with the .ini file containing information about the pack (before and after record
counts or any exceptions during the process).
Notes:

1. Backup (copy and zip) your Petra project folder before any repairs are
undertaken.
2. It is recommended but not required that you Verify, Repair and Reindex your
tables before packing them with PetraPack. exe, since PetraPack.exe relies on
a table and index that is not corrupt to correctly determine what records are
orphaned and need to be deleted. Otherwise, you might delete records that
appear orphaned because of an error in the table or index when the records are
really not orphaned, but rather their parent just cannot be properly located.
3. Launching PetraPack simply opens a dialog for you to choose the project:

PetraPack then runs the Pack function on all that project’s tables as below
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How to Use the Z Cross Plot Module
Opening the Z Cross Plot Module
On the Main Module, select Tools>Z Data Cross Plot from the menu bar at the top of
the screen. This brings up the “Data Definition” screen superimposed over the main
Crossplot Module, both of which are blank by default.

The Data Definition window (left) and a blank Z Cross Plot Module

Setting the Axes
The first step is to set the axes for the two variables on the scatter plot. Petra brings
up the “Data Definition” screen by default after opening the module for the first time.
Otherwise, select Data from the menu bar at the top of the screen.
X-Y Axis Tab
This tab controls the basic settings for the plot, like the plot title and axes. Here, set
the set the specific zone and data item, as well as the scale for X and Y axes. The
“Log Scale” button sets the selected axis to a logarithmic scale. The “Stats” button
displays a histogram of the z data for the selected wells, which can aid in setting a
reasonable minimum and maximum scale for the plot. The “Defaults” button sets the
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minimum and maximum scale based on the minimum and maximum data value in the
data. If the minimum and maximum values are more than 500 apart (and is not a top
or contains negative numbers), Petra will automatically scale the axis to a logarithmic
scale. Note that dates can also be used in these fields in the format MM/DD/YY, like
01/01/1910.

The example below plots a calculated Net to Gross plot, where the NET is on the X
axis, and GROSS is on the Y axis. In this example, GROSS is a simple interval
thickness between two tops and NET is a thickness based on a gamma ray cutoff.
Both scales are set to 30-100’. The “Stats” button for the GROSS interval shows a
histogram of these values.

When graphed, the cross plot shows the relationship between net and gross in the 2
nd Wall Creek Formation.
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Z Axis Tab
The Z-Axis tab color codes data points by an additional Z data value, giving an
additional dimension to the XY scatter plot. Note that data points that do not have a Z
value will not be plotted. Select the desired zone and data item and set the scale
using the minimum, maximum, and scale. Select the “Colors…” button to set the color
bar.

Carrying on the example, the plot now adds a statistical average of the density
porosity from 10% to 20%.

Options Tab
This option governs a couple of additional settings for the plot, including setting the
labels for the axes and the symbol size. The “Do Not Use LOG Scale to Compute
Defaults” button forces Petra to always use linear scales when setting defaults on the
X-Y Axis Tab and the Z-Axis Tab.
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File Tab
The file tab saves and loads settings for the “Data Definition” window as a *.ZXS file
in the project’s PARMS directory. This only saves the settings for the axes, title, and
labeling; it does not save polygons.

Selecting Wells
By default, The Z Crossplot Module simply uses the wells selected in the Main
Module. All data points for all these wells show up on the scatter plot. To increase or
decrease the number of wells selected on the Z Cross-plot, select Wells on the menu
bar at the top of the screen.
All Wells
This option selects all wells in the project.
Select by Data
This option opens the “Select Wells By Data” option. This tool can refine the wells
used in the cross plot based on several different criteria. Additionally, multiple nested
searches can combine to make for more precise well lists.
Wells from Main/Map/Cross-Section
These options select the wells currently active in the relevant module. As an example,
selecting “Wells from Map” selects only the wells currently selected in the Map
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Module.
Highlight from Polygon
This option changes the color of the data points inside a given polygon to use the
same color as the polygon.

Drawing a Regression Line
Petra can also perform variety of regression operations on the cross plot data. To
add regression lines to the plot, select Options>Regression from the menu bar at the
top of the screen.
Auto Fit Line
This option adds a linear regression line to the log crossplot. The equation for the
line, correlation, and standard deviation are all shown at the bottom of the screen.
Auto Fit Quadratic
This option adds a quadratic curve to the log crossplot. Like the linear regression, the
equation for the line, correlation, and standard deviation are all shown at the bottom of
the screen.
User Fit Line
The User Fit line creates a linear user-drawn line across the log crossplot. The
equation for the line, correlation, and standard deviation are all shown at the bottom of
the screen.
Show Standard Error Bars
This option adds error bars at one standard deviation. The better the line fits the
data, the smaller these bars will be. As a reminder, these bars will include about 68%
of the data points assuming a normal distribution.

The example below shows an auto-fit line with standard deviation error bars.
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Creating and Modifying Polygons
Z Crossplot polygons outline different areas of the graph, separating wells that have
specific z data relationships. Each polygon in the Z Crossplot Module can have its
own name, color, and value. Note that polygon values don’t have any effect in the Z
Crossplot Module, but exist so that polygons can be shared with the Log Crossplot
Module. Polygons allow the user to select wells based a more nuanced criteria rather
than by simple data searches, since polygons can vary the cutoff based on the
relationship between zone data.

The example below shows the Net to Gross crossplot with a single “OUTLIER”
polygon. This polygon covers the data points the net to gross ratio is outside a single
standard deviation. Put another way, the amount of net sand in these wells is
significantly lower than what the rest of the data would suggest. This could be due to
gamma normalization problems or petrophysical effects.
Making a Polygon
To establish a polygon, right click anywhere on the log plot and select “Add Polygon.”
Alternatively, select Polygons>Add from the menu bar at the top of the screen.
Drawing a polygon works exactly the same as drawing lines elsewhere in Petra. Pick
polygon node points with the left mouse button and select the right mouse button to
stop picking points. Petra will automatically close open polygons.

During picking, press ESC picking to cancel the current polygon or DELETE to drop
the last picked point. Selecting F1 while picking will snap the cursor to the nearest
node point on another polygon, which can be useful for generating polygons with no
empty space between them and no overlap.
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Once the polygon is picked, Petra brings up the “Polygon Definition” box. Here,
simply enter the name of the polygon, pick a color, and add a polygon value. The
polygon name is a good way of distinguishing the polygons apart when exporting
wells, so spending time on descriptive names is a good idea.

Modifying and Deleting a Polygon
To change the area of a facies polygon, right click anywhere on the log plot, select
“Select Polygon”, and then left click on the desired polygon. Make sure to click right
on the line. Alternatively, select Polygons>Select from the menu bar at the top of the
screen, and then left click on the desired polygon. This highlights the polygon and
shows its node points; select a node point and drag it to the desired position to
change the outline of the polygon. When finished, right click and select “Redraw” to
refresh the screen and show the changes.
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Changing a polygon’s name, color, and value is similar. Select the polygon with the
mouse, as outlined above. Once the polygon is highlighted, right click and select
“Modify Polygon.” Alternatively, select Polygons>Modify from the menu bar at the top
of the screen with the polygon is highlighted. This opens the Polygon Definition box,
which sets name, value, and color for the polygon.

To delete a drawn polygon, select the polygon with the mouse as outlined above.
Once the polygon is highlighted, right click and select “Modify Polygon.” Alternatively,
select Polygons>Modify from the menu bar at the top of the screen with the polygon
is highlighted. This opens the Polygon Definition box. Select the “Delete Polygon”
button on the bottom of the box.
Loading and Saving Polygons
Closing the Log Crossplot Module erases the polygons from Petra’s memory, so
make sure to save the polygons to a file if you want to use them later. Select
Polygons>Save from the menu bar at the top of the screen. Create a name and
select the save button.

On the Save Polygons to Disk box, the area outside the polygons name and value can
be modified. By default this area is named “DEFAULT” and its value is zero. This
screen also allows for a comment to better describe the polygons.

On the Save Polygons to Disk box, the area outside the polygons name and value can
be modified. By default this area is named “DEFAULT” and its value is zero. This
screen also allows for a comment to better describe the polygons.
Exporting Wells inside a Polygon
To save a well list select Polygon>Export wells. Here, select the “Browse” button to
navigate to a location on the network and name a WSN list. Next, add a comment for
the WSN list if desired. Finally, select the polygon containing the wells to be included
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in the WSN list. Note that the “Output Wells Outside All Polygons” only selects the
wells not inside any polygon. The example below shows how the wells inside the
“OUTLIER” polygon will be written to a WSN list called “outlier.wsn.”

18.10 How To Calculate Volumetrics With Grids
The Map Module’s “Compute Volume from a Grid” tool calculates volumetrics from a
single grid. With a good quality isopach, pore volume, or hydrocarbon pore volume
grid, this method can generate accurate estimations of the area occupied by
hydrocarbons, and can divide these volumetrics into different lease polygons.

When to use a Grid-Based Approach
Petra can calculate reservoir volumetrics in two different ways: a deterministic
approach and a grid-based approach. The Advanced Volumetrics Module (available
in the Main Module under Tools>Volumetrics on the menu bar at the top of the screen)
calculates reservoir volumetrics based on a single set of averaged reservoir and fluid
properties inside a perfectly homogenous cube with a defined volume. This method is
best suited for exploratory fields with little hard data.
Well-drilled fields with large amounts of petrophysical data are better served by a
grid-based volumetrics calculation. This method calculates volumetrics using the
mapped thickness, water saturation, and porosity at each grid node, which better
accounts for heterogeneous reservoirs.

How Grid-Based Volumetrics Works
When Petra calculates a grid from a data set (such as pay thickness or porosity
measured at each well), it creates a surface that interpolates the values across the
empty spaces between data points. In the simplest case, an isopach grid of net pay
thickness reflects the thickness of pay (the Z value) at every point on a map (X and Y
for Lat and Long). The example below is an isopach grid projected into threedimensional space. The volume underneath the surface of the isopach grid (down to
zero feet thick) equals the volume of the reservoir. Given a good grid that accurately
maps the subsurface, this method can generate much more precise measurements of
the volume of a reservoir than conventional estimation.
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This same grid-based volumetrics can also increase accuracy in heterogeneous
reservoirs. Both porosity and water saturations often vary significantly across an
entire reservoir. Deterministic calculations force a single average porosity and water
saturation, which can easily ignore these effects. In contrast, multiplying individually
mapped grids of reservoir thickness, porosity, and hydrocarbon saturation together
can generate a more accurate picture of the total volume occupied by hydrocarbons.
The diagram below shows how different kinds of grids can be used to calculate
volumetrics in an oil and gas context. The red arrow on each line shows when the
volumetrics calculation is performed, and which assumptions are made during the
calculation. The first example shows a simple isopach grid; calculating a total volume
of oil or gas requires an assumed average porosity and gas saturation. The second
example shows an isopach and porosity grid. Multiplying these together generates a
pore volume grid, which gives the distribution of pore space footage. Calculating
volumetrics here requires an average gas saturation. The final example multiplies an
isopach, porosity, and gas saturation grid together to form a hydrocarbon pore
volume (HPV) grid. Since this HPV grid already calculates the distribution of
hydrocarbons in the system, it needs no further assumed reservoir variables.
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Initial Polygon Setup
Volumetrics can be calculated for the grid as a whole, or only for the grid underneath
active overlay polygons on the Map Module. While this is most used for assessing
volumetrics in individual leases, volumetric polygons can also be used to outline a
specific area of interest or to eliminate the effect of large but unproductive areas. To
use polygons, select the overlay line in the map module and double-click to bring up
the line’s attributes. On the General Tab, make sure that the line is a closed polygon.
Note that the “Arrows” tab changes to “Volm.”

Next, select the Volm Tab to edit the polygon’s name and working interest. The
calculations made inside this polygon will be referenced by this name. While this is
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most used for assessing volumetrics in individual leases, volumetric polygons can also
be used to outline a specific area of interest or to eliminate the effect of large but
unproductive areas. In the example below, the selected polygon’s volumetrics name
is “AOI” and its WI is 100%. You can also designate a specific well’s WSN to store
the specific polygon’s calculated volume. Remember that a well’s WSN number is the
number Petra assigns to the well when it is created in the project; it is not the API or
UWI number. This volume is stored in the well’s zone data, and is set up during the
volumetrics process. In the example below, volumetric data for this “AOI” polygon will
be stored in the well with a WSN of 178.

Petra will calculate volumetrics for all visible polygons with a volumetric name, so be
sure to turn off all irrelevant named polygons before proceeding.

Calculating Volumetrics - Data Tab
Once the overlay volumetric polygons are set-up, select
Contours>Volumetrics>Compute Volume From a Grid… on the menu bar at the top of
the Map Module to open the volumetrics tool. Here, select the grid and grid type to be
used in the calculation from the dropdown labeled “Grid File Used For Volumes.” In
the example below the “HPV” grid is selected. To change the grid directory, select a
different file path on the Dir Tab. Note that grids on this dropdown menu can be
sorted alphabetically by selecting the
button. The
button selects the most
recently created grid in the directory.
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Grid Units
When calculating volumetrics, it’s important to make sure the units are correct. Petra
stores the default XY and depth units of measurement (feet or meters) in the Map
Projections Settings. When Petra calculates a grid, it uses these XY coordinate units.
The units used to create the selected grid are shown under Grid XY Units.
By default, Petra assumes that the Z units for the grid are the “Default Depths Units”
selected on the Map Projection Settings. Make sure the units selected here reflect
the units of the grid.

Grid Type - “Iso”
The “Grid Type” dropdown tells Petra what the numerical values in the grid actually
mean. A grid used in volumetrics can be one of three types: “Iso” type data with
values from zero to positive numbers, structure data with structural highs as larger
numbers, or structural data with structural highs as smaller numbers. In the example
below, the SCMR ISOPACH grid is selected as an isopach.
With “Iso” grids (including isopach grids, pore volume grids, and hydrocarbon pore
volume grids), Petra uses the thickness to calculate the volume underneath the grid
nodes. This is the most common and easiest way to calculate volumetrics with a grid.
Note that Petra will ignore the effect of negative numbers in “Iso” type grids.

Grid Type - Structure
Though Petra can use a structure grid in a volumetric calculation, it is almost always
better to use an isopach grid. In practice, using a structure grid really only works with
small, simple structures with a thick, homogenous reservoir and a discrete water
contact.
The numerical representation of a structural high or low is dependent on the reference
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datum (Measured Depth/MD or SubSea/SS). SS grids store structural highs as larger
numbers (e.g. +2,000 SS is higher than +1,000 SS and -1,000’ SS is higher than 2,000’ SS). MD grids store structural highs as smaller numbers (e.g. 1,000’ MD is
higher than 2,000’ MD). Practically, grids referenced to SS use the “Structural Highs
as Larger Numbers” option, while grids referenced to MD use “Structural Highs as
Smaller Numbers" option.

A single structure map only represents the elevations of a surface and doesn’t
inherently have any measurement of thickness. When using a structure map, Petra
calculates thickness by using the volume of the grid between the minimum and
maximum Z values set on the Data Tab. In the example below, Petra will calculate a
thickness between -1200’ SS and -2200’ SS. It’s important to note that setting a limit
below the bottom of the grid will add a large extra bulk to the volumetric calculation.
The example below will have an additional 200’ of section added to the volumetric
calculation.

Calculating volumetrics with a structure map can also lead to problems if the thickness
of the reservoir rock is thinner than the difference between the grid and the bounding
lower z value. With a sufficiently thick reservoir, the bounds are completely covered
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by reservoir rock. With thinner reservoirs, the volumetric calculation can include a
volume that doesn’t actually include reservoir rock, thus overestimating the volume.

Compute Volume for Following Area(s)
This section tells Petra whether the volume underneath a grid will be broken out by
different volumetric polygons. The “Generate Volumes for Each Visible Overlay
Volumetric Polygon” option will calculate the volume of the grid covered by every
visible overlay polygon. Recall that a line defining these polygons need to be closed
on the line’s General Tab and named on the line’s Volm Tab. If these polygons
overlap, Petra will count the volume of the shared area twice. Setting this option to
“Generate Volume For Entire Grid Only” will instead ignore visible polygons and
calculate the volume over the entire grid.

Compute Volumes Between
The Minimum and Maximum Z values set limits on the overall volumetric calculation.
Though these settings are critical when using a structure grid, the limits can also be
useful when calculating volumetrics on thickness or “iso” maps. In particular, setting
the limits can help to reduce the effect of a large, thin uneconomic area on the
calculation.

Horizontal Slice Volumes
It’s also possible to calculate volumetrics for horizontal slices from the minimum z
value to the maximum z value through the reservoir. In the example below, horizontal
slices will be calculated for 0-10’ of thickness, 10-20’, 20-30’, and so on through the
entire section. With large grids and small increments, this additional step can be fairly
time-consuming.
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Options Tab
The Options tab provides a few more options for the volumetrics calculation.

Ignore Volume if Thickness is Less Than - This option sets the minimum thickness
necessary for Petra to consider in the volumetric calculation; anything below this
thickness isn’t included. By default, this thickness cutoff is set at zero, which means
that all the entire positive volume of the grid is used. Setting this thickness higher can
help to reduce the influence of a large thin or uneconomic area. Note that the cutoff
thickness is relative to the selected grid units – a 10’ cutoff applied to an isopach grid
is very different than a 10’ cutoff applied to a HPV grid.
Grid Refinement - The Grid Refinement option breaks larger grid cells into smaller
triangular areas. This slightly increases the accuracy of the volumetrics calculation at
the cost of more computing time.
Also Output Volumes to CSV File - The ”Also Output Volumes to CSV File” option
writes a CSV file containing the name, area (both a total area of the polygon and the
total area of the grid underneath the polygon), relevant calculated volume, an average
grid thickness (if selected), the working interest, and the WSN of the polygon’s
“designated well.” Petra creates a CSV file using the volumetric grid name in the
project’s GRIDS directory. Using the example above, Petra creates a file named
HPV.CSV. Leaving this CSV file open while trying to calculate a new volume (and
thus export data to the same CSV file) can create an IO error.

Print Average Value for each Polygon in Report - This option simply calculates the
average grid thickness for each visible named polygon. What this thickness actually
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represents depends on the type of the grid used. The average Z value for a structure
grid will be an average elevation rather than an average thickness.
Apply Working Interests Associated with Overlay Polygons - This option scales each
volume inside a volumetrics polygon by the working interest.
Write Volumes to SHAPE FILE - This option saves currently visible volumetric
polygons and data to a shape file. Select the option and navigate to the desired shape
file. This copies all currently visible volumetric polygons to a single shape file.

Reserves Tab
The Reserves Tab selects the type of reserves calculation and specifies the type of
input grid. The reserves types include basic volumes, recoverable oil in place,
recoverable gas in place, coal bed methane, and coal tonnage. The map type tells
Petra whether the input grid is an isopach, a pore volume map, or a hydrocarbon pore
volume map. The Map Type only affects oil and gas reserve calculations. The
options on the Reserves tab changes depending on the selected reservoir and map
type. Similarly, the area and volume dropdowns at the bottom of the window show
the relevant units for the specific reserves calculation.

Basic Volumes (No Scaling)
The simplest form of a volumetric calculation is the first option, “Basic Volumes (No
Scaling).” This option simply calculates the volume occupied by the grid without any
additional reservoir calculations. Note that the “Map Type” option has no effect on
this calculation.
The “Basic Volume” calculation can display results in a variety of areas and formats.
For area, the available units include raw units (as defined on the Units Tab), square
feet, square meters, and acreage. For volume, the available units include raw units
(as defined on the Units Tab), cubic feet, acre-feet, acre-meters, MBO, MMCF, and
cubic meters.
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Oil in Place with Recovery
Petra’s oil reserves calculations multiplies the total area of pore space occupied by
hydrocarbons by a recovery factor. This volume is then divided by Bo to correct for
differences in volume between hydrocarbons in the reservoir and the same
hydrocarbon at surface conditions.
Recoverable Oil In Place: ROIP = Volume*Por*(1-Sw)*Rf / Bo
The three options for “Map Type” (isopach, pore volume, and hydrocarbon pore
volume) simply tell Petra what the selected grid represents. Practically, the map type
grays out irrelevant options.
An isopach grid just contains thickness and will need an average water saturation and
porosity. A pore volume grid already contains the thickness and porosity information
and just needs average water saturation. A hydrocarbon pore volume grids already
contains all this information, and therefore needs no averaged porosity and saturation
information.
The “Oil In Place with Recovery” calculation can display results in a variety of areas
and formats. For area, the available units include raw units (as defined on the Units
Tab), square feet, square meters, and acreage. For volume, the available units
include raw units (as defined on the Units Tab), cubic feet, acre-feet, acre-meters, or
MBO.
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Gas in Place with Recovery
Petra’s oil reserves calculations multiplies the total area of pore space occupied by
hydrocarbons by a recovery factor. This volume is then divided by Bg to correct for
differences in volume between hydrocarbons in the reservoir and the same
hydrocarbon at surface conditions.
Gas In Place: GIP = Volume*Por*(1-Sw)*Rf / Bg
Where Bg = Patm/P*(460+T/460+60)*Z; Patm = 1
The three options here for “Map Type” (isopach, pore volume, and hydrocarbon pore
volume) simply tell Petra what the selected grid represents. Practically, the map type
grays irrelevant options out.
An isopach grid just contains thickness and will need an average water saturation and
porosity. A pore volume grid already contains the thickness and porosity information
and just needs average water saturation. A hydrocarbon pore volume grids already
contains all this information, and therefore needs no averaged porosity and saturation
information.
The recoverable gas in place calculation also requires a compressibility factor,
reservoir pressure, and reservoir temperature. The calculation only uses the
numbers on the imperial units side; SI units must be converted to imperial
units. Using imperial units is fairly simple – simply enter the reservoir pressure and
temperature in PSI and °F into the boxes on the left (highlighted in yellow) To use SI
units, enter in the pressure and temperature in kPAA and °C into the boxes on the
right (not highlighted) and select the arrow buttons
for bth pressure and
temperature to convert to imperial units. After the SI pressure and temperature are
converted, then compute the volumetrics normally.
The “Gas In Place with Recovery” calculation can display results in a variety of areas
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and formats. For area, the available units include raw units (as defined on the Units
Tab), square feet, square meters, and acreage. For volume, the calculation is limited
to MMCF.

Coal Bed Methane (CBM) in Place with Recovery
The “CBM Gas in Place with Recovery” option calculates reserves for a coal bed
methane field. Note that the “Map Type” option has no effect on these calculations,
and the grid is always assumed to be an isopach grid.
CBM Gas In Place: CBMGIP = Volume*Cf*Gc*Sg*Rf
where Cf converts bulk density in g/cc to tons/acre-ft
The “Coal Gas In Place with Recovery” calculation displays results in a variety of
areas and formats. For area, the available units include raw units (as defined on the
Units Tab), square feet, square meters, and acreage. For volume, the calculation is
limited to MMCF.
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Coal Tonnage
Coal tonnage simply calculates the volumetrics of an isopach grid and multiplies this
value by an average coal density.
Coal (Tons) = Volume*CoalDensity*62.42796061/2000 when density is in gm/cc
Coal (Tons) = Volume*CoalDensity/1000 when density is in kg/m3
The “Coal Tonnage” calculation displays results in a variety of areas and formats. For
area, the available units include raw units (as defined on the Units Tab), square feet,
square meters, and acreage. For volume, the calculation is limited to Tons (2,000
lbs).

Wells Tab
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Petra can copy the volumetric data for each named polygon to a specific well’s
designated zone and data item. Recall that each polygon’s designated well is
established by double-clicking the polygon in the map module to open its Overlay Line
Attributes screen (see Initial Polygon Setup above). The “Store Polygon Volume in
Each Polygon’s Designated Well” option stores the calculated volume to the
designated well.

The “Zone To Store Polygon Volume” dropdown simply sets the zone where the
relevant volumetric data will be stored. By default, volumetric data is saved in the
WELL zone. In the example below, data will be stored in the “VOLUMETRICS” zone.
The “Item to Store Polygon Volume” selects the specific data item where the relevant
volume is stored. In the example below, data will be stored in the “GIP” zone
The “Item to Store AVG Z” selects the specific pre-existing data item where the
average grid thickness for each visible named polygon is stored. What this thickness
actually represents depends on the type of the grid used Note that the “Print Average
Value for each Polygon in Report” option on the Options Tab needs to be selected for
this option to work. In the example below, data will be stored in the “GIP” data item
in the VOLUMETRICS zone.
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Dir Tab
This tab simply sets the directory of available grids. By default, this option is set to
the project’s GRIDS folder.

18.11 How to use the Histogram Module

The Histogram Module displays a histogram of log curve values. Put another way, the
histogram visually shows the distribution of log curve values without respect to depth.
These values can be limited to a specific depth or zone, or filtered by up to three
separate “discriminator” log curves.
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Opening the Histogram Module
On the Main Module, select Tools>Log Histogram from the menu bar at the top of the
screen. Alternatively, select the
button on the toolbar at the top of the top of the
Main Module. This opens the Histogram module. The first time this module is
opened, the “Histogram Data Definition” screen superimposed over the main
Histogram Module, which are both blank by default.

Loading/Saving settings
To load or save histogram settings, select File>Load Settings… or File>Save
Settings… on the menu bar at the top of the screen. Saving these settings creates a
*.HS file that retains the selected curves, scales, and histogram settings.
The Histogram Module looks at the log data stored inside the project’s database, so
the data is always live. Changing the curve data will change the appearance of the
histogram, even after loading old settings.

Selecting Wells
It’s often useful to only work with a small subset of wells in a project. The Histogram
Module can select wells in a few different ways available from Wells>Select on the
menu bar at the top of the screen.
“All Wells” selects all wells available in the project. “By Data Criteria” selects wells
based on a set of nested criteria including well header information, logs, or zone data.
“With Selected Curve” selects only the wells that have the currently selected log
curve on the Log Curve Tab. “Cross Section Wells” selects the wells currently
selected in the Cross Section Module. “Well From Main” selects the single well
currently selected in the Main Module. “All Wells From Main” selects all wells currently
selected in the Main Module.
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To switch between wells, select either the desired well on the dropdown at the top of
the Histogram Module or use the left and right arrows to scroll through the selected
wells. PageUp and PageDwn also cycle through the set of wells.

Plot Single/Combine All Wells
Petra can either plot the log data points from a single well or from multiple wells in
aggregate. To switch between these two modes, select Wells>Plot Single Well and
Wells>Combine All Wells. Note that showing multiple wells will remove the curves
displayed on the right side of the screen – after all, with log curve data from multiple
wells, which well’s curve would you show?

Setting the Log Curve and Scale
On the menu bar at the top of the screen, select Logs>Axes and Scales… from the
button on the top
menu bar at the top of the screen. Alternatively, select the
toolbar. This opens the Log Curve Tab on the Histogram Data Definition window.

The Log Curve tab controls the basic settings for the histogram plot. Here, add a title
for the plot. Next, set the specific curve and scale. The “Log Scale” button sets the
selected axis to a logarithmic scale. By default, Petra displays the curve scale
increasing from left to right; the “Reverse Curve Display.”
The “Default Scale Range” button sets the minimum and maximum scale for the log
based on the curve’s established minimum and maximum scale. The “Statistical Scale
Range” button sets the minimum and maximum scale based on the minimum and
maximum data value in the data.
The example below plots a histogram of gamma ray curve values, where the GR
displayed from 0 to 150 API units. Note that the “Use Log Aliases” button is selected,
so Petra will use the GR curve’s alias list.
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Setting Depths
It’s often useful to limit the histogram’s data points to a specific interval of interest.
Data points can be constrained by zone definition, tops, or by a specified depth (MD
or TVD). On the menu bar at the top of the screen, select Depths>Set Depths… from
the menu bar at the top of the screen. Alternatively, select the
button on the
toolbar at the top of the Histogram Module. This opens the Depths Tab on the
Histogram Data Definition screen.

To set depths by a zone’s interval definitions, select the desired zone on the “Select
Zone(s)” list. Next, select the desired zone. Note that the WELL zone by default
covers -1M MD to +1M MD, so it should cover the entire footage of all wells. If the
tops used in the zone interval definition are missing for a well, Petra will not display
the histogram for that well.
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To set depths by tops or by a specific depth range, select the “Set Depth From
Range” button. Next, select the “Set Range” button. In the Set Depth Range box,
select the relevant top, MD, or TV Depth button. For MD and TVD, select the
relevant button and enter the adjacent depth in the entry field. For tops, select the
desired top from the “Fm Top Name” dropdown box. Notice that an offset can also
be added or subtracted to the fm top; this offset will include data points above or
below the actual fm top depth.
The histogram below is limited only to the area defined by two tops – it’s 20’ above
the 2ND_WALL_CREEK and 20’ below the 2ND_WALL_CREEK_BASE. The
histogram is limited to a sand bracketed by shale, so the histogram shows a bimodal
distribution of the two distinct lithologies’ gamma values.

Modifying the Histogram
Histogram Cells
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The “Number of Histogram Cells” varies the number of “cells” (otherwise known as
“bins”) on Petra’s histogram. In the example on the left, the histogram uses 25 cells
(from 0-150 API units, so each contains a spread of 6 API units). The example on the
left, on the other hand, uses 75 cells where each cell is only 2 API units wide. It’s
worth noting that there’s no “best” number of cells for a histogram; different numbers
of cells can reveal different things about the data.

Other Options
The “Maximum Samples Per Cell” and “Compute Maximum Samples from Data”
options on the Histogram Tab set the scaling for the vertical frequency axis. The
“Compute Maximum Samples from Data” option automatically sets the vertical
frequency scale to the largest frequency value. To change this scaling, deselect the
“Compute Maximum Samples from Data.” The “Maximum Samples Per Cell” manually
sets the upper limit of the frequency plot.
The “Show Mean and Std Dev on Histogram” option calculates the arithmetic mean (or
average) plus and minus one standard deviation of the log values. These three lines
are displayed as vertical dashed lines on the plot. The actual values for the mean,
standard deviation (labeled as “SD”), and mode are listed on the bottom of the graph.
The example on the left has no statistics, while the example below on the right has the
mean and standard deviation added.
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The “Color Fill Histogram Cells” option simply fills in the histogram cells; removing this
option just leaves outlines for each cell.

Histogram Types
The “Histogram Types” box sets the histogram’s general plot type: Standard,
Cumulative, or “Greater Than” Freq Plot. The Standard plot displays the total number
of values (or “frequency”) for each cell. The Cumulative plot shows the total number
of values for each bin plus all preceding bins. Similar to a Cumulative plot, the
“Greater Than” Freq Plot shows the percentage of values greater than any one bin.
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Filtering the Histogram by other Log Curves
Discriminator curves filter data points by log criteria. To use a discriminator curve,
select the desired curve on the dropdowns, and set the scale using the Minimum and
Maximum. Data points with values that fall outside of this data criteria are not
included on the cross plot. In the example below, only gamma values with an
associated resistivity log of 10 to 100 will be included on the histogram.
The “Include Discriminators Logs When Plotting Log Curves” shows the discriminator
curve or curves against the log curve on the right.

With a discriminator curve, the histogram shows a much tighter spread of gamma
values since these resistivity cutoff excludes the shales above and below the sand.
Note how the “RILD” discriminator curve is displayed to the right of the log curve.
Discriminator curve values outside the minimum and maximum scale values will show
up as a straight line on the edge of the log window.
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Adding Tops to the Offset
The log curves on the right side of the screen can also show tops, which can help
orient the user. First, open the Histogram data Data Definition screen by selecting
Logs>Axes and Scales… from the menu bar at the top of the screen or the
on the toolbar. Select the Tops Tab.

button

To add a top, highlight the desired top name in the "Available Tops" list and click the
add button (">"). This moves the log over to the “Selected Tops” list. To remove a
top, highlight the top name in the “Selected Tops” list and click the remove button
("<"). The “>>” and ”<<” buttons add all tops and remove all tops, respectively. To
change the color of a top, select the top on the “Selected Tops” list and select the
desired color using the color box on the right.
The example below adds the “2ND_WALL_CREEK” and
“2ND_WALL_CREEK_BASE” tops to the display.
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Picks
“Picks“ are database-stored curve values. Picks are most commonly used for log
curve normalization, such as scaling all gamma ray values in a project to set “sand”
and “shale” values. Commonly, picks are first created for the entire project from
statistical measurements, and the histogram module is used to visually inspect and
QC the pick relative to the actual curve.
When working with picks, it’s usually a good idea make sure the “CrossHair Cursor”
option is on. When this option is selected, (Display>CrossHair Cursor on the menu
bar at the top of the screen), Petra draws a vertical line on the correlation log that
corresponds to the cursor’s location on the histogram. This can make it significantly
easier to see the relationship between the histogram value and the log.

Displaying Existing Picks
On the menu bar at the top of the screen, select Picks>Define Picks from the menu
bar at the top of the screen. Alternatively, select the
button from the Picks
toolbar at the top of the screen. This opens the Define Histogram Picks window.
Here, select an existing zone data item with the zone (top) and data item (bottom) in
the “Available Zone Items” box.
The example below shows two picks: “PC10GR” and “PC90GR.” Both of these picks
these are log statistics created in the Main Module (Compute> From
Logs>Statistics…), where “PC10GR” is the curve’s 10th percentile, and “PC90GR” is
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the curve’s 90th percentile.

The picks for each well will then be displayed on the histogram. The examples below
show two different wells. Since wells are logged with different tools at different
times, the picks are slightly different. The well on the left has a smaller difference
between the 10th percentile sand and the 90th percentile shales than the well on the
left.

Creating New Picks
To create a new data item in the selected zone, select the

button in the

“Define Histogram Picks” window. Select the
button to add the data item to the
“Selected Picks” list in the lower left corner of the window. Note that new zone data
items won’t have any data, so no picks will immediately appear.

Modifying Picks
To modify a displayed pick, in the main Histogram Module window select the desired
pick from the dropdown on the Picks toolbar, and select the “Start” button.
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Select the new location of the pick on the histogram. As mentioned above, the
“CrossHair Cursor” draws a vertical line on the log to show the histogram’s value
relative to the curve. Left click to set the selected pick. Next, right click to open a set
of options. These options include: Next Well, Prev Well, Redraw, End Picking, Delete
Picking. Selecting “Next Well” and “Prev Well” saves the pick change and scrolls
through the wells selected in the Histogram module. “Redraw” saves the pick
change, refreshes the screen to reflect the changes, and leaves the pick tool active.
“End Picking” saves the pick change and deactivates the picking tool, but does not
refresh the screen. “Delete Pick” erases the pick value entirely, leaving a null value in
the database for that well.

18.12 How to Digitize a Raster Log
Raster logs are scanned copies of paper logs saved as image files. Digital logs, on
the other hand, store log values in a form that is directly readable by a computer.
Digital logs have several advantages over raster logs: they’re more easily stored in
Petra’s database, look great in a cross section, and can be calibrated and used in
calculations. Converting a raster log into a digital log is called “digitizing.”
Going from a simple image file to a digital log involves two major steps: depth
calibrating the raster image, and tracing the desired log curve. This guide walks
through depth calibrating and digitizing the GR curve on the D-122 well in the
TUTORIAL project.

Depth-Calibrating the Raster Image
Raster logs are scanned copies of paper logs saved as image files. Petra needs to
know what part of the image corresponds to which depth in order to assign values
during digitizing. Most commercial data vendors depth register their data, but images
directly from scanners and state providers are not depth calibrated.
The first step to calibrating a raster is to select the correct well in the Main Module.
For this example, select the D-122 well in the Main Module.
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The Raster Calibration Screen
To start calibrating a raster log, open the raster calibration screen. In the Main
Module, click on the “Assign/Calibrate” button on the Rasters Tab. This opens the
“Calibrate Log Image” screen. Notice that the selected well’s UWI and name appear
on the screen.
NEEDS New Image
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Next, open an image file by going to File>Open Image on the menu bar. Navigate to
the specific image file and select it. By default, the D-122’s raster log will be located
here C:\geoplus1\Projects\TUTORIAL\IMAGES\D-122.TIF. It might be useful to use
the zoom buttons (
) on the upper right corner of the window to make the
image larger or smaller.
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Group Names
All raster images are assigned “group names.” A group name usually describes the
log type (like “Resistivity”) and/or scaling (1”, 2”, or “5”) of a log image. Select the
appropriate image group from the "Image Group Name" drop-down list. To add a
new group, click the “+” button next to the group names dropdown box (highlighted in
red in the example below) or to Group>Add or Delete Groups... on the menu bar.
Since the raster image is a resistivity log, add a “Resistivity” group.

When selecting or creating group names, it’s generally better to aim for fewer, more
general group names rather than create many precise group names. The more group
names in a project, the tougher it will be to display cross-sections later.

The Depth Calibration Toolbar
Though most of the tools to calibrate logs are available from the menu bar at the top
© 2014

1676

PETRA Help

of the screen, the quickest and easiest way calibrate a raster log is to use the Depth
Calibration Toolbar (highlighted in blue in the example above). To turn on this toolbar,
go to View>Depth Calibration Toolbar on the menu bar.

Define the Calibration Depths
As mentioned above, Petra needs computer-recognizable depths to be assigned to
depths printed on the log. This process involves picking 2 or more depth calibration
points from the image. Only the log between the top and bottom depth calibration
point can be digitized or shown on a cross-section.
To create a new calibration depth, click the “Add” button on the Calibration Tool Bar
Alternatively, go to Edit>Add Depth Point on the menu bar. Next, position the
horizontal cursor at the depth you wish to pick and click the left mouse button. You will
be prompted for the depth value. After entering the depth value, the screen will
redraw showing the new calibration depth point. Repeat the process for each new
depth calibration point.

To change the location of the depth, click and drag the depth calibration point using
the left mouse button. To edit the value of an existing depth, click on the depth
calibration point with the right mouse button and enter a new value.
The better the quality of the raster log, the fewer points necessary to depth calibrate
the image. Most raster logs only really need a handful of points. Petra also
automatically scales and places reference black lines every 100’. Unlike normal red
calibration lines, these cannot be moved – they just show Petra’s scaling between
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your calibration lines. If these black lines look close to the actual image, your
calibration points are sufficient. If the thin black calibration lines are off of the depths
printed on the raster log, add new points or adjust your existing depth calibration
points.

Deleting Calibration Depths
To delete an individual depth calibration point, click the “Drop” button on the
Calibration Tool Bar. Alternatively, go to Edit>Delete Depth on the menu bar. After
selecting this tool, click the left mouse button on the depth marker to be deleted. The
screen will redraw once the marker is deleted.
You can also delete all depth calibration points by going to Edit>Delete All Depths...
on the menu bar.

Interpolating Depths
Petra can interpolate and create calibration depth points between the uppermost and
lowermost calibrated depths. Since Petra already scales between registered depths,
adding a lot of new points generally does not aid in the overall calibration of the raster
log.
After creating two or more depth calibration points, click the “Interp…” button on the
Depth Calibration Toolbar or go to Edit>Interpolate Depths on the menu bar. Select
the interpolation increment, and Petra will compute depths at your specified interval
between the top and bottom depth calibration point.

Saving Calibrations
Though it’s not strictly necessary for digitizing, this is a good point to save the
calibration. A calibration file stores information like depth calibration points and
edges, raster image file name, and group name. Saving a calibration file also updates
the Petra database to link the image and group name with the currently selected well.
. Alternatively, go
Click the “Save Calibration As…” button at the top of the screen:
to File>Save Calibration As… on the menu bar. This brings up the “Save File As”
box. It’s generally best to use the default name and to store the calibration file in the
same folder as the image.

After saving the file, the group name will now show up on the Rasters Tab in the Main
Module, and you will be able to plot the raster in a cross section.
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Digitizing the Curve
Turn On the Curve Digitizing Toolbar
Once the raster image is open, select View>Curve DigitizingToolbar on the menu bar
at the top of the screen to toggle the toolbar on and off. It will appear on the right
side of the screen.

Select the Digital Log Curve and Scale
The next step is to tell Petra the curve name and the scale for the log to digitize.
Select the red “Set Curve” button at the top of the digitizing tool bar.

This button opens up the “Log Digitization Details” window. In the “Log Curve to
Digitize” dropdown box, select an existing curve or enter a new curve name. This
curve name will be the name of your digital log, so be careful about replacing an
existing digital log for the selected well. Next, specify the curve values for the left and
right sides of the track boundary. For curves on a logarithmic scale, such as
resistivity, make sure to select the “Use Log10 Scale” button.
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For this example, we’ll digitize the gamma ray curve. Notice that the footer of the D122 log states that the GR curve is has a micrograms radium-equivalent/ton scale
from a 0.8 to 8.8. In order to distinguish it from a more traditional gamma curve, it is
named “GR_RAEQ.” The track boundaries are set below – just like on the footer, the
scales go from 0.8 to 8.8. The actual raster log wraps when the count exceeds that
8.8, but that’s easy to deal with later.

Notice that the same scale box on the digitizing toolbar now shows the name of the
curve to be digitized and the scale.

Set the Left and Right Track Edge
The next step is to set the left and right edges of the track containing the curve to be
digitized. Petra uses these lines to calculate a numerical value for the digital log.
Notice that the footer of the log states that the curve’s scale is from 0.8 to 8.8. The
left and right digitizing track edges will tell Petra where 0.8 and 8.8 are, with digitized
points in the middle scaled accordingly. As an example, a digitized point halfway
between the left and right track edges will be stored as 4.8.
To set digitizing tracks, select the “Left” and “Right” buttons in the Tracks box on the
digitizing toolbar and then click on the respective track boundary. Remember that
digitizing tracks (in the blue box on the left side of the screen) are different than track
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edges.

In the example below, the left and right digitizing track edges (in red) are around the
first track containing the gamma ray curve.

Raster logs are often curved due to paper stretching or slipping during scanning.
Crooked logs mean inaccurate digital logs. To handle crooked rasters, you can either
straighten the whole image, or adjust the left and right track boundaries.
Straightening the whole image has two advantages. You only have to adjust one
track straight edge instead of two separate track boundaries, and you can save your
work as a new copy of the straightened raster image. If you’re digitizing multiple
tracks on the same raster log or a fairly long section, straightening the whole image
will ultimately save time. For information on how to straighten a raster log, see here.
The other way of dealing with crooked raster logs is to adjust the left and right
digitizing track lines. Both the left and right track edges have control nodes at every
calibration depth. You can move these control points with the left mouse button to
align track edges with the image. The advantage to this method is that it saves a step
and eliminates the need to store multiple copies of the raster image. Simply adjusting
track boundaries is easier for short digitizing runs on straight raster images.
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Draw the Digitizing Line
The next step is to actually trace the log curve with a digitizing line. As mentioned
above, Petra reads these lines and compares them to the track boundaries in order to
calculate a digital log value for each depth.
There are two major ways to draw these lines: Manual and Automatic.

Draw the Digitizing Line - Manual
To manually digitize log curves, first click the “Start” button on the Digitize section of
the digitizing toolbar.

The Log Digitization Details box will reappear to confirm the settings on the log and
scale. Here, you can also select the digitizing style. The default drawing style is that
every left click creates one control point on a digitizing line. You can also select
“Stylus Mode”, which continually records points at the specified increment when you
hold down the left mouse button. In the example below, the stylus mode will create a
point every half foot. Select OK to keep the log settings and the pick mode and return
to the raster image.
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The next step is to draw the digitizing line. In stylus mode, click and hold the left
mouse button to continually record points. If using point and click mode, simply click
on top of the curve to create points and draw a line. If in point and click mode, you
can temporarily activate the stylus mode by holding down the ALT key.
Notice that on the bottom of the screen Petra shows the depth and the value of the
curve at the mouse position. These are the values going into the digital log, so it’s a
good idea to check this in the beginning to make sure the curve and depth values are
reasonable.

To stop tracing the digitizing line, click the “Stop” button on the Digitize section of the
toolbar or right click the mouse. Digitizing lines are divided into independent
segments. Each time you select “Start” during manual digitizing, Petra brings up the
Log Digitization screen and you create a new curve segment with its own scale.
Selecting “Continue”, on the other hand, just adds more points to the existing curve
segment at the same scale. You can have as many or as few curve segments as you
want. For more on curve segments, see “Editing Curve Segments” below.
IF YOU MAKE A MISTAKE, you can either immediately stop and fix the mistake or
wait until the end. To fix a mistake you can either individually select and move control
points (see “Editing Curve Segments” below), or simply select “Continue” and draw
over the mistake.

Draw the Digitizing Line - Automatic
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Petra can also automatically follow and trace simple, bold, well-defined curves.

First, select the "Start" button under the "Auto" section, then click on the uppermost
point on the curve to be digitized. The auto tracer will attempt to follow the densest
portion of the log beginning at the selected point. You can press the ESC key or click
the left mouse button to stop the auto tracer. The "Manual" button allows you to
manually re-digitize over section not properly handled by the auto tracer.
The "Set" button displays a screen for setting properties controlling the auto tracer.

Pick Aperture - When automatically digitizing a curve, Petra looks for the darkest
adjacent point within a window or aperture. The pick aperture sets the size of this
window, which is by default 10 pixels wide by 5 pixels tall.
Sample Increment – This determines how many nodes will be created for a given foot
of log. In the example below, the increment is set for 0.5, so one point will be created
at every half foot. Note that this increment just determines the how smooth the traced
line will be. The sample rate of the digital curve is independent of this number.
Maximum Feet (Mtrs) To Digitize per Pick - This option sets the maximum distance
Petra will digitize a line. Limiting line length prevents Petra from getting stuck on the
wrong line and creating a large mess.
Maximum Duplicate X or Y before Stopping - If Petra starts tracing a straight line,
odds are good that Petra is following either a horizontal or vertical grid line. This sets
the maximum number of duplicate pixels Petra will allow before stopping.

Image Filtering
There are a few tricks that can help with auto digitizing. Since the tracing algorithm
looks for adjacent dark pixels, it can easily get confused by vertical scale lines and
horizontal depth lines. Petra can filter out straight horizontal and vertical lines. This
process modifies your image file, so be sure not to save over the original image file
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and have a backup. Both of these filters can reduce the clarity of the curves as well,
especially where the curves intersect the filtered horizontal or vertical lines. To
restore the filtered lines select File>Reload Original Image.

Edit>Filter>Remove Vertical Lines

Edit>Filter>Remove Horizontal Lines
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Changing the Track Scales (Curve Wrapping)
Whenever the curve on the raster image reaches a track edge, the scale will "wrap"
and the curve will reappear on the opposite side of the track. At this point, you will
need to stop digitizing and change the scale. The left and right side track scale is
displayed near the top of the Digitize Toolbar.
Each curve scale range is displayed in a different color beginning with red for the base
scale. There are 6 colors defined above and below the base scale. To increase the
scale range and wrap the curve, click on either the
button or on the right side scale
value. To decrease the scale range and shift the scale to the left, click on either the
button or on the left side scale value.

In the example below, the GR curve has started reading above 8.8, and has
“wrapped” around the scale. At this point, right-click or select “Stop.”
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Next, click the
arrow to wrap the digitizing scale to the right from 0.8-8.8 to 8.816.8 and select “Continue” to digitize the wrapped section of the curve. Note that the
digitizing line skips a saddle in between the two hot highs; it’s perfectly reasonable to
skip a section and come back to it later. Notice in the example below that the
digitizing scale and the digitizing line are pink to show that they are on a 8.8-16.8
scale.
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Right click or select “Stop” to stop digitizing. Click the
button to wrap the scale
back to 0.8-8.8 scale and select “Continue.” Notice that the digitizing line color has
returned to red. Make sure to fill in the saddle in between the two high gamma count
spikes.
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Scale wrapping also works for the automatic tracer. When it detects that the curve
has run into the track edge, it will ask if you want it to automatically adjust the curve
scale. In the example below, the automatic digitizer has spotted the track edge.
Selecting “Yes” will stop the digitizer and automatically wrap the scale for you. The
next step is to click on the uppermost part of the wrapped curve.

Editing a Curve Segment
As mentioned above, digitizing lines are divided into segments. Every time you press
“Start” for either manual or automatic digitizing, you create a new line segment. Each
segment has its own scale and can be shifted left and right or up and down
independently of any other segment.
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Selecting a Curve Segment - To edit a curve segment, first click the “Select” button on
the red “Edit” toolbar. Alternatively, double-click on the curve segment. Selecting a
line segment shows each of the control points as small rectangles. To deselect a
segment, click the right mouse button. In the example below, there are two curve
segments. The top segment is selected, which shows all the control points for that
line.

Moving Curve Segment Points - Once a curve segment is selected, you can
individually move any control point. Simply left click and drag the control point to its
new position. Right clicking deselects the curve segment to show the newly edited
curve.
Deleting a Curve Segment - To delete the selected curve section, either click on the
"Delete" toolbar button or press the Delete key on the keyboard. Remember that his
deletes the entire curve segment. If you accidentally delete something, use the Undo
Button on the Edit toolbar.
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Changing Curve Scale Range - To change a curve segment’s scale range, first set the
correct scale range at the top of the digitizing toolbar. Next, select the segment and
click the "Scale" button. The curve section will then be set to the scale shown on the
top of the scale bar.
Breaking a Curve Segment - You can break a segment into two segments. First,
select the segment. Then, hold down the CTRL-key and click on a segment control
point. All points ABOVE the picked point will become unselected. They are now part
of a different segment.
Breaking and Deleting Part of a Segment - You can also break a segment into two
segments then delete the bottom portion. First, select the segment. Then, hold down
the CTRL and ALT-keys together and click on a segment control point. All points
BELOW the picked point will be deleted.
Using the Delete Rectangle - You can draw a rectangle to delete intermediate points
of the selected curve segment. First, select a curve segment. Next, hold down the
SHIFT-key and click and drag to form a rectangle. All points within the depth range of
the rectangle will be deleted. The segment will be de-selected and two new segments
will be formed.
Deleting ALL Curve Segments - Click on the "Clear" tool bar button in the Edit section
to delete all curve segments.
Merging of Curve Segments - Normally, when a curve segment is digitized over the
same depth interval as a previous curve segment, the new segment is automatically
merged into the earlier segment. Merging prevents having multiple segments over the
same depth interval. Segments will not be merged when the auto-trace function is
used or when the "wrap" settings are different. You can manually merge segments by
first selecting a curve segment then press the F5 function key.
Bulk Shifting a Curve Segment - Sometimes it’s useful to shift an entire curve
segment. To move an entire curve segment at one time, first select the segment.
Next, select one of the arrow buttons in the “Shift” toolbar. This moves the entire
segment in the direction of the arrow.

Saving and Loading Your Work-In-Progress
You can save the digitized curve segments to an external file. This file stores both the
digitizing line and digitizing track settings, but not depth-calibration lines. This is useful
for creating a backup on a long digitizing project or for when you need to change
gears and work on something else.

Store a Curve to the Database
The final step of digitizing a raster log is to store the traced line as a digital log. In
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this step, the curve segments are resampled to the specified sample rate and merged
together. When segments overlap in depth, earlier segments are replaced by later
ones. In other words, where lines overlap, Petra will use the last drawn line. Once
stored, the digital curve is available in Petra’s database for drawing in cross sections
or calculations.

To store a curve, select the “Store” button on the blue “Curve” toolbar. This brings up
the Log Digitization Details box. First, select the digital curve name you want the
curve stored as. In the example below, we’ll stick with “GR_RAEQ.”
Notice that the options under “Track boundaries” are greyed out – since each
segment stores its own scale, there’s no need to change this.
Next, set the depth sample rate, which just sets how many samples will be stored per
unit of depth. The default is 1 foot, as shown in the example below. If you’ll be using
this log for calculations with other logs, make sure that this number matches the
sample rate of your other digital logs. Most digital logs are stored on a half foot
sample rate.
Next, set the Database Curve Update Mode. If there’s already a curve stored with
the same curve name, this determines how the digitized log will be stored. “Replace
Curve” will completely erase the old digital log and replace it with the new digitized
curve. “Merge With Curve” will keep the old log and only replace the sections you’ve
digitized.
Finally, set the curve interpolation method. The linear method draws a straight line
between control points, while a spline attempts to fit a curve between control points.
The interpolation method on the main screen is linear, so most people digitizing
already account for that when picking points. In other words, people mostly place the
points close enough together for a linear interpolation to accurately trace the curve
line.
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The now digitized log now appears in Petra’s database, and can be used for
calculations or display. In the example below, notice how GR_RAEQ now has a value
for every depth.

© 2014

"How To" Workflows

1693

Loading a Curve from the Database
The "Load" button under the "Curve" section lets you load a digital log curve from the
database to display on top of a depth-registered raster curve. This is particularly
useful for doing quality control on someone else’s digitizing work.

First, set the left and right track scales. Next, select the red “Scale” button at the top
of the digitizing tool bar.

Next, select the pre-existing digital log curve on the “Log Curve to Digitize” dropdown
menu. This is the log you’ll load into the digitizing screen. Select OK.

Finally, select the “Load” button on the “Curve” toolbar. This will replace any digitizing
lines on the main screen with the digital data from the selected curve in the database.

Starting Another Curve
If you want to digitize more than one curve, you will need to use the "Edit>Clear"
button on the toolbar. This will remove previously digitized segments from memory so
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they don't get stored as part of the new curve.
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